ISV5.0 CM3230 V104

Última Modificação: 8 Outubro 2008 (br99-204-007-tr)

Copyright © 1997-2010
Cummins Inc.
Todos os direitos reservados


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be caused by an internal ECM problem. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111.

Last Modified: 10-Nov-2014
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 131

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 131 PID: P91 SPN: 91 FMI: 3/3 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 1 circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position, and Fault Code 132 goes inactive, and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed.

If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal circuit shorted to battery or (+) 5 volt supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Malfunctioning accelerator pedal or lever position sensor.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code t05-131.

Last Modified: 11-Dec-2014


Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 132

Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 132 PID: P91 SPN: 91 FMI: 4/4 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 1 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Newer engines use two throttle position sensors to determine the throttle position. Older throttle pedals used a single throttle position sensor and an idle validation switch. If Fault Codes 132 and 1241 are active when the accelerator pedal is in the idle position and Fault Code 132 goes inactive and Fault Code 1239 goes active when the throttle is depressed, the incorrect throttle pedal has been installed in the vehicle. A throttle pedal with two acceleration position sensors must be installed. If troubleshooting an intermittent accelerator problem:

The accelerator pedal or lever position sensor signal voltage can be monitored with INSITE™ electronic service tool, while flexing the harness to locate the intermittent connection. Intermittent connections will show up as abrupt changes in signal voltage displayed by INSITE™ electronic service tool.

Possible causes of this fault include:

  • Accelerator pedal or lever position signal shorted to engine ground or return wires in the OEM harness or sensor
  • Damaged accelerator pedal or lever position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

NOTE: The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 132.

Last Modified: 11-Dec-2014


Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Possible reduced engine performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The oil pressure switch is located on the lower right bank and is threaded to the block, close to the oil filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the engine oil pressure drops below the engine protection limit. Troubleshoot the engine for low oil pressure.

Refer to Troubleshooting Fault Code 143.

Last Modified: 09-Dec-2014


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144.

Last Modified: 09-Dec-2014


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 145.

Last Modified: 09-Dec-2014


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Engine coolant temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 108°C [226°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the applicable engine service manual.

Refer to Troubleshooting Fault Code 146.

Last Modified: 09-Dec-2014


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. Engine coolant temperature signal indicates engine coolant temperature above engine protection critical limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 113°C [ 235°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature.

Refer to Troubleshooting Fault Code 151.

Last Modified: 09-Dec-2014


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Air Temperature Sensor

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Intake manifold air temperature sensor is located on the intake connection where it joins to the intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153.

Last Modified: 10-Nov-2014


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Air Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Intake manifold air temperature sensor is located on the intake connection where it joins to the intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154.

Last Modified: 10-Nov-2014


Wait-to-Start Lamp Driver Circuit - Root Cause Not Known

FAULT CODE 186

Wait-to-Start Lamp Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 186 PID: S36 SPN: 675 FMI: 11/11 LAMP: Amber SRT: | Error detected in the Wait to Start Lamp driver circuit. | The lamp will be illuminated constantly or will not be illuminated at all.
Engine Control Module (ECM)

Circuit Description

The wait-to-start lamp is controlled by the engine ECM. It is used to indicate to the driver when the intake air heater has completed the pre-heat cycle and the engine can be started.

Component Location

The wait-to-start lamp is located in the vehicle dash.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON when the intake air heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a malfunction of the Wait to Start Lamp

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness
  • Wait To Start Lamp malfunction
Refer to Troubleshooting Fault Code 186.

Last Modified: 04-May-2017


Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low engine coolant level detected. | Possible reduced engine performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage was higher than 3-VDC for more than 30 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 197.

Last Modified: 10-Nov-2014


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine Crankshaft Speed/Position - Data Valid But Above Normal Operational Range - Most Severe Level. Engine speed signal indicates engine speed above engine protection limit. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position and camshaft position sensor location varies, depending on engine model.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Reverse powering (motoring) of the engine
  • Tampering of the engine speed/position sensors.

Inspect the intake manifold for sources of flammable vapors. Check the turbocharger seals to verify there are no oil leaks. Inspect the engine speed/position sensors for damage or tampering.

If Fault Code 234 becomes active only during engine braking, and the engine brakes fail to engage, check for a short circuit to ground in the engine brake wiring harness. The rocker lever cover must be removed to perform this inspection. Repair or replace the engine brake wiring harness as necessary.

Refer to Troubleshooting Fault Code 234.

Last Modified: 11-Dec-2014


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on the engine speed sensor +5 volt supply circuit. If the voltage falls below a calibratible limit, this fault is recorded.

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238.

Last Modified: 11-Dec-2014


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the 5 volt sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The backup engine speed sensor will be used by the ECM for the engine speed signal.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.

Refer to Troubleshooting Fault Code 239.

Last Modified: 11-Dec-2014


Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

FAULT CODE 241

Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 241 PID: P84 SPN: 84 FMI: 2/2 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect. The ECM lost the vehicle speed signal or is reading an erratic value. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

The vehicle speed sensor senses the speed of the tailshaft gear on the vehicle's transmission. This speed signal is then transmitted to the engine control module (ECM) and converted into a vehicle speed.

Component Location

The vehicle speed sensor is located in the rear of the vehicle transmission. Refer to the OEM service manual for location.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of vehicle speed when other engine operating conditions indicated that the vehicle should be in motion. This fault code can also become active if the calculated gear ratio and actual gear ratio do not agree while the vehicle is in motion.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine speed operating range is limited to the adjustable parameter “Maximum Engine Speed without VSS”.
  • ECM powerdown will be delayed for 60 seconds after key OFF.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

There are multiple types of vehicle speed sensors. Various types include magnetic pickup, data link, digital, and tachograph. Contact the OEM for the specific type installed on the vehicle.

This fault is set active when the ECM loses a vehicle speed signal when other engine conditions indicate the vehicle is moving. The fault can also become active if there is a series of clutch, service brake or throttle movements with no vehicle movement. The fault is set inactive when the ECM receives a valid vehicle speed signal.

Since the vehicle speed sensor is an OEM installed component, this troubleshooting procedure will not cover all malfunctions of the circuit due to components not under Cummins Inc. control. Sensor resistance values, data link speed sensors and tachographs are not fully covered under this procedure. For more information on those components, refer to the OEM service manual.

A damaged vehicle speed sensor or debris on the end of the sensor could cause the fault to become active.

Incorrect INSITE™ electronic service tool feature and parameter settings (gear ratio, tire size, rear axle ratio, etc) will also cause the fault to become active. Feature and parameter settings under Transmission Setup and Vehicle Speed source need to be verified with the vehicle components.

NOTE: If the power is removed from the ECM within 60 seconds of key OFF and before the ECM has powered down, Fault Code 1117 may become active.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 241.

Last Modified: 10-Nov-2014


Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 249

Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 249 PID: P171 SPN: 171 FMI: 3/3 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at ambient air temperature circuit. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 249.

Last Modified: 10-Nov-2014


Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 256

Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 256 PID: P171 SPN: 171 FMI: 4/4 LAMP: Amber SRT: | Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at ambient air temperature circuit. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ambient air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the harness
  • Signal shorted to return or ground in the sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 256.

Last Modified: 10-Nov-2014


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 0/16 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Fuel temperature above the warning level has been detected. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature exceeded the warning limit.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Operating the engine in a hot ambient environment with a low fuel tank level
  • A malfunctioning fuel temperature sensor
  • Wrong Fuel Grade/Type
  • High coolant temperature
  • High fuel inlet restriction
  • High fuel drain line restriction
Refer to Troubleshooting Fault Code 261.

Last Modified: 10-Nov-2014


Engine Fuel Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 262

Engine Fuel Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 262 PID: P174 SPN: 174 FMI: 1/18 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level. Fuel temperature below the low warning level has been detected. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature was lower than expected for the operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel temperature sensor
  • Wrong Fuel Grade/Type
  • Malfunctioning ambient air temperature sensor
Refer to Troubleshooting Fault Code 262.

Last Modified: 11-Dec-2014


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at fuel temperature circuit. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel temperature signal voltage was greater than 4.97-VDC for more than 5 second.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • A malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 263.

Last Modified: 10-Nov-2014


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine fuel temperature sensor circuit. | Possible reduced engine performance.
Fuel Temperature Sensor Circuit

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • A default value for the fuel temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A signal shorted to ground in the harness
  • A malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 265.

Last Modified: 10-Nov-2014


Fuel Delivery Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 268

Fuel Delivery Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 268 PID: P94 SPN: 94 FMI: 2/2 LAMP: Amber SRT: | Fuel Delivery Pressure - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected that the fuel pressure is higher than a calibrated threshold. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and ground to the fuel pressure sensor on the sensor supply circuit. The Fuel pressure sensor provides a signal to the ECM on the fuel pressure sensor signal circuit. This sensor monitors the fuel pressure from the low fuel pressure system (lift pump to the stage 2 filter).

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after initial key ON.

This diagnostic runs when the fuel lift pump relay is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected The Fuel Pressure is greater than or equal to 7 bar.

The Engine Control Module (ECM) detected the measured fuel pressure is less than 4.5 bar.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel delivery pressure sensor.
  • Damaged engine harness
Refer to Troubleshooting Fault Code 268.

Last Modified: 04-Dec-2014


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 271

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 271 PID: S126 SPN: 1347 FMI: 4/4 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage is detected at the fuel pump actuator circuit. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the fuel pump actuator signal or return circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the electronic fuel pump actuator circuit. Causes for this fault code are short circuit to ground or low resistance (fuel pump actuator coil is shorted internally) in the circuit for the fuel pump actuator. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Refer to Troubleshooting Fault Code 271.

Last Modified: 13-Nov-2014


Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 272

Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 272 PID: S126 SPN: 1347 FMI: 3/3 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit is detected at the fuel pump actuator circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the fuel pump actuator circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Sensed fuel rail pressure will not follow the commanded rail pressure.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the fuel pump actuator circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, short circuit to ground, or low resistance (fuel pump actuator is shorted internally) in the fuel pump actuator circuit. If there is high harness resistance or an intermittent open circuit, Fault Code 2311 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the fuel pump actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

If the fault code is intermittent, inspect the ECM connector, wiring harness, and harness connectors for loose pins and bad connections. Look closely for loose wire connections that can cause an intermittent short to ground or open circuit in the wiring harness or connectors. It may help to wiggle the harness and harness connections and watch for fault code state changes.

Refer to Troubleshooting Fault Code 272.

Last Modified: 13-Nov-2014


Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 281

Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 281 PID: S126 SPN: 1347 FMI: 7/7 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment. The fuel pump actuator driver reported an error. | Possible reduced engine performance.
Fuel Pump Actuator Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the fuel pump actuator. The actuator is grounded in the ECM. The actuator is normally open. The PWM duty cycle to the fuel pump actuator depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the critical limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • A malfunctioning fuel pump actuator
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 281.

Last Modified: 14-Nov-2014


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate. The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU or damaged Cummins® ECM. It can become necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 285.

Last Modified: 10-Nov-2014


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | SAE J1939 Multiplexing Configuration Error - Out of Calibration. The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 286.

Last Modified: 14-Nov-2014


Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 311

Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 311 PID: S1 SPN: 651 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 1 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 311.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 312

Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 312 PID: S5 SPN: 655 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 5 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 312.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 313

Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 313 PID: S3 SPN: 653 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 3 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 313.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 314

Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 314 PID: S6 SPN: 656 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 6 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 314.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 315

Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 315 PID: S2 SPN: 652 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 2 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 315.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 321

Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 321 PID: S4 SPN: 654 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 4 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 321.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 322.

Last Modified: 14-Nov-2014


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 323.

Last Modified: 14-Nov-2014


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 3 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 324.

Last Modified: 14-Nov-2014


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 6 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 325.

Last Modified: 14-Nov-2014


Engine Fuel Pump Pressurizing Assembly 2 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 328

Engine Fuel Pump Pressurizing Assembly 2 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 328 PID: S127 SPN: 1348 FMI: 7/7 LAMP: Amber SRT: | Engine Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment. The fuel pump actuator driver reported an error. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pressure Relief Valve

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the critical limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel pressure relief valve
  • Damaged engine harness
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 328.

Last Modified: 11-Dec-2014


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 2 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 331.

Last Modified: 14-Nov-2014


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 4 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 332.

Last Modified: 14-Nov-2014


Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 334

Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 334 PID: P110 SPN: 110 FMI: 2/2 LAMP: Amber SRT: | Engine Coolant Temperature - Data Erratic Intermittent or Incorrect. The engine coolant temperature sensor is reading an erratic value at initial key ON. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than other engine temperature sensors by a calibratable value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the engine coolant temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • Monitor Engine Coolant Temperature Using INSITE™ electronic service tool during the Diagnostic Road Test or Dynamometer run. Coolant temperature should remain in the normal operating range
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine coolant temperature sensor
  • High resistance in the engine coolant temperature sensor signal or return lines.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Refer to Troubleshooting Fault Code 334.

Last Modified: 14-Nov-2014


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 338

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 338 PID: S87 SPN: 1267 FMI: 3/3 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal, or Shorted to High Source. Open circuit or short to voltage source detected at the idle shutdown vehicle accessory/ignition bus relay circuit. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded OFF, it records this fault code. This fault code can be caused by:

  • ECM Idle Shutdown feature set up incorrectly.
  • Open circuit in the idle shutdown relay, OEM harness, or connectors.
  • Short circuit to a voltage source in the OEM harness or relay.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 338.

Last Modified: 14-Nov-2014


Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 339

Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 339 PID: S87 SPN: 1267 FMI: 4/4 LAMP: Amber SRT: | Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal, or Shorted to Low Source. Low voltage detected at the idle shutdown vehicle accessory or ignition bus relay circuit when commanded ON. | Vehicle accessories or ignition bus loads controlled by the idle shutdown relay will not power up.
Idle Shutdown Vehicle Accessories Relay Driver Circuit

Circuit Description

The Engine Control Module (ECM) Idle Shutdown feature has an optional parameter for a shutdown accessory relay. When this parameter is set to “Installed”, the ECM sends a signal to energize the relay and turn off vehicle accessories during idle shutdown events. The idle shutdown relay return circuit varies by Original Equipment Manufacturer (OEM). The return circuit can be returned to the ECM through the ECM Return (General) or connected directly to ground. Refer to the OEM service manual to determine grounding configuration.

Component Location

The idle shutdown relay location varies by OEM. Refer to the OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle shutdown relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The accessories controlled by the idle shutdown relay will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. This fault code is logged if it detects a low voltage when the relay signal is commanded on. This fault code can be caused by a short circuit to ground in the idle shutdown relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 339.

Last Modified: 14-Nov-2014


Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

FAULT CODE 343

Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 343 PID: S254 SPN: 629 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component. ECM power supply errors have been detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.

This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 343 active.

Refer to Troubleshooting Fault Code 343.

Last Modified: 14-Nov-2014


Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

FAULT CODE 346

Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 346 PID: S253 SPN: 630 FMI: 12/12 LAMP: Amber SRT: | Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component. Invalid switch configuration adjustable parameter setting have been detected by the Engine Control Module (ECM). | Various optional switch inputs to the ECM may not operate correctly.
Engine Control Module (ECM)

Circuit Description

The Orginal Equipment Manufacturer (OEM) wiring harness connects multiple outputs or switched inputs to the ECM which can be enabled or disabled using INSITE™ electronic service tool, such as such as the accelerator interlock/engine torque limit switch or the clutch/engine protection override switch. Many of the outputs and switched inputs share a common wire on the OEM wiring harness. Refer to the engine wiring diagram to determine which features share common wires in the OEM harness.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected features which share a common input or output to the ECM were simultaneously enabled..

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Many of the outputs and switched inputs share a common wire on the OEM wiring harness. If two features that share a common OEM wire are enabled simultaneously in the ECM, this fault code will be logged. To disable the fault code, disable one of the features on the shared OEM wire. For example, if the accelerator interlock switch and powertrain protection torque limit switch are both enabled in the ECM, either disable one of the features with INSITE™ electronic service tool or configure one of the features to be multiplexed using the SAE J1939 multiplexing feature.

Refer to Troubleshooting Fault Code 346.

Last Modified: 26-Jan-2015


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | Injector Power Supply - Bad Intelligent Device or Component. The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The engine harness connects the ECM to the pass-through connector(s) that are located in the rocker housing. Internal injector harnesses are located under the valve cover and connect the injectors to the engine harness at the pass-through connector(s).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will become active after key ON if the battery charge is above a minimum threshold, and, at the same time, the measured injector power supply voltage is lower than the commanded injector power supply voltage.

Refer to Troubleshooting Fault Code 351.

Last Modified: 26-Jan-2015


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The engine control module (ECM) provides a dedicated 5 volt supply to various engine sensors. The following sensors make-up sensor supply 1: rail fuel pressure, fuel pressure, exhaust gas pressure, Turbocharger Compressor Inlet Pressure, Camshaft Position, Charge-Air Cooler Outlet Pressure and Temperature, Turbocharger Compressor Intake Pressure and Temperature, Crankcase pressure, turbo speed, EGR bypass position and EGR position sensors.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was less than 4.64-VDC for more than one second.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 1, Fault Code 352 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

• Operate the engine under the conditions that will cause Fault Code 352 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 352 stops logging under the test conditions. Each sensor can be unplugged with the engine running. Note: The engine may not start if the camshaft position sensor is unplugged.

Refer to Troubleshooting Fault Code 352.

Last Modified: 26-Jan-2015


Engine Failed Automatic Start - Condition Exists

FAULT CODE 359

Engine Failed Automatic Start - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 359 PID: S124 SPN: 1664 FMI: 11/31 LAMP: Red SRT: | Engine Failed Automatic Start - Condition Exists. Engine Camshaft to Crankshaft synchronization had not been achieved within a calibratable window. | The engine will not start.
Camshaft Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The camshaft position sensor is mounted on the right bank (exhaust cam) valve cover and can be seen from the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is cranking.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The engine will not start.
  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged or malfunctioning camshaft position sensor.
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 359.

Last Modified: 04-Dec-2014


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 386.

Last Modified: 17-Nov-2014


Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 418

Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 418 PID: P97 SPN: 97 FMI: 0/15 LAMP: Maintenance SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level. Water has been detected in the fuel filter. | None on performance.
Water-in-Fuel Indicator Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that water has been detected in the water separation fuel filter. Drain the water from the fuel filter.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 418.

Last Modified: 17-Nov-2014


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 428

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 428 PID: P97 SPN: 97 FMI: 3/3 LAMP: Amber SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Open RETURN or SIGNAL circuit in the harness, connectors, or sensor
  • SIGNAL wire shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 428.

Last Modified: 17-Nov-2014


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 429

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 429 PID: P97 SPN: 97 FMI: 4/4 LAMP: Amber SRT: | Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the water-in-fuel circuit. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the OEM supplied suction fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

Short to ground in the wire harness

SIGNAL wire shorted to ground

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 429.

Last Modified: 17-Nov-2014


Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 435

Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 435 PID: P100 SPN: 100 FMI: 2/2 LAMP: Amber SRT: | Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect. The engine oil pressure sensor is reading an erratic value. | None on performance.
Engine Oil Rifle Pressure Sensor Circuit

Circuit Description

An engine oil pressure switch or oil pressure sensor is used by the engine control module (ECM) to monitor the lubricating oil pressure. For engines with an oil pressure switch, the switch is normally closed when the engine is not running and open when oil pressure is present. For engines with an oil pressure sensor, the ECM will detect a low signal voltage at operating conditions when the oil pressure is low. The ECM will detect a high signal voltage at operating conditions when the oil pressure is high.

Component Location

The engine oil pressure sensor is located in the oil rifle.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON posistion or the engine is running.
  • The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure reading was higher or lower than the other absolute pressure sensors on the engine after the keyswitch has been turned OFF and the engine has stopped running.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning engine oil pressure switch

High resistance in the engine harness.

Refer to Troubleshooting Fault Code 435.

Last Modified: 17-Nov-2014


Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 436

Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 436 PID: P105 SPN: 105 FMI: 2/2 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect. The intake manifold temperature sensor is reading an erratic value at initial key ON or while the engine is running. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run.

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake manifold temperature sensor reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the intake manifold temperature reading.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor
  • High resistance in the engine intake manifold temperature sensor signal or return lines.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Refer to Troubleshooting Fault Code 436.

Last Modified: 17-Nov-2014


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel rail pressure sensor circuit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the fuel rail pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the return wire
  • Malfunctioning sensor
  • Malfunctioning ECM.
Refer to Troubleshooting Fault Code 451.

Last Modified: 17-Nov-2014


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel rail pressure sensor circuit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Injector Metering Rail 1 Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the fuel rail pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes for this fault code include:

  • Supply or signal wire is shorted to ground.
  • Damaged sensor
  • Damaged ECM.
Refer to Troubleshooting Fault Code 452.

Last Modified: 17-Nov-2014


Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 477

Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 477 PID: P444 SPN: 444 FMI: 1/18 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level. The voltage supply to the diesel exhaust fluid controller is lower than the electrical system voltage. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Controller Voltage Supply Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. The diesel exhaust fluid controller communicates to the engine control module (ECM) via the J1939 data link connection.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid controller detected the battery supply voltage was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Improper battery voltage setting in INSITE™ electronic service tool
  • A damaged alternator causing low voltage
  • A weak or damaged battery.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 477.

Last Modified: 13-Jan-2016


Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 478

Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 478 PID: P444 SPN: 444 FMI: 0/16 LAMP: Amber SRT: | Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level. The voltage supply to the diesel exhaust fluid controller is higher than the electrical system voltage. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Controller Voltage Supply Circuit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. The diesel exhaust fluid controller communicates to the engine control module (ECM) via the J1939 data link connection.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

  • The aftertreatment diesel exhaust fluid controller detected the battery supply voltage was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Improper battery voltage setting in INSITE™ electronic service tool
  • A damaged alternator causing high voltage
  • Improperly connected batteries.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 478.

Last Modified: 17-Nov-2014


Engine Fuel Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 482

Engine Fuel Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 482 PID: P94 SPN: 94 FMI: 1/18 LAMP: None SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low fuel delivery pressure has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Fuel Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and ground to the fuel pressure sensor on the sensor supply circuit. The Fuel pressure sensor provides a signal to the ECM on the fuel pressure sensor signal circuit. This sensor monitors the fuel pressure from the low fuel pressure system (lift pump to the stage 2 filter).

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than normal.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A plugged fuel filter
  • Blocked or restricted fuel line.
  • A malfunctioning fuel filter outlet pressure sensor.
  • A malfunctioning fuel lift pump
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 482.

Last Modified: 26-Jan-2015


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Intake manifold air temperature sensor is located on the intake connection where it joins to the intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manfiold air temperature was greater than 132°C [270°F] for 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the amber CHECK ENGINE lamp immediately after the diagnostic runs and fails on two consecutive trips.
  • The torque output of the engine will be reduced.
  • Maximum engine operating speed will be decreased.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the charge-air cooler
  • Undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488.

Last Modified: 17-Nov-2014


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected on the +5 volt sensor supply circuit. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit is a dedicated (+) 5-VDC supply for the DPF Differential Pressure Sensor.

Component Location

Sensor Supply 6 originates in the OEM Connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.

Refer to Troubleshooting Fault Code 515.

Last Modified: 11-Dec-2014


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected on the +5 volt sensor supply circuit. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit is a dedicated (+) 5-VDC supply for the DPF Differential Pressure Sensor.

Component Location

Sensor Supply 6 originates in the OEM Connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.

Refer to Troubleshooting Fault Code 516.

Last Modified: 11-Dec-2014


Engine Fuel Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 535

Engine Fuel Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 535 PID: P174 SPN: 174 FMI: 2/2 LAMP: Amber SRT: | Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. Fuel temperature above the warning level has been detected. | Possible reduced engine performance.
ECM

Circuit Description

The fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel entering the high pressure pump. The engine control module (ECM) supplies 5 volts to the fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the fuel temperature. The fuel temperature is used by the ECM for the engine protection system, timing, and fueling control.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

  • The Engine Control Module (ECM) detected the fuel temperature sensor was higher or lower than expected.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • A malfunctioning fuel temperature sensor
  • Resistance in the wiring harness
  • Operating the engine in a hot ambient environment with a low fuel tank level
Refer to Troubleshooting Fault Code 535.

Last Modified: 18-Nov-2015


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P94 SPN: 94 FMI: 3/3 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the fuel delivery pressure sensor circuit. | None on performance.
Fuel Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and ground to the fuel pressure sensor on the sensor supply circuit. The Fuel pressure sensor provides a signal to the ECM on the fuel pressure sensor signal circuit. This sensor monitors the fuel pressure from the low fuel pressure system (lift pump to the stage 2 filter).

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to a voltage source.
  • Open return circuit in the engine harness, connectors, or sensor
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine ECM
Refer to Troubleshooting Fault Code 546.

Last Modified: 17-Nov-2014


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P94 SPN: 94 FMI: 4/4 LAMP: Amber SRT: | Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel delivery pressure sensor circuit. | None on performance.
Fuel Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and ground to the fuel pressure sensor on the sensor supply circuit. The Fuel pressure sensor provides a signal to the ECM on the fuel pressure sensor signal circuit. This sensor monitors the fuel pressure from the low fuel pressure system (lift pump to the stage 2 filter).

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the fuel delivery pressure reading is used.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine ECM
Refer to Troubleshooting Fault Code 547.

Last Modified: 17-Nov-2014


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was greater than the commanded fuel rail pressure.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

A fuel pump actuator with excessive leakage or a damaged inboard o-ring will result in high fuel rail pressures at idle or light load.

Refer to Troubleshooting Fault Code 553.

Last Modified: 17-Nov-2014


Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 554

Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 554 PID: P157 SPN: 157 FMI: 2/2 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the fuel pressure signal is erratic. | Possible reduced engine performance.
Injector Metering Rail 1 Pressure Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This is a two part diagnostic.

This diagnostic runs when the keyswitch is turned ON and before engine speed is detected.

This diagnostic runs at key OFF. The fault will be active at the next key-ON event.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • malfunctioning fuel pressure sensor
  • Malfunctioning ECM
Refer to Troubleshooting Fault Code 554.

Last Modified: 17-Nov-2014


Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | Crankcase Pressure - Data Valid but Above Normal Operational Range - Moderately Severe Level. The crankcase breather filter requires maintenance. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located near the crankcase ventilation filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Plugged or restricted crankcase breather oil drain tube or check valve
  • Plugged or restricted crankcase breather draft tube
  • Frozen, plugged, or restricted crankcase breather tube.

It is important to check for plugged or restricted hoses, tubes, check valves, oil separator, and filters in extreme cold ambient temperatures. If Fault Code 555 becomes active due to a plugged filter before the maintenance interval is reached or the filter plugs frequently, see the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree.

Refer to Troubleshooting Fault Code 555.

Last Modified: 12-May-2015


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operational Range - Moderately Severe Level. The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure is below the commanded fuel rail pressure by at least 100 bar [1450 psi] for 7 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • High fuel inlet restriction
  • A malfunctioning fuel lift pump
  • Air in the fuel
  • Leaking fuel rail pressure relief valve
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel injectors and or fuel injector connectors
Refer to Troubleshooting Fault Code 559.

Last Modified: 17-Nov-2014


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 595

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 595 PID: P103 SPN: 103 FMI: 0/16 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level. High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was greater than 150,000 rpm for more than 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

If the fault occurs intermittently, look for causes of intermittent open or short circuits in the turbocharger speed sensor circuit (including the speed sensor pigtail connector).

Refer to Troubleshooting Fault Code 595.

Last Modified: 17-Nov-2014


Electrical Charging System Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 596

Electrical Charging System Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 596 PID: P167 SPN: 167 FMI: 0/16 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Above Normal Operational Range - Moderately Severe Level. High battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was greater than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if idle speedup is enabled. Use INSITE™ electronic service tool to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM battery supply (+) is coming directly from the battery and not the starter.

Possible cause of this fault code:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 596.

Last Modified: 17-Nov-2014


Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 597

Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 597 PID: P167 SPN: 167 FMI: 1/18 LAMP: Amber SRT: | Electrical Charging System Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the battery voltage monitor feature. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the battery voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is part of the Battery Voltage Monitor feature. The ECM can increase idle speed and deactivate idle decrement switch if Idle Speedup is enabled. Use INSITE™ electronic service tool to view the Battery Voltage Monitor feature settings. Disabling the Battery Voltage Monitor feature will also disable this fault code.

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter.

Possible causes of this fault code include:

  • Undercharged batteries caused by a malfunctioning alternator or regulator.
  • High-current devices on the vehicle such as citizens band radio amplifiers, numerous exterior lights, or other accessories.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 597.

Last Modified: 17-Nov-2014


Engine Oil Change Interval - Condition Exists

FAULT CODE 649

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 649 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Maintenance SRT: | Engine Oil Change Interval - Condition Exists. Change engine oil and filter. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) informs the driver of a maintenance event by using the Maintenance Monitor feature's lubrication oil drain limits.

Component Location

Not Applicable

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil and filter required changing based on the programmable setting in the Maintenance Monitor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

Use the INSITE electronic service tool to reset the Maintenance Monitor feature.

  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will only become active if the Maintenance Monitor is enabled in INSITE™ electronic service tool. Make sure the oil and filter are changed before clearing the fault code.

Refer to Troubleshooting Fault Code 649.

Last Modified: 17-Nov-2014


Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 687

Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 687 PID: P103 SPN: 103 FMI: 1/18 LAMP: Amber SRT: | Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low turbocharger speed detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was less than 600 rpm for more than 1 second when the engine speed was greater than 1200 rpm.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The ECM will estimate the turbocharger speed.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Items that can cause this fault code include:

  • Damaged turbocharger speed sensor
  • Damaged engine harness
  • Damaged ECM.

Operating the engine at idle or high idle while stationary will not create enough load to maintain boost pressure at 1.19 times ambient pressure for 30 consecutive seconds. .

Although it is possible for a damaged ECM to be the root cause of this fault code, it is highly unlikely. ECM replacement should only be considered as a last resort, if no other repairs are successful in clearing the fault code.

In very rare cases, it has been shown that the turbocharger can cause this fault code to come active and turbocharger replacement may be the only way to clear the fault code.

Refer to Troubleshooting Fault Code 687.

Last Modified: 17-Nov-2014


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect. The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Engine Crankshaft Speed/Position Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor is located at the front of the engine and is bolted to the front cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The backup engine speed sensor will be used by the ECM for the engine speed signal.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning engine speed sensor
  • Damaged tone wheel
  • Sensor air gap that is too small or too large.
Refer to Troubleshooting Fault Code 689.

Last Modified: 11-Dec-2014


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 691

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 691 PID: P351 SPN: 1172 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Temperature Sensor Circuit

Circuit Description

The compressor intake air temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 691, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or short circuit to a voltage source
  • Damaged sensor.
Refer to Troubleshooting Fault Code 691.

Last Modified: 17-Nov-2014


Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 692

Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 692 PID: P351 SPN: 1172 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at turbocharger compressor intake air temperature circuit. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the compressor intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger compressor intake air temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active. Before troubleshooting Fault Code 692, check for multiple fault codes. An extension harness between the main engine harness and the turbocharger compressor intake temperature sensor can be used depending on the turbocharger arrangement.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor
  • Damaged sensor.
Refer to Troubleshooting Fault Code 692.

Last Modified: 17-Nov-2014


Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 693

Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 693 PID: P351 SPN: 1172 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect. A temperature too high or low for the operating conditions has been detected by the turbocharger compressor intake temperature sensor. | Possible reduced engine performance.
Turbocharger 1 Compressor Intake Temperature Sensor Circuit

Circuit Description

The turbocharger compressor intake temperature sensor is a variable resistor sensor and is used to measure the temperature of the air entering the compressor intake of the turbocharger. The engine control module (ECM) supplies 5-VDC to the compressor intake temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the air temperature.

Component Location

The turbocharger compressor intake temperature sensor is located in the compressor inlet of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF.
  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the compressor intake temperature reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the compressor intake temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range compressor intake temperature sensor
  • High resistance in the compressor intake temperature sensor signal or return lines
  • ECM malfunction.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Refer to Troubleshooting Fault Code 693.

Last Modified: 17-Nov-2014


Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 697

Engine ECU Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 697 PID: P21 SPN: 1136 FMI: 3/3 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted high.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • ECM malfunction.
Refer to Troubleshooting Fault Code 697.

Last Modified: 09-Dec-2014


Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 698

Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 698 PID: P21 SPN: 1136 FMI: 4/4 LAMP: Amber SRT: | ECM Internal Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the internal ECM temperature sensor. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was shorted to ground.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • ECM malfunction.
Refer to Troubleshooting Fault Code 698.

Last Modified: 09-Dec-2014


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 PID: P21 SPN: 1136 FMI: 2/2 LAMP: Amber SRT: | Engine ECU Temperature - Data Erratic, Intermittent or Incorrect. An incorrect of inconsistent temperature reading has been detected internal to the ECM. | None on performance.
ECM

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was irrational.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to the Troubleshooting Fault Code 699.

Last Modified: 17-Nov-2014


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment. Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Speed/Position Sensor Circuit
Camshaft Speed/Postion Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply to the position sensor and a return circuit. As the teeth on the crankshaft speed ring or the dimples in the back of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM interprets this signal and converts it to an engine speed. A missing tooth on the crankshaft gear is used by the ECM to determine the position of the engine.

Component Location

The crankshaft position sensor is located at the front of the engine and is bolted to the front cover.

The camshaft position sensor is mounted on the right bank (exhaust cam) valve cover and can be seen from the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Engine speed sensor rings that are loose or not aligned correctly
  • Mechanical misalignment.
Refer to Troubleshooting Fault Code 731.

Last Modified: 11-Dec-2014


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 741

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 741 PID: S314 SPN: 1176 FMI: 3/3 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Inlet Pressure/Temperature Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The combination turbocharger compressor intake pressure/temperature sensor is located in the original equipment manufacturer (OEM) intake air plumbing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the engine harness.
  • An open return circuit in the engine harness
  • A malfunctioning turbocharger compressor intake pressure/temperature sensor
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 741.

Last Modified: 18-Nov-2014


Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 742

Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 742 PID: S314 SPN: 1176 FMI: 4/4 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the turbocharger compressor intake pressure sensor circuit. | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The combination turbocharger compressor intake pressure/temperature sensor is located in the original equipment manufacturer (OEM) intake air plumbing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger compressor intake pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
  • A malfunctioning turbocharger compressor intake pressure/temperature sensor
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 742.

Last Modified: 18-Nov-2014


Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 743

Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 743 PID: S314 SPN: 1176 FMI: 2/2 LAMP: Amber SRT: | Turbocharger 1 Compressor Intake Pressure - Data erratic, intermittent or incorrect | Possible reduced engine performance.
Turbocharger Compressor Intake Pressure Sensor Circuit

Circuit Description

The combination turbocharger compressor intake pressure/temperature sensor is used to measure ambient air pressure. The pressure measuring portion of the sensor responds to pressure changes in the atmospheric pressure, which occur based on elevation at which the engine is presently operating. The turbocharger compressor intake pressure sensor has a 5 volt supply circuit, a pressure sensor signal voltage, and a return circuit. The ECM will detect a low signal voltage when the vehicle is operating at high altitudes. The ECM will detect a high signal voltage when the vehicle is operating at sea level altitudes.

Component Location

The combination turbocharger compressor intake pressure/temperature sensor is located in the original equipment manufacturer (OEM) intake air plumbing.

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON posistion or the engine is running.
  • The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric pressure reading was higher or lower than the other absolute pressure sensors on the engine, or an in-range malfunction of the sensor was detected.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger compressor intake pressure/temperature sensor
Refer to Troubleshooting Fault Code 743.

Last Modified: 18-Nov-2014


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 778

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 778 PID: S64 SPN: 723 FMI: 2/2 LAMP: Amber SRT: | Engine Camshaft Speed / Position Sensor - Data Erratic, Intermittent, or Incorrect. The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Engine Camshaft Speed/Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the camshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As slots in the front of the camshaft gear move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the cam gear slots indicate to the ECM the position of the engine. This sensor is used as a backup sensor if the engine crankshaft position signal is lost.

Component Location

The camshaft position sensor is mounted on the right bank (exhaust cam) valve cover and can be seen from the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the 5 volt supply, signal, or return wire in the engine harness.
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged speed indicator lobe.
  • Sensor air gap that is too large or small.
Refer to Troubleshooting Fault Code 778.

Last Modified: 18-Nov-2014


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Make sure the ECM unswitched battery supply is coming directly from the battery and not the starter. If unswitched power is coming from the starter, it is possible for the battery voltage to drop low enough during cranking to set this fault active.This fault can also be caused by resistance in the ECM battery supply (+) or (-) circuits. Resistance in these circuits can cause the voltage level at the ECM input to drop low enough to set Fault Code 1117 active. Use of battery disconnect switches to turn off the engine or any device that disconnects battery voltage to the ECM within 10 seconds of turning the keyswitch OFF can cause damage to the aftertreatment system. The vehicle should not be operated with an active Fault Code 1117.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1117.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1139

Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1139 PID: S1 SPN: 651 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1139.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1141

Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1141 PID: S2 SPN: 652 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1141.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1142

Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1142 PID: S3 SPN: 653 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1142.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1143

Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1143 PID: S4 SPN: 654 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1143.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1144

Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1144 PID: S5 SPN: 655 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1144.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 1145

Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1145 PID: S6 SPN: 656 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 1145.

Last Modified: 26-Jan-2015


EGR Valve Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1228

EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1228 PID: P27 SPN: 27 FMI: 2/2 LAMP: Amber SRT: | EGR Valve Position - Data Erratic, Intermittent, or Incorrect. The EGR valve is unable to meet commanded position. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

Component Location

The EGR valve position sensor is internal to the EGR valve assembly and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve was unable to reach the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Intermittent open or short in the wiring harness
  • Malfunctioning EGR valve position sensor
  • Malfunctioning ECM
Refer to Troubleshooting Fault Code 1228.

Last Modified: 18-Nov-2014


VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1229

VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1229 PID: S27 SPN: 2795 FMI: 2/2 LAMP: Amber SRT: | VGT Position Sensor - Data erratic, intermittent, or incorrect. Intermittent variable geometry turbocharger (VGT) position information is being received by the electronic control module (ECM). | Possible reduced engine performance.
Variable Geometry Turbocharger Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Variable Geometry Turbocharger (VGT) actuator was slow to meet the commanded position.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning variable geometry turbocharger (VGT)
  • High exhaust restriction.
Refer to Troubleshooting Fault Code 1229.

Last Modified: 11-Dec-2014


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1239

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1239 PID: S385 SPN: 2623 FMI: 3/3 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was greater than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Accelerator pedal position 2 signal circuit shorted to battery or 5-VDC supply
  • Open accelerator pedal return circuit in the harness or connections
  • Accelerator supply shorted to battery
  • Damaged accelerator pedal position sensor.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1239.

Last Modified: 11-Dec-2014


Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1241

Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1241 PID: S385 SPN: 2623 FMI: 4/4 LAMP: Amber SRT: | Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at accelerator pedal position number 2 signal circuit. | The engine will operate in Limp Home mode.
Accelerator Pedal or Lever Position Sensor 2 Circuit

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the throttle pedal signal voltage was less than a calibratible value for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Accelerator pedal position signal shorted to engine ground or return wires in the harness or sensor
  • Damaged accelerator pedal position sensor
  • Open circuit in the accelerator signal, supply, or return wire in the harness or connectors.

The three wires in the accelerator position sensor circuit must be twisted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1241.

Last Modified: 11-Dec-2014


Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1242

Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1242 PID: P91 SPN: 91 FMI: 2/2 LAMP: Red SRT: | Accelerator Pedal or Lever Position Sensor 1 and 2 - Data Erratic, Intermittent, or Incorrect. Accelerator position sensor number 1 and number 2 are reading different values. | Engine will only idle.
Accelerator Pedal or Lever Position Sensor Circuits

Circuit Description

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the readings between the accelerator position sensor 1 and accelerator position sensor 2 differ by more than 2 percent.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • Damaged accelerator pedal position sensor number 1 or damaged accelerator pedal position sensor number 2
  • Accelerator pedal position sensor number 1 and accelerator pedal position sensor number 2 signal wires are shorted together.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1242.

Last Modified: 11-Dec-2014


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data in Error

FAULT CODE 1515

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1515 PID: P91 SPN: 91 FMI: 2/19 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the multiplexed accelerator pedal or lever sensor system.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the multiplexed accelerator pedal.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1515.

Last Modified: 12-May-2015


Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1548

Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1548 PID: S7 SPN: 657 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 7 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 1 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 1548.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1549

Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1549 PID: S8 SPN: 658 FMI: 5/5 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit. Malfunction detected at injector 8 circuit. | Possible reduced engine performance.
Injector Solenoid Driver Cylinder 5 Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

Possible causes of a single injector fault include:

• Open circuit in the engine harness(es) or injector solenoid

• High resistance in a single injector or injector solenoid

• Malfunctioning or damaged ECM.

Refer to Troubleshooting Fault Code 1549.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 8 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 1561

Injector Solenoid Driver Cylinder 8 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1561 PID: S8 SPN: 658 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 8 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 1561.

Last Modified: 18-Nov-2014


Injector Solenoid Driver Cylinder 7 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 1623

Injector Solenoid Driver Cylinder 7 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1623 PID: S7 SPN: 657 FMI: 6/6 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 Circuit - Current Above Normal or Grounded Circuit. The ECM has detected a short circuit in the injector 7 circuit. | Engine will misfire or run rough.
Injector circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector is shorted to a voltage source, shorted to a battery source, or low injector solenoid resistance.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include.

  • Open signal circuit or short circuit to a voltage source

Low resistance in the injector.

Refer to Troubleshooting Fault Code 1623.

Last Modified: 18-Nov-2014


Engine Misfire Cylinder 1 - Condition Exists

FAULT CODE 1654

Engine Misfire Cylinder 1 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1654 PID: SPN: 1323 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 1- Condition Exists. Engine misfire has been detected in cylinder number 1. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 1 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1654 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event, such as air entering the fuel system following a filter change, caused the fault. Inactive counts of Fault Code 1654 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1654.

Last Modified: 18-Nov-2014


Engine Misfire Cylinder 2 - Condition Exists

FAULT CODE 1655

Engine Misfire Cylinder 2 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1655 PID: SPN: 1324 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 2 - Condition Exists. Engine misfire has been detected in cylinder number 2. | Possible reduced engine performance.
Engine Control Module

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 2 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1655 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1655 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1655.

Last Modified: 21-Nov-2014


Engine Misfire Cylinder 3 - Condition Exists

FAULT CODE 1656

Engine Misfire Cylinder 3 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1656 PID: SPN: 1325 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 3 - Condition Exists. Engine misfire has been detected in cylinder number 3. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

  • The Engine Control Module (ECM) detected a cylinder 3 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1656 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event, such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1656 should be disregarded unless other performance symptoms are present. The coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1656.

Last Modified: 21-Nov-2014


Engine Misfire Cylinder 4 - Condition Exists

FAULT CODE 1657

Engine Misfire Cylinder 4 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1657 PID: SPN: 1326 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 4 - Condition Exists. Engine misfire has been detected in cylinder number 4. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 4 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1657 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1657 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1657.

Last Modified: 21-Nov-2014


Engine Misfire Cylinder 5 - Condition Exists

FAULT CODE 1658

Engine Misfire Cylinder 5 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1658 PID: SPN: 1327 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 5 - Condition Exists. Engine misfire has been detected in cylinder number 5. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 5 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1658 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1658 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1658.

Last Modified: 21-Nov-2014


Engine Misfire Cylinder 6 - Condition Exists

FAULT CODE 1659

Engine Misfire Cylinder 6 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1659 PID: SPN: 1328 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 6 - Condition Exists. Engine misfire has been detected in cylinder number 6. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 6 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1659 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event, such as air entering the fuel system, following a filter change caused the fault. Inactive counts of Fault Code 1659 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1659.

Last Modified: 21-Nov-2014


Engine Misfire Cylinder 7 - Condition Exists

FAULT CODE 1661

Engine Misfire Cylinder 7 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1661 PID: SPN: 1329 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 7 - Condition Exists. Engine misfire has been detected in cylinder number 7. | Possible reduced engine performance.
Engine Control Module

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 7 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1661.

Last Modified: 04-Dec-2014


Engine Misfire Cylinder 8 - Condition Exists

FAULT CODE 1662

Engine Misfire Cylinder 8 - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1662 PID: SPN: 1330 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire Cylinder 8 - Condition Exists. Engine misfire has been detected in cylinder number 8. | Possible reduced engine performance.
Engine Control Module

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a cylinder 8 misfire.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder malfunction (check for high blowby when the engine is loaded)
  • Valve malfunction or valve held open (listen for intake valve “chirping” noise in the intake)
  • Extra, missing, or damaged sealing washer under an injector
  • Injector malfunctions (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1662.

Last Modified: 04-Dec-2014


Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

FAULT CODE 1664

Aftertreatment 1 Diesel Oxidation Catalyst Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1664 PID: S380 SPN: 4796 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists. The aftertreatment diesel oxidation catalyst is not present in the exhaust system. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs during active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor signal and the aftertreatment diesel particulate filter intake temperature sensor signal during an active regeneration of the aftertreatment system was too small indicating a missing diesel oxidation catalyst.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code becomes active when the aftertreatment diesel oxidation catalyst intake and aftertreatment diesel particulate filter intake temperature sensors do not detect the presence of a catalyst in the aftertreatment system.

Possible causes of this fault code include:

  • Tampering with the catalyst system
  • Removing the catalyst system from the vehicle
  • A damaged catalyst.
Refer to Troubleshooting Fault Code 1664.

Last Modified: 13-Jan-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1668

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1668 PID: SPN: 1761 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank level sensor circuit. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1668.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1669

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1669 PID: SPN: 1761 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst tank level sensor circuit. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1669.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 1673

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1673 PID: SPN: 1761 FMI: 1/1 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level. The aftertreatment diesel exhaust fluid tank level has fallen below the critical warning level. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is part of the dosing unit which is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was critically low.

Action Taken When the Fault Code is Active

The Diesel Exhaust Fluid Lamp will be flashing.

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after the engine has been shutdown, 1 hour of engine idle time, or the fuel tank has been refilled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the Diesel Exhaust Fluid (DEF) level is critically low and there will be a power loss. Engine power will be reduced automatically. This can be corrected by refilling the DEF tank. Normal engine power will be restored after refilling the DEF tank.

Refer to Troubleshooting Fault Code 1673.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1677

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1677 PID: SPN: 3031 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid tank temperature sensor circuit. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1677.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 1678

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1678 PID: None SPN: 3031 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid tank temperature sensor circuit | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF Tank Temperature Sensor Signal is greater than 4.4-VDC for 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1678.

Last Modified: 11-Dec-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1679

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1679 PID: SPN: 3031 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid tank temperature sensor has indicated a tank temperature too high or too low for the ambient conditions. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is part of the dosing unit which is located in the DEF tank

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature sensor reading was higher or lower than the other temperature sensors on the engine.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, the engine must be shut down with the keyswitch in the OFF position for 8 hours. After the 8 hour cold soak, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range failure of the diesel exhaust fluid tank temperature sensor
  • Damaged wiring harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1679.

Last Modified: 12-May-2015


Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

FAULT CODE 1682

Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1682 PID: SPN: 3362 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists. The aftertreatment diesel exhaust fluid dosing unit is unable to prime. | Possible reduced engine performance.
Dosing unit

Circuit Description

The diesel exhaust fluid dosing unit lines are responsible for transporting diesel exhaust fluid between the dosing unit, dosing valve, and diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid line heater is located between the diesel exhaust fluid tank and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the SCR system is trying to prime.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit was unable to successfully prime after multiple attempts.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank
  • The line heaters are not successfully thawing the frozen diesel exhaust fluid
  • The diesel exhaust fluid pressure line between the dosing unit and dosing valve is kinked, broken, or disconnected
  • Malfunctioning diesel exhaust fluid dosing unit
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.
Refer to Troubleshooting Fault Code 1682.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

FAULT CODE 1683

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1683 PID: SPN: 3363 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank heater circuit is shorted to battery or open circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Diesel exhaust fluid tank heater signal wire and return wire shorted together
  • Malfunctioning diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1683.

Last Modified: 06-Jul-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1684

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1684 PID: SPN: 3363 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid tank heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid tank heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid tank heater control valve
  • A short circuit to ground
Refer to Troubleshooting Fault Code 1684.

Last Modified: 06-Jul-2015


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1685

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1685 PID: SPN: 3364 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage below normal, or shorted to low source | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment DEF quality sensor reported an out of range low condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 1685.

Last Modified: 19-Feb-2016


Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1686

Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1686 PID: SPN: 3364 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage above normal, or shorted to high source | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment DEF quality sensor reported an out of range high condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 1686.

Last Modified: 19-Feb-2016


Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

FAULT CODE 1688

Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1688 PID: SPN: 3360 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel exhaust fluid controller. | Possible reduced engine performance.
Dosing unit

Circuit Description

The SCR dosing system is an In-tank system with a Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

An internal error was detected in the aftertreatment diesel exhaust fluid controller, and has been communicated to the Engine Control Module (ECM) via the J1939 data link.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1688.

Last Modified: 26-Jan-2015


Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1691

Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1691 PID: S380 SPN: 5298 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The temperature increase across the aftertreatment catalyst is lower than expected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the DOC efficiency was less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning diesel oxidation catalyst
Refer to Troubleshooting Fault Code 1691.

Last Modified: 21-Nov-2014


Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1694

Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1694 PID: SPN: 3226 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic only runs during INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the aftertreatment intake and outlet NOx sensor readings.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test found in the ECM Diagnostic Tests Section.

Shop Talk

Possible causes of this fault code include:

  • The ECM has detected that the NOx reading is higher or lower than is possible from the engine output
  • Exhaust system leaks
  • NOx sensor part number is incorrect.
  • Possible engine misfire
Refer to Troubleshooting Fault Code 1694.

Last Modified: 21-Nov-2014


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Above Normal or Shorted to High Source. High voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various aftertreatment and OEM sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

High voltage on the 5-VDC supply wire can be caused by a short circuit to a power supply, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1695.

Last Modified: 11-Dec-2014


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source. Low voltage detected at sensor supply number 5 circuit in the OEM harness. | The engine will operate in Limp Home mode.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various aftertreatment and OEM sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1696.

Last Modified: 11-Dec-2014


Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 1712

Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1712 PID: SPN: 3363 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank heater is unable to thaw the frozen diesel exhaust fluid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature failed to thaw after the aftertreatment diesel exhaust fluid tank heater was commanded on for a calibratable time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1712.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1713

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1713 PID: SPN: 3363 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid tank heater is continuously in the ON position. | Engine torque output will be reduced.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is NOT being commanded.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the DEF tank temperature was greater than 58°C [136°F] indicating the aftertreatment diesel exhaust fluid tank heater was in the ON position when the ECM was commanding the heater to be in the OFF position.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Before troubleshooting this fault code, make sure the equipment is not equipped with an auxiliary heating device for the diesel exhaust fluid tank. Such a device can result in overheating the diesel exhaust fluid in the tank.

This fault code may be inactive when the vehicle is brought in for service. Even if inactive, follow the troubleshooting tree completely.

Reason: If there is a problem with the diesel exhaust fluid (DEF) tank heater control valve, the valve is stuck open, there is coolant leaking past the valve seat, or the valve is incorrectly installed, it can take long periods of operation at high load before the tank temperature gradually increases to the fault code threshold value of 58°C [136°F]. As soon as the temperature drops below 58°C [136°F] due to a stopped engine, overnight parking, reduced coolant temperature, and so forth, the fault code will go inactive while the root cause of the issue is still present.

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve installed incorrectly, reversed relative to coolant flow direction.
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve – stuck open or leakage past the valve seat.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1713.

Last Modified: 15-Oct-2015


Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

FAULT CODE 1715

Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1715 PID: SPN: 3364 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known | Engine power derate.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has reported an internal error.

Action Taken When the Fault Code is Active

The ECM will illuminate the amber CHECK ENGINE light immediately when the diagnostic runs and fails.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 1715.

Last Modified: 19-Feb-2016


Engine Misfire for Multiple Cylinders - Condition Exists

FAULT CODE 1718

Engine Misfire for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1718 PID: SPN: 1322 FMI: 11/31 LAMP: Amber SRT: | Engine Misfire for Multiple Cylinders - Condition Exists. Engine misfire has been detected in multiple cylinder numbers. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

An algorithm in the ECM calibration monitors engine speed as each injector fires. If a cylinder(s) has high or low contribution to engine speed, the fault will become active. The intention of the fault is to assist in troubleshooting performance complaints such as engine misfire and low power.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a misfire of two or more cylinders.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If Fault Code 1718 is inactive in the ECM memory and there is no complaint such as “low power” or “engine misfire”, it is possible that an intermittent event such as air entering the fuel system following a filter change caused the fault. Inactive counts of Fault Code 1718 should be disregarded unless other performance symptoms are present. The engine coolant temperature must be greater than 71°C [160°F] before this diagnostic will run.

Causes of cylinder misfire can include:

  • Valve lash out of specification (compare actual valve lash to reset limits)
  • Cylinder damaged (check for high blowby when the engine is loaded)
  • Valve damaged or valve held open (listen for intake valve “chirping” noise in the intake)
  • Injector malfunction (“swap” injectors to see if the problem “follows” the indicated injector).
Refer to Troubleshooting Fault Code 1718.

Last Modified: 21-Nov-2014


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located on the left bank valve at the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 1843.

Last Modified: 21-Nov-2014


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located on the left bank valve at the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 1844.

Last Modified: 21-Nov-2014


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level. The Water in Fuel Indicator indicates that the water level is above warning level. | None on performance.
Water-in-Fuel Indicator Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The water-in-fuel sensor is integrated into the bottom of the stage 1 fuel filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

The fuel filter must be drained immediately.

Refer to Troubleshooting Fault Code 1852.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1866

Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1866 PID: P411 SPN: 411 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure - Data Erratic, Intermittent, or Incorrect. An error in the EGR delta pressure signal was detected at initial key ON or the sensor failed the autozero test. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR cooler.

Conditions for Running the Diagnostics

This diagnostic runs at key OFF when the following conditions are met:

  • Engine coolant temperature is 68°C [154°F] or higher.
  • Intake manifold air temperature is 7°C [44°F] or higher.
  • Keyswitch transitions from ON to OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure sensor was reading higher or lower than a calibratable value when the keyswitch was turned OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This check is only performed at keyswitch OFF, during the ECM powerdown. During this diagnostic check, the ECM monitors the value of the EGR differential pressure sensor. If this value is outside of a specified range, Fault Code 1866 is set active.

Possible causes of this fault code include:

  • A damaged EGR differential pressure sensor.
  • High resistance in the wiring harness on the signal or return wire.
  • Plugged or restricted EGR differential pressure sensor flow ports.
Refer to Troubleshooting Fault Code 1866.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1867

Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1867 PID: P412 SPN: 412 FMI: 2/2 LAMP: Amber SRT: | Engine Gas Recircuilation Temperature - Data Erratic, Intermittent, or Incorrect. Engine misfire has been detected in multiple cylinder numbers. | Possible reduced engine performance.
EGR Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the EGR connection tube between the EGR cooler and the air intake connection.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned to the ON position after a 8 hour cold soak, during which the keyswitch has been turned OFF. The second part runs continuously while the engine is running and EGR flow is above a calibratible value.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature reading was too high or tool low for the operating conditions, or the EGR temperature reading was not changing with the operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range EGR temperature sensor
  • High resistance in the EGR temperature sensor signal or return wires.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Refer to Troubleshooting Fault Code 1867.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1879

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1879 PID: S324 SPN: 3251 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment differential pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the aftertreatment diesel particulate filter differential pressure is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1879.

Last Modified: 11-Dec-2014


Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1881

Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1881 PID: S324 SPN: 3251 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage or open circuit detected at the aftertreatment differential pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value of the aftertreatment diesel particulate filter differential pressure is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1881.

Last Modified: 11-Dec-2014


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1883

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1883 PID: S324 SPN: 3251 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value at initial key ON or during engine operation. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs when the keyswitch is initially turned ON before the engine is started
  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter differential pressure was greater than 1.5 kpa [0.44 in HG] at initial key ON, or is not changing with engine conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value of the aftertreatment diesel particulate filter differential pressure is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 1883.

Last Modified: 04-Feb-2015


Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1885

Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1885 PID: P102 SPN: 3216 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment intake NOx sensor assembly.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor has malfunctioned or is damaged
  • The aftertreatment intake NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1885.

Last Modified: 21-Nov-2014


Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1887

Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1887 PID: P2202 SPN: 3226 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment outlet NOx sensor assembly.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment outlet NOx sensor has malfunctioned or is damaged
  • The aftertreatment outlet NOx sensor internal heater has malfunctioned
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1887.

Last Modified: 21-Nov-2014


EGR Valve Controller - Out of Calibration

FAULT CODE 1896

EGR Valve Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1896 PID: S146 SPN: 2791 FMI: 13/13 LAMP: Amber SRT: | EGR Valve Controller - Out of Calibration. The EGR valve has failed the automatic calibration procedure at initial key ON. | Possible reduced engine performance.
EGR Valve Circuit

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON and occasionally during normal engine operation after the EGR valve is commanded closed.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve failed the autozero span check.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the keyswitch is initially turned ON and at various times during engine operation, the closed position of the EGR valve is checked. This diagnostic checks to make sure the EGR valve is not stuck open.

The EGR valve will close when the fault code is active. The fault code will remain active until the next key cycle.

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter.

Refer to Troubleshooting Fault Code 1896.

Last Modified: 21-Nov-2014


VGT Actuator Controller - Bad Intelligent Device or Component

FAULT CODE 1897

VGT Actuator Controller - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1897 PID: S27 SPN: 641 FMI: 12/12 LAMP: Amber SRT: | VGT Actuator Controller - Bad Intelligent Device or Component. An internal error has been detected by the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) detected an internal error in the VGT smart device.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the VGT smart actuator detected an internal error within the VGT actuator. The VGT actuator will stop controlling the turbocharger when this fault code is active.

Fault Code 1897 will become active if the VGT actuator is removed from the turbocharger and then the keyswitch is turned to the ON position; or it may be possible for it to become active if the actuator fails the install/calibrate procedure. If this occurs, disconnect the VGT actuator from the engine harness with the keyswitch ON, and connect the VGT actuator to the engine harness. Fault Code 1897 should go inactive. Follow the VGT actuator installation procedure to install the VGT actuator.

Refer to Troubleshooting Fault Code 1897.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1921

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1921 PID: S324 SPN: 3251 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter was moderately severe. The aftertreatment system needs to be regenerated to remove the soot.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins® warranty.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • Possible engine damage that causes excessive black soot to be generated.
  • If Fault Code 2777 is active along with Fault Code 1921, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not permitted. Confirm that OEM settings for the aftertreatment permit switch are configured correctly. A stationary regeneration of the aftertreatment diesel particulate filter can be performed. Use INSITE™ electronic service tool.
Refer to Troubleshooting Fault Code 1921.

Last Modified: 11-Dec-2014


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 1922

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1922 PID: S324 SPN: 3251 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. Engine protection derate is enabled. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had exceeded the maximum operating limits.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.

Conditions for Clearing the Fault Code

After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.

  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.

Shop Talk

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The aftertreatment wiring harness or the aftertreatment temperature sensor connector pin installation may be incorrect.
  • The engine has been operating in a light load condition that prevents exhaust temperatures from being high enough to actively regenerate the aftertreatment diesel particulate filter.
  • A possible base engine malfunction that causes excessive black soot to be generated.
  • If both Fault Code 1921 and 2777 are inactive with an active Fault Code 1922, this indicates that a regeneration inhibit message has been received by the engine ECM and that active regeneration of the aftertreatment diesel particulate filter was not allowed. Use the OEM manuals to confirm that the OEM settings for the aftertreatment permit switch are configured correctly.
Refer to Troubleshooting Fault Code 1922.

Last Modified: 11-Dec-2014


ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 1938

ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1938 PID: S212 SPN: 3597 FMI: 1/18 LAMP: Amber SRT: | ECU Power Output Supply Voltage 1 - Data Valid But Below Normal Operational Range - Moderately Severe Level. Low battery voltage detected by the VGT actuator. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

Voltage supplied to the Variable Geometry Turbocharger (VGT) actuator dropped below 10-VDC for 10 seconds and the engine speed was at zero rpm or greater than 575 rpm.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the voltage to the VGT actuator drops below 10-VDC. The VGT will still continue to respond to commands from the primary engine ECM.

Refer to Troubleshooting Fault Code 1938.

Last Modified: 21-Nov-2014


Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1942

Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1942 PID: P101 SPN: 101 FMI: 2/2 LAMP: Amber SRT: | Crankcase Pressure - Data Erratic, Intermittent, or Incorrect. The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
Engine Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located on the left bank valve at the front of the engine.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part of this diagnostic runs at initial key ON and the second part runs when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure sensor was reading an erratic value at key ON or the crankcase pressure reading was not changing with engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a crankcase breather hose disconnected between the engine outlet and crankcase filter assembly on engines with an externally mounted crankcase filter option.

Possible causes of this fault code include:

  • Resistance in the wiring harness
  • A malfunctioning in-range pressure sensor
  • Crankcase pressure sensor is not installed correctly in the housing.
Refer to Troubleshooting Fault Code 1942.

Last Modified: 21-Nov-2014


Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1974

Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1974 PID: P101 SPN: 101 FMI: 0/15 LAMP: Maintenance SRT: | Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. High crankcase pressure detected. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located on the left bank valve at the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure reading was higher than a threshold for 60 cumulative minutes at idle.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool “Data Monitor/Logger” feature to monitor "Crankcase Pressure" with the engine running at idle. If the crankcase pressure reading is below 7.0 in H20, the repair has been validated.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

If this fault code is active, the crankcase breather element may need to be replaced.

Refer to Troubleshooting Fault Code 1974.

Last Modified: 26-Jan-2015


VGT Actuator Driver Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1976

VGT Actuator Driver Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1976 PID: S27 SPN: 641 FMI: 0/15 LAMP: None SRT: | VGT Actuator Driver Over Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level. High internal VGT actuator temperature has been detected. | None on performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The internal temperature of the Variable Geometry Turbocharger (VGT) actuator exceeded 125°C [257°F] continuously for 30 minutes.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code will be inactive when the vehicle is in the shop because the VGT actuator temperature has cooled down. Troubleshoot multiple inactive counts of this fault code as an active fault code.

Also check for exhaust leaks blowing on the VGT actuator. Repair any external leaks.

Refer to Troubleshooting Fault Code 1976.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Missing - Condition Exists

FAULT CODE 1993

Aftertreatment Diesel Particulate Filter Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1993 PID: SPN: 4795 FMI: Not Mapped/31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Missing - Condition Exists. The aftertreatment diesel particulate filter in the exhaust system is not present. | Possible reduced engine performance.
Electronic Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter differential pressure was below a calibratiable value and the exhaust flow rate was above a calibratiable value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment diesel particulate filter has been removed from the vehicle
  • The aftertreatment diesel particulate filter is cracked or broken
  • The aftertreatment diesel particulate filter differential tubes are installed incorrectly, broken, loose, or have been tampered with
  • The aftertreatment diesel particulate filter differential tubes are installed backwards.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 1993.

Last Modified: 21-Nov-2014


Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2185

Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2185 PID: S232 SPN: 3512 FMI: 3/3 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a short circuit to a voltage source in the OEM harness or a short circuit to an actuator signal circuit that is greater than 5-VDC.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2185.

Last Modified: 11-Dec-2014


Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2186

Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2186 PID: S232 SPN: 3512 FMI: 4/4 LAMP: Amber SRT: | Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at the 5 VDC sensor supply circuit to the accelerator pedal position sensor. | Engine will only idle.
Sensor Supply 4 Circuit

Circuit Description

Sensor supply 4 of the engine control module (ECM) provides a 5 VDC supply to the accelerator pedal position sensor.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 4 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine will only idle.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Low voltage on the 5 VDC supply wire can be caused by a short circuit to ground in the supply wire, a short circuit between the supply wire and return circuit, a malfunctioning accelerator, or a malfunctioning ECM power supply.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2186.

Last Modified: 11-Dec-2014


VGT Actuator Driver Circuit - Root Cause Not Known

FAULT CODE 2198

VGT Actuator Driver Circuit - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2198 PID: S27 SPN: 641 FMI: 11/11 LAMP: Amber SRT: | VGT Actuator Driver Circuit - Root Cause Not Known. Intermittent communication between the smart VGT controller and the ECM has been detected. The VGT controller is not interpreting the J1939 message from the ECM correctly. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator did not receive a valid J1939 data link message from the Engine Control Module (ECM) for 4 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Intermittent J1939 data link connections or interference on the J1939 network are possible causes of this fault code. Also check for intermittent power supply and ground connections to the VGT actuator.

Refer to Troubleshooting Fault Code 2198.

Last Modified: 21-Nov-2014


Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

FAULT CODE 2217

Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2217 PID: S253 SPN: 630 FMI: 11/31 LAMP: Amber SRT: | Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Module (ECM) is mounted on the intake manifold side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Verify the engine control module (ECM) calibration is correct. Check the calibration revision history found on QuickServe® Online for applicable fixes to the calibration stored in the ECM. If necessary, recalibrate the ECM.

Possible causes of this fault code include:

  • Corrupted engine calibration
  • Incorrect ECM software
Refer to Troubleshooting Fault Code 2217.

Last Modified: 04-Dec-2014


Fault Code Path Selection

FAULT CODE 245-fc2222
Fault Code Path Selection

Is the fuel level sensor a 2-wire sensor? | Go to 245-fc2222-2wire
Is the fuel level sensor a 3-wire sensor? | Go to 245-fc2222-3wire

Last Modified: 26-Jan-2015


Fault Code Path Selection

FAULT CODE 245-fc2223
Fault Code Path Selection

Is the fuel level sensor a 2-wire sensor? | Go to 245-fc2223-2wire
Is the fuel level sensor a 3-wire sensor? | Go to 245-fc2223-3wire

Last Modified: 26-Jan-2015


Fuel Level (Main Tank) - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2224

Fuel Level (Main Tank) - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2224 PID: P96 SPN: 96 FMI: 2/2 LAMP: Amber SRT: | Fuel Level (Main Tank) - Data Erratic, Intermittent, or Incorrect. Fuel tank level reading detected irrational. | None on performance.
Fuel Level Sensor Circuit

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Vehicle has traveled over 500 miles with the Fuel level is less than 15%

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel level sensor
Refer to Troubleshooting Fault Code 2224.

Last Modified: 11-Dec-2014


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2265

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2265 PID: S126 SPN: 1075 FMI: 3/3 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source. High voltage detected at the fuel lift pump relay control signal circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump relay is controlled by the ECM, and provides power to the fuel lift pump.

Component Location

Location of the Lift pump/Stage 1 filter is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs during the first 1 minute after initial key ON, when the fuel lift pump is being commanded to run.

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump relay signal circuit voltage was greater than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The engine fuel lift pump will be disabled.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to a voltage source in the OEM harness or relay.
  • A malfunctioning fuel lift pump
  • A malfunctioning fuel lift pump relay.
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 2265.

Last Modified: 21-Nov-2014


Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2266

Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2266 PID: S126 SPN: 1075 FMI: 4/4 LAMP: Amber SRT: | Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel lift pump relay circuit. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Fuel Lift Pump Circuit

Circuit Description

The fuel lift pump relay is controlled by the ECM, and provides power to the fuel lift pump.

Component Location

Location of the Lift pump/Stage 1 filter is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and the lift pump timer has expired 1 minute after initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel lift pump relay signal circuit voltage was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, key OFF for 1 minute, then key ON for 1 minute.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground.
  • A malfunctioning fuel lift pump
  • A malfunctioning fuel lift pump relay.
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 2266.

Last Modified: 21-Nov-2014


EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2271

EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2271 PID: P27 SPN: 27 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR valve position sensor circuit. | EGR valve actuation will be disabled.
EGR Valve Position Circuit

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • An open return circuit in the engine harness, connectors, or sensor
  • A short circuit to voltage source in the wiring harness
  • A malfunctioning EGR valve
  • A malfunctioning ECM.
Refer to Troubleshooting Fault Code 2271.

Last Modified: 21-Nov-2014


EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2272

EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2272 PID: P27 SPN: 27 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the EGR valve position sensor circuit. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR valve position sensor signal voltage was less than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 2272.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2273

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2273 PID: P411 SPN: 411 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was greater than 4.8-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the EGR differential pressure sensor is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor
  • A signal wire shorted to sensor supply or battery voltage
  • A damaged EGR differential pressure sensor.
Refer to Troubleshooting Fault Code 2273.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2274

Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2274 PID: P411 SPN: 411 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Valve Delta Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the EGR differential pressure sensor circuit. | Possible reduced engine performance.
EGR Differential Pressure Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR differential pressure signal voltage was less than 0.26-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the EGR differential pressure sensor is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground
  • A malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code 2274.

Last Modified: 21-Nov-2014


Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2288

Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2288 PID: P103 SPN: 103 FMI: 0/15 LAMP: None SRT: | Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level. High turbocharger speed has been detected by the ECM. | Possible reduced engine performance.
Turbocharger Speed Sensor Circuit

Circuit Description

The turbocharger speed sensor is a variable reluctance speed sensor. It consists of a coil of wire and an iron core. The target on the turbocharger shaft is a ground flat in the center of the shaft. As the flat on the turbocharger shaft spins past the speed sensor, a signal is generated. The Engine Control Module (ECM) interprets this signal and converts it to a turbocharger speed reading.

Component Location

The turbocharger speed sensor is mounted in the center housing of the turbocharger.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the turbocharger speed was above the maximum calibratible limits.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The ECM will reduce the torque output of the engine to reduce turbocharger speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine has taken the necessary action to reduce the turbocharger speed, this fault code is logged. This fault code is for information only and no repairs are necessary. The engine can possibly be derated when operating near the maximum turbocharger speed limits.

Refer to Troubleshooting Fault Code 2288.

Last Modified: 21-Nov-2014


Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2347

Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2347 PID: P404 SPN: 2629 FMI: 0/15 LAMP: None SRT: | Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level. High turbocharger compressor outlet air temperature has been calculated by the engine control module (ECM). | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas temperature is calculated by the engine control module (ECM). The exhaust gas temperature is derived by the ECM, based on engine operating conditions such as intake manifold air temperature, engine speed, injection timing, intake manifold pressure, and fuel flow.

Component Location

There is not a physical turbocharger compressor outlet temperature sensor in the system. The turbocharger compressor outlet air temperature is a calculation of temperature of the air after it is compressed by the turbocharger compressor, but before exhaust gas recirculation (EGR) is mixed into the system, and before it enters the charge-air cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the turbocharger compressor outlet temperature was greater than 230°C [446°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Fuel is limited in an attempt to decrease the calculated compressor outlet temperature.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible caused of this fault code include:

  • Air intake leaks allowing hot under-hood air to enter the intake system
  • Faulty Charge Air Cooler pressure readings
  • High turbocharger speed readings
  • Faulty Turbocharger Compressor Intake pressure readings
  • A malfunctioning turbocharger
Refer to Troubleshooting Fault Code 2347.

Last Modified: 13-Jan-2016


EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2351

EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2351 PID: S146 SPN: 2791 FMI: 4/4 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage has been detected at the EGR valve position sensor circuit. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the EGR motor supply circuits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible cause of this fault code:

  • A short circuit to ground in the harness
  • A malfunctioning EGR valve
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 2351.

Last Modified: 20-Nov-2014


EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2352

EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2352 PID: S146 SPN: 2791 FMI: 3/3 LAMP: Amber SRT: | EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the EGR valve position sensor circuit. | Possible reduced engine performance.
EGR Valve Position Circuit

Circuit Description

The EGR valve device driver in the ECM provides power to the EGR valve motor. The EGR valve motor is used to move the EGR valve to the correct position, as commanded by the ECM.

The engine control module (ECM) uses the EGR valve position sensor to determine whether or not the valve is meeting the commanded position. The ECM supplies 5 volts to the EGR valve position signal circuit, and the EGR valve position sensor outputs a voltage signal to the ECM, based on the valve position. The ECM converts this signal into a percentage value, 0 to 100, indicating valve position. A fully-opened valve is equivalent to 100 percent.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open circuit in the engine wiring harness or EGR valve motor coil.

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible cause of this fault code:

  • A short circuit to voltage source in the engine harness
  • A malfunctioning EGR valve
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 2352.

Last Modified: 04-Dec-2014


Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2373

Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2373 PID: P131 SPN: 1209 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located on the left bank of the intake manifold of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was greater than 4.75-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the exhaust gas pressure sensor reading.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the engine harness, connectors, or sensor.
  • A signal wire shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 2373.

Last Modified: 21-Nov-2014


Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2374

Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2374 PID: P131 SPN: 1209 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the exhaust gas pressure circuit. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas pressure signal voltage was less than 0.25-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the exhaust gas pressure sensor reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The exhaust gas pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal circuit open or shorted to ground in the engine harness or sensor
  • A supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 2374.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2375

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2375 PID: P412 SPN: 412 FMI: 3/3 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the intake connection towards on the front of the engine

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was greater than 4.9-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the exhaust gas recirculation temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • An open return circuit in the harness, connectors, or sensor
  • An open signal circuit or shorted to a voltage source.
Refer to Troubleshooting Fault Code 2375.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2376

Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2376 PID: P412 SPN: 412 FMI: 4/4 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at EGR temperature circuit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the intake connection towards on the front of the engine

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature signal voltage was less than 0.05-VDC for more than 8 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the exhaust gas recirculation temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The EGR temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • A signal shorted to ground in the harness
  • A signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 2376.

Last Modified: 21-Nov-2014


VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 2387

VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2387 PID: S27 SPN: 641 FMI: 7/7 LAMP: Amber SRT: | VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment. The smart VGT controller has detected incorrect stop limits, or the VGT is unable to move to the closed position. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator position could not meet the commanded position for greater than 10 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The VGT actuator will continue to attempt to meet commanded position, even when the CHECK ENGINE lamp is on.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • A malfunctioning turbocharger actuator

The aftertreatment system must be inspected for potential damage after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system can possibly have occurred.

Refer to Troubleshooting Fault Code 2387.

Last Modified: 21-Nov-2014


Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2398

Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2398 PID: P171 SPN: 171 FMI: 2/2 LAMP: Amber SRT: | Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect. The ambient air temperature sensor is reading an erratic value. | Possible reduced engine performance.
Ambient Air Temperature Sensor Circuit

Circuit Description

The ambient air temperature sensor is a variable resistor sensor and is used to measure the temperature of the ambient air. The engine control module (ECM) uses this temperature reading to optimize engine performance, and determine if heating of the SCR system is required. The engine control module (ECM) supplies 5 volts to the ambient air temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the ambient air temperature.

Component Location

The mounting location for the ambient air temperature sensor is OEM dependent. Refer to the appropriate OEM service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run.

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ambient air temperature reading was higher or lower than the other temperature sensors on the engine after an extended period of engine off time, or the ambient air temperature was reading was too high or too low for the engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the ambient air temperature reading is used.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range ambient air temperature sensor
  • High resistance in the ambient air temperature sensor signal or return lines
  • ECM malfunction.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2398.

Last Modified: 21-Nov-2014


Engine Control Module Calibration Memory Checksum - Out of Calibration

FAULT CODE 2416

Engine Control Module Calibration Memory Checksum - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2416 PID: S253 SPN: 1634 FMI: 13/13 LAMP: Amber SRT: | Engine Control Module Calibration Memory Checksum - Out of Calibration. The ECM has detected a calibration mismatch error. | None on performance.
Engine Control Module

Circuit Description

The Engine Control Module (ECM) calculates a calibration memory checksum based on the values of certain parameters in the ECM. This checksum is compared to an expected value in the ECM to detect tampering.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the calibration memory checksum did not match the expected value or it did not complete before ECM shutdown.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

In order for this fault code to go inactive, a calibration download is necessary.

  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Malfunctioning ECM software

  • Tampering of the ECM
Refer to Troubleshooting Fault Code 2416.

Last Modified: 21-Nov-2014


Engine Injector Group 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 2423

Engine Injector Group 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2423 PID: SPN: 2797 FMI: 6/6 LAMP: Amber SRT: | Engine Injector Group 1 Circuit - Current Above Normal or Grounded Circuit. The ECM detected the injector bank 1 high side driver is shorted to ground or battery. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 2423.

Last Modified: 11-Dec-2014


Engine Injector Group 2 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 2424

Engine Injector Group 2 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2424 PID: SPN: 2798 FMI: 6/6 LAMP: Amber SRT: | Engine Injector Group 2 Circuit - Current Above Normal or Grounded Circuit. The ECM detected the injector bank 2 high side driver is shorted to ground or battery. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 2424.

Last Modified: 11-Dec-2014


Injector Solenoid Driver Cylinder 1 - Out of Calibration

FAULT CODE 2442

Injector Solenoid Driver Cylinder 1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2442 PID: S1 SPN: 651 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 1 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2442.

Last Modified: 20-Nov-2014


Injector Solenoid Driver Cylinder 2 - Out of Calibration

FAULT CODE 2443

Injector Solenoid Driver Cylinder 2 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2443 PID: S2 SPN: 652 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 2 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2443.

Last Modified: 20-Nov-2014


Injector Solenoid Driver Cylinder 3 - Out of Calibration

FAULT CODE 2444

Injector Solenoid Driver Cylinder 3 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2444 PID: S3 SPN: 653 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 3 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2444.

Last Modified: 21-Nov-2014


Injector Solenoid Driver Cylinder 4 - Out of Calibration

FAULT CODE 2445

Injector Solenoid Driver Cylinder 4 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2445 PID: S4 SPN: 654 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 4 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2445.

Last Modified: 21-Nov-2014


Injector Solenoid Driver Cylinder 5 - Out of Calibration

FAULT CODE 2446

Injector Solenoid Driver Cylinder 5 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2446 PID: S5 SPN: 655 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 5 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2446.

Last Modified: 21-Nov-2014


Injector Solenoid Driver Cylinder 6 - Out of Calibration

FAULT CODE 2447

Injector Solenoid Driver Cylinder 6 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2447 PID: S6 SPN: 656 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 6 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 2447.

Last Modified: 21-Nov-2014


Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

FAULT CODE 2448

Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2448 PID: P111 SPN: 111 FMI: 1/17 LAMP: Maintenance SRT: | Coolant Level - Data Valid But Below Normal Operational Range - Least Severe Level. Low engine coolant level detected. | None on performance.
Engine Coolant Level Sensor

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level sensor signal voltage is between 1.75 VDC and 3 VDC for more than 30 seconds, indicating low coolant level.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2448.

Last Modified: 21-Nov-2014


VGT Actuator Controller - Out of Calibration

FAULT CODE 2449

VGT Actuator Controller - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2449 PID: S27 SPN: 641 FMI: 13/13 LAMP: Red SRT: | VGT Actuator Controller - Out of Calibration. The VGT actuator has been installed incorrectly. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is initially turned to the ON position.

The keyswitch must be turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.

Conditions for Setting the Fault Codes

The Variable Geometry Turbocharger (VGT) actuator position was not known during initial power ON.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the keyswitch in the ON position for 1 minute. Note that the keyswitch must be completely turned OFF for more than 30 seconds before this diagnostic will run at initial key ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can only be logged after the VGT actuator has been removed or replaced, and then not installed correctly. The gear alignment between the actuator and the turbocharger housing is misaligned. The correct installation procedure must be followed when replacing the VGT actuator.

Refer to Troubleshooting Fault Code 2449.

Last Modified: 21-Nov-2014


Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2554

Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2554 PID: P131 SPN: 1209 FMI: 2/2 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Erratic, Intermittent or Incorrect. The exhaust gas pressure sensor is reading an erratic value. | Possible reduced engine performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The exhaust gas pressure sensor is located on the left bank of the intake manifold of the engine.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

One part runs immediately after the keyswitch is turned OFF, and the engine coolant temperature is above 70°C or 158°F.

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

  • The Engine Control Module (ECM) detected the exhaust pressure reading was higher or lower than the other absolute pressure sensors when the keyswitch is OFF and the engine is not running.
  • The Engine Control Module (ECM) detected the exhaust pressure was higher or lower than expected during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value is used for the exhaust gas pressure sensor reading.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, first ensure the engine coolant temperature is above 70°C or 158°F. Operate the engine if necessary.
  • Cycle the keyswitch to the ON position for 30 seconds, then cycle the keyswitch to the OFF position for 30 seconds. Start the engine and run it at high idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range exhaust gas pressure sensor reading
  • High resistance in the exhaust gas pressure sensor signal or return lines
  • Plugging or restriction in the exhaust gas pressure sensor tube
  • Leaks in the exhaust system
Refer to Troubleshooting Fault Code 2554.

Last Modified: 21-Nov-2014


Engine Charge Air Cooler Outlet Temperature - Voltage Above Normal or Shorted to High Source

FAULT CODE 2571

Engine Charge Air Cooler Outlet Temperature - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2571 PID: SPN: 2630 FMI: 3/3 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Temperature - Voltage above normal, or shorted to high source | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The ECM supplies 5 volts to the Charge Air Cooler outlet temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the Charge Air Cooler outlet temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine charge air cooler outlet temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 2571.

Last Modified: 21-Nov-2014


Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2572

Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2572 PID: SPN: 2630 FMI: 4/4 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source. | Fan will stay ON if controlled by the engine control module (ECM).
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The ECM supplies 5 volts to the Charge Air Cooler outlet temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the Charge Air Cooler outlet temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine charge air cooler outlet temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the harness
  • Signal circuit shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 2572.

Last Modified: 21-Nov-2014


VGT Actuator Driver Circuit - Condition Exists

FAULT CODE 2635

VGT Actuator Driver Circuit - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2635 PID: S27 SPN: 641 FMI: 11/31 LAMP: Red SRT: | VGT Actuator Driver Circuit - Condition Exists. A calibration mismatch between the VGT actuator and the ECM has been detected. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code can be activated for the following reasons:

  • The Engine Control Module (ECM) detected a calibration incompatibility between the VGT actuator and the ECM calibration.
  • The Variable Geometry Turbocharger (VGT) detected the system voltage was incorrect for the VGT actuator part number.
  • The Engine Control Module (ECM) detected an incorrect VGT actuator installed on the turbocharger.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected that an incorrect VGT actuator has been installed on the turbocharger.

Refer to Troubleshooting Fault Code 2635.

Last Modified: 26-Jan-2015


VGT Actuator Driver Circuit - Abnormal Update Rate

FAULT CODE 2636

VGT Actuator Driver Circuit - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2636 PID: S27 SPN: 641 FMI: 9/9 LAMP: Red SRT: | VGT Actuator Driver Circuit - Abnormal Update Rate. No communications on the J1939 data link between the engine ECM and the smart VGT controller. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a valid J1939 data link message from the Variable Geometry Turbocharger (VGT) actuator for more than 1 second.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • VGT actuation will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The VGT actuator is not receiving power from the ECM. This can be caused by an open circuit in the power supply wire or low voltage supplied by the primary engine ECM.
  • Rapid cycling of the keyswitch
  • An open return circuit on the VGT actuator circuit
  • An open or short circuit on the J1939 data link circuit between the ECM and VGT actuator
  • Intermittent communications between the VGT actuator and the primary engine ECM on the J1939 data link
  • A damaged termination resistor in the engine data link harness
Refer to Troubleshooting Fault Code 2636.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2638

Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2638 PID: S380 SPN: 5298 FMI: 1/17 LAMP: None SRT: | Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level. The temperature increase across the aftertreatment diesel oxidation catalyst is lower than expected. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst is located in the exhaust system. The location of the catalyst can vary, depending on the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the DOC efficiency was less than required to successfully complete a regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning diesel oxidation catalyst
  • A malfunctioning aftertreatment fuel injector
Refer to Troubleshooting Fault Code 2638.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2639

Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2639 PID: S324 SPN: 3251 FMI: 0/15 LAMP: None SRT: | Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level. The soot load of the aftertreatment diesel particulate filter has exceeded the recommended limits. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the soot load of the aftertreatment diesel particulate filter had reached the first stage of plugging.

Action Taken When the Fault Code is Active

  • The ECM will illuminate the aftertreatment diesel particulate filter lamp immediately after the diagnostic is set.
  • The ECM will flash the aftertreatment dash lamp as the severity of the soot load increases.
  • Torque output of the engine will be reduced as the soot load in the aftertreatment diesel particulate filter increases.

Conditions for Clearing the Fault Code

After completing a stationary regeneration (as instructed in this fault code troubleshooting tree) and no additional faults become active, the repair has been validated.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the aftertreatment diesel particulate filter lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Note: This fault code indicates that the aftertreatment diesel particulate filter requires maintenance by performing a stationary regeneration procedure. This is a maintenance procedure only and is not covered by Cummins Inc. warranty.

Note: Repeated occurrences of this fault code may indicate the engine requires frequent regeneration. Refer to symptom tree t147 (Aftertreatment Diesel Particulate Filter-Excessive Automatic and/or Stationary Regeneration) to identify the cause of frequent regeneration.

Possible causes of this fault code include:

  • The engine has been operating in light load operating conditions that prevent exhaust temperatures from being high enough to regenerate the aftertreatment diesel particulate filter
  • Possible engine damage that causes excessive black smoke to be generated.
Refer to Troubleshooting Fault Code 2639.

Last Modified: 21-Nov-2014


Engine Coolant Temperature - Condition Exists

FAULT CODE 2646

Engine Coolant Temperature - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2646 PID: P110 SPN: 110 FMI: 14/31 LAMP: Amber SRT: | Engine Coolant Temperature - Condition Exists. The EGR valve was closed to reduce engine coolant temperature. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was above a threshold and closed the EGR valve to reduce the engine coolant temperature.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When the engine coolant temperature nears the engine protection limits, the EGR valve will be closed to reduce the coolant temperature. This fault code is used as an information fault code, only indicating that the EGR valve has closed. No malfunction has occurred to cause this fault code. Other engine protection fault codes will be active if the engine coolant temperature has exceeded the engine protection limits.

Refer to Troubleshooting Fault Code 2646.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect

FAULT CODE 2692

Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2692 PID: SPN: 3936 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect. The aftertreatment particulate matter sensor has detected a problem with the diesel particulate filter system. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor detected soot emissions higher than a calibrated value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • The aftertreatment diesel particulate filter is cracked or broken
  • An engine malfunction resulting in high engine out smoke
  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 2692.

Last Modified: 19-Feb-2016


Engine Speed Calculation - Bad Intelligent Device or Component

FAULT CODE 2698

Engine Speed Calculation - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2698 PID: SPN: 520319 FMI: 12/12 LAMP: Amber SRT: | Engine Speed Calculation - Bad Intelligent Device or Component. Internal ECM redundant speed calculation does not match primary calculation. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Crankshaft Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The crankshaft position sensor is located at the front of the engine and is bolted to the front cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

Absolute value of difference between Engine RPM and an independently calculated engine speed is greater than 500 RPM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault code include:

  • Crankshaft position sensor malfunction
  • Malfunctioning ECM
Refer to Troubleshooting Fault Code 2698.

Last Modified: 15-Dec-2014


Fuel System Shutdown Failure - Condition Exists

FAULT CODE 2715

Fuel System Shutdown Failure - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2715 PID: SPN: 520323 FMI: 11/31 LAMP: Amber SRT: | Fuel System Shutdown Failure - Condition Exists. Internal ECM injector driver diagnostic failed. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned OFF.

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

Internal ECM injector driver diagnostic failed to catch intrusive injector on time diagnostic.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector

Malfunctioning ECM.

Refer to Troubleshooting Fault Code 2715.

Last Modified: 15-Dec-2014


Governor Fueling Error - Condition Exists

FAULT CODE 2717

Governor Fueling Error - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2717 PID: SPN: 520324 FMI: 11/31 LAMP: Amber SRT: | Governor Fueling Error - Condition Exists. ECM detected inconsistent fueling for conditions. | Possible reduced engine performance.
Engine Control Module

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Fueling commands were not consistent with engine running conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injectors
  • A malfunctioning brake pedal position switch
  • Crankshaft position sensor malfunction
  • Malfunctioning ECM
Refer to Troubleshooting Fault Code 2717.

Last Modified: 15-Dec-2014


Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists

FAULT CODE 2718

Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2718 PID: SPN: 6304 FMI: 11/31 LAMP: None SRT: | Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists. The ECM has detected the brake pedal and accelerator pedal were depressed simultaneously. | The engine will operate in Limp Home mode.
Engine Control Module (ECM)

Circuit Description

The accelerator pedal contains two position sensors. These position sensors are used to measure the throttle position. Both position sensors receive a 5 volt supply from the ECM. A corresponding signal voltage based on the position of the accelerator pedal is then received from the ECM. The signal voltage for accelerator position 1 is twice as much as the signal voltage from the accelerator position 2.

The accelerator position sensor is a Hall effect sensor attached to the accelerator pedal. The accelerator position sensor varies the signal voltage to the engine control module (ECM) as the accelerator pedal is depressed and released. Low signal voltage is received by the ECM when the accelerator pedal is at 0 percent. A high signal voltage is received by the ECM when the accelerator pedal is at 100 percent. The accelerator pedal position circuit contains an accelerator pedal position 5 volt supply, accelerator pedal position return, and accelerator pedal position signal.

Component Location

The accelerator pedal or lever position sensor is mounted to the accelerator pedal assembly. Refer to the OEM service manual.

The brake pedal position switch is mounted to the brake pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

  • This diagnostic runs continuously when the vehicle is in motion, if the feature is enabled.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the accelerator pedal and brake pedal were depressed simultaneously.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The engine will have limp-home throttle control only.

Conditions for Clearing the Fault Code

To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to detect conditions where both the accelerator pedal and brake pedal were depressed at the same time. When this condition occurs, the accelerator pedal position is defaults to idle. If the fault occurs when both pedals are NOT depressed, this may indicate that either the accelerator pedal position or brake pedal position are NOT returning to 0 percent.

Refer to Troubleshooting Fault Code 2718.

Last Modified: 21-Nov-2014


Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

FAULT CODE 2771

Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2771 PID: SPN: 3226 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment outlet NOx sensor. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment outlet NOx sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The Aftertreatment Outlet NOx Sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, blown NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment outlet NOx sensor battery return.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment outlet NOx sensor.
  • Intermittent communications between the aftertreatment outlet NOx sensor and the ECM on the J1939 data link.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 2771.

Last Modified: 26-Nov-2014


Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

FAULT CODE 2777

Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2777 PID: S390 SPN: 3703 FMI: 11/31 LAMP: Maintenance SRT: | Particulate Trap Active Regeneration Inhibited Due to Inhibit Switch - Condition Exists. Regeneration of the diesel particulate filter has been prevented due to the permit switch being disabled. | Possible frequent need for aftertreatment regeneration.
Aftertreatment Regeneration Inhibit Switch Circuit

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter regeneration permit switch was disabling regeneration while the ECM was requesting active regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

  • The ECM illuminates the white MAINTENANCE lamp or flashes the amber CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault code is active and there has been damage to the aftertreatment system, the permit switch can possibly have prevented the aftertreatment system from performing a mobile (active) regeneration.

Consult with the OEM if the aftertreatment system has malfunctioned due to the permit switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 2777.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2961

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2961 PID: P412 SPN: 412 FMI: 0/15 LAMP: None SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the intake connection towards on the front of the engine

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than 210°C [410°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Plugged or restricted EGR differential pressure sensor ports
  • Damaged EGR differential pressure tubes
  • A malfunctioning EGR valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger
  • A fouled EGR cooler.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2961.

Last Modified: 21-Nov-2014


Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

FAULT CODE 2962

Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2962 PID: P412 SPN: 412 FMI: 0/16 LAMP: Amber SRT: | Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operational Range - Moderately Severe Level. EGR temperature has exceeded the engine protection limit. | Possible reduced engine performance.
Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the intake connection towards on the front of the engine

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than 250°C [482°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A fouled EGR cooler
  • Plugged or restricted EGR differential pressure sensor ports
  • A damaged EGR valve
  • A low reading from the EGR differential pressure sensor
  • A low reading for the EGR valve position sensor
  • High exhaust temperatures
  • Low coolant level
  • High coolant temperature
  • An incorrect coolant/water mixture
  • A stuck closed variable geometry turbocharger.

Note: This fault code will most likely not be active with no load in the shop. The engine must be loaded to trigger this fault code.

Refer to Troubleshooting Fault Code 2962.

Last Modified: 21-Nov-2014


Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2963

Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2963 PID: P110 SPN: 110 FMI: 0/15 LAMP: None SRT: | Engine Coolant Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. Engine coolant temperature is above the engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 107°C [225°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limits for high coolant temperature. Refer to Engine Coolant Temperature Above Normal symptom troubleshooting tree in the base engine service manual.

Refer to Troubleshooting Fault Code 2963.

Last Modified: 21-Nov-2014


Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

FAULT CODE 2964

Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2964 PID: P105 SPN: 105 FMI: 0/15 LAMP: None SRT: | Intake Manifold 1 Temperature - Data Valid But Above Normal Operational Range - Least Severe Level. Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Intake Manifold Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Intake manifold air temperature sensor is located on the intake connection where it joins to the intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 120°C [248°F].

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The intake manifold 1 temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Plugged charge-air cooler fins
  • Restricted airflow through the charge-air cooler
  • An undersized charge-air cooler
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 2964.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3133

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3133 PID: SPN: 3610 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Above Normal, or Shorted to High Source. High signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure signal voltage was out range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3133.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3134

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3134 PID: SPN: 3610 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter outlet pressure sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Signal circuit open or shorted to ground in the engine harness or sensor
  • Supply wire open or shorted to ground.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3134.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3135

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3135 PID: SPN: 3610 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent or Incorrect. The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value at initial key ON or during engine operation. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • One part runs when the keyswitch is initially turned ON before the engine is started
  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet pressure was greater than 1.5 kpa [0.22 psi] or less than -1.5 kpa [0.22 psi] at initial key ON, or was not changing with engine conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires
  • Higher than expected diesel particulate filter outlet pressure
  • Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube
  • Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

Note: It is possible to set this fault in a shop environment by performing a key cycle with the tailpipe connected to an exhaust ventilation system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3135.

Last Modified: 21-Nov-2014


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3146

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3146 PID: SPN: 4363 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Catalyst Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3146.

Last Modified: 21-Nov-2014


Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3147

Aftertreatment 1 SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3147 PID: SPN: 4363 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the SCR outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3147.

Last Modified: 21-Nov-2014


Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3148

Aftertreatment 1 SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3148 PID: SPN: 4363 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment SCR Outlet Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The selective catalytic reduction (SCR) outlet temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the exhaust gas temperature sensors are compared to other engine temperatures during engine operation. The engine coolant temperature must be above 60°C [140°F] before the diagnostic will run.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR outlet temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the SCR catalyst outlet temperature is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning aftertreatment SCR outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3148.

Last Modified: 21-Nov-2014


Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

FAULT CODE 3151

Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3151 PID: SPN: 4794 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment SCR Catalyst System Missing - Condition Exists. The aftertreatment SCR catalyst in the exhaust system is not present. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion efficiency of the SCR catalyst was critically low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Tampering with SCR catalyst system, removal of SCR catalyst from vehicle, or malfunctioning SCR catalyst
  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

  • For unit that has come back into with repeat failures consider the possibility that customer is not using Ultra-low sulfur Diesel fuel
Refer to Troubleshooting Fault Code 3151.

Last Modified: 04-Dec-2015


Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3165

Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3165 PID: SPN: 4363 FMI: 0/0 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The selective catalytic reduction (SCR) outlet temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 800°C [1472°F] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhuast fluid
  • Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3165.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3168

Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3168 PID: SPN: 3936 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level. The system has detected a malfunction in the filtering capability of the aftertreatment diesel particulate filter. | None on performance.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit

Circuit Description

The ECM calculates an aftertreatment diesel particulate filter flow resistance, using the aftertreatment diesel particulate filter differential pressure and calculated exhaust flow rate.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) calculated the aftertreatment diesel particulate filter flow resistance was too low after successful regeneration of the aftertreatment diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

  • A damaged aftertreatment diesel particulate filter differential pressure sensor
  • Missing or malfunctioning aftertreatment diesel particulate filter differential pressure sensor tubes
  • Malfunction aftertreatment diesel particulate filter.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3168.

Last Modified: 21-Nov-2014


Glow Plug Control Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 3177

Glow Plug Control Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3177 PID: SPN: 7576 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Control Module - Voltage Above Normal or Shorted to High Source. High battery supply voltage detected at the glow plug control module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The glow plug control module supply voltage was greater than 16.5 volts.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Overcharged batteries caused by a malfunctioning alternator or regulator.
  • Battery charger or external voltage source above threshold.
  • A Malfunction of the glow plug control module

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3177.

Last Modified: 03-Mar-2016


Glow Plug Control Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3178

Glow Plug Control Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3178 PID: SPN: 7576 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Control Module - Voltage Below Normal or Shorted to Low Source. Low battery supply voltage detected at the glow plug control module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Glow Plug Module detected supply voltage below a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Glow Plug control module is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned fuse, or low voltage supplied by the battery.
  • An open or short circuit in the SAE J1939 datalink circuit
  • A Malfunction of the glow plug control module

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3178.

Last Modified: 11-Dec-2014


Glow Plug Heater Circuit #1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3179

Glow Plug Heater Circuit #1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3179 PID: SPN: 854 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #1 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 1 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3179.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3181

Glow Plug Heater Circuit #1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3181 PID: SPN: 854 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #1 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 1 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3181.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #2 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3182

Glow Plug Heater Circuit #2 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3182 PID: SPN: 855 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #2 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 2 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3182.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3183

Glow Plug Heater Circuit #2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3183 PID: SPN: 855 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #2 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 2 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3183.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #3 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3184

Glow Plug Heater Circuit #3 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3184 PID: SPN: 856 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #3 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 3 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3184.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #3 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3185

Glow Plug Heater Circuit #3 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3185 PID: SPN: 856 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #3 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 3 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3185.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #1 - Current Below Normal or Open Circuit

FAULT CODE 3187

Glow Plug Heater Circuit #1 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3187 PID: SPN: 854 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #1 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 1 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3187.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #2 - Current Below Normal or Open Circuit

FAULT CODE 3188

Glow Plug Heater Circuit #2 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3188 PID: SPN: 855 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #2 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 2 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3188.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #3 - Current Below Normal or Open Circuit

FAULT CODE 3189

Glow Plug Heater Circuit #3 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3189 PID: SPN: 856 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #3 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 3 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3189.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #4 - Current Below Normal or Open Circuit

FAULT CODE 3191

Glow Plug Heater Circuit #4 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3191 PID: SPN: 857 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #4 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 4 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3191.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #5 - Current Below Normal or Open Circuit

FAULT CODE 3192

Glow Plug Heater Circuit #5 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3192 PID: SPN: 858 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #5 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 5 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3192.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #6 - Current Below Normal or Open Circuit

FAULT CODE 3193

Glow Plug Heater Circuit #6 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3193 PID: SPN: 859 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #6 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 6 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3193.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #7 - Current Below Normal or Open Circuit

FAULT CODE 3194

Glow Plug Heater Circuit #7 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3194 PID: SPN: 860 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #7 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 7 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3194.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #8 - Current Below Normal or Open Circuit

FAULT CODE 3195

Glow Plug Heater Circuit #8 - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3195 PID: SPN: 861 FMI: 5/5 LAMP: Amber SRT: | Glow Plug Heater Circuit #8 - Current Below Normal or Open Circuit. Open circuit detected in the Glow plug 8 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • An open circuit in the harness
Refer to Troubleshooting Fault Code 3195.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #4 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3196

Glow Plug Heater Circuit #4 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3196 PID: SPN: 857 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #4 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 4 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3196.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #4 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3197

Glow Plug Heater Circuit #4 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3197 PID: SPN: 857 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #4 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 4 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3197.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3198

Glow Plug Heater Circuit #5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3198 PID: SPN: 858 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #5 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 5 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3198.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3199

Glow Plug Heater Circuit #5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3199 PID: SPN: 858 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #5 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 5 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3199.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #6 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3211

Glow Plug Heater Circuit #6 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3211 PID: SPN: 859 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #6 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 6 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3211.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #6 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3212

Glow Plug Heater Circuit #6 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3212 PID: SPN: 859 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #6 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 6 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3212.

Last Modified: 15-May-2015


Tachograph Output Shaft Speed - Received Network Data in Error

FAULT CODE 3213

Tachograph Output Shaft Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3213 PID: SPN: 1623 FMI: 2/19 LAMP: Amber SRT: | Tachograph Output Shaft Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor. | None on performance.
SAE J1939 Backbone Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the tachograph output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the tachograph output shaft speed sensor.

Refer to Troubleshooting Fault Code 3213.

Last Modified: 21-Nov-2014


Glow Plug Control Module - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3214

Glow Plug Control Module - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3214 PID: SPN: 7576 FMI: 2/2 LAMP: Amber SRT: | Glow Plug Control Module - Data Erratic, Intermittent, or Incorrect. The ECM has received Invalid status data from the Glow Plug Control Module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid message from the glow plug control module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3214.

Last Modified: 15-Dec-2014


Glow Plug Heater Circuit #7 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3215

Glow Plug Heater Circuit #7 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3215 PID: SPN: 860 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #7 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 7 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3215.

Last Modified: 15-May-2015


Glow Plug Heater Circuit #7 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3216

Glow Plug Heater Circuit #7 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3216 PID: SPN: 860 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #7 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 7 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3216.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #8 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3217

Glow Plug Heater Circuit #8 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3217 PID: SPN: 861 FMI: 4/4 LAMP: Amber SRT: | Glow Plug Heater Circuit #8 - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected on the glow plug heater 8 circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

Low voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 3217.

Last Modified: 21-Nov-2014


Glow Plug Heater Circuit #8 - Voltage Above Normal or Shorted to High Source

FAULT CODE 3218

Glow Plug Heater Circuit #8 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3218 PID: SPN: 861 FMI: 3/3 LAMP: Amber SRT: | Glow Plug Heater Circuit #8 - Voltage Above Normal or Shorted to High Source. High signal voltage detected on the glow plug 8 heater circuit. | Engine may not start or may be difficult to start.
Glow Plug Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

High voltage has been detected on the glow plug

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle and leave the key in the ON position for 2 minutes. Then start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • A malfunctioning glow plug
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 3218.

Last Modified: 21-Nov-2014


Glow Plug Control Module - Abnormal Update Rate

FAULT CODE 3219

Glow Plug Control Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3219 PID: SPN: 7576 FMI: 9/9 LAMP: Amber SRT: | Glow Plug Control Module - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the glow plug control module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code was triggered when the ECM loses J1939 data link communications with the glow plug control module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Glow Plug control module is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned fuse, or low voltage supplied by the battery.
  • An open or short circuit in the SAE J1939 datalink circuit
  • A Malfunction of the glow plug control module

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3219.

Last Modified: 21-Nov-2014


Glow Plug Control Module - Out of Calibration

FAULT CODE 3221

Glow Plug Control Module - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3221 PID: SPN: 7576 FMI: 13/13 LAMP: Amber SRT: | Glow Plug Control Module - Out of Calibration. A calibration mismatch between the glow plug control module and the ECM has been detected | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software mismatch with the Glow Plug Control Module

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A Malfunction of the glow plug control module
  • Incorrect software in glow plug control module
Refer to Troubleshooting Fault Code 3221.

Last Modified: 21-Nov-2014


Glow Plug Control Module - Bad Intelligent Device or Component

FAULT CODE 3222

Glow Plug Control Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3222 PID: SPN: 7576 FMI: 12/12 LAMP: Amber SRT: | Glow Plug Control Module - Bad Intelligent Device or Component. An internal error has been detected in the glow plug control module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The glow plug control module reported an internal error.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Glow Plug control module is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned fuse, or low voltage supplied by the battery.
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 3222.

Last Modified: 26-May-2015


Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3228

Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3228 PID: SPN: 3216 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect. An incorrect NOx sensor reading has been detected by the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx reading was higher or lower than the calculated aftertreatment intake NOx value for the engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Exhaust system leaks
  • An incorrectly installed aftertreatment intake NOx sensor
  • An aftertreatment intake NOx sensor that has carbon buildup on the tip of the sensor
  • Excessive oil consumption
  • Possible engine misfire
  • The NOx sensor part number is incorrect.
Refer to Troubleshooting Fault Code 3228.

Last Modified: 29-Feb-2016


Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

FAULT CODE 3232

Aftertreatment 1 Intake NOx Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3232 PID: SPN: 3216 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the aftertreatment intake NOx sensor. | Possible reduced engine performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code was triggered when the ECM loses J1939 data link communications with the aftertreatment intake NOx sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • The aftertreatment intake NOx sensor is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned NOx sensor fuse, or low voltage supplied by the battery.
  • Open return circuit on the aftertreatment intake NOx sensor circuit between the battery circuit aftertreatment intake NOx sensor.
  • Open or short circuit on the J1939 data link circuit between the engine ECM and aftertreatment intake NOx sensor.
  • Intermittent communications between the aftertreatment intake NOx sensor and the ECM on the J1939 data link

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3232.

Last Modified: 21-Nov-2014


Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3235

Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3235 PID: SPN: 4363 FMI: 0/16 LAMP: Red SRT: | Aftertreatment SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The SCR outlet temperature sensor reading has exceeded the maximum temperature limit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the SCR catalyst outlet temperature sensor was greater than 650°C [1202°F] for more than 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the SCR outlet temperature drops below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning in-range SCR outlet temperature sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3235.

Last Modified: 26-Jan-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3237

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3237 PID: S254 SPN: 4340 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was above a calibratible value and the line heater current was above a calibratible value.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3237.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3238

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3238 PID: SPN: 4340 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the diesel exhaust fluid line heater 1 circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the line heater voltage was below a calibratible value and the line heater current was below a calibratable valure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • A malfunctioning line heater
Refer to Troubleshooting Fault Code 3238.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3242

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3242 PID: SPN: 3363 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment. The aftertreatment diesel exhaust fluid temperature did not increase when the aftertreatment diesel exhaust fluid tank heater was commanded ON. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs a calibrated amount of time after diesel exhaust fluid tank heating is first commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank heater was commanded on by the engine engine control module (ECM), but no corresponding temperature increase in the aftertreatment diesel exhaust fluid tank temperature was recorded by the tank temperature sensor.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The fault code status in INSITE™ electronic service tool will change to INACTIVE immediately after the system is able to adequately heat and the diagnostic runs and passes. If heating can not be completed, use the "Diesel Exhaust Fluid Doser System Heater Test" found under "ECM Diagnostic Test" in INSITE™ electronic service tool to command heating to the tank heater and all line heaters.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Aftertreatment diesel exhaust fluid tank heater control valve stuck closed
  • Blockage or restrictions in the coolant plumbing to the diesel exhaust fluid tank heater
  • Engine coolant level low
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3242.

Last Modified: 06-Jul-2015


Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3243

Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3243 PID: SPN: 3060 FMI: 1/18 LAMP: Amber SRT: | Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine is not warming up as expected. | None on performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The coolant temperature sensor is threaded to the engine front cover on the right bank side next to the EGR Cooler coolant pipes.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running if the coolant temperature was less than 52°C [126°F] when the engine was started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature did not reach 72°C [162°F] in a specified amount of time.

The Engine Control Module (ECM) detected the engine coolant temperature was less than a calibrated threshold

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level, or air in the cooling system
  • Malfunctioning coolant temperature sensor
  • Malfunctioning engine coolant thermostat.
Refer to Troubleshooting Fault Code 3243.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3251

Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3251 PID: S326 SPN: 4765 FMI: 0/16 LAMP: Red SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel oxidation catalyst intake temperature sensor reading has exceeded the maximum temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the temperature at the diesel oxidation catalyst intake was greater than 745°C [1373°F] for 65 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel oxidation catalyst and/or aftertreatment diesel particulate filter.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damage and reuse. Refer to the OEM service manual.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3251.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3253

Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3253 PID: SPN: 3242 FMI: 0/16 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 735°C [1355°F] for 145 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is logged when the ECM has detected a high temperature condition in the aftertreatment system and active regeneration of the aftertreatment diesel particulate filter is not occurring. The fault code indicates that a secondary fuel source is entering the aftertreatment system and is creating a temperature increase across the aftertreatment diesel particulate filter. This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive when the vehicle is in the shop. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst

The aftertreatment system must be inspected after making the appropriate repair outlined in this fault code troubleshooting tree. Progressive damage to the aftertreatment system may have occurred. Remove the exhaust aftertreatment system from the vehicle to inspect it for potential damaged and reuse. Refer to the OEM service manual.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3253.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3254

Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3254 PID: SPN: 3242 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 650°C [1202°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3254.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3255

Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3255 PID: SPN: 3246 FMI: 0/16 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter intake temperature sensor reading was greater than 735°C [1355°F] for 145 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3255.

Last Modified: 21-Nov-2014


Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 3256

Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3256 PID: SPN: 3246 FMI: 0/15 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter outlet temperature sensor was greater than 650°C [1202°F] for 5 seconds on five separate occasions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons, this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • Excessive engine oil or diesel fuel being introduced into the exhaust system from the engine
  • A damaged engine fuel injector causing unburned diesel fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3256.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3258

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3258 PID: SPN: 4340 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit. Open circuit detected in the diesel exhaust fluid line heater 1. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an open in the line heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3258.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3311

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3311 PID: SPN: 3242 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The aftertreatment diesel particulate filter intake temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter intake temperature reading was greater than 800°C [1472°F] for more than 30 seconds, or the temperature differential across the diesel oxidation catalyst was greater than 540°C [1004°F] for more than 90 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive immediately after the aftertreatment temperatures drop below the warning limit, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • A malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • Excessive engine oil being introduced into the exhaust system from the engine.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3311.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3312

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3312 PID: SPN: 3246 FMI: 0/0 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operational Range - Most Severe Level. The aftertreatment diesel particulate filter outlet temperature sensor reading has exceeded the maximum engine protection temperature limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet temperature reading was greater than 810°C [1490°F] for 35 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault will go inactive after the aftertreatment temperatures drop below the warning limit and a key cycle has occurred, and will likely be inactive at the time of diagnosis. For these reasons this troubleshooting tree must be used for both active and inactive fault codes.

Possible causes of this fault code include:

  • A malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • Excessive engine oil being introduced into the exhaust system from the engine.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3312.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3313

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3313 PID: SPN: 4765 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the catalyst intake sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel oxidation catalyst intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3313.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3314

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3314 PID: SPN: 4765 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the catalyst intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel oxidation catalyst intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3314.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3315

Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3315 PID: SPN: 4765 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel oxidation catalyst intake temperature sensor is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel oxidation catalyst intake temperature sensor is located in the aftertreatment system. It is located at the intake of the aftertreatment catalyst. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel oxidation catalyst intake temperature sensor data and diesel particulate filter intake temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel oxidation catalyst intake temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel particulate filter intake temperature sensor
  • A malfunctioning aftertreatment diesel oxidation catalyst intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3315.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3316

Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3316 PID: SPN: 3242 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment particulate filter intake temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3316.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3317

Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3317 PID: SPN: 3242 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the aftertreatment diesel particulate filter intake temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter intake temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel particulate filter intake temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3317.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3318

Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3318 PID: SPN: 3242 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter intake temperature is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter intake temperature sensor is located in the aftertreatment system. It is located at the outlet of the diesel oxidation catalyst and before the diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the difference between the aftertreatment diesel particulate filter intake temperature sensor data and diesel particulate filter outlet temperature sensor data did not match the expected value for the present engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value for the aftertreatment diesel particulate filter intake temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel particulate filter intake temperature sensor
  • A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3318.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3319

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3319 PID: SPN: 3246 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter outlet temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3319.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3321

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3321 PID: SPN: 3246 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel particulate filter outlet temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the aftertreatment diesel particulate filter outlet temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3321.

Last Modified: 21-Nov-2014


Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3322

Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3322 PID: SPN: 3246 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect. The aftertreatment diesel particulate filter outlet temperature is not changing with engine operating conditions. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter outlet temperature sensor is located in the aftertreatment system. It is located at the outlet of the aftertreatment diesel particulate filter. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel particulate filter outlet temperature sensor reading did not change with engine operating conditions.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • A default value for the aftertreatment diesel particulate filter outlet temperature sensor reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel particulate filter intake temperature sensor
  • A malfunctioning aftertreatment diesel particulate filter outlet temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3322.

Last Modified: 21-Nov-2014


SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

FAULT CODE 3326

SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3326 PID: SPN: 91 FMI: 9/9 LAMP: Red SRT: | SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate. The ECM expected information from a multiplexed accelerator pedal or lever sensor but did not receive it soon enough or did not receive it at all. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a damaged connection between the component and the OEM VECU, damaged OEM VECU, or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3326.

Last Modified: 21-Nov-2014


Transmission Output Shaft Speed - Abnormal Update Rate

FAULT CODE 3328

Transmission Output Shaft Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3328 PID: SPN: 191 FMI: 9/9 LAMP: Amber SRT: | Transmission Output Shaft Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

This fault can occur for the following reasons:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, bad OEM VECU or bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3328.

Last Modified: 21-Nov-2014


Engine Idle Fuel Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3337

Engine Idle Fuel Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3337 PID: SPN: 5395 FMI: 0/16 LAMP: Amber SRT: | Engine Idle Fuel Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level. The fueling quantity at idle is higher than expected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle fuel quantity was lower than expected.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injectors
Refer to Troubleshooting Fault Code 3337.

Last Modified: 11-Dec-2014


Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3338

Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3338 PID: SPN: 5395 FMI: 1/18 LAMP: Amber SRT: | Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level. The fueling quantity at idle is lower than expected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the idle fuel quantity was lower than expected.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injectors
Refer to Troubleshooting Fault Code 3338.

Last Modified: 26-Nov-2014


Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3342

Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3342 PID: P091 SPN: 4752 FMI: 1/18 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The EGR cooler is not cooling the recirculated exhaust gas sufficiently. | None on performance.
Engine Exhaust Gas Recirculation Temperature Sensor Circuit

Circuit Description

The exhaust gas recirculation (EGR) temperature sensor is a variable resistor sensor and is used to measure the temperature of the EGR gas flow after it exits the EGR cooler. The engine control module (ECM) supplies 5 volts to the EGR temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the EGR flow temperature.

The EGR temperature value is used by the ECM for the engine protection system and engine emissions control.

Component Location

The EGR temperature sensor is located on the intake connection towards on the front of the engine

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR temperature was greater than a threshold for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning EGR temperature sensor
  • A malfunctioning EGR cooler.
Refer to Troubleshooting Fault Code 3342.

Last Modified: 26-Nov-2014


Engine Charge-Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3343

Engine Charge-Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3343 PID: SPN: 5285 FMI: 1/18 LAMP: Amber SRT: | Engine Charge-Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine charge air cooler is not cooling the intake air flow sufficiently. | None on performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than 95°C [203°F] for 5 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • A malfunctioning intake manifold temperature sensor
  • A malfunctioning charge-air cooler.
Refer to Troubleshooting Fault Code 3343.

Last Modified: 26-Nov-2014


Roll Over Protection Brake Control Active - Condition Exists

FAULT CODE 3374

Roll Over Protection Brake Control Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3374 PID: SPN: 1818 FMI: 11/31 LAMP: None SRT: | Roll Over Protection Brake Control Active - Condition Exists. The ECM received a message from the anti-lock braking (ABS) controller, inhibiting cruise control operation. | Cruise control could possibly not operate.
Engine Control Module (ECM)

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The anti-lock bracking (ABS) controller detected certain driving conditions and inhibited cruise control.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Cruise control has temporarily been inhibited.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, cruise control could possibly not function. This is an information only fault code, indicating that the anti-lock braking (ABS) controller detected certain driving conditions and temporarily inhibited cruise control operation. Refer to the OEM service manual.

Refer to Troubleshooting Fault Code 3374.

Last Modified: 12-May-2015


Aftertreatment Diesel Particulate Filter Regeneration Too Frequent - Condition Exists

FAULT CODE 3375

Aftertreatment Diesel Particulate Filter Regeneration Too Frequent - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3375 PID: S115 SPN: 5397 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Regeneration too Frequent - Condition Exists. The system has detected the need for an active regeneration has occurred too soon following the last active regeneration. | None on performance.
Engine Control Module (ECM)

Circuit Description

The ECM records the time from the completion of an active regeneration of the aftertreatment diesel particulate filter until the ECM request another active regeneration of the diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The time between the completion of a successful active regeneration and the requests for another active regeneration was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

This diagnostic can not be run in the shop enviornment.

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • A face plugged aftertreatment diesel oxidation catalyst
  • A malfunctioning aftertreatment diesel particulate filter differential pressure sensor
  • An engine malfunction resulting in high engine out soot.
Refer to Troubleshooting Fault Code 3375.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists

FAULT CODE 3376

Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3376 PID: SPN: 5319 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Incomplete Regeneration - Condition Exists. The system has detected that the aftertreatment diesel particulate filter differential pressure is too high following an active regeneration. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The engine aftertreatment system monitors the soot load in the aftertreatment diesel particulate filter. Under normal operating conditions, the aftertreatment diesel particulate filter is self-cleaning, where soot is converted to carbon dioxide, nitrogen, and water. Under light load operating conditions, it can be necessary to perform a stationary regeneration of the aftertreatment diesel particulate filter. The soot load in the aftertreatment diesel particulate filter is estimated, using the aftertreatment differential pressure sensor and the calculated soot output of the engine.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic only runs after successful completion of an active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The estimated soot load in the aftertreatment diesel particulate filter was higher than a calibratible value.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel injector causing unburned fuel to enter the exhaust system
  • Malfunctioning aftertreatment temperature sensors
  • A malfunctioning aftertreatment diesel oxidation catalyst
  • A malfunctioning or stuck in-range aftertreatment diesel particulate filter differential pressure sensor
  • An engine malfunction resulting in high engine out smoke
  • A damaged or malfunctioning OEM wiring harness to the differential pressure sensor.
Refer to Troubleshooting Fault Code 3376.

Last Modified: 26-Nov-2014


Engine Crankcase Ventilation Hose Disconnected - Condition Exists

FAULT CODE 3377

Engine Crankcase Ventilation Hose Disconnected - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3377 PID: SPN: 5396 FMI: 11/31 LAMP: Amber SRT: | Engine Crankcase Ventilation Hose Disconnected - Condition Exists. A disconnected Crankcase Ventilation Hose has been detected. | None on performance.
Crankcase Ventilation System

Circuit Description

This diagnostic detects a disconnected tube in a crankcase ventilation system. If average Crankcase ventilation Pressure is less than this threshold then the diagnostic predicts that the tube is disconnected and the error is set. If the Crankcase ventilation Pressure average is higher than the threshold, then the diagnostic predicts that the hose is intact and error is cleared.

Component Location

The Engine Crankcase Ventilation Hose is located in a crankcase ventilation system

Conditions for Running the Diagnostics

This diagnostic runs when the engine speed is above 1500 RPM, coolant Temperature is above 72 degree Celsius and boost pressure is above a calibratable threshold.

Conditions for Setting the Fault Codes

Fault sets if average crankcase pressure is less than the calibratable threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, run the engine above 1500 RPM and coolant Temperature above 72 degree Celsius.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code can be caused by a disconnected tube in a crankcase ventilation system.

Refer to Troubleshooting Fault Code 3377.

Last Modified: 16-Jan-2017


Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3382

Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3382 PID: SPN: 3058 FMI: 1/18 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level. Measured EGR flow is lower than commanded. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the actual EGR flow was less than what was being commanded based on the current engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code are:

  • Leaks or restrictions in the EGR flow plumbing
  • Internally leaking EGR valve
  • Stuck closed EGR valve
  • Malfunctioning EGR differential pressure sensor.
Refer to Troubleshooting Fault Code 3382.

Last Modified: 26-Nov-2014


Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3383

Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3383 PID: P411 SPN: 3058 FMI: 0/16 LAMP: Amber SRT: | Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level. Measured EGR flow is higher than commanded. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The exhaust gas recirculation (EGR) differential pressure sensor has two ports that sense exhaust pressure. The sensor outputs a voltage which represents the pressure difference between the two ports located across an orifice in the EGR tube. The engine control module (ECM) uses this pressure to determine how much exhaust gas is flowing in the EGR connection tube to the intake manifold. This information is used to control the EGR valve for correct emission levels.The ECM provides a 5 volt supply to the EGR differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The EGR differential pressure sensor provides a signal to the ECM on the EGR differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure in the EGR crossover tube.The EGR differential pressure sensor measures the exhaust gas pressure drop across the EGR differential pressure orifice. This pressure drop is used to calculate the amount of EGR flow into the intake manifold.

Component Location

The EGR valve is mounted to the rear of the EGR cooler on the right bank of the engine.

The EGR differential pressure sensor is mounted to the inlet air connection next to the EGR cooler.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured EGR flow was greater than what was being commanded based on the present engine.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault are:

  • Blockage, restrictions, or leaks in the EGR differential pressure sensor ports
  • Leaking EGR valve
  • Stuck open EGR valve
  • Malfunctioning EGR differential pressure sesnor.
Refer to Troubleshooting Fault Code 3383.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists

FAULT CODE 3396

Aftertreatment Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3396 PID: SPN: 3750 FMI: 11/31 LAMP: Amber SRT: | Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists. The aftertreatment temperatures are not warm enough for aftertreatment injection. | Possible frequent need for aftertreatment regeneration.
Engine Control Module (ECM)

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter is located in the exhaust system and is installed by the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and the ECM is requesting active regeneration of the aftertreatment diesel particulate filter.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel oxidation catalyst temperature was too low for active regeneration of the diesel particulate filter.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the aftertreatment diesel oxidation catalyst temperatures were NOT warm enough to inject fuel for active regeneration of the diesel particulate filter.

Refer to Troubleshooting Fault Code 3396.

Last Modified: 26-Nov-2014


Transmission Output Shaft Speed - Received Network Data in Error

FAULT CODE 3418

Transmission Output Shaft Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3418 PID: SPN: 191 FMI: 2/19 LAMP: Amber SRT: | Transmission Output Shaft Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined there was a malfunction of the transmission output shaft speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the transmission output shaft speed sensor.

Refer to Troubleshooting Fault Code 3418.

Last Modified: 26-Nov-2014


Engine Charge Air Cooler Outlet Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3478

Engine Charge Air Cooler Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3478 PID: SPN: 2630 FMI: 2/2 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Pressure - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an engine charge air cooler outlet pressure signal that is too high or too low for present engine operating conditions. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic consists of two parts. The first part runs when the keyswitch is turned ON and before engine speed is detected. The ECM must not see a key cycle for a period of 8 hours before this part of the diagnostic will run.

  • The second part runs continuously while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake manifold temperature sensor reading was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • In-range malfunction of the engine intake manifold temperature sensor
  • High resistance in the engine intake manifold temperature sensor signal or return lines.

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Refer to Troubleshooting Fault Code 3478.

Last Modified: 11-Dec-2014


Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

FAULT CODE 3488

Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3488 PID: SPN: 563 FMI: 9/9 LAMP: Amber SRT: | Anti-Lock Braking (ABS) Controller - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the anti-lock braking (ABS) controller. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Potential causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, a bad OEM VECU, or a bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3488.

Last Modified: 26-Nov-2014


Real Time Clock - Abnormal Rate of Change

FAULT CODE 3492

Real Time Clock - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3492 PID: SPN: 251 FMI: 10/10 LAMP: Amber SRT: | Real Time Clock - Abnormal Rate of Change. The real time clock indicates a stuck engine off timer. | None on performance.
Engine Control Module (ECM)

Circuit Description

The real-time clock consists of a timing chip internal to the engine control module (ECM) which monitors engine off time, i.e. how long the engine has been shut down.

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The engine off timer was not counting correctly and does not match other timers in the ECM.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The ECM will not be able to monitor engine off time accurately.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Monitoring the engine off time is necessary in to make sure that all other engine sensors and actuators are performing correctly. If the ECM is recalibrated or replaced during the repair and the fault code is no longer present, the instructions in the "Conditions for Clearing" section must be followed in order for the diagnostic to run again and validate the repair.

Potential causes of this fault code include:

  • Malfunctioning real time clock chip internal to the ECM
  • Engine calibration issue.
Refer to Troubleshooting Fault Code 3492.

Last Modified: 26-Nov-2014


Engine Wait to Start Lamp - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3494

Engine Wait to Start Lamp - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3494 PID: SPN: 1081 FMI: 7/7 LAMP: Amber SRT: | Engine Wait to Start Lamp - Mechanical system not responding or out of adjustment. Wait to Start lamp has malfunction | None on performance.
Engine Control Module (ECM)

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON when the intake air heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a malfunction of the Wait to Start Lamp

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

A malfunctioning Wait to Start Lamp

  • A short circuit to ground
  • An open circuit in the OEM harness
  • A malfunctioning engine control module (ECM)
Refer to Troubleshooting Fault Code 3494.

Last Modified: 13-Jan-2016


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 3497

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3497 PID: SPN: 1761 FMI: 1/17 LAMP: Maintenance SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level. The aftertreatment diesel exhaust fluid tank level is low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was low.

Action Taken When the Fault Code is Active

  • The Diesel Exhaust Fluid Lamp will be illuminated.
  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is low, and the tank must be refilled at the operator's earliest convenience.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3497.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3498

Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3498 PID: SPN: 1761 FMI: 1/18 LAMP: Maintenance SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid tank level is very low. | None on performance.
Aftertreatment Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank level was very low.

Action Taken When the Fault Code is Active

The Diesel Exhaust Fluid Lamp will be flashing.

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the diesel exhaust fluid level is very low. The diesel exhaust fluid tank must be refilled.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3498.

Last Modified: 26-Nov-2014


Wheel-Based Vehicle Speed - Received Network Data in Error

FAULT CODE 3525

Wheel-Based Vehicle Speed - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3525 PID: SPN: 84 FMI: 2/19 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the wheel-based vehicle speed sensor.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the wheel-based vehicle speed sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3525.

Last Modified: 26-Nov-2014


Wheel-Based Vehicle Speed - Abnormal Update Rate

FAULT CODE 3526

Wheel-Based Vehicle Speed - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3526 PID: SPN: 84 FMI: 9/9 LAMP: Amber SRT: | Wheel-Based Vehicle Speed - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the wheel-based vehicle speed sensor. | Engine speed limited to Maximum Engine Speed without VSS parameter value. Cruise Control, Gear-Down Protection, and Road Speed Governor will not work.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices may not function as desired.

Possible causes of this fault code include:

  • When the ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a bad J1939 data link connection between the OEM VECU and Cummins® ECM, a bad connection between the component and the OEM VECU, a bad OEM VECU, or a bad Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

It is possible to use INSITE™ electronic service tool to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3526.

Last Modified: 26-Nov-2014


Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

FAULT CODE 3527

Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3527 PID: P91 SPN: 558 FMI: 2/19 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Switch - Received Network Data In Error. The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the accelerator pedal or lever idle validation switch.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The J1939 multiplexing controller has indicated a malfunction of the accelerator pedal or lever idle validation switch.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 3527.

Last Modified: 12-May-2015


Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

FAULT CODE 3528

Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3528 PID: SPN: 558 FMI: 9/9 LAMP: Red SRT: | Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the accelerator pedal or lever idle validation switch. | Engine will only idle.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

This fault can occur for the following reasons:

  • The ECM is set up properly (components enabled and OEM VECU source addressed correctly) to receive information from an OEM VECU, but the OEM VECU is actually transmitting a message that says that component is not available for multiplexing. This can be caused when a multiplexed component is enabled in the Cummins® ECM, but the OEM VECU source address of the VECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM VECU is not set up to transmit the multiplexed component message.
  • This fault can also be caused by a damaged J1939 data link connection between the OEM VECU and Cummins® ECM, a malfunctioning connection between the component and the OEM VECU, damaged OEM VECU, or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3528.

Last Modified: 26-Nov-2014


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3539

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3539 PID: SPN: 51 FMI: 3/3 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • A short circuit to battery in the engine harness.
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 3539.

Last Modified: 26-Nov-2014


Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3541

Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3541 PID: SPN: 51 FMI: 4/4 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the engine intake air throttle position sensor circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor circuit voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
  • A short circuit to ground in the engine harness
  • An open circuit in the engine harness
Refer to Troubleshooting Fault Code 3541.

Last Modified: 26-Nov-2014


Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3542

Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3542 PID: SPN: 51 FMI: 2/2 LAMP: Amber SRT: | Engine Intake Throttle Actuator Position Sensor - Data erratic, intermittent or incorrect. The engine intake air throttle posistion feedback is erratic or incorrect. | Possible reduced engine performance.
Engine Intake Air Throttle Position Sensor Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle position sensor signal is incorrect.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning engine intake air throttle position sensor
Refer to Troubleshooting Fault Code 3542.

Last Modified: 26-Nov-2014


NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

FAULT CODE 3543

NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3543 PID: S115 SPN: 4094 FMI: 11/31 LAMP: Amber SRT: | NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists. The diesel exhaust fluid quality is not sufficient enough to provide adequate NOx reduction. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected, and the diesel exhaust fluid tank has recently been refilled.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault include:

  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.
Refer to Troubleshooting Fault Code 3543.

Last Modified: 12-May-2015


Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

FAULT CODE 3545

Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3545 PID: P2202 SPN: 3226 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Circuit - Abnormal Rate of Change. The aftertreatment outlet NOx sensor reading is not valid. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the aftertreatment outlet NOx sensor indicates to the ECM that it is not providing valid data.

Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1887, 2771, or 3682 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3545.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

FAULT CODE 3547

Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3547 PID: S115 SPN: 4096 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists. The diesel exhaust fluid tank is empty. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit

Circuit Description

The aftertreatment diesel exhaust fluid level sensor is used to monitor the diesel exhaust fluid level inside the diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid tank was empty and the dosing unit was unable to prime.

Action Taken When the Fault Code is Active

There are two levels of action taken by the ECM when this fault code is active:

Level 1: Action taken when the diesel exhaust fluid tank is empty:

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The Diesel Exhaust Fluid Lamp will be flashing.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be severely reduced.

Level 2: Action taken when the diesel exhaust fluid tank is empty and engine shutdown or extended idle.

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

The Diesel Exhaust Fluid Lamp will be flashing.

  • Engine torque will be severely reduced.
  • Vehicle speed will be limited to 8 km [5 mi] per hour.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the diesel exhaust fluid lamp immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates that the aftertreatment diesel exhaust fluid tank is empty and needs refilled immediately.

Refer to Troubleshooting Fault Code 3547.

Last Modified: 26-Nov-2014


Engine Wait to Start Lamp - Abnormal Update Rate

FAULT CODE 3555

Engine Wait to Start Lamp - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3555 PID: SPN: 1081 FMI: 9/9 LAMP: Amber SRT: | Engine Wait to Start Lamp - Abnormal update rate. A loss of communication has been detected. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the Engine Wait to Start Lamp.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect feature and parameter settings
  • A malfunctioning SAE J1939 datalink circuit
Refer to Troubleshooting Fault Code 3555.

Last Modified: 26-Nov-2014


Engine Wait to Start Lamp - Received Network Data in Error

FAULT CODE 3556

Engine Wait to Start Lamp - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3556 PID: SPN: 1081 FMI: 2/19 LAMP: Amber SRT: | Engine Wait to Start Lamp - Received Network Data In Error. The ECM received an invalid signal on the SAE J1939 datalink. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The OEM VECU determined that there was a malfunction of the Engine Wait to Start Lamp.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SAE J1939 Datalink controller has indicated a malfunction of the Engine Wait to Start Lamp.

Refer to Troubleshooting Fault Code 3556.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3557

Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3557 PID: SPN: 3360 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Data Erratic,Intermittent or Incorrect. The diesel exhaust fluid controller has detected an invalid reading. | Possible reduced engine performance.
Dosing unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The operating conditions were too high or low on the sensor supply between the diesel exhaust fluid controller and the dosing unit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when manlfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3557.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3558

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3558 PID: SPN: 3361 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage was greater than a calibratible value or the diesel exhaust fluid dosing unit supply was shorted to battery or open circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Short to battery voltage in the diesel exhaust fluid dosing unit
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3558.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3559

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3559 PID: SPN: 3361 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
19r00207

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit performs many functions, one of which is to generate adequate diesel exhaust fluid pressure in the lines, using a pump, to allow for dosing. The ECM provides a battery voltage supply and a ground to the diesel exhaust fluid dosing unit. The ECM also supplies a signal to the dosing unit to control the diesel exhaust fluid output. This signal changes, based on the diesel exhaust fluid pressure being commanded.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit signal voltage or the aftertreatment diesel exhaust fluid dosing unit supply voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to ground in the diesel exhaust fluid dosing unit
  • A short circuit to ground in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3559.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

FAULT CODE 3561

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3561 PID: SPN: 3361 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit. Open circuit detected at the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Dosing Unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftreatment diesel exhaust fluid controller detected the diesel exhaust dosing unit circuit was open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the OEM harness
  • Malfunctioning aftertreatment diesel exhaust fluid controller.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3561.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3565

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3565 PID: SPN: 5394 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the diesel exhaust fluid dosing valve. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp and/or MIL immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
  • A short circuit to battery in the OEM harness
Refer to Troubleshooting Fault Code 3565.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 3567

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3567 PID: SPN: 5394 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Valve - Current Below Normal or Open Circuit. A circuit error has been detected in the aftertreatment diesel exhaust fluid dosing valve circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve circuit was shorted high, shorted low, or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

To validate the repair:

  • Perform a key cycle.
  • Start and idle the engine.
  • Monitor the Aftertreatment Diesel Exhaust Fluid Dosing Unit State in INSITE™ electronic service tool.
  • The Aftertreatment Diesel Exhaust Fluid Dosing Unit State in INSITE™ electronic service tool must transition to Dosing, indicating the system has primed.
  • Turn the key switch OFF and allow the ECM to completely powerdown.
  • Turn the key switch ON.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open circuit in the diesel exhaust fluid dosing valve
  • A short circuit to battery in the OEM harness
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3567.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3568

Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3568 PID: SPN: 5394 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid (DEF) Dosing Valve - Mechanical System Not Responding or Out of adjustment. A mechanical malfunction has been detected in the DEF dosing valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing valve is controlled by the ECM. When the engine control module (ECM) commands DEF dosing, the ECM sends a pulse width modulated (PWM) signal to the dosing valve, which opens the dosing valve and allows DEF to be sprayed into the exhaust stream.

Component Location

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing valve is mechanically stuck.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve

Contamination of the DEF can be a possible cause for this fault code.

Refer to Troubleshooting Fault Code 3568.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 3571

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3571 PID: SPN: 4334 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid pressure sensor circuit. | Possible reduced engine performance.
19r00207

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to sensor supply or battery voltage
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3571.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3572

Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3572 PID: SPN: 4334 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid pressure sensor circuit. | Possible reduced engine performance.
Diesel Exhaust Fluid Controller Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Signal wire shorted to ground
  • A malfunctioning aftertreatment diesel exhaust fluid pressure sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3572.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3574

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3574 PID: SPN: 4334 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low diesel exhaust fluid pressure has been detected in the dosing unit. | Possible reduced engine performance.
Diesel Exhaust Fluid Controller Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing unit is in the priming or dosing state.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Low diesel exhaust fluid tank level
  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit supply line
  • Blocked or restricted diesel exhaust fluid tank filter
  • Blocked or restricted diesel exhaust fluid dosing unit filter
  • Blocked or restricted diesel exhaust fluid dosing unit supply line fitting
  • Malfunctioning diesel exhaust fluid dosing unit
  • Contaminated diesel exhaust fluid
  • Debris from the diesel exhaust fluid tank. If debris is found in the diesel exhaust fluid tank, clean the diesel exhaust fluid tank thoroughly and fill with certified diesel exhaust fluid.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3574.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3575

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3575 PID: SPN: 4334 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Pressure Sensor - Data Valid But Above Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid dosing unit has detected a blockage in the diesel exhaust fluid return flow. | Possible reduced engine performance.
Diesel Exhaust Fluid Controller Circuit

Circuit Description

The Engine Control Module (ECM) provides a 5 volt supply and a ground to the aftertreatment diesel exhaust fluid pressure sensor. The pressure sensor provides a signal to the ECM on the sensor signal circuit. This sensor signal voltage changes, based on the aftertreatment diesel exhaust fluid pressure supplied by the dosing unit. The ECM will detect a low signal voltage at low diesel exhaust fluid pressures, and a high signal voltage at high diesel exhaust fluid pressures.

Component Location

The aftertreatment diesel exhaust fluid pressure sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than 1100 kpa [159 psi] for more than 20 seconds.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot other active SCR related faults before this fault.

Possible causes of this fault code include:

  • Blocked, restricted, or frozen diesel exhaust fluid dosing unit return line or return line fitting
  • Malfunctioning diesel exhaust fluid dosing unit.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3575.

Last Modified: 26-Nov-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

FAULT CODE 3576

Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3576 PID: SPN: 3363 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit. Open circuit detected at the aftertreatment diesel exhaust fluid tank heater control valve. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Control Valve Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The diesel exhaust fluid controller detected the diesel exhaust fluid tank heater circuit was open.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid tank heating will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the OEM harness
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • Malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3576.

Last Modified: 06-Jul-2015


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 3577

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3577 PID: SPN: 4376 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source. High signal voltage detected at the aftertreatment diesel exhaust fluid return valve. | Possible reduced engine performance.
Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the Engine Control Module (ECM). The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid return valve circuit was out of range high or open.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be aftertreatment diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines can freeze and the SCR system can become damaged in cold weather if the system is not properly purged.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3577.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 3578

Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3578 PID: SPN: 4376 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the diesel exhaust fluid return valve. | Possible reduced engine performance.
Diesel Exhaust Fluid Controller Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is controlled by the Engine Control Module (ECM). The return valve position determines where diesel exhaust fluid will flow as it exits the dosing unit. When the return valve is activated, the dosing system will purge and return the diesel exhaust fluid in the lines to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic only runs when the aftertreatment diesel exhaust fluid dosing system is purging.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid return valve voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

If this fault is active, the dosing system may not be able to purge, which means there will be diesel exhaust fluid left in the lines. Care must be taken when removing connections. Also, lines could freeze and become damaged in cold weather if the system is not properly purged.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3578.

Last Modified: 26-Nov-2014


Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3583

Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3583 PID: SPN: 5031 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor Heater - Abnormal Rate of Change. The aftertreatment outlet NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Outlet NOx Sensor Heater Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
  • Intermittent power connection to the aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3583.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate

FAULT CODE 3597

Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3597 PID: SPN: 3360 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate. Data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have been interrupted. | Possible reduced engine performance.
Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid controller is the central control for the selective catalytic reduction (SCR) diesel exhaust fluid dosing system, and handles the dosing activity, tank level sensing, tank temperature sensing, line heating, and tank heating. The diesel exhaust fluid controller communicates to the engine control module (ECM) via the J1939 data link connection.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic consists of two parts:

  • The first part of the diagnostic runs continuously when the keyswitch is in the ON position and detects a loss of communication.
  • The second part of the diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit is in dosing mode and detects an aftertreatment diesel exhaust fluid controller which has gone into “waiting to shutdown” mode.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) and the aftertreatment diesel exhaust fluid controller lost communication via the J1939 data link, or the ECM has detected the aftertreatment diesel exhaust fluid controller had gone into waiting to shutdown mode.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • If the fault code status displayed by INSITE™ electronic service tool does not change to INACTIVE after 1 minute, it will be necessary to perform the Aftertreatment Diesel Exhaust Fluid System Leak Test for the second part of the diagnostic to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Loss of battery voltage to the aftertreatment diesel exhaust fluid controller
  • Loss of battery ground to the aftertreatment diesel exhaust fluid controller
  • Loss of keyswitch input to the aftertreatment diesel exhaust fluid controller
  • Shorted or open J1939 data link wiring between the aftertreatment diesel exhaust fluid controller and the primary engine ECM
  • Damaged aftertreatment diesel exhaust fluid controller
  • Blown or missing fuses on the battery voltage or keyswitch inputs to the aftertreatment diesel exhaust fluid controller.

Fault Code 1713 causes the aftertreatment diesel exhaust fluid controller to go into “waiting to shutdown” mode, which can cause Fault Code 3597 to become active. Troubleshoot Fault Code 1713 before troubleshooting Fault Code 3597.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3597.

Last Modified: 26-Nov-2014


Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

FAULT CODE 3649

Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3649 PID: SPN: 5024 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Heater - Abnormal rate of change. The aftertreatment intake NOx sensor heater is unable to maintain its normal operating temperature. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx sensor heater was unable to maintain its normal operating temperature.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The NOx sensor heater is internal to the NOx sensor assembly, and can not be serviced separately.

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Intermittent power connection to the aftertreatment intake NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3649.

Last Modified: 26-Nov-2014


Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3681

Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3681 PID: P411 SPN: 3228 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment outlet NOx sensor power supply - Data erratic, intermittent, or incorrect. The aftertreatment outlet NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the outlet NOx sensor was above or below a calibratible threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Open NOx sensor power supply circuit in the OEM harness
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the outlet NOx sensor
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3681.

Last Modified: 26-Jan-2015


Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3682

Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3682 PID: P190 SPN: 3218 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor Power Supply - Data Erratic, Intermittent or Incorrect. The aftertreatment intake NOx sensor indicates that the power supply to the sensor is incorrect. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the power supply to the intake NOx sensor was above or below a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Short to battery or ground in the OEM harness
  • Open NOx sensor power supply circuit in the OEM harness
  • Incorrect system voltage set-up in INSITE™ electronic service tool
  • Internal malfunction of the intake NOx sensor
  • The NOx sensor part number is incorrect.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3682.

Last Modified: 04-Apr-2017


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Engine Control Module Calibration Memory - Bad Intelligent Device or Component. Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunction of the ECM software.
Refer to Troubleshooting Fault Code 3697.

Last Modified: 26-Nov-2014


Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3712

Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3712 PID: P105 SPN: 5246 FMI: 0/0 LAMP: Red SRT: | Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operational Range - Most Severe Level. Critical SCR related fault codes have been active for an extended period of time and require immediate attention. | Vehicle speed will be limited to 8 km [5 miles] per hour.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been operated for an extended amount of time with critical SCR faults active, and no repair action has been taken. This amount of time will vary, depending on which SCR faults are active.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • Engine torque will be reduced.
  • Vehicle speed will be limited to 8 km [5 mi] per hour.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate and vehicle speed limit have been implemented in order to make sure that the critical SCR related fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3712.

Last Modified: 26-Nov-2014


Engine Protection Torque Derate - Condition Exists

FAULT CODE 3714

Engine Protection Torque Derate - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3714 PID: S115 SPN: 1569 FMI: 11/31 LAMP: Amber SRT: | Engine Protection Torque Derate - Condition Exists. Critical fault codes related to engine operation are active. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM continuously monitors the engine's fault code status to determine if any fault codes critical to successful engine operation are active.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected certain critical fault codes related to engine operation were active and the engine continued to operate.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all other active fault codes have been addressed. Refer to the appropriate fault code troubleshooting tree.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

This fault code is for information only, and indicates that an engine power derate has been implemented in order to make sure that the critical fault codes that are presently active in the ECM are addressed as quickly as possible.

Refer to Troubleshooting Fault Code 3714.

Last Modified: 26-Nov-2014


Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level.

FAULT CODE 3715

Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level.

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3715 PID: SPN: 188 FMI: 0/16 LAMP: Amber SRT: | Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level. The engine speed at idle has exceeded the governed idle speed. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) continuously monitors the engine speed at idle and adjusts fueling to maintain governed idle speed.

Component Location

The engine speed is monitored by the crankshaft and/or camshaft position sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed was 50 rpm above governed idle speed for 30 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Fuel system malfunction
  • Crankshaft position sensor malfunction
  • Camshaft position sensor malfunction
  • Alternate fuel source entering intake system
Refer to Troubleshooting Fault Code 3715.

Last Modified: 26-Nov-2014


Engine Speed At Idle - Data Valid But Below Normal Operational Range - Moderately Severe Level

FAULT CODE 3716

Engine Speed At Idle - Data Valid But Below Normal Operational Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3716 PID: SPN: 188 FMI: 1/18 LAMP: Amber SRT: | Engine Speed At Idle - Data Valid But Below Normal Operational Range - Moderately Severe Level. Engine is not maintaining the governed idle speed. | None on performance.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) continuously monitors the engine speed at idle and adjusts fueling to maintain governed idle speed.

Component Location

The engine speed is monitored by the crankshaft and/or camshaft position sensors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle and PTO is not active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed was 50 rpm below governed idle speed for 30 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Fuel system malfunction
  • Crankshaft position sensor malfunction
  • Camshaft position sensor malfunction
  • Increased engine accessory load
Refer to Troubleshooting Fault Code 3716.

Last Modified: 26-Nov-2014


Aftertreatment Outlet NOx Sensor - Out of Calibration

FAULT CODE 3717

Aftertreatment Outlet NOx Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3717 PID: SPN: 3226 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor -Out of Calibration. A nominal system voltage mismatch has been detected by the aftertreatment outlet NOx sensor. | None on performance.
Aftertreatment Outlet NOx Sensor Power Supply

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Calibration incompatibility between aftertreatment outlet NOx sensor and ECM calibration
  • System voltage incorrect for installed aftertreatment outlet NOx sensor part number.
  • Incorrect aftertreatment outlet NOx sensor is installed in exhaust system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3717.

Last Modified: 26-Nov-2014


Aftertreatment 1 Intake NOx - Out of Calibration

FAULT CODE 3718

Aftertreatment 1 Intake NOx - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3718 PID: SPN: 3216 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Intake NOx - Out of Calibration. A nominal system voltage mismatch has been detected by the aftertreatment intake NOx sensor. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the engine's electrical system voltage and the NOx sensor voltage rating.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Calibration incompatibility between aftertreatment intake NOx sensor and ECM calibration.
  • System voltage is incorrect for the installed aftertreatment intake NOx sensor part number.
  • Incorrect aftertreatment intake NOx sensor is installed in exhaust system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3718.

Last Modified: 25-Apr-2016


Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

FAULT CODE 3725

Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3725 PID: P102 SPN: 3216 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Abnormal Rate of Change. The aftertreatment intake NOx sensor reading is not valid. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftetreatment diesel oxidation catalsyst intake temperature sensor has been above 150° C [302° F] for 5 seconds while the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment intake Nox sensor reading was not valid.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • This fault code sets when the aftertreatment intake NOx sensor indicates to the ECM that it is not providing valid data.
  • Troubleshoot the aftertreatment outlet NOx sensor for Fault Codes 1885, 3232, or 3681 before troubleshooting this fault code.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3725.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

FAULT CODE 3736

Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3736 PID: SPN: 3360 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known. Unexpected data link communications between the ECM and the aftertreatment diesel exhaust fluid controller have occurred. | Possible reduced engine performance.
Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) sent an unexpected message via the data link to the diesel exhaust fluid controller and the message could not be interpreted.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect data link termination resistance
  • Open or short circuit on J1939 data link
  • Malfunctioning engine ECM
  • Corrupted engine calibration
  • Malfunctioning diesel exhaust fluid controller
  • Corrupted diesel exhaust fluid controller calibration
Refer to Troubleshooting Fault Code 3736.

Last Modified: 26-Nov-2014


Engine Starter Mode Overcrank Protection - Condition Exists

FAULT CODE 3737

Engine Starter Mode Overcrank Protection - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3737 PID: S115 SPN: 1675 FMI: 11/31 LAMP: None SRT: | Engine Starter Mode Overcrank Protection - Condition Exists. The starter motor has been temporarily disabled in order to prevent starter damage. | Starter operation is prohibited until the starter motor has adequately cooled.
Engine Control Module (ECM)

Circuit Description

The overcrank protection feature (or starter lockout) is designed to prevent damage to the starter motor during hard start conditions. Excessive cranking of the engine can cause the starter motor to overheat, resulting in permanent damage. When excessive engine cranking is detected, the overcrank protection feature locks out the starter until the starter motor has adequately cooled, and is safe to operate again.

Component Location

The overcrank protection feature is controlled by the ECM, and can not be modified.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter motor was engaged for a long enough period of time that continued cranking can cause starter damage. This cumulative time includes continuous cranking and/or a series of shorter cranking attempts within a certain time window.

Action Taken When the Fault Code is Active

  • The starter is locked out and the engine can not be cranked over until the starter motor has adequately cooled.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This is an information only fault code, and does not indicate an issue with the starter.

Refer to Troubleshooting Fault Code 3737.

Last Modified: 26-Nov-2014


Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3748

Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3748 PID: SPN: 3216 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment Intake NOx Sensor - Data Not Rational - Drifted High. An offset in the intake NOx sensor reading has been detected. | None on performance.
Aftertreatment Intake NOx Sensor Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment intake NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.
  • Engine torque will be severely reduced.

Vehicle speed will be limited to 8 km [5 mi] per hour after extended engine operation with the fault code active.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment diesel oxidation catalyst intake temperature must be above 150° C [302° F] for 5 seconds before the aftertreatment intake NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Improperly installed aftertreatment intake NOx sensor.
Refer to Troubleshooting Fault Code 3748.

Last Modified: 26-Nov-2014


Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

FAULT CODE 3749

Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3749 PID: S254 SPN: 3226 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High. An offset in the outlet NOx sensor reading has been detected. | None on performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature is above 200°C [392°F], and the engine is in a motoring condition.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment outlet NOx sensor was not reading zero while in a motoring (non-fueling) condition.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment outlet NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment outlet NOx sensor.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 3749.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 3867

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3867 PID: SPN: 3364 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level. The diesel exhaust fluid (DEF) has been detected to be below a critical threshold. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhuast fluid
  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 3867.

Last Modified: 19-Feb-2016


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

FAULT CODE 3868

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3868 PID: SPN: 3364 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change .No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment DEF quality sensor. | Engine power derate.
Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is part of the aftertreatment dosing unit which is loacted in the DEF tank.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the keyswitch in in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.
  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Use INSITE electronic service tool to verify the fault code is inactive.

Shop Talk

Possible causes of this fault code include:

  • Contaminated diesel exhaust fluid
Refer to Troubleshooting Fault Code 3868.

Last Modified: 26-Nov-2014


Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3878

Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3878 PID: SPN: 3364 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect. The diesel exhaust fluid (DEF) quality sensor has detected an over temperature condition. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code is triggered when the DEF quality sensor detects that the internal temperature has exceeded 125°C.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 3878.

Last Modified: 07-Mar-2016


Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4143

Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4143 PID: SPN: 5835 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 4143.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4144

Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4144 PID: SPN: 5835 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 4144.

Last Modified: 19-Feb-2016


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4151

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4151 PID: SPN: 5742 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal update rate. No communications on the J1939 data link between the ECM and the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment diesel particulate filter temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low battery voltage supply
  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
Refer to Troubleshooting Fault Code 4151.

Last Modified: 01-Dec-2014


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

FAULT CODE 4152

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4152 PID: SPN: 5743 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Abnormal update rate. No communication on the J1939 data link between the ECM and the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of communication with the aftertreatment SCR temperature sensor module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Low battery voltage supply
  • Incorrect terminating resistance of the SAE J1939 datalink circuit
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Incorrect Battery System Voltage setting in INSITE
Refer to Troubleshooting Fault Code 4152.

Last Modified: 01-Dec-2014


Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4153

Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4153 PID: SPN: 7321 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 4153.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4154

Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4154 PID: SPN: 7323 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 4154.

Last Modified: 19-Feb-2016


Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4157

Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4157 PID: SPN: 4376 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical system not responding or out of adjustment. A stuck aftertreatment diesel exhaust fluid return valve has been detected. | None on performance.
Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid return valve is used to purge the aftertreatment diesel exhaust fluid dosing system. When the return valve is energized, the dosing system will purge and return the aftertreatment diesel exhaust fluid to the tank.

Component Location

The aftertreatment diesel exhaust fluid return valve is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic only runs when the aftertreatment diesel exhaust fluid dosing system is purging.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure did not drop when the aftertreatment diesel exhaust fluid return valve was commanded on.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid System Leak Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid return valve
Refer to Troubleshooting Fault Code 4157.

Last Modified: 01-Dec-2014


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4158

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4158 PID: SPN: 5742 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad intelligent device or component. An internal error has been detected in the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module Circuit

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel particulate filter temperature sensor module
Refer to Troubleshooting Fault Code 4158.

Last Modified: 01-Dec-2014


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

FAULT CODE 4159

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4159 PID: SPN: 5743 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad intelligent device or component. An internal error has been detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module Circuit

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported an internal error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR temperature sensor module
Refer to Troubleshooting Fault Code 4159.

Last Modified: 01-Dec-2014


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4161

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4161 PID: SPN: 5742 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal, or Shorted to High Source. High battery supply voltage detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module Circuit

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • High battery voltage supply
Refer to Troubleshooting Fault Code 4161.

Last Modified: 26-Jan-2015


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4162

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4162 PID: SPN: 5742 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage below normal, or shorted to low source. Low battery supply voltage detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Low battery voltage supply
Refer to Troubleshooting Fault Code 4162.

Last Modified: 26-Jan-2015


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4163

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4163 PID: SPN: 5742 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Temperature Sensor Module- Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment diesel particulate filter temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to over heating of the aftertreatment diesel particulate filter temperature sensor module.

Refer to Troubleshooting Fault Code 4163.

Last Modified: 01-Dec-2014


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 4164

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4164 PID: SPN: 5743 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal, or Shorted to High Source. High battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported high battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • High battery voltage supply
Refer to Troubleshooting Fault Code 4164.

Last Modified: 26-Jan-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4165

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4165 PID: SPN: 5743 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage below normal, or shorted to low source. Low battery supply voltage detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported low battery supply voltage.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect Battery System Voltage setting in INSITE
  • Incorrect sensor for the application (12 VDC versus 24 VDC)
  • Low battery voltage supply
Refer to Troubleshooting Fault Code 4165.

Last Modified: 26-Jan-2015


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4166

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4166 PID: SPN: 5743 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment SCR temperature sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment SCR temperature sensor module.

Refer to Troubleshooting Fault Code 4166.

Last Modified: 01-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4168

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4168 PID: SPN: 5745 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Voltage Above Normal, or Shorted to High Source. The aftertreatment diesel exhasut fluid dosing unit heater is detected to be stuck on. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit heater temperature was rising when the aftertreatment diesel exhaust fluid dosing unit heater was commanded OFF.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 4168.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4169

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4169 PID: SPN: 5745 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Below Normal, or Shorted to Low Source. Low signal voltage detected at the aftertreatment diesel exhaust fluid dosing unit heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The SCR dosing system is an In-tank system with a Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low signal voltage or a short to ground at the diesel exhaust fluid dosing unit heater circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 4169.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4171

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4171 PID: SPN: 5745 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level. The aftertreatment diesel exhaust fluid dosing unit failed to thaw. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment diesel exhaust fluid dosing unit heater is commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit failed to reach a target temperature after heating for a calibratable amount of time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit heater
Refer to Troubleshooting Fault Code 4171.

Last Modified: 12-May-2015


Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4213

Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4213 PID: SPN: 3695 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Regeneration Inhibit Switch - Data erratic, intermittent or incorrect. The aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position. | Possible frequent need for aftertreatment regeneration.
Aftertreatment Regeneration Inhibit Switch Circuit

Circuit Description

The OEM truck manufacturer can install a permit switch in the dash or send an inhibit message via the J1939 data link to the engine ECM. The function of the inhibit message is to prevent the aftertreatment system from performing mobile regenerations.

Component Location

The aftertreatment regeneration permit switch can be an actual switch in the vehicle dash or it can be a J1939 message sent via the J1939 data link. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment regeneration permit switch is stuck in the OFF or INHIBIT position and the ECM is requesting active regeneration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and perform the INSITE™ electronic service tool Aftertreatment Diesel Particulate Filter Regeneration Test.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment regeneration permit switch circuit.
  • Incorrect feature and parameter settings
Refer to Troubleshooting Fault Code 4213.

Last Modified: 01-Dec-2014


Anti-Lock Braking (ABS) Active - Condition Exists

FAULT CODE 4215

Anti-Lock Braking (ABS) Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4215 PID: SPN: 563 FMI: 11/31 LAMP: None SRT: | Anti-Lock Braking (ABS) Active - Condition Exists. Cruise control was paused due to an anti-wheel slip message from teh ABS controller. | Adaptive cruise control will not operate. Standard cruise control may not operate.
Engine Control Module (ECM)

Circuit Description

Certain anti-lock braking (ABS) controllers communicate with the engine control module (ECM) through the SAE J1939 data link. Under certain driving conditions, the anti-lock braking (ABS) controller can send a cruise control inhibit message to the ECM and cruise control will temporarily be disabled.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) disabled cruise control due to an anti-wheel slip message from the anti-lock braking (ABS) controller.

Action Taken When the Fault Code is Active

  • Cruise control has temporarily been inhibited.
  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

This is an information only fault code to indicate that cruise control was interrupted due to a message from the ABS controller. No troubleshooting is necessary.

Refer to Troubleshooting Fault Code 4215.

Last Modified: 01-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4233

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4233 PID: SPN: 3515 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Temperature Sensor - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the diesel exhaust fluid temperature sensor circuit | Possible reduced engine performance.
ECM

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Aftertreatment diesel exhaust fluid temperature 2 is the temperature of the diesel exhaust fluid internal to the aftertreatment diesel exhaust fluid quality sensor.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 4233.

Last Modified: 07-Mar-2016


Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4234

Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4234 PID: SPN: 3515 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Temperature Sensor - Voltage Below Normal or Shorted to Low Source. Low signal voltage or short circuit detected at the diesel exhaust fluid temperature sensor circuit | Possible reduced engine performance.
ECM

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Aftertreatment diesel exhaust fluid temperature 2 is the temperature of the diesel exhaust fluid internal to the aftertreatment diesel exhaust fluid quality sensor.

Component Location

The DEF quality sensor is typically mounted in the DEF tank or in-line with the DEF dosing unit supply line. Reference the OEM service manual for a detailed component location view.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 4234.

Last Modified: 07-Mar-2016


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4244

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4244 PID: SPN: 4337 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Temperature - Data erratic, intermittent or incorrect. The aftertreatment diesel exhaust fluid dosing temperature is irrational. | None on performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit heater is used to defrost and/or prevent freezing of the diesel exhaust fluid dosing unit.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

The engine must be turned OFF for period of 8 hours before this diagnostic will run. This diagnostic runs when the keyswitch is turned to the ON position after an 8 hour cold soak.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing unit temperature was higher or lower than the other temperature sensors on the engine after an extended period of engine OFF time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit temperature sensor

If there is a Low Coolant fault active or very recently inactive, please ensure low coolant is adequately resolved and all air is out of the system before troubleshooting

Refer to Troubleshooting Fault Code 4244.

Last Modified: 12-May-2015


Aftertreatment Diesel Exhaust Fluid Controller - Condition Exists

FAULT CODE 4248

Aftertreatment Diesel Exhaust Fluid Controller - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4248 PID: SPN: 3360 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component. An internal error has been detected in the aftertreatment diesel exhaust fluid controller. | Possible reduced engine performance.
Dosing unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

An internal error was detected in the aftertreatment diesel exhaust fluid controller, and has been communicated to the Engine Control Module (ECM) via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4248.

Last Modified: 01-Dec-2014


Engine Wait to Start Lamp - Condition Exists

FAULT CODE 4252

Engine Wait to Start Lamp - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4252 PID: SPN: 1081 FMI: 11/31 LAMP: Amber SRT: | Engine Wait to Start Lamp - Condition Exists. The received signal does not match the commanded signal. | None on performance.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the received status of the Engine Wait to Start Lamp did not match the commanded status.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The SAE J1939 Datalink controller has indicated a malfunction of the Engine Wait to Start Lamp.

Refer to Troubleshooting Fault Code 4252.

Last Modified: 01-Dec-2014


Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4259

Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4259 PID: SPN: 5742 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known. Intermittent battery voltage supply detected at the aftertreatment diesel particulate filter temperature sensor module. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Temperature Sensor Module

Circuit Description

The aftertreatment diesel particulate filter temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment diesel partculate filter temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment diesel particulate filter temperature sensor module is used to measure the aftertreatment diesel oxidation catalyst intake temperature, aftertreatment diesel particulate filter intake temperature, and aftertreatment diesel particulate filter outlet temperature. The temperature probes are permanently attached to the aftertreatment diesel particulate filter temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment diesel particulate filter temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4259.

Last Modified: 01-Dec-2014


Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

FAULT CODE 4261

Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4261 PID: SPN: 5743 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known. Intermittent battery voltage supply detected at the aftertreatment SCR temperature sensor module. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an intermittent battery voltage supply to the aftertreatment SCR temperature sensor module resulting in an internal reset of the module.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code sets when the ECM detects an internal reset of the sensor. This internal reset is caused by an intermittent battery voltage supply. This fault code indicates that an intermittent wiring problem has been detected. All wiring and connectors should be closely inspected for intermittent connections.

Refer to Troubleshooting Fault Code 4261.

Last Modified: 26-Jan-2015


High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4262

High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4262 PID: SPN: 5571 FMI: 3/3 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Voltage Above Normal, or Shorted to High Source. High signal voltage or open circuit is detected at the High Pressure Common Rail Fuel Pressure Relief Valve circuit. | Possible reduced engine performance.
Fuel Pressure Relief Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short to battery, short pin-to-pin, or open circuit in the high pressure common rail fuel pressure relief valve circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects an open or short circuit in the high pressure common rail fuel pressure relief valve circuit. Causes of this fault code include a short circuit to a positive voltage, open circuit, or low resistance (high pressure common rail fuel pressure relief valve is shorted internally). If there is high harness resistance or an intermittent open circuit, Fault Code 4867 can have high inactive counts. When excessive current or a short circuit is detected, the ECM driver to the high pressure common rail fuel pressure relief valve actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will run this diagnostic again. The ECM driver is enabled at key ON, so if the cause is no longer present, the fault code will become inactive and can be cleared.

Refer to Troubleshooting Fault Code 4262.

Last Modified: 26-Jan-2015


High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4263

High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4263 PID: SPN: 5571 FMI: 4/4 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Voltage below Normal, or Shorted to low Source. Low signal voltage is detected at the High Pressure Common Rail Fuel Pressure Relief Valve circuit. | Possible reduced engine performance.
Fuel Pressure Relief Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a short circuit to ground in the High Pressure Common Rail Fuel Pressure Relief Valve circuit signal or return circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault becomes active when the ECM detects a short circuit in the high pressure common rail fuel relief valve circuit. Causes for this fault code are short circuit to ground or low resistance (high pressure common rail fuel pressure relief valve actuator coil is shorted internally). When excessive current or a short circuit is detected, the ECM driver to the high pressure common rail fuel pressure relief valve actuator is turned off to protect the circuit. It is necessary to cycle the keyswitch OFF and then back ON before the ECM will test again for the cause of the fault code. The ECM driver is enabled at key ON; if the cause is no longer present, the fault code will become inactive and can be cleared. If the fault code is intermittent, look for causes of an intermittent short to ground in the wiring harness or connectors.

Refer to Troubleshooting Fault Code 4263.

Last Modified: 03-Dec-2014


Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

FAULT CODE 4277

Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4277 PID: SPN: 3364 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change. The Urea Quality Sensor has been unable to generate a concentration value for a period of time. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment DEF quality sensor via the J1939 data link.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Low aftertreatment diesel exhaust fluid level in the diesel exhaust fluid tank

  • Shorted or open J1939 data link wiring.
  • Malfunctioning DEF Quality Sensor

Inactive counts can be caused by elevation changes or tank sloshing while driving.

Refer to Troubleshooting Fault Code 4277.

Last Modified: 17-Dec-2015


Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4449

Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4449 PID: SPN: 6773 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level. The aftertreatment particulate matter sensor has detected in-range high sensor values. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The residual current flow through the sensor after a sensor regeneration was higher than a threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
  • Internal engine damage.
Refer to Troubleshooting Fault Code 4449.

Last Modified: 19-Feb-2016


Vehicle Identification Number - Out of Calibration

FAULT CODE 4517

Vehicle Identification Number - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4517 PID: SPN: 237 FMI: 13/13 LAMP: Amber SRT: | Vehicle Identification Number - Out of Calibration. The vehicle identification number has not been programmed into the ECM. | None on performance.
Engine Control Module (ECM)

Circuit Description

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the vehicle identification number (VIN) was not programmed in the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Incorrect feature and parameter settings
Refer to Troubleshooting Fault Code 4517.

Last Modified: 03-Dec-2014


Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4518

Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4518 PID: SPN: 5862 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment SCR Intermediate Gas Temperature Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected at the aftreatment SCR intermediate temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intermediate temperature signal was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intermediate temperature sensor
Refer to Troubleshooting Fault Code 4518.

Last Modified: 03-Dec-2014


Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4519

Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4519 PID: SPN: 5862 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment SCR Intermediate Gas Temperature Sensor Circuit - Voltage below normal, or shorted to low source. Low signal voltage detected at the aftertreatment SCR intermediate temperature sensor circuit. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment SCR temperature sensor module reported the aftertreatment SCR intermediate temperature signal was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intermediate temperature sensor
Refer to Troubleshooting Fault Code 4519.

Last Modified: 03-Dec-2014


Aftertreatment 1 SCR Intermediate Gas Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4521

Aftertreatment 1 SCR Intermediate Gas Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4521 PID: SPN: 5862 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment SCR Intermediate Gas Temperature Sensor - Data erratic, intermittent or incorrect. The aftertreatment SCR intermediate temperature sensor reading is irrational. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intermediate temperature sensor

A malfunctioning aftertreatment SCR outlet temperature sensor

Refer to Troubleshooting Fault Code 4521.

Last Modified: 03-Dec-2014


Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4524

Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4524 PID: SPN: 5862 FMI: 0/0 LAMP: Red SRT: | Aftertreatment SCR Intermediate Gas Temperature - Data valid but above normal operational range - Most Severe Level. The aftertreatment SCR intermediate temperature sensor reading is above the engine protection limit. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature was above 700 C [1292] for 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injectors
  • A malfunctioning aftertreatment SCR intermediate temperature sensor
  • Contaminated diesel exhaust fluid
Refer to Troubleshooting Fault Code 4524.

Last Modified: 03-Dec-2014


Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4525

Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4525 PID: SPN: 5862 FMI: 16/16 LAMP: Red SRT: | Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High SCR Intermediate temperature detected. | Progressive power and/or speed derate increasing in severity from time of alert. If the Engine Protection Shutdown feature is enabled, the engine will shut down 30 seconds after the red STOP lamp starts flashing.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running and active regeneration of the aftertreatment diesel particulate filter is not occurring.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature was above 650 C [1202 F] for 60 seconds.

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injectors
  • A malfunctioning aftertreatment SCR intermediate temperature sensor
  • Contaminated diesel exhaust fluid
Refer to Troubleshooting Fault Code 4525.

Last Modified: 03-Dec-2014


Brake Pedal Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4526

Brake Pedal Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4526 PID: SPN: 521 FMI: 2/2 LAMP: Amber SRT: | Brake Pedal Position - Data erratic, intermittent or incorrect. The values of the 2 brake switch signals do not match. | None on performance.
Brake Switch Circuit

Circuit Description

The Engine Control Module (ECM) monitors the brake pedal position using two brake pedal position switches.

Component Location

The brake pedal position switch is mounted to the brake pedal. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the two brake switch signals do not match.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning brake pedal position switch
  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness
Refer to Troubleshooting Fault Code 4526.

Last Modified: 03-Dec-2014


Aftertreatment Diesel Particulate Filter System - Special Instructions

FAULT CODE 4584

Aftertreatment Diesel Particulate Filter System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4584 PID: SPN: 3936 FMI: 14/14 LAMP: Red SRT: | Aftertreatment Diesel Particulate Filter System - Special Instructions. the incorrect aftertreatment diesel particulate filter system has been installed with the engine | Engine will be shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment diesel particulate filter temperature sensor module is mounted on the aftertreatment diesel particulate filter.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine has been manufactured with the incorrect Diesel Particulate Filter System

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • A malfunctioning aftertreatment diesel particulate filter temperature sensor module
  • A malfunctioning engine control module (ECM)

Malfunctioning ECM software

Refer to Troubleshooting Fault Code 4584.

Last Modified: 03-Dec-2014


Aftertreatment 1 SCR Catalyst System - Special Instructions

FAULT CODE 4585

Aftertreatment 1 SCR Catalyst System - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4585 PID: SPN: 4792 FMI: 14/14 LAMP: Red SRT: | Aftertreatment 1 SCR Catalyst System - Special Instructions. The Incorrect SCR system has been Installed | Engine will be shut down.
Engine Control Module (ECM)

Circuit Description

Because engines and aftertreatment components are manufactured in different locations, they are shipped to OEM customers for final vehicle assembly. The process involves both hardware and software elements in detecting the correct match of aftertreatment system to engine model during initial engine to machine integration.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs at key ON in the first 50 hours of engine run time.

Conditions for Setting the Fault Codes

The engine control module detects that the engine has been manufactured with the incorrect SCR

Action Taken When the Fault Code is Active

The ECM illuminates the red STOP ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • A malfunctioning aftertreatment SCR temperature sensor module
  • A malfunctioning engine control module (ECM)

Malfunctioning ECM software

Refer to Troubleshooting Fault Code 4585.

Last Modified: 03-Dec-2014


Engine Intake Manifold Pressure System Monitor - Condition Exists

FAULT CODE 4612

Engine Intake Manifold Pressure System Monitor - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4612 PID: SPN: 5321 FMI: 11/31 LAMP: Amber SRT: | Engine Intake Manifold Pressure System Monitor - Condition Exists. The engine is unable to meet the air handling system commands. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

The exhaust gas recirculation (EGR) valve is controlled by a brushless motor located on top of the EGR valve. The EGR valve motor uses three different motor legs to move the valve through its range of motion. The ECM uses the EGR motor A, B, and C wires to command the EGR valve to the appropriate position in order to meet EGR flow targets.The EGR valve motor contains three position sensors that detect the location of the EGR valve. These sensors report the position of the valve back to the ECM over the EGR valve position A, B, and C wires.

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

The EGR Valve and EGR Differential Pressure Sensor location varies depending on engine model.

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the EGR flow, intake manifold pressure, or exhaust pressure was unable to meet the command.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.

Shop Talk

Troubleshoot any fault codes related to the intake manifold pressure/temperature, EGR differential pressure, barometric pressure, exhaust gas pressure, VGT, EGR, or engine intake air throttle prior to troubleshooting 4612.

Refer to Troubleshooting Fault Code 4612.

Last Modified: 03-Dec-2014


Injector Solenoid Driver Cylinder 7 - Out of Calibration

FAULT CODE 4643

Injector Solenoid Driver Cylinder 7 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4643 PID: SPN: 657 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 7 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4643.

Last Modified: 03-Dec-2014


Injector Solenoid Driver Cylinder 8 - Out of Calibration

FAULT CODE 4644

Injector Solenoid Driver Cylinder 8 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4644 PID: SPN: 658 FMI: 13/13 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 - Out of Calibration. Invalid injector barcode information has been entered. | Possible reduced engine performance.
Injector Solenoid Driver Circuit

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 8 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode needs to be entered into the ECM with INSITE™ electronic service tool. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector barcode values can be read directly off the top of each injector without the need of removing any additional parts. Use INSITE™ electronic service tool to enter the barcode values into the ECM for this fault code to go inactive.

Refer to Troubleshooting Fault Code 4644.

Last Modified: 03-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4658

Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4658 PID: SPN: 4331 FMI: 1/18 LAMP: Amber SRT: | Aftertreatment SCR Actual Dosing Reagent Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level. Low aftertreatment diesel exhaust fluid flow detected. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The SCR dosing system is an In-tank system with a Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid dosing unit location is original equipment manufacturer (OEM) dependent. Refer to the OEM service manual.

The aftertreatment diesel exhaust fluid dosing valve is installed in the exhaust system. It is mounted directly to the aftertreatment decomposition tube, before the selective catalytic reduction (SCR) catalyst. Installation position will vary, based on the aftertreatment architecture and the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs when the diesel exhaust fluid dosing valve is being commanded on.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid dosing performance is low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
  • A malfunctioning aftertreatment diesel exhaust fluid dosing valve
Refer to Troubleshooting Fault Code 4658.

Last Modified: 13-Jan-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Bad Intelligent Device or Component

FAULT CODE 4678

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4678 PID: SPN: 1761 FMI: 12/12 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level - Bad Intelligent Device or Component. An internal error has been detected by the DEF Tank level sensor. | Possible reduced engine performance.
Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is part of the dosing unit which is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit detected an internal error.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
  • Tampering of the aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4678.

Last Modified: 03-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 4679

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4679 PID: SPN: 1761 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit. Low current or an open circuit has been detected at the diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment DEF sensor detected an internal open circuit

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4679.

Last Modified: 18-Apr-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit

FAULT CODE 4682

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4682 PID: SPN: 3031 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit. Low current or an open circuit has been detected at the diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment DEF sensor detected an internal open circuit

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4682.

Last Modified: 26-May-2015


Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4691

Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4691 PID: SPN: 5585 FMI: 1/18 LAMP: Amber SRT: | Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The fuel rail pressure during cranking is too low for the engine to start. | Engine may not start or may be difficult to start.
Engine Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a primary fuel pressure signal to the ECM on the fuel rail pressure sensor signal 1 circuit. The sensor also provides a secondary fuel pressure sensor signal on the fuel rail pressure signal 2 circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is being started.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure during cranking was too low for the engine to start.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel lift pump
  • Low fuel gear pump output pressure
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel rail pressure relief valve
  • Leaking fuel injectors and or fuel injector connectors
Refer to Troubleshooting Fault Code 4691.

Last Modified: 03-Dec-2014


Engine Fuel Injection Quantity Error for Multiple Cylinders - Condition Exists

FAULT CODE 4713

Engine Fuel Injection Quantity Error for Multiple Cylinders - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4713 PID: SPN: 5357 FMI: 11/31 LAMP: Amber SRT: | Engine Fuel Injection Quantity Error for Multiple Cylinders - Condition Exists. A malfunction of all fuel injectors has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to verify injector operation. During selected conditions, each injector is fired. The fueling quantity and timing are then compared to a specified threshold.

Component Location

The engine harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs periodically during engine operation.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for all injectors.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injectors
Refer to Troubleshooting Fault Code 4713.

Last Modified: 03-Dec-2014


Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4728

Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4728 PID: SPN: 1209 FMI: 1/18 LAMP: Amber SRT: | Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. The commanded VGT position and exhaust pressure were not met. | None on performance.
Exhaust Gas Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

The exhaust gas pressure sensor is used to measure exhaust gas pressure in the exhaust manifold. This information is used by the engine control module (ECM) to control emissions and exhaust gas recirculation (EGR) valve operation. The ECM provides a 5 volt supply to the exhaust gas pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The exhaust gas pressure sensor provides a signal to the ECM on the exhaust gas pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure in the exhaust manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the air intake manifold.

The exhaust gas pressure sensor is located above the front section of the exhaust manifold and is plumbed into the exhaust manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is operating in SCR warm-up mode.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected both the VGT position and the difference of the exhaust pressure and intake manifold pressure are lower than commanded.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning intake manifold pressure sensor
  • A malfunctioning exhaust gas pressure sensor
  • A malfunctioning turbocharger
Refer to Troubleshooting Fault Code 4728.

Last Modified: 03-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

FAULT CODE 4731

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4731 PID: SPN: 3031 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration. The received datalink message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank temperature sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4731.

Last Modified: 06-Jul-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

FAULT CODE 4732

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4732 PID: SPN: 1761 FMI: 13/13 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration. The received datalink message was not valid. | None on performance.
Aftertreatment Diesel Exhaust Fluid Tank Level Sensor

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank level sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4732.

Last Modified: 06-Jul-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 4736

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4736 PID: SPN: 3031 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit. High current or a grounded circuit has been detected at the diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment DEF sensor detected excess current in an internal circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4736.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

FAULT CODE 4737

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4737 PID: SPN: 3031 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank temperature sensor. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid tank temperature sensor is located in the diesel exhaust fluid tank. Location of the tank and temperature sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 4737.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 4738

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4738 PID: SPN: 1761 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit. High current or a grounded circuit has been detected at the diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid (DEF) sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment DEF sensor performs its own internal diagnostics and reports malfunctions back to the primary engine control module via the J1939 datalink. The aftertreatment DEF sensor monitors the tank level, temperature and quality of the DEF fluid.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment DEF sensor detected excess current in an internal circuit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4738.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

FAULT CODE 4739

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4739 PID: SPN: 1761 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known. An unknown error has been detected with the aftertreatment diesel exhaust fluid tank level sensor. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid tank level sensor reported an unknown error.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4739.

Last Modified: 12-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4746

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4746 PID: SPN: 3361 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Dosing Unit Temperature - Data Erratic, Intermittent, or Incorrect. An internal error has been detected in the aftertreatment diesel exhaust fluid dosing unit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs immediately after the keyswitch is turned to the ON position, and continues until the diesel exhaust fluid dosing unit attempts to prime.

Conditions for Setting the Fault Codes

The diesel exhaust fluid dosing unit was unable to maintain the commanded diesel exhaust fluid pressure.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • Start the engine and let it idle. If, after the engine idles for 10 minutes, the fault code is still not active, the repair has been validated.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning dosing unit
  • Short circuit to ground in the aftertreatment diesel exhaust fluid dosing unit signal/dosing unit temperature wire.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4746.

Last Modified: 03-Dec-2014


Aftertreatment Intake Oxygen Sensor - Data Not Rational - Drifted High

FAULT CODE 4747

Aftertreatment Intake Oxygen Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4747 PID: SPN: 3217 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment Intake Oxygen - Data Not Rational - Drifted High. An in-range high failure has been detected. | None on performance.
J1939 Datalink Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment intake NOx sensor.
  • Exhaust system leaks.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Leaks in the air intake system between the turbocharger and intake manifold

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4747.

Last Modified: 19-Feb-2016


Aftertreatment Intake Oxygen Sensor - Data Not Rational - Drifted Low

FAULT CODE 4748

Aftertreatment Intake Oxygen Sensor - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4748 PID: SPN: 3217 FMI: 2/21 LAMP: Amber SRT: | Aftertreatment Intake Oxygen - Data Not Rational - Drifted Low. An in-range low failure has been detected. | None on performance.
J1939 Datalink Circuit

Circuit Description

The aftertreatment intake NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment intake NOx sensor is used to measure the NOx emissions at the intake of the aftertreatment system.

Component Location

The aftertreatment intake NOx sensor is mounted on the engine near the turbocharger turbine outlet.

Conditions for Running the Diagnostics

This diagnostic runs when the aftertreatment SCR outlet temperature has been above 200°C [392° F] for a calibratible period of time while the engine is running.

Conditions for Setting the Fault Codes

The ECM detected that the absolute difference between the inlet and outlet NOx sensors was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start and operate the engine to raise exhaust temperatures. This can be done by either driving the vehicle or initiating a stationary regeneration using INSITE™ electronic service tool.
  • The aftertreatment SCR outlet temperature must be above 200° C [392° F] for 60 seconds before the aftertreatment outlet NOx sensor can run its internal diagnostics.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning aftertreatment intake NOx sensor
  • Diesel exhaust fluid crystallization or deposits
  • Improperly installed aftertreatment intake NOx sensor.
  • Exhaust system leaks.

Exhaust gas recirculation (EGR) system leaks can also cause this fault code. Inspect the EGR bellows and EGR connections for signs of leaks.

Leaks in the air intake system between the turbocharger and intake manifold

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 4748.

Last Modified: 23-Feb-2016


Aftertreatment Outlet Oxygen - Data Not Rational - Drifted High

FAULT CODE 4749

Aftertreatment Outlet Oxygen - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4749 PID: SPN: 3227 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment Outlet NOx Sensor - Data Not Rational - Drifted High. An offset in the outlet NOx sensor reading has been detected. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the aftertreatment intake and outlet NOx sensor readings.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
Refer to Troubleshooting Fault Code 4749.

Last Modified: 02-Dec-2014


Aftertreatment Outlet Oxygen - Data Not Rational - Drifted Low

FAULT CODE 4751

Aftertreatment Outlet Oxygen - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4751 PID: SPN: 3227 FMI: 2/21 LAMP: Amber SRT: | Aftertreatment Outlet Oxygen - Data Not Rational - Drifted Low. An in-range low failure has been detected. | Possible reduced engine performance.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a mismatch between the aftertreatment intake and outlet NOx sensor readings.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A damaged aftertreatment outlet NOx sensor
Refer to Troubleshooting Fault Code 4751.

Last Modified: 11-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

FAULT CODE 4768

Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4768 PID: SPN: 3521 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known. Unknown fluid inside DEF tank. | Engine power derate.
SAE J1939 Datalink

Circuit Description

The DEF quality sensor is a smart device and communicates with the engine electronic control module (ECM) via the J1939 data link. The DEF quality sensor receives power and ground directly from the battery. The sensor performs its own internal diagnostics and reports malfunctions back to the primary engine ECM via the J1939 data link. The DEF quality sensor is used to measure the concentration of the DEF in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has fallen below a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 4768.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

FAULT CODE 4769

Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4769 PID: SPN: 1761 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change. A valid diesel exhaust fluid tank level reading has NOT been received. | Possible reduced engine performance.
SAE J1939 Datalink Circuit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is located in the aftertreatment diesel exhaust fluid tank. Location of the tank and level sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid tank level sensor reading was invalid for an extended period of time.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
  • Tampering of the aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 4769.

Last Modified: 12-May-2015


Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4842

Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4842 PID: SPN: 3364 FMI: 0/15 LAMP: None SRT: | Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level. The aftertreatment diesel exhaust fluid quality sensor has detected an in-range high condition. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment diesel exhaust fluid quality sensor is a smart device that communicates to the ECM via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor performs its own internal diagnostics and reports malfunctions back to the primary engine contol module via the J1939 datalink. The aftertreatment diesel exhaust fluid quality sensor is used to measure the concentration of the aftertreatment diesel exhaust fluid in the tank.

Component Location

The aftertreatment diesel exhaust fluid quality sensor is located in the aftertreatment diesel exhaust fluid tank. It may be a combination sensor with the aftertreatement diesel exhaust fluid tank level and tank temperature sensors. Location of the tank and sensor is OEM dependent. Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The DEF quality sensor has detected that the DEF concentration has risen above a critical threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • Start and idle the engine for 1 minute
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault include:

  • Degraded, diluted, or incorrect diesel exhuast fluid
  • Malfunctioning DEF Quality Sensor
Refer to Troubleshooting Fault Code 4842.

Last Modified: 19-Feb-2016


Variable Geometry Turbocharger Actuator Software - Out of Calibration

FAULT CODE 4956

Variable Geometry Turbocharger Actuator Software - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4956 PID: SPN: 6713 FMI: 13/13 LAMP: Red SRT: | Engine Variable Geometry Turbo (VGT) Software - Out of Calibration. VGT software does not match application. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected an application software mismatch with the Turbocharger actuator calibration.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger application identification number in the VGT actuator does not match the turbocharger application identification number in the ECM.

Refer to Troubleshooting Fault Code 4956.

Last Modified: 03-Dec-2014


Variable Geometry Turbocharger Actuator Software - Condition Exists

FAULT CODE 4957

Variable Geometry Turbocharger Actuator Software - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4957 PID: SPN: 6713 FMI: 11/31 LAMP: Red SRT: | Engine Variable Geometry Turbo (VGT) Software - Condition Exists. The VGT actuator and ECM software is not compatible. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The turbocharger actuator calibration revision in the VGT actuator is not compatible with the ECM software.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The turbocharger actuator interface level in the VGT actuator is not compatible with the ECM software.

Refer to Troubleshooting Fault Code 4957.

Last Modified: 03-Dec-2014


Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate

FAULT CODE 5177

Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5177 PID: P SPN: 6713 FMI: 9/9 LAMP: Amber SRT: | Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate. The ECM lost communication or did not support message from the VGT actuator. | Possible reduced engine performance.
VGT Actuator Circuit

Circuit Description

The variable geometry turbocharger (VGT) is electronically activated by the VGT actuator. The VGT actuator is a smart device and receives information via the J1939 data link from the primary engine control module (ECM). The VGT actuator performs its own diagnostics and reports malfunctions back to the primary engine ECM, using the J1939 data link. The ECM then decodes the error message and converts it to a fault code.

Component Location

The VGT actuator is located on the turbocharger bearing housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a valid J1939 data link message from the Variable Geometry Turbocharger (VGT) actuator for more than 1 second.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that the ECM did not recieve the turbocharger actuator identification message from the VGT actuator.

Refer to Troubleshooting Fault Code 5177.

Last Modified: 03-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

FAULT CODE 5278

Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5278 PID: SPN: 6802 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists. The ECM has detected conditions which indicate the Diesel Exhaust Fluid Dosing System is frozen. | Engine power derate.
Aftertreatment DEF Line Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

The aftertreatment diesel exhaust fluid tank heater keeps the diesel exhaust fluid from freezing in the diesel exhaust fluid tank. The tank heater consists of an electrically powered tank heater control valve which controls the flow of engine coolant to a heating coil inside the diesel exhaust fluid tank. The tank heater control valve opens to allow coolant to flow to the heating coil when heating is commanded, and closes when heating is no longer required.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

The diesel exhaust fluid tank heater control valve is located near the diesel exhaust fluid tank. Specific location will vary depending on the OEM. The tank heating coil is internal to the diesel exhaust fluid tank.

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the diesel exhaust fluid dosing system was unable to prime when the ambient air temperature was low (non-heated diesel exhaust fluid dosing systems).

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • To validate the repair, perform the "Aftertreatment Diesel Exhaust Fluid Doser Pump Override Test" found under "ECM Diagnostic Tests" in the INSITE™ electronic service tool
  • This fault code can not be cleared with INSITE™ electronic service tool.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

Shop Talk

Possible caused of this fault code include:

  • Malfunctioning aftertreatment diesel exhaust fluid controller
  • Malfunctioning aftertreatment diesel exhaust fluid tank heater control valve
  • A malfunctioning line heater
  • An open circuit in the harness
  • A short circuit to battery in the harness.
Refer to Troubleshooting Fault Code 5278.

Last Modified: 12-May-2015


Glow Plug Control Module Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5296

Glow Plug Control Module Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5296 PID: SPN: 7577 FMI: 0/16 LAMP: Amber SRT: | Glow Plug Control Module - Abnormal Update Rate. No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the glow plug control module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

This fault code was triggered when the ECM loses J1939 data link communications with the glow plug control module.

Action Taken When the Fault Code is Active

  • The ECM illuminates the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Glow Plug control module is not receiving power from the battery supply circuit in the OEM harness. This can be caused by an open circuit in the power supply wire, malfunctioned fuse, or low voltage supplied by the battery.
  • An open or short circuit in the SAE J1939 datalink circuit
  • A Malfunction of the glow plug control module

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5296.

Last Modified: 10-Nov-2014


Glow Plug Control Module - Root Cause Not Known

FAULT CODE 5324

Glow Plug Control Module - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5324 PID: SPN: 7576 FMI: 11/11 LAMP: Amber SRT: | Glow Plug Control Module - Root Cause Not Known. An unknown error has been detected with the glow plug control module. | Engine may not start or may be difficult to start.
Glow Plug Control Module

Circuit Description

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

The glow plug module is mounted on the chassis near the back of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The glow plug control module reported an internal error.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Glow Plug control module is not receiving power from the battery supply circuit in the engine harness. This can be caused by an open circuit in the power supply wire, malfunctioned fuse, or low voltage supplied by the battery.
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5324.

Last Modified: 12-Nov-2015


Engine Glow Plug 1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5415

Engine Glow Plug 1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5415 PID: SPN: 5324 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 1 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 1 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5415.

Last Modified: 02-Dec-2014


Engine Glow Plug 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5416

Engine Glow Plug 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5416 PID: SPN: 5325 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 2 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 2 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5416.

Last Modified: 03-Dec-2014


Engine Glow Plug 3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5417

Engine Glow Plug 3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5417 PID: SPN: 5326 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 3 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 3 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5417.

Last Modified: 03-Dec-2014


Engine Glow Plug 4 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5418

Engine Glow Plug 4 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5418 PID: SPN: 5327 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 4 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 4 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5418.

Last Modified: 03-Dec-2014


Engine Glow Plug 5 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5419

Engine Glow Plug 5 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5419 PID: SPN: 5328 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 5 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 5 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5419.

Last Modified: 03-Dec-2014


Engine Glow Plug 6 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5421

Engine Glow Plug 6 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5421 PID: SPN: 5329 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 6 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 6 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5421.

Last Modified: 03-Dec-2014


Engine Glow Plug 7 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5422

Engine Glow Plug 7 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5422 PID: SPN: 5330 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 7 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 7 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5422.

Last Modified: 03-Dec-2014


Engine Glow Plug 8 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5423

Engine Glow Plug 8 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5423 PID: SPN: 5331 FMI: 2/2 LAMP: Amber SRT: | Engine Glow Plug 8 - Data Erratic, Intermittent, or Incorrect. Low current detected in the glow plug 8 heater circuit. | None on performance.
Glow Plug Controller Circuit

Circuit Description

Glow plugs provide rapid heating of the air inside the cylinder to aid in starting the engine during cold ambient conditions. The ceramic glow plug heating element extends into the combustion chamber area where the fuel will be injected. The voltage supplied through the Glow Plug Control Module is grounded through the cylinder head. When the Glow Plug Control Module commands the glow plugs to activate, the Wait to Start Lamp will be commanded by the ECM to turn ON. Allowing the Wait to Start Lamp to shut off before cranking the engine will ensure that the optimum conditions for starting are present in the cylinder.

The Glow Plug Control Module controls the timing and intensity of the glow plug outputs on the engine using data provided by the ECM through the J1939 datalink. The Glow Plug Control Module will not activate the glow plugs if the glow plug module reads a temperature greater than a calibrated amount. The Glow Plug Control Module receives fused power directly from the battery, and switched power through the smart power relay.

Component Location

Glow plugs are located in the cylinder heads where the heads are joined to the intake manifold, adjacent to the fuel rail on each bank.

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

An Open circuit has been detected on the glow plug

This fault code sets when the glow plug is outside of the acceptable range of resistance.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Glow plug operation will be disabled

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • If the fault code does not go inactive, it may be necessary to perform a 8 hour cold soak with the key OFF, then turn the keyswitch to the ON position so that the key ON portion of the diagnostic will run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning glow plug
  • Open circuit in the wiring harness
  • A Malfunction of the glow plug control module
Refer to Troubleshooting Fault Code 5423.

Last Modified: 03-Dec-2014


Engine Fuel Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 5534

Engine Fuel Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5534 PID: SPN: 94 FMI: 1/17 LAMP: Amber SRT: | Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level. Low fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply and ground to the fuel pressure sensor on the sensor supply circuit. The Fuel pressure sensor provides a signal to the ECM on the fuel pressure sensor signal circuit. This sensor monitors the fuel pressure from the low fuel pressure system (lift pump to the stage 2 filter).

Component Location

The fuel pressure and the Fuel temperature sensors are located in the stage 2 filter housing. The Stage 2 filter housing is located on the left side of the engine, above the valve cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Fuel inlet restrictions (filters, low pressure fuel lines, ECM check valve, OEM plumbing, etc.)
  • Fuel system prime (make sure fuel is in the tank(s) and the system is primed)
  • A malfunctioning fuel lift pump
  • Malfunctioning fuel delivery pressure sensor.
Refer to Troubleshooting Fault Code 5534.

Last Modified: 26-Jan-2015


Engine Cylinder 1 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5535

Engine Cylinder 1 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5535 PID: SPN: 5358 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 1 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5535.

Last Modified: 03-Dec-2014


Engine Cylinder 2 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5536

Engine Cylinder 2 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5536 PID: SPN: 5359 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 2 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5536.

Last Modified: 04-Dec-2014


Engine Cylinder 3 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5537

Engine Cylinder 3 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5537 PID: SPN: 5360 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 3 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5537.

Last Modified: 04-Dec-2014


Engine Cylinder 4 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5538

Engine Cylinder 4 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5538 PID: SPN: 5361 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 4 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5538.

Last Modified: 04-Dec-2014


Engine Cylinder 5 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5539

Engine Cylinder 5 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5539 PID: SPN: 5362 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 5 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5539.

Last Modified: 04-Dec-2014


Engine Cylinder 6 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5541

Engine Cylinder 6 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5541 PID: SPN: 5363 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 6 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5541.

Last Modified: 04-Dec-2014


Engine Cylinder 7 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5542

Engine Cylinder 7 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5542 PID: SPN: 5364 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 7 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5542.

Last Modified: 04-Dec-2014


Engine Cylinder 8 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5543

Engine Cylinder 8 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5543 PID: SPN: 5365 FMI: 2/2 LAMP: Amber SRT: | Engine Cylinder 8 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect. Cylinder fuel balancing has exceeded it correction limits. | Possible reduced engine performance.
Engine Control Module

Circuit Description

Fuel Balancing is intended to decrease variances in fuel quantity from cylinder to cylinder. The change in engine speed due to a single cylinder combustion is calculated. The ECM will correct the fuel injected into each cylinder to reduce the variance in engine speed from cylinder to cylinder.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fueling correction for this cylinder exceeded its allowable limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5543.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 7 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5544

Injector Solenoid Driver Cylinder 7 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5544 PID: SPN: 657 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 5544.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 8 - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5545

Injector Solenoid Driver Cylinder 8 - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5545 PID: SPN: 658 FMI: 7/7 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 - Mechanical System Not Responding or Out of Adjustment. The ECM has detected an error with the injection timing or quantity. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

The ECM uses diagnostic software to verify injector performance. At Idle, the rail pressure is set at 350 bar, each injector is fired. The diagnostic will monitor engine speed and Fueling for each individual injector. Fueling will be adjusted based on the change in engine speed. The adjustment in fueling must not exceed a calibratible limit.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is operating at idle.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fueling timing or quantity error for the specified injector.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code is intended to identify fueling quantity and timing issues.

Refer to Troubleshooting Fault Code 5545.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 1 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5546

Injector Solenoid Driver Cylinder 1 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5546 PID: SPN: 651 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5546.

Last Modified: 03-Dec-2014


Injector Solenoid Driver Cylinder 2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5547

Injector Solenoid Driver Cylinder 2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5547 PID: SPN: 652 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5547.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 3 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5548

Injector Solenoid Driver Cylinder 3 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5548 PID: SPN: 653 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5548.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 4 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5549

Injector Solenoid Driver Cylinder 4 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5549 PID: SPN: 654 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5549.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 5 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5551

Injector Solenoid Driver Cylinder 5 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5551 PID: SPN: 655 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5551.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 6 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5552

Injector Solenoid Driver Cylinder 6 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5552 PID: SPN: 656 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5552.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 7 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5553

Injector Solenoid Driver Cylinder 7 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5553 PID: SPN: 657 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5553.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 8 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5554

Injector Solenoid Driver Cylinder 8 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5554 PID: SPN: 658 FMI: 3/3 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 - Voltage Above Normal or Shorted to High Source. The ECM has detected the Injector Low side driver is shorted to battery. | Possible reduced engine performance.
Fuel Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to battery or a voltage source.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.
  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5554.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 1 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5555

Injector Solenoid Driver Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5555 PID: SPN: 651 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 1 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5555.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 2 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5556

Injector Solenoid Driver Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5556 PID: SPN: 652 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 2 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5556.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 3 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5557

Injector Solenoid Driver Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5557 PID: SPN: 653 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 3 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5557.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 4 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5558

Injector Solenoid Driver Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5558 PID: SPN: 654 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 4 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5558.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 5 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5559

Injector Solenoid Driver Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5559 PID: SPN: 655 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 5 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5559.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 6 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5561

Injector Solenoid Driver Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5561 PID: SPN: 656 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 6 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5561.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 7 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5562

Injector Solenoid Driver Cylinder 7 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5562 PID: SPN: 657 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 7 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5562.

Last Modified: 04-Dec-2014


Injector Solenoid Driver Cylinder 8 - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5563

Injector Solenoid Driver Cylinder 8 - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5563 PID: SPN: 658 FMI: 4/4 LAMP: Amber SRT: | Injector Solenoid Driver Cylinder 8 - Voltage Below Normal or Shorted to Low Source. The ECM has detected the Injector Low side driver is shorted to the High side or another injector. | Engine will misfire or run rough.
Injector Circuit

Circuit Description

The Fuel Injectors’ timing and quantity is controlled by the Engine Control Module (ECM). The ECM provides current to energize the actuator (Piezo) in the Fuel Injector. This causes the needle valve to rise and flow fuel into the combustion chamber. The ECM has an internal injector driver for each Group of Injectors. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM. Electrically, fuel injectors 1, 4, 6, and 7 make-up Group 1. Fuel Injectors 2, 3, 5, and 8 make-up Group 2.

Component Location

Injectors are located on top of the cylinder heads, down the middle of the valve covers. Physically, the Right Bank consists of injectors 1,3,5, and 7. The Left Bank consists of injectors 2, 4, 6, and 8.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the Injector Low side driver is shorted to another injector or a high side driver.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

Short circuit to voltage source in the engine harness.

  • Malfunctioning fuel injector
Refer to Troubleshooting Fault Code 5563.

Last Modified: 04-Dec-2014


Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source

FAULT CODE 5577

Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5577 PID: SPN: 6778 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5577.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5578

Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5578 PID: SPN: 6778 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5578.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5579

Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5579 PID: SPN: 6778 FMI: 0/16 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5579.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5581

Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5581 PID: SPN: 7329 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5581.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5582

Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5582 PID: SPN: 7854 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect. The aftertreatment particulate sensor detected intermittent supply voltage to the control module | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The power supply to the aftertreatment particulate sensor has been intermittently interrupted.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Damaged wiring harness
  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5582.

Last Modified: 23-Feb-2016


Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change

FAULT CODE 5583

Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5583 PID: SPN: 6777 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change. The aftertreatment particulate sensor reading is not valid. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor reading was not valid.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5583.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5584

Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5584 PID: SPN: 6773 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment. The aftertreatment particulate sensor was unable to enter measurement mode. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor heater was unable to maintain sensor regeneration temperature for a calibrated period of time.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5584.

Last Modified: 19-Feb-2016


Number of ECM Resets - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5618

Number of ECM Resets - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5618 PID: SPN: 152 FMI: 0/16 LAMP: None SRT: | Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect. Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
ECM

Circuit Description

The Engine Control Module (ECM) is the brains for engine operation. It interprets signals from sensors to determine actuator positions and fueling control. The ECM gather and maintain data in its internal memory. The ECM receives constant voltage from the batteries through unswitched battery connections. It also receives switched battery input through the vehicle key switch wire when the vehicle is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ECM power supply was removed before power-down parameters could be saved. The fault code will be active when the keyswitch is turned ON following the incomplete power-down event.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Power-down data like trip information, maintenance monitor, and fault information will not get saved to permanent memory when the keyswitch is turned OFF.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Improperly connected batteries.
  • ECM power supply or grounds
  • ECM malfunction.
Refer to Troubleshooting Fault Code 5618.

Last Modified: 15-Dec-2014


Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

FAULT CODE 5655

Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5655 PID: SPN: 4364 FMI: 11/31 LAMP: Amber SRT: | Aftertreatment SCR Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level. NOx conversion across the SCR catalyst is too low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) monitors the NOx concentration in the engine's exhaust gases using an aftertreatment intake NOx sensor and an aftertreatment outlet NOx sensor. By comparing these two values, the ECM is able to determine the conversion efficiency of the SCR catalyst and dosing system.

Component Location

The SCR catalyst is located in the vehicle's exhaust system, after the diesel particulate filter and decomposition tube.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the NOx conversion across the SCR catalyst was less than expected.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Troubleshoot all other active NOx sensor and SCR dosing system related fault codes before this fault.

Possible causes of this fault code include:

  • Malfunctioning diesel exhaust fluid dosing system
  • Exhaust system leaks
  • Malfunctioning SCR catalyst
  • Degraded, diluted, or incorrect diesel exhaust fluid
  • Diesel exhaust fluid deposits in the decomposition tube.
  • For unit that has come back into with repeat failures consider the possibility that customer is not using Ultra-low sulfur Diesel fuel
Refer to Troubleshooting Fault Code 5655.

Last Modified: 02-Dec-2015


Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Received Network Data in Error

FAULT CODE 5672

Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5672 PID: SPN: 3031 FMI: 2/19 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration. The received datalink message was not valid. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is part of the dosing unit which is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the SAE J1939 datalink message received from the aftertreatment diesel exhaust fluid tank temperature sensor was NOT valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank temperature sensor
Refer to Troubleshooting Fault Code 5672.

Last Modified: 04-Dec-2014


Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Above Normal or Shorted to High Source

FAULT CODE 5673

Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5673 PID: SPN: 520905 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Above Normal or Shorted to High Source. The Aftertreatment Diesel Exhaust Fluid Controller reported high supply voltage. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

A High voltage condition has been detected on the sensor supply circuit between the diesel exhaust fluid controller and the dosing unit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when manlfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5673.

Last Modified: 04-Dec-2014


Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5674

Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5674 PID: SPN: 520905 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Below Normal or Shorted to Low Source. The Aftertreatment Diesel Exhaust Fluid Controller reported low supply voltage. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

A Low voltage condition has been detected on the sensor supply circuit between the diesel exhaust fluid controller and the dosing unit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when manlfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5674.

Last Modified: 04-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5675

Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5675 PID: SPN: 5480 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature - Data Erratic, Intermittent, or Incorrect. An incorrect of inconsistent temperature reading has been detected internal to the Diesel Exhaust Fluid Controlle. | Possible reduced engine performance.
Dosing unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment Diesel exhaust Fluid controller detects that the internal temperature sensor circuit is irrational.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5675.

Last Modified: 04-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5676

Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5676 PID: SPN: 5480 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage or open circuit detected at the internal diesel exhaust fluid controller temperature sensor. | Possible reduced engine performance.
Dosing unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment Diesel exhaust fluid controller detects that the internal temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5676.

Last Modified: 04-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5677

Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5677 PID: SPN: 5480 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the internal diesel exhaust fluid controller temperature sensor. | Possible reduced engine performance.
Dosing unit

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The aftertreatment diesel exhaust fluid controller is mounted to the DEF dosing unit.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment Diesel exhaust fluid controller detects that the internal temperature sensor circuit is out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The aftertreatment diesel exhaust fluid controller is not serviceable, and must be replaced when malfunctioning.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 5677.

Last Modified: 04-Dec-2014


Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Received Network Data in Error

FAULT CODE 5678

Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5678 PID: SPN: 1761 FMI: 2/19 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Received Network Data in Error. The Aftertreatment Diesel Exhaust Fluid controller has indicated a malfunction of the DEF tank level sensor | Possible reduced engine performance.
Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid tank level sensor is used to monitor the aftertreatment diesel exhaust fluid level inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid tank level sensor is part of the dosing unit which is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Aftertreatment Diesel Exhaust Fluid Controller has indicated a malfunction of the Diesel Exhaust Fluid Tank Level sensor

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid tank level sensor
  • Tampering of the aftertreatment diesel exhaust fluid tank level sensor
Refer to Troubleshooting Fault Code 5678.

Last Modified: 04-Dec-2014


Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

FAULT CODE 5689

Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5689 PID: SPN: 3226 FMI: 11/11 LAMP: Amber SRT: | Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known. Signal indicates wrong reading or sensor tampering. | Engine torque output will be reduced.
Aftertreatment Outlet NOx Sensor Circuit

Circuit Description

The aftertreatment outlet NOx (nitrogen oxides) sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment outlet NOx sensor performs its own internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment outlet NOx sensor is used to measure the NOx emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment outlet NOx sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment outlet NOx sensor reading was not valid.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Engine torque will be reduced.

Conditions for Clearing the Fault Code

To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle.

  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

•An incorrectly installed aftertreatment outlet NOx sensor.

  • A malfunctioning aftertreatment outlet NOx sensor
Refer to Troubleshooting Fault Code 5689.

Last Modified: 11-Dec-2014


Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

FAULT CODE 5715

Aftertreatment 1 Diesel Particulate Filter Differential Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5715 PID: SPN: 3251 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor - Abnormal Rate of Change. The aftertreatment diesel particulate filter differential pressure sensor is reading an erratic value at initial key ON or during engine operation. | Active and stationary regeneration of the diesel particulate filter will be disabled.
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter differential pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter differential pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter differential pressure sensor signal circuit. This sensor signal voltage changes, based on the differential pressure across the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the change in the aftertreatment diesel particulate filter differential pressure was less than a calibratable value with changing engine conditions

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • A default value of the aftertreatment diesel particulate filter differential pressure is used.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter differential pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter differential pressure sensor signal or return wires
  • Disconnected or damaged aftertreatment diesel particulate filter differential pressure sensor tubes
  • Plugged aftertreatment differential pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned off.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5715.

Last Modified: 12-Oct-2015


Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

FAULT CODE 5716

Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5716 PID: SPN: 3610 FMI: 10/10 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change. The aftertreatment diesel particulate filter outlet pressure sensor is reading an erratic value at initial key ON or during engine operation. | Possible reduced engine performance.
Aftertreatment Diesel Particulate Filter Outlet Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the aftertreatment diesel particulate filter outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The aftertreatment diesel particulate filter outlet pressure sensor provides a signal to the ECM on the aftertreatment diesel particulate filter outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the outlet of the aftertreatment diesel particulate filter.

Component Location

The aftertreatment diesel particulate filter differential pressure sensor is mounted on the diesel particulate filter. It is a combination sensor that detects both diesel particulate filter differential pressure and outlet pressure. Refer to the original equipment manufacturer (OEM) service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the change in the aftertreatment diesel particulate filter outlet pressure was less than a calibratable value with changing engine conditions

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.

For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after four consecutive trips where the diagnostic runs and passes.

  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Stuck in-range aftertreatment diesel particulate filter outlet pressure sensor reading
  • High resistance in the aftertreatment diesel particulate filter outlet pressure sensor signal or return wires
  • Higher than expected diesel particulate filter outlet pressure
  • Excessive diesel exhaust fluid (DEF) deposits in the aftertreatment decomposition tube
  • Plugged aftertreatment outlet pressure sensor ports could cause this fault code if pressure is held in the port after the engine is turned OFF.

Note: It is possible to set this fault in a shop environment by performing a key cycle with the tailpipe connected to an exhaust ventilation system.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 5716.

Last Modified: 12-Oct-2015


Switched Output #2 - Voltage Above Normal or Shorted to High Source

FAULT CODE 5736

Switched Output #2 - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5736 PID: SPN: 6050 FMI: 3/3 LAMP: Amber SRT: | Switched Output #2 - Voltage Above Normal or Shorted to High Source. High voltage detected on output. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Power Relay Circuit

Circuit Description

The Power Relay provides voltage to the smart power sensors at key on. The Engine Control Module (ECM) controls the relay that switches on power to the Aftertreatment Temperature sensor modules, ammonia sensor, inlet and outlet NOx sensors.

Component Location

The power relay is located in the engine harness near the Engine Control Module.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high voltage on the control signal circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the harness.

A malfunctioning relay

Refer to Troubleshooting Fault Code 5736.

Last Modified: 11-Dec-2014


Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5792

Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5792 PID: SPN: 7321 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5792.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low

FAULT CODE 5837

Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5837 PID: SPN: 5835 FMI: 2/21 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low. An in-range low failure has been detected. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatement particulate matter sensor has detected the probe temperature value is not changing with conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 5837.

Last Modified: 19-Feb-2016


Aftertreatment 1 SCR Feedback Control Status - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 5868

Aftertreatment 1 SCR Feedback Control Status - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5868 PID: SPN: 4339 FMI: 7/7 LAMP: Amber SRT: | Aftertreatment 1 SCR Feedback Control Status - Condition Exists. The maximum dosing adjustment has been reached. | None on performance.
Engine Control Module (ECM)

Circuit Description

The SCR dosing system is an In-tank system with an integrated Dosing control unit (DCU) that controls the dosing pump and monitors Urea heating, level, quality, pressure and temperature. This Dosing system is powered by battery voltage and an initialization signal from the smart power relay. The (DCU) activates Priming, dosing, heating and purging of urea using data provided by the Engine Control module (ECM) via the J1939 datalink. The DCU performs its own diagnostics and reports malfunctions back to the ECM. The ECM then decodes the error and converts it to a fault code.

Component Location

The primary components of the SCR exhaust aftertreatment system are the SCR catalyst, diesel exhaust fluid (DEF) dosing unit, DEF controller, DEF dosing valve, DEF tank, decomposition tube, various DEF lines, intake NOx sensor, and outlet NOx sensor. The locations of these components will vary depending on the vehicle application and the OEM.

Conditions for Running the Diagnostics

This diagnostic has to meet specific engine and aftertreatment conditions to run and complete.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the adjusted aftertreatment diesel exhaust fluid dosing command based on the aftertreatment outlet NOx sensor has reached a maximum limit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

It is necessary to use the "Reset All Faults" command in INSITE™ electronic service tool to clear this fault and extinguish the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL).

Shop Talk

Possible causes for this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing system
  • A malfunctioning aftertreatment SCR temperature sensor module
Refer to Troubleshooting Fault Code 5868.

Last Modified: 04-Dec-2014


Engine Control Module Calibration Memory (ROM) Corruption - Root Cause Not Known

FAULT CODE 5874

Engine Control Module Calibration Memory (ROM) Corruption - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5874 PID: SPN: 630 FMI: 11/11 LAMP: Amber SRT: | Engine Control Module Calibration Memory (ROM) Corruption - Root Cause Not Known. The ECM detected an internal error within the module. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) contains microprocessors that calculates, interprets, and stores data from connected inputs and output devices. The ECM runs diagnostics to check its internal memory and software. If the memory or software becomes corrupted, a fault will be set.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Corrupted engine calibration
  • Incorrect ECM software
Refer to Troubleshooting Fault Code 5874.

Last Modified: 12-May-2015


Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5879

Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5879 PID: SPN: 3464 FMI: 3/3 LAMP: Amber SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage above normal, or shorted to high source. A short circuit to battery or open circuit has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position and the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to voltage when the actuator is commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for up to 5 minutes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to battery in the engine harness.
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 5879.

Last Modified: 04-Dec-2014


Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5881

Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5881 PID: SPN: 3464 FMI: 4/4 LAMP: Amber SRT: | Electronic Throttle Control Actuator Driver Circuit - Voltage below normal, or shorted to low source. A short circuit to ground has been detected in the engine intake air throttle actuator signal circuit. | Possible reduced engine performance.
Engine Intake Air Throttle Actuator Circuit

Circuit Description

The engine control module (ECM) controls the engine intake air throttle actuator. The ECM can open and close the throttle based on the operating condtions in order to regulate air flow to the engine.

Component Location

The engine intake air throttle actuator is mounted in the piping between the charge air cooler and intake manifold.

Conditions for Running the Diagnostics

This diagnostic runs when the engine intake air throttle actuator is being commanded ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine intake air throttle actuator signal is shorted to ground when the actuator is commanded ON.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Engine intake air throttle actuation will be disabled. The engine intake air throttle will default to the open position.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 5 minutes. After 5 minutes, shut OFF the engine, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine harness
  • A malfunctioning engine intake air throttle actuator
Refer to Troubleshooting Fault Code 5881.

Last Modified: 04-Dec-2014


Internal Monitor Processor Performance - Monitor Support Malfunction Detected - Condition Exists

FAULT CODE 5884

Internal Monitor Processor Performance - Monitor Support Malfunction Detected - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5884 PID: SPN: 520956 FMI: 11/31 LAMP: Amber SRT: | Internal Monitor Processor Performance - Monitor Support Malfunction Detected - Condition Exists. Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The Engine Control Module (ECM) contains microprocessors that calculates, interprets, and stores data from connected inputs and output devices. The ECM runs diagnostics to check its internal memory and software. If the memory or software becomes corrupted, a fault will be set.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Corrupted engine calibration
  • Incorrect ECM software
Refer to Troubleshooting Fault Code 5884.

Last Modified: 12-May-2015


Engine Charge Air Cooler Outlet Pressure - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5951

Engine Charge Air Cooler Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5951 PID: SPN: 2631 FMI: 2/2 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Pressure - Data Erratic, Intermittent, or Incorrect. The engine control module (ECM) has detected an engine charge air cooler outlet pressure signal that is too high or too low for present engine operating conditions. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Charge Air Cooler outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Charge Air Cooler outlet pressure sensor provides a signal to the ECM on the Charge Air Cooler outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure exiting the Charge Air Cooler.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

  • The first part of the diagnostic runs continuously while the keyswitch is in the ON posistion or the engine is running.
  • The second part of the diagnostic runs at key OFF.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor was reading higher or lower than expected at keyoff or during normal engine operation.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning intake manifold pressure/temperature sensor
  • A malfunctioning turbocharger compressor intake pressure/temperature sensor
  • Damaged engine harness
Refer to Troubleshooting Fault Code 5951.

Last Modified: 11-Dec-2014


Engine Charge Air Cooler Outlet Pressure - Voltage Above Normal or Shorted to High Source

FAULT CODE 5952

Engine Charge Air Cooler Outlet Pressure - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5952 PID: SPN: 2631 FMI: 3/3 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Pressure - Voltage Above Normal or Shorted to High Source. High voltage has been detected on the engine charge air cooler outlet pressure sensor circuit. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Charge Air Cooler outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Charge Air Cooler outlet pressure sensor provides a signal to the ECM on the Charge Air Cooler outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure exiting the Charge Air Cooler.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning intake manifold pressure sensor
  • A short circuit to voltage source in the engine harness
Refer to Troubleshooting Fault Code 5952.

Last Modified: 26-Jan-2015


Engine Charge Air Cooler Outlet Pressure - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5953

Engine Charge Air Cooler Outlet Pressure - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5953 PID: SPN: 2631 FMI: 4/4 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Pressure - Voltage Below Normal or Shorted to Low Source. Low voltage has been detected on the engine charge air cooler outlet pressure sensor circuit. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Charge Air Cooler outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Charge Air Cooler outlet pressure sensor provides a signal to the ECM on the Charge Air Cooler outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure exiting the Charge Air Cooler.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning intake manifold pressure sensor
  • A short circuit to ground in the engine harness
Refer to Troubleshooting Fault Code 5953.

Last Modified: 26-Jan-2015


Engine Charge Air Cooler Outlet Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6237

Engine Charge Air Cooler Outlet Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6237 PID: SPN: 2631 FMI: 0/16 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level. Signal indicates pressure above engine protection normal limit. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Charge Air Cooler outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Charge Air Cooler outlet pressure sensor provides a signal to the ECM on the Charge Air Cooler outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure exiting the Charge Air Cooler.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was higher than expected for the engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • A malfunctioning engine intake air throttle actuator
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 6237.

Last Modified: 11-Dec-2014


Engine Charge Air Cooler Outlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 6238

Engine Charge Air Cooler Outlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6238 PID: SPN: 2631 FMI: 1/18 LAMP: Amber SRT: | Engine Charge Air Cooler Outlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level. Engine charge air cooler outlet pressure is below the minimum operating limit. | Possible reduced engine performance.
Engine Charge Air Cooler Outlet Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the Charge Air Cooler outlet pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The Charge Air Cooler outlet pressure sensor provides a signal to the ECM on the Charge Air Cooler outlet pressure sensor signal circuit. This sensor signal voltage changes based on the pressure exiting the Charge Air Cooler.

Component Location

The Charge Air Cooler Outlet Pressure sensor is installed on the intake connection close to the charge air cooler outlet connection, just after the engine Intake throttle valve

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure reading was below the expected level for the engine operating conditions.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Leaks in the air intake system between the turbocharger and intake manifold
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 6238.

Last Modified: 11-Dec-2014


High Pressure Common Rail Fuel Pressure Relief Valve - Out of Calibration

FAULT CODE 6239

High Pressure Common Rail Fuel Pressure Relief Valve - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6239 PID: SPN: 5571 FMI: 13/13 LAMP: Amber SRT: | High Pressure Common Rail Fuel Pressure Relief Valve - Out of Calibration. The fuel pressure relief valve is outside calibrated limits. | Possible reduced engine performance.
Fuel Pressure Relief Valve Circuit

Circuit Description

The circuit is a pulse-width modulation (PWM) driver in the engine control module (ECM) that controls the high pressure common rail fuel pressure relief valve. The high pressure common rail fuel pressure relief valve is grounded in the ECM. The high pressure common rail fuel pressure relief valve is normally open. The PWM duty cycle to the high pressure common rail fuel pressure relief valve depends on the difference between desired rail pressure and sensed rail pressure.

Component Location

The high-pressure fuel pump is mounted to a flange on the cylinder block at the front of the engine between the cylinder heads. The fuel pump actuator is mounted on the fuel pump. The rail fuel pressure sensor is located on the right bank fuel rail. The fuel pressure relief valve is mounted on the left bank high pressure fuel rail.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected the fuel pressure relief valve closed-loop compensation value is outside of calibrated limits.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Exhaust Gas Recirculation (EGR) valve operation will be disabled.
  • Active and stationary regeneration of the diesel particulate filter will be disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Fuel filter plugging
  • A malfunctioning fuel pump actuator
  • malfunctioning fuel pressure sensor
  • A malfunctioning fuel pressure relief valve
  • Damaged wiring harness
Refer to Troubleshooting Fault Code 6239.

Last Modified: 11-Dec-2014


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 6256

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6256 PID: SPN: 168 FMI: 0/15 LAMP: None SRT: | Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level. ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6256.

Last Modified: 04-Dec-2014


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 6257

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6257 PID: SPN: 168 FMI: 1/17 LAMP: None SRT: | Battery 1 Voltage - Data Valid But Below Normal Operational Range - Moderately Severe Level. ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by the OEM harness. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • Verify that the ECM unswitched power supply is coming from the batteries and not the starter or other device. Check for possible weak batteries.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6257.

Last Modified: 04-Dec-2014


Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6261

Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6261 PID: SPN: 677 FMI: 3/3 LAMP: None SRT: | Starter Relay Driver Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was NOT at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.
  • The Starter Lockout feature will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a voltage when the signal is commanded off, it records this fault code. This fault code can be caused by:

  • Open circuit in the starter lockout relay, OEM harness, or connectors
  • Short circuit to a voltage source in the OEM harness or relay.

This fault can also be set active if the over crank protection feature (starter lockout) is enabled, but the engine/ECM is not wired to support it.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6261.

Last Modified: 11-Dec-2014


Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6262

Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6262 PID: SPN: 677 FMI: 4/4 LAMP: None SRT: | Starter Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source. Low voltage detected at starter lockout circuit. | Either the engine will not start or the engine will not have starter lockout protection.
Starter Lockout Relay Driver Circuit

Circuit Description

The starter lockout relay is controlled by the engine control module (ECM) through the starter lockout relay signal circuit. The relay prevents the starter from being engaged when the engine is running. The relay return circuit is dependent on OEM wiring. It can be wired back to the ECM on some vehicles or wired to chassis or block ground on others. Consult the OEM wiring diagram for return circuit details. The starter lockout relay circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

Component Location

The starter lockout relay is installed by the vehicle OEM. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the starter lockout relay pulse width modulated (PWM) signal was at system voltage when the pulse width modulated (PWM) signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The Starter Lockout feature will be disabled.
  • The ECM logs the fault code immediately when the diagnostic runs and fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The ECM monitors the voltage level on this circuit. If it detects a low voltage when the signal is commanded ON, it records this fault code. This fault code can be caused by a short circuit to ground in the starter lockout relay, OEM harness, or connectors.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6262.

Last Modified: 11-Dec-2014


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6263

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6263 PID: SPN: 647 FMI: 3/3 LAMP: None SRT: | Fan Control Circuit - Voltage Above Normal or Shorted to High Source. Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • An open circuit in the harness or fan control solenoid.
  • A short circuit to voltage source in the OEM harness.
  • A malfunctioning ECM.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6263.

Last Modified: 11-Aug-2016


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6264

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6264 PID: SPN: 647 FMI: 4/4 LAMP: None SRT: | Fan Control Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. INSITE™ electronic service tool can be used to determine which fan type is presently set up for use. The fan control circuit varies by the OEM. OEMs can use a solenoid return that is wired to the ECM or use a return that goes to engine block or chassis ground.

Component Location

The control solenoid location varies by OEM. Refer to the appropriate OEM service manual to determine the location.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

The fan control logic can be adjusted with INSITE™ electronic service tool. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with INSITE™ electronic service tool must match the hardware configuration on the vehicle.

This fault code is logged when the ECM commands 12 or 24-VDC to the fan control solenoid, but the voltage on the fan control signal circuit is less than 12 or 24-VDC. The low voltage on the signal circuit usually indicates a short circuit to ground in the harness or solenoid.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6264.

Last Modified: 11-Aug-2016


Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

FAULT CODE 6266

Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6266 PID: SPN: 5862 FMI: 14/14 LAMP: Amber SRT: | Aftertreatment SCR Intermediate Gas Temperature Sensor - Data erratic, intermittent or incorrect. The aftertreatment SCR intermediate temperature sensor reading is irrational. | Progressive power derate increasing in severity from time of alert.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic runs when the engine is running and exhaust flow is above a minimum level.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR intermediate temperature sensor signal was irrational for more than 5 minutes.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • To validate the repair, it may be necessary to operate the vehicle on a chassis dynamometer or to drive the vehicle in order to get the engine load high enough for the diagnostic to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR temperature sensor module
  • Tampering with the catalyst system
Refer to Troubleshooting Fault Code 6266.

Last Modified: 04-Dec-2014


SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data in Error

FAULT CODE 6417

SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6417 PID: SPN: 974 FMI: 2/19 LAMP: Amber SRT: | SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Position Sensor System - Received Network Data In Error. The OEM vehicle electronic control unit (VECU) detected a fault with the remote accelerator. | Remote accelerator will not operate.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) vehicle electronic control unit (VECU) or transmission electronic control unit (ECU) in the cab. Then component values and states from components such as sensors, accelerators, and switches can be transmitted from the OEM VECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM VECUs or transmission ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM VECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received a message from the OEM VECU via the J1939 data link, indicating the remote throttle signal wire or enable switch was shorted high or shorted low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault can occur when the OEM VECU detects an error on the remote throttle and or remote throttle enable switch. The ECM has been set up properly (components enabled and OEM VECU source addressed correctly) to receive multiplexed information for the remote throttle enable switch states and remote accelerator position over the J1939 data link from an OEM VECU, and the OEM VECU is transmitting the message for that component. Most OEM VECUs will not have the circuitry to detect a remote throttle switch error.

The two types of errors that can occur for this fault are:

  • The OEM VECU determines that the remote throttle signal line is shorted high or shorted low. This fault status is transmitted to the Cummins® ECM on the J1939 data link, which causes this fault to occur in the Cummins® ECM.
  • When the remote throttle enable switch has a shorted high or shorted low error detected by the OEM VECU, this fault status is transmitted to the ECM on the J1939 data link, which causes this fault to occur in the ECM. Most OEM VECUs will not incorporate fault detection on a switch.

NOTE: It is still possible to get a Fault Code 285 or 286, if there is an incorrect setup in the OEM VECU or Cummins® ECM for other components, or the remote throttle and remote throttle switch, or the data link is damaged. The OEM configurations must multiplex the remote throttle and remote throttle switch inputs together to allow the use of the J1939 multiplexing feature for these components. The INSITE™ electronic service tool can be used to monitor multiplexed components.

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6417.

Last Modified: 19-Feb-2016


Engine Camshaft Speed/Position Sensor - Special Instructions

FAULT CODE 6433

Engine Camshaft Speed/Position Sensor - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6433 PID: SPN: 723 FMI: 14/14 LAMP: Amber SRT: | Engine Camshaft Speed/Position Sensor - Special Instructions. The Camshaft and Crankshaft Speed/Position Sensor signals do not match. | Engine may not start.
Camshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the camshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As slots in the front of the camshaft gear move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the cam gear slots indicate to the ECM the position of the engine. This sensor is used as a backup sensor if the engine crankshaft position signal is lost.

Component Location

The camshaft position sensor is mounted on the right bank (exhaust cam) valve cover and can be seen from the front of the engine.

Conditions for Running the Diagnostics

This diagnostic runs immediately after the engine has been started for the first time after a timing reset.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • This fault code can not be cleared with INSITE™ electronic service tool.

Shop Talk

This fault can only be set after a timing reset has been performed from an electronic service tool. It indicates that the camshaft position signal is at least one tooth off from being timed correctly.

Possible causes of this fault code include:

  • Camshaft position sensor malfunction
  • Damaged camshaft gear.
  • Malfunctioning ECM
Refer to Troubleshooting Fault Code 6433.

Last Modified: 23-Jan-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted High

FAULT CODE 6622

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6622 PID: SPN: 4334 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted High. High pressure has been detected at the diesel exhaust fluid pressure sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was greater than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 6622.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted Low

FAULT CODE 6623

Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6623 PID: SPN: 4334 FMI: 2/21 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted Low. Low pressure has been detected at the diesel exhaust fluid pressure sensor. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs at initial key ON.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment diesel exhaust fluid pressure was less than a threshold.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 6623.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Below Normal or Open Circuit

FAULT CODE 6624

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6624 PID: SPN: 5745 FMI: 5/5 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Below Normal or Open Circuit. Low current or an open circuit has been detected at the dosing unit heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit detected an open circuit on the internal heater circuit.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 6624.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 6625

Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6625 PID: SPN: 5745 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Above Normal or Grounded Circuit. High current or a grounded circuit has been detected at the dosing unit heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Tank Heater Circuit

Circuit Description

The aftertreatment diesel exhaust fluid dosing unit communicates to the primary engine electronic control module (ECM) through the J1939 public data link network. The aftertreatment diesel exhaust fluid dosing unit also receives battery supply, keyswitch input, and ground from the OEM vehicle.

Component Location

The diesel exhaust fluid tank heater is located in the diesel exhaust fluid tank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when diesel exhaust fluid tank heating is being commanded.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit detected an internal error.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

Refer to Troubleshooting Fault Code 6625.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Above Normal or Grounded Circuit

FAULT CODE 6626

Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6626 PID: SPN: 4340 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Above Normal or Grounded Circuit. High current or a grounded circuit has been detected at the line heater circuit. | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Line Heater 1 Circuit

Circuit Description

The aftertreatment diesel exhaust fluid line heaters are used to defrost and/or prevent freezing of the diesel exhaust fluid lines.

Component Location

The aftertreatment diesel exhaust fluid line heater 1 is located on the supply line between the diesel exhaust fluid dosing unit and the diesel exhaust fluid dosing valve.

Conditions for Running the Diagnostics

This diagnostic runs when the keyswitch is in the ON position and line heating is commanded ON.

Conditions for Setting the Fault Codes

The Aftertreatment DEF dosing controller detected the DEF Line heater was shorted to ground.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • The line heater will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and then use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test found under ECM Diagnostic Tests.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault include:

  • Malfunctioning line heater
  • A short circuit to battery in the OEM harness

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.

For intermittent power supply and datalink communication issues with Aftertreatment Components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing or intermittent connections.

Refer to Troubleshooting Fault Code 6626.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Received Network Data in Error

FAULT CODE 6627

Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6627 PID: SPN: 4337 FMI: 2/19 LAMP: Amber SRT: | Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Received Network Data in Error. The received datalink message was invalid | Possible reduced engine performance.
Aftertreatment Diesel Exhaust Fluid Dosing Unit

Circuit Description

The aftertreatment diesel exhaust fluid tank temperature sensor is used to monitor the temperature of the aftertreatment diesel exhaust fluid inside the aftertreatment diesel exhaust fluid tank.

Component Location

The aftertreatment diesel exhaust fluid dosing temperature sensor is internal to the aftertreatment diesel exhaust fluid dosing unit and can not be service separately.

The aftertreatment diesel exhaust fluid dosing unit is located in the DEF tank

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel exhaust fluid dosing unit received an invalid message from the dosing unit temperature sensor.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment diesel exhaust fluid dosing unit
Refer to Troubleshooting Fault Code 6627.

Last Modified: 26-May-2015


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6642

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6642 PID: SPN: 5569 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit- Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6642.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6643

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6643 PID: SPN: 5569 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit- Voltage Above Normal or Shorted to High Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6643.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6644

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6644 PID: SPN: 5569 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit- Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6644.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 6645

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6645 PID: SPN: 5569 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit- Voltage Above Normal or Shorted to High Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6645.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6646

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6646 PID: SPN: 5569 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect. Erratic internal temperatures have been detected by the aftertreatment particulate sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor has detected a mismatch between the internal ECU temperature probes.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6646.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source

FAULT CODE 6647

Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6647 PID: SPN: 6780 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6647.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6648

Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6648 PID: SPN: 6780 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source. An internal circuit error has been detected by the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6648.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 6649

Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6649 PID: SPN: 6780 FMI: 2/2 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect. The aftertreatment particulate matter sensor has detected a temperature that is incorrect for the conditions. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An internal circuit error was detected in the aftertreatment particulate sensor assembly

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
  • Malfunctioning aftertreatment temperature sensors
Refer to Troubleshooting Fault Code 6649.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source

FAULT CODE 6651

Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6651 PID: SPN: 7854 FMI: 3/3 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source. The aftertreatment particulate sensor has detected high supply voltage. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The voltage to the aftertreatment particulate matter sensor is above a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
  • A damaged alternator causing high voltage
Refer to Troubleshooting Fault Code 6651.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source

FAULT CODE 6652

Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6652 PID: SPN: 7854 FMI: 4/4 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source. The aftertreatment particulate sensor has detected low supply voltage. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The voltage to the aftertreatment particulate matter sensor is below a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
  • Short or open circuit in the aftertreatment wiring harness
Refer to Troubleshooting Fault Code 6652.

Last Modified: 19-Feb-2016


Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Current Above Normal or Grounded Circuit

FAULT CODE 6653

Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Current Above Normal or Grounded Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6653 PID: SPN: 7854 FMI: 6/6 LAMP: Amber SRT: | Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Current Above Normal or Grounded Circuit. The aftertreatment particulate sensor has detected high supply current. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment particulate matter sensor has detected low resistance in its power supply.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Malfunctioning aftertreatment particulate matter sensor
Refer to Troubleshooting Fault Code 6653.

Last Modified: 19-Feb-2016


Aftertreatment 1 Particulate Sensor - Abnormal Update Rate

FAULT CODE 6688

Aftertreatment 1 Particulate Sensor - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6688 PID: SPN: 5835 FMI: 9/9 LAMP: Amber SRT: | Aftertreatment 1 Particulate Sensor - Abnormal Update Rate. No communication or an invalid data transfer rate detected on the J1939 data link between the ECM and the aftertreatment particulate matter sensor. | Possible reduced engine performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the aftertreatment particulate matter sensor via the J1939 data link.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes for this fault include:

  • Sensor supply wire open or shorted to ground

Sensor return wire open.

  • An open or short circuit in the SAE J1939 datalink circuit
  • Malfunctioning aftertreatment particulate matter sensor

For intermittent power supply and data link communication issues with aftertreatment components, it is highly recommended that the OEM Power Distribution Center fuses and relays be thoroughly checked for loose, missing, or intermittent connections.

Refer to Troubleshooting Fault Code 6688.

Last Modified: 19-Feb-2016


Engine Desired Air Fuel Ratio - Data Not Rational - Drifted High

FAULT CODE 6689

Engine Desired Air Fuel Ratio - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6689 PID: SPN: 6392 FMI: 2/20 LAMP: Amber SRT: | Engine Desired Air Fuel Ratio - Data Not Rational - Drifted High. Measured air fuel ratio is higher than expected. | Possible reduced engine performance.
ECM

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The measured air fuel ratio was above the desired air fuel ratio by more than a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Malfunctioning fuel injectors
Refer to Troubleshooting Fault Code 6689.

Last Modified: 04-May-2017


Engine Desired Air Fuel Ratio - Data Not Rational - Drifted Low

FAULT CODE 6691

Engine Desired Air Fuel Ratio - Data Not Rational - Drifted Low

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6691 PID: SPN: 6392 FMI: 2/21 LAMP: Amber SRT: | Engine Desired Air Fuel Ratio - Data Not Rational - Drifted Low. Measured air fuel ratio is lower than expected. | Possible reduced engine performance.
ECM

Circuit Description

The aftertreatment 1 intake NOx sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment 1 intake NOx sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The NOx sensor is permanently attached to the NOx control module. They are serviced as a single component and can not be replaced individually. The aftertreatment 1 intake NOx sensor is used to measure the NOx emissions at the engine exhaust outlet connection.

Component Location

The aftertreatment intake NOx sensor is mounted near the inlet of the DOC.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The measured air fuel ratio was below the desired air fuel ratio by more than a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips .

Conditions for Clearing the Fault Code

  • To validate the repair using a Diagnostic Road Test, utilize a route that incorporates both stop and go city type driving and steady state highway type driving. It may be necessary to load the unit for certain diagnostics in the ECM to run.
  • To validate the repair using a Chassis Dynamometer, utilize a routine that incorporates acceleration and motoring events, steady state highway type operation, and load. This will simulate normal driving and allow the diagnostics in the ECM to run.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The Engine Control Module (ECM) will turn off the malfunction indicator lamp (MIL) after 3 consecutive ignition cycles that the diagnostic runs and passes.
  • The Reset All Faults command in the electronic service tool and be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • Damaged aftertreatment intake NOx sensor
  • Malfunctioning fuel injectors
Refer to Troubleshooting Fault Code 6691.

Last Modified: 04-May-2017


Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6735

Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6735 PID: SPN: 5569 FMI: 0/16 LAMP: None SRT: | Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level. High internal temperature detected in the aftertreatment diesel particulate filter soot sensor module. | None on performance.
SAE J1939 Datalink

Circuit Description

The aftertreatment particulate matter sensor is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The aftertreatment particulate matter sensor performs internal diagnostics and reports malfunctions back to the primary ECM using the J1939 data link. The particulate matter sensor is permanently attached to the particulate matter control module. They are serviced as a single component and can not be replaced individually. The aftertreatment particulate matter sensor is used to measure the soot emissions at the outlet of the aftertreatment system.

Component Location

The aftertreatment particulate matter sensor location can vary depending on engine application. It is usually located in the exhaust system at the outlet of the selective catalytic reduction (SCR) catalyst.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The aftertreatment diesel particulate filter soot sensor module reported the internal circuit board temperature was too high.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

This fault code indicates the internal temperature of the aftertreatment diesel particulate filter soot sensor module was too high. Troubleshoot the exhaust system for leaks, missing heat shields, or dirt and debris that could lead to overheating of the aftertreatment diesel particulate filter soot sensor module.

Refer to Troubleshooting Fault Code 6735.

Last Modified: 19-Feb-2016


Aftertreatment 1 SCR Intake Temperature Sensor - Data Not Rational - Drifted High

FAULT CODE 6881

Aftertreatment 1 SCR Intake Temperature Sensor - Data Not Rational - Drifted High

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6881 PID: SPN: 4360 FMI: 2/20 LAMP: Amber SRT: | Aftertreatment SCR Intermediate Gas Temperature Sensor - Data erratic, intermittent or incorrect. The aftertreatment SCR intermediate temperature sensor reading is irrational. | Possible reduced engine performance.
Aftertreatment SCR Temperature Sensor Module

Circuit Description

The aftertreatment SCR (selective catalytic reduction) temperature sensor module is a smart device that communicates with the engine control module via the J1939 data link. The aftertreatment SCR temperature sensor module performs its own internal diagnostics and reports malfunctions back to the engine control module using the J1939 data link. The aftertreatment SCR temperature sensor module is used to measure the aftertreatment SCR intermediate temperature and aftertreatment SCR outlet temperature. The temperature probes are permanently attached to the aftertreatment SCR temperature sensor module and can not be replaced individually.

Component Location

The aftertreatment SCR temperature sensor module is mounted on the aftertreatment SCR catalyst.

Conditions for Running the Diagnostics

This diagnostic is designed to run at key-on after the ECM has been key-off for 8 hours.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the aftertreatment SCR Intermediate temperature sensor reading was out of range high.

The ECM must be off for 8 hours for the diagnostic to run. Once key-on occurs the diagnostic compares the aftertreatment temperature sensor to a threshold if the aftertreatment is above this temperature a fault is set.

Action Taken When the Fault Code is Active

The ECM illuminates the amber CHECK ENGINE lamp and/or Malfunction Indicator Lamp (MIL) after the diagnostic fails on two consecutive trips.

  • Diesel exhaust fluid injection into the aftertreatment system is disabled.
  • Engine torque will be reduced if the engine is operated for an extended period of time with this fault active.

Conditions for Clearing the Fault Code

  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning aftertreatment SCR intermediate temperature sensor

Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM

Refer to Troubleshooting Fault Code 6881.

Last Modified: 04-May-2017


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 (3-Wire Sensor) PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source. High signal voltage detected at engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the OEM harness
  • An open circuit in the OEM harness
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 195 (3-Wire Sensor).

Last Modified: 26-Jan-2015


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196 (3-Wire Sensor)

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 (3-Wire Sensor) PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the engine coolant level circuit. | None on performance.
Engine Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp and/or the Malfunction Indicator Lamp (MIL) immediately when the diagnostic runs and fails.
  • No engine protection will be available for low coolant level.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • For On-Board Diagnostics (OBD) engines, the ECM will extinguish the Malfunction Indicator Lamp (MIL) after three consecutive trips where the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • An open circuit in the OEM harness
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 (3-Wire Sensor).

Last Modified: 26-Jan-2015


Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2222 (2-Wire Sensor)

Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2222 (2-Wire Sensor) PID: P96 SPN: 96 FMI: 3/3 LAMP: Amber SRT: | Fuel Level (Main Tank) Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected at the fuel level sensor circuit. | None on performance.
Engine Contol Module

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the OEM harness
  • A short circuit to battery in the OEM harness
  • A malfunctioning fuel level sensor
Refer to Troubleshooting Fault Code 2222 (2-Wire Sensor).

Last Modified: 21-Nov-2014


Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2222 (3-Wire Sensor)

Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2222 (3-Wire Sensor) PID: P96 SPN: 96 FMI: 3/3 LAMP: Amber SRT: | Fuel Level (Main Tank) Sensor Circuit - Voltage above normal, or shorted to high source. High signal voltage detected at the fuel level sensor circuit. | None on performance.
Fuel Level Sensor Circuit

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel level sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to voltage source in the OEM harness
  • An open circuit in the OEM harness
  • A malfunctioning fuel level sensor
Refer to Troubleshooting Fault Code 2222 (3-Wire Sensor).

Last Modified: 11-Dec-2014


Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2223 (2-Wire Sensor)

Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2223 (2-Wire Sensor) PID: P96 SPN: 96 FMI: 4/4 LAMP: Amber SRT: | Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel level sensor circuit. | None on performance.
Engine Control Module

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • A malfunctioning fuel level sensor

Many vehicles are equipped with a multiplexed fuel level sensor. Be sure to check the features and parameter settings are correct for the vehicle configuration.

Refer to Troubleshooting Fault Code 2223 (2-Wire Sensor).

Last Modified: 21-Nov-2014


Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2223 (3-Wire Sensor)

Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2223 (3-Wire Sensor) PID: P96 SPN: 96 FMI: 4/4 LAMP: Amber SRT: | Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source. Low signal voltage detected at the fuel level sensor circuit. | None on performance.
Fuel Level Sensor Circuit

Circuit Description

The fuel level sensor is used to monitor the amount of diesel fuel in the vehicle's fuel tank(s).

Component Location

The fuel level sensor is an OEM component. Refer to the OEM service manual for component location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the keyswitch is in the ON position or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel level sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it idle for 1 minute.
  • The fault code status displayed by INSITE™ electronic service tool will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The Reset All Faults command in INSITE™ electronic service tool can be used to clear active and inactive faults, as well as extinguish the MIL for OBD applications.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the OEM harness
  • A malfunctioning fuel level sensor

Many vehicles are equipped with a multiplexed fuel level sensor. Be sure to check the features and parameter settings are correct for the vehicle configuration.

Refer to Troubleshooting Fault Code 2223 (3-Wire Sensor).

Last Modified: 11-Dec-2014


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than 3 counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM.

Guided Step 1A - Check the ECM.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 111 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn the keyswitch ON.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than 3 counts?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2A

Repair complete

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 131 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 43367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 active?
 | STEP 1B. Check for an active fault code. | Fault Code 131 active?
STEP 2. | Check the accelerator pedal or lever position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 132 active and Fault Code 131 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 131 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 2185.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal or lever position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position sensor +5 SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active and Fault Code 131 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal or lever.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 132 - Accelerator Pedal or Lever Position Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB.ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2185 or 2186 active?
 | STEP 1B. Check for an active fault code. | Fault Code 132 active?
STEP 2. | Check the accelerator pedal or lever position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 131 active and Fault Code 132 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 132 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 132 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 or 2186 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage from the accelerator pedal position +5 volt SUPPLY pin to the accelerator pedal position RETURN pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the accelerator pedal position +5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131 active and Fault Code 132 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 active?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 132 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2017


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High in Section TS, in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate faultcode troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for QSK78, QSK23, and ISV5.0 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4327291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for ISV5.0 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except IISV5.0 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2017


FAULT CODE 186 - Wait-to-Start Lamp Driver Circuit - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the original equipment manufacture (OEM) wiring harness. |
 | STEP 1A. Check for open circuit. | Less than 10 ohms?
 | STEP 1B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 2. | Check the WAIT TO START lamp. |
 | STEP 2A. Inspect the WAIT TO START lamp. | Lamp not burned out?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the OEM wiring harness.

Guided Step 1A - Check for open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the WAIT TO START lamp from the OEM wiring harness.
  • Disconnect the OEM wiring harness from the ECM.

Action

All measurements are to be made on the OEM wiring harness, not the ECM or the WAIT TO START lamp.

  • Inspect the pins and connector for damage. Refer to Procedure 019-361 in Section 19.
  • Measure the resistance from the WAIT TO START lamp pin at the WAIT TO START lamp OEM harness connector to the WAIT TO START lamp pin at the ECM connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM wiring harness.

Repair or replace the OEM wiring harness.

Go to 1B

Go to 3A

Guided Step 1B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the WAIT TO START lamp from the OEM wiring harness.
  • Disconnect the OEM wiring harness from the ECM.

Action

All measurements are to be made on the OEM wiring harness, not the ECM or the WAIT TO START lamp.

  • Measure the resistance between the WAIT TO START lamp pin at the WAIT TO START lamp OEM harness connector and all others pins in the OEM wiring harness ECM connector side.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM wiring harness.

Repair or replace the OEM wiring harness.

Go to 2A

Go to 3A

Guided Step 2 - Check the WAIT TO START lamp.

Guided Step 2A - Inspect the WAIT TO START lamp.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the WAIT TO START lamp.

Lamp not burned out?

YES NO

Replace the WAIT TO START lamp bulb. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 02-May-2017


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K105 | 4326157
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K108 | 4332823
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K116 | 4367444
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K111 | 4358519
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K117 | 4367449
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K121 | 4388645
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss symptom troubleshooting tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 197 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 15-May-2017


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

WARNING

Do not operate a diesel engine where there are or can be combustible vapors. These vapors can be sucked through the air intake system and cause engine acceleration and over speeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of over speeding where an engine, due to the application, is operating in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. The equipment owner and operator are responsible for safe operation in a hostile environment. Contact a Cummins® Authorized Repair Location for further information.
CAUTION

If the engine speed stays above 3500 rpm, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Motoring down hill?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1E. Test the vehicle. | Fault Code 234 inactive?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Motoring down hill?
YES NO
No Repair

Check for engine damage.

  • Electronics are ok.
  • Check the base engine for damage due to overspeed condition.

Go to 1B

Go to 2A

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a fuel-controlled event where the engine rapidly accelerated to or past 3400 rpm, followed by moderate deceleration to 3400 rpm.

Alternate fuel source?
YES NO

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Engine is operating.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 1D

Troubleshoot Fault Codes 689 and 778.

Guided Step 1D - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.

Action

Check for active Fault Code 234 when the engine is not operating above 3200 rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1E

Go to 2A

Guided Step 1E - Test the vehicle.

Conditions

  • Turn keyswitch ON.

Action

Test the vehicle in a road test or the vessel in a sea trail to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-May-2017


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K117 | 4367449
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 L121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 L121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 241 - Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
STEP 2. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the OEM harness pins and the sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the OEM harness connector pins at the ECM. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check for additional OEM devices. |
 | STEP 3A. Check the vehicle speed sensor circuit for additional devices. | Extra devices?
 | STEP 3B. Check for the gear slipping on the shaft. | Gear or tone wheel damaged or slips?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Transmission Setup -Top Gear Transmission Ratio
  • Vehicle Speed Source -Rear Axle Ratio
  • Vehicle Speed Source -Tire Size
  • Vehicle Speed Source - Vehicle Speed Sensor Type

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 2A

Go to 4A

Guided Step 2 - Check the OEM harness.

Guided Step 2A - Inspect the OEM harness pins and the sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Repair the damaged connector pins.
  • Repair or replace the engine harness with the damaged pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the OEM harness connector pins at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter, check for an open circuit in the OEM harness.

  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (+) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.
  • Measure the resistance of the magnetic vehicle speed sensor SIGNAL (-) wire between the OEM harness ECM connector and the OEM harness magnetic vehicle speed sensor connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 4A

Guided Step 2D - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Check for a short circuit to ground on the magnetic vehicle speed sensor SIGNAL (+) and magnetic vehicle speed sensor SIGNAL (-) circuit in the OEM harness.

  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (+) at the ECM connector and engine block ground.
  • Measure the resistance between the magnetic vehicle speed sensor SIGNAL (-) at the ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the OEM harness from the vehicle speed sensor.

Action

Use a multimeter to check for a pin-to-pin short circuit in the OEM harness.

  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (+) pin at the OEM harness ECM connector and all other pins in the connector.
  • Measure the resistance and check for a short circuit between the magnetic vehicle speed sensor SIGNAL (-) pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

  • Replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check for additional OEM devices.

Guided Step 3A - Check the vehicle speed sensor circuit for additional devices.

Conditions

  • Turn keyswitch OFF.

Action

Check the vehicle speed sensor circuit.

  • Inspect the vehicle speed sensor circuit for any additional or extra devices that can interfere with the speed signal.

Extra devices?
YES NO

Remove the device or see equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for the gear slipping on the shaft.

Conditions

  • Turn keyswitch OFF.
  • Remove the vehicle speed sensor from the transmission.

Action

Check for the gear slipping.

  • Inspect the gear or tone wheel on the rear of the transmission where the speed sensor picks up the speed signal. Make sure the gear or tone wheel is not damaged or slipping on the shaft.

Gear or tone wheel damaged or slips?
YES NO

See equipment manufacturer service information to repair or replace the gear or tone wheel.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Nov-2015


FAULT CODE 249 - Ambient Air Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 249 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 256 active and Fault Code 249 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 249 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and the ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the ambient air temperature SIGNAL pin and the ambient air temperature RETURN pin at the sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active and Fault Code 249 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES NO

A damaged ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use a wiring diagram for pin identificaton and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 256 - Ambient Air Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 256 inactive?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active and Fault Code 256 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 256 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 256 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active and Fault Code 256 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the ambient air temperature sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

Replace the ambient air temperature sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, VECU, and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Refer to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-May-2017


FAULT CODE 286 - SAE J1939 Multiplexing Configuration Error - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 334 - Engine Coolant Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | ISF2.8 CM2220 AN | 4022178
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 AN | 4021708
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2150 SN | 4022190
Coolant Thermostat | Refer to Procedure 008-013 | ISM11 CM876 SN | 4022196
Coolant Thermostat | Refer to Procedure 008-013 | ISZ13 CM2150 | 4022133
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2250 | 4022254
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B105 | 4332778
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L102 | 4332796
Coolant Thermostat | Refer to Procedure 008-013 | ISC8.3 and ISL9 CM2250 | 4022257
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2250 and GX CM2250 | 4022250
Coolant Thermostat | Refer to Procedure 008-013 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L101 | 4310787
Coolant Thermostat | Refer to Procedure 008-013 | ISX12 CM2350 X102 | 4310646
Coolant Thermostat | Refer to Procedure 008-013 | ISX15 CM2350 X101 | 4310641
Coolant Thermostat | Refer to Procedure 008-013 | ISB4.5 CM2350 B104 | 4332646
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B103 | 4332641
Coolant Thermostat | Refer to Procedure 008-013 | ISV5.0 CM3230 V104 | 4367291
Coolant Thermostat | Refer to Procedure 008-013 | ISL9 CM2350 L111 | 4367223
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2350 F109 | 4367218
Coolant Thermostat | Refer to Procedure 008-013 | QSF3.8 CM2350 F107 | 4367316
Coolant Thermostat | Refer to Procedure 008-013 | QSB4.5 CM2350 B106 | 4367376
Coolant Thermostat | Refer to Procedure 008-013 | QSG12 CM2350 G110 | 4367323
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 F110 | 4358480
Coolant Thermostat | Refer to Procedure 008-013 | ISG11 CM2880 G106 | 4332695
Coolant Thermostat | Refer to Procedure 008-013 | ISG12 CM2880 G106 | 4332690
Coolant Thermostat | Refer to Procedure 008-013 | ISB5.9 CM2880 B127 | 4383645
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2880 L112 | 4388493
Coolant Thermostat | Refer to Procedure 008-013 | ISL9.5 CM2150 SN | 4310608
Coolant Thermostat | Refer to Procedure 008-013 | ISB3.9 CM2220 B107 | 4310792
Coolant Thermostat | Refer to Procedure 008-013 | ISB/ISD4.5 CM2150 B119 | 4358465
Coolant Thermostat | Refer to Procedure 008-013 | ISB/ISD6.7 CM2150 B120 | 4358470
Coolant Thermostat | Refer to Procedure 008-013 | ISL8.9 CM2150 L110 | 4358475
Coolant Thermostat | Refer to Procedure 008-013 | ISF3.8 CM2220 F116 | 4383664
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B130 | 4388668
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L118 | 4388673
Coolant Thermostat | Refer to Procedure 008-013 | ISB6.7 CM2350 B142 | 5411131
Coolant Thermostat | Refer to Procedure 008-013 | F3.8 CM2350 F120B | 5411237
Coolant Thermostat | Refer to Procedure 008-013 | X15 CM2350 X114B | 5411181
Coolant Thermostat | Refer to Procedure 008-013 | X15 CM2350 X116B | 5411186
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B121B | 5411223
Coolant Thermostat | Refer to Procedure 008-013 | B4.5 CM2350 B129B | 5411247
Coolant Thermostat | Refer to Procedure 008-013 | B4.5 CM2350 B147B | 5411252
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B135B | 5411257
Coolant Thermostat | Refer to Procedure 008-013 | B6.7 CM2350 B148B | 5411262
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L119B | 5411267
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L116B | 5411330
Coolant Thermostat | Refer to Procedure 008-013 | QSB6.7 CM2350 B145 | 5411273
Coolant Thermostat | Refer to Procedure 008-013 | QSL9 CM2350 L122 | 5411278
Coolant Thermostat | Refer to Procedure 008-013 | QSB4.5 CM2350 B144 | 5411382
Coolant Thermostat | Refer to Procedure 008-013 | L9 CM2350 L123B | 5411465
Coolant Thermostat | Refer to Procedure 008-013 | QSX15 CM2350 X118 | 5467247
Coolant Thermostat | Refer to Procedure 008-013 | QSG12 CM2350 G113 | 5467252
Coolant Thermostat | Refer to Procedure 008-013 | QSF3.8 CM2350 F125 | 5411494
Coolant Thermostat | Refer to Procedure 008-013 | ISF4.5 CM2220 F123 | 5411320
Coolant Thermostat | Refer to Procedure 008-013 | ISF2.8 CM2220 F101 | 4310846
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN | 4021704
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 AN | 4022178
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG11 CM2880 G106 | 4332695
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISG12 CM2880 G107 | 4332690
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B127 | 4383645
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2880 L112 | 4388493
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9.5 CM2880 SN | 4310608
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB3.9 CM2220 B107 | 4310792
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F116 | 4383664
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF4.5 CM2220 F123 | 5411320
Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISG11 CM28880 G106 | 4332695
Engine Control Module | Refer to Procedure 019-031 | ISG12 CM28880 G107 | 4332690
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B127 | 4383645
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2880 L112 | 4388493
Engine Control Module | Refer to Procedure 019-031 | ISL9.5 CM2150 SN | 4310608
Engine Control Module | Refer to Procedure 019-031 | ISB3.9 CM2220 B107 | 4310792
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISG11 CM2880 G106 | 4332695
Engine Wiring Harness | Refer to Procedure 019-043 | ISG12 CM2880 G107 | 4332690
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B127 | 4383645
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2880 L112 | 4388493
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9.5 CM2150 SN | 4310608
Engine Wiring Harness | Refer to Procedure 019-043 | ISB3.9 CM2220 B107 | 4310792
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 144 and 145. | Fault Code 144 or 145 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the thermostat. |
 | STEP 2A. Check the thermostat. | Thermostat operate correctly?
STEP 3. | Check the engine coolant temperature sensor and circuit. |
 | STEP 3A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 144 active?
 | STEP 3C. Check the circuit response. | Fault Code 145 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 144 active?
 | STEP 4C. Check the circuit response. | Fault Code 145 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 144 and 145.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 or 145 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to Fault Code 144 or 145 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the thermostat.

Guided Step 2A - Check the thermostat.

Conditions

  • Turn keyswitch OFF.

Action

Check the thermostat for correct operation.

Refer to Procedure 008-013 in the Associated Procedures Table.

Thermostat operate correctly?
YES NO
No Repair

Replace the thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the engine coolant temperature sensor and circuit.

Guided Step 3A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor and connector pins.

Action

Inspect the engine harness and engine coolant temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 23-May-2017


FAULT CODE 338 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for active fault codes. | Fault Code 338 active?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the idle shutdown relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins.
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 338 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic setting.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the idle shutdown relay. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the idle shutdown relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance between the idle shutdown relay RETURN pin at the idle shutdown relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected. Use the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector idle shutdown relay RETURN pin and the OEM harness idle shutdown relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the idle shutdown SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 338 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 339 - Idle Shutdown Vehicle Accessories Relay Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and electronic settings. |
 | STEP 1A. Check for active fault codes. | Fault Code 339 active?
 | STEP 1B. Check the ECM setup for idle shutdown accessory relay. | INSITE™ electronic service tool Idle Shutdown feature set up correctly?
STEP 2. | Check the idle shutdown relay and circuit. |
 | STEP 2A. Inspect the idle shutdown relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the idle shutdown relay for an open circuit. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the idle shutdown relay. |
 | STEP 2C. Check the idle shutdown relay diagnostic supply voltage, supply line, and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 339 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and electronic settings.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for idle shutdown accessory relay.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the Idle Shutdown feature.

  • If the vehicle has an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Installed”.
  • If the vehicle does not have an idle shutdown relay installed, INSITE™ electronic service tool parameter Shutdown Accessory Relay must be set to “Not Installed”.

INSITE™ electronic service tool Idle Shutdown feature set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the Idle Shutdown feature setup.

Go to 2A

Go to 4A

Guided Step 2 - Check the idle shutdown relay and circuit.

Guided Step 2A - Inspect the idle shutdown relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Inspect the OEM harness and idle shutdown relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the idle shutdown relay for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check the idle shutdown relay resistance.

  • Measure the resistance between the idle shutdown relay SIGNAL pin and the idle shutdown relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the idle shutdown relay.

See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the idle shutdown relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the idle shutdown relay SIGNAL pin and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the idle shutdown relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the idle shutdown relay diagnostic supply voltage, supply line, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the idle shutdown relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Use the OEM wiring diagram for connector pin identification.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the idle shutdown relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM harness ECM connector and ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the idle shutdown relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the idle shutdown relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 339 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Jan-2017


FAULT CODE 343 - Engine Control Module Warning Internal Hardware Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 343 active or more than three inactive counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Recalibrate the ECM. |
 | STEP 4A. Recalibrate the ECM. | Fault Code 343 active after recalibrating the ECM?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 343 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 5A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Inspect the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery supply (+) pin of the engine harness ECM battery supply stub connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 5A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM battery supply stub from the ECM connector.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the engine harness ECM battery supply stub connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the engine harness ECM battery supply stub connector and the negative battery connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 5A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch input.

  • Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM connector.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 5A

Guided Step 4 - Recalibrate the ECM.

Guided Step 4A - Recalibrate the ECM

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a short circuit to ground.

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 343 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 418 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for Fault Code 418. | Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 or 429 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 418.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 418.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 418 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Drain the water from the fuel filter.

If Fault Code 418 remains active, a malfunction in the sensor and/or connector may have occurred. Repair or replace the sensor and/or connector, as necessary.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 12-Jun-2017


FAULT CODE 428 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Water in Fuel Sensor | Refer to Procedure 019-127 | ISV5.0 CM3230 V104 | 4367291
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F103 | 4310839
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 SN | 4022190
Water in Fuel Sensor | Refer to Procedure 019-127 | ISM11 CM876 SN | 4022196
Water in Fuel Sensor | Refer to Procedure 019-127 | ISZ13 CM2150 | 4022133
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2250 | 4022254
Water in Fuel Sensor | Refer to Procedure 019-127 | ISC8.3 and ISL9 CM2250 | 4022257
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 GX CM2250 | 4022250
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12/ISX11.9 CM2250 | 2883445
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 | 4022256
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 | 4022255
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 EC | 2883621
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX11.9 CM2250 ECF | 2883561
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 ECF | 2883557
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 ECF | 4310661
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 | 4310664
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 EC | 2883647
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B101 | 2883567
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L101 | 4310787
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B105 | 4332778
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L102 | 4332796
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L107 | 4367386
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12 CM2350 X102 | 4310646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2350 X101 | 4310641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 SN | 4310736
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F101 | 4310846
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5 CM2350 B104 | 4332646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B103 | 4332641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD4.5 CM2150 B119 | 4358465
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2150 B120 | 4358470
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 L110 | 4358475
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F110 | 4358480
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L111 | 4367223
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z101 | 4358364
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z102 | 4358369
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F107 | 4367316
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B106 | 4367376
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B112 | 4358498
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2350 F109 | 4367218
Water in Fuel Sensor | Refer to Procedure 019-127 | F3.8 CM2350 F120B | 5411237
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G110 | 4367323
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F114 | 4383734
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 B128 | 4388601
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 L115 | 4388626
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F117 | 4388578
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F118 | 4388708
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK3.8 CM2350 F119 | 4388703
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B130 | 4388668
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L118 | 4388673
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B122 | 4388767
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 X115 | 4388739
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2250 B131 | 4388774
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 B137 | 5411058
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F126 | 5411159
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X114B | 5411181
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X116B | 5411186
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B121B | 5411223
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B142 | 5411131
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B129B | 5411247
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B147B | 5411252
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B135B | 5411257
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B148B | 5411262
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L119B | 5411267
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L116B | 5411330
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B145 | 5411273
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L122 | 5411278
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B144 | 5411382
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L123B | 5411465
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F131 | 5411489
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G113 | 5467252
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2350 X118 | 5467247
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F125 | 5411494
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 428 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Greater than 3.87 Mega-ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 428 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 428 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water in fuel sensor.

Action

Inspect the engine harness, and water in fuel connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the water in fuel SIGNAL pin and the water in fuel RETURN pin at the water in fuel sensor connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 3.87 Mega-ohms?
YES NO

Replace the water in fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water in fuel sensor RETURN pin and the engine harness water in fuel sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector water in fuel sensor SIGNAL pin and the engine water in fuel sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 inactive?
YES NO

None. The removal and installation of the connector corrected the fault code.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 429 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 L110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F103 | 4310839
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Water in Fuel Sensor | Refer to Procedure 019-127 | ISV5.0 CM3230 V104 | 4367291
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 SN | 4022190
Water in Fuel Sensor | Refer to Procedure 019-127 | ISM11 CM876 SN | 4022196
Water in Fuel Sensor | Refer to Procedure 019-127 | ISZ13 CM2150 | 4022133
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2250 | 4022254
Water in Fuel Sensor | Refer to Procedure 019-127 | ISC8.3 and ISL9 CM2250 | 4022257
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 GX CM2250 | 4022250
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12/ISX11.9 CM2250 | 2883445
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 | 4022256
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 | 4022255
Water in Fuel Sensor | Refer to Procedure 019-127 | Marine QSB6.7 CM2250 | 4310611
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 EC | 2883621
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B105 | 4332778
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L102 | 4332796
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L107 | 4367386
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX11.9 CM2250 ECF | 2883561
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 ECF | 2883557
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 ECF | 4310661
Water in Fuel Sensor | Refer to Procedure 019-127 | PowerGen QSX15 CM2250 | 4310664
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 EC | 2883647
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX12 CM2350 X102 | 4310646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2350 X101 | 4310641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISX15 CM2250 SN | 4310736
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F101 | 4310846
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB4.5 CM2350 B104 | 4332646
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B103 | 4332641
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD4.5 CM2150 B119 | 4358465
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB/ISD6.7 CM2150 B120 | 4358470
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL8.9 CM2150 L110 | 4358475
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF3.8 CM2220 F110 | 4358480
Water in Fuel Sensor | Refer to Procedure 019-127 | ISL9 CM2350 L111 | 4367223
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z101 | 4358364
Water in Fuel Sensor | Refer to Procedure 019-127 | QSZ13 CM2150 Z102 | 4358369
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F107 | 4367316
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B106 | 4367376
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B112 | 4358498
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G110 | 4367323
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F114 | 4383734
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F117 | 4388578
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2250 B128 | 4388601
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2250 L115 | 4388626
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F118 | 4388708
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK3.8 CM2350 F119 | 4388703
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B130 | 4388668
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L118 | 4388673
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B122 | 4388767
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2250 X1152 | 4388739
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2250 B131 | 4388774
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB3.3 CM2250 B137 | 5411058
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F126 | 5411159
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X114B | 5411181
Water in Fuel Sensor | Refer to Procedure 019-127 | X15 CM2350 X116B | 5411186
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B121B | 5411223
Water in Fuel Sensor | Refer to Procedure 019-127 | ISB6.7 CM2350 B142 | 5411131
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B129B | 5411247
Water in Fuel Sensor | Refer to Procedure 019-127 | B4.5 CM2350 B147B | 5411252
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B135B | 5411257
Water in Fuel Sensor | Refer to Procedure 019-127 | B6.7 CM2350 B148B | 5411262
Water in Fuel Sensor | Refer to Procedure 019-127 | L9 CM2350 L119B | 5411267
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB6.7 CM2350 B145 | 5411273
Water in Fuel Sensor | Refer to Procedure 019-127 | QSL9 CM2350 L122 | 5411278
Water in Fuel Sensor | Refer to Procedure 019-127 | QSB4.5 CM2350 B144 | 5411382
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F131 | 5411489
Water in Fuel Sensor | Refer to Procedure 019-127 | QSX15 CM2350 X118 | 5467247
Water in Fuel Sensor | Refer to Procedure 019-127 | QSG12 CM2350 G113 | 5467252
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF3.8 CM2350 F125 | 5411494
Water in Fuel Sensor | Refer to Procedure 019-127 | QSF2.8 CM2880 F124 | 5411484
Water in Fuel Sensor | Refer to Procedure 019-127 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 429 active?
STEP 2. | Check the water in fuel sensor. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 429 active?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness, sensor, and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 428 active and Fault Code 429 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for a pin to ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 429 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water-in-fuel sensor.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water-in-fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 active?
YES NO

A damaged sensor has been detected.

Replace the water-in-fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness, sensor, and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the water-in-fuel sensor.

Action

Inspect the engine harness, sensor, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 for Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 428 active and Fault Code 429 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the water-in-fuel sensor.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin at the ECM connector of the engine harness and all other pins in the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin to ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the water-in-fuel sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin to ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 429 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2017


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 AN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B101 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L101 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358575
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358580
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | GSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | GSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 AN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B101 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L101 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | GSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | GSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 AN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 EC | 4310575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332687
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K105 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358570
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358580
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 IAN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358470
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358475
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358480
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSb4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L102 | 4332796
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2250 | 4022254
Crankcase Breather (External) | Refer to Procedure 003-001 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather (External) | Refer to Procedure 003-001 | ISM11 CM876 SN | 4022196
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 | 4022256
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 | 4022255
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 ECF | 2883557
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather (External) | Refer to Procedure 003-001 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather (External) | Refer to Procedure 003-001 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L101 | 4310787
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 CM2350 X102 | 4310646
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX15 CM2350 X101 | 4310641
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather (External) | Refer to Procedure 003-001 | ISL9 CM2350 L111 | 4367223
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L115 | 4388626
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2250 L118 | 4388673
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L107 | 4367386
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B105 | 4332778
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2250 | 4022254
Crankcase Breather Tube | Refer to Procedure 003-018 | Marine QSB6.7 CM2250 | 4310611
Crankcase Breather Tube | Refer to Procedure 003-018 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 | 4022256
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 | 4022255
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 EC | 2883621
Crankcase Breather Tube | Refer to Procedure 003-018 | QSX11.9 CM2250 | 2883561
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 EC | 2883647
Crankcase Breather Tube | Refer to Procedure 003-018 | ISB6.7 CM2350 B101 | 2883567
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Tube | Refer to Procedure 003-018 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B112 | 4358498
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B106 | 4367376
Crankcase Breather Tube | Refer to Procedure 003-018 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B128 | 4388601
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2250 B130 | 4388668
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B122 | 4388767
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Tube | Refer to Procedure 003-018 | B6.7 CM2350 B121B | 5411223
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather Tube | Refer to Procedure 003-018 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Tube | Refer to Procedure 003-018 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L119B | 5411267
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L116B | 5411330
Crankcase Breather Tube | Refer to Procedure 003-018 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B105 | 4332778
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L102 | 4332796
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2250 | 4022254
Crankcase Blowby, Measure | Refer to Procedure 014-010 | Marine QSB6.7 CM2250 | 4310611
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISM11 CM876 SN | 4022196
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 | 4022256
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 | 4022255
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 EC | 2883621
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX11.9 CM2250 ECF | 2883561
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 ECF | 2883557
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Blowby, Measure | Refer to Procedure 014-010 | PowerGen QSX15 CM2250 | 4310664
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 EC | 2883647
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B101 | 2883567
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 B101 | 4310787
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX12 CM2350 X102 | 4310646
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISX15 CM2350 X102 | 4310641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISB6.7 CM2350 B103 | 4332641
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B112 | 4358498
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B106 | 4367376
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISL9 CM2350 L111 | 4367223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B128 | 4388601
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L115 | 4388626
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2250 B130 | 4388668
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2250 L118 | 4388673
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSL9 CM2350 L107 | 4367386
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B122 | 4388767
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2250 B131 | 4388774
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB3.3 CM2250 B137 | 5411058
Crankcase Blowby, Measure | Refer to Procedure 014-010 | B6.7 CM2350 B121B | 5411223
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2250 X115 | 4388739
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB6.7 CM2350 B145 QSL9 CM2350 L122 | 5411273 5411278
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSB4.5 CM2350 B144 | 5411382
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L119B | 5411267
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L116B | 5411330
Crankcase Blowby, Measure | Refer to Procedure 014-010 | L9 CM2350 L123B | 5411465
Crankcase Blowby, Measure | Refer to Procedure 014-010 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?
 | STEP 2B. Verify crankcase breather type and maintenance history. | Filter below the maintenance interval or fitted with maintenance free element?
 | STEP 2C. Inspect the crankcase breather element. | Crankcase breather element have contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator. | Oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3733 or 3734 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use the INSITE™ electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ± 0.28 kPa - G [0 ± 1.13 in H20]?

YES NO
No Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Verify crankcase breather type and maintenance history.

Conditions

  • Determine if crankcase breather system is fitted with filter element or maintenance free breather insert.

Action

Check mileage / hours on the crankcase breather filter since last maintenance, if equipped.

Contact a Cummins® Authorized Repair Location for crankcase breather filter maintenance intervals for specific engine application.

Filter below the maintenance interval or fitted with maintenance free element?
YES NO
No Repair

Replace the crankcase breather filter element. Refer to Procedure 003-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase breather element.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase breather element for contamination or blockage.

Crankcase breather element have contamination or blockage?
YES NO

Inspect the crankcase breather element and clean or replace as necessary.

Refer to Procedure 003-019 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, breather tubes, and oil separator.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, breather tubes, and oil separator for plugging.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, breather tube, or separator.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Do not operate engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Measure the crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Crankcase blowby measurement within specification?
YES NO

Inspect the crankcase breather element and clean or replace as necessary. Refer to Procedure 003-019 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

  • Reference the Crankcase Gases (Blowby) Excessive symptom tree in the appropriate service manual for a specific engine application.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 14-Mar-2017


FAULT CODE 596 - Electrical Charging System Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Are the voltages at least (+) 12 VDC (volts of direct current) under normal conditions and at least (+) 6.2 VDC during cranking?
STEP 2. | Check the charging system. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within original equipment manufacturer (OEM) specifications?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion.
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Are the voltages at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the charging system.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging rate within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 597 - Electrical Charging System Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use these test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Inspect the battery cable and alternator connections. | Damaged or loose connections?
 | STEP 1B. Check the battery voltage. | Is the battery voltage at least (+) 12 VDC (volts of direct current) under normal conditions and at least (+) 6 VDC during cranking?
STEP 2. | Check the alternator and power harness. |
 | STEP 2A. Inspect the alternator. | Is the alternator charging within original equipment manufacturer (OEM) specifications?
 | STEP 2B. Check for an open circuit in the unswitched battery supply circuit. | Less than 10 ohms?
 | STEP 2C. Check for a short circuit. | More than 100k ohms?
 | STEP 2D. Check the add-on or accessory wiring at the positive (+) terminal of the battery. | Any damaged wires?
 | STEP 2E. Check for a short circuit in the power harness. | More than 100k ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Inspect the battery cable and alternator connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery cable and alternator connections for the following:

  • Corrosion
  • Loose connection.

Damaged or loose connections?
YES NO

Repair the damaged connections.

Tighten the battery connections and clean the battery terminals. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal.
  • Measure the battery voltage from the positive (+) terminal to the negative (-) terminal while trying to start the engine.

Is the battery voltage at least (+) 12 VDC under normal conditions and at least (+) 6.2 VDC during cranking?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the alternator and power harness.

Guided Step 2A - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use the OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amperes).

It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Is the alternator charging rate within OEM specifications?
YES NO
No Repair

Repair or replace the alternator and/or OEM wiring to the alternator.

See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check for an open circuit in the unswitched battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive battery cable from the battery.

Action

Check for an open circuit in the unswitched battery supply circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins of the OEM power harness ECM connector and the positive (+) battery terminal.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the battery harness. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM battery SUPPLY (+) pins and the ECM battery SUPPLY (-) pins of the ECM power harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring and examine the wire(s) for damaged insulation or an installation error that can cause a short circuit in the SUPPLY wire to the engine block.

Any damaged wires?
YES NO

Repair the damaged wiring.

 No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit in the power harness

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness connector from the ECM.
  • Disconnect the positive (+) battery cable from the battery.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance between the ECM Battery SUPPLY (+) pins in the OEM power harness connector to all pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

More than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM power harness.

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jul-2014


FAULT CODE 649 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 649. | Fault Code 649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 649.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 649.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 649 active?
YES NO

Change the engine lubricating oil and filter.

Use INSITE™ electronic service tool to reset the Maintenance Monitor.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Feb-2013


FAULT CODE 691 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2250 | 4022254
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISC8.3 and ISL9 CM2250 | 4022257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 ECF | 4310661
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | PowerGen QSX15 CM2250 | 4310664
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L102 | 4332796
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 | 4022256
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 | 4022255
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 691 active?
STEP 3. | Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 692 active and Fault Code 691 inactive?
 | STEP 3C. Check for an open circuit in the engine harness or OEM harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness or OEM harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 691 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?

YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • For engines equipped with a turbocharger compressor intake air temperature sensor: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM), engine harness, and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM, engine harness, or OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM, engine harness, or OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM, engine harness, or OEM harness connector.

Repair the damaged harness, connector, or pins, if possible.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3854510.

Install the appropriate connector seal if it is damaged or missing.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake air temperature sensor SIGNAL pin and the turbocharger compressor intake air temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active and Fault Code 691 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor RETURN pin and the engine harness turbocharger compressor intake air temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector turbocharger compressor intake air temperature sensor SIGNAL pin and the engine harness turbocharger compressor intake air temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness or OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 692 - Turbocharger 1 Compressor Intake Temperature Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK50 CM2350 K108 | 4332823
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISL8.9 CM2150 SN | 4022190
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSL9 CM2250 | 4022256
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 | 4022255
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSB6.7 CM2250 EC | 2883621
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSX15 CM2250 ECF | 2883557
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK19 CM2350 K105 | 4326157
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z101 | 4358364
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSZ13 CM2150 Z102 | 4358369
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compresssor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K116 | 4367444
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | QSK60 CM2350 K121 | 4388645
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF2.8 CM2220 F122 | 5467376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX11.9 CM2250 ECF | 2883561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F105 | 4358561
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F107 | 4367316
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2250 B128 | 4388601
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2250 L115 | 4388626
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L118 | 4388673
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L107 | 4367386
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F118 | 4388708
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F119 | 4388703
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B122 | 4388767
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSL9 CM2350 L122 | 5411278
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F124 | 5411484
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2880 F131 | 5411489
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSX15 CM2350 X118 | 5467247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF3.8 CM2350 F125 | 5411494
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSF2.8 CM2350 F124 | 5411484

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 2. | Check the turbocharger compressor intake air temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM), engine harness, or original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 691 active and Fault Code 692 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness or OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 692 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake air temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active and Fault Code 692 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake air temperature sensor.

  • Use the following procedure for engines equipped with a turbocharger compresssor intake air temperature sensor. Refer to Procedure 019-395 in the Associated Procedures Table.
  • Use the following procedure for engines equipped with a turbocharger compressor intake pressure/temperature sensor: Refer to Procedure 019-466 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM, engine harness, or OEM harness.

Guided Step 3A - Inspect the ECM and engine harness, and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness, OEM harness, and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Multiple unrelated faults will become active at this time as well. These can be temporarily ignored.

Fault Code 691 active and Fault Code 692 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness or OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine turbocharger compressor intake temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the turbocharger compressor intake air temperature SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the pin-to-pin shorted signal circuit.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the turbocharger compressor intake air temperature sensor from the engine harness or OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the turbocharger compressor intake air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness or OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a local Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 693 - Turbocharger 1 Compressor Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC and ISL CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 AN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC and ISL CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wirng Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISZ13 CM2150 | 4022133
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2250 GX CM2250 | 4022250
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12/ISX11.9 CM2250 | 2883445
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX12 CM2350 X102 | 4310646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISX15 CM2350 X101 | 4310641
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | F3.8 CM2350 F120B | 5411237
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X114B | 5411181
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | X15 CM2350 X116B | 5411186
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411247
Turbocharger Compressor Intake Air Temperature Sensor | Refer to Procedure 019-395 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L101 | 4310787
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISL9 CM2350 L111 | 4367223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISF3.8 CM2350 F109 | 4367218
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G110 | 4367323
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B121B | 5411223
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B129B | 5411247
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B4.5 CM2350 B147B | 5411252
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B135B | 5411257
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | B6.7 CM2350 B148B | 5411262
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L119B | 5411267
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L116B | 5411330
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | L9 CM2350 L123B | 5411465
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 693 active?
 | STEP 1B. Check for Fault Codes 691 and 692. | Fault Code 691 or 692 active?
STEP 2. | Check the turbocharger compressor intake temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault code 691 active?
 | STEP 2C. Check the circuit response. | Fault Code 692 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 691 active?
 | STEP 3C. Check the circuit response. | Fault Code 692 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 693 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for Fault Codes 691 and 692.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 or 692 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and the turbocharger compressor intake temperature RETURN pin at the turbocharger compressor intake temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

An in-range malfunction of the turbocharger compressor intake temperature sensor has been detected.

Replace the turbocharger compressor intake temperature sensor.

  • For engines equipped with turbocharger compressor intake air temperature sensors: Refer to Procedure 019-395 in the Associated Procedures Table.
  • For engines equipped with turbocharger compressor intake pressure/temperature sensors: Refer to Procedure 019-466 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) power harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 691 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the turbocharger compressor intake temperature SIGNAL pin and turbocharger compressor intake temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 692 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Jan-2017


FAULT CODE 697 - ECM Internal Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V014 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 697 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 697 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 698 - Engine ECU Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 698 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 698 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 699 - ECM Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 AN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 active?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]. During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-ECM wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117 active?
YES NO
No Repair

If high inactive counts of Fault Code 1117 are found in the ECM, check the battery disconnect devices in the vehicle. If the keyswitch and ECM power are disconnected at the same time, Fault Code 1117 will be logged.

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or battery supply connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the battery supply connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the battery supply connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the battery supply connector and the negative battery connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO
No Repair

Correct the wiring so the wire is uninterrupted.

Go to 3E

Go to 4A

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete

Go to 1A

Last Modified: 05-Apr-2017


FAULT CODE 1239 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
STEP 2. | Check the accelerator pedal position sensor circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1241 active and Fault Code 1239 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1239 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1239 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal or lever position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal or lever position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active and Fault Code 1239 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal or lever to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active?
YES NO

A damaged accelerator pedal or lever has been detected. Contact a Cummins® Authorized Repair Location.

Replace the accelerator pedal or lever. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal RETURN pin and the OEM harness accelerator pedal RETURN pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1241 - Accelerator Pedal or Lever Position Sensor 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
STEP 2. | Check the accelerator pedal position sensor and circuit. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1239 active and Fault Code 1241 inactive?
 | STEP 2D. Check the fault codes and verify accelerator pedal or lever condition. | Fault Code 1241 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1241 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696.

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor and circuit.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the accelerator pedal position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the accelerator pedal position sensor supply voltage.

  • Measure the voltage from the accelerator pedal position sensor 5 volt SUPPLY pin to the accelerator pedal position sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the accelerator pedal position 5 volt SUPPLY pin and the accelerator pedal position SIGNAL pin at the sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1239 active and Fault Code 1241 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify accelerator pedal condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 active?
YES NO

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal or lever SUPPLY pin and the OEM harness accelerator pedal or lever connector SUPPLY pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector accelerator pedal SIGNAL pin and the OEM harness accelerator pedal connector SIGNAL pin.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the accelerator pedal SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1241 inactive?
YES NO

The removal and installation of the connector corrected the fault.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 1242 - Accelerator Pedal or Lever Position Sensor 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Codes 131, 132, 1239, or 1241 active?
STEP 2. | Check the accelerator pedal position sensor readings. |
 | STEP 2A. Inspect the accelerator pedal position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Codes 132 and 1241 both active?
 | STEP 2C. Check the accelerator pedal position 1 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the accelerator pedal position 2 sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2E. Check the fault codes. | Fault Code 1242 inactive?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 131, 132, 1239, or 1241 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the accelerator pedal position sensor readings.

Guided Step 2A - Inspect the accelerator pedal position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and accelerator pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 132 and 1241 both active?
YES NO
No Repair

If Fault Code 132 did not go active, follow Fault Code 132 troubleshooting tree.

If Fault Code 1241 did not go active, follow Fault Code 1241 troubleshooting tree.

Go to 2C

Appropriate fault code troubleshooting tree

Guided Step 2C - Check the accelerator pedal position 1 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal position 1 sensor +5 volt SUPPLY pin to the accelerator pedal position 1 sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 132 troubleshooting tree.

Go to 2D

Fault Code 132 troubleshooting tree

Guided Step 2D - Check the accelerator pedal position 2 sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal position sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

Measure the voltage from the accelerator pedal position 2 sensor +5 volt SUPPLY pin to the accelerator pedal position 2 sensor RETURN pin at the sensor connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Low sensor supply voltage has been detected.

See Fault Code 1241 troubleshooting tree.

Go to 2E

Fault Code 1241 troubleshooting tree

Guided Step 2E - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the accelerator pedal to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1242 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the accelerator position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

A damaged accelerator pedal has been detected.

Replace the accelerator pedal. See equipment manufacturer service information.

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Apr-2017


FAULT CODE 1515 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 1515 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and the engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1515 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and the ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the Society of Automotive Engineers (SAE) J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the multiplexed accelerator pedal or lever sensor system or OEM vehicle electronic control unit.

See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Go to 1A

Last Modified: 07-Apr-2017


FAULT CODE 1673 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1673 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1673 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 1685 - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

A circuit malfunction has been detected in the aftertreatment diesel exhaust fluid quality sensor.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2015


FAULT CODE 1686 - Aftertreatment Diesel Exhaust Fluid Quality Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

A circuit failure has been detected in the aftertreatment diesel exhaust fluid quality sensor.

Replace the aftertreatment diesel exhaust fluid quality sensor.

See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2015


FAULT CODE 1715 - Aftertreatment Diesel Exhaust Fluid Quality - Root Cause Not Known

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3868 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES NO
No Repair

An internal malfunction has been detected in the aftertreatment diesel exhaust fluid (DEF) quality sensor.

Replace the aftertreatment DEF quality sensor. See equipment manufacturer service information.

Fault Code 3868 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Nov-2015


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor +5 volt SUPPLY pin to the crankcase pressure sensor RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2250 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2250 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | Marine QSB6.7 CM2250 | 4310611
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B1O6 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411186
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2250 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Datapate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1852.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 03-Oct-2015


FAULT CODE 1866 - Exhaust Gas Recirculation Differential Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Connection | Refer to Procedure 010-080 | QSF3.8 CM2350 F107 | 4367316
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2250 | 4022254
Air Intake Connection | Refer to Procedure 010-080 | ISC8.3 ISL9 CM2250 | 4022257
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2250 | 4022256
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 | 4022255
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2250 EC | 2883621
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B101 | 2883567
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L101 | 4310787
Air Intake Connection | Refer to Procedure 010-080 | ISB4.5 CM2350 B104 | 4332646
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B103 | 4332641
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B105 | 4332778
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L102 | 4332796
Air Intake Connection | Refer to Procedure 010-080 | ISL9 CM2350 L111 | 4367223
Air Intake Connection | Refer to Procedure 010-080 | QSF2.8 CM2880 F105 | 4358561
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | QSF2.8 CM2880 F114 | 4383734
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L107 | 4367386
Air Intake Connection | Refer to Procedure 010-080 | QSB6.7 CM2350 B130 | 4388668
Air Intake Connection | Refer to Procedure 010-080 | QSL9 CM2350 L118 | 4388673
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B121B | 5411223
Air Intake Connection | Refer to Procedure 010-080 | ISB6.7 CM2350 B142 | 5411131
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L116B | 5411330
Air Intake Connection | Refer to Procedure 010-080 | B4.5 CM2350 B129B | 54111247
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B135B | 5411257
Air Intake Connection | Refer to Procedure 010-080 | B4.5 CM2350 B147B | 5411252
Air Intake Connection | Refer to Procedure 010-080 | B6.7 CM2350 B148B | 5411262
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L119B | 5411267
Air Intake Connection | Refer to Procedure 010-080 | L9 CM2350 L123B | 5411465
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12/ISX11.9 CM2250 | 2883445
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX CM2250 GX CM2250 | 4022250
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX11.9 CM2250 ECF | 2883561
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | QSX15 CM2250 ECF | 2883557
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX12 CM2350 X102 | 4310646
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | ISX15 CM2350 X101 | 4310641
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | X15 CM2350 X114B | 5411181
EGR Mass Measurement Flow Assembly | Refer to Procedure 011-066 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F14 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2273 and 2274. | Fault Code 2273 or 2274 active?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor ports. |
 | STEP 2A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 3. | Check the EGR differential pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins.
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes 2273 and 2274.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 or 2274 active?
YES | NO
No Repair | No Repair

Fault Code 2273 or 2274 troubleshooting tree

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor ports.

Guided Step 2A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • For ISB, ISC, ISL, QSB, and QSL engines, use the following procedure in the appropriate manual. Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX and QSX engines, use the following procedure in the appropriate manual. Refer to Procedure 011-066 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube.

  • For ISB, ISC, ISL, QSB, QSL, B4.5, and B6.7 engines, use the following procedure in the appropriate manual. Refer to Procedure 010-080 in the Associated Procedures Table.
  • For ISX and QSX engines, use the following procedure in the appropriate manual. Refer to Procedure 011-066 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR differential pressure sensor and circuit.

Guided Step 3A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 VOLT SUPPLY pin and the EGR differential pressure SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 VOLT SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 1879 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 2. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF differential pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1881 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1879 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1879 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor RETURN pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.

Reference the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal an installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor RETURN pin and the OEM harness aftertreatment DPF differential pressure sensor connector RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1881 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 ECF2 | 4022178
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2220 F103 | 4310839
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF differential pressure sensor and electronic connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1879 active?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1881 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 1881 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment DPF differential pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment DPF differential pressure SUPPLY pin and the aftertreatment DPF differential pressure RETURN pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure sensor SUPPLY pin and the aftertreatment DPF differential pressure sensor SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SUPPLY pin and the OEM harness aftertreatment DPF differential pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19 and a wiring diagram.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 1885 - Aftertreatment 1 Intake NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 | 4367444
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K117 | 4367449
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K121 | 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B147B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 or 3682 active?
 | STEP 1B. Check for active and inactive fault codes. | Fault Code 1885 active or inactive with more than one count?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 or 3682 is active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active and inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885 active or inactive with more than one count?
YES NO

An internal error has been detected in the aftertreatment intake nitrogen oxides (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 1921 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISL9 CM2350 L111 | 4367223
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSG12 CM2350 G110 | 4367323
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | QSL9 CM2350 L118 | 4388673
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | F3.8 CM2350 F120B | 5411237
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B4.5 CM2350 B129B | 5411247
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B6.7 CM2350 B135B | 5411257
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B4.5 CM2350 B147B | 5411252
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | B6.7 CM2350 B148B | 5411262
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B101 | 2883567
Snap Acceleration Test | Refer to Procedure 014-017 | ISF3.8 CM2350 F109 | 4367218
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L101 | 4310787
Snap Acceleration Test | Refer to Procedure 014-017 | ISB4.5 CM2350 B104 | 4332646
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B103 | 4332641
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L111 | 4367223
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | QSG12 CM2350 G110 | 4367323
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F117 | 4388578
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B130 | 4388668
Snap Acceleration Test | Refer to Procedure 014-017 | QDL9 CM2350 L118 | 4388673
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F126 | 5411159
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B142 | 5411131
Snap Acceleration Test | Refer to Procedure 014-017 | F3.8 CM2350 F120B | 5411237
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B129B | 5411247
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B135B | 5411257
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B147B | 5411252
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B148B | 5411262
Snap Acceleration Test | Refer to Procedure 014-017 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 1921 are active?
STEP 2. | Check the duty cycle of the application. |
 | STEP 2A. Check the aftertreatment duty cycle. | Does the duty cycle of the application need to be increased?
STEP 3. | Check the aftertreatment DPF differential tubes. |
 | STEP 3A. Check the aftertreatment DPF differential tubes. | Aftertreatment DPF differential pressure sensor tubes blocked?
STEP 4. | Perform stationary regeneration procedure. |
 | STEP 4A. Perform stationary regeneration procedure. | Fault Code 1921 active after the stationary regeneration has been completed?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 1921 are active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the duty cycle of the application.

Guided Step 2A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the Duty Cycle of the engine.
  • View the Aftertreatment Trip Information.

Determine if the duty cycle of the application needs to change in order to increase the exhaust temperatures entering the aftertreatment system.

Does the duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the exhaust temperatures entering the aftertreatment system.

 No Repair

Appropriate base engine troubleshooting procedure

Go to 3A

Guided Step 3 - Check the aftertreatment DPF differential tubes.

Guided Step 3A - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor tubes.

Action

Check for plugged aftertreatment DPF differential pressure sensor tubes.

  • Inspect tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform the stationary regeneration procedure.

Guided Step 4A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and let it idle.

Action

Perform the aftertreatment stationary regeneration procedure.

Use the following procedure for ISB4.5 CM2350 B104, ISB6.7 CM2350 B101, ISB6.7 CM2350 B103, ISL9 CM2350 L101, ISX12 CM2350 X102, ISX15 CM2350 X101, ISL9 CM2350 L111, B4.5 CM2350 B129B, B6.7 CM2350 B135B, B4.5 CM2350 B147B, B6.7 CM2350 B148B, and L9 CM2350 L119B engines:

  • Refer to Procedure 014-016 in the Associated Procedures Table.

Use the following procedure for ISL9 CM2350 L11 and L9 CM2350 L119B engines:

  • Refer to Procedure 014-015 in the Associated Procedures Table.

Use the following procedure for all other applications:

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Use INSITE™ electronic service tool to perform the aftertreatment DPF regeneration test found in the ECM diagnostic tests.

Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment DPF.

Fault Code 1921 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that may have become active during the regeneration event. Troubleshoot any active fault codes.

Perform the Snap Acceleration Test to check for a damaged DPF.

Use the following procedure for ISB4.5 CM2350 B104, ISB6.7 CM2350 B101, ISB6.7 CM2350 B103, ISL9 CM2350 L101, ISX12 CM2350 X102, and ISX15 CM2350 X101, ISL9 CM2350 L111, B4.5 CM2350 B129B, B6.7 CM2350 B135B, B4.5 CM2350 B147B, B6.7 CM2350 B148B, and L9 CM2350 L119B engines:

  • Refer to Procedure 014-017 in the Associated Procedures Table.

Use the following procedure for ISL9 CM2350 L11 and L9 CM2350 L119B engines:

  • Refer to Procedure 014-015 in the Associated Procedures Table.

Use the following procedure for all other applications:

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jun-2017


FAULT CODE 1922 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Restriction Test | Refer to Procedure 011-085 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F101 | 4310846
Snap Acceleration Test | Refer to Procedure 014-017 | ISF3.8 CM2350 F109 | 4367218
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B101 | 2883567
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L101 | 4310787
Snap Acceleration Test | Refer to Procedure 014-017 | ISX12 CM2350 X102 | 4310646
Snap Acceleration Test | Refer to Procedure 014-017 | ISX15 CM2350 X101 | 4310641
Snap Acceleration Test | Refer to Procedure 014-017 | ISB4.5 CM2350 B104 | 4332646
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B103 | 4332641
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L111 | 4367223
Snap Acceleration Test | Refer to Procedure 014-017 | QSG12 CM2350 G110 | 4367323
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F117 | 4388578
Snap Acceleration Test | Refer to Procedure 014-017 | QSB6.7 CM2350 B130 | 4388668
Snap Acceleration Test | Refer to Procedure 014-017 | QSL9 CM2350 L118 | 4388673
Snap Acceleration Test | Refer to Procedure 014-017 | ISF2.8 CM2220 F126 | 5411159
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B142 | 5411131
Snap Acceleration Test | Refer to Procedure 014-017 | F3.8 CM2350 F120B | 5411237
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B129B | 5411247
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B135B | 5411257
Snap Acceleration Test | Refer to Procedure 014-017 | B4.5 CM2350 B147B | 5411252
Snap Acceleration Test | Refer to Procedure 014-017 | B6.7 CM2350 B148B | 5411262
Snap Acceleration Test | Refer to Procedure 014-017 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 F101 | 4310846
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L101 | 4310787
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2350 X101 | 4310641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2250 | 4022254
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISX15 CM2250 | 4022250
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISL9 CM2350 L111 | 4367223
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSG12 CM2350 G110 | 4367323
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | QSL9 CM2350 L118 | 4388673
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | F3.8 CM2350 F120B | 5411237
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B129B | 5411247
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B135B | 5411257
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B4.5 CM2350 B147B | 5411252
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | B6.7 CM2350 B148B | 5411262
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1922 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3375 or 3376 active or inactive?
 | STEP 1C. Check for active fault codes. | Fault Code 1922 active?
 | STEP 1D. Review the fault code snapshot information. | Operator ignored aftertreatment diesel particulate filter (DPF) lamps?
 | STEP 1E. Perform the Aftertreatment DPF Reset Procedure. | Aftertreatment Maintenance Reset Procedure completed?
 | STEP 1F. Perform the stationary regeneration procedure. | Fault Code 1922 active after stationary regeneration completed?
STEP 2. | Check the aftertreatment temperature sensors. |
 | STEP 2A. Check for active fault codes. | Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
 | STEP 2B. Monitor the aftertreatment exhaust gas temperature sensors. | Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
STEP 3. | Inspect the aftertreatment DPF differential pressure sensor. |
 | STEP 3A. Verify the aftertreatment DPF differential pressure sensor accuracy. | Aftertreatment DPF differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
 | STEP 3B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor supply tubes blocked?
STEP 4. | Check the duty cycle of the application. |
 | STEP 4A. Check the aftertreatment duty cycle. | Duty cycle of the application need to be increased?
STEP 5. | Check for excessive black smoke. |
 | STEP 5A. Inspect the exhaust for excessive black smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
 | STEP 5B. Check aftertreatment diesel particulate filter restriction, if available. | Aftertreatment diesel particulate filter restriction within specifications?
 | STEP 5C. Inspect the aftertreatment diesel particulate filter. | Aftertreatment diesel particulate filter meet reuse guidelines?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1922 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3375 or 3376 active or inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree for Fault Code 3375 or 3376

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1922 active?
YES NO

The aftertreatment DPF has plugged with soot and the stationary regeneration procedure can not be performed until it has been inspected and cleaned in an SPX air pulse cleaning machine, or equivalent machine.

Use the following instructions to remove, inspect, and clean or replace the aftertreatment DPF.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Use the following procedure if the aftertreatment DPF does not meet the inspection criteria and must be replaced.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Aftertreatment DPFs that meet the inspection criteria and are cleaned in an SPX air pulse cleaning machine, or equivalent machine, must have a stationary regeneration after the cleaning process is complete.

No Repair

Go to 1D

Repair complete

Guided Step 1D - Review the fault code snapshot information.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Review all fault codes, active or inactive, that are present in the ECM. Determine if any fault codes are present in the ECM that inhibit aftertreatment regeneration. If fault codes are present in the ECM that can inhibit aftertreatment regeneration, review the fault code snapshot information for the fault code(s) and determine if the fault code was active when Fault Codes 1921, 1922, and/or 2639 were active. If the fault(s) inhibiting aftertreatment regeneration were active when Fault Code 1921, 1922 and/or 2639 were active, it is likely the customer was not able to induce a stationary regeneration.
  • Review the ECM timestamps for Fault Codes 1921, 1922, and 2639.
  • If the ECM time stamp between each fault code is greater than 0.5 hour, the operator should be interviewed to determine why a stationary regeneration was not performed.

Fault Code 2777 indicates that the aftertreatment regeneration permit switch was in the inhibit position when Fault Codes 1921, 1922, and/or 2639 were active. Reference the appropriate troubleshooting tree for this fault code and determine if this fault was active at the time Fault Code 1922 was active.

Operator ignored aftertreatment DPF lamps?
YES NO

  • Inform the customer on the proper procedure for initiating a stationary regeneration.

 No Repair

Go to 1E

Go to 1E

Guided Step 1E - Perform the Aftertreatment DPF Procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Aftertreatment Maintenance Reset Procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment DPF Reset Procedure located in the aftertreatment maintenance selection under the advanced ECM data menu.
  • After clicking the OK button, it may take several minutes for Fault Code 1922 to go inactive, and Fault Code 1921 to go active.

Fault Code 1922 must be active before the Aftertreatment Maintenance Reset Procedure can be performed.

Fault Code 1922 will go inactive and Fault Code 1921 will go active after completing this procedure.

Aftertreatment Maintenance Reset Procedure completed?
YES NO
No Repair

Perform INSITE™ electronic service tool Aftertreatment Maintenance Reset Procedure listed in the Action section of this troubleshooting step.

Go to 1F

Go to 1F

Guided Step 1F - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and idle.

Action

Perform the stationary regeneration procedure.

  • Use INSITE™ electronic service tool to perform the Aftertreatment DPF Regeneration Test found in the ECM diagnostic tests.

Some vehicles can be equipped with a stationary regeneration switch in the dash. This switch can also be used to perform the stationary regeneration procedure. Refer to the original equipment manufacturer (OEM) service manual.

  • Refer to Procedure 014-016 in the Associated Procedures Table.

If stationary regeneration will not activate, please reference the Stationary Regeneration - Will Not Activate troubleshooting symptom tree in Section TS of the appropriate service manual.

Fault Code 2639 will become active during the regeneration procedure. This is normal operation as the soot is removed from the aftertreatment DPF.

Fault Code 1922 active after stationary regeneration has been completed?
YES NO

A system issue may be causing Fault Code 1922 to remain active.

Continue to follow the troubleshooting symptom tree to locate the issue causing Fault Code 1922 to remain active.

 No Repair

Go to 2A

Go to 6A

Guided Step 2 - Check the aftertreatment temperature sensors.

Guided Step 2A - Check for active fault codes

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment temperature sensors.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 3319, 3321, or 3322 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2B

Guided Step 2B - Monitor the aftertreatment exhaust gas temperature sensors.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Idle engine for greater than 10 minutes

Action

Monitor the aftertreatment exhaust gas temperature sensors with an electronic service tool while the engine is idling.

  • Idle the engine for 10 minutes to stabilize the exhaust temperatures in the aftertreatment system.
  • If any fault codes occur, see the appropriate fault code troubleshooting tree.
  • If no fault codes occur, record the values of the three aftertreatment exhaust gas temperature sensors.

Aftertreatment exhaust gas temperature sensors vary by more than 24°C or 43°F?
YES NO

Check for a short circuit from the SIGNAL pin of the temperature sensor in question to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short is found, replace the temperature sensor that is reading higher or lower than the other sensors. Refer to Procedure 019-449 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Inspect the aftertreatment DPF differential pressure sensor.

Guided Step 3A - Verify the aftertreatment DPF differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment DPF differential pressure sensor signal voltage reading with INSITE™ electronic service tool.
  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor signal voltage within specification with the keyswitch ON and the engine OFF?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

Action

Disconnect the aftertreatment DPF differential pressure sensor supply tubes.

  • Inspect the supply tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor supply tubes blocked?
YES NO

Remove and clean the aftertreatment DPF differential pressure sensor supply tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

If no short circuit is found, replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 4 - Check the duty cycle of the application.

Guided Step 4A - Check the aftertreatment duty cycle.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the duty cycle.

  • Use INSITE™ electronic service tool to view the duty cycle of the engine.
  • View the aftertreatment trip information.

Determine if the duty cycle of the application needs to change in order to increase the temperature of the exhaust gases entering the aftertreatment system.

Duty cycle of the application need to be increased?
YES NO

Change the duty cycle of the application in order to increase the temperature of the exhaust gases entering the aftertreatment system.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check for excessive black smoke.

Guided Step 5A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Refer to Procedure 014-017 in the Associated Procedures Table.

To perform a snap acceleration test, it could be necessary to temporarily adjust the maximum engine speed with no vehicle speed sensor parameter in INSITE™ electronic service tool, to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of the excessive black smoke.

  • Reference the appropriate engine performance troubleshooting tree.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Check aftertreatment diesel particulate filter restriction, if available.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • If the Aftertreatment Diesel Particulate Filter Restriction Test is not available, skip to Step 5C.

Action

Perform the following sections of the Aftertreatment Diesel Particulate Filter Restriction Test.

Refer to Procedure 011-085 in the Associated Procedures Table.

  • Test.
  • Analyzing the Data.

Aftertreatment diesel particulate filter restriction within specifications?
YES NO
No Repair

Replace the DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5C - Inspect the aftertreatment diesel particulate filter.

Conditions

  • Remove the aftertreatment diesel particulate filter
  • Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel particulate filter.

  • Inspect the aftertreatment diesel particulate filter.
  • Refer to Procedure 011-041 in the Associated Procedures Table.

Aftertreatment diesel particulate filter meet reuse guidelines?
YES NO

Clean the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.

Remove and replace the aftertreatment diesel particulate filter. Refer to Procedure 011-041 in the Associated Procedures Table.

If the aftertreatment diesel particulate filter required replacement for excessive ash and had not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Reference the Ash Cleaning - Excessive troubleshooting symptom tree in Section TS, if necessary.

Go to 6A

Go to
Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 15-Jun-2017


FAULT CODE 1942 - Crankcase Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISX12 G CM2180 EJ | 4310682
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2250 B131 | 4388774
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2250 X115 | 4388739
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X114B | 5411181
Crankcase Breather (External) | Refer to Procedure 003-001 | X15 CM2350 X116B | 5411186
Crankcase Breather (External) | Refer to Procedure 003-001 | B6.7 CM2350 B121B | 5411223
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L116B | 5411330
Crankcase Breather (External) | Refer to Procedure 003-001 | QSL9 CM2350 L122 | 5411278
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB4.5 CM2350 B144 | 5411382
Crankcase Breather (External) | Refer to Procedure 003-001 | QSB6.7 CM2350 B145 | 5411273
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L119B | 5411267
Crankcase Breather (External) | Refer to Procedure 003-001 | L9 CM2350 L123B | 5411465
Crankcase Breather (External) | Refer to Procedure 003-001 | QSX15 CM2350 X118 | 5467247
Crankcase Breather Element | Refer to Procedure 003-019 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Breather Element | Refer to Procedure 003-019 | ISM11 CM876 SN | 4022196
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 | 4022256
Crankcase Breather Element | Refer to Procedure 003-019 | QSX11.9 CM2250 ECF | 2883561
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 ECF | 2883557
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Breather Element | Refer to Procedure 003-019 | PowerGen QSX15 CM2250 | 4310664
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L101 | 4310787
Crankcase Breather Element | Refer to Procedure 003-019 | ISX12 CM2350 X102 | 4310646
Crankcase Breather Element | Refer to Procedure 003-019 | ISX15 CM2350 X101 | 4310641
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L102 | 4332796
Crankcase Breather Element | Refer to Procedure 003-019 | ISL9 CM2350 L111 | 4367223
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2250 L115 | 4388626
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L107 | 4367386
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L118 | 4388673
Crankcase Breather Element | Refer to Procedure 003-019 | QSB3.3 CM2250 B137 | 5411058
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2250 X115 | 4388739
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L116B | 5411330
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L119B | 5411267
Crankcase Breather Element | Refer to Procedure 003-019 | L9 CM2350 L123B | 5411465
Crankcase Breather Element | Refer to Procedure 003-019 | QSL9 CM2350 L122 | 5411278
Crankcase Breather Element | Refer to Procedure 003-019 | QSX15 CM2350 X118 | 5467247
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 M2350 B103 | 4332641
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B106 | 4367376
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B122 | 4388767
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISV5.0 CM3230 V104 | 4367291
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B128 | 4388601
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2250 B130 | 4388668
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISL G CM2180 | 4021649
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2250 B131 | 4388774
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB3.3 CM2250 B137 | 5411058
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISB6.7 CM2350 B142 | 5411131
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B121B | 5411330
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B135B | 5411257
Crankcase Ventilation Filter | Refer to Procedure 003-021 | B6.7 CM2350 B148B | 5411262
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB4.5 CM2350 B144 | 5411382
Crankcase Ventilation Filter | Refer to Procedure 003-021 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISX12 G CM2180 EJ | 4310682
Engine Control Module | Refer to Procedure 019-031 | ISL G CM2180 | 4021649
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 G CM2180 EJ | 4310682
Engine Wiring Harness | Refer to Procedure 019-043 | ISL G CM2180 | 4021649
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2250 | 4022254
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISC8.3 and ISL9 CM2250 | 4022257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISM11 CM876 SN | 4022196
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2250 GX CM2250 | 4022250
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12/ISX11.9 CM2250 | 2883445
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 | 4022256
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 | 4022255
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 EC | 2883621
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX11.9 CM2250 ECF | 2883561
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 ECF | 2883557
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 ECF | 4310661
Crankcase Pressure Sensor | Refer to Procedure 019-445 | PowerGen QSX15 CM2250 | 4310664
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 EC | 2883647
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B101 | 2883567
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L101 | 4310787
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 CM2350 X102 | 4310646
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX15 CM2350 X101 | 4310641
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B103 | 4332541
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B105 | 4332778
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B112 | 4358498
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L102 | 4332796
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL9 CM2350 L111 | 4367223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B106 | 4367376
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B122 | 4388767
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2250 B128 | 4388601
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2250 L115 | 4388626
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L107 | 4367386
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B130 | 4388668
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L118 | 4388673
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISX12 G CM2180 EJ | 4310682
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISL G CM2180 | 4021649
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2250 B131 | 4388774
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB3.3 CM2250 B137 | 5411058
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X114B | 5411181
Crankcase Pressure Sensor | Refer to Procedure 019-445 | X15 CM2350 X116B | 5411189
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B121B | 5411223
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L116B | 5411330
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISB6.7 CM2350 B142 | 5411131
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2250 X115 | 4388739
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B135B | 5411257
Crankcase Pressure Sensor | Refer to Procedure 019-445 | B6.7 CM2350 B148B | 5411262
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSL9 CM2350 L122 | 5411278
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB4.5 CM2350 B144 | 5411382
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSB6.7 CM2350 B145 | 5411273
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L119B | 5411267
Crankcase Pressure Sensor | Refer to Procedure 019-445 | L9 CM2350 L123B | 5411465
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSX15 CM2350 X118 | 5467247

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1843 and 1844. | Fault Code 1843 or 1844 active?
 | STEP 1B. Check the oil fill cap. | Oil fill cap properly installed?
 | STEP 1C. Check the crankcase filter tube, if equipped. | Crankcase breather hose connected properly and free of restrictions?
 | STEP 1D. Check the crankcase breather element, if equipped. | Crankcase breather element installed correctly?
 | STEP 1E. Check the mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below maintenance interval?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 1844 active?
 | STEP 3C. Check the circuit response. | Fault Code 1843 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1843 and 1844.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 or 1844 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the oil fill cap.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil fill cap.

  • Check the oil fill cap for proper installation.

Oil fill cap properly installed?
YES NO
No Repair

Install the oil fill cap properly.

Go to 1C

Go to 1C

Guided Step 1C - Check the crankcase filter tube, if equipped.

Conditions

  • Turn keyswitch OFF.
  • Skip to Step 1D, if the engine is not equipped with a crankcase filter tube.

Action

Check the crankcase breather tube between the engine and the crankcase filter assembly.

Make sure the breather tube is properly connected and there are no kinks or other restrictions present.

Crankcase breather hose connected properly and free of restrictions?
YES NO
No Repair

Properly connect the crankcase breather hose.

Go to 1D

Go to 4A

Guided Step 1D - Check the crankcase breather element, if equipped.

Conditions

  • Turn keyswitch OFF.

Action

Check that the crankcase breather element is correctly installed.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Crankcase breather element installed correctly?
YES NO
No Repair

Install the crankcase breather element correctly.

Use the procedure(s) appropriate for your application.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.
  • Refer to Procedure 003-001 in the Associated Procedures Table.

Go to 1E

Repair complete.

Guided Step 1E - Check the mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate the maintenance record (miles/hours) of the latest crankcase breather filter replacement.

Action

Check the filter maintenance record.

  • Check the mileage/hours on the crankcase breather filter since the last maintenance.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase breather filter.

  • Refer to Procedure 003-019 in the Associated Procedures Table.
  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2A

Go to 4A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin at the crankcase pressure sensor connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

An in-range malfunction of the crankcase pressure sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 5 volt SUPPLY pin and the crankcase pressure SIGNAL pin on the ECM.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 1843 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Check all harnesses connected in series.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 09-Feb-2017


FAULT CODE 2185 - Sensor Supply 4 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISB4.5,ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2150 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2185 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Check for a short circuit to battery in the OEM harness. | Greater than 100k ohms?
 | STEP 2B. Check for a short circuit to keyswitch power in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Check for a short circuit to battery in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to battery.

  • Measure the resistance and check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM battery SUPPLY (+) pins in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check for a short circuit to keyswitch power in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check the OEM harness for a short circuit to keyswitch power.

  • Check for a short circuit between the accelerator pedal position +5 volt SUPPLY pin and the ECM keyswitch SIGNAL pin in the OEM harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-May-2017


FAULT CODE 2186 - Sensor Supply 4 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ and test lead Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2186 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2186 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3B-1. Check for a pin-to-ground short circuit in the OEM harness. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the accelerator pedal/lever position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2186 active?
YES NO
No Repair

Replace the accelerator pedal/lever position sensor. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the OEM harness connector or ECM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal +5 volt SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit art or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator +5 volt SUPPLY pin and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2017


FAULT CODE 2198 - VGT Actuator Driver Circuit - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2250 | 4022254
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B101 | 2883567
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 EC | 2883621
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 | 4022255
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISC8.6 and ISL9 CM2250 | 4022257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L101 | 4310787
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 | 4022256
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX11.9 CM2250 ECF | 2883561
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12/ISX11.9 CM2250 | 2883445
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX12 CM2350 X102 | 4310646
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2250 GX CM2250 | 4022250
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISX15 CM2350 X101 | 4310641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 ECF | 2883557
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 | 4310664
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | PowerGen QSX15 CM2250 ECF | 4310661
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B103 | 4332641
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B105 | 4332778
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B112 | 4358498
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L102 | 4332796
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISL9 CM2350 L111 | 4367223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B106 | 4367376
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L107 | 4367386
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2250 L115 | 4388626
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2250 B128 | 4388601
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B130 | 4388668
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L118 | 4388673
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B122 | 4388767
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X114B | 5411181
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | X15 CM2350 X116B | 5411186
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B121B | 5411223
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISB6.7 CM2350 B142 | 5411131
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2250 X115 | 4388739
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2350 L116B | 5411330
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B129B | 5411247
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B135B | 5411257
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B4.5 CM2350 B147B | 5411252
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | B6.7 CM2350 B148B | 5411262
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSL9 CM2350 L122 | 5411278
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB4.5 CM2350 B144 | 5411382
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSB6.7 CM2350 B145 | 5411273
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2250 L119B | 5411267
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | L9 CM2250 L123B | 5411465
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | ISC8.6 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.6 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 or 1894 active?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2636 or 1894 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2198 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 2198 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 1894 active?
YES | NO
No Repair | No Repair

Fault Code 2636 or 1894 troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 1894 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the VGT actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2198 active?
YES NO

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Feb-2017


FAULT CODE 2222 (2-Wire Sensor) - Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool and fault codes. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
 | STEP 1B. Check for an active fault code. | Fault Code 2222 active?
STEP 2. | Check the fuel level sensor and circuit. |
 | STEP 2A. Inspect the fuel level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2223 active and Fault Code 2222 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2222 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2222 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool and the fault codes.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Society of Automotive Engineers (SAE) J1939 Multiplexing - Fuel Level Sensor.

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 1B

Go to 4A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the fuel level sensor and circuit.

Guided Step 2A - Inspect the fuel level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and fuel level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel level sensor connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel level sensor SIGNAL pin and the fuel level sensor RETURN pin at the fuel level sensor connector of the OEM harness.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 active and Fault Code 2222 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 active?
YES NO

A damaged sensor has been detected.

Replace the fuel level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor RETURN pin and the OEM harness fuel level sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor SIGNAL pin and the fuel level sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2222 (3-Wire Sensor) - Fuel Level (Main Tank) Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool and fault codes. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
 | STEP 1B. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1C. Check for an active fault code. | Fault Code 2222 active?
STEP 2. | Check the fuel level sensor and circuit. |
 | STEP 2A. Inspect the fuel level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2223 active and Fault Code 2222 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2222 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2222 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool and the fault codes.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

ActionUse INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • SAE J1939 Multiplexing - Fuel Level Sensor

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 1B

Go to 4A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 1695

Go to 1B

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel level sensor and circuit.

Guided Step 2A - Inspect the fuel level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Inspect the OEM harness and fuel level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel level sensor SIGNAL pin and the fuel level sensor RETURN pin at the fuel level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 active and Fault Code 2222 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel level sensor SUPPLY pin and the fuel level sensor RETURN pin at the fuel level sensor connector of the OEM harness.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 active?
YES NO

A damaged sensor has been detected.

Replace the fuel level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor RETURN pin and the OEM harness fuel level sensor connector RETURN pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Dec-2014


FAULT CODE 2223 (2-Wire Sensor) - Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool and fault codes. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
 | STEP 1B. Check for an active fault code. | Fault Code 2223 active?
STEP 2. | Check the fuel level sensor and circuit. |
 | STEP 2A. Inspect the fuel level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2222 active and Fault Code 2223 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2223 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2223 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the vehicle settings in INSITE™ electronic service tool and the fault codes.

Guided Step 1A - Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • Society of Automotive Engineers (SAE) J1939 Multiplexing - Fuel Level Sensor.

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 1B

4A

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19

Guided Step 2 - Check the fuel level sensor and circuit.

Guided Step 2A - Inspect the fuel level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 active and Fault Code 2223 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 active?
YES NO

A damaged fuel level sensor has been detected.

Replace the fuel level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor RETURN pin and the OEM harness fuel level sensor connector RETURN pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor SIGNAL pin and the fuel level sensor connector SIGNAL pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fuel level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit between pins has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the fuel level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2223 (3-Wire Sensor) - Fuel Level (Main Tank) Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the vehicle settings in INSITE™ electronic service tool and fault codes. |
 | STEP 1A. Verify that the vehicle configuration and the settings in INSITE™ electronic service tool match. | Settings in INSITE™ electronic service tool match the vehicle configuration?
 | STEP 1B. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1C. Check for an active fault code. | Fault Code 2223 active?
STEP 2. | Check the fuel level sensor and circuit. |
 | STEP 2A. Inspect the fuel level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2222 active and Fault Code 2223 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2223 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 2223 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the vehicle settings in INSITE™ electronic service tool and the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool. Go to Features and Parameters and verify the following parameters match the vehicle configuration.

  • SAE J1939 Multiplexing - Fuel Level Sensor .

The settings in INSITE™ electronic service tool match the vehicle configuration?
YES NO
No Repair

Change the settings in the ECM with INSITE™ electronic service tool to match the vehicle configuration.

Go to 1B

Go to 4A

Guided Step 1B - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Reference Fault Code 1696

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel level sensor and circuit.

Guided Step 2A - Inspect the fuel level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Inspect the OEM harness and fuel level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel level SUPPLY pin and the fuel level RETURN pin at the fuel level sensor connector of the OEM harness.

Reference a wiring diagram for connector in identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 4.75 and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel level sensor SUPPLY pin and the fuel level sensor SIGNAL pin at the fuel level sensor connector of the OEM harness.

Reference a circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 active and Fault Code 2223 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to the OEM service manual.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor SUPPLY pin and the OEM harness fuel level sensor connector SUPPLY pin.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fuel level sensor SIGNAL pin and the OEM harness fuel level sensor connector SIGNAL pin.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the fuel level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Reference a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2223 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Dec-2014


FAULT CODE 2273 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F118 | 4388708
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F119 | 4388703
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2273 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2274 active and Fault Code 2273 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2273 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active and Fault Code 2273 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the problem.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related ti this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault the Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2274 - Exhaust Gas Recirculation Differential Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2250 | 4022254
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2250 GX CM2250 | 4022250
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12/ISX11.9 CM2250 | 2883445
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2250 | 4022256
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 | 4022255
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2250 EC | 2883621
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX11.9 CM2250 ECF | 2883561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSX15 CM2250 ECF | 2883557
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | PowerGen QSX15 CM2250 | 4310664
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B101 | 2883567
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L101 | 4310787
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX12 CM2350 X102 | 4310646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISX15 CM2350 X101 | 4310641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISF3.8 CM2220 F103 | 4310839
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F107 | 4367316
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB4.5 CM2350 B104 | 4332646
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B103 | 4332641
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B105 | 4332778
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B112 | 4358498
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L102 | 4332796
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISL9 CM2350 L111 | 4367223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F105 | 4358561
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B106 | 4367376
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF2.8 CM2880 F114 | 4383734
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L107 | 4367386
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB6.7 CM2350 B130 | 4388668
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSL9 CM2350 L118 | 4388673
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F118 | 4388708
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSF3.8 CM2350 F119 | 4388703
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | QSB4.5 CM2350 B122 | 4388767
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X114B | 5411181
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | X15 CM2350 X116B | 5411186
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B121B | 5411223
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISB6.7 CM2350 B142 | 5411131
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L116B | 5411330
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B129B | 5411247
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B135B | 5411257
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B4.5 CM2350 B147B | 5411252
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | B6.7 CM2350 B148B | 5411262
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L119B | 5411267
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2274 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit. |
 | STEP 2A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2273 active and Fault Code 2274 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2274 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) differential pressure sensor and circuit.

Guided Step 2A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR differential pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine EGR differential pressure sensor SUPPLY pin to the EGR differential pressure sensor RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure sensor SUPPLY pin and the EGR differential pressure sensor SIGNAL pin at the ECM connector.

See the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active and Fault Code 2274 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault the Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2288 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2288. | Active or inactive counts of Fault Code 2288?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2288.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive counts of Fault Code 2288.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2288?
YES NO

The engine has been derated due to turbocharger high speed conditions. This is normal operation, but a torque derate was used to protect the engine from exceeding turbocharger high speed limits.

No repair action is necessary.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Jun-2014


FAULT CODE 2373 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119 | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332968
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2373 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2374 active and Fault Code 2373 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2373 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to the Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active and Fault Code 2373 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2374 - Exhaust Gas Pressure Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM3250 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM3250 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL8.9 CM2150 SN | 4022190
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2250 | 4022254
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12/ISX11.9 CM2250 | 2883445
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 | 4022256
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 | 4022255
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 EC | 2883621
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX11.9 CM2250 ECF | 2883561
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 ECF | 2883557
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | PowerGen QSX15 CM2250 | 4310664
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B101 | 2883567
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L101 | 4310787
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX12 CM2350 X102 | 4310646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISX15 CM2350 X101 | 4310641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F101 | 4310846
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISF3.8 CM2350 F109 | 4367218
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB4.5 CM2350 B104 | 4332646
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | ISB6.7 CM2350 B103 | 4332641
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B105 | 4332778
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L102 | 4332796
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L107 | 4367386
Exhaust Gas Presssure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B112 | 4358498
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISL9 CM2350 L111 | 4367223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B106 | 4367376
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G110 | 4367323
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2220 F117 | 4388578
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B130 | 4388668
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L118 | 4388673
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F118 | 4388708
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F119 | 4388703
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2250 B128 | 4388601
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2250 L115 | 4388626
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B122 | 4388767
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISF2.8 CM2250 F126 | 5411159
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X114B | 5411181
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | X15 CM2350 X116B | 5411186
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B121B | 5411223
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2250 B131 | 4388774
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2250 X115 | 4388739
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISB6.7 CM3250 B142 | 5411131
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L116B | 5411330
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | F3.8 CM2350 F120B | 5411237
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B129B | 5411247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B135B | 5411257
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B4.5 CM2350 B147B | 5411252
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | B6.7 CM2350 B148B | 5411262
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L119B | 5411267
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | L9 CM2350 L123B | 5411465
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSL9 CM2350 L122 | 5411278
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB4.5 CM2350 B144 | 5411382
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSB6.7 CM2350 B145 | 5411273
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSF3.8 CM2350 F125 | 5411494
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSX15 CM2350 X118 | 5467247
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | QSG12 CM2350 G113 | 5467252

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP :1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 2374 inactive?
STEP 2. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 2373 active and Fault Code 2374 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2374 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor and circuit.

Guided Step 2A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the engine exhaust gas pressure SUPPLY pin to the engine exhaust gas pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 active?
YES NO

A damaged sensor has been detected.

Replace the exhaust gas pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the exhaust gas pressure sensor SUPPLY pin to the exhaust gas pressure sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open or shorted SUPPLY circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure sensor SUPPLY pin and the exhaust gas pressure sensor SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active and Fault Code 2374 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2374 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 2375 - Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2250 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F017 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2220 F103 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2250 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 43332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISF3.8 CM2250 | 4310839
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB4.5 CM2350 B104 | 4332646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B103 | 4332641
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L102 | 4332796
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F107 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L111 | 4367223
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F105 | 4358561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F114 | 4383734
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F118 | 4388708
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F119 | 4388703
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X114B | 5411181
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X116B | 5411186
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B121B | 5411223
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B142 | 5411131
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L116B | 5411330
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B129B | 5411247
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B135B | 5411257
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B147B | 5411252
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B148B | 5411262
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L119B | 5411267
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 2375 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Resistance between 200 ohms to 2.4M ohms?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2375 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2376 active and Fault Code 2375 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2375 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the EGR temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the EGR temperature sensor.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 200 ohms to 2.4M ohms?
YES NO
No Repair

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR temperature sensor SIGNAL pin and the EGR temperature sensor RETURN pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2376 active and Fault Code 2375 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness form the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor RETURN pin and the engine harness EGR temperature sensor connector RETURN pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector EGR temperature sensor SIGNAL pin and the engine harness EGR temperature sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedure needs to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Jan-2017


FAULT CODE 2376 - Exhaust Gas Recirculation Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V102102 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2250 | 4022254
EGR Temperature Sensor | Refer to Procedure 019-378 | ISC8.3 and ISL9 CM2250 | 4022257
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2250 GX CM2250 | 4022250
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12/ISX11.9 CM2250 | 2883445
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2250 | 4022256
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 | 4022255
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2250 EC | 2883621
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX11.9 CM2250 ECF | 2883561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSX15 CM2250 ECF | 2883557
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 ECF | 4310661
EGR Temperature Sensor | Refer to Procedure 019-378 | PowerGen QSX15 CM2250 | 4310664
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B101 | 2883567
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L101 | 4310787
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX12 CM2350 X102 | 4310646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISX15 CM2350 X101 | 4310641
EGR Temperature Sensor | Refer to Procedure 019-378 | ISF3.8 CM2220 F103 | 4310839
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB4.5 CM2350 B104 | 4332646
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B103 | 4332641
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B105 | 4332778
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L107 | 4367386
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B112 | 4358498
EGR Temperature Sensor | Refer to Procedure 019-378 | ISL9 CM2350 L111 | 4367223
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F017 | 4367316
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF2.8 CM2880 F105 | 4358561
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B106 | 4367376
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB6.7 CM2350 B130 | 4388668
EGR Temperature Sensor | Refer to Procedure 019-378 | QSL9 CM2350 L118 | 4388673
EFR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F118 | 4388708
EGR Temperature Sensor | Refer to Procedure 019-378 | QSF3.8 CM2350 F119 | 4388703
EGR Temperature Sensor | Refer to Procedure 019-378 | QSB4.5 CM2350 B122 | 4388767
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X114B | 5411181
EGR Temperature Sensor | Refer to Procedure 019-378 | X15 CM2350 X116B | 5411186
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B121B | 5411223
EGR Temperature Sensor | Refer to Procedure 019-378 | ISB6.7 CM2350 B142 | 5411131
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L116B | 5411330
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B129B | 5411247
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B135B | 5411257
EGR Temperature Sensor | Refer to Procedure 019-378 | B4.5 CM2350 B147B | 5411252
EGR Temperature Sensor | Refer to Procedure 019-378 | B6.7 CM2350 B148B | 5411262
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L119B | 5411267
EGR Temperature Sensor | Refer to Procedure 019-378 | L9 CM2350 L123 | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2376 inactive?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2376 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active and Fault Code 2376 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2376 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active and Fault Code 2376 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedure Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A pin-to-pin short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the EGR temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the EGR temperature sensor SIGNAL pin in the engine harness ECM connector and ground

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedure needs to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 2448 - Coolant Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 SN | 4022190
Cooling System | Refer to Procedure 008-018 | ISM11 CM876 SN | 4022196
Cooling System | Refer to Procedure 008-018 | ISZ13 CM2150 | 4022133
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2250 | 4022254
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | ISC8.3 and ISL9 CM2250 | 4022257
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 GX CM2250 | 4022250
Cooling System | Refer to Procedure 008-018 | ISX12/ISX11.9 CM2250 | 2883445
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 | 4022256
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 | 4022255
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 EC | 2883621
Cooling System | Refer to Procedure 008-018 | QSX11.9 CM2250 ECF | 2883561
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 ECF | 2883557
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 EC | 2883647
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | ISB/ISD4.5 CM2150 B119 | 4358465
Cooling System | Refer to Procedure 008-018 | ISB/ISD6.7 CM2150 B120 | 4358470
Cooling System | Refer to Procedure 008-018 | ISL8.9 CM2150 L110 | 4358475
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F110 | 4358480
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSL9 CM2250 L115 | 4388626
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2250 B128 | 4388601
Cooling System | Refer to Procedure 008-018 | ISF3.8 CM2220 F116 | 4383664
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | QSX15 CM2250 X115 | 4388739
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | ISF4.5 CM2220 F123 | 5411320
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 2448. | Active or inactive counts of Fault Code 2448?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 2448.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2448?
YES NO

Add coolant to the engine.

Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 2448 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 2448 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Mar-2017


FAULT CODE 2639 - Aftertreatment Diesel Particulate Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISX15 CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | L9 CM2350 L119B | 5411267
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F117 | 4388578
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF2.8 CM2220 F126 | 5411159
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault codes other than 2639 active?
 | STEP 1B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked?
STEP 2. | Perform stationary regeneration procedure. |
 | STEP 2A. Perform stationary regeneration procedure. | Fault Code 2639 is active after the stationary regeneration has been completed?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes other than 2639 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor tubes.

Action

Check for plugged aftertreatment DPF differential pressure sensor tubes.

  • Inspect tubes for blockage.
  • Refer to Procedure 011-047 in the Associated Procedures Table.

It is important to check for a frozen, plugged, or restricted aftertreatment DPF differential pressure sensor tube in extreme cold ambient temperatures. Ice can form in the differential pressure sensor tubes causing obstruction/sticking and may not be present at the time of troubleshooting.

Aftertreatment DPF differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure for stationary regeneration information. Refer to Procedure 014-013 in the Associated Procedures Table.

For ISF2.8 CM2220 F117, ISB4.5 CM2350 B104, ISB6.7 CM2350 B103, F3.8 CM2350 F120B, and ISV5.0 CM3230 V104 engines:

  • Refer to Procedure 014-016 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found in the ECM diagnostic tests.

If active fault codes occur during the regeneration test, abort the test and troubleshoot the active fault code.

Fault Code 2639 active after the stationary regeneration has been completed?
YES NO

Check for active fault codes that have become active during the regeneration event. Troubleshoot any active fault codes.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jun-2017


FAULT CODE 2692 - Aftertreatment 1 Diesel Particulate Filter System - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L123B | 5411465
Snap Acceleration Test | Refer to Procedure 014-017 | ISB6.7 CM2350 B101 | 2883567
Snap Acceleration Test | Refer to Procedure 014-017 | ISX15 CM2350 X101 | 4310641
Snap Acceleration Test | Refer to Procedure 014-017 | ISX12 CM2350 X102 | 4310646
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | L9 CM2350 L123B | 5411465
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for aftertreatment particulate sensor fault codes. | Fault Code 4143, 4144, 4153, 4154, 5577, 5578, 5579, 5581, 5582, 5583, 5584, 5792, 5793, 5837, 6642, 6643, 6644, 6645, 6646, 6647, 6648, 6649, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for aftertreatment diesel particulate filter (DPF) fault codes. | Fault Code 1921, 1922, 1981, 1993, or 2639 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for aftertreatment DPF regeneration fault codes. | Fault Code 3375 or 3376 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1D. Check for an active fault code. | Fault Code 2692 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check for excessive black smoke. |
 | STEP 2A. Check the exhaust smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 3. | Check the aftertreatment particulate sensor. |
 | STEP 3A. Inspect the aftertreatment particulate sensor. | Aftertreatment particulate sensor damaged?
STEP 4. | Check the aftertreatment DPF. |
 | STEP 4A. Inspect the aftertreatment DPF. | Aftertreatment DPF damaged per Procedure 011-041 in the Associated Procedures Table?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment particulate sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4143, 4144, 4153, 4154, 5577, 5578, 5579, 5581, 5582, 5583, 5584, 5792, 5793, 5837, 6642, 6643, 6644, 6645, 6646, 6647, 6648, 6649, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment DPF fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1921, 1922, 1981, 1993, or 2639 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment DPF regeneration fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3375 or 3376 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Read the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2692 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for excessive black smoke.

Guided Step 2A - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected Test. Refer to Procedure 014-017 in the Associated Procedures Table.

To perform a snap acceleration test, it could be necessary to temporarily adjust the maximum engine speed with no vehicle speed sensor parameter in INSITE™ electronic service tool to the high idle speed of the engine.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Reference the appropriate engine performance troubleshooting tree, then return to this tree when complete.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment particulate sensor.

Guided Step 3A - Inspect the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

Action

Inspect the aftertreatment particulate sensor for damage.

  • Inspect the tip of the particulate sensor for contamination (liquids, chemicals, or other debris). Refer to Procedure 019-478 in the Associated Procedures Table.

Aftertreatment particulate sensor damaged?
YES NO

A damaged aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

Inspect for a damaged or missing aftertreatment particulate sensor water shield.

Repair or replace the aftertreatment particulate sensor water shield. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment DPF.

Guided Step 4A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

  • Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.
  • Inspect the aftertreatment DPF for cracks or other damage. Refer to Procedure 011-041 in the Associated Procedures Table for reuse guidelines.

Aftertreatment DPF damaged per Procedure 011-041 in the Associated Procedures Table?
YES NO

A damaged aftertreatment DPF has been detected.

Replace the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to 1A

Last Modified: 17-Jul-2017


FAULT CODE 2777 - Aftertreatment Regeneration Inhibited Due to Inhibit Switch - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISC8.3 and ISL9 CM2250 | 4022257
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2250 GX CM2250 | 4022250
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12/ISX11.9 CM2250 | 2883345
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2250 | 4022256
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2250 | 4022255
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSX11.9 CM2250 ECF | 2883561
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSX15 CM2250 ECF | 2883557
Exhaust System Diagnostics | Refer to Procedure 011-056 | PowerGen QSX15 CM2250 ECF | 4310661
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B101 | 2883567
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L101 | 4310787
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB4.5 CM2350 B104 | 4332646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF3.8 CM2350 F109 | 4367218
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSX15 CM2350 X105 | 4332667
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L111 | 4367223
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B142 | 5411131
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | F3.8 CM2350 F120B | 5411237
Exhaust System Diagnostics | Refer to Procedure 011-056 | B4.5 CM2350 B129 | 5411247
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B135B | 5411257
Exhaust System Diagnostics | Refer to Procedure 011-056 | B4.5 CM2350 B147B | 5411252
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B148B | 5411262
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L119B | 5411267
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465
Aftertreatment Testing | Refer to Procedure 014-013 | ISB6.7 CM2250 | 4022254
Aftertreatment Testing | Refer to Procedure 014-013 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Testing | Refer to Procedure 014-013 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Testing | Refer to Procedure 014-013 | QSL9 CM2250 | 4022256
Aftertreatment Testing | Refer to Procedure 014-013 | QSB6.7 CM2250 | 4022255
Aftertreatment Testing | Refer to Procedure 014-013 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Testing | Refer to Procedure 014-013 | QSX15 CM2250 ECF | 2883557
Aftertreatment Testing | Refer to Procedure 014-013 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Testing | Refer to Procedure 014-013 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSX15 CM2350 X105 | 4332667
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | L9 CM2350 L119B | 5411267

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2777 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2777 active?
YES NO

This fault code indicates that the aftertreatment regeneration permit switch was disabled when the ECM was requesting an active regeneration of the aftertreatment system.

Verify that the permit switch (inhibit switch) has been set up properly for the original equipment manufacturer (OEM) application. Refer to Procedure 011-056 in the Associated Procedures Table.

Refer to the OEM service manual or consult the OEM if the aftertreatment system has malfunctioned due to the permit switch (inhibit switch).

  • Perform the aftertreatment testing procedure to check the performance of the aftertreatment system. Refer to Procedure 014-013 in the Associated Procedures Table. Use the following procedure for ISB4.5 CM2350 B104, ISB6.7 CM2350 B103, ISF3.8 CM2350 F109, QSX15 CM2350 X105, and ISV5.0 CM3230 V104 engines. Refer to Procedure 014-016 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2017


FAULT CODE 2963 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | GX15 CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F114 | 4383734
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature. |
 | STEP 1A. Monitor coolant temperature. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature.

Guided Step 1A - Monitor coolant temperature.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 2964 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSF2.8 CM2880 F114 | 4383734
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSF2.8 CM2880 F131 | 5411489
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 CM2350 X102 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2350 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2880 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold temperature. |
 | STEP 1A. Monitor intake manifold temperature. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold temperature.

Guided Step 1A - Monitor intake manifold temperature.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Reference the the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS.

Replace the intake manifold temperature sensor. Use the following procedure for all except QSF2.8 CM2880 F114, QSF2.8 CM2880 F131, ISV5.0 CM3230 V104, and L9 CM2350 L123B applications. Refer to Procedure 019-159 in the Associated Procedures Table.

Use Procedure 019-059 for QSF2.8 CM2880 F114, QSF2.8 CM2880 F131, ISV5.0 CM3230 V104, and L9 CM2350 L123B applications. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-May-2017


FAULT CODE 3133 - Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3133 active?
STEP 2. | Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the accelerator pedal position sensor supply voltage and return circuit. | Fault Code 3134 active?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 3133 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3133 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

Fault Code 1695

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter outlet pressure sensor RETURN pin at the aftertreatment diesel particulate filter outlet pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet pressure sensor RETURN pin and the OEM harness aftertreatment diesel particulate filter outlet pressure sensor connector RETURN pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SUPPLY wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3134 - Aftertreatment 1 Diesel Particulate Filter Outlet Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2250 | 4022254
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISC8.3 and ISL9 CM2250 | 4021257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2250 | 4022256
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2250 | 4022255
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX11.9 CM2250 ECF | 2883561
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSX15 CM2250 ECF | 2883557
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | PowerGen QSX15 CM2250 ECF | 4310661
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B129B | 5411247
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B135B | 5411257
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B4.5 CM2350 B147B | 5411252
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | B6.7 CM2350 B148B | 5411262
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L119B | 5411267
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather Pack™ test lead, Part Number 3823996 - female Weather Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 3134 inactive?
STEP 2. | Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 3133 active?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3134 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 3134 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Fault Code 1696 troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel particulate filter outlet pressure sensor and circuit.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter outlet pressure sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter outlet pressure sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the sensor supply voltage and return circuit.

  • Measure the voltage between the aftertreatment diesel particulate filter outlet pressure SUPPLY pin and the aftertreatment diesel particulate filter outlet pressure RETURN pin at the aftertreatment diesel particulate filter outlet pressure sensor connector of the OEM harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin and the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin at the aftertreatment diesel particulate filter outlet pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter outlet pressure sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 active?
YES NO

A damaged sensor has been detected.

Replace the aftertreatment diesel particulate filter outlet pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet pressure sensor SUPPLY pin and the OEM harness aftertreatment diesel particulate filter outlet pressure sensor connector SUPPLY pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin and the OEM harness aftertreatment diesel particulate filter outlet pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter outlet pressure sensor from the OEM harness.

Action

Check for a pin to ground short.

  • Measure the resistance between the aftertreatment diesel particulate filter outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3134 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

The troubleshooting steps need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jan-2017


FAULT CODE 3213 - Tachograph Output Shaft Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3213 active?
STEP 2. | Check the original equipment manufacturer (OEM) VECU and engine engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3213 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Dec-2015


FAULT CODE 3326 - SAE J1939 Multiplexed Accelerator Pedal or Lever Sensor System - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F112 | 4383825
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9.3 CM2880 L113 | 4383811
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSC8.3 CM2880 C102 | 4388785
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2880 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3326 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3326 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for engine control module (ECM) communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ECM communication.

  • Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® engine ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connector to all other pins in the OEM connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3326 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Go to 6A

The appropriate ECM No Communication symptom tree

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Feb-2017


FAULT CODE 3328 - Transmission Output Shaft Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES NO
No Repair

A communication issue between the ECM and data link, a damaged ECM, or an incorrect calibration is causing the fault code.

Reference the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3328 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Reference Service Bulletin Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have ben completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3374 - Roll Over Protection Brake Control Active - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3374 active or inactive?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 3374.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3374 active or inactive?
YES NO

Cruise control was inhibited temporarily by the anti-lock braking (ABS) controller due to certain driving conditions. No repair is necessary. This fault code is for information only.

Cruise control was inhibited temporarily by the ABS controller due to certain driving conditions. No repair is necessary. This fault code is for information only.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Dec-2015


FAULT CODE 3418 - Transmission Output Shaft Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3418 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3418 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the transmission output shaft speed sensor or OEM vehicle electronic control unit. See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3488 - Anti-Lock Braking (ABS) Controller - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3488 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to No Cummunication Troubleshooting Tree in Section TT of the ISX15 CM2250 SN Service Manual, Bulletin 4310736.

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3488 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Use the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Dec-2015


FAULT CODE 3492 - Real Time Clock - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2150 B119 ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2150 B120 ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Verify fault condition and check engine control module (ECM) calibration. |
 | STEP 2A. Perform the diagnostic and verify the fault condition exists. | Fault Code 3492 active?
 | STEP 2B. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Refer to Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Verify fault condition and check ECM calibration.

Guided Step 2A - Perform the diagnostic and verify the fault condition exists.

Conditions

  • Turn keyswitch OFF.

Action

Perform the following steps in order to allow the diagnostic to run and complete and verify that the fault condition still exists.

  • Leave keyswitch off for at least 1 minute.
  • Turn keyswitch back on for 15 minutes.
  • At the end of 15 minutes, use INSITE™ electronic service tool to read the fault codes.

Fault Code 3492 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2017


FAULT CODE 3497 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3497 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3497 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2015


FAULT CODE 3498 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3498 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3498 active?
YES NO

A low aftertreatment diesel exhaust fluid (DEF) level has been detected.

Fill the DEF tank completely full.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jan-2016


FAULT CODE 3525 - Wheel-Based Vehicle Speed - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3525 is active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3525 is active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the wheel-based vehicle speed sensor or OEM vehicle electronic control unit.

See equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3526 - Wheel-Based Vehicle Speed - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3526 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3526 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3526 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 3A

Go to 6A

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Go to Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration matches the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3526 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

See the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 3527 - Accelerator Pedal or Lever Idle Validation Switch - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3527 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration udate for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3527 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Engine ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

There is an OEM issue with the accelerator pedal or lever idle validation switch or OEM vehicle electronic control unit.

Refer to the equipment manufacturer service information.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair Complete

Go to 1A

Last Modified: 09-Dec-2015


FAULT CODE 3528 - Accelerator Pedal or Lever Idle Validation Switch - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2880 B117 | 4358390
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3528 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3528 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3528 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM vehicle electronic control unit and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which vehicle electronic control unit multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM vehicle electronic control unit multiplexing configuration component enables and OEM vehicle electronic control unit source addresses from the appropriate OEM information or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM vehicle electronic control unit multiplexed component enables and source addresses.

Reference the Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM vehicle electronic control unit multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a vehicle electronic control unit, vehicle electronic control unit setup, or vehicle electronic control unit to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM vehicle electronic control unit source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connector to the J1939 data link harness connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3528 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM, or calibration is causing the fault code.

Go to 6A

The appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 20-Jan-2017


FAULT CODE 3539 - Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L11 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B144 | 5411382
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3539 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3539 inactive and Fault Code 3541 active?
 | STEP 2C. Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the engine intake throttle actuator position sensor supply and return circuit at the ECM. | 4.75 VDC to 5.25 VDC?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 3539 inactive and Fault Code 3541 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the engine intake throttle actuator connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 inactive and Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position +5 VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the engine intake throttle actuator position sensor supply and return circuit at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator position 5 VDC SUPPLY pin and the engine intake throttle actuator position return at the ECM port.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor SIGNAL pin and the engine intake throttle actuator position sensor RETURN pin at the ECM engine connector.

Check for the appropriate ECM response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 inactive and Fault Code 3541 active?
YES NO

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 3541 - Engine Intake Throttle Actuator Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L111 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B144 | 5411382
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISD6.7 CM2880 D101 | 5411372
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F129 | 5411325
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411186
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | ISD6.7 CM2880 D101 | 5411372
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F129 | 5411325
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | ISD6.7 CM2880 D101 | 5411372
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F129 | 5411325
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 3541 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3539 active and Fault Code 3541 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 3541 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins.. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and engine intake throttle actuator sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine harness connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active and Fault Code 3541 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine intake throttle actuator position sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES NO

Replace the engine intake throttle actuator. Refer to Procedure 010-140 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 3539 active and Fault Code 3541 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 3541 active?
YES NO

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator +5 VDC position SUPPLY pin and the engine intake throttle actuator position RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 3541 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2017


FAULT CODE 3542 - Engine Intake Throttle Actuator Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 E | 4022178
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 EC2CF | 4310846
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISB6.7 CM2350 B101 | 2883567
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L101 | 4310787
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISX15 CM2350 X101 | 4310641
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2250 | 4022256
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L102 | 4332796
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB6.7 CM2350 B105 | 4332778
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISL9 CM2350 L111 | 4367223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B106 | 4367376
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F117 | 4388578
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L107 | 4367386
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSB4.5 CM2350 B122 | 4388767
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISF2.8 CM2220 F126 | 5411159
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X114B | 5411181
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | X15 CM2350 X116B | 5411186
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | B6.7 CM2350 B121B | 5411223
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L116B | 5411330
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L119B | 5411267
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | QSL9 CM2350 L122 | 5411278
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 EC2CF | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 (174 HP and Above) | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor circuit fault codes. | Fault Code 3539 or 3541 active?
STEP 2. | Check the engine intake throttle actuator position sensor and circuit. |
 | STEP 2A. Inspect the engine intake throttle. | Engine intake throttle blocked or sticking?
 | STEP 2B. Inspect the engine harness and sensor connector pins | Dirty or damaged pins?
 | STEP 2C. Check the circuit response. | Fault Code 3539 active?
 | STEP 2D. Check the circuit response. | Fault Code 3541 active?
 | STEP 2E. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 3539 active?
 | STEP 3C. Check the ECM response. | Fault Code 3541 active?
 | STEP 3D. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor circuit fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 or 3541 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine intake throttle actuator position sensor and circuit.

Guided Step 2A - Inspect the engine intake throttle.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the intake throttle for blockage or obstruction.

Note: It is important to check for a frozen, plugged, or restricted engine intake air throttle in extreme cold ambient temperatures. Ice can form on the engine intake air throttle causing obstuction/sticking and may not be present at the time of troubleshooting.

Engine intake throttle blocked or sticking?
YES NO

A stuck or obstructed engine intake throttle actuator has been detected.

Remove the blockage or obstruction.

Refer to Procedure 010-140 in the Associated Procedures Table.

If icing is suspected, make sure ice is removed. Refer to Cold Weather Operations of Diesel Engines, Bulletin 3379009, to prevent future icing.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine harness and sensor connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 3539 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the engine intake throttle actuator connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES | NO
No Repair | No Repair

Go to 2E

Go to 3A

Guided Step 2E - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the engine intake throttle actuator position sensor +5 VDC SUPPLY pin and the engine intake throttle actuator position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for multimeter useage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

A stuck or broken engine intake throttle actuator has been detected.

Replace the engine intake throttle actuator.

Refer to Procedure 010-140 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to Procedure 019-361 in Section 19 for general inspection techniques.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3539 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake throttle actuator position sensor RETURN pin and the engine intake throttle actuator position sensor SIGNAL pin at the ECM engine connector.

  • Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3541 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the engine intake throttle actuator position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the engine intake throttle actuator position +5 VDC SUPPLY pin and the engine intake throttle actuator position RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for multimeter useage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO

An intermittent short or open circuit has been detected in the engine harness.

Repair or replace the engine harness.

019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jan-2017


FAULT CODE 3545 - Aftertreatment 1 Outlet NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK19 CM2350 K105 | 4326157
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK50 CM2350 K108 | 4332823
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K116 | 4367444
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K117 | 4367449
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K121 | 4388645
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B X15 CM2350 X116B | 5411181 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1887, 2771, or 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3545 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771 or 3681 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3545 active?
YES NO

An internal error has been detected in the aftertreatment outlet nitrogen oxides (NOx) sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3583 - Aftertreatment 1 Outlet NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2880 L112 | 4358493
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 F110 | 4358483
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL8.9 CM2150 L110 | 4358478
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB/ISD6.7 CM2150 B120 | 4358473
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB/ISD4.5 CM2150 B119 | 4354868
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B X15 CM2350 X116B | 5411181 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3583 active?
 | STEP 1B. Check for active fault codes. | Active or inactive counts of Fault Code 1887, 2771, or 3681?
 | STEP 1C. Check for active fault codes. | Fault Code 3144, 3146, 3147, or 3148 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxide (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3583 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1887, 2771, or 3681?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3144, 3146, 3147, or 3148 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet nitrogen oxide (NOx) sensor circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreament outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage with keyswitch ON while cranking the engine and with engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

A damaged aftertreatment outlet NOx sensor heater has been detected.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to the engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3649 - Aftertreatment 1 Intake NOx Sensor Heater - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3649 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 1885, 3232, or 3682 active?
 | STEP 1C. Check for active fault codes. | Fault Codes 3313, 3314, or 3315 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect the aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3649 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3232, or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3313, 3314, or 3315 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect the aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the OEM harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Disconnect the sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage with keyswitch ON, while cranking the engine and with engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

A damaged aftertreatment intake NOx sensor heater has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections and clean the terminals.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the OEM harness to the engine block ground.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3681 - Aftertreatment 1 Outlet NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220 F122 | 5467376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 SN | 4310736
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for the correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor correct for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
 | STEP 2F. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3681 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3681 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2C - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment outlet NOx sensor.

Action

Verify aftertreatment outlet NOx sensor is the correct sensor for the engine configuration.

The aftertreatment outlet NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment SCR catalyst outlet temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment outlet NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3681 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt system)
  • At least +24 VDC (24 volt system).

Cranking conditions:

  • At least +6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery (s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment outlet NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment outlet NOx sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-May-2017


FAULT CODE 3682 - Aftertreatment 1 Intake NOx Sensor Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411189
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB64.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor circuit. |
 | STEP 2A. Inspect aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
 | STEP 2E. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3682 active?
 | STEP 2F. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3682 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 3C. Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3682 active?
YES NO

No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor circuit.

Guided Step 2A - Inspect aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment intake NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor battery voltage return circuit at the NOx sensor wiring harness connector.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

the wiring diagram for connector pin identification.

Use the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment intake NOx sensor.

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine configuration.

The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3682 active?
YES NO

Use NOx sensor service tool, Part Number 2892467, to test aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 2F

Go to 4A

Guided Step 2F - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.
  • Operate the engine until the aftertreatment diesel oxidation catalyst intake temperature is above 150°C [302°F].

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

The exhaust gas temperature at the aftertreatment intake NOx sensor must be above 150°C [302°F] before the sensor can perform its internal diagnostics.

Fault Code 3682 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 FDC (12 volt system)
  • At least +24 VDC (24 volt system)/

Cranking conditions:

  • At least _6.2 VDC (12 volt system)
  • At least +12 VDC (24 volt system).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the aftertreatment intake NOx sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment intake NOx sensor battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 EC2CF | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
5467376Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module. | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2350 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES | NO
No Repair | No Repair

Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the engine control module (ECM).

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to calibrate the ECM with the latest engine calibration. Refer to the calibration revisions listed in the ECM Calibration Revision History to find the latest calibration available for the engine being serviced.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 22-May-2017


FAULT CODE 3712 - Aftertreatment SCR Operator Inducement - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3712 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active selective catalyst reduction (SCR) related fault codes.

Fault Code 3712 active?
YES NO

This is an information only fault code that will only become active if other SCR related fault codes are active for an extended period of time.

Troubleshoot all other active SCR related fault codes.

This fault code will become inactive when all other active SCR related fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 3714 - Engine Protection Torque Derate - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3714 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 3714

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for other active fault codes.

Fault Code 3714 active?
YES NO

This is an information-only fault code that will only become active if other critical engine performance fault codes are active for an extended period of time.

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes are resolved.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Sep-2012


FAULT CODE 3717 - Aftertreatment 1 Outlet NOx Sensor - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF2.8 CM2220/ISF2.8 CM2220 AN | 4022178
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2220 AN | 4021704
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2250 | 4022254
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB64.5 CM2350 B104 | 4332646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 X101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK19 CM2350 K105 | 4326157
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L102 | 4332796
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK50 CM2350 K108 | 4332823
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L111 | 4367223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K116 | 4367444
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K117 | 4367449
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSK60 CM2350 K121 | 4388645
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L107 | 4367386
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSL9 CM2350 L118 | 4388673
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | F3.8 CM2350 F120B | 5411237
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B129B | 5411247
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B135B | 5411257
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B4.5 CM2350 B147B | 5411252
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B148B | 5411262
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L119B | 5411267
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | QSG12 CM2350 G110 | 4367323
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3681 active?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check the aftertreatment outlet NOx sensor. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment outlet NOx sensor. | Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
 | STEP 2C. Check the condition of the aftertreatment outlet NOx sensor. | Fault Code 3717 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3717 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment outlet NOx sensor circuit.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter setting.

  • Use INSITE™ electronic tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment outlet NOx sensor.

Action

Verify the aftertreatment outlet NOx sensor is the correct sensor for the engine CPL.

The aftertreatment outlet NOx sensor is available in 12 or 24 volt versions.

Aftertreatment outlet NOx sensor is the correct sensor for the engine CPL?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch ON.
  • Connect the aftertreatment outlet NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 3717 active?
YES NO

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Note: The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 3718 - Aftertreatment 1 Intake NOx - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.5 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 QSK60 CM2350 K117 QSK60 CM2350 K121 | 4367444 4367449 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3718 active?
STEP 2. | Check the aftertreatment intake nitrogen oxides (NOx) sensor. |
 | STEP 2A. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine control parts list (CPL)?
 | STEP 2B. Check for correct aftertreatment intake NOx sensor. | Aftertreatment intake NOx sensor the correct sensor for the engine CPL?
 | STEP 2E. Check the condition of the aftertreatment intake NOx sensor. | Fault Code 3718 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3718 active?
YES NO

No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment intake NOx sensor.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool "Features and Parameters" feature to determine electrical system voltage.
  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical system voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 2B

Go to 3A

Guided Step 2B - Check for correct aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment intake NOx sensor

Action

Verify aftertreatment intake NOx sensor is the correct sensor for the engine CPL.

Note: The aftertreatment intake NOx sensor is available in 12 volt or 24 volt versions.

Aftertreatment intake NOx sensor is the correct sensor for the engine CPL?
YES NO
No Repair

An incorrect aftertreatment outlet NOx sensor for the voltage application has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment intake NOx sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3718 active?
YES NO

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 3725 - Aftertreatment 1 Intake NOx Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB4.3 CM2350 B104 | 4332646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2250 | 4022254
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B103 | 4332641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISC8.3 and ISL9 CM2250 | 4022257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2250 GX CM2250 | 4022250
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12/ISX11.9 CM2250 | 2883445
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2250 | 4022256
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2250 | 4022255
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK19 CM2350 K105 | 4326157
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK50 CM2350 K108 | 4332823
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 | 4332778
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L102 | 4332796
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L111 | 4367223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSG12 CM2350 G110 | 4367323
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L107 | 4367386
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSK60 CM2350 K116 QSK60 CM2350 K117 QSK60 CM2350 K121 | 4367444 4367449 4388645
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSL9 CM2350 L118 | 4388673
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B142 | 5411131
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | F3.8 CM2350 F120B | 5411237
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B129B | 5411247
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B135B | 5411257
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B4.5 CM2350 B147B | 5411252
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B148B | 5411262
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L119B | 5411267
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1885, 3232, or 3682 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3725 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 1885, 3232 or 3682 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3725 active?
YES NO

An internal error has been detected in the aftertreatment intake mono-nitrogen oxide (NOx) sensor.

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 3737 - Engine Starter Mode Overcrank Protection - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3737 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3737 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

Use the appropriate troubleshooting symptom tree in the appropriate Service Manual.

  • Refer to Engine Will Not Crank or Cranks Slowly (Electric Starter) troubleshooting symptom tree in Section TS.
  • Refer to the Engine Performance troubleshooting symptom tree in Section TT.

 No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 01-Nov-2016


FAULT CODE 3867 - Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B105 | 4332778
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L102 | 4332796
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F107 | 4367316
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B106 | 4367376
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F118 | 4388708
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B130 | 4388668
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L118 | 4388673
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B122 | 4388767
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3867. | Fault Code 3867 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF concentration. | DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3867.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3867 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF Refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. Refer to Procedure 019-475 in the Associated Procedures Table. For B6.7 CM2350 B121B, ISB6.7 CM2350 B101, ISL9 CM2350 L101, and ISV5.0 CM3230 V104 engines, see equipment manufacturer service information.

Drain the DEF fluid tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to

Last Modified: 09-Jan-2017


FAULT CODE 3878 - Aftertreatment Diesel Exhaust Fluid Quality - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 3878. | Fault Code 3878 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the aftertreatment DEF concentration. | Aftertreatment DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 3878.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3878 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the DEF concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning aftertreatment DEF quality sensor has been detected.

  • Replace the aftertreatment DEF quality sensor. Refer to Procedure 019-475 in the Associated Procedures Table.
  • See equipment manufacturer service information for B6.7 CM2350 B121B, ISB6.7 CM2350 B101, ISL9 CM2350 L101, ISX15 CM2350 X101, ISX12 CM2350 X102, and ISV5.0 CM3230 V104 products.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4143 - Aftertreatment 1 Particulate Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4143 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4143 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4144 - Aftertreatment 1 Particulate Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4144 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4144 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4153 - Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4153 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4153 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4154 - Aftertreatment 1 Particulate Sensor Heater Low Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4154 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4154 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 4213 - Aftertreatment Regeneration Inhibit Switch - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB4.5 CM2350 B104 | 4332646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B101 | 2883567
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B103 | 4332641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L101 | 4310787
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L111 | 4367223
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF3.8 CM2350 F109 | 4367218
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B142 | 5411131
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | F3.8 CM2350 F120B | 5411237
Exhaust System Diagnostics | Refer to Procedure 011-056 | B4.5 CM2350 B129B | 5411247
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B135B | 5411257
Exhaust System Diagnostics | Refer to Procedure 011-056 | B4.5 CM2350 B147B | 5411252
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B148B | 5411262
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 B119B | 5411267
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4213 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4213 active?
YES NO

This fault code indicates that the aftertreatment regeneration permit switch was disabled and the soot load of the diesel particulate filter (DPF) is above a calibrated threshold.

Perform an Aftertreatment Stationary Regeneration.

Verify that the permit switch (inhibit switch) has been set up properly for the original equipment manufacturer (OEM) application. Refer to Procedure 011-056 in the Associated Procedures Table.

See equipment manufacturer service information or consult the OEM if the aftertreatment system has malfunctioned due to the permit switch (inhibit switch).

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 4215 - Anti-Lock Braking (ABS) Active - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4215 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4215 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

This fault code indicates that the cruise control was disabled due to the ABS controller transmitting a message to the ECM indicating wheel slip. This is an information only fault.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 21-Apr-2017


FAULT CODE 4233 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4233 active?
 | STEP 1B. Check for fault codes. | Active or inactive counts of Fault Code 3868?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4233 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3868?
YES NO
No Repair

An internal error has been detected in the aftertreatment diesel exhaust fluid quality temperature sensor circuit.

Replace the aftertreatment diesel exhaust fluid quality sensor. See equipment manufacturer service information.

Fault Code 3868

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 08-Mar-2017


FAULT CODE 4234 - Aftertreatment 1 Diesel Exhaust Fluid Temperature 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4234 active?
 | STEP 1B. Check for fault codes. | Active or inactive counts of Fault Code 3868?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4234 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3868?
YES NO
No Repair

An internal error has been detected in the aftertreatment diesel exhaust fluid quality temperature sensor circuit.

Replace the aftertreatment diesel exhaust fluid quality sensor. See equipment manufacturer service information.

Fault Code 3868

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 08-Mar-2017


FAULT CODE 4252 - Engine Wait to Start Lamp - Condition Exists

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4252 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4252 active?
YES | NO
No Repair | No Repair

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

  • Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

There is an OEM issue with the multiplexed wait to start lamp or OEM VECU.

Refer to the OEM service manual.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jan-2015


FAULT CODE 4277 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L102 | 4332796
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISF3.8 CM2350 F109 | 4367318
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B106 | 4367316
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L107 | 4367386
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSL9 CM2350 L118 | 4388673
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | X15 CM2350 X114B | 5411186
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | F3.8 CM2350 F120B | 5411237
Aftertreatment Diesel Exhaust Fluid Quality Sensor | Refer to Procedure 019-475 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4277. | Fault Code 4277 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Inspect aftertreatment DEF tank for contamination. | Foreign objects or debris detected in the DEF tank?
 | STEP 2B. Check the DEF concentration. | DEF concentration within 32.5 percent ± 1.5 percent?
 | STEP 2C. Check for low DEF tank level. |
 | STEP 2D. Check for Fault Code 4277. |
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4277.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4277 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for foreign objects or debris.

Foreign objects or debris detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use a DEF Cummins® refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.

DEF concentration within 32.5 percent ± 1.5 percent?
YES NO
No Repair

Drain the DEF tank and fill with new DEF.

Go to 2C

Go to 3A

Guided Step 2C - Check for low DEF tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank level.

  • Check that tank level is at least 50 percent.

Tank level is less than 50 percent?
YES NO

Fill tank completely with fresh DEF.

 No Repair

Go to 2D

Go to 2D

Guided Step 2D - Check for Fault Code 4277.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Wait 5 minutes.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4277 active?
YES NO

A malfunctioning DEF quality sensor has been detected. Refer to Procedure 019-475 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps haven been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 12-Jun-2017


FAULT CODE 4449 - Aftertreatment 1 Particulate Sensor Regeneration Status - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4143, 4144, 4153, 4154, 5577, 5578, 5579, 5581, 5582, 5583, 5584, 5792, 5793, 5837, 6642, 6643, 6644, 6645, 6646, 6647, 6648, 6649, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes. | Fault Code 1879, 1881, 1883, 1921, 1922, 1981, 1993, or 2639 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Read the fault codes. | Fault Code 3375 or 3376 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1D. Read the fault codes. | Fault Code 4449 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment particulate sensor faults.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4143, 4144, 4153, 4154, 5577, 5578, 5579, 5581, 5582, 5583, 5584, 5792, 5793, 5837, 6642, 6643, 6644, 6645, 6646, 6647, 6648, 6649, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment diesel particulate filter (DPF) fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, 1883, 1921, 1922, 1981, 1993, or 2639 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment DPF fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3375 or 3376 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1D

Guided Step 1D - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4449 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A malfunction has been detected in the aftertreatment particulate matter sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete

Repair complete

Last Modified: 29-Jul-2016


FAULT CODE 4584 - Aftertreatment Diesel Particulate Filter System - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | QSG12 CM2350 G110 | 4367323
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | B6.7 CM2350 B121B | 5411223
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L116B | 5411330
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | X15 CM2350 X114B | 5411181
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | X15 CM2350 X116B | 5411186
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4584 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4584 active?
YES NO

This fault code indicates that the incorrect aftertreatment diesel particulate filter (DPF) system has been installed with the engine.

Verify the correct aftertreatment DPF system has been installed with the engine.

If the incorrect aftertreatment DPF system has been installed, replace it with the correct aftertreatment DPF system. Refer to Procedure 011-041 in the Associated Procedures Table.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Jan-2017


FAULT CODE 4585 - Aftertreatment 1 SCR Catalyst System - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL9 CM2350 L101 | 4310787
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX12 CM2350 X102 | 4310646
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISX15 CM2350 X101 | 4310641
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK19 CM2350 K105 | 4326157
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B105 | 4332778
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L102 | 4332796
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK50 CM2350 K108 | 4332833
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | ISL9 CM2350 L111 | 4367223
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B112 | 4358498
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSF3.8 CM2350 F107 | 4367316
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK50 CM2350 K108 | 4332823
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK19 CM2350 K105 | 4326157
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB4.5 CM2350 B106 | 4367376
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK60 CM2350 K116 | 4367444
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK60 CM2350 K117 | 4367449
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSG12 CM2350 G110 | 4367323
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L107 | 4367386
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB6.7 CM2350 B130 | 4388668
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSL9 CM2350 L118 | 4388673
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | L9 CM2350 L123B | 5411465
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSK60 CM2350 K121 | 4388645
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSF3.8 CM2350 F118 | 4388708
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | QSB4.5 CM2350 B122 | 4388767
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | X15 CM2350 X114B | 5411181
Aftertreatment Selective Catalytic Reduction (SCR) Catalyst | Refer to Procedure 011-036 | X15 CM2350 X116B | 5411186
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Does one of the scenarios apply?"
 | STEP 1B. Check for active fault codes. | Fault Code 4585 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Determine if the calibration and selective catalytic reduction (SCR) are compatible.

The following scenarios that can lead to Fault Code 4585 coming active. Below are the listed scenarios and solutions:

1. A calibration has been transferred to an ECM that has under 50 hours of cumulative Engine Run Time

  • Follow Repair 1 directions.

2. A calibration has been transferred to an ECM after an ECM ROM Boot

  • Follow Repair 2 directions.

3. A calibration has been transferred to the new ECM after an ECM replacement

  • Follow Repair 2 directions.

4. Save and Restore doesn’t perform correctly during calibration transfer, Engine Run Time is under 50 hours

  • Follow Repair 2 directions.

5. Save and Restore doesn’t perform correctly during calibration transfer, Engine Run Time is over 50 hours

  • Follow Repair 3 directions.

Does one of the scenarios apply?
YES NO

Repair 1:

  • Install a new SCR Temperature Sensor Module. Refer to procedure 011-036 in the Associated Procedures Table. A new SCR Temperature Sensor Module can be ordered using the current part number on the module.
  • Perform a Reset All Faults command in INSITE™. This will force the diagnostic to run again and will make the code go inactive.

Repair 2:

  • Install a new SCR Temperature Sensor Module. Refer to procedure 011-036 in the Associated Procedures Table. A new SCR Temperature Sensor Module can be ordered using the current part number on the module.
  • Perform a Reset All Faults command in INSITE™. This will force the diagnostic to run again and will make the code go inactive.
  • Transfer template to ECM. Verify information has been transferred correctly.

Repair 3:

  • ROM Boot the ECM and transfer the calibration.
  • Install a new SCR Temperature Sensor Module. Refer to procedure 011-036 in the Associated Procedures Table. A new SCR Temperature Sensor Module can be ordered using the current part number on the module.
  • Perform a Reset All Faults command in INSITE™. This will force the diagnostic to run again and will make the code go inactive.
  • Transfer template to ECM. Verify information has been transferred correctly.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4585 active?
YES NO

This fault code indicates that the incorrect aftertreatment selective catalytic reduction system has been installed with the engine.

Verify the correct aftertreatment selective catalytic reduction system has been installed with the engine.

If the incorrect aftertreatment selective catalytic reduction system has been installed, replace it with the correct aftertreatment selective catalytic reduction system. Refer to procedure 011-036 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-May-2017


FAULT CODE 4658 - Aftertreatment 1 Diesel Exhaust Fluid Actual Dosing Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISB6.7 CM2350 B101 | 2883567
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISF3.8 CM2350 F109 | 4367218
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L101 | 4310787
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISL9 CM2350 L111 | 4367223
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISF3.8 CM2350 F109 | 4367218
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISL9 CM2350 L101 | 4310641
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISB6.7 CM2350 B101 | 4367223
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Exhaust Fluid Dosing Unit Filter | Refer to Procedure 011-060 | L9 CM2350 L123B | 5411465
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9 CM2350 L101 | 4310787
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX12 CM2350 X102 | 4310646
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISX15 CM2350 X101 | 4310641
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISL9 CM2350 L111 | 4367223
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | L9 CM2350 L123B | 5411465
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISF3.8 CM2350 F109 | 4367218
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4658 active?
STEP 2. | Check the diesel exhaust fluid (DEF) dosing system. |
 | STEP 2A. Check the DEF for contamination or debris. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
 | STEP 2C. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 3. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 3A. Perform the Aftertreatment DEF Doser Pump Override Test. | Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4658 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the DEF for contamination or debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Visually inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® Diesel Exhaust Fluid Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank and rinse the tank with water.

Refill the DEF tank with pure DEF. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Use the following procedure for ISV5.0 or ISF3.8 engines. Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-062 in the Associated Procedures Table. Use the following procedure for ISV5.0 or ISF3.8 engines. Refer to Procedure 011-098 in the Associated Procedures Table.

No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Remove aftertreatment DEF dosing valve from decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.
  • The DEF dosing valve must be removed and placed in a measuring container in order to run the Diesel Exhaust Fluid Doser Pump Override Test. Make sure the DEF dosing unit is not plugged and DEF is flowing from all holes.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit filter. (Note that this filter can not be reused and must be changed upon removal.) Refer to Procedure 011-060 in the Associated Procedures Table.

Perform the aftertreatment DEF doser pump override test again with the new filter. If the dosing unit still does not operate according to the specifications, replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF dosing unit operation.

Guided Step 3A - Perform the Aftertreatment DEF Doser Pump Override Test.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Clean or replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Jan-2017


FAULT CODE 4731 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4731 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4731 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid (DEF) tank temperature sensor has been detected.

Replace the aftertreatment DEF tank temperature sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Nov-2015


FAULT CODE 4732 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4732 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4732 active?
YES NO

A malfunctioning aftertreatment diesel exhaust fluid (DEF) tank level sensor has been detected.

Replace the aftertreatment DEF tank level sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Nov-2015


FAULT CODE 4747 - Aftertreatment Intake Oxygen Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX12 CM2350 X102 | 4310646
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4747 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 1885, 3232, 3649, 3682, or 3748 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for active fault codes. | Fault Code 122, 123, 124, 125, 155, 221, 222, 295, or 488 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1D. Check for active fault codes. | Fault Code 595, 687, 1228, 1896, 1938, 1961, 1962, 1976, 2198, 2272, 2273, 2274, 2288, 2349, 2353, 2387, 2449, 2634, 2636, 2961, 2962, 2964, 2973, 4612, 4956, 4957, or 5177 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Verify proper installation of the aftertreatment nitrogen oxides (NOx) sensor. |
 | STEP 1F. Check for active fault codes. | Fault Code 4749 or 4751 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4747 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active NOx sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 3232, 3649, 3682, or 3748 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code Fault Code 122, 123, 124, 125, 155, 221, 222, 295, or 488 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595, 687, 1228, 1896, 1938, 1961, 1962, 1976, 2198, 2272, 2273, 2274, 2288, 2349, 2353, 2387, 2449, 2634, 2636, 2961, 2962, 2964, 2973, 4612, 4956, 4957, or 5177 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Verify proper installation of the aftertreatment nitrogen oxides (NOx) sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment intake NOx sensor.

  • Inspect the aftertreatment intake NOx sensor for proper installation. Refer to Procedure 019-463 in the Associated Procedures Table.

Aftertreatment intake NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 1F

Go to 2A

Guided Step 1F - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active NOx sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4749 or 4751 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment outlet NOx sensor and aftertreatment intake NOx sensor have been detected.

  • Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.
  • Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

A damaged aftertreatment intake NOx sensor has been detected.

  • Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Jan-2017


FAULT CODE 4748 - Aftertreatment Intake Oxygen Sensor - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISL9 CM2350 L101 | 4310787
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISL9 CM2350 L101 | 4310787
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISX15 CM2350 X101 | 4310641
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | B6.7 CM2350 B121B | 5411223
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L116B | 5411330
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X114B | 5411181
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | X15 CM2350 X116B | 5411186
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4748 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 1885, 3232, 3649, 3682, or 3748 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for active fault codes. | Fault Code 122, 123, 124, 125, 155, 221, 222, 295, or 488 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1D. Check for active fault codes. | Fault Code 595, 687, 1228, 1896, 1938, 1961, 1962, 1976, 2198, 2272, 2273, 2274, 2288, 2349, 2353, 2387, 2449, 2634, 2636, 2961, 2962, 2964, 2973, 4612, 4956, 4957, or 5177 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1E. Verify proper installation of the aftertreatment nitrogen oxides (NOx) sensor. |
 | STEP 1F. Check for active fault codes. | Fault Code 4749 or 4751 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4748 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active NOx sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 3232, 3649, 3682, or 3748 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122, 123, 124, 125, 155, 221, 222, 295, or 488 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595, 687, 1228, 1896, 1938, 1961, 1962, 1976, 2198, 2272, 2273, 2274, 2288, 2349, 2353, 2387, 2449, 2634, 2636, 2961, 2962, 2964, 2973, 4612, 4956, 4957, or 5177 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Verify proper installation of the aftertreatment nitrogen oxides (NOx) sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment intake NOx sensor.

  • Inspect the aftertreatment intake NOx sensor for proper installation. Refer to Procedure 019-463 in the Associated Procedures Table.

Aftertreatment intake NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 1F

Go to 2A

Guided Step 1F - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active NOx sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4749 or 4751 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment outlet NOx sensor and aftertreatment intake NOx sensor have been detected.

  • Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.
  • Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

A damaged aftertreatment intake NOx sensor has been detected.

  • Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Jan-2017


FAULT CODE 4768 - Aftertreatment 1 Diesel Exhaust Fluid Property - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B105 | 4332778
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L102 | 4332796
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F107 | 4367316
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B106 | 4367376
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F118 | 4388708
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B130 | 4388668
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L118 | 4388673
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B122 | 4388767
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L116B | 5411330
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | B6.7 CM2350 B121B | 5411223
Exhaust System Diagnostics | Refer to Procedure 011-056 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4768. | Fault Code 4768 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF tank for contamination. | Diesel fuel detected in the DEF tank?
 | STEP 2B. Check the aftertreatment DEF for contamination and concentration. | DEF concentration within 32.5 ± 1.25 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4768.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4768 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the aftertreatment DEF for contamination and concentration.

Guided Step 2A - Check the DEF tank for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Inspect the DEF tank for diesel fuel. Refer to Procedure 011-056 in the Associated Procedures Table.

Diesel fuel detected in the DEF tank?
YES NO

Drain the DEF tank. Flush and clean the DEF tank with distilled water.

Fill the tank with fresh DEF.

Diesel contamination may damage the DEF quality sensor.

Replace the DEF quality sensor. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF Refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. See equipment manufacturer service information.

Drain the DEF tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to

Last Modified: 08-Jan-2017


FAULT CODE 4842 - Aftertreatment Diesel Exhaust Fluid Quality - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B105 | 4332778
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L102 | 4332796
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B112 | 4358498
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F107 | 4367316
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B106 | 4367376
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSG12 CM2350 G110 | 4367323
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L107 | 4367386
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSF3.8 CM2350 F118 | 4388708
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB6.7 CM2350 B130 | 4388668
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L118 | 4388673
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX15 CM2350 X101 | 4310641
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISX12 CM2350 X102 | 4310646
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSB4.5 CM2350 B122 | 4388767
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X114B | 5411181
Exhaust System Diagnostics | Refer to Procedure 011-056 | X15 CM2350 X116B | 5411186
Exhaust System Diagnostics | Refer to Procedure 011-056 | QSL9 CM2350 L118 | 4388673

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 4842. | Fault Code 4842 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) concentration. |
 | STEP 2A. Check the DEF concentration. | DEF concentration within 32.5 ± 1.5 percent?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 4842.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4842 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the aftertreatment DEF concentration.

Guided Step 2A - Check the DEF concentration.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF concentration.

  • Use DEF refractometer, Part Number 4919318, to measure the concentration of the DEF in the tank.
  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration within 32.5 ± 1.5 percent?
YES NO

A malfunctioning DEF quality sensor has been detected. See equipment manufacturer service information.

Drain the DEF fluid tank and fill with new DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to 1A

Last Modified: 05-May-2017


FAULT CODE 4956 - Variable Geometry Turbocharger Actuator Software - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L101 | 4310789
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISF2.8 CM2220 F101 | 4310846
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L102 | 4332796
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L111 | 4367223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L107 | 4367386
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L1118 | 4388673
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B121B | 5411223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L116B | 5411330
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X114B | 5411181
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X116B | 5411186
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISX12 CM2350 X102 | 4310646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSX15 CM2350 X105 | 4332667
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L122 | 5411278
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B129B | 5411247
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B135B | 5411257
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B147B | 5411252
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B148B | 5411262
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L119B | 5411267
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4956 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for Active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4956 active?
YES NO

The turbocharger application identification number in the variable geometry turbocharger (VGT) actuator does not match the turbocharger application identification number in the ECM.

Download the turbocharger actuator calibration code with the correct turbocharger application identification number into the VGT actuator.

  • Refer to Procedure 010-150 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 4957 - Variable Geometry Turbocharger Actuator Software - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB4.5 CM2350 B104 | 4332646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B103 | 4332641
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B101 | 2883567
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L101 | 4310789
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISL9 CM2350 L111 | 4367223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISF2.8 CM2220 F101 | 4310846
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B105 | 4332778
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L102 | 4332796
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B112 | 4358498
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B106 | 4367376
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L107 | 4367386
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B130 | 4388668
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L118 | 4388673
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISB6.7 CM2350 B142 | 5411131
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | ISX12 CM2350 X102 | 4310646
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L116B | 5411330
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB6.7 CM2350 B145 | 5411273
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSL9 CM2350 L122 | 5411278
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | QSB4.5 CM2350 B144 | 5411382
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B121B | 5411223
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X114B | 5411181
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | X15 CM2350 X116B | 5411186
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B129B | 5411247
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B135B | 5411257
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B4.5 CM2350 B147B | 5411252
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | B6.7 CM2350 B148B | 5411262
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L119B | 5411267
Turbocharger Actuator Calibration Code | Refer to Procedure 010-150 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4957 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4957 active?
YES NO

The turbocharger actuator interface level in the variable geometry turbocharger (VGT) actuator is not compatible with the ECM software.

Check the turbocharger interface level in the VGT actuator and the allowed turbocharger interface levels using the Turbocharger Actuator Compatibility feature under Advanced ECM Data in INSITE electronic service tool.

Download the turbocharger actuator calibration code with the correct turbocharger application identification number and interface level.

Refer to Procedure 010-150 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2017


FAULT CODE 5177 - Variable Geometry Turbocharger Actuator Software - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5177 active?
 | STEP 1B. Check the fault codes. | Fault Code 2636 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 5177 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 2A

Guided Step 1B - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 2636 active?
YES | NO
No Repair | No Repair

Go to Fault Code 2636 troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jun-2013


FAULT CODE 5577 - Aftertreatment 1 Particulate Sensor Power Supply - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5577 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5577 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5578 - Aftertreatment 1 Particulate Sensor Power Supply - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5578 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2C. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5578 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5579 - Aftertreatment 1 Particulate Sensor Power Supply - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5579 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5579 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5581 - Aftertreatment 1 Particulate Sensor Heater Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5581 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5581 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor. Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5582 - Aftertreatment 1 Particulate Sensor Module Battery Voltage Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, 6257, or 6499 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment particulate sensor circuit. |
 | STEP 2A. Inspect aftertreatment particulate sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment particulate sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check the condition of the aftertreatment particulate sensor. | Fault Code 5582 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment particulate sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, 6257, or 6499 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment particulate sensor circuit.

Guided Step 2A - Inspect aftertreatment particulate sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment particulate sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet particulate sensor module.

  • Measure the voltage between the battery voltage supply circuit and the battery voltage return circuit at the aftertreatment particulate sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment particulate sensor.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 5582 active?
YES NO

A malfunctioning aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment particulate sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment particulate sensor battery voltage SUPPLY pin of the OEM harness to battery ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment outlet particulate sensor module battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment outlet particulate sensor module battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5583 - Aftertreatment 1 Particulate Sensor Detection Status - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5583 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5583 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5584 - Aftertreatment 1 Particulate Sensor Regeneration Status - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5584 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment particulate sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5584 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A malfunction has been detected in the aftertreatment particulate matter sensor.

Replace the aftertreatment particulate matter sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5792 - Aftertreatment 1 Particulate Sensor Heater High Side Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5792 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the battery. |
 | STEP 2A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 2B. Check battery voltage. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 2C. Check for active fault codes. | Fault Code 5792 active or inactive with more than one count logged in the last 25 engine hours?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment particulate sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5792 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the battery.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems)

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volt systems)

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5792 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5837 - Aftertreatment 1 Particulate Sensor - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM2350 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5837 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment particulate sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5837 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Appropriate fault code troubleshooting tree

2A

Guided Step 2 - Check the aftertreatment particulate sensor.

Guided Step 2A - Check sensor condition.

Conditions

  • Turn keyswitch OFF.

Action

Inspect aftertreatment particulate sensor.

  • Check that sensor is installed properly and not missing.
  • Inspect sensor tip for damage.
  • Refer to Procedure 019-478 in the Associated Procedures Table.

Sensor present and undamaged?
YES NO
No Repair

A missing or damaged aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Jan-2017


FAULT CODE 5952 - Engine Charge Air Cooler Outlet Pressure - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 5952 inactive?
STEP 2. | Check the charge-air cooler outlet pressure sensor and circuit. |
 | STEP 2A. Inspect the charge-air cooler outlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5953 active and Fault Code 5952 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5952 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the charge-air cooler outlet pressure sensor and circuit.

Guided Step 2A - Inspect the charge-air cooler outlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure sensor from the engine harness.

Action

Inspect the engine harness and charge-air cooler outlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 active and Fault Code 5952 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the charge-air cooler outlet pressure +5 volt SUPPLY pin to the charge-air cooler outlet pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the charge-air cooler outlet pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 active?
YES NO

A damaged sensor has been detected.

Replace the charge-air cooler outlet pressure sensor. Refer to Procedure 019-560 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 active and Fault Code 5952 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the charge-air cooler outlet pressure +5 volt SUPPLY pin to the charge-air cooler outlet pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5953 - Engine Charge Air Cooler Outlet Pressure - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 5953 inactive?
STEP 2. | Check the charge-air cooler outlet pressure sensor and circuit. |
 | STEP 2A. Inspect the charge-air cooler outlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5952 active and Fault Code 5953 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 5953 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the charge-air cooler outlet pressure sensor and circuit.

Guided Step 2A - Inspect the charge-air cooler outlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure sensor from the engine harness.

Action

Inspect the engine harness and charge-air cooler outlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 active and Fault Code 5953 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the charge-air cooler outlet pressure +5 volt SUPPLY pin to the charge-air cooler outlet pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the charge-air cooler outlet pressure to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 active?
YES NO

A damaged sensor has been detected.

Replace the charge-air cooler outlet pressure sensor. Refer to Procedure 019-560 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 active and Fault Code 5953 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the charge-air cooler outlet pressure +5 volt SUPPLY pin to the charge-air cooler outlet pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6417 - SAE J1939 Multiplexing Remote Accelerator Pedal or Lever Sensor System - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 6417 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Monitor the remote accelerator parameters with INSITE™ electronic service tool. |
 | STEP 3A. Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
 | STEP 3B. Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM. | Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6417 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the SAE J1939 data link to the engine ECM and compare to the engine ECM configuration

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for proper multiplexing configuration.

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Does the engine ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 4A

Guided Step 3 - Monitor the remote accelerator parameters with INSITE™ electronic service tool.

Guided Step 3A - Determine if the remote throttle switch and or remote accelerator parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool
  • Make sure the remote throttle switch is ON and the remote accelerator is in the released position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Status/Idle Validation

Monitor parameters can possibly notappear in the electronic service tool exactly as listed above.

When the remote throttle is released, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value of 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value of 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, the remote throttle, or the OEM VECU.

Refer to the appropriate OEM service manual for further instructions.

Go to 3B

Go to 4A

Guided Step 3B - Determine if the remote throttle switch and or remote throttle parameters are being received properly by the engine ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Make sure the remote throttle switch is ON and the remote accelerator is in the depressed position.

Action

Monitor the following parameters in INSITE™ electronic service tool Monitor Mode:

  • Percent Throttle
  • Remote Throttle Switch Status

Monitor parameters can possibly notappear in the electronic service tool exactly as shown above.

When the remote throttle is depressed, the Remote Throttle Switch parameter mustdisplay ON and the Percent Throttle parameter mustdisplay a value greater than 0.

Remote Throttle Switch parameter displays ON and Percent Throttle parameter displays a value greater than 0?
YES NO
No Repair

There is an OEM issue with the remote throttle switch, or the remote throttle, or the OEM VECU.

Refer to the OEM service manual for further instructions.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Jul-2016


FAULT CODE 6642 - Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6642 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6642 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment DPF sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6643 - Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6643 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6643 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment DPF sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6644 - Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6644 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6644 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6645 - Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature 2 Circuit - Voltage Below Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6645 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6645 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6646 - Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6646 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6646 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6647 - Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6647 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6647 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6648 - Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 6648 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, 6651, 6652, 6653, or 6688 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6648 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6649 - Aftertreatment 1 Diesel Particulate Filter Soot Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5582, 5583, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 3148 or 6268 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for active fault codes. | Fault Code 6649 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?
 | STEP 2C. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5582, 5583, or 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active selective catalyst reduction (SCR) outlet temperature fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3148 or 6268 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6649 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

An internal error has been detected in the aftertreatment particulate sensor.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6651 - Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6651 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment particulate sensor circuit. |
 | STEP 2A. Inspect the aftertreatment particulate sensor and connector pins. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 2B. Check the voltage to the aftertreatment particulate sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment particulate sensor. | Aftertreatment particulate sensor the correct sensor for engine configuration?
 | STEP 2E. Check for active fault codes. | Fault Code 6651 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment particulate sensor battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4B. Disable the fault code. | Fault code inactive?
 | STEP 2C. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6651 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment particulate sensor circuit.

Guided Step 2A - Inspect the aftertreatment particulate sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment particulate sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment particulate sensor.

  • Measure the voltage between the aftertreatment particulate sensor battery voltage supply circuit and the aftertreatment particulate sensor battery voltage return circuit at the OEM wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify aftertreatment particulate sensor is the correct sensor for the engine configuration.

  • The aftertreatment particulate sensor is available in 12 volt or 24 volt versions.

Aftertreatment particulate sensor the correct sensor for the engine configuration?
YES NO
No Repair

An incorrect aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment particulate sensor.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 6651 active?
YES NO

A malfunctioning aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment particulate sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment particulate sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment particulate sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment particulate sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6652 - Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6652 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment particulate sensor circuit. |
 | STEP 2A. Inspect the aftertreatment particulate sensor and connector pins. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 2B. Check the voltage to the aftertreatment particulate sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment particulate sensor. | Aftertreatment particulate sensor the correct sensor for engine configuration?
 | STEP 2E. Check for active fault codes. | Fault Code 6652 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment particulate sensor battery voltage supply? | Voltage within 1 VDC of battery voltage?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6652 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment particulate sensor circuit.

Guided Step 2A - Inspect the aftertreatment particulate sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment particulate sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment particulate sensor.

  • Measure the voltage between the aftertreatment particulate sensor battery voltage supply circuit and the aftertreatment particulate sensor battery voltage return circuit at the OEM wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify aftertreatment particulate sensor is the correct sensor for the engine configuration.

  • The aftertreatment particulate sensor is available in 12 volt or 24 volt versions.

Aftertreatment particulate sensor the correct sensor for the engine configuration?
YES NO
No Repair

An incorrect aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment particulate sensor.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 6652 active?
YES NO

A malfunctioning aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment particulate sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment particulate sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment particulate sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment particulate sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6653 - Aftertreatment 1 Diesel Particulate Filter Soot Sensor Module - Circuit Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6652 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment particulate sensor circuit. |
 | STEP 2A. Inspect the aftertreatment particulate sensor and connector pins. | Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 2B. Check the voltage to the aftertreatment particulate sensor. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 2D. Check for correct aftertreatment particulate sensor. | Aftertreatment particulate sensor the correct sensor for engine configuration?
 | STEP 2E. Check for active fault codes. | Fault Code 6652 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment particulate sensor battery voltage supply? | Voltage within 1 VDC of battery voltage?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6653 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, 598, 1939, 1941, 6688, 6256, or 6257 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment particulate sensor circuit.

Guided Step 2A - Inspect the aftertreatment particulate sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment particulate sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment particulate sensor.

  • Measure the voltage between the aftertreatment particulate sensor battery voltage supply circuit and the aftertreatment particulate sensor battery voltage return circuit at the OEM wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the OEM connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES | NO
No Repair | No Repair

Go to 2D

Go to 4A

Guided Step 2D - Check for correct aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify aftertreatment particulate sensor is the correct sensor for the engine configuration.

  • The aftertreatment particulate sensor is available in 12 volt or 24 volt versions.

Aftertreatment particulate sensor the correct sensor for the engine configuration?
YES NO
No Repair

An incorrect aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment particulate sensor.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 6653 active?
YES NO

A malfunctioning aftertreatment particulate sensor has been detected.

Replace the aftertreatment particulate sensor. Refer to Procedure 019-478 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment particulate sensor battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment particulate sensor battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the aftertreatment particulate sensor battery voltage return circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

An open circuit has been detected in the aftertreatment particulate sensor battery voltage supply circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6688 - Aftertreatment 1 Particulate Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISB6.7 CM2350 B101 | 2883567
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISX12 CM2350 X102 | 4310646
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISX15 CM2350 X101 | 4310641
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | X15 CM2350 X114B | 5411181
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | X15 CM2350 X116B | 5411186
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | B6.7 CM2350 B121B | 5411223
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | L9 CM2350 L116B | 5411330
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | L9 CM2350 L123B | 5411465
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX12 CM2350 X102 | 4310646
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISX15 CM2350 X101 | 4310641
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X114B | 5411181
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | X15 CM2350 X116B | 5411186
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | B6.7 CM2350 B121B | 5411223
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L116B | 5411330
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 6688 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2636 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1D. Check the fault codes. | Fault Code 2771, 3232, 3868, 4151, 4152, 4572, or 4677 active or more than one inactive count?
STEP 2. | Check the aftertreatment particulate sensor circuit. |
 | STEP 2A. Inspect the aftertreatment particulate sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment particulate sensor. | Voltage greater than 10.8 VDC (12 volt systems) or voltage greater than 21.6 VDC (24 volt systems)?
 | STEP 2C. Check the voltage to the aftertreatment particulate sensor. | Voltage greater than 10.8 VDC (12 volt systems) or voltage greater than 21.6 VDC (24 volt systems)?
STEP 3. | Check the aftertreatment particulate sensor and circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Resistance between 54 to 66 ohms?
STEP 4. | Check the power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 to 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 to 132 ohms?
STEP 6. | Check the J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5 volts?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.1 and 4.5 volts?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6688 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to the block ground.

Electrical system voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 7A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1D

Guided Step 1D - Check the fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3232, 3868, 4151, 4152, 4572, or 4677 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment particulate sensor circuit.

Guided Step 2A - Inspect the aftertreatment particulate sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment particulate sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged OEM harness, connector, or pins, if possible.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment particulate sensor.

  • Measure the voltage between the aftertreatment particulate sensor battery voltage supply circuit and the aftertreatment particulate sensor return circuit at the particulate sensor wiring harness connector.

Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC (12 volt systems) or voltage greater than 21.6 VDC (24 volt systems)?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment particulate sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment particulate sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment particulate sensor.

  • Measure the voltage between the aftertreatment particulate sensor battery voltage supply circuit at the aftertreatment particulate sensor wiring harness connector and battery ground.

Check the voltage at keyswitch ON while cranking the engine.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC (12 volt systems) or voltage greater than 21.6 VDC (24 volt systems)?
YES NO

An open or high resistance circuit has been detected in the aftertreatment particulate sensor battery voltage return circuit.

  • Troubleshoot the OEM harness and all interconnects for the malfunction.
  • Repair or replace the damaged component as necessary.

An open or high resistance circuit has been detected in the aftertreatment particulate sensor battery voltage supply circuit.

  • Troubleshoot the OEM harness and all interconnects for the malfunction.
  • Repair or replace the damaged component as necessary.

Go to 7A

Go to 7A

Guided Step 3 - Check the aftertreatment particulate sensor and circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment particulate sensor

Action

Check the terminating resistance of the Society of Automotive Engineers (SAE) J1939 datalink.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the aftertreatment particulate sensor wiring harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Resistance between 54 to 66 ohms?
YES NO

A malfunction has been detected in the aftertreatment particulate sensor.

  • Replace the aftertreatment particulate sensor. Refer to Procedure 019-451 Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 datalink.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the OEM crossover connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 108 to 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

  • Perform the OEM harness check.
  • Refer to Procedure 019-417 in the Associated Procedures Table.
  • Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

  • Go to the engine harness check. Refer to Procedure 019-417 in the Associated Procedures Table.
  • Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3-pin service data link connector and battery ground. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

  • Go to the data link short circuit isolation section. Refer to Procedure 019-417 in the Associated Procedures Table.
  • Repair or replace the malfunctioning component(s).

Go to 6B

Go to 7A

Guided Step 6B - Check the J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit.

  • Measure the voltage between the SAE J1939 (-) pin at the 3-pin service data link connector and battery ground. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

  • Go to the data link short circuit isolation section. Refer to Procedure 019-417 in the Associated Procedures Table.
  • Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6689 - Engine Desired Air Fuel Ratio - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Charge-Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Air Intake Restriction | Refer to Procedure 010-031 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
EGR Cooler | Refer to Procedure 011-019 | ISV5.0 CM3230 V104 | 4367291
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Exhaust Transfer Tubes | Refer to Procedure 011-103 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 124, 125, 1885, 3232, 3382, 3383, 3682, 3725, 3748, 4747, or 4748 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Perform fuel system diagnostic tests. |
 | STEP 2A. Perform the High-Pressure Fuel Injector Return Flow Test. | Injectors meet specification in Procedure 005-236?
 | STEP 2B. Check the fuel injector drain line. | Injector drain flow meets the specifications in Procedure 005-236?
STEP 3. | Check the exhaust gas recirculation (EGR) system for leaks or restrictions. |
 | STEP 3A. Check the EGR system for leaks. | Leaks detected?
 | STEP 3B. Check the EGR differential pressure ports for plugging. | Debris or soot found in either EGR differential pressure port?
 | STEP 3C. Check the EGR differential pressure sensor mounting surface for leaks. | Leaks detected at the EGR differential pressure sensor mounting surface?
 | STEP 3D. Check the exhaust transfer tubes for restriction. | Restriction or damage to the exhaust transfer tube?
 | STEP 3E. Check the EGR valve for restriction. | Restriction or damage to the EGR valve?
 | STEP 3F. Check the EGR cooler for restriction. | Restriction or damage to the EGR cooler?
STEP 4. | Check the air intake system for leaks. |
 | STEP 4A. Check the charge air cooler for leaks. | Air leak present?
 | STEP 4B. Check the charge air cooler outlet, inlet, and connections for leaks. | Air leak present?
 | STEP 4C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 4D. Check for a restricted charge air cooler. | Differential pressure across the charge air cooler within specifications?
STEP 5. | Check for restriction. |
 | STEP 5A. Check exhaust restriction. | Exhaust restriction within specifications?
 | STEP 5B. Check the intake restriction. | Air intake restriction within specifications?
STEP 6. | Check for inactive fault code. |
 | STEP 6A. Check for inactive fault code. | Fault code inactive?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use electronic service tool to read the fault codes.

Fault Code 124, 125, 1885, 3232, 3382, 3383, 3682, 3725, 3748, 4747, or 4748 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform fuel system diagnostic tests.

Guided Step 2A - Perform the High-Pressure Fuel Injector Return Flow Test.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Return Flow Test.

Injectors meet specification in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2B

Go to 7A

Guided Step 2B - Check the fuel injector drain line.

Conditions

  • Turn keyswitch ON.

Action

  • Check injector drain line restriction.
  • Refer to Procedure 005-236 in the Associated Procedures Table for High-Pressure Injector Drain Line Restriction.

Injector drain flow meets the specifications in Procedure 005-236?
YES NO
No Repair

Restriction in the injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Check the EGR system for leaks or restrictions.

Guided Step 3A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

  • Check for leaks in the EGR system.
  • Leaks can be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the EGR differential pressure ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure ports for debris or soot plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the restriction.

 No Repair

Go to 7A

Go to 3C

Guided Step 3C - Check the EGR differential pressure sensor mounting surface for leaks.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the mounting surface of the EGR differential pressure sensor.
  • Leaks can be easily noted by traces of soot; however, the EGR differential pressure sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Leaks detected at the EGR differential pressure sensor mounting surface?
YES NO

Repair or replace the leaking component.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3D

Guided Step 3D - Check the exhaust transfer tubes for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check all exhaust tubes for damage or restriction.
  • Refer to Procedure 011-103 in the Associated Procedures Table.

Restriction or damage to the exhaust transfer tube?
YES NO

Clear the restriction or replace the exhaust transfer tubes.

 No Repair

Go to 7A

Go to 3E

Guided Step 3E - Check the EGR valve for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the EGR valve for restriction.
  • Refer to Procedure 011-022 in the Associated Procedures Table.

Restriction or damage to the EGR valve?
YES NO

Clear the restriction or replace the EGR valve.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3F

Guided Step 3F - Check the EGR cooler for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check for restriction in the EGR cooler.
  • Refer to Procedure 011-019 in the Associated Procedures Table.

Restriction or damage to the EGR cooler?
YES NO

Replace the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the air intake system for leaks.

Guided Step 4A - Check the charge air cooler for leaks.

Conditions

  • Operate engine.

Action

  • Check the charge air cooler for leaks, cracks or damage.
  • Refer to Procedure 010-027 in the Associated Procedures Table.

Air leak present?
YES NO

Repair or replace the charge air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the charge air cooler outlet, inlet, and connections for leaks.

Conditions

  • Operate the engine.

Action

  • Check the charge air cooler connections for leaks between the turbocharger compressor outlet and the charge air cooler.
  • Check the charge air cooler connections between the charge air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge air cooler hoses for leaks or loose connections.
  • Inspect the charge air cooler clamps to make sure they are tight.
  • Inspect the charge air plumbing for cracks

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 4C

Guided Step 4C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Check for wear or damage to turbocharger compressor and turbine blades.
  • Refer to Procedure 010-112 in the Associated Procedures Table.

Damage or wear found on the turbocharger blades?
YES NO

A damaged turbocharger has been detected. Replace the turbocharger.

Refer to Procedure 010-112 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4D

Guided Step 4D - Check for a restricted charge air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

  • Check for a restricted charge air cooler.
  • Refer to Procedure 010-027 in the Associated Procedures Table.

Differential pressure across the charge air cooler within specifications?
YES NO
No Repair

A restricted charge air cooler has been detected.

Clean or replace the charge air cooler, if necessary.

Go to 5A

Go to 7A

Guided Step 5 - Check for restriction.

Guided Step 5A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Check exhaust restriction.
  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Restricted exhaust has been detected.

Repair or replace the restricted components.

Go to 5B

Go to 7A

Guided Step 5B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Check for intake restriction.
  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO

A damaged aftertreatment intake NOx sensor has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Restricted intake detected.

Repair or replace the restricted component.

Go to 6A

Go to 7A

Guided Step 6 - Check for inactive fault code.

Guided Step 6A - Check for inactive fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Failed fuel injectors have been detected. Replace all eight fuel injectors.

Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 03-May-2017


FAULT CODE 6691 - Engine Desired Air Fuel Ratio - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Charge Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Air Intake Restriction | Refer to Procedure 010-031 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
EGR Cooler | Refer to Procedure 011-019 | ISV5.0 CM3230 V104 | 4367291
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Exhaust Transfer Tubes | Refer to Procedure 011-103 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 124, 125, 1885, 3232, 3382, 3383, 3682, 3725, 3748, 4747, or 4748 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Perform fuel system diagnostic tests. |
 | STEP 2A. Perform the High-Pressure Fuel Injector Return Flow Test. | Injectors meet specification in Procedure 005-236?
 | STEP 2B. Check the fuel injector drain line. | Injector drain flow meets the specifications in Procedure 005-236?
STEP 3. | Check the exhaust gas recirculation (EGR) system for leaks or restrictions. |
 | STEP 3A. Check the EGR system for leaks. | Leaks detected?
 | STEP 3B. Check the EGR differential pressure ports for plugging. | Debris or soot found in either EGR differential pressure port?
 | STEP 3C. Check the EGR differential pressure sensor mounting surface for leaks. | Leaks detected at the EGR differential pressure sensor mounting surface?
 | STEP 3D. Check the exhaust transfer tubes for restriction. | Restriction or damage to the exhaust transfer tube?
 | STEP 3E. Check the EGR valve for restriction. | Restriction or damage to the EGR valve?
 | STEP 3F. Check the EGR cooler for restriction. | Restriction or damage to the EGR cooler?
STEP 4. | Check the air intake system for leaks. |
 | STEP 4A. Check the charge air cooler for leaks. | Air leak present?
 | STEP 4B. Check the charge air cooler outlet, inlet, and connections for leaks. | Air leak present?
 | STEP 4C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 4D. Check for a restricted charge air cooler. | Differential pressure across the charge air cooler within specifications?
STEP 5. | Check for restriction. |
 | STEP 5A. Check exhaust restriction. | Exhaust restriction within specifications?
 | STEP 5B. Check the intake restriction. | Air intake restriction within specifications?
STEP 6. | Check for inactive fault code. |
 | STEP 6A. Check for inactive fault code. | Fault code inactive?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use electronic service tool to read the fault codes.

Fault Code 124, 125, 1885, 3232, 3382, 3383, 3682, 3725, 3748, 4747, or 4748 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Perform fuel system diagnostic tests.

Guided Step 2A - Perform the High-Pressure Fuel Injector Return Flow Test.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Return Flow Test.

Injectors meet specification in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2B

Go to 7A

Guided Step 2B - Check the fuel injector drain line.

Conditions

  • Turn keyswitch ON.

Action

  • Check injector drain line restriction.
  • Refer to Procedure 005-236 in the Associated Procedures Table for High-Pressure Injector Drain Line Restriction.

Injector drain flow meets the specifications in Procedure 005-236?
YES NO
No Repair

Restriction in the injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Check the EGR system for leaks or restrictions.

Guided Step 3A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

  • Check for leaks in the EGR system.
  • Leaks can be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Check the EGR differential pressure ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure ports for debris or soot plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the restriction.

 No Repair

Go to 7A

Go to 3C

Guided Step 3C - Check the EGR differential pressure sensor mounting surface for leaks.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the mounting surface of the EGR differential pressure sensor.
  • Leaks can be easily noted by traces of soot; however, the EGR differential pressure sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Leaks detected at the EGR differential pressure sensor mounting surface?
YES NO

Repair or replace the leaking component.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3D

Guided Step 3D - Check the exhaust transfer tubes for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check all exhaust tubes for damage or restriction.
  • Refer to Procedure 011-103 in the Associated Procedures Table.

Restriction or damage to the exhaust transfer tube?
YES NO

Clear the restriction or replace the exhaust transfer tubes.

 No Repair

Go to 7A

Go to 3E

Guided Step 3E - Check the EGR valve for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the EGR valve for restriction.
  • Refer to Procedure 011-022 in the Associated Procedures Table.

Restriction or damage to the EGR valve?
YES NO

Clear the restriction or replace the EGR valve.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3F

Guided Step 3F - Check the EGR cooler for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check for restriction in the EGR cooler.
  • Refer to Procedure 011-019 in the Associated Procedures Table.

Restriction or damage to the EGR cooler?
YES NO

Replace the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 4A

Guided Step 4 - Check the air intake system for leaks.

Guided Step 4A - Check the charge air cooler for leaks.

Conditions

  • Operate engine.

Action

  • Check the charge air cooler for leaks, cracks, or damage.
  • Refer to Procedure 010-027 in the Associated Procedures Table.

Air leak present?
YES NO

Repair or replace the charge air cooler. Refer to Procedure 010-027 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the charge air cooler outlet, inlet, and connections for leaks.

Conditions

  • Operate engine.

Action

  • Check the charge air cooler connections for leaks between the turbocharger compressor outlet and the charge air cooler.
  • Check the charge air cooler connections between the charge air cooler and the intake manifold.
  • Check the air compressor inlet plumbing connections between the charge air cooler and air compressor head for leaks.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge air cooler hoses for leaks or loose connections.
  • Inspect the charge air cooler clamps to make sure they are tight.
  • Inspect the charge air plumbing for cracks

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 4C

Guided Step 4C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

  • Check for wear or damage to turbocharger compressor and turbine blades.
  • Refer to Procedure 010-112 in the Associated Procedures Table.

Damage or wear found on the turbocharger blades?
YES NO

A damaged turbocharger has been detected. Replace the turbocharger.

Refer to Procedure 010-112 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4D

Guided Step 4D - Check for a restricted charge air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

  • Check for a restricted charge air cooler.
  • Refer to Procedure 010-027 in the Associated Procedures Table.

Differential pressure across the charge air cooler within specifications?
YES NO
No Repair

A restricted charge air cooler has been detected.

Clean or replace the charge air cooler, if necessary.

Go to 5A

Go to 7A

Guided Step 5 - Check for restriction.

Guided Step 5A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Check exhaust restriction.
  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Restricted exhaust has been detected.

Repair or replace the restricted components.

Go to 5B

Go to 7A

Guided Step 5B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Check for intake restriction.
  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO

A damaged aftertreatment intake NOx sensor has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in the Associated Procedures Table.

Restricted intake detected.

Repair or replace the restricted component.

Go to 6A

Go to 7A

Guided Step 6 - Check for inactive fault code.

Guided Step 6A - Check for inactive fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Failed fuel injectors have been detected. Replace all eight fuel injectors.

Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-May-2017


FAULT CODE 6735 - Aftertreatment 1 Diesel Particulate Filter 1 Soot Sensor ECU Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Heat Shield | Refer to Procedure 011-032 | ISB6.7 CM2350 B101 | 2883567
Heat Shield | Refer to Procedure 011-032 | ISX15 CM2350 X101 | 4310641
Heat Shield | Refer to Procedure 011-032 | ISX12 CM2350 X102 | 4310646
Heat Shield | Refer to Procedure 011-032 | B6.7 CM2350 B121B | 5411223
Heat Shield | Refer to Procedure 011-032 | L9 CM2350 L116B | 5411330
Heat Shield | Refer to Procedure 011-032 | ISV5.0 CM3230 V104 | 4367291
Heat Shield | Refer to Procedure 011-032 | L9 CM2350 L123B | 5411465
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISB6.7 CM2350 B101 | 2883567
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX15 CM2350 X101 | 4310641
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISX12 CM2350 X102 | 4310646
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X114B | 5411181
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | X15 CM2350 X116B | 5411186
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | B6.7 CM2350 B121B | 5411223
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L116B | 5411330
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Particulate Sensor | Refer to Procedure 019-478 | L9 CM2350 L123B | 5411465

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 6735 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment particulate sensor module. |
 | STEP 2A. Verify the aftertreatment particulate sensor module is properly mounted. | Aftertreatment particulate sensor module properly installed?
 | STEP 2B. Check the aftertreatment particulate sensor module mounting area for air flow obstructions. | Signs of air flow restriction or excessive heat to particulate sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6735 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment particulate sensor module.

Guided Step 2A - Make sure that the aftertreatment particulate sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Shut down the engine.

Action

Verify the aftertreatment particulate sensor module is properly mounted.

  • Verify the module is mounted correctly. Refer to Procedure 019-478 in the Associated Procedures Table.
  • Verify the proper heat shield is mounted over the temperature sensor module, if applicable. Refer to Procedure 011-032 in the Associated Procedures Table.

Aftertreatment particulate sensor module properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment particulate sensor module at the correct mounting location. Refer to Procedure 019-478 in the Associated Procedures Table.

Install the heat shield if applicable. Refer to Procedure 011-032 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment particulate sensor module.

Conditions

  • Turn keyswitch OFF.
  • Shut down the engine.

Action

Check the aftertreatment particulate sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module.
  • Aftermarket shields, flaps, or brackets mounted too close to the module.
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to particulate sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the sensor module.

Relocate any aftermarket accessories that might be restricting air flow.

Repair any causes of excessive heat to the sensor module.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2017


FAULT CODE 6881 - Aftertreatment 1 SCR Intake Temperature Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-May-2017


FAULT CODE 271 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 271 active?
STEP 2. | Check the power distribution center and fuse(s). |
 | STEP 2A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 3. | Check the fuel pump actuator and circuit. |
 | STEP 3A. Inspect the fuel pump actuator and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 272 active and Fault Code 271 inactive?
 | STEP 3C. Check the fault codes and verify sensor condition. | Fault Code 271 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM response. | Fault Code 272 active and Fault Code 271 inactive?
 | STEP 4C. Check for pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 271 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the power distribution center and fuse(s).

Guided Step 2A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Check for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel pump actuator and circuit.

Guided Step 3A - Inspect the fuel pump actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connect shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Note: Inspect the pigtail wire harness as well as the engine harness for wire insulation damage that can cause a short circuit.

Use the following procedure for general inspect techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 271 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 271 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been be detected.

Go to 4A

Go to 1A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-May-2015


FAULT CODE 272 - Engine Fuel Pump Pressurizing Assembly 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 272 active?
STEP 2. | Check the power distribution center and fuse(s). |
 | STEP 2A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 3. | Check the fuel pump actuator and circuit. |
 | STEP 3A. Inspect the engine harness and actuator connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 271 active and Fault Code 272 inactive?
 | STEP 3C. Check the fault codes and verify sensor condition. | Fault Code 272 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM response. | Fault Code 271 active and Fault Code 272 inactive?
 | STEP 4C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 272 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the power distribution center and fuse(s).

Guided Step 2A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Check for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the fuel pump actuator and circuit.

Guided Step 3A - Inspect the engine harness and actuator connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check the circuit response.

  • Place a jumper wire between the fuel pump actuator SIGNAL pin and ground at the fuel pump actuator connector of the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active and Fault Code 272 inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active?
YES NO

A damaged fuel pump actuator has been detected.

Replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or original equipment manufacturer (OEM) harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Check the circuit response.

  • Place a jumper wire between the fuel pump actuator SIGNAL pin and ground at the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271 active and Fault Code 272 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel pump actuator SIGNAL pin at the ECM connector of the engine harness and the fuel pump actuator SIGNAL pin at the fuel pump actuator connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Check for a pin-to-pin short circuit on one connector.

  • Measure the resistance between the fuel pump actuator SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-May-2015


FAULT CODE 346 - Engine Control Module Calibration Memory Software - Bad Intelligent Device or Component

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 346 active?
STEP 2. | Check the adjustable parameter settings. |
 | STEP 2A. Check for correct adjustable parameter settings. | Both accelerator interlock and powertrain protection torque limit switch features enabled, and both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE J1939 multiplexing feature?
 | STEP 2B. Check for correct adjustable parameter settings. | Both air shutoff valve and idle shutdown relay features enabled?
 | STEP 2C. Check for correct adjustable parameter settings. | Both switched maximum engine operating speed and switched maximum vehicle speed features enabled?
 | STEP 2D. Check for correct adjustable parameter settings. | Both Engine Protection Override switch and remote PTO features enabled?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 346 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the adjustable parameter settings.

Guided Step 2A - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for accelerator interlock switch and engine torque limit switch.

Both accelerator interlock and powertrain protection torque limit switch features enabled, and both the accelerator interlock switch and powertrain protection torque limit switch features disabled in the SAE J1939 multiplexing feature?

YES NO

Use INSITE™ electronic service tool to disable either the accelerator interlock switch or the engine torque limit switch features.

OR

Use INSITE™ electronic service tool to configure either the accelerator interlock switch or the engine torque limit switch to be multiplexed.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for the air shutoff valve and idle shutdown relay.

AC pressure and Engine Protection Shutdown switch features enabled?
YES NO

Use INSITE™ electronic service tool to disable either the air shutoff valve or idle shutdown relay features.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for switched maximum engine operating speed and switched maximum vehicle speed features.

Both switched maximum engine operating speed and switched maximum vehicle speed features enabled?
YES NO

Use INSITE™ electronic service tool to disable either the switched maximum engine operating speed or switched maximum vehicle speed features.

No Repair

Go to 2D

Go to 2D

Guided Step 2D - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Use INSITE™ electronic service tool to check the feature and parameter settings for Engine Protection Override switch and remote power take-off (PTO).

Both Engine Protection Override switch and remote PTO features enabled?
YES NO

Use INSITE™ electronic service tool to disable either the Engine Protection Override switch or remote PTO

 No Repair

Go to 2E

Go to 2E

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jan-2015


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 351 inactive
 | STEP 1B. Check for active fault codes. | Fuel injector fault codes active?
 | STEP 1C. Interview customer for intermittent condition. | Was truck stalled at recent key-off event?
 | STEP 1D. Inspect engine/truck. | Truck or engine been modified with performance enhancing kit?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update is available for this fault code is available, does the ECM contain that revision or higher?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 351.

  • Use INSITE™ electronic service tool to read the fault codes.`

Fault Code 351 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fuel injector fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Interview customer for intemittent condition.

Conditions

  • N/A

Action

Interview customer on driving conditions.

  • .

Truck stalled at recent key-off event?
YES NO

Clear fault code and return to customer.

 No Repair

Repair complete.

Go to 1D

Guided Step 1D - Inspect engine/truck.

Conditions

  • N/A

Action

Investigate truck and engine for signs of a performance enhancement kit.

  • .

Has truck or engine been modified with performance enhancing kit?
YES NO

No repair. Return to customer.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Repair complete.

Repair complete.

Last Modified: 16-Jan-2015


FAULT CODE 352 - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Pressure Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4367291
Camshaft Position Sensor | Refer to Procedure 019-363 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the charge-air cooler outlet pressure/charge-air cooler temperature sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the compressor inlet pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Inspect the fuel supply pressure sensor and circuit to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
 | STEP 2F. Inspect the exhaust pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2F-1. Check the circuit response. |
 | STEP 2G. Inspect the intake air throttle and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2G-1. Check the circuit response. |
 | STEP 2H. Inspect the exhaust gas recirculation (EGR) valve position sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2H-1. Check the circuit response. |
 | STEP 2I. Inspect the crankcase pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2I-1. Check the circuit response. |
 | STEP 2J. Inspect the EGR delta pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2J-1. Check the circuit response. |
 | STEP 2K. Inspect the fan controller and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2K-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the camshaft position sensor.

Refer to 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the fuel rail pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and the fuel rail pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the charge-air cooler outlet pressure/charge-air cooler temperature sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure/charge-air cooler temperature sensor from the engine harness.

Action

Inspect the engine harness and charge-air cooler outlet pressure/charge-air cooler temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet pressure/charge-air cooler temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the charge-air cooler outlet pressure/charge-air cooler temperature sensor.

Refer to Procedure 019-560 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the compressor inlet pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet pressure sensor from the engine harness.

Action

Inspect the engine harness and compressor inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the compressor inlet pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the compressor inlet pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Inspect the fuel supply and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.

Action

Inspect the engine harness and compressor inlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fuel supply pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Inspect the exhaust pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2F-1

Guided Step 2F-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the exhaust pressure sensor.

Refer to Procedure 019-376 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2G - Inspect the intake air throttle and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake air throttle from the engine harness.

Action

Inspect the engine harness and intake air throttle connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2G-1

Guided Step 2G-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the intake air throttle.

Refer to Procedure 010-140 in the Associated Procedures Table.

Go to 2H

Go to 4A

Guided Step 2H - Inspect the EGR valve position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor from the engine harness.

Action

Inspect the engine harness and EGR valve position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2H-1

Guided Step 2H-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve position sensor sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 2I

Go to 4A

Guided Step 2I - Inspect the crankcase pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2I-1

Guided Step 2I-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the crankcase pressure sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2J

Go to 4A

Guided Step 2J - Inspect the EGR delta pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR delta pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2J-1

Guided Step 2J-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR delta pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the EGR delta pressure sensor.

Refer to Procedure 019-370 in the Associated Procedures Table.

Go to 2K

Go to 4A

Guided Step 2K - Inspect the fan controller and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan controller from the engine harness.

Action

Inspect the engine harness and fan controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2K-1

Guided Step 2K-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan controller from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Replace the fan controller. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 386 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO
No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

There is a short circuit to a voltage source in the engine harness sensor supply 1 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 436 - Intake Manifold 1 Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 436 active?
 | STEP 1B. Check for Fault Codes 153 and 154. | Fault Code 153 or 154 active?
STEP 2. | Check the engine intake manifold temperature sensor and circuit. |
 | STEP 2A. Verify the sensor condition. | Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F of each other?
 | STEP 2A-1. Inspect the engine intake manifold temperature sensor and connector pins. |
 | STEP 2B. Check the circuit response. | Fault Code 153 active?
 | STEP 2C. Check the circuit response. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 153 active?
 | STEP 3C. Check the circuit response. | Fault Code 154 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 436 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 153 and 154.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 or 154 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine intake manifold temperature sensor and circuit.

Guided Step 2A - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger.

  • Compare INSITE™ electronic service tool reading for intake manifold temperature to ambient air temperature.

Intake manifold temperature and ambient air temperature reading within 5.6°C or 10°F?
YES NO
No Repair

Replace the intake manifold temperature sensor.

Refer to Procedure 019-059 in the Associated Procedures Table.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine intake manifold temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Inspect the engine harness and engine intake manifold temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the OEM wiring harness.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the intake manifold temperature RETURN pin and the intake manifold temperature SIGNAL pin at the intake manifold temperature sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

An in-range malfunction of the intake manifold temperature sensor has been detected.

Replace the engine intake manifold temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 is active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold temperature RETURN pin and the intake manifold temperature SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Repair complete.

Last Modified: 02-Dec-2016


FAULT CODE 477 - Battery 2 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 477 is active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Codes 441, 597, 598, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and harness. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF dosing unit. | Voltage is within 1 VDC of battery voltage?
 | STEP 2C. Check the voltage to the aftertreatment DEF dosing unit. | Voltage is within 1 VDC of battery voltage?
STEP 3. | Check the battery. |
 | STEP 3A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 3B. Verify that the fuse is installed correctly. | Good fuse installed correctly?
 | STEP 3C. Check for the correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine Control Parts List (CPL)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 477 is active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 441, 597, 598, or 6257 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Inspect aftertreatment DEF dosing unit and harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit connector from the dosing unit.

Action

Inspect the original equipment manufacturer (OEM) harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the dosing unit or harness connector.

Repair or replace the OEM wiring harness.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF dosing unit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM wiring harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuits to the aftertreatment DEF dosing unit.

  • Measure the voltage between the aftertreatment DEF dosing unit battery voltage supply circuit and the aftertreatment DEF dosing unit battery voltage return circuit at the OEM harness connector.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment DEF dosing unit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM wiring harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuits to the aftertreatment DEF dosing unit.

  • Measure the voltage between the aftertreatment DEF dosing unit battery voltage supply circuit and engine block ground.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage is within 1 VDC of battery voltage?
YES NO

An open circuit or high resistance has been detected in the glow plug control module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects.

Repair or replace the damaged component. Refer to Procedure 019-071 in Section 19.

An open circuit or high resistance has been detected in the glow plug control module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects.

Repair or replace the damaged component. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the battery.

Guided Step 3A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. Refer to the OEM service manual.

Go to 3B

Go to 4A

Guided Step 3B - Verify that the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the fuse is installed correctly and is not blown.

  • Inspect the fuse for correct installation and check to see if its blown.

Good fuse installed correctly?
YES NO
No Repair

Install the fuse correctly or replace the blown fuse. Refer to Procedure 019-198 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2016


FAULT CODE 478 - Battery 2 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3824811 - male Deutsch™ test lead, and Part Number 3824812 - female Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 478 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Codes 442, 596, or 6256 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and harness. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DEF dosing unit. | Less than +18 VDC for 12 volt system and less than +32 VDC for 24 volt system?
 | STEP 2C. Check for the correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine Control Parts List (CPL)?
STEP 3. | Check the alternator. |
 | STEP 3A. Check the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Connect INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 478 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 442, 596, or 6256 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Inspect aftertreatment DEF dosing unit and harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the aftertreatment DEF dosing unit.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connectors
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the dosing unit or harness connector.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DEF dosing unit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn the keyswitch ON.

Action

Check the power supply and return circuits to the aftertreatment DEF dosing unit.

  • Measure the voltage between the aftertreatment DEF dosing unit battery voltage SUPPLY circuit and the aftertreatment DEF dosing unit battery voltage RETURN circuit at the OEM harness connector.

Note: Check the voltage at key ON, while cranking the engine, and with the engine at idle.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Less than +18 VDC for 12 volt system and less than +32 VDC for 24 volt system?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for the correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine CPL.

Electrical System Voltage parameter correct for the engine CPL?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine CPL.

Go to 4A

Go to 4A

Guided Step 3 - Check the alternator.

Guided Step 3A - Check the alternator.

Conditions

  • Turn keyswitch OFF
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Note: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the INSITE™ service tool to find the ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jan-2016


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification symptom tree in the appropriate service manual.

Replace the intake manifold air temperature sensor. Refer to Procedure 019-059 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 515 - Sensor Supply 6 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 515 active?
STEP 2. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and OEM harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor supply 6 pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter differential pressure sensor from the OEM harness.

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the sensor SUPPLY 6 pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 516 - Sensor Supply 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male WeatherPack™ test lead, Part Number 3823996 - female WeatherPack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 516 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter delta pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the aftertreatment diesel particulate filter delta pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter delta pressure sensor from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 -

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter delta pressure sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO
No Repair

Replace the aftertreatment diesel particulate filter delta pressure sensor. Refer to Procedure 019-443 in the Associated Procedure Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Repair the damaged pins.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Flush the dirt, debris, or moisture from the connector pins. Use electrical contact cleaner, Part Number 3824510.

Install the appropriate connector seal if it is damaged or missing.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter delta pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply number 6 5-VDC SUPPLY and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment diesel particulate filter delta pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply number 6 5-VDC SUPPLY pin and the engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 595 - Turbocharger 1 Speed - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for an intermittent fault condition. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of fault codes related to the turbocharger, compressor intake pressure sensor, or charge-air cooler outlet pressure sensor?
 | STEP 1B. Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active. | Fault Code 595 become active during engine keyswitch ON?
 | STEP 1C. Operate the engine and confirm that the turbocharger speed fault comes active. | Fault Code 595 become active during engine operation?
STEP 2. | Check the turbocharger speed sensor and connector. |
 | STEP 2A. Inspect the turbocharger speed sensor and connector. | Dirty or damaged pins?
 | STEP 2B. Inspect the turbocharger speed sensor for damage. | Damaged sensor?
STEP 3. | Check the turbocharger speed sensor and engine harness. |
 | STEP 3A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3C. Check the turbocharger speed sensor signal circuit for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check the fault code and verify the turbocharger speed sensor condition. | Fault Code 595 active?
STEP 4. | Check the turbocharger speed sensor circuit at the ECM. |
 | STEP 4A. Check the turbocharger speed sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 4B. Connect all components and determine if the fault code occurs again. | Fault Code 595 become active during engine operation?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for an intermittent fault condition.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger, compressor intake pressure sensor, or charge-air cooler outlet pressure sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes related to the turbocharger, compressor intake pressure sensor, or charge-air cooler outlet pressure sensor?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Turn engine keyswitch ON and confirm that the turbocharger speed fault becomes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use electronic service tool to read the fault codes.

Fault Code 595 become active during engine keyswitch ON?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

An intermittent fault condition exists. Refer to Procedure 019-362 in Section 19.

Go to 1C

Guided Step 1C - Operate the engine and confirm that the turbocharger speed fault comes active.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Clear the inactive fault codes.

Action

Start the engine.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle.
  • Use electronic service tool to read the fault codes.

This step is valid even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 become active during engine operation?
YES | NO
No Repair | No Repair

Go to 2A

An intermittent fault condition exists. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger speed sensor and connector.

Guided Step 2A - Inspect the turbocharger speed sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the engine harness and turbocharger speed sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the turbocharger speed sensor connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the turbocharger speed sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Remove the turbocharger speed sensor from the housing. Refer to Procedure 019-390 in the Associated Procedures Table.

Action

Inspect the turbocharger speed sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by blades
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the turbocharger speed sensor.

  • Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the turbocharger speed sensor and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the turbocharger speed sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the turbocharger speed sensor +5 volt SUPPLY pin and the turbocharger speed sensor 1 RETURN pin at the turbocharger speed sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the turbocharger speed sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the turbocharger speed sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 5A

Guided Step 3D - Check the fault code and verify the turbocharger speed sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use electronic service tool to read the fault codes.

Fault Code 595 active?
YES NO

A damaged turbocharger speed sensor has been detected.

  • Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the turbocharger speed sensor circuit at the ECM.

Guided Step 4A - Check the turbocharger speed sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON

Action

Check the turbocharger speed sensor supply voltage and return circuit.

Measure the sensor supply voltage between the turbocharger speed sensor +5 volt SUPPLY pin and the turbocharger speed sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Connect all components and determine if the fault code occurs again.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Connect the engine harness to the ECM connector.
  • Turn keyswitch ON.
  • Start the engine.

Action

Operate the engine at idle.

  • Use the accelerator pedal to accelerate the engine speed to high idle (100 percent) and hold the engine speed at high idle for at least 20 seconds.
  • Return the engine speed to idle speed.
  • Use electronic service tool to read the fault codes.

This step applies even if maximum engine speed, without vehicle speed sensor, limits the engine speed.

Fault Code 595 become active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

The faulty condition was repaired when the components were reconnected.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-May-2015


FAULT CODE 687 - Turbocharger 1 Speed - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Speed Sensor | Refer to Procedure 019-390 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Cannon™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 691, 692, 693, 741, 742, 743, 2571, 2572, 3478, 5951, 5952, 5953, 6237, or 6238 active?
STEP 2. | Check for a malfunctioning turbocharger speed sensor. |
 | STEP 2A. Inspect the engine harness connector to the turbocharger speed sensor. | Dirty or damaged pins?
 | STEP 2B. Measure the turbocharger speed sensor resistance. | Resistance between 600 and 1600 ohms?
 | STEP 2C. Check for a short circuit to ground in the turbocharger speed sensor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the turbocharger speed sensor circuit continuity. | Continuity within 10 ohms of the sensor resistance?
 | STEP 3C. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check the ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disabel the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Read the fault codes with INSITE™ electronic service tool.

Fault Code 691, 692, 693, 741, 742, 743, 2571, 2572, 3478, 5951, 5952, 5953, 6237, or 6238 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check for a malfunction in the turbocharger speed sensor.

Guided Step 2A - Inspect the engine harness connector to the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Inspect the turbocharger speed sensor connector, the engine harness connector, and the turbocharger speed sensor pigtail harness for signs of the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the turbocharger speed sensor connector or speed sensor.

Repair or replace the damaged connector or turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Measure the turbocharger speed sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Measure the resistance.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin to the turbocharger speed SIGNAL (-) pin at the sensor.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 600 and 1600 ohms?
YES NO
No Repair

The turbocharger speed sensor has malfunctioned.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ground in the turbocharger speed sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger speed sensor from the engine harness.

Action

Check for a short circuit to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin at the sensor to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

The turbocharger speed sensor is shorted to ground.

Replace the turbocharger speed sensor. Refer to Procedure 019-390 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness ECM connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the turbocharger speed sensor circuit continuity.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check the sensor continuity.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to the turbocharger speed SIGNAL (-) pin of the engine harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

NOTE: The resistance of the turbocharger speed sensor circuit should be no more than 10 ohms greater than the resistance of the turbocharger speed sensor. The turbocharger speed sensor resistance value was read in Step 3B.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Continuity within 10 ohms of sensor resistance?
YES NO
No Repair

There is high resistance or an open circuit in the engine harness or turbocharger speed sensor connector.

Repair or replace the engine harness or connector(s). Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a short to ground.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

There is a short to ground in the turbocharger speed sensor circuit. Inspect the engine harness for a short to ground.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger speed sensor to the engine harness.
  • Disconnect the engine harness connector from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Use a multimeter to measure the resistance from the turbocharger speed SIGNAL (+) pin of the engine harness ECM connector to all other pins in the connector except the turbocharger speed SIGNAL (-) pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

The turbocharger speed sensor has malfunctioned.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Inspect the engine harness for a short between two pins.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-May-2015


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft | Refer to Procedure 001-016 | ISV5.0 CM3230 V104 | 4367291
Vibration Damper, Rubber | Refer to Procedure 001-051 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active?
STEP 2. | Inspect the tone wheels and speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Any damage?
 | STEP 2B. Inspect the tone wheels for any damage. | Any damage?
STEP 3. | Check the engine speed sensor and connector. |
 | STEP 3A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 4. | Check the crankshaft position sensor circuit. |
 | STEP 4A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 to 5.25 VDC?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 4D. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4E. Inspect the air gap. | Air gap between 0.25 mm [0.009 in] and 2.00 mm [0.078 in]?
 | STEP 4F. Check the fault code and verify the crankshaft position sensor condition. | Fault Code 689 active?
 | STEP 4G. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4H. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. | Between 4.75 to 5.25-VDC?
 | STEP 4I. Check the fault code and verify crankshaft position sensor condition. | Fault Code 689 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the tone wheels and speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine speed sensor for damage.

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Any damage?
YES NO

Replace the speed sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheels for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft tone wheels for damage.

  • Inspect the crankshaft wheel for defects.
  • Make sure the vibration damper/crankshaft speed indicator ring assembly is aligned. Refer to Procedure 001-051 in the Associated Procedures Table.

Any damage?
YES NO

Replace the tone wheel. Refer to Procedure 001-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the engine speed sensor and connector.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the crankshaft position sensor circuit.

Guided Step 4A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4C

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Inspect the air gap.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine block and measure the air gap at several points in the crankshaft's revolution. Refer to Procedure 019-365 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Air gap between 0.25 mm [0.009 in] and 2.00 mm [0.078 in]?
YES NO
No Repair

Replace or shim the sensor if air gap is out of specification. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 4F

Go to 5A

Guided Step 4F - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 4G

Guided Step 4G - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4H

Guided Step 4H - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 to 5.25-VDC?
YES NO

A damaged connection has been detected in the engine harness.

Clean the connector and pins.

Repair the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4I

Guided Step 4I - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Replace the ECM. Refer to procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the failure.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft | Refer to Procedure 001-016 | ISV5.0 CM3230 V104 | 4367291
Vibration Damper, Rubber | Refer to Procedure 001-051 | ISV5.0 CM3230 V104 | 4367291
Overhead Camshaft | Refer to Procedure 002-039 | ISV5.0 CM3230 V104 | 4367291
Camshaft Position Sensor | Refer to Procedure 019-363 | ISV5.0 CM3230 V104 | 4367291
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 active only?
STEP 2. | Inspect the engine and vehicle grounding. |
 | STEP 2A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 3. | Inspect the tone wheel and crankshaft sensor. |
 | STEP 3A. Inspect the crankshaft sensor for damage. | Any sensor damage?
 | STEP 3B. Inspect the tone wheel for any damage. | Any damage?
STEP 4. | Check the camshaft gears and sensors. |
 | STEP 4A. Inspect the camshaft sensor for damage. | Any sensor damage?
 | STEP 4B. Inspect the camshaft gears for any damage. | Any damage?
 | STEP 4C. Inspect the camshaft gears for any damage. | Camshaft timing marks properly aligned at top dead center?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active only?

YES NO
No Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the engine and vehicle grounding.

Guided Step 2A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 3A

Go to 3A

Guided Step 3 - Inspect the tone wheel and crankshaft sensor.

Guided Step 3A - Inspect the crankshaft sensor for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft sensors for damage.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

Any sensor damage?
YES NO

Replace the crankshaft sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the tone wheel for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft tone wheel for defects.

  • Inspect the crankshaft speed indicator ring for missing or bent teeth, cracks, or damaged surfaces. Refer to Procedure 001-051 in the Associated Procedures Table.

Any damage?
YES NO

Replace the tone wheel assembly. Refer to Procedure 001-051 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the camshaft gears and sensors.

Guided Step 4A - Inspect the camshaft sensor for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft sensor for damage.

  • Refer to Procedure 019-363 in the Associated Procedures Table.

Any sensor damage?
YES NO

Replace the camshaft sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the camshaft gears for damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve covers.

Action

Inspect the camshaft gears.

  • Inspect the camshaft gears for excessive wear, fretting, and missing teeth. Refer to Procedure 002-039 in the Associated Procedures Table.

Any damage?
YES NO

Replace the camshaft gears. Refer to Procedure 002-039 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check static timing.

Conditions

  • Remove the valve covers.
  • Rotate the engine to top dead center (TDC) for the number 1 cylinder and verify the camshaft gear timing marks are properly aligned.

Action

Inspect the timing.

–

Camshaft timing marks properly aligned at top dead center?
YES NO
No Repair

Remove and install the camshaft to properly align timing marks at TDC. Refer to Procedure 002-039 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repeat all steps and if fault code is still active:

The crankshaft and camshaft should be inspected thoroughly. Refer to Procedure 001-016 and 002-039 in the Associated Procedure Table.

Repair complete

Go to 1A

Last Modified: 22-Jan-2015


FAULT CODE 741 - Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
STEP 2. | Check the turbocharger compressor intake pressure sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 742 active and Fault Code 741 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 741 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake pressure sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active and Fault Code 741 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 volt SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake pressure/temperature sensor.

  • Refer to Procedure 019-466 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active and Fault Code 741 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 inactive?
YES NO

The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature 5 volt SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2015


FAULT CODE 742 - Turbocharger 1 Compressor Intake Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 742 active?
STEP 2. | Check the turbocharger compressor intake pressure sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75-VDC to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 741 active and Fault Code 742 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 742 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the turbocharger compressor intake pressure sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active and Fault Code 742 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the turbocharger compressor intake pressure/temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES NO

A damaged sensor has been detected.

Replace the turbocharger compressor intake pressure/temperature sensor.

  • Refer to Procedure 019-466 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin to the turbocharger compressor intake pressure/temperature RETURN pin at the ECM engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75-VDC to 5.25-VDC?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 inactive?
YES NO

The removal and installation of the connector corrected the fault.

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harnes from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active and Fault Code 742 inactive?
YES NO
No Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 inactive?
YES NO

The removal and installation of the connector corrected the fault.

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Jan-2015


FAULT CODE 743 - Turbocharger 1 Compressor Intake Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Code 741 and Fault Code 742. | Fault Code 741 or Fault Code 742 active?
STEP 2. | Check the turbocharger compressor intake pressure/temperature sensor and circuit. |
 | STEP 2A. Inspect the turbocharger compressor intake pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 742 active?
 | STEP 2C. Check the circuit response. | Fault Code 741 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 742 active?
 | STEP 3C. Check the circuit response. | Fault Code 741 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Code 741 and Fault Code 742.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 or Fault Code 742 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the turbocharger compressor intake pressure/temperature sensor and circuit.

Guided Step 2A - Inspect the turbocharger compressor intake pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and turbocharger compressor intake pressure/temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the turbocharger compressor intake pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature sensor +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the turbocharger compressor intake pressure/temperature sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES NO

An in-range malfunction of the turbocharger compressor intake pressure/temperature sensor has been detected.

Replace the turbocharger compressor intake pressure/temperature sensor. Refer to Procedure 019-466 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 742 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the turbocharger compressor intake pressure/temperature sensor +5 VOLT SUPPLY pin and the turbocharger compressor intake pressure SIGNAL pin at the ECM connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 741 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-Jan-2015


FAULT CODE 778 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Camshaft Position Sensor | Refer to Procedure 019-363 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply Fault Code 352 or 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 778 active?
STEP 2. | Check the battery. |
 | STEP 2A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 3. | Check the camshaft position sensor and connector. |
 | STEP 3A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 4. | Check the camshaft position sensor circuit. |
 | STEP 4A. Check the camshaft position sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 4B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 4B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 4B-3. Verify adequate camshaft position sensor air gap. |
 | STEP 4B-4. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 4C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4C-1. Check the sensor supply voltage and return circuit. |
 | STEP 4C-2. Check the fault code and verify camshaft position sensor condition. |
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply Fault Code 352 or 386 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the battery.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten loose connections. Clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 5A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (=) battery terminal wile trying to start engine.

Normal conditions:

  • At least +12 VDC (12 volt systems)
  • At least +24 VDC (24 volt systems).

Cranking conditions:

  • At least +6.2 VDC (12 volt systems)
  • At least +12 VDC (24 volts systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 3A

Go to 5A

Guided Step 3 - Check the camshaft position sensor and connector.

Guided Step 3A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor.
  • Damage to the end of the sensor caused by camshaft gear.
  • Oil leakage or insulation problems such as swelling.
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the camshaft position sensor circuit.

Guided Step 4A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4B

Go to 4C

Guided Step 4B - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B-1

Guided Step 4B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4B-2

Go to 5A

Guided Step 4B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4B-3

Go to 5A

Guided Step 4B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor and measure the air gap at several points in the camshaft's revolution. Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap between 0.25 mm [0.009 in] and 2.00 mm [0.078 in]?
YES NO
No Repair

Replace or shim the sensor if the air gap is out of specification. If the target runout is excessive, replace the target.

Go to 4B-4

Go to 5A

Guided Step 4B-4 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C-1

Guided Step 4C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 to 5.25 VDC?
YES NO

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C-2

Guided Step 4C-2 - Check the fault code and verify camshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 778 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2016


FAULT CODE 1228 - EGR Valve Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor circuit fault codes. | Fault Codes 352, 386, 2271, or 2272, 2351, 2352 active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2271 active?
 | STEP 2C. Check the circuit response. | Fault Code 2272 active?
 | STEP 2D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2271 active?
 | STEP 3C. Check the ECM response. | Fault Code 2272 active?
 | STEP 3D. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 352, 386, 2271, or 2272, 2351, 2352 active?
YES NO

Troubleshoot active fault codes 352, 386, 2271, and/or 2272 before fault code 1228.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the EGR valve connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position sensor +5-VDC SUPPLY pin and the EGR valve position sensor RETURN pin at the engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

A stuck or broken EGR valve has been detected.

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Note: Multiple unrelated fault codes will become active when the engine harness is unplugged. These faults can be temporarily ignored.

Fault Code 2271 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the ECM engine connector.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read fault codes.

Note: Multiple unrelated fault codes will become active when the engine harness is unplugged. These faults can be temporarily ignored.

Fault Code 2272 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor Supply voltage and Return circuit at the ECM.

  • Measure the voltage between the EGR valve position +5-VDC SUPPLY pin and the EGR valve position RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO

An intermittent short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jan-2015


FAULT CODE 1229 - VGT Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment System | Refer to Procedure 011-050 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1229 active?
 | STEP 1B. Check for active fault codes. | Fault Code 5736, 2387, or 2636 active?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Nozzle movement meet the requirements in Procedure 010-134?
 | STEP 2D. Check for active Fault Code 1229. | Fault Code 1229 active?
STEP 3. | Check aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active Fault Code 1229.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1229 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 1229 is active.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5736, 2387, or 2636 is active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • VGT actuator removed from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand. Refer to Procedure 010-134 in the Associated Procedures Table.

Nozzle movement meet the requirements in Procedure 010-134?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for active Fault Code 1229.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 1229.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1229 active?
YES NO

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Refer to Procedure 014-013 in the Associated Procedures Table.

Action

Check for damage to the aftertreatment system.

Perform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter. Refer to Procedure 014-013 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s). Refer to Procedure 011-050 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jan-2015


FAULT CODE 1664 - Aftertreatment Diesel Oxidation Catalyst Missing - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 4151, 4158, 4161, 4162, 4163, or 4259 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for the presence of a diesel oxidation catalyst (DOC). | DOC - diesel particulate filter (DPF) assembly present in the aftertreatment system?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3313, 3314, 3315, 3316, 3317, 3318, 4151, 4158, 4161, 4162, 4163, or 4259 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for the presence of a DOC.

Conditions

  • Turn keyswitch OFF.

Action

Check the DOC - DPF assembly.

  • Refer to Procedure 011-099 in Section 11.

DOC - DPF assembly present in the aftertreatment system?
YES NO
No Repair

Properly install the DOC - DPF assembly for the application.

See equipment manufacturer service information.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jan-2016


FAULT CODE 1668 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1668 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Repace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-May-2015


FAULT CODE 1669 - Aftertreatment Diesel Exhaust Fluid Tank Level Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1669 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1669 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 1677 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1677 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 1678 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1678 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1678 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 1679 - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1677 or 1678 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for fault codes. | Fault Code 285, 334, or 436 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Verify the aftertreatment DEF tank temperature sensor accuracy. | INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677 or 1678 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 285, 334, or 436 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor.

Guided Step 2A - Verify the aftertreatment DEF tank temperature sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the accuracy of the aftertreatment DEF tank temperature sensor.

  • Measure the temperature of the aftertreatment DEF in the tank with an infrared thermometer or thermocouple.
  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare the INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature to the value measured with the infrared thermometer or thermocouple.

INSITE™ electronic service tool aftertreatment DEF tank temperature reading within 5.6°C or 10°F of the measured value?
YES NO
No Repair

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1682 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Input Lines - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair and make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758, male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917, female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1682 active or more than two inactive counts?
 | STEP 1B. Check for low aftertreatment diesel exhaust fluid (DEF) tank level. | Aftertreatment DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1C. Check for related fault codes. | Fault Code 3569, 3574, 3575, or 3596 active or more than two inactive counts?
STEP 2. | Check the aftertreatment DEF tank and filter. |
 | STEP 2A. Check the aftertreatment DEF concentration. | DEF concentration within 32.5 +/- 1.5 percent?
 | STEP 2B. Check the aftertreatment DEF tank. | Aftertreatment DEF tank and vent clean and free of debris?
 | STEP 2C. Inspect the aftertreatment DEF tank filter for blockage. | Aftertreatment DEF tank filter blocked?
STEP 3. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 3A. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1682 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

An intermittent fault condition exists. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low aftertreatment DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the aftertreatment DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Code: 1673, 3497, or 3498.

Aftertreatment DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3569, 3574, 3575, or 3596 active or more than two inactive counts?
YES NO

Troubleshoot occurrences of Fault Code 3569, 3574, 3575, or 3596 before troubleshooting Fault Code 1682.

 No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank and filter.

Guided Step 2A - Check the aftertreatment DEF concentration.

Conditions

  • Turn the keyswitch OFF.

Action

Check the aftertreatment DEF concentration.

  • Use a DEF refractometer, Part number 4919318, to measure the concentration of DEF in the tank. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF concentration within 32.5 +/- 1.5 percent?
YES NO
No Repair

Follow the Clean and Inspect for Reuse guidelines. If necessary, replace the aftertreatment DEF dosing unit assembly. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check the aftertreatment DEF tank.

Conditions

  • Turn the keyswitch OFF.

Action

Check the aftertreatment DEF tank.

  • Check the aftertreatment DEF tank for debris or foreign particles.
  • Check the aftertreatment DEF tank vent for crystallization buildup and clogging.

Aftertreatment DEF tank and vent clean and free of debris?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the aftertreatment DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Completely drain DEF tank and remove the dosing unit assembly from the aftertreatment DEF tank. Refer to Procedure 011-058 in the Associated Procedures Table.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

–

Aftertreatment DEF tank filter blocked?
YES NO

Follow Clean and Inspect for Reuse guidelines. If necessary replace the aftertreatment DEF dosing unit assembly. Refer to Procedure 011-058 in the Associated Procedures Table.

Clean the aftertreatment DEF tank thoroughly. Using certified aftertreatment DEF, fill the tank to approximately half full.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF dosing unit operation.

Guided Step 3A - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all aftertreatment DEF lines and electrical connectors to the dosing unit and aftertreatment DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit assembly. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1683 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1683 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1684 active?
 | STEP 2C. Check for an open circuit. | Less than 10 ohms?
 | STEP 2D. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1683 active?
STEP 3. | Check the aftertreatment DEF dosing unit and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1683 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve form the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DEF tank heater control valve SUPPLY pin and the aftertreatment DEF tank heater control valve RETURN pin at the aftertreatment DEF tank heater control valve OEM harness connector.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater 2 relay ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1684 active?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for an open return circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve RETURN pin at the tank heater control valve wiring harness connector and engine block gound.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 2D - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 1683 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF dosing unit and OEM harness.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for an open supply circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the tank heater control valve wiring harness connector and the aftertreatment DEF tank heater control valve SUPPLY pin(s) at the OEM harness aftertreatment DEF dosing unit connector.

Note: For 12 VDC applications, there are 2 SUPPLY pins for the tank heater control valve at the DEF dosing unit connector. Both must be measured for resistance to the heater control valve connector SUPPLY pin.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pins(s) at the OEM harness aftertreatment DEF dosing unit connector and all other pins in the connector.

Note: For 12 VDC applications, there are 2 SUPPLY pins for the tank heater control valve at the DEF dosing unit connector. Both must be measured for resistance to all other pins. Low resistance between these 2 pins should be ignored.

Greater than 100k ohms?
YES NO

A malfunctioning DEF dosing unit assembly has been detected.

Replace the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1684 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1684 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3576 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 1684 active?
STEP 3. | Check the aftertreatment DEF dosing unit and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve form the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool read the fault codes.

Fault Code 3576 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater 2 relay ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1684 active?
YES NO

A malfunctioning aftertreatment DEF tank heater control valve has been detected.

Replace the aftertreatment DEF tank heater control valve. See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF dosing unit and OEM harness.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a short circuit to ground.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the OEM harness aftertreatment DEF dosing unit connector and block ground.

Note: For 12 VDC applications, there are 2 SUPPLY pins for the tank heater control valve at the DEF dosing unit connector. Both must be measured for resistance to block ground.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pins(s) at the OEM harness aftertreatment DEF dosing unit connector and all other pins in the connector.

Note: For 12 VDC applications, there are 2 SUPPLY pins for the tank heater control valve at the DEF dosing unit connector. Both must be measured for resistance to all other pins. Low resistance between these 2 pins should be ignored.

Greater than 100k ohms?
YES NO

A malfunctioning DEF dosing unit assembly has been detected.

Replace the DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1688 - Aftertreatment Diesel Exhaust Fluid Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1688 active?
STEP 2. | Perform "Reset All Faults" command in INSITE™ electronic service tool. |
 | STEP 2A. Disable the fault codes. | Did Fault Code 1688 come back active?
 | STEP 2B. Perform leak test. | Fault Code 1688 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1688 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform "Reset All Faults" command in INSITE™ electronic service tool.

Guided Step 2A - Disable the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Use INSITE electronic service tool to clear all fault codes.
  • Turn keyswitch OFF for 90 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the active fault codes.

Did Fault Code 1688 come back active?
YES NO

Replace the aftertreatment DEF controller.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform leak test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Prime the aftertreatment system.

  • Use INSITE™ electronic service tool to initiate the Aftertreatment DEF System Leak Test found under the ECM diagnostics test menu.
  • Turn keyswitch OFF for 90 seconds.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1688 active?
YES NO

Replace the aftertreatment DEF controller. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jan-2015


FAULT CODE 1691 - Aftertreatment 1 Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISL9 CM2350 L101 | 4310787
Snap Acceleration Test | Refer to Procedure 014-017 | ISL9 CM2350 L101 | 4310787

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 1691 active?
 | STEP 1B. Read the fault codes. | Fault codes related to the aftertreatment diesel oxidation catalyst temperature sensors or aftertreatment diesel particulate filter temperature sensors active?
 | STEP 1C. Read the fault codes. | Fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve active?
 | STEP 1D. Read the fault codes. | Fault codes related to the fuel system active?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Inspect the aftertreatment diesel oxidation catalyst. | Any problems found during the inspection of the aftertreatment diesel oxidation catalyst?
 | STEP 3B. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
 | STEP 3C. Inspect the exhaust for excessive black smoke. | Excessive black smoke according to the procedure?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 1691 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the aftertreatment diesel oxidation catalyst temperature sensors or aftertreatment diesel particulate filter temperature sensors active?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the turbocharger or EGR valve active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the fuel system active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Inspect the aftertreatment diesel oxidation catalyst.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst from the vehicle. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Inspect the aftertreatment diesel oxidation catalyst for plugging from soot or oil contamination.
  • Inspect the aftertreatment diesel oxidation catalyst for cracks or damage of any cells in the catalyst.
  • Inspect the aftertreatment diesel oxidation catalyst for soot plugging the front face of the catalyst.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any problems found during the inspection of the aftertreatment diesel oxidation catalyst?
YES NO

Repair or replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Continue to troubleshoot the system to determine the root cause of the problem.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Check for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel, coolant, or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the exhaust for excessive black smoke.

Conditions

  • Exhaust pipe disconnected from turbocharger outlet.
  • Engine operating.

Action

Check the exhaust smoke.

  • Perform the Snap Acceleration - Aftertreatment Disconnected procedure to check for excessive black smoke
  • Refer to Procedure 014-017 in the Associated Procedures Table.

Excessive black smoke according to the procedure?
YES NO

Troubleshoot the cause of the excessive black smoke.

  • Reference the appropriate engine performance troubleshooting tree.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1694 - Aftertreatment 1 Outlet NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1694 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887, 2771, 3545, 3583, 3681, or 3749 active?
 | STEP 1C. Check for active fault codes. | Fault Code 1885, 3228, 3232, 3649, 3682, 3725, or 3748 active?
 | STEP 1D. Verify proper installation of the aftertreatment outlet mono-nitrogen oxides (NOx) sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check engine control module (ECM) calibration. |
 | STEP 2A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
STEP 3. | Check the aftertreatment diesel exhaust fluid (DEF) decomposition tube. |
 | STEP 3A. Check the decomposition tube for crystallization. | Crystallization buildup in the decomposition tube?
STEP 4. | Verify the condition of the aftertreatment NOx sensors. |
 | STEP 4A. Verify the condition of the aftertreatment NOx sensors. | Fault Code 1694 active?
 | STEP 4B. Check for active fault codes. | Fault Code 3228 active?
STEP 5. | Clear the fault codes. |
 | STEP 5A. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1694 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment outlet NOx sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771, 3545, 3583, 3681, or 3749 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment intake NOx sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 3228, 3232, 3649, 3682, 3725, or 3748 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Verify proper installation of the aftertreatment NOx sensor.

Conditions

  • Turn keyswitch ON.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

  • Inspect the aftertreatment outlet NOx sensor for proper installation. Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3A

Go to 5A

Guided Step 3 - Check the aftertreatment DEF decomposition tube.

Guided Step 3A - Check the decomposition tube for crystallization.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF decomposition tube.

Action

Check for DEF crystallization.

  • Inspect the decomposition tube for crystallization.
  • Refer to Procedure 011-062 in the Associated Procedures Table.

Crystallization buildup in the decomposition tube?
YES NO

Remove the crystallization buildup.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Verify the condition of the aftertreatment NOx sensors.

Guided Step 4A - Verify the condition of the aftertreatment NOx sensors.

Conditions

  • Turn keyswitch ON.
  • Start and run the engine at idle.
  • Connect INSITE™ electronic service tool.
  • Perform the Aftertreatment Diesel Particulate Filter Regeneration Test under the ECM Diagnostics Tests menu.

Note: The Regeneration Test is in addition to the first Regeneration Test that was performed when Fault Code 1694 became active. A second Regeneration Test must be performed at this time.

Action

Verify the sensor condition.

  • Use INSITE™ electronic service tool to read the active faults.

Fault Code 1694 active?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the aftertreatment intake NOx sensor.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 3228 active?
YES NO

Replace the aftertreatment intake NOx sensor.

Refer to Procedure 019-463 in the Associated Procedures Table.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear the fault codes.

Guided Step 5A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1695 - Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367891

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1695 inactive?
STEP 2. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 2A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the OEM harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harenss connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the engine coolant level sensor.
  • Disconnect the fuel level sensor, if hardwired.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 5 pin at the OEM harness ECM connector to all other pins in the connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short circuit to ECM battery (+) in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal from the OEM harness.
  • Disconnect the engine coolant level sensor.
  • Disconnect the fuel level sensor, if hardwired.

Action

Check for a short circuit to ECM battery (+).

  • Measure the resistance between the OEM +5 volt SUPPLY pin at the OEM harness ECM connector to the ECM battery (+) pins at the OEM harness connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1696 - Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1696 inactive?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Check the circuit response. | Fault Code 1696 active?
 | STEP 2B. Check the circuit response. | Fault Code 1696 active?
 | STEP 2C. Check the circuit response. | Fault Code 1696 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the accelerator pedal sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the accelerator pedal sensor. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel level sensor from the OEM harness, if hardwired.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Replace the fuel level sensor. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Repair the damaged pins.

Repair or replace the engine harness, or replace the ECM, whichever has the damaged pins.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the fuel level sensor, if hardwired.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the accelerator pedal 5 VDC SUPPLY pin and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the accelerator pedal/lever position sensor from the OEM harness.
  • Disconnect the coolant level sensor from the OEM harness.
  • Disconnect the fuel level sensor, if hardwired.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the accelerator 5 VDC SUPPLY pin and the engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1712 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 3597, 4248, 4291, 4292, 5673, or 5674 active?
STEP 2. | Check the aftertreatment DEF tank heating system. |
 | STEP 2A. Inspect the diesel exhaust fluid tank heater coolant lines. | Aftertreatment DEF tank temperature sensor value increase?
 | STEP 2B. Check the engine coolant level. | Coolant level correct?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 3597, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heating system.

Guided Step 2A - Inspect the DEF tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the heater operation.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater ON using the Diesel Exhaust Fluid Tank Heater Override.
  • After 3 minutes, use INSITE™ electronic service tool Data Monitor/Logger and monitor the aftertreatment DEF tank temperature sensor.

Aftertreatment DEF tank temperature sensor value increase?
YES NO
No Repair

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1713 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1713 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes. | Fault Code 1677, 1678, 1679, 1683, or 1684 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank temperature sensor. |
 | STEP 2A. Check the aftertreatment DEF tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify that the aftertreatment DEF tank heater control valve is installed correctly. | DEF tank heater control valve installed correctly?
 | STEP 3B. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1713 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1677, 1678, 1679, 1683, or 1684 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank temperature sensor.

Guided Step 2A - Check the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the DEF in the DEF tank with an infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for the aftertreatment DEF tank temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infared thermometer reading?
YES NO
No Repair

Replace the DEF tank temperature sensor.

  • See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify that the aftertreatment DEF tank heater control valve is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the installation of the tank heater control valve.

  • Make sure that the tank heater control valve is installed correctly, and not reversed.

See equipment manufacturer service information for details on the tank heater control valve.

DEF tank heater control valve installed correctly?
YES NO
No Repair

Remove the DEF tank heater control valve, and install it in the correct position. Make sure the valve is not reversed according to the coolant flow direction where applicable.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Start engine and allow coolant to achieve operating temperature.
  • Connect INSITE™ electronic service tool.

Action

Verify the proper operation of the aftertreatment DEF tank heater control valve.

  • Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the ECM Diagnostic Tests menu.
  • Use the Diesel Exhaust Fluid Tank Heater option in the test menu to override the tank heater control valve to ON.
  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

See equipment manufacturer service information for details on the tank heater control valve.

NOTE: The Diesel Exhaust Fluid Doser System Heater Test allows the technician to override the tank heater control valve to on. It does not test if the tank heater control valve is operating correctly. With the tank heater control valve commanded on, a temperature rise may be felt on the coolant hose to the diesel exhaust fluid tank.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the DEF tank heater control valve.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1867 - Exhaust Gas Recirculation Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 2375 and 2376. | Fault Code 2375 or 2376 active?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature sensor and circuit. |
 | STEP 2A. Inspect the EGR temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2375 active?
 | STEP 2C. Check the circuit response. | Fault Code 2376 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2375 active?
 | STEP 3C. Check the circuit response. | Fault Code 2376 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 2375 and 2376.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 or 2376 active?
YES | NO
No Repair | No Repair

Fault Code 2375 or 2376 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas recirculation (EGR) temperature sensor and circuit.

Guided Step 2A - Inspect the EGR temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor and connector pins.

Action

Inspect the engine harness and EGR temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2375 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR temperature SIGNAL pin and the EGR temperature RETURN pin at the EGR temperature connector of the engine harness.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2376 active?
YES NO

Replace the EGR temperature sensor.

Refer to Procedure 019-378 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2375 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR temperature SIGNAL pin and EGR temperature RETURN pin at the ECM engine connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool, read the fault codes.

Fault Code 2376 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-May-2015


FAULT CODE 1883 - Aftertreatment Diesel Particulate Filter Differential Pressure Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1879 and 1881. | Fault Code 1879 or 1881 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
 | STEP 2B. Monitor the aftertreatment DPF differential pressure sensor voltage. | Aftertreatment DPF differential pressure sensor voltage within specifications?
STEP 3. | Check the presence of the aftertreatment DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or removal of the aftertreatment system detected?
STEP 4. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 4A. Inspect the aftertreatment DPF differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 1881 active?
 | STEP 5C. Check the circuit response. | Fault Code 1879 active?
STEP 5. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 5A. Inspect ECM and OEM harness connector pins. | Dirty or damaged?
 | STEP 5B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 5D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 5E. Check the aftertreatment differential pressure sensor voltage value. | Value change?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1879 and 1881.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 or 1881 active?
YES | NO
No Repair | No Repair

Fault Code 1879 or 1881 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor tubes.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes.

  • Make sure the tubes are installed correctly (not reversed).
  • Make sure both ends of the tubes are securely connected
  • Inspect the tubes for leaks or damage
  • Inspect the tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Monitor the aftertratment DPF differential pressure sensor voltage.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Engine not operating.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment DPF differential pressure sensor voltage with an electronic service tool.

An exhaust ventilation system connected to the exhaust can cause the differential pressure sensor to read incorrectly. Make sure to remove any ventilation or vacuum equipment from the exhaust before reading the differential pressure sensor value with INSITE™ electronic service tool.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor voltage reading within specifications?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF

Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

  • Refer to the Procedure 011-041 in the Associated Procedures Table.

Tampering or removal of the aftertreatment system detected?
YES NO

Install the correct aftertreatment system for the vehicle.

Refer to the Procedure 011-041 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 4A - Inspect the aftertreatment DPF differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure 5 volt SUPPLY pin and the aftertreatment DPF differential pressure SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1879 active?
YES NO

An in-range malfunctioning aftertreatment DPF differential pressure sensor has been detected.

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the engine control module (ECM) and original equipment manufacturer (OEM) harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5E

Go to 6A

Guided Step 5E - Check the aftertreatment differential pressure sensor voltage value.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for a change in the voltage value.

  • Use INSITE™ electronic service tool to monitor the aftertreatment differential pressure sensor voltage.
  • Perform a Snap Acceleration Test.

Value change?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Calibrate the ECM.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Mar-2015


FAULT CODE 1887 - Aftertreatment 1 Outlet NOx Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2771 or 3681 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887 active?
STEP 2. | Check engine contol module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 or 3681 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887 active?
YES NO

An internal error has been detected in the aftertreatment outlet mono-nitrogen oxides (NOx) sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 1896 - EGR Valve Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1896 active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve operation. |
 | STEP 2A. Check for active fault codes. | Fault Code 1896 active?
STEP 3. | Check for damage to the aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the exhaust gas recirculation (EGR) valve operation.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Turn the keyswitch OFF for 1 minute and then turn the keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1896 active?
YES NO

A stuck open EGR valve has been detected.

Clean the EGR valve assembly.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Perform the Snap-Acceleration Test to check for a malfunctioning diesel particulate filter (DPF).

  • Refer to Procedure 014-013 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check for damage to the aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the aftertreatment initial check procedure to test for a malfunctioning DPF.

Action

Check for aftertreatment progressive damage.

  • Perform the aftertreatment initial check procedure to test for a malfunctioning DPF.

Progressive damage to the aftertreatment system may have occurred. The aftertreatment system must be inspected for reuse.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment component.

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1897- VGT Actuator Controller - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment System | Refer to Procedure 011-050 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check Variable Geometry Turbocharger (VGT) actuator installation. |
 | STEP 1A. Check for previous VGT actuator removals | VGT actuator recently been removed or replaced?
 | STEP 1B. Check the VGT actuator. | VGT actuator removed from the turbocharger and the keyswitch turned ON?
 | STEP 1C. Disconnect and connect VGT actuator connector. | Fault Code 1897 inactive after disconnecting and connecting the VGT actuator connector?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
STEP 3. | Check for progressive damage. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check VGT actuator installation.

Guided Step 1A - Check for previous VGT actuator removals.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The VGT actuator has recently been removed or replaced and Fault Codes 1897 and 2449 are active.

  • Fault Codes 2449 and 1897 are active.

VGT actuator recently been removed or replaced?
YES NO

Remove the actuator and install it in the correct position. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1B

Guided Step 1B - Check the VGT actuator.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for correct VGT actuator installation.

VGT actuator removed from the turbocharger and the keyswitch turned ON?
YES NO

Remove the actuator and install it in the correct position. Refer to Procedure 010-134 in the Associated Procedures Table.

No Repair

Go to 1C

Go to 2A

Guided Step 1C - Disconnect and connect VGT actuator connector.

Conditions

Not applicable

Action

If the VGT actuator is removed from the turbocharger and the keyswitch is turned ON with the wiring harness connected to the VGT actuator, Fault Code 1897 will be active. Follow the procedures below:

  • Turn keyswitch ON.
  • Disconnect the VGT actuator from the engine harness and connect.

Fault Code 2636 will be active temporarily when the turbocharger actuator is disconnected.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Fault Code 1897 is inactive after disconnecting and connecting the VGT actuator connector?
YES | NO
No Repair | No Repair

Repair complete

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

A damaged VGT actuator has been detected.

  • Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check for progressive damage.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform a Snap Acceleration Test to test for a damaged diesel particulate filter (DPF).
  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Progressive damage to the aftertreatment system may have occurred.

  • Perform a Snap Acceleration Test to test for a damaged DPF. Refer to Procedure Refer to 014-017 in the Associated Procedures Table.

Progressive damage to the aftertreatment system is detected?
YES NO

Replace the damaged aftertreatment component. Refer to Procedure 011-050 in the Associated Procedures Table.

Check for active aftertreatment-related fault codes and follow any active aftertreatment fault code troubleshooting trees.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1938 - Electronic Control Unit Power Output Supply Voltage 1 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the equipment battery system. |
 | STEP 1A. Check for active fault codes. | Fault Code 441, 442, 596, 597, 5736, or 5737 active?
 | STEP 1B. Check for active fault codes. | Fault Codes 2636, 2771, 3219, 3232, 3597, 4151, and 4152 active?
 | STEP 1C. Check the battery connections. | Battery connections tight and free of corrosion?
 | STEP 1D. Check the battery voltage. | Battery voltage acceptable in normal conditions?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
 | STEP 2C. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. |

Guided Step 1 - Check the equipment battery system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Fault Code 441, 442, 596, 597, 5736, or 5737 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Fault Codes 2636, 2771, 3219, 3232, 3597, 4151, and 4152 active?
YES NO

Replace Smart Power Relay.

See equipment manufacturer service information.

 No Repair

Go to appropriate fault code tree

Go to 1C

Guided Step 1C - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery terminals for corrosion or loose connections.

  • Inspect the battery terminal connections on both positive (+) and negative (-) terminals.

Battery connections tight and free of corrosion?
YES NO
No Repair

Tighten the loose connections, and clean the terminals.

See equipment manufacturer service information.

Go to 1D

Go to 3A

Guided Step 1D - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Measure the battery voltage.

Normal Conditions:

  • At least 12 VDC (12 VDC systems).

Battery voltage acceptable in normal conditions?
YES NO
No Repair

Charge or replace the batteries.

See equipment manufacturer service information.

Go to 2A

Go to 3A

Guided Step 2 - Check the variable geometry turbocharger (VGT) actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the VGT actuator or harness connector

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator voltage supply circuit and the VGT actuator return circuit at the VGT actuator wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES NO

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator voltage supply circuit at the VGT actuator wiring harness connector and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the wiring diagram and the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES NO

An open or high resistance circuit has been detected in the VGT actuator battery voltage return circuit.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

An open or high resistance circuit has been detected in the VGT actuator battery voltage supply circuit.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1974 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather (External) | Refer to Procedure 003-001 | ISV5.0 CM3230 V104 | 4367291
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291
Crankcase Ventilation Filter | Refer to Procedure 003-021 | ISV5.0 CM3230 V104 | 4367291
Crankcase Blowby, Measure | Refer to Procedure 014-010 | ISV5.0 CM3230 V104 | 4367291
Crankcase Pressure Sensor | Refer to Procedure 019-445 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1974 active or more than 1 inactive counts?
STEP 2. | Inspect the crankcase ventilation system. |
 | STEP 2A. Verify pressure sensor accuracy. | Pressure reading 0 ±0.28 kPa - G [0 ±1.13 in-H2O]?
 | STEP 2B. Check the mileage/hours on the crankcase ventilation filter since last maintenance. | Filter below the maintenance interval?
 | STEP 2C. Inspect the crankcase ventilation filter. | Crankcase ventilation filter has contamination or blockage?
 | STEP 2D. Inspect the crankcase ventilation oil drain tubes, check valves, and breather tubes. | Oil drain tubes, check valves, breather tube, or oil separator plugged?
STEP 3. | Measure the crankcase blowby. |
 | STEP 3A. Perform the crankcase blowby measurement. | Crankcase blowby measurement within specification?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1974 active or more than 1 inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Inspect the crankcase ventilation system.

Guided Step 2A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Do not operate engine.

Action

Use INSITE™ electronic service tool "Data Monitor/Logger" feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not running.
  • Use INSITE™ electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ±0.28 kPa - G [0 ±1.13 in-H2O]?
YES NO
No Repair

Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check mileage/hours on the crankcase ventilation filter since last maintenance.

Conditions

  • Locate maintenance records (miles/hours) of the latest crankcase ventilation filter replacement.

Action

Check mileage/hours on the crankcase ventilation filter since last maintenance.

Contact a Cummins® Authorized Repair Location for crankcase ventilation filter maintenance intervals for specific engine application.

Filter below the maintenance interval?
YES NO
No Repair

Replace the crankcase ventilation filter.

  • Refer to Procedure 003-021 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the crankcase ventilation filter.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the crankcase ventilation filter for contamination or blockage.

Crankcase ventilation filter has contamination or blockage?
YES NO

Replace the crankcase ventilation filter.

Refer to Procedure 003-021 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Inspect the crankcase ventilation oil drain tubes, check valves, and breather tubes.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the oil drain tubes, check valves, and breather tubes for plugging.

Refer to Procedure 003-001 in the Associated Procedures Table.

Refer to Procedure 003-018 in the Associated Procedures Table.

Oil drain tubes, check valves, breather tube, or oil separator plugged?
YES NO

Clean or replace the crankcase ventilation oil drain tubes, check valves, or breather tube.

  • Refer to Procedure 003-001 in the Associated Procedures Table.
  • Refer to Procedure 003-018 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Measure the crankcase blowby.

Guided Step 3A - Perform the crankcase blowby measurement.

Conditions

  • Turn keyswitch ON.
  • Do not operate engine.

Action

Operate the engine at rated speed and under load by one of the following methods:

  • Engine testing, a chassis dynamometer, or engine dynamometer
  • A stall speed test for engine equipped with automatic transmissions only.

Measure the crankcase blowby. Refer to Procedure 014-010 in the Associated Procedures Table.

Crankcase blowby measurement within specification?
YES NO

Replace the crankcase ventilation filter. Refer to Procedure 003-021 in the Associated Procedures Table.

Troubleshoot the possible causes for excessive crankcase gases.

  • See the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 1976 - VGT Actuator Driver Over Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Coolant Hoses | Refer to Procedure 010-041 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the variable geometry turbocharger (VGT) actuator cooling system. |
 | STEP 1A. Check for active fault codes. | Fault codes related to high coolant temperature are active or high count or inactive coolant temperature related faults?
 | STEP 1B. Inspect VGT actuator coolant lines. | Blockages found in the VGT actuator cooling plate or coolant lines?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the variable geometry turbocharger (VGT) actuator cooling system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to high coolant temperature are active or high count or inactive coolant temperature related faults?
YES NO

The VGT actuator internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Inspect VGT actuator coolant lines.

Action

Inspect the VGT actuator coolant lines for kinks and blockages.

  • Blow shop air in reverse flow through the VGT actuator cooling plate to check blockages.

Blockages found in the VGT actuator cooling plate or coolant lines?
YES NO

Repair or replace the blocked coolant line.

  • Refer to Procedure 010-041 in the Associated Procedures Table.

No Repair

Repair complete

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 1993 - Aftertreatment 1 Diesel Particulate Filter Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1879, 1881, or 1883 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes installed correctly?
STEP 3. | Check the presence of the aftertreatment DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or removal of the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter (DPF) differential pressure.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes.
  • Loose fittings on the differential pressure sensor tubes.
  • Missing or broken differential pressure sensor tubes.
  • Plugged tubes.
  • Make sure the differential pressure sensor tubes are installed correctly. It is possible the differential pressure tubes are connected backwards at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Tampering or removal of the aftertreatment system detected?
YES NO

Install the correct aftertreatment system for the vehicle.

  • Refer to the Procedure 011-041 in the Associated Procedures Table.

Continue to inspect the aftertreatment systems for signs of tampering.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 2217 - Engine Control Module Calibration Program Memory (RAM) Corruption - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Fault Codes 111, 343, 6257, 6256, 1117, 2416, and/or 3697 active?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Calibrations download successful?
STEP 3. | Clear the fault codes. |
 | STEP 3A. Verify the fault code is inactive. | Fault Code 2217 inactive?
 | STEP 3B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for multiple active fault codes.

  • Use INSITE™ electronic service tool to check for multiple active fault codes.

Fault Codes 111, 343, 6257, 6256, 1117, 2416, and/or 3697 active?
YES NO

Troubleshoot the fault code using the appropriate troubleshooting guide.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the engine control module (ECM).

Guided Step 2A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Calibrate the ECM.

  • Use INSITE™ electronic service tool to calibrate the ECMs. Refer to Procedure 019-032 in Section 19.
  • Repeat for each engine ECM, as appropriate.

Calibrations download successful?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Clear the fault codes.

Guided Step 3A - Verify the fault code is inactive.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Verify the fault code is inactive.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2217 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 3B

Go to 1A

Guided Step 3B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Appropriate troubleshooting steps

Last Modified: 26-May-2015


FAULT CODE 2224 - Fuel Level (Main Tank) - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2224 active?
 | STEP 1B. Check for an active Controller Area Network (CAN) fault codes. | CAN fault codes active?
 | STEP 1C. Check for an active fault code. | Fault Code 2222 or 2223 active?
STEP 2. | Check the fuel level sensor and circuit. |
 | STEP 2A. Check for adequate fuel supply. | Equipment/vehicle has an adequate fuel supply?
 | STEP 2B. Verify inactive fault Code. | Fault Code 2224 inactive?
STEP 3. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2224 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for an active Controller Area Network (CAN) fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault cods.

  • Use INSITE™ electronic service tool to read the fault codes.

CAN fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2222 or 2223 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code tree

Go to 2A

Guided Step 2 - Check the fuel level sensor and circuit.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment/vehicle has an adequate fuel supply?
YES NO

A damaged sensor has been detected.

Replace the fuel level sensor.

See equipment manufacturer service information.

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 3A

Go to 2B

Guided Step 2B - Verify inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2224 inactive?
YES NO
No Repair

A malfunctioning sensor has been detected.

Replace the fuel level sensor. See equipment manufacturer service information

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 14-Jan-2015


FAULT CODE 2271 - EGR Valve Position Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 or 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2271 active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2272 active and Fault Code 2271 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 2271 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 or 386 active?
YES NO

Troubleshoot Fault Code.

 No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the exhaust gas recirculation (EGR) valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the EGR valve connector of the engine harness.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active and Fault Code 2271 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position sensor +5 VDC SUPPLY pin and the EGR valve position sensor RETURN pin at the engine harness connector.

Use the Circuit Diagram or Wiring Diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES NO

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the EGR valve position sensor RETURN pin and the EGR valve position sensor SIGNAL pin at the ECM engine connector.

  • Check for the appropriate ECM response after 30 seconds.
  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2272 active and Fault Code 2271 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 2271 active?
YES NO

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the EGR valve position +5 VDC SUPPLY pin and the EGR valve position RETURN pin at the ECM connector.

Use the Circuit Diagram or Wiring Diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active?
YES NO

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 2272 - EGR Valve Position Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352, 386 active?
 | STEP 1B. Check for an active fault code. | Fault Code 2272 active?
STEP 2. | Inspect the exhaust gas recirculation (EGR) valve position sensor and circuit. |
 | STEP 2A. Inspect the engine harness and sensor connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2271 active and Fault Code 2272 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 2272 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352, 386 active?
YES NO

Troubleshoot Fault Code.

 No Repair

Appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Inspect the exhaust gas recirculation (EGR) valve position sensor and circuit.

Guided Step 2A - Inspect the engine harness and sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2271 active and Fault Code 2272 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the engine harness.

  • Measure the voltage between the EGR valve position sensor +5 VDC SUPPLY pin and the EGR valve position sensor RETURN pin at the engine harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine control module (ECM) and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read fault codes.

Fault Code 2271 active and Fault Code 2272 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the EGR valve position sensor supply voltage and return circuit at the ECM.

  • Measure the voltage between the EGR valve position +5 VDC SUPPLY pin and the EGR valve position RETURN pin at the ECM connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for multimeter useage information. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2272 active?
YES NO

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-May-2015


FAULT CODE 2347 - Turbocharger Compressor Outlet Temperature (Calculated) - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active turbocharger fault codes. | Fault Code 595, 687, 1229, 1897, 2198, 2387, 2449, or 2636 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 693, 741, or 5951 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check sensor readings. |
 | STEP 2A. Check the turbocharger compressor intake pressure sensor accuracy. | Turbocharger compressor intake pressure within ± 2 kPa [± 0.29 psi] of local barometric pressure?
 | STEP 2B. Check the charge air cooler pressure sensor accuracy. | Charge air cooler pressure within ± 10.3 kPa [± 1.49 psi] of local barometric pressure?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 595, 687, 1229, 1897, 2198, 2387, 2449, or 2636 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 693, 741, or 5951 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check sensor readings.

Guided Step 2A - Check the turbocharger compressor intake pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Start INSITE™ Data Monitor/Logger and compare the INSITE™ electronic service tool reading for turbocharger compressor intake pressure to local barometric pressure.

Turbocharger compressor intake pressure within ± 2 kPa [± 0.29 psi] of local barometric pressure?
YES NO
No Repair

Replace the turbocharger compressor intake pressure sensor. Refer to Procedure 019-466 in Section 19.

Go to 2B

Go to 3A

Guided Step 2B - Check the charge air cooler pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the value of the charge air pressure without the engine running.

Charge air cooler pressure within ± 10.3 kPa [± 1.49 psi] of local barometric pressure?
YES NO
No Repair

Replace the charge air pressure sensor.

Refer to Procedure 019-560 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Jan-2016


FAULT CODE 2351 - EGR Valve Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for exhaust gas recirculation (EGR) motor circuit fault codes. | Fault Code 2351 active?
STEP 2. | Check the EGR valve and circuit. |
 | STEP 2A. Inspect the EGR valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the EGR valve motor. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2351 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR motor circuit fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Start the engine. Allow it to idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve and circuit.

Guided Step 2A - Inspect the EGR valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Check for a short circuit to ground in the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and engine block ground.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

Repalce the EGR valve. Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged, harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Chek for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2351 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 2352 - EGR Valve Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2352 active?
STEP 2. | Check the exhaust gas recirculation (EGR) valve motor and circuit. |
 | STEP 2A. Inspect the EGR valve motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the EGR valve motor circuit. | Less than 15 ohms?
 | STEP 2B-1. Check for an open circuit in the EGR valve motor. |
 | STEP 2B-2. Check for an open circuit in the engine harness. |
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to voltage source. | Less than 1.5 VDC?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2352 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2352 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the EGR valve motor and circuit.

Guided Step 2A - Inspect the EGR valve motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Inspect the engine harness and EGR valve motor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the EGR valve motor circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the EGR valve to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the EGR valve motor circuit.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-1

Guided Step 2B-1 - Check for an open circuit in the EGR valve motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR valve from the engine harness.

Action

Check for an open circuit in the EGR valve motor.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin and the EGR valve motor SIGNAL (-) pin at the EGR valve connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

An open circuit has been detected in the EGR valve.

Replace the EGR valve assembly. Refer to Procedure 011-022 in the Associated Procedures Table.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the EGR valve.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and the EGR valve motor SIGNAL (+) pin at the EGR valve motor connector of the engine harness.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and the EGR valve motor SIGNAL (-) pin at the EGR valve motor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pin
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspections techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged, harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit to voltage has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the EGR valve.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance between the EGR valve motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the EGR valve motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Chek for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2352 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 2387 - VGT Actuator Driver Circuit (Motor) - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
VGT Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment System | Refer to Procedure 011-050 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for previous variable geometry turbocharger (VGT) actuator removals. | Actuator removed or replaced during the current repair event?
 | STEP 1C. Check for exhaust gas recirculation (EGR) -related fault codes. | EGR system fault codes active?
 | STEP 1D. Check exhaust restriction. | Exhaust restriction greater than 308 mm-Hg [12 in-Hg]?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in the Associated Procedures Table?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2387.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387 active or inactive with more than one count logged in the last 25 engine hours?
YES NO
No Repair

No troubleshooting is necessary. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Conditions

Not applicable.

Action

Check for previous replacements.

  • Determine if the actuator has been removed or replaced and Fault Code 2387 is active.

Actuator been removed or replaced during the present repair event?
YES NO

Remove the actuator. Install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for EGR-related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve, EGR temperature, and EGR differential pressure-related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for active Fault Codes 1896, 2357, 2359, 2764, 2961, 2962, 3382, and 3383.

EGR system fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting procedure.

Go to 1D

Guided Step 1E - Check exhaust restriction.

Conditions

  • Install a pressure gauge into the exhaust system.
  • Turn keyswitch ON.
  • Run engine at rated horsepower and rpm.

Action

Check exhaust restriction by installing a pressure gauge into the exhaust system, just past the turbocharger outlet.

If a port is not found in the exhaust system, remove the aftertreatment diesel oxidation catalyst intake sensor and install the pressure gauge in the temperature sensor port.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction greater than 308 mm-Hg [12 in-Hg]?
YES NO

Remove the diesel oxidation catalyst from the vehicle. Inspect for face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Check for a broken drive gear on the VGT actuator.

Gear broken on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger bearing housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Sector gear teeth are not damaged and movement meets the requirements when using the sector gear gauge, according to Procedure 010-134 in the Associated Procedures Table in the base engine service manual?

YES NO

A damaged VGT actuator has been detected.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly.

  • Refer to Procedure 010-112 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Perform the aftertreatment initial check procedure to test for a damaged diesel particulate filter. Refer to Procedure 014-017 in the Associated Procedures Table.

Action

Check for progressive damage to the aftertreatment system.

Perform the aftertreatment initial check procedure to test for a damage diesel particulate filter.

  • Refer to Procedure 014-017 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s). Refer to Procedure 011-050 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance

Last Modified: 29-Jun-2017


FAULT CODE 2398 - Ambient Air Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2398 active?
 | STEP 1B. Check for Fault Codes 249 and 256. | Fault Code 249 or 256 active?
STEP 2. | Check the ambient air temperature sensor and circuit. |
 | STEP 2A. Inspect the ambient air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 249 active?
 | STEP 2C. Check the circuit response. | Fault Code 256 active?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 249 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2398 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 249 and 256.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 or 256 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the ambient air temperature sensor and circuit.

Guided Step 2A - Inspect the ambient air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Inspect the OEM harness and ambient air temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ambient air temperature sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the ambient air temperature sensor SIGNAL pin and the ambient air temperature sensor RETURN pin at the ambient air temperature sensor connector of the OEM harness.

Use the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 256 active?
YES NO

An in-range malfunction of the ambient air temperature sensor has been detected.

Replace the ambient air temperature sensor.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector ambient air temperature sensor RETURN pin and the OEM harness ambient air temperature sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector ambient air temperature sensor SIGNAL pin and the OEM harness ambient air temperature sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the ambient air temperature sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the ambient air temperature sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 249 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair Complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2449 - VGT Actuator Controller - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and previous service history. |
 | STEP 1A. Check for active fault codes. | Fault Code 2449 active?
 | STEP 1B. Check for previous variable geometry turbocharger (VGT) actuator removals. | VGT actuator removed or replaced?
 | STEP 1C. Check for active fault codes. | Fault Code 1938 or 2636 active?
STEP 2. | Check the VGT actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on the VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Nozzle movement meets the requirements according to Procedure 010-134 using the sector gauge?
 | STEP 2D. Check the VGT output gear for correct calibration. | VGT actuator gear moves when connected to the engine wiring harness?
 | STEP 2D-1. Check the VGT output gear for manual rotation by hand. |
 | STEP 2E. Check for active Fault Code 2449. | Fault Code 2449 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and previous service history.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Cycle the keyswitch several times. Wait 30 seconds between each key cycle to see if Fault Code 2449 goes active.

Fault Code 2449 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 2449 is active. Clear the inactive fault code.

Go to 1B

Go to 3A

Guided Step 1B - Check for previous VGT actuator removals.

Action

Determine if the actuator has just been removed or replaced and Fault Code 2449 is active.

VGT actuator removed or replaced?
YES NO

Remove the actuator. Install it in the correct position.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938 or 2636 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Nozzle movement meet the requirements according to Procedure 010-134 using sector gauge?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

NOTE: This malfunction can be caused by debris exiting the engine, causing the turbocharger to stop moving. Inspect base engine components for signs of damage.

Replace the turbocharger.

  • Refer to Procedure 010-112 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the VGT output gear for correct calibration.

Conditions

  • Disconnect the VGT actuator from the engine wiring harness.
  • Turn keyswitch ON.

Action

Check the VGT actuator output gear operation.

  • Connect the VGT actuator to the engine wiring harness. The VGT actuator gear should rotate.

NOTE: The VGT actuator output gear will exhibit one of the following movements, depending on the ECM calibration. Make sure to closely observe the VGT actuator gear when the VGT actuator is connected to the engine wiring harness.

  • The actuator output gear could possibly rotate completely in one direction and then rotate completely in the opposite direction, OR
  • The actuator output gear may only move a few degrees in one direction. This movement will be a quick snap when the VGT actuator is connected to the engine wiring harness.
  • If the VGT actuator gear does not move, disconnect the VGT actuator from the engine wiring harness for 1 second and then reconnect.
  • Repeat the above procedure three times, checking for VGT actuator gear movement each time the VGT actuator is connected to the engine wiring harness.

VGT actuator gear moves when connected to the engine wiring harness?
YES NO

Install the VGT actuator back on the turbocharger. Be sure the theft actuator install and calibrate procedures are performed.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 2E

Go to 2D-1

Guided Step 2D-1 - Check the VGT output gear for manual rotation by hand.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine wiring harness.

Action

Turn the VGT actuator output gear by hand.

  • Try turning the VGT actuator output gear by hand in either direction.

NOTE: Do not use pliers or any other tool to turn the gear. Only rotate the gear by hand.

VGT actuator output gear rotates by hand?
YES NO

Install the VGT actuator back on the turbocharger. Make sure the theft actuator install and calibrate procedures are performed.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for active Fault Code 2449.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 2449.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2449 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2554 - Exhaust Gas Pressure 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor Tube | Refer to Procedure 011-027 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for turbocharger fault codes. | Fault Code 2387, 1897, or 2636 active?
 | STEP 1B. Check for Fault Codes 2373 and 2374. | Fault Code 2373 or 2374 active?
STEP 2. | Check the exhaust gas pressure sensor tube. |
 | STEP 2A. Check the exhaust gas pressure sensor tube. | Plugging or damage found on the exhaust gas pressure sensor tube?
STEP 3. | Check the exhaust gas pressure sensor and circuit. |
 | STEP 3A. Inspect the exhaust gas pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2374 active?
 | STEP 3C. Check the circuit response. | Fault Code 2373 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2374 active?
 | STEP 4C. Check the circuit response. | Fault Code 2373 active?
STEP 5. | Check the variable geometry turbocharger (VGT) actuator. |
 | STEP 5A. Inspect the VGT actuator. | Dirty or damaged pins?
 | STEP 5B. Inspect the VGT actuator. | Gear broken on the VGT actuator?
 | STEP 5C. Inspect the turbocharger shaft movement. | Nozzle movement meets requirements according to Procedure 010-134 using sector gauge?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for turbocharger fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2387, 1897, or 2636 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Codes 2373 and 2374.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 or 2374 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust gas pressure sensor tube.

Guided Step 2A - Check the exhaust gas pressure sensor tube.

Conditions

  • Turn keyswitch OFF.
  • Remove the exhaust gas pressure sensor tube. Refer to Procedure 011-027 in the Associated Procedures Table.

Action

Check the exhaust gas pressure sensor tube.

Inspect the inside of the tube. If clogged, use compressed air to remove debris or soot buildup.

Check the tube for cracks and thread damage.

Replace the tube if cracks or other damage is found. Refer to Procedure 011-027 in the Associated Procedures Table.

Plugging or damage found on the exhaust gas pressure sensor tube?
YES NO

Clean or replace the exhaust gas pressure sensor tube. Refer to Procedure 011-027 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the exhaust gas pressure sensor and circuit.

Guided Step 3A - Inspect the exhaust gas pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.

Action

Inspect the engine harness and exhaust gas pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2374 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the exhaust gas pressure sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

Fault Code 2374 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 6A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas pressure +5 volt SUPPLY pin and the exhaust gas pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2373 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5 - Check the VGT actuator.

Guided Step 5A - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear broken on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5C

Guided Step 5C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand. Refer to Procedure 010-134 in the Associated Procedures Table.

Nozzle movement meets requirements according to Procedure 010-134 using sector gauge?
YES NO

An in-range malfunction of the exhaust gas pressure sensor has been detected.

Replace the exhaust gas temperature sensor.. Refer to Procedure 019-376 in the Associated Procedures Table.

A turbocharger mechanical malfunction has been detected.

This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Replace the turbocharger assembly. Refer to Procedure 010-112 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2571 - Engine Charge-Air Cooler Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2571 inactive?
STEP 2. | check the charge-air cooler outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the charge-air cooler outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2572 active and Fault Code 2571 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2571 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2572 active and Fault Code 2571 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault codes. | Fault Code 2571 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the charge-air cooler outlet temperature sensor and circuit.

Guided Step 2 - Inspect the charge-air cooler outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the charge-air cooler outlet temperature sensor SIGNAL pin and charge-air cooler outlet temperature sensor RETURN pin at the engine harness charge-air cooler outlet temperature sensor connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 2572 active and Fault Code 2571 inactive?
YES NO

Replace the charge-air cooler temperature sensor. Refer to Procedure 019-560 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the charge-air cooler outlet temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damage connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connectors.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM resposne.

  • Place a jumper wire between the charge-air cooler outlet temperature sensor SIGNAL pin and charge-air cooler outlet temperature sensor RETURN pin at the ECM connector.

Use the circuit diagram or wiring diagram for component pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active and Fault Code 2571 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector charge-air cooler outlet temperature sensor RETURN pin and the engine harness charge-air cooler outlet temperature sensor connector RETURN pin.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector charge-air cooler outlet temperature sensor SIGNAL pin and the engine harness charge-air cooler outlet temperature sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code could be detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of the troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2572 - Engine Charge Air Cooler Outlet Temperature - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code | Fault Code 2572 inactive?
STEP 2. | Check the charge-air cooler outlet temperature sensor and circuit. |
 | STEP 2A. Inspect the charge-air cooler outlet temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2571 active and Fault Code 2572 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2572 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 2571 active and Fault Code 2572 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2572 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the charge-air cooler outlet temperature sensor and circuit.

Guided Step 2A - Inspect the charge-air cooler outlet temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active and Fault Code 2572 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the charge-air cooler outlet temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES NO

A damaged sensor has been detected.

Replace the charge-air cooler outlet temperature sensor.

Refer to Procedure 019-560 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 active and Fault Code 2572 inactive?
YES NO
No Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the charge-air cooler outlet temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the charge-air cooler outlet temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine charge-air cooler outlet temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the charge-air cooler outlet temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 2635 - VGT Actuator Driver Circuit - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine control module (ECM) calibration. |
 | STEP 1A. Check the ECM calibration. | ECM code correct for the engine control parts list (CPL)?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM calibration.

Guided Step 1A - Check the ECM calibration.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM calibration and make sure it is correct for the engine CPL.

  • Make sure the ECM code calibration voltage is correct for the application. A 24 volt calibration downloaded into a 12 volt system can cause this fault code.

ECM code correct for the engine CPL?
YES NO

An incorrect variable geometry turbocharger actuator for the voltage application has been detected.

Replace the variable geometry turbocharger actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

Download the correct ECM code for the engine CPL.

2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2636 - VGT Actuator Driver Circuit - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2636 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. |
 | STEP 1C. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 1D. Check the fault codes. | Fault Code 2771, 3219, 3232, 3597, 3868, 3911, 4151, 4152, or 4572 active or more than one inactive count?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator and circuit. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
 | STEP 2C. Check the voltage to the VGT actuator. | Voltage greater than 10 VDC?
STEP 3. | Check the VGT actuator and J1939 circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | 108 to 132 ohms?
 | STEP 3B. Check the J1939 terminating resistance. | 108 to 132 ohms?
STEP 4. | Check the power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 to 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 to 132 ohms?
STEP 6. | Check the J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5 VDC?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.1 and 4.5 VDC?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1962 or 1976 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the equipment manufacturer harness ECM connector to the block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1D

Go to 7A

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3219, 3232, 3597, 3868, 3911, 4151, 4152, or 4572 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the VGT actuator and circuit.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the VGT actuator or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator battery voltage supply circuit and the VGT actuator battery voltage return circuit at the VGT actuator wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the VGT actuator.

Conditions

  • Turn keyswitch ON.
  • Disconnect the VGT actuator from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the VGT actuator.

  • Measure the voltage between the VGT actuator battery voltage supply circuit at the VGT actuator wiring harness connector and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10 VDC?
YES NO

An open or high resistance circuit has been detected in the VGT actuator battery voltage return circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

An open or high resistance circuit has been detected in the VGT actuator battery voltage supply circuit.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 3 - Check the VGT actuator and J1939 circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the VGT actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES | NO
No Repair | No Repair

Go to 3B

Go to 5A

Guided Step 3B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the VGT actuator from the engine harness.

Action

Measure the terminating resistance of the VGT actuator.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire of the VGT actuator.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

A malfunctioning VGT actuator has been detected.

Replace the VGT actuator.

  • Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s).

See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 data link.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Resistance between 108 to 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

Refer to Procedure 019-417 in the Associated Procedures Table for the aftertreatment harness isolation check.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

Refer to Procedure 019-417 in the Associated Procedures Table for the engine harness isolation check.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link (+) for a short circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit

  • Measure the voltage between the SAE J1939 (+) pin at the 3 pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

Use the following procedure to perform the data link circuit isolation check.

  • Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 6B

Go to 7A

Guided Step 6B - Check the J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit

  • Measure the voltage between the SAE J1939 (-) pin at the 3 pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

Use the following procedure to perform the data link circuit isolation check.

  • Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2016


FAULT CODE 2638 - Aftertreatment Diesel Oxidation Catalyst Conversion Efficiency - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2638 active?
 | STEP 1B. Read the fault codes. | Fault codes related to the aftertreatment diesel oxidation catalyst (DOC) temperature sensors or aftertreatment diesel particulate filter (DPF) temperature sensors active?
 | STEP 1C. Read the fault codes. | Fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve active?
 | STEP 1D. Read the fault codes. | Fault codes related to the fuel system active?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust between the turbocharger and aftertreatment system for leaks. | Exhaust system leaks found?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Inspect the aftertreatment DOC. | Problems found during the inspection of the aftertreatment DOC?
 | STEP 3B. Inspect the turbocharger exhaust outlet for oil, coolant, or fuel. | Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
 | STEP 3C. Inspect the exhaust for excessive black smoke. | Excessive black smoke according to the procedure?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2638 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the aftertreatment DOC temperature sensors or aftertreatment DPF temperature sensors active?
YES | NO
No Repair | No Repair

Go to the appropriate fault codes troubleshooting tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the turbocharger or EGR valve active?
YES | NO
No Repair | No Repair

Go to the appropriate fault codes troubleshooting tree.

Go to 1D

Guided Step 1D - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault codes related to the fuel system active?
YES | NO
No Repair | No Repair

Go to the appropriate fault codes troubleshooting tree.

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust between the turbocharger and aftertreatment system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the exhaust for leaks.

Inspect the exhaust system between the turbocharger outlet and the aftertreatment system.

Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Inspect the aftertreatment DOC.

Conditions

  • Remove the aftertreatment DOC from the vehicle. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst for the following:

  • Plugging from soot or oil contamination.
  • Cracks or damage of any cells in the catalyst
  • Soot plugging the front face of the catalyst.

Refer to Procedure 011-049 in the Associated Procedures Table.

Problems found during the inspection of the aftertreatment DOC?
YES NO

Clean or replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Continue to troublehshoot the system to determine the root cause of the problem.

 No Repair

Go to 3B

Go to 3B

Guided Step 3B - Inspect the turbocharger exhaust outlet for oil, coolant, or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Inspect the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil, coolant, or fuel being introduced into the aftertreatment system from the engine.
  • Check for signs of moisture in the turbocharger exhaust outlet.

Engine oil, coolant, or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel, coolant, or engine oil being carried from the engine into the aftertreatment system.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the exhaust for excessive black smoke.

Conditions

  • Disconnect the exhaust pipe from turbocharger outlet.
  • Operate engine.

Action

Check the exhaust smoke.

  • Use the Snap Acceleration - Aftertreatment Disconnected procedure to check for excessive black smoke.
  • Refer to Procedure 014-017 in the Associated Procedures Table.

Excessive black smoke according to the procedure?
YES NO

Troubleshoot the cause of the excessive black smoke.

  • See the appropriate engine performance troubleshooting tree.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2646 - Engine Coolant Temperature - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2646 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2646 active?
YES NO

The exhaust gas recirculation valve was closed to reduce engine coolant temperature.

No repair is necessary.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2698 - Engine Speed Calculation - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2698 the only active fault code?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault code inactive?
STEP 3. | Vehicle test. |
 | STEP 3A. Road test to determine if fault condition exists. | Does Fault Code 2698 become active during engine operation?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2698 the only active fault code?
YES NO
No Repair

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Go to 2A

Go to the appropriate fault code troubleshooting tree.

Guided Step 2 - Clear fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clear the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Repair complete.

Guided Step 3 - Vehicle test.

Guided Step 3A - Road test to determine if fault condition exists.

Conditions

  • Connect the primary speed sensor (crankshaft sensor) to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine. With the engine operating, accelerate the engine several times.

  • Use INSITE™ electronic service tool to observe fault codes.

Does Fault Code 2698 become active during engine operation?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2715 - Fuel System Shutdown Failure - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2715 active?
 | STEP 1B. Check for active fault codes. | Any fuel injector fault codes active?
 | STEP 1C. Interview customer for intermittent condition. | Was truck stalled at a recent key-off event?
 | STEP 1D. Inspect the engine/truck. | Truck or engine been modified with performance enhancing kit?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2715.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2715 active?
YES NO
No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 1B

Go to 2A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any fuel injector fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Interview customer for intermittent condition.

Conditions

  • N/A

Action

Interview customer on driving conditions.

.

Was truck stalled at recent key-off event?
YES NO

Clear fault code and return to customer.

 No Repair

Repair complete.

Go to 1D

Guided Step 1D - Inspect the engine/truck.

Conditions

  • N/A

Action

Inspect the engine/truck.

Investigate truck and engine for signs of a performance enhancement kit.

Truck or engine been modified with performance enhancing kit?
YES NO

No repair. Return to customer.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 2717 - Governor Fueling Error - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Exhaust Gas Pressure Sensor | Refer to Procedure 019-376 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for multiple active fault codes. | Multiple fault codes active?
STEP 2. | Check the coolant temperature sensor. |
 | STEP 2A. Check the coolant temperature sensor. | Coolant temperature reading abnormally low for operating conditions?
STEP 3. | Check the accelerator pedal position sensor. |
 | STEP 3A. Check the accelerator pedal position sensor. | Voltages transition shown on scan tool smooth while depressing throttle and volt swing smooth?
STEP 4. | Check the exhaust gas pressure sensor. |
 | STEP 4A. Check the exhaust gas pressure sensor. | Exhaust gas pressure sensor reading higher than the boost pressure reading?
STEP 5. | Check the intake manifold pressure sensor. |
 | STEP 5A. Check the intake manifold pressure sensor. | Boost pressure reading higher than the exhaust gas pressure sensor reading?
STEP 6. | Check the brake switch and circuit. |
 | STEP 6A. Check the brake switch. | Brake switch status changing correctly?
 | STEP 6B. Inspect the brake switch and connector pins. | Dirty or damaged pins?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?
STEP 8. | Check for engine or fuel modifications that exceed original equipment manufacturer (OEM) specifications. |
 | STEP 8A. Check for engine or fuel modifications that exceed OEM specifications. | Evidence of engine or fuel modifications present that exceed OEM specifications?
 | STEP 8B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for multiple active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM for multiple active fault codes.

  • Use INSITE™ electronic service tool to check for multiple active fault codes.

Multiple fault codes active?
YES NO

Troubleshoot the fault code(s) using the appropriate troubleshooting guide.

 No Repair

Go to appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the coolant temperature sensor.

Guided Step 2A - Check the coolant temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read Fault Code Freeze Frame Data.

  • Use INSITE™ electronic service tool to read the Freeze Frame Data.

Coolant temperature reading abnormally low for the operating conditions?
YES NO

Replace the coolant sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the accelerator pedal position sensor.

Guided Step 3A - Check the accelerator pedal position sensor.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool
  • Turn keyswitch ON.

Action

Monitor the APPS 1 and APPS 2 voltages while depressing the throttle pedal.

  • Use INSITE™ electronic service tool to monitor the voltages.

Voltages transition shown on scan tool smooth while depressing throttle and volt swing smooth?
YES NO
No Repair

A damaged accelerator pedal has been detected. Contact a Cummins® Authorized Repair Location for repair instructions.

Replace the accelerator pedal. See equipment manufacturer service information.

Go to 4A

Go to 7A

Guided Step 4 - Check the exhaust gas pressure sensor.

Guided Step 4A - Check the exhaust gas pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the Fault Code Freeze Frame Data.

  • Use INSITE™ electronic service tool to read Freeze Frame Data.

Exhaust gas pressure sensor reading higher than the boost pressure reading?
YES NO

A damaged sensor has been detected.

Replace the exhaust back pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the intake manifold pressure sensor.

Guided Step 5A - Check the intake manifold pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the Fault Code Freeze Frame Data.

  • Use INSITE™ electronic service tool to read Freeze Frame Data.

Boost pressure reading higher than the exhaust gas pressure sensor reading?
YES NO

A damaged sensor has been detected.

Replace the exhaust back pressure sensor. Refer to Procedure 019-376 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 6A

Guided Step 6 - Check the brake switch and circuit.

Guided Step 6A - Check the brake switch.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the brake switch position while cycling the brake pedal.

  • Use INSITE™ electronic service tool to switch status.

Brake switch status changing correctly?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6B

Guided Step 6B - Inspect the brake switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake swtich from the OEM harness.

Action

Inspect the OEM harness and brake switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the switch or harness connector.

  • Repair or replace the OEM harness, or replace the sensor, whichever has the damaged pins. See equipment manufacturer service information.

A damaged switch has been detected.

  • Replace the brake switch. See equipment manufacturer service information.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 8A

Guided Step 8 - Check for engine or fuel modifications that exceed OEM specifications.

Guided Step 8A - Check for engine or fuel modifications that exceed OEM specifications.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and fuel system for modifications.

  • Any Engine or Fuel modification that exceeds OEM specifications can affect the parameters that this diagnostic monitors.
  • Any device/software that modifies the values reported by any of the Cummins® actuators/sensors could fail this diagnostic.
  • Any devices that puts a high parasitic load on the engine could also cause this diagnostic to fail.

Evidence of engine or fuel modifications present that exceed OEM specifications?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Return vehicle to customer.

Go to 8B

Guided Step 8B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 2718 - Brake Switch and Accelerator Pedal Position Incompatible - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Anti-Lock Brake System (ABS) and/or Electronic Shift Control (ESC) warning lamp(s) on or throttle fault codes active?
STEP 2. | Interview the customer. |
 | STEP 2A. Interview the customer. | Customer a two-footed driver?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

ABS and/or ESC warning lamp(s) on or throttle fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Interview the customer.

Guided Step 2A - Interview the customer.

Conditions

  • This fault code can become active if the customer is a two-footed driver (Customer rests a foot on the brake pedal while using the accelerator pedal).

Action

Diagnostics run when the following occurs:

  • Engine is running.
  • Throttle position is maintained above 8 percent with less than 2 percent deviation for 2 seconds.
  • If the brake pedal is depressed during the monitoring conditions above, the fault code will set.

Customer a two-footed driver?
YES NO

Explain the diagnostic operation to the customer.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair complete.

Repair complete.

Last Modified: 01-Jul-2015


FAULT CODE 2636 - Aftertreatment 1 Outlet NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2771 active or more than one inactive count?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2636 or 3597 active or more than one inactive count?
 | STEP 1D. Check the fault codes. | Fault Code 3219, 3232, 3868, 3911, 4151, 4152, or 4572 active or more than one inactive count?
STEP 2. | Check the aftertreatment outlet nitrogen oxides (NOx) sensor and circuit. |
 | STEP 2A. Inspect the aftertreatment outlet NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage greater than 10.8-VDC?
 | STEP 2C. Check the voltage to the aftertreatment outlet NOx sensor. | Voltage greater than 10.8-VDC?
STEP 3. | Check the aftertreatment outlet NOx sensor and circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
STEP 4. | Check the power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 and 132 ohms?
STEP 6. | Check the J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5-VDC?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.4 and 4.5-VDC?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to the block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 7A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 3597 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1D

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3219, 3232, 3868, 3911, 4151, 4152, or 4572 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment outlet NOx sensor and circuit.

Guided Step 2A - Inspect the aftertreatment outlet NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.

Action

Inspect the interface harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit and the aftertreatment outlet NOx sensor battery voltage return circuit at the aftertreatment outlet NOx sensor wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8-VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment NOx outlet sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment outlet NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet NOx sensor.

  • Measure the voltage between the aftertreatment outlet NOx sensor battery voltage supply circuit at the aftertreatment outlet NOx sensor wiring harness connector and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8-VDC?
YES NO

An open or high resistance circuit has been detected in the aftertreatment outlet NOx sensor battery voltage return circuit.

  • Troubleshoot the OEM harness, and all interconnects for the malfunction.
  • Repair or replace the damaged component as necessary.

An open or high resistance circuit has been detected in the aftertreatment outlet NOx sensor battery voltage supply circuit.

  • Troubleshoot the OEM harness, and all interconnects for the malfunction.
  • Repair or replace the damaged component as necessary.

Go to 7A

Go to 7A

Guided Step 3 - Check the aftertreatment outlet NOx sensor and circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect INLINE adapter from the 3-pin service data link connector.
  • Disconnect the aftertreatment outlet NOx sensor.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the aftertreatment outlet NOx sensor wiring harness connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES NO

A malfunction has been detected in the aftertreatment outlet NOx sensor.

  • Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 data link.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect INLINE adapter from the 3-pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect INLINE adapter from the 3-pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 108 and 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link. Refer to the aftertreatment harness isolation check section of Procedure 019-417 (Data Link Circuit, Proprietary). Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link. Refer to the engine harness isolation check section of Procedure 019-417 (Data Link Circuit, Proprietary).Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3-pin service data link connector and battery ground.Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5-VDC?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

Refer to the data link short circuit isolation section of Procedure 019-417 (Data Link Circuit, Proprietary). Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component. See equipment manufacturer service information.

Go to 6B

Go to 7A

Guided Step 6B - Check the J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit.

  • Measure the voltage between the SAE J1939 (-) pin at the 3-pin service data link connector and battery ground.Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5-VDC?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

Refer to the data link short circuit isolation section of Procedure 019-417 (Data Link Circuit, Proprietary). Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component. See equipment manufacturer service information.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 2961 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
EGR Cooler | Refer to Procedure 011-019 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2961?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature. |
 | STEP 2A. Check the EGR temperature sensor accuracy. | EGR temperature within 10°C [18°F] of ambient air temperature?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2961?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR temperature.

Guided Step 2A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10°C [18°F] of ambient air temperature?
YES NO
No Repair

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and fill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Refer to Procedure 008-018 in the Associated Procedures Table.
  • Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube. Refer to Procedure 010-080 in the Associated Procedures Table.

Clean the EGR cooler. Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. THe ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 2962 - Exhaust Gas Recirculation Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3230 V104 | 4367291
EGR Cooler | Refer to Procedure 011-019 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 2962?
STEP 2. | Check the exhaust gas recirculation (EGR) temperature. |
 | STEP 2A. Check the EGR temperature sensor accuracy. | EGR temperature within 10°C [18°F] of ambient air temperature?
STEP 3. | Check the cooling system. |
 | STEP 3A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 3B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 4. | Check the EGR system. |
 | STEP 4A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure port?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 2962?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR temperature.

Guided Step 2A - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10°C [18°F] of ambient air temperature?
YES NO
No Repair

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor. Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the cooling system.

Guided Step 3A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and fill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3B

Go to 5A

Guided Step 3B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

  • Refer to Procedure 008-018 in the Associated Procedures Table.
  • Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant, if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the EGR system.

Guided Step 4A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor. Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the debris or replace the EGR differential pressure tube. Refer to Procedure 010-080 in the Associated Procedures Table.

Clean the EGR cooler. Refer to Procedure 011-019 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. THe ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 3135 - Aftertreatment Diesel Particulate Filter Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3133 and 3134. | Fault Code 3133 or 3134 active?
STEP 2. | Check the aftertreatment system. |
 | STEP 2A. Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked?
 | STEP 2B. Monitor the aftertreatment DPF outlet pressure sensor with an electronic service tool. | Aftertreatment DPF outlet pressure sensor reading 0 ± 1.5 kPa [0 ± 0.44 in Hg] with key ON and engine OFF?
STEP 3. | Check the aftertreatment DPF outlet pressure sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DPF outlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3134 active?
 | STEP 3C. Check the circuit response. | Fault Code 3133 active?
STEP 4. | Check the engine control module (ECM) and the original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 3135 inactive?
STEP 5. | Check exhaust system restriction. |
 | STEP 5A. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
 | STEP 5B. Check exhaust system restriction. | Exhaust restriction within specifications in 018-020?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3133 and 3134.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 or 3134 active?
YES | NO
No Repair | No Repair

Fault Code 3133 or 3134 troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment system.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Engine OFF
  • Disconnect the aftertreatment DPF differential pressure sensor tubes.

Action

Check for plugged aftertreatment DPF differential pressure sensor tubes.

  • Inspect the tubes for blockage.
  • Refer to Procedure 011-047 in the Associated Procedures Table.

Are the aftertreatment DPF differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Monitor the aftertreatment DPF outlet pressure sensor with an electronic service tool.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Engine not running.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment DPF outlet pressure sensor with an electronic service tool.

An exhaust ventilation system connected to the exhaust can cause the outlet pressure sensor to read incorrectly. Be sure to remove any ventilation or vacuum equipment from the exhaust before reading the outlet pressure sensor value with INSITE™ electronic service tool.

Is the aftertreatment DPF outlet pressure sensor reading 0 ± 1.5 kPa [0 ± 0.44 in Hg] with key ON and engine OFF?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the aftertreatment DPF outlet pressure sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DPF outlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF outlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 will also be active.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM harness
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF outlet pressure 5 volt SUPPLY pin and the aftertreatment DPF outlet pressure SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the OEM harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 will also be active.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF outlet pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3135 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5 - Check exhaust system restriction.

Guided Step 5A - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Engine not running.

Action

Inspect the decomposition tube for deposits.

  • Remove the aftertreatment decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits. Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the SCR decomposition assembly. Refer to Procedure 011-098 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO

Replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443 in the Associated Procedures Table.

Continue to investigate the cause of the high exhaust restriction.

Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3151 - Aftertreatment 1 SCR Catalyst System Missing - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Decomposition Tube and Aftertreatment SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3151 active?
 | STEP 1B. Check for active aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault Codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
 | STEP 1C. Check for active aftertreatment selective catalyst reduction (SCR) temperature sensor fault codes. | Fault codes related to the aftertreatment SCR temperature sensors active?
 | STEP 1D. Check for active aftertreatment SCR temperature sensor fault codes. | Fault Code 3543 active?
 | STEP 1E. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | DEF dosing system related fault codes active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Inspect the DEF dosing system for external leaks | External leaks detected in the system?
 | STEP 2C. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2D. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment SCR Performance Test. | Did the Aftertreatment SCR Performance Test complete?
 | STEP 3B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check the aftertreatment SCR performance test results. |
 | STEP 4A. Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test. | Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
 | STEP 4B. Check the status of the Aftertreatment SCR Catalyst Test. | Aftertreatment SCR Catalyst Test pass?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3151 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active aftertreatment SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment SCR temperature sensors active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system and DEF quality sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF dosing system related fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the DEF dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment DEF dosing system for signs of external leaks, including:

  • DEF dosing unit and dosing unit connectors.
  • DEF lines.
  • DEF dosing valve.

DEF will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Perform the Aftertreatment SCR Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON and start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test.

Aftertreatment SCR Performance Test complete?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-098 in the Associated Procedures Table.

Repeat the Aftertreatment SCR Performance Test.

Go to 4A

Go to 4A

Guided Step 4 - Check the Aftertreatment SCR Performance Test results.

Guided Step 4A - Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
YES NO
No Repair

An in-range malfunction has been detected in the aftertreatment outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor. Refer to procedure 019-451 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the status of the Aftertreatment SCR Catalyst Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Test pass?
YES NO
No Repair

A malfunctioning aftertreatment SCR catalyst has been detected.

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-098 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3165 - Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4152, 4159, 4164, 4165, 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) quality. |
 | STEP 2A. Check the DEF quality fault codes. | DEF quality fault codes?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell wall. | Cracks found in the cell walls?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4152, 4159, 4164, 4165, 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF quality .

Guided Step 2A - Check the DEF quality fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF quality fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell wall.

Conditions

  • Aftertreatment DOC removed.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3168 - Aftertreatment 1 Diesel Particulate Filter System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 1879, 1881, or 1883 active?
STEP 2. | Inspect the aftertreatment diesel particulate filter (DPF) differential pressure sensor and tubes. |
 | STEP 2A. Verify the aftertreatment DPF differential pressure sensor accuracy. | Aftertreatment DPF differential pressure sensor reading 0 ± 1.5 kPa [0 ± 0.44 in Hg] with keyswitch ON and the engine OFF?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes installed correctly?
STEP 3. | Check the presence of the aftertreatment DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or damage to the aftertreatment DPF?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1879, 1881, or 1883 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Inspect the aftertreatment DPF differential pressure sensor and tubes.

Guided Step 2A - Verify the aftertreatment DPF differential pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the sensor accuracy.

  • Monitor the aftertreatment DPF differential pressure sensor reading with INSITE™ electronic service tool.

Aftertreatment DPF differential pressure sensor reading 0 ± 1.5 kPa [0 ± 0.44 in Hg] with keyswitch ON and the engine OFF?
YES NO
No Repair

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • If no short circuit is found, replace the aftertreatment DPF differential pressure sensor. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes for the following:

  • Leaks or cracks in the differential pressure sensor tubes
  • Loose fittings on the differential pressure sensor tubes
  • Missing or broken differential pressure sensor tubes
  • Plugged tubes
  • Make sure the differential pressure tubes are installed correctly. It is possible the differential pressure tubes are connected backward at the rubber tubes at the sensor connection. Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes installed correctly?
YES NO
No Repair

Repair or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

  • Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with, has been removed from the exhaust system, or has been damaged.

Refer to Procedure 011-041 in the Associated Procedures Table.

Tampering or damage to the aftertreatment DPF?
YES NO

Install the correct aftertreatment system for the vehicle. Refer to Procedure 011-041 in the Associated Procedures Table.

Continue inspecting the aftertreatment systems for signs of tampering.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3235 - Aftertreatment 1 SCR Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Selective Catalytic Reduction (SCR) Performance Test | Refer to Procedure 014-015 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) quality. |
 | STEP 2A. CHeck the DEF quality fault codes. | DEF quality fault codes?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF quality.

Guided Step 2A - Check the DEF quality fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF quality fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine. Operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.
  • Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-015 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment DOC.

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3237 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3237 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater 1. | Between 2 and 26 ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3237 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the DEF dosing unit harness.

Action

Inspect the aftertreatment DEF line heater 1 and DEF dosing unit harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF line heater 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the DEF dosing unit harness.

Action

Check the resistance of the aftertreatment DEF line heater 1.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 26 ohms?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

The line heater 1 resistance is out of specification.

  • Replace the aftertreatment DEF line heater 1. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3238 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3238 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater 1. | Between 2 and 100 ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the DEF dosing unit harness.

Action

Inspect the aftertreatment DEF line heater 1 and DEF dosing unit harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the line heater 1 or harness connector.

  • Clean the connector and pins
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF line heater 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the DEF dosing unit harness.

Action

Check the resistance of the aftertreatment DEF line heater 1.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 100 ohms?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

The line heater 1 resistance is out of specification.

  • Replace the aftertreatment DEF line heater 1. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3242 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CMCM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part No. 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead: Part No. 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 197, 1677, 1678, 1679, 1683, 1684, 2448, 4682, 4736, or 4737 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heating system. |
 | STEP 2A. Inspect the DEF tank heater coolant lines. | Leaks or damage found in tank heater coolant plumbing?
 | STEP 2B. Check the engine coolant level. | Coolant level ok?
STEP 3. | Check the aftertreatment DEF tank heater operation. |
 | STEP 3A. Verify proper operation of the aftertreatment DEF tank heater control valve. | DEF tank heater control valve operating correctly?
 | STEP 3B. Verify the aftertreatment DEF tank temperature. | DEF tank temperature rising?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 197, 1677, 1678, 1679, 1683, 1684, 2448, 4682, 4736, or 4737 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heating system

Guided Step 2A - Inspect the DEF tank heater coolant lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF tank heater coolant lines and connectors for the following:

  • Leaking or damaged coolant lines
  • Kinked, restricted, or blocked coolant lines (including the original equipment manufacturer (OEM) in-line shutoff valve, if equipped)
  • Loose connections
  • Leaking seals or gaskets.

See equipment manufacturer service information for details on coolant line routing and flow.

Leaks or damage found in tank heater coolant plumbing?
YES NO

Repair or replace the leaking or damaged coolant lines, fittings, or seals.

Verify that the engine coolant level is within normal operating range before returning to service. Add coolant as necessary.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF

Action

Check engine coolant level.

  • Make sure that coolant level is within normal operating levels.

Coolant level ok?
YES NO
No Repair

Fill the coolant. Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF tank heater operation.

Guided Step 3A - Verify proper operation of the aftertreatment DEF tank heater control valve.

Conditions

  • Turn keyswitch ON.
  • Start engine and allow coolant to achieve operating temperature.
  • Connect INSITE™ electronic service tool.

Action

Verify the proper operation of the aftertreatment diesel exhaust fluid tank heater control valve.

  • Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.
  • Use the Diesel Exhaust Fluid Tank Heater 2 Relay option in the test menu to override the tank heater control valve to ON.
  • Make sure the tank heater control valve is operating correctly, not stuck closed or slow to respond, and able to fully open.
  • Make sure the tank heater control valve is installed correctly, and not reversed.

See equipment manufacturer service information for details on the tank heater control valve.

  • NOTE: The Diesel Exhaust Fluid Doser System Heater Test allows the technician to override the tank heater control valve to on. It does not test if the tank heater control valve is operating correctly. With the tank heater control valve commanded on, a temperature rise may be felt on the coolant hose to the diesel exhaust fluid tank.

DEF tank heater control valve operating correctly?
YES NO
No Repair

Repair or replace the diesel exhaust fluid tank heater control valve.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Verify the aftertreatment DEF tank temperature.

Conditions

  • Turn keyswitch ON.
  • Start engine and allow coolant to achieve operating temperature.
  • Connect INSITE™ electronic service tool.

Action

Verify the aftertreatment diesel exhaust fluid tank temperature is changing with conditions.

  • Use INSITE™ electronic service tool to perform the “Diesel Exhaust Fluid Doser System Heater Test” under the “ECM Diagnostic Tests” menu.
  • Use the Diesel Exhaust Fluid Tank Heater 2 Relay option in the test menu to override the tank heater control valve to ON.
  • Use INSITE™ electronic service tool to monitor “Aftertreatment Diesel Exhaust Fluid Tank Temperature” under “Data Logger/Monitor”.
  • Make sure tank temperature is rising.

NOTE: Do not allow the DEF tank temperature to exceed 65°C [150°F].

DEF tank temperature rising?
YES NO
No Repair

A damaged aftertreatment DEF tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor.

See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3243 - Engine Cooling System Monitor - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Thermostat | Refer to Procedure 008-013 | ISV5.0 CM3250 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3250 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 144, 145, or 334 active?
STEP 2. | Check engine fan operation. |
 | STEP 2A. Verify proper operation of the engine cooling fan. | Engine fan operating correctly?
STEP 3. | Check the thermostat. |
 | STEP 3A. Verify proper thermostat operation. | Engine thermostat operating correctly and not leaking or stuck open?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144, 145, or 334 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check engine fan operation.

Guided Step 2A - Verify proper operation of the engine cooling fan.

Conditions

  • Turn keyswitch OFF
  • Connect INSITE™ electronic service tool
  • Start the engine and run at low idle.

Action

Check engine cooling fan operation.

  • Use INSITE™ electronic service tool to perform the Fan Override Test.
  • Verify that the fan operates correctly, is not stuck on, and turns ON and OFF as commanded.

Engine fan operating correctly?
YES NO
No Repair

Troubleshoot and repair the cause of the malfunctioning engine fan operation.

Inspect engine fan wiring and original equipment manufacturer (OEM) harness for short or open circuits. Check engine fan switches for proper operation.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the thermostat.

Guided Step 3A - Verify proper thermostat operation.

Conditions

  • Turn keyswitch OFF.

Action

Check for a leaking or stuck open thermostat.

  • Make sure that the thermostat is not stuck open or leaking, and that it opens at the correct coolant temperature. Refer to Procedure 008-013 in the Associated Procedures Table.

Engine thermostat operating correctly and not leaking or stuck open?

YES NO

A malfunctioning coolant temperature sensor has been detected.

Replace the coolant temperature sensor. Refer to Procedure 019-019 in Associated Procedures Table.

Replace the malfunctioning thermostat. Refer to Procedure 008-013 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Jan-2015


FAULT CODE 3251 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the Appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Cylinder Cutout Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3253 - Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to run the Cylinder Cutout Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. Refer to the OEM service manual.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls.
  • Refer to Procedure 011-049 in the Associated Procedures Table.

Cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3254 - Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 4A. Check the aftertreatment DOC for soot accumulation. | More than fifty percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and operate at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is operating at low idle.

  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage.

  • Refer to Procedure 014-016 in the Associated Procedures Table.

 No Repair

Appropriate troubleshooting tree

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage.

  • Refer to Procedure 014-016 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the aftertreatment DOC.

Guided Step 4A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than fifty percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Remove aftertreatment DOC.

Action

Inspect the aftertreatment DOC

  • Check for cracks in the aftertreatment DOC cell walls.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment DOC.

  • Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3255 - Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 4A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls. | Are any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Cutout Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 4A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls.

Conditions

  • Remove aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3256 - Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 4A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls. | Are any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Cutout Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 4A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls.

Conditions

  • Remove aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3258 - Aftertreatment 1 Diesel Exhaust Fluid Line Heater 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Codes 3258 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3237 or 3238 active?
STEP 2. | Check the aftertreatment DEF heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment DEF line heater. | 27 ohms or greater?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3258 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 3237 or 3238 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Inspect the aftertreatment DEF line heater 1 and OEM connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment DEF line heater.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance of the aftertreatment DEF line heater between the SUPPLY and RETURN pins.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

27 ohms or greater?
YES NO

An open circuit has been detected in the aftertreatment DEF line heater 1,

Replace the aftertreatment DEF line heater 1.

See equipment manufacturer service information.

A malfunctioning DEF dosing unit assembly has been detected.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3311 - Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 4A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls. | Are any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Cutout Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 4A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls.

Conditions

  • Remove aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3312 - Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
STEP 2. | Check the fuel system. |
 | STEP 2A. Check for an injector misfire. | Engine misfire detected?
STEP 3. | Check the turbocharger outlet. |
 | STEP 3A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 4. | Inspect the aftertreatment diesel oxidation catalyst. |
 | STEP 4A. Check the aftertreatment diesel oxidation catalyst for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 4B. Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls. | Are any cracks found in the cell walls?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4151, 4158, 4161, 4162, 4259 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the fuel system.

Guided Step 2A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool to monitor the Cylinder Cutout Test results.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire. Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector.

Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the turbocharger outlet.

Guided Step 3A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet. See equipment manufacturer service information.

Action

Look for signs of moisture in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Repair or replace any components that caused the engine oil or diesel fuel contamination.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Inspect the aftertreatment diesel oxidation catalyst.

Guided Step 4A - Check the aftertreatment diesel oxidation catalyst for soot accumulation.

Conditions

  • Remove the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment diesel oxidation catalyst for soot accumulation and/or face plugging. Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 4B

Go to 4B

Guided Step 4B - Inspect the aftertreatment diesel oxidation catalyst for cracks in the cell walls.

Conditions

  • Remove aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

Action

Inspect the aftertreatment diesel oxidation catalyst

  • Check for cracks in the aftertreatment diesel oxidation catalyst cell walls. Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3313 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3314 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3315 - Aftertreatment 1 Diesel Oxidation Catalyst Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3316 - Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3317 - Aftertreatment 1 Diesel Particulate Filter Intake Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3318 - Aftertreatment 1 Diesel Particulate Filter Intake Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes

Conditions

  • Connect all components.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter (DPF) temperature sensor module has been detected.

Replace the aftertreatment DPF temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3319 - Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes

Conditions

  • Connect all components.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter (DPF) temperature sensor module has been detected.

Replace the aftertreatment DPF temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3321 - Aftertreatment 1 Diesel Particulate Filter Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter (DPF) temperature sensor module has been detected.

Replace the aftertreatment DPF temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3322 - Aftertreatment 1 Diesel Particulate Filter Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging an engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4151, 4161, 4162, 4163, or 4259?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected. Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Go to appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3337 - Engine Idle Fuel Quantity - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3250 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3337 active?
 | STEP 1B. Check for active fault codes. | Fault Code 131, 132, 241, 242, 1239, 1241, 1242 active?
 | STEP 1C. Read the fault codes. | Injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1D. Check for air handling fault codes. | Turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1E. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1F. Read the fault codes. | Misfire fault codes active or have accumulated inactive counts?
STEP 2. | Perform injector diagnostic tests. |
 | STEP 2A. Perform the high-pressure fuel injector drain flow test. | Injectors meet specification. Refer to Procedure 005-236 in the Associated Procedures Table.
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3337 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active throttle and vehicle speed fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131, 132, 241, 242, 1239, 1241, 1242 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts.
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1D

Guided Step 1D - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes related to the air handling system.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1E

Guided Step 1E - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1F

Guided Step 1F - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Misfire fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Perform Injector diagnostic tests.

Guided Step 2A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector drain Flow Test on the both injector banks.

  • Reference the High-Pressure Fuel Injector Drain Flow Test. Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specification. Refer to Procedure 005-236 in the Associated Procedures Table.
YES NO

Use the following troubleshooting symptom tree, Engine Runs Rough or Misfire in Section TS, in the appropriate service manual.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3338 - Engine Idle Fuel Quantity - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3250 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3338 active?
 | STEP 1B. Check for active fault codes. | Fault Code 131, 132, 241, 242, 1239, 1241, 1242 active?
 | STEP 1C. Read the fault codes. | Injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1D. Check for air handling fault codes. | Turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1E. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1F. Read the fault codes. | Misfire fault codes active or have accumulated inactive counts?
STEP 2. | Perform injector diagnostic tests. |
 | STEP 2A. Perform the high-pressure fuel injector drain flow test. | Injectors meet specification. Refer to Procedure 005-236 in the Associated Procedures Table.
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3338 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active throttle and vehicle speed fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 131, 132, 241, 242, 1239, 1241, 1242 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts.
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1D

Guided Step 1D - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes related to the air handling system.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1E

Guided Step 1E - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1F

Guided Step 1F - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Misfire fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Perform Injector diagnostic tests.

Guided Step 2A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector drain Flow Test on the both injector banks.

  • Reference the High-Pressure Fuel Injector Drain Flow Test. Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specification. Refer to Procedure 005-236 in the Associated Procedures Table.
YES NO

Use the following troubleshooting symptom tree, Engine Runs Rough or Misfire in Section TS, in the appropriate service manual.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3342 - Engine Exhaust Gas Recirculation Cooler Efficiency - Data Valid But Normal Operating Range - Moderately Severe Range

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3250 V104 | 4367291
EGR Cooler | Refer to Procedure 011-019 | ISV5.0 CM3250 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3250 V104 | 4367291
EGR Temperature Sensor | Refer to Procedure 019-378 | ISV5.0 CM3250 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male Weather-Pack™ test lead, Part Number 3823996 - female Weather-Pack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active fault codes present other than Fault Code 3342?
STEP 2. | Check the cooling system. |
 | STEP 2A. Check the engine coolant mixture. | Engine coolant is proper mixture?
 | STEP 2B. Check the engine coolant level. | Engine coolant level at proper level?
STEP 3. | Check the exhaust gas recirculation (EGR) system. |
 | STEP 3A. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure sensor ports?
 | STEP 3B. Check the EGR temperature sensor accuracy. | EGR temperature within 10° C [18° F] of ambient air temperature?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active fault codes present other than Fault Code 3342?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the cooling system.

Guided Step 2A - Check the engine coolant mixture.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine coolant mixture.

Incorrect coolant mixture will cause high EGR temperatures due to inefficient cooling.

Check the freeze point of the engine coolant to be sure of a proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Engine coolant is proper mixture?
YES NO
No Repair

Drain the coolant and refill the cooling system with the proper mixture.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the engine coolant level.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper engine coolant level.

Refer to Procedure 008-018 in the Associated Procedures Table.

NOTE: Low engine coolant level can cause erratic coolant flow through the engine and EGR cooler, in turn, causing the EGR temperatures to rise.

Engine coolant level at proper level?
YES NO
No Repair

Replenish the cooling system and troubleshoot for loss of coolant if necessary.

  • Refer to Procedure 008-018 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the EGR system.

Guided Step 3A - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR differential pressure sensor.
  • Refer to Procedure 019-370 in the Associated Procedures Table.

Action

Inspect the EGR differential pressure sensor ports and cross drillings for restrictions, soot plugging, and debris plugging.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure sensor ports?
YES NO

Clear the debris. Refer to Procedure 019-370 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 3B - Check the EGR temperature sensor accuracy.

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR temperature sensor from the EGR plumbing.
  • Connect INSITE electronic service tool.
  • Turn keyswitch ON.

Action

Check the EGR temperature sensor accuracy.

  • Use INSITE™ electronic service tool to monitor the EGR temperature sensor reading.
  • Compare the EGR temperature sensor reading to ambient air temperature.

NOTE: Allow the EGR temperature sensor enough time to cool down to ambient temperature before comparing the reading.

EGR temperature within 10° C [18° F] of ambient air temperature?
YES NO

Inspect the EGR cooler for fouling.

Clean or replace the EGR cooler.

Refer to Procedure 011-019 in the Associated Procedures Table.

A malfunctioning EGR temperature sensor has been detected.

Replace the EGR temperature sensor.

Refer to Procedure 019-378 in the Associated Procedures Table.

Go to 6A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Dataplate in Featrues & Parameters

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3343 - Engine Charge Air Cooler Efficiency - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Verify charge-air cooler temperature sensor condition |
 | STEP 1A. Check for active fault codes. | Fault Codes 153, 154, or 436 active?
 | STEP 1B. Monitor the intake manifold air temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Verify charger-air cooler temperature sensor condition.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 2571, 2572, or 3478 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Monitor the charge-air cooler air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the charge-air cooler temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Refer to the Intake Manifold Air Temperature Above Specification symptom tree in the appropriate service manual.

Replace the charge-air cooler air temperature sensor.

  • Refer to Procedure 019-466 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3375 - Aftertreatment Diesel Particulate Filter Regeneration too Frequent - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3250 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3250 V104 | 4367291
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3250 V104 | 4367291
Fuel Rail Supply Line (High Pressure) | Refer to Procedure 006-071 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3376 active or inactive?
 | STEP 1B. Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes. | Fault Code 1879, 1881, 1883, 3133, 3134, or 3135 acitve or inactive?
 | STEP 1C. Check for active or inactive fuel system related fault codes. | Fault Code 322, 323, 324, 325, 331, 331, 332, 351, 559, 1139, 1141, 1142, 1143, 1144, 1145, 1654, 1655, 1656, 1657, 1658, 1659, 1718, 2311, 2372, 3727, 3741, 4726, or 4727 active or inactive?
 | STEP 1D. Check for active or inactive air handling system related fault codes. | Fault Code 125, 2973, 4612, or 4616 active or inactive?
 | STEP 1E. Check for exhaust gas recirculation (EGR) or turbocharger system related fault codes. | Fault codes related to EGR or turbocharger systems active or inactive?
 | STEP 1F. Check for aftertreatment system related fault codes. | Fault Code 1691, 2638, 3168, 3315, 3318, 3322, or 3396 active or inactive?
 | STEP 1G. Check for aftertreatment diesel particulate filter related fault codes. | Fault Code 1921, 1922, 1981, or 2639 active or inactive?
 | STEP 1H. Check for debris in the fuel tank. | Debris found in the tank?
STEP 2. | Check the aftertreatment DPF differential pressure sensor. |
 | STEP 2A. Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool. | Aftertreatment DPF differential pressure sensor signal voltage reading 0.69 VDC (+/- 0.1 VDC at 25°C [77°F] or below or 0.69 VDC +/- 0.06 VDC at 26°C [78°F] or greater) at key ON, engine OFF, and does not fluctuate while moving the associated wiring harness and connector?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
 | STEP 2C. Check the aftertreatment DPF differential pressure sensor circuit response. | Fault Codes 1881 and 3134 become active?
 | STEP 2D. Check the aftertreatment DPF differential pressure sensor wiring. | Fault Codes 1879 and 3134 become active?
STEP 3. | Check the high-pressure fuel system. |
 | STEP 3A. Chec for leaks in the high-pressure system. | Leak detected?
 | STEP 3B. Check the fuel pump actuator and the pressure relief valve. | Actuators within the specifications. Refer to Procedure 005-236 in the Associated Procedures Table.
 | STEP 3C. Check the injector return flow. | Injector return flows meets the specifications. Refer to Procedure 005-236 in the Associated Procedures Table.
STEP 4. | Check the exhaust system. |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3376 active or inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, 1883, 3133, 3134, or 3135 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fuel system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any fuel Injector or fuel pressure relief valve fault codes active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1D

Guided Step 1D - Check for active or inactive air handling system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive air handling system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 125, 358, 2973, 4612, or 4616 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1E

Guided Step 1E - Check the EGR or turbocharger system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive EGR or VGT system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to EGR or turbocharger systems active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1F

Guided Step 1F - Check for aftertreatment system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1691, 2638, 3168, 3315, 3318, 3322, or 3396 active or inactive?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1G

Guided Step 1G - Check for aftertreatment diesel particulate filter related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1921, 1922, 1981, or 2639 active or inactive?
YES NO

Note: Possible causes for Fault Codes 1921, 1922, 1981, and 2639 can be identified using this troubleshooting tree. It is not necessary to troubleshoot these fault codes first if they are associated with Fault Code 3376.

No Repair

Go to 2A

Go to 1H

Guided Step 1H - Check for debris in the fuel tank.

Conditions

  • Turn keyswitch ON.
  • Remove the fuel tank filter cap.

Action

Check for debris in the fuel tank.

  • See equipment manufacturer service information.

Debris found in the tank?
YES NO

Remove the debris from the tank. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor.

Guided Step 2A - Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Connect the aftertreatment DPF differential pressure sensor.

Action

Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Aftertreatment DPF differential pressure sensor signal voltage reading 0.69 VDC (+/- 0.1 VDC at 25°C [77°F] or below or 0.69 VDC +/- 0.06 VDC at 26°C [78°F] or greater) at keyswitch ON, engine OFF, and does not fluctuate while moving the associated wiring harness and connector?

YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • Check for high resistance on the RETURN pin of the aftertreatment DPF differential pressure sensor harness. Refer to Procedure 019-360 in Section 19.
  • Replace the aftertreament DPF differential pressure sensor if the wiring checks are okay. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.

Action

Check the aftertreatment DPF differential pressure sensor tubes for plugging, kinks, or leakage.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
YES NO

Clean or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment DPF differential pressure sensor circuit response.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect the aftertreatment DPF differential pressure sensor wiring harness connector.

Action

Use INSITE™ electronic service tool to verify that Fault Code 1881 and 3134 are active.

Fault Codes 1881 and 3134 become active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Refer to the appropriate wiring diagram or see equipment manufacturer service information.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DPF differential pressure sensor wiring.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect the aftertreament DPF differential pressure sensor wiring harness connector.

Action

Use the Framatome™ male test lead, Part Number 3164596, or equivalent, to short the aftertreatment DPF differential pressure sensor 5-VDC SUPPLY (pin 4 of the wiring harness connector) to the aftertreatment DPF differential pressure sensor SIGNAL (pin 2 of the wiring harness connector).

Fault Codes 1879 and 3134 become active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Refer to the appropriate wiring diagram or the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Check the high-pressure fuel system.

Guided Step 3A - Check for leaks in the high-pressure system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect for fuel leaks.

  • Fuel supply line from the stage 2 fuel Filter and high-pressure fuel pump.
  • Fuel rail supply lines.
  • Injector supply lines.

Refer to Procedure 005-236 in the Associated Procedures Table.

Leak detected?
YES NO

Repair or replace the leaky component.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the Fuel pump actuator and the pressure relief valve.

Conditions

  • Turn keyswitch ON.

Action

Perform the High Fuel Pressure Actuator Test in INSITE™ electronic service tool.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Actuators within the specifications. Refer to Procedure 005-236 in the Associated Procedures Table.
YES NO
No Repair

If the fuel pump actuator is not within specifications, replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

If the pressure relief valve is not within specifications, replace the pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive fuel leakage from the injectors.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flows meets the specifications. Refer to Procedure 005-236 in the Associated Procedures Table.
YES NO
No Repair

Replace the leaky injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Repair or replace the damaged component(s).

Go to 5A

Go to 5A

Guided Step 4 - Check the exhaust system.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke by performing the Snap Acceleration - Aftertreatment Disconnected Test.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • To perform a snap acceleration test, it may be necessary to use INSITE™ electronic service tool "Setup for Dynamometer" found under the Diagnostic Tests menu to allow the engine to reach high idle.

Refer to Procedure 014-017 in the Associated Procedures Table.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of excessive black smoke.

Remove and replace the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

NOTE: If the aftertreatment DPF requried replacement for excessive ash and has not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Refer to the Ash Cleaning - Excessive troubleshooting symptom tree in Section TS, if necessary.

Go to the appropriate engine performance troubleshooting symptom tree.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Note: If the aftertreatment DPF was replaced and the ECM was not recalibrated, the Aftertreatment Maintenance Filter Installation procedure must be performed. The Aftertreatment Maintenance Filter Installation is located in INSITE™ electronic service tool in the Advanced ECM Data menu.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3376 - Aftertreatment Diesel Particulate Filter (DPF) Incomplete Regeneration - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3250 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 3376 active or inactive?
 | STEP 1B. Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes. | Fault Code 1879, 1881, 1883, 3133, 3134, or 3135 acitve or inactive?
 | STEP 1C. Check for active or inactive fuel system related fault codes. | Injector circuit or fuel system related fault codes active or inactive?
 | STEP 1D. Check for active or inactive air handling system related fault codes. | Fault Code 6238 or 5951 active
 | STEP 1E. Check for exhaust gas recirculation (EGR) or variable geometry turbocharger (VGT) system related fault codes. | Turbocharger or EGR related Fault Codes active or inactive?
 | STEP 1F. Check for aftertreatment system related fault codes. | Fault Code 1691, 2638, 3168, 3315, 3318, 3322, or 3396 active or inactive?
 | STEP 1G. Check for aftertreatment diesel particulate filter related fault codes. | Fault Code 1921, 1922, 1981, or 2639 active or inactive?
 | STEP 1H. Check for debris in the fuel tank. | Debris found in the tank?
STEP 2. | Check the aftertreatment DPF differential pressure sensor. |
 | STEP 2A. Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool. | Aftertreatment DPF differential pressure sensor signal voltage reading 0.69 VDC (+/- 0.1 VDC at 25°C [77°F] or below or 0.69 VDC +/- 0.06 VDC at 26°C [78°F] or greater) at key ON, engine OFF, and does not fluctuate while moving the associated wiring harness and connector?
 | STEP 2B. Check the aftertreatment DPF differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
 | STEP 2C. Check the aftertreatment DPF differential pressure sensor circuit response. | Fault Codes 1881 and 3134 become active?
 | STEP 2D. Check the aftertreatment DPF differential pressure sensor wiring. | Fault Codes 1879 and 3134 become active?
STEP 3. | Inspect the aftertreatment DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Aftertreatment diesel particulate filter meet reuse guidelines?
STEP 4. | Check the exhaust system. |
 | STEP 4A. Inspect the exhaust for excessive smoke. | Excessive black smoke during acceleration or constant black smoke at high idle?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3376 active or inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF differential pressure sensor related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879, 1881, 1883, 3133, 3134, or 3135 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fuel system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any fuel Injector or fuel pressure relief valve fault codes active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1D

Guided Step 1D - Check for active or inactive air handling system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive air handling system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6238 or 5951 active.
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1E

Guided Step 1E - Check the EGR or variable geometry turbocharger (VGT) system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive EGR or VGT system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Turbocharger or EGR related fault codes active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1F

Guided Step 1F - Check for aftertreatment system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment system related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1691, 3168, 3315, 3318, or 3322 active or inactive?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1G

Guided Step 1G - Check for aftertreatment diesel particulate filter related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive aftertreatment DPF related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1921, 1922, 1981, or 2639 active or inactive?
YES NO

Note: Possible causes for Fault Codes 1921, 1922, 1981, and 2639 can be identified using this troubleshooting tree. It is not necessary to troubleshoot these fault codes first if they are associated with Fault Code 3376.

No Repair

Go to 2A

Go to 1H

Guided Step 1H - Check for debris in the fuel tank.

Conditions

  • Turn keyswitch ON.
  • Remove the fuel tank filter cap.

Action

Check for debris in the fuel tank.

  • See equipment manufacturer service information.

Debris found in the tank?
YES NO

Remove the debris from the tank. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor.

Guided Step 2A - Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Connect the aftertreatment DPF differential pressure sensor.

Action

Monitor the aftertreatment DPF differential pressure sensor with INSITE™ electronic service tool.

Aftertreatment DPF differential pressure sensor signal voltage reading 0.69 VDC (+/- 0.1 VDC at 25°C [77°F] or below or 0.69 VDC +/- 0.06 VDC at 26°C [78°F] or greater) at keyswitch ON, engine OFF, and does not fluctuate while moving the associated wiring harness and connector?

YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

  • Check for a short circuit from the SIGNAL pin of the aftertreatment DPF differential pressure sensor to all other pins in the harness. Refer to Procedure 019-360 in Section 19.
  • Check for high resistance on the RETURN pin of the aftertreatment DPF differential pressure sensor harness. Refer to Procedure 019-360 in Section 19.
  • Replace the aftertreament DPF differential pressure sensor if the wiring checks are okay. Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn engine OFF.

Action

Check the aftertreatment DPF differential pressure sensor tubes for plugging, kinks, or leakage.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes blocked, kinked, or leaking?
YES NO

Clean or replace the aftertreatment DPF differential pressure sensor tubes. Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the aftertreatment DPF differential pressure sensor circuit response.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect the aftertreatment DPF differential pressure sensor wiring harness connector.

Action

Use INSITE™ electronic service tool to verify that Fault Code 1881 and 3134 are active.

Fault Codes 1881 and 3134 become active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Refer to the appropriate wiring diagram or see equipment manufacturer service information.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DPF differential pressure sensor wiring.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.
  • Connect INSITE™ electronic service tool.
  • Disconnect the aftertreament DPF differential pressure sensor wiring harness connector.

Action

Use the Framatome™ male test lead, Part Number 3164596, or equivalent, to short the aftertreatment DPF differential pressure sensor 5-VDC SUPPLY (pin 4 of the wiring harness connector) to the aftertreatment DPF differential pressure sensor SIGNAL (pin 2 of the wiring harness connector).

Fault Codes 1879 and 3134 become active?
YES NO
No Repair

An issue with the aftertreatment DPF differential pressure sensor or associated wiring has been found.

Check for proper pin-to-pin location in the harness between the ECM and the aftertreatment DPF differential pressure sensor wiring harness connector. Refer to the appropriate wiring diagram or the OEM service manual.

Go to 3A

Go to 3A

Guided Step 3 - Inspect the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

  • Inspect the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Aftertreatment diesel particulate filter meet reuse guidelines?
YES NO

Clean the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Remove the replace the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

NOTE: If the aftertreatment DPF requried replacement for excessive ash and has not reached the normal ash cleaning interval, further troubleshooting is required. Check for lubricating oil consumption, coolant consumption, or previous repairs that may have corrected an issue resulting in lubricating oil or coolant consumption. Refer to the Ash Cleaning - Excessive troubleshooting symptom tree in Section TS, if necessary.

Go to 4A

Go to 4A

Guided Step 4 - Check the exhaust system.

Guided Step 4A - Inspect the exhaust for excessive smoke.

Conditions

  • Disconnect the exhaust pipe from the aftertreatment inlet.
  • Operate the engine.

Action

Check the exhaust smoke by performing the Snap Acceleration - Aftertreatment Disconnected Test.

  • Perform two snap accelerations from low to high idle. Hold the engine at high idle for 5 seconds.
  • A small puff of black smoke upon acceleration that clears at a steady high idle speed is normal.
  • To perform a snap acceleration test, it may be necessary to use INSITE™ electronic service tool "Setup for Dynamometer" found under the Diagnostic Tests menu to allow the engine to reach high idle.

Refer to Procedure 014-017 in the Associated Procedures Table.

Excessive black smoke during acceleration or constant black smoke at high idle?
YES NO

Troubleshoot the cause of excessive black smoke.

 No Repair

Go to the appropriate engine performance troubleshooting symptom tree.

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Note: If the aftertreatment DPF was replaced and the ECM was not recalibrated, the Aftertreatment Maintenance Filter Installation procedure must be performed. The Aftertreatment Maintenance Filter Installation is located in INSITE™ electronic service tool in the Advanced ECM Data menu.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3377 - Engine Crankcase Ventilation Hose Disconnected - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather Tube | Refer to Procedure 003-018 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 555, 1843, 1844, 1942, or 1974 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the crankcase ventilation System. |
 | STEP 2A. Check the crankcase breather tube. | Crankcase breather tube connected properly and free of restrictions?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 555, 1843, 1844, 1942, or 1974 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the crankcase ventilation System.

Guided Step 2A - Check the crankcase breather tube.

Conditions

  • Turn keyswitch OFF.

Action

Check the crankcase breather tube in the crankcase ventilation system.

  • Use INSITE™ electronic service tool to read the fault codes.

Crankcase breather tube connected properly and free of restrictions?
YES NO
No Repair

Replace or Properly connect the Crankcase breather tube connected. Refer to Procedure 003-018 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 24-Jan-2017


FAULT CODE 3382 - Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3250 V104 | 4367291
EGR Cooler | Refer to Procedure 011-019 | ISV5.0 CM3250 V104 | 4357291
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3250 V104 | 4367291
Exhaust Transfer Tubes | Refer to Procedure 011-103 | ISV5.0 CM3250 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active exhaust gas recirculation (EGR) valve fault codes. | Fault Code 1228, 1896, 2272, 2351, or 2352 active?
 | STEP 1B. Check for active EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 active?
 | STEP 1C. Check for active variable geometry turbocharger (VGT) fault codes. | Fault Code 1898, 2387, or 3361 active?
 | STEP 1D. Check for active engine intake throttle fault codes. | Fault Code 5879, 5881, 177, 3539, 3541, or 3542 active?
STEP 2. | Check the EGR system for leaks or restrictions. |
 | STEP 2A. Check the EGR system for leaks. | Leaks detected?
 | STEP 2B. Check the EGR differential pressure ports for plugging. | Debris or soot found in either EGR differential pressure port?
 | STEP 2C. Check the EGR differential pressure sensor mounting surface for leaks. | Leaks detected at the EGR differential pressure sensor mounting surface?
 | STEP 2D. Check the exhaust transfer tubes for restriction. | Restriction or damage to the exhaust transfer tubes?
 | STEP 2E. Check the EGR valve for restriction. | Restriction or damage to the EGR valve?
 | STEP 2F. Check the EGR cooler for restriction. | Restriction or damage to the EGR cooler?
STEP 3. | Check the EGR differential pressure sensor and circuit. |
 | STEP 3A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2274 active?
 | STEP 3C. Check the circuit response. | Fault Code 2273 active?
STEP 4. | Check the ECM and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR valve fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1228, 1896, 2272, 2351, or 2352 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR differential pressure sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active VGT fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active VGT fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1898, 2387, or 3361 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active engine intake throttle fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active engine intake throttle fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879, 5881, 177, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR system for leaks or restrictions.

Guided Step 2A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR plumbing for leaks.

  • Leaks can be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the EGR differential pressure ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Remove the EGR differential pressure sensor.

Inspect the EGR differential pressure ports for debris or soot plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure port?
YES NO

Clear the restriction.

 No Repair

Go to 5A

Go to 2C

Guided Step 2C - Check the EGR differential pressure sensor mounting surface for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure sensor mounting surface for leaks.

  • Leaks can be easily noted by traces of soot; however, the EGR differential pressure sensor may need to be removed to inspect the o-rings between the EGR differential pressure sensor and the mounting surface.

Leaks detected at the EGR differential pressure sensor mounting surface?
YES NO

Repair or replace the leaking component.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2D

Guided Step 2D - Check the exhaust transfer tubes for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Exhaust transfer tube for restrictions, or any other damage.

  • Refer to Procedure 011-103 in the Associated Procedures Table.

Restriction or damage to the exhaust transfer tube?
YES NO

Clear the restriction or replace the exhaust transfer tubes.

 No Repair

Go to 5A

Go to 2E

Guided Step 2E - Check the EGR valve for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR valve for restrictions.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

Restriction or damage to the EGR valve?
YES NO

Clear the restriction or replace the EGR valve.

  • Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2F

Guided Step 2F - Check the EGR cooler for restriction.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR cooler for restrictions.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

Restriction or damage to the EGR cooler?
YES NO

Replace the EGR cooler.

  • Refer to Procedure 011-019 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the EGR differential pressure sensor and circuit.

Guided Step 3A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO

Clear the restriction.

 No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the EGR differential pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

A damaged sensor has been detected.

Replace the EGR differential pressure sensor.

  • Refer to Procedure 019-370 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR differential pressure 5 volt SUPPLY pin and the EGR differential pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3383 - Engine Exhaust Gas Recirculation (EGR) System - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Intake Connection | Refer to Procedure 010-080 | ISV5.0 CM3250 V104 | 4367291
EGR Valve | Refer to Procedure 011-022 | ISV5.0 CM3250 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for EGR valve fault codes. | Active or inactive counts of fault codes 1228, 1896, 2272, 2351, or 2352?
 | STEP 1B. Check for active EGR differential pressure sensor fault codes. | Fault Code 1866, 2273, or 2274 active?
 | STEP 1C. Check for VGT fault codes. | Fault Codes 1898, 2387, or 3361 active?
 | STEP 1D. Check for active engine intake throttle fault codes. | Fault Code 5879, 5881, 177, 3539, 3541, or 3542 active?
 | STEP 1E. Check for Fault Code 125? | Active or inactive counts of fault code 125?
STEP 2. | Check the EGR differential pressure sensor and mounting surfaces for leaks or debris plugging. |
 | STEP 2A. Check the EGR differential pressure ports for leaks. | Leaks detected?
 | STEP 2B. Check the EGR differential pressure sensor ports for plugging. | Debris or soot found in either EGR differential pressure sensor ports?
STEP 3. | Check the EGR valve. |
 | STEP 3A. Inspect the EGR valve | Damaged or stuck open EGR valve?
STEP 4. | Check the EGR differential pressure sensor and circuit. |
 | STEP 4A. Inspect the EGR differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 2274 active?
 | STEP 4C. Check the circuit response. | Fault Code 2273 active?
STEP 5. | Check the engine control module (ECM) and engine harness. |
 | STEP 5A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check the circuit response. | Fault Code 2274 active?
 | STEP 5C. Check the circuit response. | Fault Code 2273 active?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for EGR valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active turbocharger fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of fault codes 1228, 1896, 2272, 2351, or 2352?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active EGR differential pressure sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active EGR differential pressure sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1866, 2273, or 2274 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for VGT fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1898, 2387, or 3361 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active engine intake throttle fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active engine intake throttle fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879, 5881, 177, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1E

Guided Step 1E - Check for Fault Code 125.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active boost fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of fault code 125?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the EGR differential pressure sensor and mounting surfaces for leaks or debris plugging.

Guided Step 2A - Check the EGR differential pressure ports for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR differential pressure sensor and mounting surfaces for leaks.

  • Check the EGR differential pressure sensor for leaks. The sensor may need to be removed to inspect the o-ring.
  • Refer to Procedure 010-080 in the Associated Procedures Table.
  • Leaks can be easily noted by traces of soot.

Leaks detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the EGR differential pressure sensor ports for plugging.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the EGR differential pressure sensor ports for plugging.

  • Refer to Procedure 010-080 in the Associated Procedures Table.

Debris or soot found in either EGR differential pressure sensor port?
YES NO

Clear the debris.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the EGR valve.

Guided Step 3A - Inspect the EGR valve

Conditions

  • Turn keyswitch OFF.
  • Remove the EGR valve from the engine.

Action

Inspect the EGR valve.

  • Check for a stuck open EGR valve
  • Check for a damaged EGR valve that allows flow when closed.
  • Refer to Procedure 011-022 in the Associated Procedures Table.

Damaged or stuck open EGR valve?
YES NO

Replace the EGR valve.

Refer to Procedure 011-022 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the EGR differential pressure sensor and circuit.

Guided Step 4A - Inspect the EGR differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.

Action

Inspect the engine harness and EGR differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the EGR differential pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve differential pressure sensor SUPPLY pin and the EGR valve differential pressure sensor SIGNAL pin at the EGR valve differential pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

  • Fault Code 2273 active?
YES NO

A malfunctioning EGR differential pressure sensor has been detected.

Replace the EGR differential pressure sensor.

Refer to Procedure 019-370 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the ECM and engine harness.

Guided Step 5A - Inspect the ECM and engine harness connector pins.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2274 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5C

Go to 6A

Guided Step 5C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the EGR valve differential pressure sensor SUPPLY pin and the EGR valve differential pressure sensor SIGNAL pin at the ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2273 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clean fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Troubleshoot any remaining active fault codes.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3396 - Diesel Particulate Filter 1 Conditions Not Met for Active Regeneration - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter (DPF) Regeneration Test | Refer to Procedure 014-016 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3396 active?
STEP 2. | Perform the stationary regeneration procedure. |
 | STEP 2A. Perform the stationary regeneration procedure. | Fault Code 3396 active or the stationary regeneration did not complete?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3396 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform the stationary regeneration procedure.

Guided Step 2A - Perform the stationary regeneration procedure.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Start the engine and allow it to idle.

Action

Perform the aftertreatment stationary regeneration procedure.

  • Use the following procedure for stationary regeneration information. Refer to Procedure 014-016 in the Associated Procedures Table.
  • Use INSITE™ electronic service tool to perform the aftertreatment diesel particulate filter regeneration test found in the ECM diagnostic tests.

If active fault codes occur during the regeneration test, abort the test and troubleshoot the active fault codes.

Fault Code 3396 active or the stationary regeneration did not complete?

YES | NO
No Repair | No Repair

Reference the Stationary Regeneration - Will Not Complete troubleshooting symptom tree in Section TS.

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3478 - Engine Charge Air Cooler Outlet Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5. CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3478 active?
 | STEP 1B. Check for Fault Codes 2571 and 2572. | Fault Code 2571 or 2572 active?
STEP 2. | Check the engine charge-air cooler outlet pressure/temperature sensor and circuit. |
 | STEP 2A. Verify the sensor condition. | Charge-air cooler temperature and ambient air temperature reading within 5.6°C or10°F of each other?
 | STEP 2A-1. Inspect the engine engine charge-air cooler outlet pressure/temperature sensor and connector pins. |
 | STEP 2B. Check the circuit response. | Fault Code 2571 active?
 | STEP 2C. Check the circuit response. | Fault Code 2572 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 2571 is active?
 | STEP 3C. Check the circuit response. | Fault Code 2572 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3478 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 2571 and 2572.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 or 2572 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine charge-air cooler outlet pressure/temperature sensor and circuit.

Guided Step 2A - Verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger

  • Compare INSITE™ electronic service tool reading for charge-air cooler temperature to ambient air temperature.

NOTE: Coolant temperature must be below 20°C or 70°F before performing check.

Charge air cooler temperature and ambient air temperature reading within 5.6°C or10°F of each other?
YES NO
No Repair

Replace the charge-air cooler outlet pressure/temperature sensor.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine charge-air cooler outlet pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and engine charge air cooler temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet pressure/temperature sensor from the engine harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Note: Fault Code 123 will also be active when the engine charge-air cooler outlet pressure/temperature sensor is disconnected.

Fault Code 2571 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine charge-air cooler outlet pressure/temperature sensor SIGNAL pin and the engine charge air cooler temperature RETURN pin at the engine charge-air cooler outlet pressure/temperature sensor connector of the engine harness

Use the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES NO

An in-range malfunction of the engine charge-air cooler outlet pressure/temperature sensor has been detected.

Replace the engine charge-air cooler outlet pressure/temperature sensor. Refer to Procedure 019-560 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins. Use electronic contact cleaner, Part Number 3824510.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2571 is active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine intake manifold temperature SIGNAL pin and engine intake manifold temperature RETURN pin at the ECM connector.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2572 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Feb-2015


FAULT CODE 3494 - Engine Wait to Start Lamp - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3494 active?
 | STEP 1B. Check for active fault codes related to the J1939 data link. | Fault codes related to the J1939 data link active?
STEP 2. | Check the WAIT TO START lamp configuration. |
 | STEP 2A. Check the configuration of the WAIT TO START lamp. | Is the WAIT TO START lamp configured correctly?
STEP 3. | Check the WAIT TO START lamp circuit. |
 | STEP 3A. Check the WAIT TO START lamp bulb. | Is the WAIT TO START lamp bulb failed?
 | STEP 3B. Check the WAIT TO START lamp circuit. | Is the voltage within 1 VDC of battery voltage?
 | STEP 3C. Check the WAIT TO START lamp circuit. | Less than 10 ohms?
 | STEP 3D. Check the WAIT TO START lamp circuit. | Less than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3494 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes related to the J1939 data link.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the J1939 data link active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the WAIT TO START lamp configuration.

Guided Step 2A - Check the configuration of the WAIT TO START lamp.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the configuration of the WAIT TO START lamp in Features and Parameters and compare to how the original equipment manufacturer (OEM) has the WAIT TO START lamp wired.

–

Is the WAIT TO START lamp configured correctly?
YES NO
No Repair

An incorrect setup has been detected in the Cummins® ECM.

Configure the WAIT TO START lamp to match the OEM wiring.

Go to 3A

Go to 4A

Guided Step 3 - Check the WAIT TO START lamp circuit.

Guided Step 3A - Check the WAIT TO START lamp bulb.

Conditions

  • Turn keyswitch OFF.
  • Remove the WAIT TO START lamp bulb.

Action

Inspect the WAIT TO START lamp bulb.

–

Is the WAIT TO START lamp bulb failed?
YES NO

Replace the WAIT TO START lamp bulb. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the WAIT TO START lamp circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the WAIT TO START lamp bulb.
  • Disconnect the OEM connector from the ECM.
  • Turn keyswitch ON.

Action

Measure the voltage at the WAIT TO START lamp bulb connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Is the voltage within 1 VDC of battery voltage?
YES NO
No Repair

An open circuit in the WAIT TO START lamp SUPPLY circuit has been detected.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check the WAIT TO START lamp circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the WAIT TO START lamp bulb.
  • Disconnect the OEM connector from the ECM.

Action

Measure the resistance between the WAIT TO START lamp bulb connector and the WAIT TO START lamp RETURN circuit at the OEM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the WAIT TO START lamp RETURN circuit has been detected.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check the WAIT TO START lamp circuit.

Conditions

  • Turn keyswitch OFF.
  • Remove the WAIT TO START lamp bulb.
  • Disconnect the OEM connector from the ECM.

Action

Measure the resistance between the WAIT TO START lamp RETURN circuit at the OEM connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Less than 10 ohms?
YES NO

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jan-2016


FAULT CODE 3543 - NOx Limits Exceeded Due to Insufficient Reagent Quality - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3543 active?
 | STEP 1B. Check for active aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
 | STEP 1C. Check for active aftertreatment selective catalytic reduction (SCR) temperature sensor fault codes. | Fault codes related to the aftertreatment SCR temperature sensors active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | DEF dosing system related fault codes active?
 | STEP 1E. Check for active DEF quality fault codes. | DEF quality fault codes active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Inspect the DEF dosing system for external leaks. | External leaks detected in the system?
 | STEP 2C. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056 in the Associated Procedures Table?
 | STEP 2D. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063 in the Associated Procedures Table?
 | STEP 2E. Check the aftertreatment DEF dosing valve for proper operation. | DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3543 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment intake NOx sensor and aftertreatment outlet NOx sensor active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active aftertreatment selective catalytic reduction (SCR) temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment SCR temperature sensors active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF dosing system related fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1E

Guided Step 1E - Check for active DEF quality fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to DEF quality.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF quality fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.
  • Operate engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO
No Repair

Repair or replace the damaged exhaust system component.

Go to 2B

Go to 2B

Guided Step 2B - Inspect the DEF dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment DEF dosing system for signs of external leaks, including:

  • DEF dosing unit
  • DEF tank connectors
  • DEF line
  • DEF dosing valve

DEF will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056 in the Associated Procedures Table?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank, and rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063 in the Associated Procedures Table?

YES NO
No Repair

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2E

Go to 2E

Guided Step 2E - Check the aftertreatment DEF dosing valve for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment DEF dosing valve for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under engine control module Diagnostic Tests. Refer to Procedure Refer to Procedure 011-063 in the Associated Procedures Table.

DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
YES NO

A leaking aftertreatment diesel exhaust fluid dosing valve has been detected.

Replace the aftertreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-098 in the Associated Procedures Table.

A malfunctioning aftertreatment SCR system has been detected.

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-098 in the Associated Procedures Table.

Replace the aftertreatment intake NOx sensor. Refer to procedure 019-463 in the Associated Procedures Table.

Replace the aftertreatment outlet NOx sensor. Refer to procedure 019-451 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code cleared?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 3547 - Aftertreatment Diesel Exhaust Fluid Tank Empty - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3547 active?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3547 active?
YES NO

Diesel exhaust fluid (DEF) has not been detected in the DEF tank.

Add DEF to the DEF tank.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3555 - Engine Wait to Start Lamp - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with INSITE™ electronic service tool. |
 | STEP 1A. Check for ECM communication with INSITE™ electronic service tool. | Communication between INSITE™ electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 3555 active?
STEP 3. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 4. | Check the service data link harness. |
 | STEP 4A. Inspect the service data link harness and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open or short circuit in the J1939 data link harness. | 50 ohms to 70 ohms?
STEP 5. | Check the OEM harness. |
 | STEP 5A. Check the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open or short circuit in the ECM J1939 data link harness. | 50 ohms to 70 ohms?
 | STEP 5C. Check for a short circuit in the ECM J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for an inactive fault code. | Fault Code 3555 inactive?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with INSITE™ electronic service tool.

Guided Step 1A - Check for ECM communication with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify INSITE™ electronic service tool communication with the ECM.

.

Communication between INSITE™ electronic service tool and the ECM possible?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3555 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the OEM VECU and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses.

Refer to Multiplexing Troubleshooting, Bulletin 4021378.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 6A

Go to 6A

Guided Step 4 - Check the service data link harness.

Guided Step 4A - Inspect the service data link harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Inspect the service data link connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the service data link cable.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for an open or short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the data link adapter from the service data link connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the service data link connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected on the service data link connector or harness connection to the J1939 data link backbone.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5A

Go to 6A

Guided Step 5 - Check the OEM harness.

Guided Step 5A - Check the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM data link harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection to the Cummins® ECM has been detected in the J1939 data link connector or harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open or short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open or short circuit.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the appropriate Cummins® ECM OEM connection to the J1939 data link harness connector.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

50 ohms to 70 ohms?
YES NO
No Repair

An open or short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the ECM J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire on the Cummins® ECM OEM connection to all other pins in the OEM connector.
  • Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Use a wiring diagram for pin identification and use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3555 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

A communication issue between the ECM and the data link, or a damaged ECM or calibration is causing the fault code.

Go to 6A

Reference the appropriate ECM No Communication troubleshooting symptom tree in Section TT.

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3556 - Engine Wait to Start Lamp - Received Network Data in Error

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3556 active?
 | STEP 1B. Check for an active fault code. | J1939 data link related fault codes active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3556 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

J1939 data link related fault codes active?
YES | NO
No Repair | No Repair

Reference the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3557 - Aftertreatment Diesel Exhaust Fluid (DEF) Controller - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead or Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3557 active?
 | STEP 1B. Check for active fault codes. | Fault Code 6257, 6256, 3597, 4291, 4292, 5673, or 5674 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and circuit. | Dirty or damaged pins?
 | STEP 2B. Check for an active fault code. | Fault Code 3557 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6257, 6256, 3597, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Connect the aftertreatment DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3557 active?
YES NO

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3558 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286, 477, 478, 4291, 5673, or 5674 inactive?
 | STEP 1B. Check for an active fault code. | Fault Code 3558 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and electrical connections. | Dirty or damaged pins?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 477, 478, 4291, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3558 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to
Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3559 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286, 427, 477, 478, 3557, 3558, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3559 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Check the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an active fault code. | Fault Code 3559 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to
Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the original equipment manufacturer (OEM) harness.

Action

Inspect the harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Connect all components.
  • Cycle keyswitch OFF, then back ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

Reconnecting the DEF dosing unit fixed the problem.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3561 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3561 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit controller. |
 | STEP 2A. Inspect the aftertreatment DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
 | STEP 2C. Check the voltage to the aftertreatment DEF dosing unit. | Voltage within 1-VDC of battery voltage?
 | STEP 2D. Check the voltage to the aftertreatment DEF dosing unit. | Voltage within 1-VDC of battery voltage?
 | STEP 2E. Check for an active fault code. | Fault Code 3559 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3561 active?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF dosing unit controller.

Guided Step 2A - Inspect the aftertreatment DEF dosing unit and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness from the aftertreatment DEF dosing unit.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing unit or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 25-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness from the aftertreatment DEF dosing unit.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF dosing unit.

  • Measure the voltage between the aftertreatment DEF dosing unit battery voltage supply circuit and the aftertreatment DEF dosing unit battery voltage return circuit at the DEF dosing unit wiring harness connector.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

Refer to the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit battery voltage supply circuit.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the voltage to the aftertreatment DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DEF dosing unit.

  • Measure the voltage between the aftertreatment DEF dosing unit battery voltage supply circuit at the DEF dosing unit wiring harness connector and engine block ground.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

Refer to the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF dosing unit battery voltage return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch OFF then back ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3559 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedure Table.

Reconnecting the DEF dosing unit corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3565 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3565 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF dosing valve. | Resistance between 11 and 18 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness ECM connector. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 3565 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3565 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the dosing valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for an internal short or open circuit in the aftertreatment DEF dosing valve by measuring the internal resistance.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 11 and 18 ohms?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the aftertreatment DEF controller harness.

Action

Check for a pin-to-ground short circuit in the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the controller or harness connector.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the aftertreatment DEF controller harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin at the OEM harness connector and the aftertreatment DEF dosing valve SIGNAL pin in the dosing valve harness connector.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin at the OEM harness connector and the aftertreatment DEF dosing valve RETURN pin in the dosing valve harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the aftertreatment DEF controller harness.

Repair or replace the aftertreatment DEF controller harness. See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin of the OEM harness ECM connector and engine block ground.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness ECM connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve SIGNAL pin of the OEM harness ECM connector and all other populated pins in the connector.
  • Measure the resistance between the aftertreatment diesel exhaust fluid dosing valve RETURN pin of the OEM harness ECM connector and all other populated pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the OEM harness.

Repair or replace the OEM harness. See equipment manufacturer service information.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The dosing valve must be commanded on in order for all dosing valve diagnostics to run.

Before checking the fault codes, perform the Aftertreatment DEF Dosing Unit Override Test in INSITE™ electronic service tool.

Refer to Procedure 011-063 in the Associated Procedures Table.

Fault Code 3565 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3567 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment DEF Dosing Valve | Refer to Procedure 011-059 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment DEF Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault code. | Fault Code 3567 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the aftertreatment DEF dosing valve resistance. | Resistance meets the specifications?
 | STEP 2C. Check for a short to ground in the aftertreatment DEF dosing valve. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open supply circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open return circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3F. Check for an active fault code. | Fault Code 3567 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault cods.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the aftertreatment DEF dosing valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Inspect the harness and aftertreatment DEF dosing valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check the resistance of the aftertreatment DEF dosing valve.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and RETURN pin at the aftertreatment DEF dosing valve connector.
  • Refer to Procedure 011-059 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance meets the specifications?
YES NO
No Repair

An internal short or open circuit has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check for a short to ground in the aftertreatment DEF dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing valve from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin and the metal case of the aftertreatment DEF dosing valve.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the aftertreatment DEF dosing valve.

Replace the aftertreatment DEF dosing valve.

Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open supply circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DEF dosing valve SIGNAL pin and the SIGNAL pin at the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open SUPPLY circuit has been detected. Troubleshoot the OEM harness.

Repair or replace the wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open return circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DEF dosing valve RETURN pin and the RETURN pin at the aftertreatment DEF dosing valve connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the harness. Troubleshoot the OEM harness.

Repair or replace the wiring harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin in the OEM harness ECM connector and ground.
  • Measure the resistance between the aftertreatment DEF dosing valve RETURN pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness. Troubleshoot the OEM harness.

Repair or replace the wiring harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DEF dosing valve from the harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the aftertreatment DEF dosing valve SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected in the harness. Troubleshoot the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start the engine and idle it for 1 minute.

  • Check for the appropriate circuit response after 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3567 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.Refer to Procedure 019-032 in Section 19.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 13-Mar-2017


FAULT CODE 3568 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Valve 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3568 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid dosing valve. |
 | STEP 2A. Check for a stuck closed aftertreatment diesel exhaust fluid dosing valve. | Dosing valve meets the specification outline in Procedure 011-063?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3568 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing valve.

Guided Step 2A - Check for a stuck closed aftertreatment diesel exhaust fluid dosing valve.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment diesel exhaust fluid dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a stuck closed or low flowing aftertreatment diesel exhaust fluid dosing valve.

  • Perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override test. Refer to Procedure 011-063 in the Associated Procedures Table.

Dosing valve meets the specification outline in Procedure 011-063?
YES NO
No Repair

A damaged aftertreatment diesel exhaust fluid dosing valve has been detected.

Inspect and Clean the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

After cleaning, perform the Aftertreatment Diesel Exhaust Fluid Dosing Unit Override test again. If the Dosing valve does not meet the specification outlined in Procedure 011-063, replace the aftertreatment DEF dosing valve.

  • Refer to Procedure 011-059 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM.The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Codes" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3571 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3571 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3571 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3572 - Aftertreatment 1 Diesel Exhaust Fluid Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3572 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3572 active?
YES NO

A malfunctioning diesel exhaust fluid (DEF) dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 3574 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3574 active or more than two inactive counts?
 | STEP 1B. Check for low diesel exhaust fluid (DEF) tank level. | DEF tank empty?
 | STEP 1C. Check for DEF quality fault codes. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 1D. Check for active aftertreatment DEF system fault codes. | Any fault codes related to the DEF dosing system?
STEP 2. | Check the aftertreatment DEF lines and fittings. |
 | STEP 2A. Inspect the aftertreatment DEF dosing lines. | DEF dosing line blocked, cracked, or restricted?
STEP 3. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 3A. Perform the Aftertreatment DEF Doser Pump Override Test. | Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to check the aftertreatment diesel exhaust fluid tank level and compare it to the gauge on the dash.

DEF tank empty?
YES NO

Fill the DEF tank.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for DEF quality fault codes.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank and rinse the tank with water.

Refill the DEF tank with pure DEF. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 1D

Go to 3A

Guided Step 1D - Check for active aftertreatment DEF system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to read the fault codes.

  • Check for active fault codes relating to the DEF dosing system.

Any fault codes related to the DEF dosing system?
YES NO

Troubleshoot any active fault codes in this list before troubleshooting Fault Code 3574.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF lines and fittings.

Guided Step 2A - Inspect the aftertreatment DEF dosing line.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing line from the DEF tank.

Action

Check the aftertreatment DEF dosing line for blockage.

  • Look at both ends of the line to check for signs of buildup or blockage.
  • Blow compressed shop air through the supply line to establish/confirm free flow.
  • Check the dosing line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.

DEF dosing line blocked, cracked, or restricted?
YES NO

Repair or replace the leaking DEF dosing line or fitting, as necessary. See equipment manufacturer service information.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF dosing unit operation.

Guided Step 3A - Perform the Aftertreatment DEF Doser Pump Override Test.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to perform the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3575 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 427, 477, 478, 1682, 3237, 3238, 3258, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3575 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit valve line. |
 | STEP 2A. Inspect the aftertreatment DEF dosing valve line and fittings. | Any damaged, leaking, or restricted connections found?
STEP 3. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 3A. Perform the Aftertreatment DEF Doser Override Test. | Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 1682, 3238, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3575 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing valve line.

Guided Step 2A - Inspect the aftertreatment DEF dosing valve line and fittings.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DEF dosing unit fittings and line.

  • Check the dosing valve supply connectors and fittings for loose or leaking connections.
  • Disconnect the dosing valve line connector on the dosing unit and look for signs of build-up or blockage.
  • Check the dosing unit supply line for signs of leakage or openings which would allow the dosing unit to suck in air with the DEF.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?

YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting as necessary.

See equipment manufacturer service information.

Repair or replace the aftertreatment DEF dosing unit, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF dosing unit operation.

Guided Step 3A - Perform the Aftertreatment DEF Doser Pump Override Test.

Conditions

  • Connect the DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container greater than a 1.5 liter [50 oz] capacity to perform the Aftertreatment DEF Doser Pump Override Test.

Does the aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3576 - Aftertreatment 1 Diesel Exhaust Fluid Tank Heater - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4387291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 3576 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment DEF tank heater control valve and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF tank heater control valve and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3576 inactive and Fault Code 1684 active?
 | STEP 2C. Check the fault codes and verify the aftertreatment DEF tank heater control valve condition. | Fault Code 3576 active?
STEP 3. | Check the aftertreatment DEF dosing unit and harness. |
 | STEP 3A. Inspect the aftertreatment DEF dosing unit and harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for open circuit. | Greater than 10 ohms?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF tank heater control valve and circuit.

Guided Step 2A - Inspect the aftertreatment DEF tank heater control valve and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF tank heater control valve connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Turn keyswitch OFF for 30 seconds.
  • Place a jumper wire between the aftertreatment DEF tank heater control valve SUPPLY pin and the aftertreatment DEF tank heater control valve RETURN pin at the aftertreatment DEF tank heater control valve OEM harness connector.
  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostics Tests.
  • Command the Aftertreatment DEF Tank Heater 2 Relay ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 inactive and Fault Code 1684 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the aftertreatment DEF tank heater control valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF tank heater control valve to the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3576 active?
YES NO

A damaged aftertreatment DEF tank heater control valve has been detected.

  • Replace the aftertreatment DEF tank heater control valve.
  • See equipment manufacturer service information.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the aftertreatment DEF dosing unit and harness.

Guided Step 3A - Inspect the aftertreatment DEF dosing unit and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.

Action

Inspect the OEM harness and aftertreatment DEF dosing unit connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the aftertreatment DEF dosing unit connector or OEM harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for open circuit.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the aftertreatment DEF dosing unit.
  • Disconnect the aftertreatment DEF tank heater control valve from the OEM harness.

Action

Check for an open circuit in the aftertreatment DEF tank heater control valve circuit.

  • Measure the resistance between the aftertreatment DEF tank heater control valve SUPPLY pin at the tank heater control valve wiring harness connector and the aftertreament DEF tank heater control valve SUPPLY pins at the OEM harness aftertreatment DEF dosing unit connector.
  • Measure the resistance between the aftertreatment DEF tank heater control valve RETURN pin at the tank heater control valve wiring harness connector and engine block ground.

NOTE: For 12V applications there are 2 SUPPLY pins for the tank heater control valve at the DEF dosing unit connector. Both must be measured for resistance to the heater control valve connector SUPPLY pin.

Greater than 10 ohms?
YES NO

An open circuit has been detected in the OEM harness.

Repair or replace the harness. Refer to Procedure 019-071 in Section 19.

  • See equipment manufacturer service information.

A malfunctioning DEF dosing unit assembly has been detected.

Replace DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3577 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3577 active
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Check for active fault codes. | Fault Code 3577 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Check for active fault codes.

Conditions

  • Cycle keyswitch OFF then back ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3577 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jan-2015


FAULT CODE 3578 - Aftertreatment Diesel Exhaust Fluid Return Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3578 active
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Check for active fault codes. | Fault Code 3578 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3578 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Check for active fault codes.

Conditions

  • Cycle keyswitch OFF then back ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3578 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jan-2015


FAULT CODE 3597 - Aftertreatment Diesel Exhaust Fluid Controller - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3597 active or more than one inactive count?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical System Voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2636, 2771, 3219, 3232, 3868, 3911, 4151, 4152, or 4572 active or more than one inactive count?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller and circuit. |
 | STEP 2A. Inspect the DEF controller and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the DEF controller. | Voltage greater than 10-VDC?
 | STEP 2C. Check the voltage to the DEF controller. | Voltage greater than 10-VDC?
 | STEP 2D. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 3. | Check the aftertreatment DEF controller and J1939 circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Between 108 and 132 ohms?
 | STEP 3B. Check the J1939 terminating resistance. | Between 108 and 132 ohms?
STEP 4. | Check the J1939 data link. |
 | STEP 4A. Check the J1939 terminating resistance. | Between 54 and 66 ohms?
 | STEP 4B. Check the J1939 terminating resistance. | Between 108 and 132 ohms?
STEP 5. | Check the J1939 data link circuit. |
 | STEP 5A. Check the J1939 data link (+) for a short circuit. | Between 0.1 and 4.5 volts?
 | STEP 5B. Check the J1939 data link (-) for a short circuit. | Between 0.1 and 4.5 volts?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to the block ground.

Electrical System Voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 6A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636, 2771, 3219, 3232, 3868, 3911, 4151, 4152, or 4572 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DEF controller and circuit.

Guided Step 2A - Inspect the DEF controller and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DEF controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 2B

Guided Step 2B - Check the voltage to the controller.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF controller from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the DEF controller.

  • Measure the voltage between the DEF controller battery voltage supply circuit and the DEF controller battery voltage return circuit at the DEF controller wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the voltage to the DEF controller.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF controller from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the DEF controller.

  • Measure the voltage between the DEF controller battery voltage supply circuit at the DEF controller wiring harness connector and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10-VDC?
YES NO

An open or high resistance circuit has been detected in the DEF controller battery voltage return circuit.

  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2D

Guided Step 2D - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown aftertreatment DEF controller power supply fuse.
  • Inspect the aftertreatment DEF controller power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

An open or high resistance circuit has been detected in the DEF controller battery voltage supply circuit.

  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 3 - Check the aftertreatment DEF controller and J1939 circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE adapter from the 3-pin service data link connector.
  • Disconnect the DEF controller from the OEM harness.

Action

Measure the terminating resistance of the society of automotive engineers (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire at the DEF controller connector of the OEM harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 108 and 132 ohms?
YES | NO
No Repair | No Repair

Go to 3B

Go to 4A

Guided Step 3B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE adapter from the 3-pin service data link connector.
  • Disconnect the DEF controller from the OEM harness.

Action

Measure the terminating resistance of the DEF controller.

  • Measure the resistance between the SAE J1939 data link (+) wire and the SAE J1939 data link (-) wire of the DEF controller.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 108 and 132 ohms?
YES NO
No Repair

A malfunctioning DEF controller has been detected.

  • Replace the DEF controller. Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 5A

Go to 6A

Guided Step 4 - Check the J1939 data link.

Guided Step 4A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE adapter from the 3-pin service data link connector.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE adapter from the 3-pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Measure the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 108 and 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

Use the following procedure to the aftertreatment harness isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

Use the following procedure to the aftertreatment harness isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 6A

Go to 6A

Guided Step 5 - Check the J1939 data link circuit.

Guided Step 5A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3-pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

Use the following procedure to check for a short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit.

  • Measure the voltage between the SAE J1939 (-) pin at the 3-pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

Use the following procedure to check for a short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 3715 - Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3715 active?
 | STEP 1B. Check for active fault codes. | Fault Code 241 or 242 active?
 | STEP 1C. Check for active fault codes. | Fault codes related to the fuel system active or inactive counts?
STEP 2. | Check the engine rpm. |
 | STEP 2A. Check for active fault codes. | Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
 | STEP 2B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 2C. Check for an alternate fuel source. | Alternate fuel source?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3715 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 or 242 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the fuel system.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the fuel system active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine rpm.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the crankshaft position sensor or camshaft position sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2B

Guided Step 2B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Note: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft position sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 2C

Go to Fault Codes 689 and 778.

Guided Step 2C - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check the oil contamination in the intake piping
  • Malfunctioning cold weather starting aids
  • Malfunctioning aftermarket devices.

Alternate fuel source?
YES NO

Repair or replace the damaged component.

Continue to investigate the cause of the high or surging idle. Refer to the engine performance troubleshooting tree.

Go to 3A

Go to the appropriate engine performance troubleshooting tree.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.s

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3716 - Engine Speed At Idle - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3716 active?
 | STEP 1B. Check for active fault codes. | Fault Code 241 or 242 active?
 | STEP 1C. Check for active fault codes. | Active or inactive counts of fault codes related to the fuel system or turbocharger?
STEP 2. | Check the engine rpm. |
 | STEP 2A. Check for active fault codes. | Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
 | STEP 2B. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 2C. Check the accessory load. | Damaged or additional acessories found on the engine?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3716 active?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 241 or 242 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the fuel system and turbocharger.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of fault codes related to the fuel system or turbocharger?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine rpm.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to the crankshaft position sensor or camshaft position sensor.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the crankshaft position sensor or camshaft position sensor active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2B

Guided Step 2B - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Note: Compare the engine speed reading on INSITE™ electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Inspect the crankshaft engine speed sensor and camshaft engine position sensor as outlined in Fault Codes 689 and 778.

Go to 2C

Go to Fault Codes 689 and 778.

Guided Step 2C - Check the accessory load.

Conditions

  • Turn keyswitch OFF.

Action

Check the accessory load on the engine.

  • Inspect the engine for damaged or marginal accessories such as alternators, refrigerant pumps, hydraulic pumps, air compressors, etc.
  • Inspect for additional engine accessories that could increase the load on the engine.

Damaged or additional accessories found on the engine?
YES NO

Repair or replace the damaged component or remove the additional accessory load.

Continue to investigate the cause of the low or surging idle. Refer to the engine performance troubleshooting tree.

Go to 3A

Go to the appropriate engine performance troubleshooting tree.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3736 - Aftertreatment Diesel Exhaust Fluid Controller - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3597 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3736 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Inspect the aftertreatment DEF controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3597 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3736 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES | NO
No Repair | No Repair

Go to Fault Code 3597 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3736 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF controller.

Guided Step 2A - Inspect the aftertreatment DEF controller and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness connector from the controller.

Action

Inspect the aftertreatment DEF controller harness and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF controller harness 53 pin connector from the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3597 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment DEF controller harness connector to the controller.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3736 active?
YES NO

Replace the aftertreatment DEF controller.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3b - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 3749 - Aftertreatment 1 Outlet NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3749 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887, 2771, 3583, or 3681 active?
 | STEP 1C. Verify proper installation of the aftertreatment outlet mono-nitrogen oxides (NOx) sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check the aftertreatment diesel exhaust fluid decomposition tube. |
 | STEP 2A. Check the decomposition tube for crystallization. | Crystallization buildup in the decomposition tube?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3749 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1887, 2771, 3583, or 3681 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify proper installation of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

  • Inspect the aftertreatment outlet NOx sensor for proper installation. Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel exhaust fluid decomposition tube.

Guided Step 2A - Check the decomposition tube for crystallization.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel exhaust fluid decomposition tube. Refer to Procedure 011-098 in the Associated Procedures Table.

Action

Check for diesel exhaust fluid crystallization.

  • Inspect the decomposition tube for crystallization.

Crystallization buildup in the decomposition tube?
YES NO

Remove the crystallization buildup. Refer to Procedure 011-098 in the Associated Procedures Table.

A damaged aftertreatment outlet NOx sensor has been detected.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibraton Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3868 - Aftertreatment Diesel Exhaust Fluid Quality - Abnormal Update Rate

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 3868 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit and circuit. |
 | STEP 2A. Inspect the DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the DEF dosing unit. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the original equipment manufacturer (OEM) wiring harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the DEF dosing unit battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the J1939 data link harness. |
 | STEP 4A. Inspect engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 4C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 4E. Check the J1939 terminating resistance. | Resistance between 50 and 70 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3868 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 2A - Inspect the DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the DEF dosing unit.

  • Measure the voltage between the DEF dosing unit battery voltage supply circuit and the DEF dosing unit battery voltage return circuit at the sensor wiring harness connector.

Note: Check the voltage at key ON, while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM wiring harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 5A

Guided Step 3B - Check for an open circuit in the DEF dosing unit battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM wiring harness.

Action

Check for an open circuit.

  • Measure the voltage from the DEF dosing unit battery voltage SUPPLY pin of the OEM wiring harness connector to engine block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the DEF dosing unit battery voltage return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the DEF dosing unit battery voltage.

Troubleshoot the OEM harness, any fuses, and/or relays in the supply circuit.

Repair or replace the necessary components.

Go to 5A

Go to 5A

Guided Step 4 - Check the J1939 data link harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisutre in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the DEF dosing unit from the OEM harness
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circuit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the DEF dosing unit wiring harness connector and the SAE J1939 (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the DEF dosing unit wiring harness connector and the SAE J1939 (-) wire at the ECM OEM harness connector.

Refer to the appropriate wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 5A

Guided Step 4C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and the SAE J1939 data link (-) pins.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4D

Go to 5A

Guided Step 4D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF
  • Disconnect the aftertreatment DEF dosing unit from the OEM wiring harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 4E

Go to 5A

Guided Step 4E - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF
  • Disconnect the DEF dosing unit from the OEM harness.

Action

Check the terminating resistance of the J1939 data link.

  • Measure the resistance between the J1939 data link (+) wire and the J1939 data link (-) wire at the DEF dosing unit wiring harness connector.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An incorrect terminating resistance has been detected in the OEM harness.

Repair the OEM J1939 data link. See equipment manufacturer service information.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 4157 - Aftertreatment Diesel Exhaust Fluid Return Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid System Leak Test | Refer to Procedure 011-080 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 477, 478, 3557, 3558, 3559, 3561, 4248, 5673, or 5674 active?
 | STEP 1B. Check for Fault Code 4157. | Fault Code 4157 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid lines and fittings. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid dosing unit pressure line. | Any damaged, leaking, or restricted connections found?
 | STEP 2B. Complete an aftertreatment diesel exhaust fluid dosing unit purge cycle. | Fault Code 4157 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 477, 478, 3557, 3558, 3559, 3561, 4248, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 4157.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4157 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid lines and fittings.

Guided Step 2A - Inspect the aftertreatment diesel exhaust fluid dosing unit pressure line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the dosing valve supply line between the dosing unit and the dosing valve.

  • Check the pressure line connections and fittings for loose, leaking, or damaged connections.
  • Disconnect the pressure line dosing unit connectors. Look for signs of buildup or blockage.
  • Verify proper sealing at all connection points, including the dosing unit and dosing valve.

Refer to Procedure 011-058 in the Associated Procedures Table.

Any damaged, leaking, or restricted connections found?
YES NO

Repair or replace the leaking diesel exhaust fluid line or fitting, as necessary.

See equipment manufacturer service information.

Repair or replace the aftertreatment diesel exhaust fluid dosing unit, as necessary. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Complete an aftertreatment diesel exhaust fluid dosing unit purge cycle.

Conditions

  • Connect all components.
  • Turn keyswitch ON with the engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Complete an aftertreatment diesel exhaust fluid dosing unit purge cycle.

  • Perform the Aftertreatment Diesel Exhaust Fluid Leak Test. Use INSITE™ electronic service tool. Refer to Procedure 011-080 in the Associated Procedures Table.
  • Allow INSITE™ electronic service tool to confirm the system is primed. A message will appear on the screen.
  • Press the STOP button in INSITE™ electronic service tool. Turn the keyswitch OFF. Allow the aftertreatment diesel exhaust fluid system to purge for 90 seconds.
  • Turn the keyswitch ON with the engine OFF.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4157 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4168 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4168 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Disable the fault code. | Fault code active?
 | STEP 2B. Check the vault codes and verify the aftertreatment DEF dosing unit heater condition. | Fault Code 4168 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4168 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the fault codes and verify the aftertreatment DEF dosing unit heater condition.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater 1 relay ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 4168 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4169 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4169 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Disable the fault code. | Fault code active?
 | STEP 2B. Check the vault codes and verify the aftertreatment DEF dosing unit heater condition. | Fault Code 4169 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4169 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the fault codes and verify the aftertreatment DEF dosing unit heater condition.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater 1 relay ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 4169 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4171 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Heater - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) tank heating system. |
 | STEP 2A. Check the aftertreatment DEF tank temperature sensor. | INSITE™ electronic service tool reading within 10°C or 18°F of infrared thermometer reading?
 | STEP 2B. Verify the aftertreatment DEF tank heater condition. | INSITE™ electronic service tool reading increases and within 10°C or 18°F of infrared thermometer reading?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for DEF tank heater or DEF tank temperature sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank heating system.

Guided Step 2A - Check the aftertreatment DEF tank temperature sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the temperature of the DEF in the DEF tank with in infrared thermometer.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for the aftertreatment DEF dosing unit heater temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading within 10°C or 18°F of infrared thermometer reading?
YES NO
No Repair

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Verify the aftertreatment DEF tank heater condition.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check heater operation.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the aftertreatment DEF tank heater 1 relay ON.
  • Use INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for the aftertreatment DEF dosing unit heater temperature sensor to the infrared thermometer.

INSITE™ electronic service tool reading increases and within 10°C or 18°F of infrared thermometer reading?
YES NO
No Repair

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 4244 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 144, 145, 146, 151, 155, 249, 256, 436, 2646, or 2963 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1C. Check for an active fault code. | Fault Code 4244 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Verify the aftertreatment DEF dosing unit temperature sensor accuracy. | INSITE™ electronic service tool DEF tank temperature reading within 10°C or 18°F of the measured value?
STEP 3. | Check the aftertreatment DEF dosing unit and circuit. |
 | STEP 3A. Inspect the DEF dosing unit and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the voltage to the DEF dosing unit. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the original equipment manufacturer (OEM) wiring harness. |
 | STEP 4A. Check the battery and power connector. | Connections tight and corrosion free?
 | STEP 4B. Check for an open circuit in the DEF dosing unit battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 5. | Check the J1939 data link harness. |
 | STEP 5A. Inspect engine control module (ECM) and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
 | STEP 5C. Check for a short circuit in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 5D. Check for a short circuit to ground in the J1939 data link harness. | Greater than 100k ohms?
 | STEP 5E. Check the J1939 terminating resistance. | Resistance between 50 and 70 ohms?
STEP 6. | Check ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes related to engine coolant temperature and charge-air temperature.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144, 145, 146, 151, 155, 249, 256, 436, 2646, or 2963 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4244 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment DEF dosing unit.

Guided Step 2A - Verify the aftertreatment DEF dosing unit temperature sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the accuracy of the aftertreatment DEF tank temperature sensor.

  • Measure the temperature of the aftertreatment DEF in the tank with an infrared thermometer or thermocouple.
  • Start INSITE™ electronic service tool Data Monitor/Logger.
  • Compare the INSITE™ electronic service tool reading for the aftertreatment DEF dosing unit heater temperature to the value measured with the infrared thermometer or thermocouple.

INSITE™ electronic service tool DEF tank temperature reading within 10°C or 18°F of the measured value?
YES NO
No Repair

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the aftertreatment DEF dosing unit and circuit.

Guided Step 3A - Inspect the DEF dosing unit and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pin.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the voltage to the DEF dosing unit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the DEF dosing unit.

  • Measure the voltage between the DEF dosing unit battery voltage supply circuit and the DEF dosing unit battery voltage return circuit at the sensor wiring harness connector.

Note: Check the voltage at key ON, while cranking the engine and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the OEM wiring harness.

Guided Step 4A - Check the battery and power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion free?
YES NO
No Repair

Tighten the loose connections and clean the terminals. See equipment manufacturer service information.

Go to 4B

Go to 6A

Guided Step 4B - Check for an open circuit in the DEF dosing unit battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM wiring harness.

Action

Check for an open circuit.

  • Measure the voltage from the DEF dosing unit battery voltage SUPPLY pin of the OEM wiring harness connector to engine block ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage within 1 VDC of battery voltage?
YES NO

An open circuit has been detected in the DEF dosing unit battery voltage return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

An open circuit has been detected in the DEF dosing unit battery voltage.

Troubleshoot the OEM harness, any fuses, and/or relays in the supply circuit.

Repair or replace the necessary components.

Go to 5A

Go to 6A

Guided Step 5 - Check the J1939 data link harness.

Guided Step 5A - Inspect ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • WIre insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for an open circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

Check for an open circutit in the J1939 data link harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link (+) wire at the DEF dosing unit wiring harness connector and the SAE J1939 (+) wire at the ECM OEM harness connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the DEF dosing unit wiring harness connector and the SAE J1939 (-) wire at the ECM OEM harness connector.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the J1939 data link.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a short circuit in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM wiring harness.
  • Disconnect the DEF dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness from the ECM connector.

Action

Check for a short circuit in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and all other pins in the connector.

Note: Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link (+) and SAE J1939 data link (-) pins.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 5D

Go to 6A

Guided Step 5D - Check for a short circuit to ground in the J1939 data link harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF dosing unit from the OEM wiring harness.
  • Disconnect the DEF dosing unit from the OEM wiring harness.
  • Disconnect the OEM wiring harness from the ECM connector.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link (+) wire at the ECM OEM harness connector and ground.
  • Measure the resistance between the SAE J1939 data link (-) wire at the ECM OEM harness connector and ground.

Use the wiring diagram or connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit to ground has been detected in the J1939 data link harness. Troubleshoot the OEM harness and all interconnects.

Repair or replace the malfunctioning component.

Go to 5E

Go to 6A

Guided Step 5E - Check the J1939 termination resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the DEF dosing unit from the OEM harness.

Action

Check the terminating resistance of the J1939 data link.

  • Measure the resistance between the J1939 data link (+) wire and the J1939 data link (-) wire at the DEF dosing unit wiring harness connector.

Resistance between 50 and 70 ohms?
YES NO
No Repair

An incorrect terminating resistance has been detected in the OEM harness.

Repair the OEM J1939 data link. See equipment manufacturer service information.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4248 - Aftertreatment Diesel Exhaust Fluid Controller - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4248 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4248 active?
YES NO

Replace the aftertreatment DEF dosing unit.

Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4259 - Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4259 active?
 | STEP 1B. Check for active fault codes. | Fault Code 6257, 6256, 596, 597, or 598 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4151 or 4162 active?
STEP 2. | Check the aftertreatment diesel particulate filter temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment diesel particulate filter temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment diesel particulate filter temperature sensor module. | Voltage less than 6 VDC (for 12 volt systems)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply. | Voltage less than 6 VDC (for 12 volt systems)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4259 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6257, 6256, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4151 or 4162 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment diesel particulate filter temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment diesel particulate filter temperature sensor module.

  • Measure the voltage between the aftertreatment diesel particulate filter temperature sensor module battery voltage supply circuit and the aftertreatment diesel particulate filter temperature sensor module battery voltage return circuit at the aftertreatment diesel particulate filter temperature sensor module wiring harness connector.

NOTE: Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 -VDC (for 12 volt systems)?
YES NO
No Repair

An intermittent connection has been detected at the aftertreatment diesel particulate filter temperature sensor module.

Troubleshoot the connector and OEM harness for intermittent shorts/opens.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections. Clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment diesel particulate filter temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC (for 12 volt systems)?
YES NO

An open circuit or high resistance has been detected in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment diesel particulate filter temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4262 - High Pressure Common Rail Fuel Pressure Relief Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6256, 596, 597, or 5736 active?
 | STEP 1B. Check for an active fault code. | Fault Code 4262 active?
STEP 2. | Check the power distribution center and fuse(s). |
 | STEP 2A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 3. | Check the high pressure common rail fuel pressure relief valve and circuit. |
 | STEP 3A. Inspect the engine harness and valve connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 4263 active and Fault Code 4262 inactive?
 | STEP 3C. Check the fault codes and verify valve condition. | Fault Code 4262 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM response. | Fault Code 4263 active and Fault Code 4262 inactive?
 | STEP 4C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for an open circuit. | Less than 10 ohms?
 | STEP 4E. Check for an active fault code. | Fault Code 4262 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6256, 596, 597, or 5736 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the power distribution center and fuse(s).

Guided Step 2A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Check for a blow aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the high-pressure common rail fuel pressure relief valve and circuit.

Guided Step 3A - Inspect the engine harness and valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Inspect the engine harness and valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Start the engine and idle for 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 4263 active and Fault Code 4262 inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the high-pressure common rail fuel pressure relief valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active?

YES NO

A damaged high-pressure common rail pressure relief valve has been detected.

Replace the high pressure common rail pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4263 active and Fault Code 4262 inactive?

YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin at the ECM connector of the engine harness and the high-pressure common rail fuel pressure relief valve SIGNAL pin at the high-pressure common rail fuel pressure relief valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Start the engine and let it idle for 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 inactive?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 4263 - High Pressure Common Rail Fuel Pressure Relief Valve Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4263 active?
STEP 2. | Check the power distribution center and fuse(s). |
 | STEP 2A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 3. | Check the high-pressure common rail fuel pressure relief valve and circuit. |
 | STEP 3A. Inspect the engine harness and valve connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 4262 active and Fault Code 4263 inactive?
 | STEP 3C. Check the fault codes and verify valve condition. | Fault Code 4263 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the ECM response. | Fault Code 4262 active and Fault Code 4263 inactive?
 | STEP 4C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4E. Check for an inactive fault code. | Fault Code 4263 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4263 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the power distribution center and fuse(s).

Guided Step 2A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the high-pressure common rail fuel pressure relief valve and circuit.

Guided Step 3A - Inspect the engine harness and valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Inspect the engine harness and valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds

  • Place a jumper wire between the high-pressure common rail fuel pressure relief valve SIGNAL pin at the valve connector and ground.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 4262 active and Fault Code 4263 inactive?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the fault codes and verify valve condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the high-pressure common rail fuel pressure relief valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes and verify valve condition.

  • Start the engine and let it idle for 30 seconds.
  • Use INSITE™ electronic service tool to verify the fault codes.

Fault Code 4263 active?
YES NO

A damaged high-pressure common rail fuel pressure relief valve has been detected.

Replace the high-pressure common rail fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 4 - Check the engine control module (ECM) and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the high-pressure common rail fuel pressure relief valve SIGNAL pin at the ECM connector and ground.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active and Fault Code 4263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4D

Go to 5A

Guided Step 4D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the high-pressure common rail fuel pressure relief valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the high-pressure common rail fuel pressure relief valve SIGNAL pin in the engine harness ECM connector and ground.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4E

Go to 5A

Guided Step 4E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4263 inactive?
YES NO

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been be detected.

None. The removal and installation of the connector corrected the fault.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4517 - Vehicle Identification Number - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4517 active?
STEP 2. | Check the ECM calibration for a vehicle identification number. |
 | STEP 2A. Check for a vehicle identification number in the ECM. | Vehicle identification number present?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4517 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the ECM calibration for a vehicle identification number.

Guided Step 2A - Check for a vehicle identification number in the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for a vehicle identification number under the vehicle/OEM information in the system ID and Dataplate section of Features and Parameters in INSITE™ electronic service tool.

Vehicle identification number present?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Enter the vehicle identification number into the appropriate field.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4518 - Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4519 - Aftertreatment 1 SCR Intermediate Gas Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction temperature sensor module has been detected. Refer to Procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4521 - Aftertreatment 1 SCR Intermediate Gas Temperature Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction temperature sensor module has been detected.

Replace the aftertreatment selective catalytic reduction temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4524 - Aftertreatment 1 SCR Intermediate Gas Temperature - Data valid But above normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of contamination in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Aftertreatment DOC removed.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell walls.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4525 - Aftertreatment 1 SCR Intermediate Gas Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Oxidation Catalyst | Refer to Procedure 011-049 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the aftertreatment system. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
STEP 2. | Check the diesel exhaust fluid (DEF) for contamination. |
 | STEP 2A. Check the DEF for contamination. | DEF contaminated?
STEP 3. | Check the fuel system. |
 | STEP 3A. Check for an injector misfire. | Engine misfire detected?
STEP 4. | Check the turbocharger outlet. |
 | STEP 4A. Inspect the turbocharger exhaust outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger exhaust outlet?
STEP 5. | Inspect the aftertreatment diesel oxidation catalyst (DOC). |
 | STEP 5A. Check the aftertreatment DOC for soot accumulation. | More than 50 percent of the cells on the intake face completely blocked by soot?
 | STEP 5B. Inspect the aftertreatment DOC for cracks in the cell walls. | Any cracks found in the cell walls?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the aftertreatment system.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4159, 4164, 4165, or 4261 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the diesel exhaust fluid (DEF) for contamination.

Guided Step 2A - Check the DEF for contamination.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF for contamination.

  • Refer to Procedure 011-056 in the Associated Procedures Table.

DEF contaminated?
YES NO

Drain the DEF tank. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the fuel system.

Guided Step 3A - Check for an injector misfire.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Start the engine and run at low idle.

Action

Determine if a cylinder misfire is noticed when the engine is running at low idle.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to check for a cylinder misfire.

Engine misfire detected?
YES NO

Determine the cause of the engine misfire.

  • Use INSITE™ electronic service tool Cylinder Cutout Test to isolate a malfunctioning injector. Replace the injector, if necessary. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the turbocharger outlet.

Guided Step 4A - Inspect the turbocharger exhaust outlet for oil or fuel.

Conditions

  • Remove the exhaust plumbing from the turbocharger outlet.

Action

Check for signs of contamination in the turbocharger exhaust outlet.

  • Inspect the turbocharger exhaust outlet for signs of oil or fuel being introduced into the aftertreatment system from the engine.

Engine oil or fuel contamination found in the turbocharger exhaust outlet?
YES NO

Locate the cause of possible diesel fuel or engine oil being carried from the engine into the aftertreatment system.

Inspect the aftertreatment system for possible damage. Refer to Procedure 014-017 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 5A

Guided Step 5 - Inspect the aftertreatment diesel oxidation catalyst (DOC).

Guided Step 5A - Check the aftertreatment DOC for soot accumulation.

Conditions

  • Remove the aftertreatment DOC.

Action

Inspect the aftertreatment catalyst.

  • Check the intake face of the aftertreatment DOC for soot accumulation and/or face plugging.

Refer to Procedure 011-049 in the Associated Procedures Table.

More than 50 percent of the cells on the intake face completely blocked by soot?
YES NO

Clean the aftertreatment DOC. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 5B

Go to 5B

Guided Step 5B - Inspect the aftertreatment DOC for cracks in the cell walls.

Conditions

  • Aftertreatment DOC removed.

Action

Inspect the aftertreatment DOC.

  • Check for cracks in the aftertreatment DOC cell wall.

Refer to Procedure 011-049 in the Associated Procedures Table.

Any cracks found in the cell walls?
YES NO

Replace the aftertreatment diesel oxidation catalyst. Refer to Procedure 011-049 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4526 - Brake Pedal Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4526 active?
 | STEP 1B. Check the ECM setup for the brake switch. | INSITE™ electronic service tool brake switch set up correctly?
STEP 2. | Check the brake pedal position sensors. |
 | STEP 2A. Inspect the brake pedal position sensors and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the ECM and original manufacturer equipment (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2D. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 2E. Check for an open circuit in the return of the OEM harness. | Less than 10 ohms?
 | STEP 2F. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2G. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 2H. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
STEP 3. | Verify brake switch operation. |
 | STEP 3A. Verify the brake switches. | Both brake switch values toggle when brake pedal depressed?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4526 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check the ECM setup for the brake switch.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to check the brake switch setup.

  • If the vehicle has a multiplexed brake switch signal, make sure the brake switch is properly enabled in INSITE™ electronic service tool.

INSITE™ electronic service tool brake switch set up correctly?
YES NO
No Repair

Use INSITE™ electronic service tool to correct the brake switch setup.

Go to 2A

Go to 3A

Guided Step 2 - Check the brake pedal position sensors.

Guided Step 2A - Inspect the brake pedal position sensors and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the brake pedal position sensor from the OEM harness.

Action

Inspect the OEM harness and brake pedal sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 3A

2B

Guided Step 2B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the brake pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the brake pedal position 1 switch SIGNAL pin at the brake pedal OEM wiring harness connector to the brake pedal position 1 switch SIGNAL pin and at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the brake pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the brake pedal position 2 switch SIGNAL pin at the brake pedal OEM wiring harness connector to the brake pedal position 2 switch SIGNAL pin and at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2E

Go to 3A

Guided Step 2E - Check for an open circuit in the return of the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the brake pedal from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the brake pedal position 2 switch RETURN pin at the brake pedal OEM wiring harness connector to the brake pedal position 2 switch RETURN pin and at the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2F

Go to 3A

Guided Step 2F - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the brake pedal from the OEM harness.

Action

Check for pin-to-pin short circuit.

  • Measure the resistance between the brake position 1 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2G

Go to 3A

Guided Step 2G - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the brake pedal from the OEM harness.

Action

Check for pin-to-pin short circuit.

  • Measure the resistance between the brake position 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 2H

Go to 3A

Guided Step 2H - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the brake pedal from the OEM harness.

Action

Check for pin-to-pin short circuit.

  • Measure the resistance between the brake position 2 sensor RETURN pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the RETURN wire has been detected in the OEM harness.

Repair or replace the OEM harness.

Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Verify brake switch operation.

Guided Step 3A - Verify the brake switches.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct operation.

  • Use INSITE™ electronic service tool to monitor brake switch 1 and brake switch 2.
  • Press the brake pedal several times.

Both brake switch values toggle when brake pedal depressed?
YES NO

The brake has been setup properly or the removal and installation of the connector has corrected the fault.

A damaged brake pedal has been detected.

Replace the brake pedal. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4612 - Engine Intake Manifold Pressure System Monitor - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or inactive counts of Fault Code 1229, 5951, 5952, 5953, 6237, or 6238?
 | STEP 1B. Check for active fault codes. | Active or inactive counts of Fault Code 153, 154, or 436?
 | STEP 1C. Check for active fault codes. | Active or inactive counts of Fault Code 221, 222, or 295?
 | STEP 1D. Check for active fault codes. | Active or inactive counts of Fault Code 249, 256, or 2398?
 | STEP 1E. Check for active fault codes. | Active or inactive counts of Fault Code 2373, 2374, or 2554?
 | STEP 1F. Check for active fault codes. | Any exhaust gas recirculation (EGR) fault codes active or inactive?
 | STEP 1G. Check for active fault codes. | Any turbocharger fault codes active or inactive?
STEP 2. | Check the air intake system for leaks. |
 | STEP 2A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 2B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
 | STEP 2C. Check the EGR system for leaks and restrictions. | Leaks or restrictions present in the EGR system?
STEP 3. | Check exhaust system restriction. |
 | STEP 3A. Check exhaust system restriction. | Exhaust restriction within specifications?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for intake manifold pressure fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1229, 5951, 5952, 5953, 6237, or 6238?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for intake manifold temperature fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 153, 154, or 436?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for barometric pressure fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 221, 222, or 295?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for ambient air temperature fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 249, 256, or 2398?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1E

Guided Step 1E - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for exhaust gas pressure fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 2373, 2374, or 2554?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1F

Guided Step 1F - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for EGR related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any EGR related fault codes active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1G

Guided Step 1G - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for turbocharger related fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger fault codes active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the air intake system for leaks.

Guided Step 2A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect the charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, as necessary.

Go to 2C

Go to 3A

Guided Step 2C - Check the EGR system for leaks and restrictions.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system plumbing for leaks and restrictions.

  • Check the EGR crossover tube for leaks and restrictions.
  • Check the EGR differential pressure sensor for leaks at the mounting surface. It could be necessary to remove the EGR differential pressure sensor to check the o-rings for damage.
  • Leaks can be easily noted by traces of soot

Leaks or restrictions present in the EGR system?
YES NO

Repair or replace the malfunctioning component.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check exhaust system restriction.

Guided Step 3A - Check exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust system within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4678 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 4678 active?
STEP 2. | Check the aftertreatment dosing unit. |
 | STEP 2A. Check for an active fault code. | Fault Code 4678 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4678 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment dosing unit.

Guided Step 2A - Check for an active fault code.

Conditions

  • Cycle keyswitch OFF then back ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4678 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4679 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4679 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4679 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor has been detected.

Replace the Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 4682 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Below Normal or Open Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4682 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4682 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor has been detected.

Replace the Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4713 - Engine Fuel Injection Quantity Error for Multiple Cylinders - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4713 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4713 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4728 - Exhaust Gas Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment System | Refer to Procedure 011-050 | ISV5.0 CM3230 V104 | 4367291
Snap Acceleration Test | Refer to Procedure 014-017 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4728 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1938, 2387, 2636, or 5736 active?
STEP 2. | Check the variable geometry turbocharger (VGT) actuator. |
 | STEP 2A. Inspect the VGT actuator and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the VGT actuator. | Gear broken or damaged on VGT actuator?
 | STEP 2C. Inspect the turbocharger shaft movement. | Nozzle movement meet the requirements found in Procedure 010-134 using sector gauge gear?
 | STEP 2D. Check for active Fault Code 4728. | Fault Code 4728 active?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Check for progressive damage to the aftertreatment system. | Progressive damage to the aftertreatment system detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4728.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4728 active?
YES NO
No Repair

No troubleshooting is necessary unless Fault Code 4728 is active.

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1938, 2387, 2636, or 5736 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the VGT actuator.

Guided Step 2A - Inspect the VGT actuator and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect teh VGT actuator from the engine harness.

Action

Inspect the engine harness and VGT actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator connector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the VGT actuator.

Conditions

  • Turn keyswitch OFF.
  • Drain the engine coolant. Refer to Procedure 008-018 in the Associated Procedures Table.
  • Remove the VGT actuator from the turbocharger. Refer to Procedure 010-134 in the Associated Procedures Table.

Action

Inspect the VGT actuator.

  • Check for a broken drive gear on the VGT actuator.

Gear broken or damaged on the VGT actuator?
YES NO

A damaged gear has been detected on the VGT actuator.

Replace the VGT actuator. Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Inspect the turbocharger shaft movement.

Conditions

  • Turn keyswitch OFF.
  • Remove the VGT actuator from the turbocharger.

Action

Inspect the sector gear on the turbocharger for damaged or broken gear teeth.

  • Move the sector gear lever on the turbocharger housing up and down from stop to stop. Check for smooth movement between the stops.

There will be an initial friction force that must be overcome before the actuator lever will move. Once movement is started, the actuator lever must move to the other stop position by hand.

Refer to Procedure 010-134 in the Associated Procedures Table.

Nozzle movement meet the requirements found in Procedure 010-134 using sector gauge gear?
YES NO
No Repair

A turbocharger mechanical malfunction has been detected.

Note: This malfunction can be caused by debris exiting the engine, causing the turbocharger nozzle to stop moving. Inspect the base engine components for damage.

Refer to Procedure 010-134 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for active Fault Code 4728.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for active Fault Code 4728.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4728 active?
YES NO

Replace the VGT actuator.

Refer to Procedure 010-134 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Check for progressive damage to the aftertreatment system.

Conditions

  • Refer to Procedure 014-017 in the Associated Procedures Table.

Action

Check for damage to the aftertreatment system.

Peform the aftertreatment initial check procedure to test for a malfunctioning diesel particulate filter.

  • Refer to Procedure 014-017 in the Associated Procedures Table.

Progressive damage to the aftertreatment system detected?
YES NO

Replace the damaged aftertreatment system component(s).

Refer to Procedure 011-050 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4736 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4736 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4736 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor has been detected.

Replace the Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4737 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4737 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4737 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor has been detected.

Replace the Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 4738 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4738 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4738 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor has been detected.

Replace the Aftertreatment Diesel Exhaust Fluid Tank Level/Temperature/Quality Sensor.

See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4739 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4739 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4739 active or inactive with more than one count logged in the last 25 engine hours?
YES NO

A damaged aftertreatment diesel exhaust fluid (DEF) tank level/temperature/quality sensor has been detected.

Replace the aftertreatment DEF tank level/temperature/quality sensor. See equipment manufacturer service information.

 No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4746 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4746 active or more than two inactive counts?
 | STEP 1B. Check for low aftertreatment diesel exhaust fluid (DEF) tank level. | Aftertreatment DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
 | STEP 1C. Check for related fault codes. | Fault Code 3574, 3575, 3569, or 3596 active or more than two inactive counts?
STEP 2. | Check the aftertreatment DEF tank and filter. |
 | STEP 2A. Check the aftertreatment DEF tank. | Aftertreatment DEF tank and vent clean and free of debris?
 | STEP 2B. Inspect the aftertreatment DEF tank filter for blockage. | Aftertreatment DEF tank filter blocked?
STEP 3. | Check the aftertreatment DEF dosing unit operation. |
 | STEP 3A. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications found in Procedure 011-063?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4746 active or more than two inactive counts?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for low aftertreatment DEF tank level.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Make sure the aftertreatment DEF tank is not empty and the tank level gauge is accurate.

Use INSITE™ electronic service tool to read the fault codes.

  • Check for the following active Fault Code: 1673, 3497, or 3498.

Aftertreatment DEF tank empty and/or Fault Code 1673, 3497, or 3498 active?
YES NO

Fill the DEF tank.

 No Repair

Go to 4A

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3574, 3575, 3569, or 3596 active or more than two inactive counts?
YES NO

Troubleshoot occurrences of Fault Code 3574, 3575, 3569, or 3596 before troubleshooting Fault Code 4746.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DEF tank and filter.

Guided Step 2A - Check the aftertreatment DEF tank.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment DEF tank.

  • Check the aftertreatment DEF tank for debris or foreign particles.
  • Check the aftertreatment DEF tank vent for crystallization buildup and clogging.

Aftertreatment DEF tank and vent clean and free of debris?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the aftertreatment DEF tank filter for blockage.

Conditions

  • Turn keyswitch OFF.
  • Completely drain the DEF tank. Remove the dosing unit assembly from the aftertreatment DEF tank. Refer to Procedure 011-058 in the Associated Procedures Table.

Action

Inspect the aftertreatment DEF tank filter for signs of blockage or buildup.

Aftertreatment DEF tank filter blocked?
YES NO

Replace the aftertreatment DEF dosing unit assembly.

Refer to Procedure 011-058 in the Associated Procedures Table.

Clean the aftertreatment DEF tank thoroughly. Fill the tank to approximately half full. Use certified aftertreatment DEF.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment DEF dosing unit operation.

Guided Step 3A - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all aftertreatment DEF lines and electrical connectors to the dosing unit and aftertreatment DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Aftertreatment DEF Doser Pump Override Test, under ECM Diagnostics Tests.

  • Use the following procedure for instructions and specifications. Refer to Procedure 011-063 in the Associated Procedures Table.

The aftertreatment DEF dosing valve must be removed and placed in a measuring container having greater than a 1.5 liter [50 oz] capacity to run the Aftertreatment DEF Doser Pump Override Test.

Aftertreatment DEF dosing unit operates according to the specifications found in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit assembly.

Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4749 - Aftertreatment Outlet Oxygen - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Air Intake Restriction | Refer to Procedure 010-031 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Exhaust Transfer Tubes | Refer to Procedure 011-103 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4749 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887, 2771, 3583, 3681, or 3749 active?
 | STEP 1C. Verify proper installation of the aftertreatment outlet mono-nitrogen oxides (NOx) sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for active fault codes. | High active or inactive counts of Fault Code 5951, 5952, 5953, 6238, 741, 742, 743, or 687?
 | STEP 2B. Check for active fault codes. | High active or inactive counts of fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve system?
 | STEP 2C. Check for active fault codes. | High active or inactive counts of fault codes related to the fuel pump or fuel injectors?
STEP 3. | Check the charge-air cooler outlet pressure sensor. |
 | STEP 3A. Check the charger-air cooler outlet pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] or mechanical gauge reading?
STEP 4. | Check the air intake system for leaks. |
 | STEP 4A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charger-air system?
 | STEP 4B. Check for a restricted charger-air cooler. | Charge-air cooler restriction within specifications?
 | STEP 4C. Check the EGR system for leaks and restrictions. | Leaks or restrictions present in the EGR system?
 | STEP 4D. Check the exhaust system for leaks. | Leaks found in the exhaust system?
STEP 5. | Check for restriction. |
 | STEP 5A. Check the exhaust system restriction. | Exhaust restriction within specifications?
 | STEP 5B. Check the intake restriction. | Air intake restriction within specifications?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4749 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771, 3583, 3681, or 3749 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify proper installation of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

Inspect the aftertreatment outlet NOx sensor for proper installation.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment outlet NOx sensor.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 6A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 5951, 5952, 5953, 6238, 741, 742, 743, or 687?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or the EGR valve.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes related to the turbocharger or EGR valve system?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2C

Guided Step 2C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the fuel pump or fuel injectors.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes related to the fuel pump or fuel injectors?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 3 - Check the charge-air cooler outlet pressure sensor.

Guided Step 3A - Check the charge-air cooler outlet pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical charge-air cooler outlet pressure gauge to the engine as close to the charge-air cooler outlet pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for charge-air cooler outlet pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the charge-air cooler outlet temperature/pressure sensor. Refer to Procedure 019-560 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the air intake system for leaks.

Guided Step 4A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and intake manifold.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect charge-air cooler clamps to make sure they are tighte.
  • Inspect the charge-air plumbing for cracks.
  • Inspect the drain petcock.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, as necessary.

Go to 4C

Go to 6A

Guided Step 4C - Check the EGR system for leaks and restrictions.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system for plumbing leaks and restrictions.

  • Check the exhaust transfer tube for leaks and restrictions. Refer to Procedure 011-103 in the Associated Procedures Table.
  • Check the EGR differential pressure sensor for leaks and the mounting surface. It can be necessary to remove the EGR differential pressure sensor to check the o-rings for damage. Refer to Procedure 019-370 in the Associated Procedures Table.
  • Leaks can be noted by traces of soot.

Leaks or restrictions present in the EGR system?
YES NO

Repair or replace the malfunctioning component.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Verify the exhaust system does not have any leaks.

Inspect the exhaust system for leaks. Refer to Procedure 011-56 in the Associated Procedures Table.

Leaks found in exhaust system?
YES NO

Repair exhaust leaks. Refer to Procedure 011-56 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check for restriction.

Guided Step 5A - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust system within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake within specifications?
YES NO

A damaged aftertreatment outlet NOx sensor has been detected.

  • Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Repair or replace the restricted component.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4751 - Aftertreatment Outlet Oxygen - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Air Intake Restriction | Refer to Procedure 010-031 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Exhaust Transfer Tubes | Refer to Procedure 011-103 | ISV5.0 CM3230 V104 | 4367291
EGR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4751 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887, 2771, 3583, 3681, or 3749 active?
 | STEP 1C. Verify proper installation of the aftertreatment outlet mono-nitrogen oxides (NOx) sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for active fault codes. | High active or inactive counts of Fault Code 5952, 5953, 6238, 741, 742, 743, or 687?
 | STEP 2B. Check for active fault codes. | High active or inactive counts of fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve system?
 | STEP 2C. Check for active fault codes. | High active or inactive counts of fault codes related to the fuel pump or fuel injectors?
STEP 3. | Check the charge-air cooler outlet pressure sensor. |
 | STEP 3A. Check the charger-air cooler outlet pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] or mechanical gauge reading?
STEP 4. | Check the air intake system for leaks. |
 | STEP 4A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charger-air system?
 | STEP 4B. Check for a restricted charger-air cooler. | Charge-air cooler restriction within specifications?
 | STEP 4C. Check the EGR system for leaks and restrictions. | Leaks or restrictions present in the EGR system?
 | STEP 4D. Check the exhaust system for leaks. | Leaks found in the exhaust system?
STEP 5. | Check for restriction. |
 | STEP 5A. Check the exhaust system restriction. | Exhaust restriction within specifications?
 | STEP 5B. Check the intake restriction. | Air intake restriction within specifications?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4751 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771, 3583, 3681, or 3749 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify proper installation of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

Inspect the aftertreatment outlet NOx sensor for proper installation.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO
No Repair

Properly install the aftertreatment outlet NOx sensor.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 2A

Go to 6A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 5952, 5953, 6238, 741, 742, 743, or 687?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2B

Guided Step 2B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or the EGR valve.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes related to the turbocharger or EGR valve system?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2C

Guided Step 2C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the fuel pump or fuel injectors.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes related to the fuel pump or fuel injectors?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 3A

Guided Step 3 - Check the charge-air cooler outlet pressure sensor.

Guided Step 3A - Check the charge-air cooler outlet pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical charge-air cooler outlet pressure gauge to the engine as close to the charge-air cooler outlet pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger and compare INSITE™ electronic service tool reading for charge-air cooler outlet pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the charge-air cooler outlet temperature/pressure sensor. Refer to Procedure 019-560 in the Associated Procedures Table.

Go to 4A

Go to 6A

Guided Step 4 - Check the air intake system for leaks.

Guided Step 4A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and intake manifold.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect charge-air cooler clamps to make sure they are tighte.
  • Inspect the charge-air plumbing for cracks.
  • Inspect the drain petcock.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, as necessary.

Go to 4C

Go to 6A

Guided Step 4C - Check the EGR system for leaks and restrictions.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system for plumbing leaks and restrictions.

  • Check the exhaust transfer tube for leaks and restrictions. Refer to Procedure 011-103 in the Associated Procedures Table.
  • Check the EGR differential pressure sensor for leaks and the mounting surface. It can be necessary to remove the EGR differential pressure sensor to check the o-rings for damage. Refer to Procedure 019-370 in the Associated Procedures Table.
  • Leaks can be noted by traces of soot.

Leaks or restrictions present in the EGR system?
YES NO

Repair or replace the malfunctioning component.

 No Repair

Go to 6A

Go to 4D

Guided Step 4D - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Verify the exhaust system does not have any leaks.

Inspect the exhaust system for leaks. Refer to Procedure 011-056 in the Associated Procedures Table.

Leaks found in exhaust system?
YES NO

Repair exhaust leaks. Refer to Procedure 011-056 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check for restriction.

Guided Step 5A - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust system within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 5B

Go to 6A

Guided Step 5B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake within specifications?
YES NO

A damaged aftertreatment outlet NOx sensor has been detected.

  • Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Repair or replace the restricted component.

Go to 6A

Go to 6A

Guided Step 6 - Check ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jan-2015


FAULT CODE 4769 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level Sensor - Abnormal Rate of Change

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1668, 1669, 1673, 3242, 3497, 4679, 4738, or 4739 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault codes. | Fault Code 4769 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the diesel exhaust fluid (DEF) tank. |
 | STEP 2A. Check the DEF tank level. | Sensor covered by fluid and fluid is not frozen?
 | STEP 2B. Check the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor. | Sensor present and not damaged?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1668, 1669, 1673, 3242, 3497, 4679, 4738, or 4739 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4769 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the DEF tank.

Guided Step 2A - Check the DEF tank level.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF tank level.

  • Visually check that the aftertreatment DEF tank level/temperature/quality sensor is covered by the fluid.
  • Check to see if DEF is not frozen.

Sensor covered by fluid and fluid is not frozen?

YES NO
No Repair

Fill the tank with DEF to cover the sensor.

If the fluid is frozen, check for a tank heating malfunction. See equipment manufacturer service information for tank heating hardware.

Go to 2B

Go to 3A

Guided Step 2B - Check the aftertreatment diesel exhaust fluid tank level/temperature/quality sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check the aftertreatment DEF tank level/temperature/quality sensor.

  • Check the aftertreatment DEF tank level/temperature/quality sensor is present and has not been damaged.

Sensor present and not damaged?

YES NO

An internal error has been detected in the aftertreatment DEF tank level/temperature/quality sensor.

Replace the aftertreatment DEF tank level/temperature/quality sensor.

See equipment manufacturer service information.

A missing or damaged aftertreatment DEF tank level/temperature/quality sensor has been detected.

Repair or replace the aftertreatment DEF tank level/temperature/quality sensor.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 5278 - Aftertreatment 1 Diesel Exhaust Fluid Dosing System Frozen - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5278 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for an active fault code. | Fault Code 197, 1683, 1684, 2448, 3237, 3238, 3242, 3576, or 6626 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the aftertreatment DEF line heater. | Between 2 and 100 ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5278 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 197, 1683, 1684, 2448, 3237, 3238, 3242, 3576, or 6626 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment DEF line heater and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater from the harness.

Action

Inspect the aftertreatment DEF line heater connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open circuit in the aftertreatment DEF line heater.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check the resistance of the aftertreatment DEF line heater 1.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 100 ohms?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

An open circuit has been detected in the aftertreatment DEF line heater.

Replace the aftertreatment DEF line heater. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Jul-2015


FAULT CODE 5655 - Aftertreatment 1 SCR Conversion Efficiency - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Valve | Refer to Procedure 011-059 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5655 active?
 | STEP 1B. Check for active aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault Code 1885, 1887, 2771, 3228, 3232, 3649, 3545, 3583, 3681, 3682, 3717, 3718, 3725, 3748, 3849, 4452, 4749, 4751, or 5656 active?
 | STEP 1C. Check for active aftertreatment selective catalytic reduction (SCR) temperature sensor fault codes. | Fault codes related to the aftertreatment SCR temperature sensors active?
 | STEP 1D. Check for active diesel exhaust fluid (DEF) dosing system fault codes. | DEF dosing system related fault codes active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the exhaust system for leaks. | Exhaust system leaks found?
 | STEP 2B. Inspect the DEF dosing system for external leaks | External leaks detected in the system?
 | STEP 2C. Check the DEF quality. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2D. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
 | STEP 2E. Check the aftertreatment DEF dosing valve for proper operation. | DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment SCR Performance Test. | Aftertreatment SCR Performance Test complete?
 | STEP 3B. Check for DEF deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check the aftertreatment SCR performance test results. |
 | STEP 4A. Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test. | Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
 | STEP 4B. Check the status of the Aftertreatment SCR Catalyst Test. | Aftertreatment SCR Catalyst Test pass?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5655 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 1887, 2771, 3228, 3232, 3649, 3545, 3583, 3681, 3682, 3717, 3718, 3725, 3748, 3849, 4452, 4749, 4751, or 5656 active?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active aftertreatment SCR temperature sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault codes related to the aftertreatment SCR temperature sensors active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active DEF dosing system fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes relating to the DEF dosing system.

  • Use INSITE™ electronic service tool to read the fault codes.

DEF dosing system related fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check the exhaust for leaks.

  • Inspect the entire exhaust system between the turbocharger outlet and the SCR outlet. Inspect for loose connections, leaking connections, and broken exhaust system components.

Exhaust system leaks found?
YES NO

Repair or replace the damaged exhaust system component.

 No Repair

Go to 2B

Go to 2B

Guided Step 2B - Inspect the DEF dosing system for external leaks.

Conditions

  • Turn keyswitch OFF.

Action

Inspect all components of the aftertreatment DEF dosing system for signs of external leaks, including:

  • Tank connectors
  • Dosing unit and dosing unit connectors
  • Lines
  • Dosing valve.

DEF will form white deposits around leaky fittings.

External leaks detected in the system?
YES NO

Repair the source of the external leak.

 No Repair

Go to 2C

Go to 2C

Guided Step 2C - Check the DEF quality.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination
  • Use the Cummins® DEF Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank. Rinse the tank with water.

Fill the DEF tank with pure DEF.

Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2D

Go to 2D

Guided Step 2D - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the DEF Doser Pump Override Test found under ECM Diagnostic Tests.

Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to perform the DEF Doser Pump Override Test. Make sure the DEF dosing valve is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operates according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. See equipment manufacturer service information.

Go to 2E

Go to 3A

Guided Step 2E - Check the aftertreatment DEF dosing valve for proper operation.

Conditions

  • Connect all DEF lines and electrical connectors to the dosing unit and DEF tank.
  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment DEF dosing valve for proper operation.

  • Use INSITE™ electronic service tool to perform the DEF System Leak Test found under ECM Diagnostic Tests. Refer to Procedure Refer to Procedure 011-063 in the Associated Procedures Table.

DEF leaking from the aftertreatment DEF dosing valve during the system leak test?
YES NO

A leaking aftertreatment DEF dosing valve has been detected.

Replace the aftertreatment DEF dosing valve. Refer to Procedure 011-059 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Perform the Aftertreatment SCR Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON. Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Use INSITE™ electronic service tool to perform the Aftertreatment SCR Performance Test.

Aftertreatment SCR Performance Test complete?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for DEF deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-098 in the Associated Procedures Table.

Repeat the Aftertreatment SCR Performance Test.

Go to 4A

Go to 4A

Guided Step 4 - Check the Aftertreatment SCR Performance Test results.

Guided Step 4A - Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
YES NO
No Repair

An in-range malfunction has been detected in the Aftertreatment Outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the status of the Aftertreatment SCR Catalyst Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Test portion of the SCR performance test.

Aftertreatment SCR Catalyst Test pass?
YES NO
No Repair

A malfunctioning aftertreatment SCR catalyst has been detected.

Replace the aftertreatment SCR catalyst. Refer to Procedure 011-098 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5672 - Aftertreatment 1 Diesel Exhaust Fluid Tank Temperature - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5672 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5672 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5673 - Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5673 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5673 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5674 - Aftertreatment Diesel Exhaust Fluid Controller Sensor Supply Voltage - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5674 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5674 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5675 - Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 477, 478, 3557, 3558, 3559, 3561, 4248, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5675 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 477, 478, 3557, 3558, 3559, 3561, 4248, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5675 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5676 - Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for Fault Code 5676. | Fault Code 5676 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for Fault Code 5676.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5676 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5677 - Aftertreatment 1 Diesel Exhaust Fluid Controller Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5677 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5677 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5678 - Aftertreatment 1 Diesel Exhaust Fluid Tank Level - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5678 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5678 active?
YES NO

A malfunctioning diesel exhaust fluid dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5689 - Aftertreatment 1 Outlet NOx Sensor - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5689 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1887, 2771, 3583, 3681, or 3749 active?
 | STEP 1C. Verify proper installation of the aftertreatment outlet mono-nitrogen oxides (NOx) sensor. | Aftertreatment outlet NOx sensor properly installed?
STEP 2. | Check the exhaust system for leaks. |
 | STEP 2A. Check the exhaust system for leaks. | Leaks found in exhaust system?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5689 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1887, 2771, 3583, 3681, or 3749 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Verify proper installation of the aftertreatment outlet NOx sensor.

Conditions

  • Turn keyswitch OFF.

Action

Verify proper installation of the aftertreatment outlet NOx sensor.

Inspect the aftertreatment outlet NOx sensor for proper installation.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Aftertreatment outlet NOx sensor properly installed?
YES NO

A damaged aftertreatment outlet NOx sensor has been detected.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Properly install the aftertreatment outlet NOx sensor.

  • Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 3A

Go to 2A

Guided Step 2 - Check the exhaust system for leaks.

Guided Step 2A - Check the exhaust system for leaks.

Conditions

  • Turn keyswitch OFF.

Action

Verify the exhaust system does not have any leaks.

Inspect the exhaust system for leaks. Refer to Procedure 011-056 in the Associated Procedures Table.

Leaks found in exhaust system?
YES NO

Repair exhaust leaks. Refer to Procedure 011-056 in the Associated Procedures Table.

A damaged aftertreatment outlet NOx sensor has been detected.

Replace the aftertreatment outlet NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5715 - Aftertreatment 1 Diesel Particulate Filter Differential Pressure Sensor - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Particulate Filter | Refer to Procedure 011-041 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 1879 and 1881. | Fault Code 1879 or 1881 active?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes. |
 | STEP 2A. Check the aftertreatment DPF differential pressure sensor tubes. | Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
 | STEP 2B. Monitor the aftertreatment DPF differential pressure sensor voltage with an electronic service tool. | Aftertreatment DPF differential pressure sensor voltage reading within specifications of Procedure 019-443?
STEP 3. | Check the presence of the aftertreatment DPF. |
 | STEP 3A. Inspect the aftertreatment DPF. | Tampering or removal of the aftertreatment system detected?
STEP 4. | Check the aftertreatment DPF differential pressure sensor and circuit. |
 | STEP 4A. Inspect the aftertreatment DPF differential pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 1881 active?
 | STEP 4C. Check the circuit response. | Fault Code 1879 active?
STEP 5. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 5A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 5B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 5C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 5D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 5E. Check the aftertreatment differential pressure sensor voltage value. | Value changed?
STEP 6. | Check the ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 1879 and 1881.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1879 or 1881 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment DPF differential pressure sensor tubes.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the aftertreatment DPF differential pressure sensor tubes.

  • Make sure the tubes are installed correctly (not reversed).
  • Make sure both ends of the tubes are securely connected.
  • Inspect the tubes for leaks or damage.
  • Inspect the tubes for blockage. Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes damaged, disconnected, or blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Monitor the aftertreatment DPF differential pressure sensor voltage with an electronic service tool.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Leave engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment DPF differential pressure sensor voltage with an electronic service tool.

  • An exhaust ventilation system connected to the exhaust can cause the differential pressure sensor to read incorrectly. Be sure to remove any ventilation or vacuum equipment from the exhaust before reading the differential pressure sensor value with INSITE™ electronic service tool.
  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor voltage reading within specifications of Procedure 019-443?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 3A

Go to 6A

Guided Step 3 - Check the presence of the aftertreatment DPF.

Guided Step 3A - Inspect the aftertreatment DPF.

Conditions

  • Turn keyswitch OFF.
  • Remove the aftertreatment DPF. Refer to Procedure 011-041 in the Associated Procedures Table.

Action

Inspect the aftertreatment DPF.

Inspect the aftertreatment system to determine if the aftertreatment DPF has been tampered with or has been removed from the exhaust system.

  • Refer to Procedure 011-041 in the Associated Procedures Table.

Tampering or removal of the aftertreatment system detected?
YES NO

Install the correct aftertreatment system for the vehicle.

Refer to Procedure 011-041 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Check the aftertreatment DPF differential pressure sensor and circuit.

Guided Step 4A - Inspect the aftertreatment DPF differential pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF differential pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 active?
YES | NO
No Repair | No Repair

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF differential pressure 5 volt SUPPLY pin and the aftertreatment DPF differential pressure SIGNAL pin at the aftertreatment DPF differential pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1879 active?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5A

Guided Step 5 - Check the ECM and OEM harness.

Guided Step 5A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF differential pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF differential pressure sensor connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5C

Go to 6A

Guided Step 5C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected on the SIGNAL wire in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5D

Go to 6A

Guided Step 5D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 5E

Go to 6A

Guided Step 5E - Check the aftertreatment differential pressure sensor voltage value.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for a change in value.

  • Use INSITE™ electronic service tool to monitor the aftertreatment differential pressure sensor voltage.
  • Perform a snap acceleration.

Value changed?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check the ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 19-Feb-2015


FAULT CODE 5716 - Aftertreatment 1 Diesel Particulate Filter Outlet Pressure - Abnormal Rate of Change

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filter Differential Pressure Sensor Tubes | Refer to Procedure 011-047 | ISV5.0 CM3230 V104 | 4367291
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Particulate Filer Differential Pressure Sensor | Refer to Procedure 019-443 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for sensor circuit fault codes. |
 | STEP 1A. Check for Fault Codes 3133 and 3134. | Fault Code 3133 or 3134 active?
STEP 2. | Check the aftertreatment system. |
 | STEP 2A. Check the aftertreatment diesel particulate filter (DPF) differential pressure sensor tubes for blockage. | Aftertreatment DPF differential pressure sensor tubes blocked?
 | STEP 2B. Monitor the aftertreatment DPF outlet pressure sensor voltage with an electronic service tool. | Aftertreatment DPF outlet pressure sensor voltage reading within specifications of Procedure 019-443 with key ON and engine OFF?
 | STEP 2C. Check for deposits in the decomposition tube. | Excessive diesel exhaust fluid (DEF) deposits found inside the decomposition tube?
STEP 3. | Check the aftertreatment DPF outlet pressure sensor and circuit. |
 | STEP 3A. Inspect the aftertreatment DPF outlet pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 3134 active?
 | STEP 3C. Check the circuit response. | Fault Code 3133 active?
STEP 4. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 4A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check for resistance in the OEM harness. | Less than 10 ohms?
 | STEP 4C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 4D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 4E. Check the aftertreatment outlet pressure sensor voltage value. | Value changed?
STEP 5. | Check exhaust system restriction. |
 | STEP 5A. Check exhaust system restriction. | Exhaust restriction within specifications?
STEP 6. | Check the ECM calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for Fault Codes 3133 and 3134.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3133 or 3134 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment system.

Guided Step 2A - Check the aftertreatment DPF differential pressure sensor tubes for blockage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor tubes.

Action

Check for plugged aftertreatment DPF differential pressure sensor tubes.

  • Inspect tubes for blockage.
  • Refer to Procedure 011-047 in the Associated Procedures Table.

Aftertreatment DPF differential pressure sensor tubes blocked?
YES NO

Repair or replace the aftertreatment DPF differential pressure sensor tubes.

  • Refer to Procedure 011-047 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 2B

Guided Step 2B - Monitor the aftertreatment DPF outlet pressure sensor voltage with an electronic service tool.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Leave engine OFF.
  • Connect INSITE™ electronic service tool.

Action

Monitor the aftertreatment DPF outlet pressure sensor voltage with an electronic service tool.

  • An exhaust ventilation system connected to the exhaust can cause the outlet pressure sensor to read incorrectly. Be sure to remove any ventilation or vacuum equipment from the exhaust before reading the outlet pressure sensor value with INSITE™ electronic service tool.
  • Refer to Procedure 019-443 in the Associated Procedures Table.

Aftertreatment DPF outlet pressure sensor voltage reading within specifications of Procedure 019-443 with key ON and engine OFF?

YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor.

  • Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 2C

Go to 6A

Guided Step 2C - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the aftertreatment decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube. Refer to Procedure 011-098 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 3A

Guided Step 3 - Check the aftertreatment DPF outlet pressure sensor and circuit.

Guided Step 3A - Inspect the aftertreatment DPF outlet pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential pressure sensor from the OEM harness.

Action

Inspect the OEM harness and aftertreatment DPF outlet pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1881 will also be active.

Fault Code 3134 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF differential/outlet pressure sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the aftertreatment DPF outlet pressure 5 volt SUPPLY pin and the aftertreatment DPF outlet pressure SIGNAL pin at the aftertreatment DPF outlet pressure sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 1881 will also be active.

Fault Code 3133 active?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and OEM harness.

Guided Step 4A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 6A

Go to 4B

Guided Step 4B - Check for resistance in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for resistance in the circuit.

  • Measure the resistance between the OEM harness ECM connector aftertreatment DPF outlet pressure sensor SIGNAL pin and the OEM harness aftertreatment DPF outlet pressure sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

High resistance in the signal circuit has been detected in the OEM harness.

Troubleshoot each harness connector in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4C

Go to 6A

Guided Step 4C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the aftertreatment DPF differential pressure sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit has been detected on the SIGNAL wire in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit-to-ground.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4D

Go to 6A

Guided Step 4D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the aftertreatment DPF outlet pressure sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the aftertreatment DPF outlet pressure sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4E

Go to 6A

Guided Step 4E - Check the aftertreatment outlet pressure sensor voltage value.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for a change in value.

  • Use INSITE™ electronic service tool to monitor the aftertreatment outlet pressure sensor voltage.
  • Perform a snap acceleration.

Value changed?
YES NO
No Repair

Replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 5 - Check exhaust system restriction.

Guided Step 5A - Check exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO

Replace the aftertreatment DPF differential pressure sensor.

Refer to Procedure 019-443 in the Associated Procedures Table.

Continue to investigate the cause of the high exhaust restriction.

Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 6A

Go to 6A

Guided Step 6 - Check the ECM calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5736 - Switched Output Number 2 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6257 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5736 active?
STEP 2. | Check the smart power relay circuit. |
 | STEP 2A. Inspect the smart power relay and electrical connections. | Dirty or damaged pins?
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit to battery. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5736 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Start the engine. Let it idle for 1 minute.

Fault Code 6257 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Connect all components.

Action

Check the ECM.

  • Start the engine. Allow it to idle for 1 minute.

Fault Code 5736 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the smart power relay circuit.

Guided Step 2A - Inspect the smart power relay and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the smart power relay from the OEM harness.

Action

Inspect the smart power relay and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the smart power relay or OEM harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the smart power relay from the harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the smart power relay RETURN pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the smart power relay return circuit.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the smart power relay from the harness.
  • Disconnect the OEM harness from ECM.

Action

Check for a short circuit to battery.

  • Measure the resistance between the smart power relay RETURN pin at the OEM harness ECM connect and battery positive (+).

Greater than 100k ohms?
YES NO
No Repair

A short circuit to battery has been detected in the smart power relay return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5736 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the smart power relay.

See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jan-2015


FAULT CODE 5868 - Aftertreatment 1 SCR Feedback Control Status - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust System Diagnostics | Refer to Procedure 011-056 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Diesel Exhaust Fluid Dosing Unit Override Test | Refer to Procedure 011-063 | ISV5.0 CM3230 V104 | 4367291
Decomposition Tube and SCR Catalyst Assembly | Refer to Procedure 011-098 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5868 active?
 | STEP 1B. Check for active fault codes. | Any diesel exhaust fluid (DEF) dosing related fault codes active?
 | STEP 1C. Check for aftertreatment mono-nitrogen oxides (NOx) sensor fault codes. | Fault Code 1885, 1887, 2771, 3228, 3232, 3649, 3545, 3583, 3681, 3682, 3717, 3718, 3725, 3748, 3849, 4452, 4749, 4751, or 5656 active?
STEP 2. | Check the DEF dosing system. |
 | STEP 2A. Check the DEF for contamination or debris. | DEF free from contamination and within the specifications outlined in Procedure 011-056?
 | STEP 2B. Check the aftertreatment DEF dosing unit for proper operation. | Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
STEP 3. | Check the aftertreatment system. |
 | STEP 3A. Perform the Aftertreatment Selective Catalytic Reduction (SCR) Performance Test. | Aftertreatment SCR Performance Test complete?
 | STEP 3B. Check for deposits in the decomposition tube. | Excessive DEF deposits found inside the decomposition tube?
STEP 4. | Check the Aftertreatment SCR Performance Test results. |
 | STEP 4A. Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test. | Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
 | STEP 4B. Check the status of the Aftertreatment SCR Catalyst Test. | Aftertreatment SCR Catalyst Test pass?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5868 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any DEF dosing related fault codes active?
YES NO

Troubleshoot all DEF dosing related fault codes before troubleshooting Fault Code 5868.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for aftertreatment NOx sensor fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for aftertreatment NOx sensor fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 1887, 2771, 3228, 3232, 3649, 3545, 3583, 3681, 3682, 3717, 3718, 3725, 3748, 3849, 4452, 4749, 4751, or 5656 active?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the DEF dosing system.

Guided Step 2A - Check the DEF for contamination or debris.

Conditions

  • Turn keyswitch OFF.

Action

Check the DEF quality.

  • Inspect the DEF in the tank for signs of debris or contamination.
  • Use the Cummins® Diesel Exhaust Fluid Refractometer Service Tool, Part Number 4919554, to test the DEF concentration. Refer to Procedure 011-056 in the Associated Procedures Table.

DEF free from contamination and within the specifications outlined in Procedure 011-056?
YES NO
No Repair

The fluid in the DEF tank is not pure DEF, or the DEF is diluted or degraded.

Completely drain the DEF tank. Rinse the tank with water.

Refill the DEF tank with pure DEF. Refer to Procedure 011-056 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Check the aftertreatment DEF dosing unit for proper operation.

Conditions

  • Remove the aftertreatment DEF dosing valve from the decomposition tube.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser Pump Override Test found under ECM Diagnostic Tests.

  • Refer to Procedure 011-063 in the Associated Procedures Table.

The DEF dosing valve must be removed and placed in a measuring container in order to run the Diesel Exhaust Fluid Doser Pump Override Test. Make sure the DEF dosing unit is not plugged and DEF is flowing from all holes.

Aftertreatment DEF dosing unit operate according to the specifications in Procedure 011-063?
YES NO
No Repair

Replace the aftertreatment DEF dosing unit. Refer to Procedure 011-058 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the aftertreatment system.

Guided Step 3A - Check the Aftertreatment SCR Performance Test.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check the aftertreatment system.

  • Perform the Aftertreatment SCR Performance Test.
  • Use INSITE™ electronic service tool.

Aftertreatment SCR Performance Test complete?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for deposits in the decomposition tube.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Inspect the decomposition tube for deposits.

  • Remove the decomposition tube from the vehicle.
  • Inspect for excessive DEF deposits.
  • Refer to Procedure 011-098 in the Associated Procedures Table.

Excessive DEF deposits found inside the decomposition tube?
YES NO

Clean and install the decomposition tube.

Refer to Procedure 011-098 in the Associated Procedures Table.

After cleaning the decomposition tube of deposits, it is necessary to run the Aftertreatment SCR Performance Test again.

Perform the Aftertreatment SCR Performance Test again.

Go to 4A

Go to 4A

Guided Step 4 - Check the Aftertreatment SCR Performance Test results.

Guided Step 4A - Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Outlet NOx Sensor Test portion of the SCR Performance Test.

Aftertreatment SCR Catalyst Outlet NOx Sensor Test pass?
YES NO
No Repair

An in-range malfunction has been detected in the aftertreatment outlet NOx sensor.

Replace the aftertreatment outlet NOx sensor.

Refer to Procedure 019-451 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the status of the Aftertreatment SCR Catalyst Test.

Conditions

  • Connect INSITE™ electronic service tool.

Action

Check the results of the Aftertreatment SCR Performance Test.

  • Check the status of the Aftertreatment SCR Catalyst Test portion of the SCR Performance Test.

Aftertreatment SCR Catalyst Test pass?
YES NO
No Repair

A malfunctioning aftertreatment SCR catalyst has been detected.

Replace the aftertreatment SCR catalyst.

Refer to Procedure 011-098 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-May-2017


FAULT CODE 5874 - Engine Control Module Calibration Memory (ROM) Corruption - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 111 active?
STEP 2. | Recalibrate the engine control module (ECM). |
 | STEP 2A. Recalibrate the ECM. | Fault Code 5874 active after recalibrating the ECM?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Repair complete.

Go to 2A

Guided Step 2 - Recalibrate the ECM.

Guided Step 2A - Recalibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 5874 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in Section 19.

No Repair

Repair complete.

Repair complete.

Last Modified: 30-Jun-2015


FAULT CODE 5879 - Electronic Throttle Control Actuator Driver Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5879 active?
STEP 2. | Check the intake throttle actuator motor and circuit. |
 | STEP 2A. Inspect the intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the intake throttle actuator motor. | Less than 15 ohms?
 | STEP 2B-1. Check for an open circuit in the intake throttle actuator motor. |
 | STEP 2B-2. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to a voltage source. | Less than 1.5 VDC?
 | STEP 3C. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5879 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the intake throttle actuator motor and circuit.

Guided Step 2A - Inspect the intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake throttle actuator from the engine harness.

Action

Inspect the intake throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the intake throttle actuator motor circuit.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake throttle actuator to the engine harness.
  • Disconnect the engine harness from the ECM.

Action

Check for an open circuit in the intake throttle actuator motor circuit.

  • Measure the resistance between the intake throttle actuator motor connector SIGNAL (+) pin and the intake throttle actuator motor connector SIGNAL (-) pin at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-1

Guided Step 2B-1 - Check for an open circuit in the intake throttle actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake throttle actuator from the engine harness.

Action

Check for an open circuit in the intake throttle actuator motor.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator motor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 15 ohms?
YES NO
No Repair

An open circuit has been detected in the intake throttle actuator motor circuit.

Replace the intake throttle actuator assembly.

Go to 2B-2

Go to 4A

Guided Step 2B-2 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (+) pin at the intake throttle actuator connector of the engine harness.
  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and the intake throttle actuator motor SIGNAL (-) pin at the intake throttle actuator connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to a voltage source.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.
  • Turn keyswitch ON.

Action

Check for a short circuit to a voltage source.

  • Measure the voltage between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the voltage between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Use the following procedure for multimeter usage information. Refer to Procedure 019-359 in Section 19.

Less than 1.5 VDC?
YES NO
No Repair

A short circuit to voltage has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the intake throttle actuator.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between the intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5881 - Electronic Throttle Control Actuator Driver Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Intake Throttle Actuator | Refer to Procedure 010-140 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 5881 active?
STEP 2. | Check the engine intake throttle actuator motor and circuit. |
 | STEP 2A. Inspect the engine intake throttle actuator motor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit to ground in the engine intake throttle actuator motor. | Greater than 100k ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit from pin-to-pin in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5881 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5881 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine intake throttle actuator motor and circuit.

Guided Step 2A - Inspect the engine intake throttle actuator motor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Inspect the engine intake throttle actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit to ground in the engine intake throttle actuator motor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake throttle actuator from the engine harness.

Action

Check for a short circuit to ground in the engine intake throttle actuator motor.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the engine intake throttle actuator.

Refer to Procedure 010-140 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine intake throttle actuator.

Action

Check for a short circuit to ground in the engine harness.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and engine block ground.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit from pin-to-pin in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine harness from the engine intake throttle actuator.

Action

Check for a short circuit from pin-to-pin in the engine harness.

  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (+) pin at the ECM connector of the engine harness and all other pins at the ECM connector.
  • Measure the resistance between the engine intake throttle actuator motor SIGNAL (-) pin at the ECM connector of the engine harness and all other pins at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5881 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Jan-2015


FAULT CODE 5884 - Internal Monitor Processor Performance - Monitor Support Malfunction Detected - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 111 active?
STEP 2. | Recalibrate the engine control module (ECM). |
 | STEP 2A. Recalibrate the ECM. | Fault Code 5884 active after recalibrating the ECM?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Repair complete.

Go to 2A

Guided Step 2 - Recalibrate the ECM.

Guided Step 2A - Recalibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to recalibrate the ECM with the latest engine calibration.

Fault Code 5884 active after recalibrating the ECM?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Repair complete.

Repair complete.

Last Modified: 30-Jun-2015


FAULT CODE 5951 - Engine Charge Air Cooler Outlet Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Air Intake Restriction | Refer to Procedure 010-031 | ISV5.0 CM3230 V104 | 4367291
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Turbocharger Compressor Intake Pressure/Temperature Sensor | Refer to Procedure 019-466 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Active or high inactive counts of Fault Code 595, 687, 691, 692, 693, 5952, or 5953?
 | STEP 1B. Check for active or inactive intake air throttle fault codes. | Active or high inactive counts of Fault Code 5879, 5881, 3539, 3541, or 3542?
STEP 2. | Check the barometric pressure sensor. |
 | STEP 2A. Verify the sensor accuracy. | INSITE™ electronic service tool reading within 51 mm-Hg [2 in-Hg] of local barometric pressure?
STEP 3. | Check the engine charge-air cooler outlet pressure/temperature sensor and circuit. |
 | STEP 3A. Inspect the engine charge-air cooler outlet pressure/temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Verify sensor accuracy. | INSITE™ electronic service tool reading for charge-air cooler outlet pressure 0 ±77 mm-Hg [0 ±3 in-Hg]?
 | STEP 3C. Check the circuit response. | Fault Code 5953 active?
 | STEP 3D. Check the circuit response. | Fault Code 5952 active?
 | STEP 3E. Check for a plugged engine charge-air cooler outlet pressure/temperature sensor. | Tip of the sensor have soot or carbon buildup?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 5953 active?
 | STEP 4C. Check the circuit response. | Fault Code 5952 active?
STEP 5. | Check the air intake system for leaks. |
 | STEP 5A. Check the charge-air cooler for leaks. | Air leak present?
 | STEP 5B. Check the charge-air cooler outlet, inlet, and connections for leaks. | Air leak present?
 | STEP 5C. Inspect the turbocharger compressor and turbine blades. | Damage or wear found on the turbocharger blades?
 | STEP 5D. Check for a restricted charge-air cooler. | Differential pressure across the charge-air cooler within specifications?
STEP 6. | Check for restriction. |
 | STEP 6A. Check exhaust restriction. | Exhaust restriction within specifications?
 | STEP 6B. Check the intake restriction. | Air intake restriction within specifications?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 595, 687, 691, 692, 693, 5952, or 5953?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 1B - Check for active or inactive intake air throttle fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or high inactive counts of Fault Code 5879, 5881, 3539, 3541, or 3542?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the barometric pressure sensor.

Guided Step 2A - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Start INSITE™ electronic service tool Data Monitor/Logger and compare the INSITE™ electronic service tool reading for barometric pressure to the local barometric pressure.

INSITE™ electronic service tool reading within 51-mm Hg [2 in-Hg] of local barometric pressure?
YES NO
No Repair

Replace the turbocharger compressor intake pressure sensor.

Refer to Procedure 019-466 in the Associated Procedures Table.

Go to 3A

Go to 7A

Guided Step 3 - Check the engine charge-air cooler outlet pressure/temperature sensor and circuit.

Guided Step 3A - Inspect the engine charge-air cooler outlet pressure/temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet pressure/temperature sensor from the engine harness.

Action

Inspect the charge-air cooler outlet pressure/temperature sensor connector and the engine harness connector for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the charge-air cooler outlet pressure/temperature sensor or harness connector.

  • Clean the connector and pins.
  • Replace the damaged section of harness or damaged charge-air cooler outlet pressure/temperature sensor. Use the circuit diagram or wiring diagram for all engine harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Refer to Procedure 019-560 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 3B

Guided Step 3B - Verify the sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Turn engine OFF.

Action

With the keyswitch ON and engine OFF, the charge-air cooler outlet pressure must read 0 ±77 mm-Hg [0 ±3 in-Hg].

  • Start INSITE™ electronic service tool Data Monitor/Logger. Read the INSITE™ electronic service tool reading for charge-air cooler outlet pressure (Charge-Air Cooler outlet Pressure).

INSITE™ electronic service tool reading for charge-air cooler outlet pressure is 0 ±77 mm-Hg [0 ±3 in-Hg]?
YES | NO
No Repair | No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet pressure/temperature sensor from the engine harness.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 active?
YES | NO
No Repair | No Repair

Go to 3D

Go to 4A

Guided Step 3D - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine charge-air cooler outlet pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine charge-air cooler outlet pressure +5 volt SUPPLY pin and the engine charge-air cooler outlet pressure SIGNAL pin at the engine charge-air cooler outlet pressure/temperature connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 active?
YES | NO
No Repair | No Repair

Go to 3E

Go to 4A

Guided Step 3E - Check for a plugged engine charge-air cooler outlet pressure/temperature sensor.

Conditions

  • Turn keyswitch OFF.

Action

Remove the charge-air cooler outlet pressure/temperature sensor. Inspect the tip of the sensor for soot or carbon buildup.

  • Refer to Procedure 019-560 in the Associated Procedures Table.

Tip of the sensor have soot or carbon buildup?
YES NO

Use compressed air to remove the soot or carbon buildup.

  • Refer to Procedure 019-560 in the Associated Procedures Table.

An in-range malfunction of the charge-air cooler outlet pressure/temperature sensor has been detected.

  • Refer to Procedure 019-560 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector. Repair the damaged pins.

Repair or replace the engine harness or replace the ECM, whichever has the damaged pins.

  • Flush the dirt, debris, or moisture from the connector pins. Install the appropriate connector seal if it is damaged or missing.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5953 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 7A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine charge-air cooler outlet pressure +5 volt SUPPLY pin and engine charge-air cooler outlet pressure SIGNAL pin at the ECM connector.

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5952 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 5 - Check the air intake system for leaks.

Guided Step 5A - Check the charge-air cooler for leaks.

Conditions

  • Operate engine.

Action

Check the charge-air cooler and connections for air leaks.

Air leak present?
YES NO

Repair or replace the leaking component. Refer to Procedure 010-027 in the Associated Procedures Table.

No Repair

Go to 7A

Go to 5B

Guided Step 5B - Check the charge-air cooler outlet, inlet, and connections for leaks.

Conditions

  • Operate the engine.

Action

Check for air leaks in connections and hoses between the turbocharger and charge-air cooler outlet inlet.

Air leak present?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 7A

Go to 5C

Guided Step 5C - Inspect the turbocharger compressor and turbine blades.

Conditions

  • Turn engine OFF.
  • Turn keyswitch ON.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger compressor and turbine blades for damage or wear.

  • Refer to Procedure 010-112 in the Associated Procedures Table.

Damage or wear found on the turbocharger blades?
YES NO

Refer to Procedure 010-112 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5D

Guided Step 5D - Check for a restricted charge-air cooler.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.

Action

Check the pressure differential across the charge-air cooler.

Refer to Procedure 010-027 in the Associated Procedures Table.

Differential pressure across the charge-air cooler within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, if necessary.

Go to 6A

Go to 7A

Guided Step 6 - Check for restriction.

Guided Step 6A - Check exhaust restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check exhaust restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Repair or replace the restricted components.

Go to 6B

Go to 7A

Guided Step 6B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6237 - Engine Charge Air Cooler Outlet Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Turbocharger, Variable Geometry | Refer to Procedure 010-112 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Active or inactive counts of Fault Code 5952, 5953, 741, 742, or 743?
 | STEP 1B. Check for active fault codes. | Active or inactive counts of fault codes related to the turbocharger, exhaust gas recirculation (EGR) valve, or fuel system?
 | STEP 1C. Check for active engine intake throttle fault codes. | Fault Code 5879, 5881, 3539, 3541, or 3542 active?
STEP 2. | Check the sensor accuracy. |
 | STEP 2A. Verify the sensor accuracy with a mechanical gauge. | Sensor reading within 17 kPa [2.5 psi]?
 | STEP 2B. Inspect the turbocharger compressor outlet for oil or fuel. | Engine oil or fuel contamination found in the turbocharger compressor outlet?
 | STEP 2D. Check the system for tampering. | Tampering detected?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 5952, 5953, 741, 742, or 743?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger, EGR valve, or fuel system.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of fault codes related to the turbocharger, EGR valve, or fuel system?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1C

Guided Step 1C - Check for active engine intake throttle fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active engine intake throttle fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879, 5881, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the sensor accuracy.

Guided Step 2A - Verify the sensor accuracy with a mechanical gauge.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Verify the sensor accuracy with a mechanical gauge.

  • Connect a mechanical pressure gauge to the engine.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine. Compare the charge-air cooler outlet pressure reading on the service tool monitor screen to the reading on the mechanical gauge.

Note: The engine may need to be loaded before the pressure readings can be compared.

Sensor reading within 17 kPa [2.5 psi]?
YES NO
No Repair

Replace the charge-air cooler outlet pressure sensor.

  • Refer to Procedure 019-560 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Inspect the turbocharger compressor outlet for oil or fuel.

Conditions

  • Turn keyswitch OFF.
  • Remove the plumbing from the turbocharger compressor outlet. See equipment manufacturer service information.

Action

Inspect the turbocharger compressor outlet.

  • Look for indications of oil or fuel in the turbocharger compressor outlet and connection.

Refer to Procedure 010-112 in the Associated Procedures Table.

Engine oil or fuel contamination found in the turbocharger compressor outlet?
YES NO

Inspect the turbocharger for damage.

  • Refer to Procedure 010-112 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the system for tampering.

Conditions

  • Turn keyswitch OFF.

Action

Check the turbocharger and fuel system for the following:

  • Variable geometry turbocharger tampering
  • Fuel system tampering
  • Fuel system add-on electronic devices.

Tampering detected?
YES NO

Remove tampering device.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6238 - Engine Charge Air Cooler Outlet Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Charge-Air Cooler | Refer to Procedure 010-027 | ISV5.0 CM3230 V104 | 4367291
Air Intake Restriction | Refer to Procedure 010-031 | ISV5.0 CM3230 V104 | 4367291
Exhaust Restriction | Refer to Procedure 011-009 | ISV5.0 CM3230 V104 | 4367291
Exhaust Transfer Tubes | Refer to Procedure 011-103 | ISV5.0 CM3230 V104 | 4367291
EFR Differential Pressure Sensor | Refer to Procedure 019-370 | ISV5.0 CM3230 V104 | 4367291
Engine Charge-Air Cooler Outlet Pressure/Temperature Sensor | Refer to Procedure 019-560 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | High active or inactive counts of Fault Code 5952, 5953, 687, 741, 742, or 743?
 | STEP 1B. Check for active fault codes. | High active or inactive counts of fault codes related to the turbocharger or exhaust gas recirculation (EGR) valve system?
 | STEP 1C. Check for active engine intake throttle fault codes. | Fault Code 5879, 5881, 3539, 3541, or 3542 active?
STEP 2. | Check the charge-air cooler outlet pressure sensor. |
 | STEP 2A. Check the charge-air cooler outlet pressure sensor. | INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
STEP 3. | Check the air intake system for leaks. |
 | STEP 3A. Check the charge-air cooler and charge-air plumbing for leaks. | Air leaks present in the charge-air system?
 | STEP 3B. Check for a restricted charge-air cooler. | Charge-air cooler restriction within specifications?
 | STEP 3C. Check the EGR system for leaks and restrictions. | Leaks or restrictions present in the EGR system?
STEP 4. | Check for restriction. |
 | STEP 4A. Check the exhaust system restriction. | Exhaust restriction within specifications?
 | STEP 4B. Check the intake restriction. | Air intake restriction within specifications?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of Fault Code 5952, 5953, 687, 741, 742, or 743?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for other fault codes related to the turbocharger or the EGR valve.

  • Use INSITE™ electronic service tool to read the fault codes.

High active or inactive counts of fault codes that are related to the turbocharger or EGR valve system?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for active engine intake throttle fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active engine intake throttle fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5879, 5881, 3539, 3541, or 3542 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the charge-air cooler outlet pressure sensor.

Guided Step 2A - Check the charge-air cooler outlet pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Connect a mechanical gauge to the engine, as close to the charge-air cooler outlet pressure sensor as possible.

  • Start INSITE™ electronic service tool Data Monitor/Logger. Compare INSITE™ electronic service tool reading for charge-air cooler outlet pressure to the mechanical gauge.

INSITE™ electronic service tool reading within 17 kPa [2.5 psi] of mechanical gauge reading?
YES NO
No Repair

Replace the charge-air cooler outlet temperature/pressure sensor. Refer to Procedure 019-560 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the air intake system for leaks.

Guided Step 3A - Check the charge-air cooler and charge-air plumbing for leaks.

Conditions

  • Operate the engine.

Action

Check the charge-air cooler and charge-air plumbing for leaks.

  • Check the charge-air cooler connections for leaks between the turbocharger compressor outlet and the charge-air cooler.
  • Check the charge-air cooler connections between the charge-air cooler and the intake manifold.
  • Inspect the intake manifold gasket for leaks.
  • Inspect the charge-air cooler hoses for leaks or loose connections.
  • Inspect charge-air cooler clamps to make sure they are tight.
  • Inspect the charge-air plumbing for cracks.
  • Inspect the drain petcock.

Air leaks present in the charge-air system?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a restricted charge-air cooler.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check the pressure differential across the charge-air cooler.

  • Refer to Procedure 010-027 in the Associated Procedures Table.

Charge-air cooler restriction within specifications?
YES NO
No Repair

Clean or replace the charge-air cooler, as necessary.

Go to 3C

Go to 5A

Guided Step 3C - Check the EGR system for leaks and restrictions.

Conditions

  • Turn keyswitch OFF.

Action

Check the EGR system plumbing for leaks and restrictions.

  • Check the exhaust transfer tube for leaks and restrictions. Refer to Procedure 011-103 in the Associated Procedures Table.
  • Check the EGR differential pressure sensor for leaks at the mounting surface. It could be necessary to remove the EGR differential pressure sensor to check the o-rings for damage. Refer to Procedure 019-370 in the Associated Procedures Table.
  • Leaks can be easily noted by traces of soot.

Leaks or restrictions present in the EGR system?
YES NO

Repair or replace the malfunctioning component.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check for restriction.

Guided Step 4A - Check the exhaust system restriction.

Conditions

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Action

Check exhaust system restriction.

  • Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restriction within specifications?
YES NO
No Repair

Continue to investigate the cause of the high exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check the intake restriction.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check the air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications?
YES NO
No Repair

Repair or replace the restricted component.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6239 - High Pressure Common Rail Fuel Pressure Relief Valve - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3230 V104 | 4367291
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | ISV5.0 CM3230 V104 | 4367291
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active or inactive fault codes. | Fault Code 268, 271, 272, 281, 328, 451, 452, 554, 4262, 4263, 5736, or 5737 active or inactive counts?
 | STEP 1B. Check smart power relay. | Dirty or damaged pins?
STEP 2. | Check the low and high-pressure fuel systems. |
 | STEP 2A. Check the low-pressure fuel system. | Meets specifications found in Procedure 005-236?
 | STEP 2B. Check the fuel pump actuator and pressure relief valve. | Actuators within the specifications outlined in Procedure 005-236?
STEP 3. | Check the rail fuel pressure sensor and circuit. |
 | STEP 3A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 451 active?
 | STEP 3C. Check the circuit response. | Fault Code 452 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 451 active?
 | STEP 4C. Check the circuit response. | Fault Code 452 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 268, 271, 272, 281, 328, 451, 452, 554, 4262, 4263, 5736, or 5737 active or inactive counts?
YES NO

Troubleshoot the fault codes listed above first.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check smart power relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect any smart relay from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and smart power relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the relay or harness connector.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

Replace relay, if necessary. See equipment manufacturer service information.

 No Repair

Go to 5A

Go to 2A

Guided Step 2 - Check the low and high-pressure fuel systems.

Guided Step 2A - Check the low-pressure fuel system.

Conditions

  • Turn keyswitch ON.
  • Use the following procedure for information on low-pressure fuel system checks. Refer to Procedure 005-236 in the Associated Procedures Table.

Action

Check the fuel filter.

  • Check for fuel filter restriction above specification.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Meets specifications found in Procedure 005-236?
YES NO
No Repair

Replace the Stage 1 and Stage 2 fuel filters.

  • Refer to Procedures 006-075 and 006-076 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the fuel pump actuator and pressure relief valve.

Conditions

  • Turn keyswitch ON.

Action

Perform the High-Pressure Fuel System Actuator Override in INSITE™ electronic service tool.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Actuators within the specifications outlined in Procedure 005-236?
YES NO
No Repair

If the fuel pump actuator is not within specifications, replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

If the fuel pressure relief valve is not within specifications, replace the fuel pressure relief valve.

  • Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the rail fuel pressure sensor and circuit.

Guided Step 3A - Check the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fail fuel pressure senor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirty or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the rail fuel pressure connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active?
YES NO

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirty or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 452 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6256 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 6256 active?
STEP 2. | Check the equipment battery system. |
 | STEP 2A. Check the battery voltage. | Less than +20 VDC for 12 volt system?
 | STEP 2B. Check the alternator. | Alternator charging within the original equipment manufacturer (OEM) specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6256 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the equipment battery system.

Guided Step 2A - Check the battery voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect all aftermarket devices from the battery supply circuit.
  • Disconnect the OEM power harness connector from the ECM connector.

Action

Check the battery voltage.

  • Measure the battery voltage from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.
  • Repeat above step for the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector.

Less than +20 VDC for 12 volt system?
YES NO
No Repair

Install the battery system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Note: Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or the OEM wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jan-2015


FAULT CODE 6257 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the battery. |
 | STEP 1A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 1B. Check the battery voltage. | Battery voltage acceptable in normal and cranking conditions?
STEP 2. | Check the fuse. |
 | STEP 2A. Verify the fuse is installed correctly. | Fuse installed correctly?
 | STEP 2B. Check for a blown fuse. | Fuse blown?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the OEM power harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit in the power harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3F. Check the add-on or the accessory wiring at the positive (+) terminal of the battery. | Damaged wires?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the battery.

Guided Step 1A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Check the battery terminal connections on both positive (+) and negative (-) terminals.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections. Clean the terminals. See equipment manufacturer service information.

Go to 1B

Go to 4A

Guided Step 1B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine.

Normal conditions:

  • At least +12-VDC (12 volt systems).

Cranking conditions:

  • At least +6.2-VDC (12 volt systems).

Battery voltage acceptable in normal and cranking conditions?
YES NO
No Repair

Charge or replace the battery(s). See equipment manufacturer service information.

Go to 2A

Go to 4A

Guided Step 2 - Check the fuse.

Guided Step 2A - Verify the fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the 80 ampere fuse is installed correctly.

  • Inspect the 80 ampere fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 2B

Go to 4A

Guided Step 2B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 80 ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the OEM power harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Inspect the power harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Replace the ECM.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for an open circuit.

  • Measure the resistance from the positive (+) battery terminal post to all ECM battery SUPPLY (+) pins, one at a time, in the OEM power harness ECM connector.
  • Measure the resistance from the negative (-) battery terminal post to all ECM battery SUPPLY (-) pins, one at a time, in the OEM power harness ECM connector.

Use the circuit or wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the power harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit in the power harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to the ECM battery SUPPLY (-) pins.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turnkeyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to engine block ground.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM power harness from the ECM connector.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the battery.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance from one of the ECM battery SUPPLY (+) pins in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.
  • Measure the resistance from the second ECM battery SUPPLY (+) pin in the OEM power harness ECM connector to all pins in the OEM harness ECM connector.

Reference the appropriate circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check the add-on or accessory wiring at the positive (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the positive (+) terminal of the battery.

  • Starting at the positive (+) terminal, follow any add-on or accessory wiring, and examine wire(s) for damaged insulation or an installation error that can cause the SUPPLY wire to be shorted to the engine block.

Damaged wires?
YES NO

Repair or replace the damaged wires. See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jan-2015


FAULT CODE 6261 - Engine Starter Motor Relay Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 6261 inactive?
STEP 2. | Check the starter lockout relay circuit. |
 | STEP 2A. Inspect the starter lockout relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the starter lockout relay. | Less than 10k ohms?
 | STEP 2C. Check for an open circuit in the starter lockout relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6261 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6261 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the starter lockout relay circuit.

Guided Step 2A - Inspect the starter lockout relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the starter lockout relay resistance.

  • Measure the resistance between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin.

Use the OEM wiring diagram for starter relay pin configuration.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for an open circuit in the starter lockout relay return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay RETURN pin at the starter lockout relay connector to ground.

Use the OEM wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit on the RETURN wire has been detected.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the connection malfunction.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin at the starter lockout relay connector and the starter lockout relay SIGNAL pin at the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the starter lockout relay signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6261 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6262 - Engine Starter Motor Relay Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6262 active?
STEP 2. | Check starter lockout relay and circuit. |
 | STEP 2A. Inspect starter relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the starter lockout relay resistance. | Greater than 6 ohms?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the starter lockout relay. |
 | STEP 2C. Check the starter lockout relay diagnostic supply voltage, supply line and return circuit. | Greater than 3.75 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit to ground in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6262 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6262 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check starter lockout relay and circuit.

Guided Step 2A - Inspect starter relay and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter relay from the OEM harness.

Action

Inspect the OEM starter relay and connector pins.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the starter lockout relay resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check the relay resistance.

  • Measure the resistance of the relay coil and check for low resistance between the starter lockout relay SIGNAL pin and the relay RETURN pin.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 6 ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the starter lockout relay.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a short to ground.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the starter lockout relay. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the starter lockout relay diagnostic supply voltage, supply line and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Turn keyswitch ON.

Action

Check the starter lockout relay diagnostic supply voltage and return circuit.

  • Measure the voltage between the starter lockout relay SIGNAL pin and the starter lockout relay RETURN pin at the starter lockout relay connector of the OEM harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 3.75 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit to ground in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the starter lockout relay from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to ground in the OEM harness.

  • Measure the resistance between the starter lockout relay SIGNAL pin in the OEM harness ECM connector and ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the starter lockout relay from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the starter lockout relay SIGNAL pin and all other pins in the OEM harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6262 inactive?
YES NO

None. The removal and installation of the connector corrected the failure.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jan-2015


FAULT CODE 6263 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6263 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Check the fan control assembly and circuit. | Dirty or damaged pins?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 6263 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6263 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control assembly and circuit.

Guided Step 2A - Inspect the fan control assembly and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan assembly from the engine harness.

Action

Inspect the engine harness and fan assembly connector pins for the folowing:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fan control solenoid from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM fan control assembly SIGNAL pin and the engine harness fan control assembly connector fan control assembly SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open fan control solenoid signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fan control assembly from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the control assembly SIGNAL pin in the engine harness ECM connector and all other pins in the original equipment manufacturer connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the fan control solenoid SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6263 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the fan control assembly. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Jan-2015


FAULT CODE 6264 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6264 active?
STEP 2. | Check the fan control assembly and circuit. |
 | STEP 2A. Inspect the fan control assembly and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control assembly. | Greater than 10 ohms?
 | STEP 2C. Check for a pin-to-ground short circuit in the fan control assembly. | Greater than 100k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 6264 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6264 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control assembly and circuit.

Guided Step 2A - Inspect the fan control assembly and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control assembly from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the assembly or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the original equipment manufacturer (OEM) wiring harness.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control assembly.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control assembly from the engine harness.

Action

Check for low internal resistance of the fan control assembly.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control assembly connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 10 ohms?
YES NO
No Repair

Replace the fan control assembly. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check for a pin-to-ground short circuit in the fan control assembly.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control assembly from the engine harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the SIGNAL pin of the fan control assembly connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Replace the fan control assembly. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the assembly or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fan control assembly from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the engine harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the fan control assembly from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6264 active?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 6266 - Aftertreatment 1 SCR Intermediate Gas Temperature - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Jan-2015


FAULT CODE 6622 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3597 active?
STEP 2. | Check the aftertreatment diesel exhaust fluid controller. |
 | STEP 2A. Inspect the aftertreatment diesel exhaust fluid controller and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 3597 active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 3736 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 3736 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use electronic service tool to read the fault codes.

286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use electronic service tool to read the fault codes.

Fault Code 6622 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid dosing unit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Cycle keyswitch OFF, then back ON.
  • Connect electronic service tool.

Action

Check for an active fault code.

  • Use electronic service tool to read the fault codes.

Fault Code 6622 active?
YES NO

A malfunctioning DEF dosing unit assemble has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6623 - Aftertreatment 1 Diesel Exhaust Fluid Pressure - Data Not Rational - Drifted Low

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for an active fault code. | Fault Code 6623 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Disable the fault code. | Fault code inactive?
 | STEP 2B. Check for an active fault code. | Fault Code 6623 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to 2A

Go to the appropriate fault code troubleshooting tree.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6623 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) dosing unit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check for active fault code.

Conditions

  • Turn keyswitch OFF, then back ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6623 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2016


FAULT CODE 6624 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Disable the fault code. | Fault code active?
 | STEP 2B. Check the fault codes and verify the aftertreatment DEF dosing unit heater condition. | Fault Code 6624 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6624 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust fluid (DEF) dosing unit heater circuit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the fault codes and verify the aftertreatment DEF dosing unit heater condition.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the Aftertreatment DEF Tank Heater 1 Relay ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 6624 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 6625 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit 1 Heater Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault code. | Fault Code 6625 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) controller. |
 | STEP 2A. Disable the fault code. | Fault code active?
 | STEP 2B. Check the fault codes and verify the aftertreatment DEF dosing unit heater condition. | Fault Code 6625 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6625 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust (DEF) dosing unit heater circuit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 3A

Guided Step 2B - Check the fault codes and verify the aftertreatment DEF dosing unit heater condition.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Use INSITE™ electronic service tool to perform the Diesel Exhaust Fluid Doser System Heater Test under ECM Diagnostic Tests.
  • Command the Aftertreatment DEF Tank Heater 1 Relay ON.
  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 6625 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 6626 - Aftertreatment 1 Diesel Exhaust Fluid Line 1 Heater Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault code. | Fault Code 6625 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) line heater 1 and circuit. |
 | STEP 2A. Inspect the aftertreatment DEF line heater 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the aftertreatment DEF line heater 1. | Between 2 and 100 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6626 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust (DEF) line heater 1 and circuit.

Guided Step 2A - Inspect the aftertreatment DEF line heater 1 and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the DEF dosing unit harness.

Action

Inspect the aftertreatment DEF line heater 1 and DEF dosing unit harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector pins
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for the general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the resistance of the aftertreatment DEF line heater 1.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DEF line heater 1 from the DEF dosing unit harness.

Action

Check the resistance of the aftertreatment DEF line heater 1.

  • Measure the resistance between the aftertreatment DEF line heater 1 SIGNAL pin and the aftertreatment DEF line heater 1 RETURN pin at the aftertreatment DEF line heater 1 connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for the general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 2 and 100 ohms?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

The line heater 1 resistance is out of specification.

  • Replace the aftertreatment DEF line heater 1. See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 6627 - Aftertreatment 1 Diesel Exhaust Fluid Dosing Unit Temperature - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Diesel Exhaust Fluid Dosing Unit | Refer to Procedure 011-058 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check for active fault code. | Fault Code 6627 active or inactive with more than one count logged in the last 25 engine hours?
STEP 2. | Check the aftertreatment diesel exhaust fluid (DEF) dosing unit. |
 | STEP 2A. Disable the fault code. | Fault code active?
 | STEP 2B. Check for active fault code. | Fault Code 6627 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 286, 427, 477, 478, 3557, 3558, 3559, 3561, 4248, 4291, 4292, 5673, or 5674 active or inactive with more than one count logged in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6627 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the aftertreatment diesel exhaust (DEF) dosing unit.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2B

Guided Step 2B - Check for an active fault code.

Conditions

  • Cycle keyswitch OFF, then ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6627 active?
YES NO

A malfunctioning DEF dosing unit assembly has been detected. Refer to Procedure 011-058 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 30-Jun-2015


FAULT CODE 195 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

See Fault Code 1695.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

See equipment manufacturer service information.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the supply wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 196 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 1696 acitve?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

See Fault Code 1696.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Use a circuit diagram or wiring diagram for connector pin identification.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

A damaged sensor has been detected.

Replace the engine coolant level sensor.

Refer to Procedure 019-071 in Section 19.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open supply circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

An open signal circuit has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the signal wire has been detected in the OEM harness.

Repair or replace the OEM harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the OEM harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 261 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Monitor fuel temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Monitor the fuel temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the fuel temperature reading.

  • Use INSITE™ electronic service tool to monitor the fuel temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Check the following possible causes of high fuel temperature:

  • Wrong fuel type/grade
  • Fuel tank fuel level is low
  • High fuel supply or return restriction
  • Fuel tank installation not correct
  • Fuel lines not routed correctly
  • High ambient air temperature
  • Engine coolant not cooling engine (overheat conidition exists).

See equipment manufacturer service information.

Replace the fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 262 - Engine Fuel Temperature - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | ISV5.0 CM3230 V109 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor fuel temperature reading. |
 | STEP 1A. Monitor fuel temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor fuel temperature reading.

Guided Step 1A - Monitor fuel temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the fuel temperature reading.

  • Use INSITE™ electronic service tool to monitor the fuel temperature valve.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Check for the following possible causes of low fuel temperature:

  • Wrong fuel type/grade
  • Fuel tank installation not correct
  • Fuel lines not routed correctly
  • Malfunctioning ambient air temperature.

See equipment manufacturer service information.

Replace the fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault codes.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 263 - Engine Fuel Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 263 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check the circuit continuity.

  • Place a jumper wire between the fuel temperature sensor SIGNAL pin and fuel temperature sensor RETURN pin at the engine harness fuel temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool to read the fault codes.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the fuel temperature sensor SIGNAL pin and the fuel temperature sensor RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fautl Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor RETURN pin and the engine harness engine fuel temperature sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor SIGNAL pin and the engine harness engine fuel temperature sensor connection SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Diable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Diable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 265 - Engine Fuel Temperature Sensor Circuit - Voltage Below Normal or Shorted Low to Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 265 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 265 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 265 inactive.
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is avaiable. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

A damaged sensor has been detected.

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Call for authorization to replace the ECM. Upon receipt of authorization, replace the ECM.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disocnnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disocnnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Troubleshooting procedures need to be repeated from the beginning. A fault code should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 268 - Fuel Delivery Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 281, 482, 546, or 547 active or inactive counts?
 | STEP 1B. Read the fault codes. | Fault Code 268 active?
STEP 2. | Verify the accuracy of the fuel pressure sensor. |
 | STEP 2A. Monitor the fuel pressure sensor with an electronic service tool. | Fuel pressure sensor reading within ±0.5 bar of the compressor intake pressure with key ON and engine OFF?
STEP 3. | Check the fuel pressure sensor and circuit. |
 | STEP 3A. Inspect the fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 3B. Clear the circuit response. | Fault Code 547 active?
 | STEP 3C. Clear the circuit response. | Fault Code 546 active?
STEP 4. | Check the engine control module (ECM) and engine harness. |
 | STEP 4A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the circuit response. | Fault Code 547 active?
 | STEP 4C. Check the circuit response. | Fault Code 546 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 271, 272, 281, 482, 546, or 547 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON. Wait 30 seconds.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 268 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Verify the accuracy of the fuel pressure sensor.

Guided Step 2A - Monitor the fuel pressure sensor with an electronic service tool.

Conditions

  • Turn keyswitch OFF.
  • Disconnect power from the lift pump.
  • Turn keyswitch ON.
  • Do not operate engine. Wait 30 seconds.
  • Connect INSITE™ electronic service tool.

Action

Monitor the fuel pressure sensor and compressor intake pressure with the lift pump power disconnected.

Use the electronic service tool.

Fuel pressure sensor reading within ±0.5 bar of the compressor intake pressure with key ON and engine OFF?
YES NO
No Repair

Replace the fuel pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check the fuel pressure sensor and circuit.

Guided Step 3A - Inspect the fuel pressure sensor and circuit pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor form the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropirate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.

Action

Check for the appropriate circuit repsonse after 30 seconds.

  • Place a jumper wire between the fuel pressure SIGNAL pin and the fuel pressure RETURN pin at the fuel pressure connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Refer to the circuit or wiring diagram for component pin identification.

Fault Code 546 active?
YES NO

Replace the fuel pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the ECM and engine harness.

Guided Step 4A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF>
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4C

Go to 5A

Guided Step 4C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the fuel pressure SIGNAL pin and the fuel pressure RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Refer to the circuit diagram or wiring diagram for component pin identification.

Fault Code 546 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 281 - Fuel Pump Pressurizing Assembly 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271 or 272 active or high inactive counts?
 | STEP 1B. Read the fault codes. | Fault Code 699 active or high inactive counts?
 | STEP 1C. Read the fault codes. | Fault Code 281 active?
STEP 2. | Check the fuel pump actuator. |
 | STEP 2A. Check the fuel pump actuator and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 272 active and Fault Code 281 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 281 active?
 | STEP 2D. Check the fuel pump actuator. | Fuel pump actuator within the specifications outlined in Procedure 005-236?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Check the engine harness and ECM. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 272 active and Fault Code 281 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 271 or 272 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel pump actuator.

Guided Step 2A - Check the fuel pump actuator and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.

Action

Inspect the fuel pump actuator, pigtail wires, and haress connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump actuator from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and Fault Code 281 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel pump actuator to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 281 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 2D

Go to 4A

Guided Step 2D - Check the fuel pump actutator.

Conditions

  • Turn keyswitch ON.

Action

Perform the High Fuel Pressure Actuator test in INSITE™ electronic service tool.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel pump actuator within the specifications outline in Procedure 005-236?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If the fuel pump actuator is not within specifications, replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Check the engine harness and ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the engine harness.

Action

Inspect the fuel pump acutator, pigtail wires, and harness connector pins for the following:

  • Loose connectoor
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the ECM from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 272 active and 281 inactive?
YES NO

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 311 - Injector Solenoid Driver Cylinder 1 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 311 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 311 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher.
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 311 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 1 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 1.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disonnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 1 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 1 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perfor the Fuel Injector Drain Line Restriction Test on the bank of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

Restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 311 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 312 - Injector Solenoid Driver Cylinder 5 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 312 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 312 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 312 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 5 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the resistance on the connector of injector 5.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disonnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 5 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 5 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Fuel Injector Drain Line Restriction Test on the bank of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

Restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 312 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 313 - Injector Solenoid Driver Cylinder 3 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 313 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150 Kohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 313 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 313 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or inetermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector 3 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 3.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 150 Kohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 3 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 3 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perfor the Fuel Injector Drain Line Restriction Test on the bank of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

Restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 313 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 314 - Injector Solenoid Driver Cylinder 6 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 314 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 314 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 314 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 6 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 6.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 6 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 6 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perfor the Fuel Injector Drain Line Restriction Test on the bank of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

Restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 311 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 315 - Injector Solenoid Driver Cylinder 2 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 315 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 315 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 315 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector 2 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 2.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 2 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 2 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perfor the Fuel Injector Drain Line Restriction Test on the bank of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

Restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 315 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 321 - Injector Solenoid Driver Cylinder 4 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 321 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 321 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 321 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector 4 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 4.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 4 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 5A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 4 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perfor the Fuel Injector Drain Line Restriction Test on the bank of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

Restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 321 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dity or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connectors.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from injector 1.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and injector 1 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 1.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 1 RETURN pin and the engine harness injector 1 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 1.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 1 SIGNAL pin and the engine harness injector 1 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dity or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connectors.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from injector 5.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and injector 5 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 5.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 5 RETURN pin and the engine harness injector 5 connector RETURN pin.
  • Measure the resistance between the engine harness ECM connector injector 5 SIGNAL pin and the engine harness injector 5 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 5.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 5 SIGNAL pin and the engine harness injector 5 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dity or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connectors.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from injector 3.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and injector 3 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 3.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 3 RETURN pin and the engine harness injector 3 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 3.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 3 SIGNAL pin and the engine harness injector 3 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dity or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connectors.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from injector 6.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and injector 6 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 6.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 6 RETURN pin and the engine harness injector 6 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 6.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 6 SIGNAL pin and the engine harness injector 6 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 328 - Fuel Pump Pressurizing Assembly 2 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4262 or 4263 active or high inactive counts?
 | STEP 1B. Read the fault codes. | Fault Code 699 active or high inactive counts?
 | STEP 1C. Read the fault codes. | Fault Code 328 active?
STEP 2. | Check the pressure relief valve. |
 | STEP 2A. Check the pressure relief valve and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4262 active and Fault Code 328 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 328 active?
 | STEP 2D. Check the pressure relief valve. | Pressure relief valve within the specifications outlined in Procedure 005-236?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4262 active and Fault Code 328 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted low or high.

Fault Code 4262 or 4263 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 328 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the pressure relief valve.

Guided Step 2A - Check the pressure relief valve and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pressure relief valve from the engine harness.

Action

Inspect the pressure relief valve, pigtail wires, and harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pressure relief valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active and Fault Code 328 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the pressure relief valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 328 active?
YES NO
No Repair

None. The removal and installation of the connector corrected the fault.

Go to 2D

Go to 4A

Guided Step 2D - Check the pressure relief valve.

Conditions

  • Turn keyswitch ON.

Action

Perform the High Fuel Pressure Actuator test in INSITE™ electronic service tool.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Pressure relief valve within the specifications outline in Procedure 005-236?
YES NO

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

If the pressure relief valve is not within specifications, replace the pressure relief valve. Refer to Procedure 019-117 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM pins for the following:

  • Loose connectoor
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the pressure relief valve.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4262 active and 328 inactive?
YES NO

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM. Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dity or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connectors.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from injector 2.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and injector 2 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 2.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 2 RETURN pin and the engine harness injector 2 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 2.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 2 SIGNAL pin and the engine harness injector 2 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dity or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connectors.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from injector 4.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and injector 4 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 4.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 4 RETURN pin and the engine harness injector 4 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engine harness from injector 4.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 4 SIGNAL pin and the engine harness injector 4 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 359 - Engine Failed Automatic Start - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Vibration Damper, Rubber | Refer to Procedure 001-051 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Camshaft Position Sensor | Refer to Procedure 019-363 | ISV5.0 CM3230 V104 | 4367291
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 359 the only active fault?
STEP 2. | Inspect the crankshaft and camshaft speed/position sensors. |
 | STEP 2A. Inspect the engine speed and position sensors for damage. | Damaged or misaligned?
 | STEP 2B. Inspect the tone wheel for damage. | Any damaged?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
STEP 4. | Check the camshaft position sensor circuit. |
 | STEP 4A. Check the camshaft position sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 4B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 4B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 4B-3. Verify adequate camshaft position sensor air gap. |
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 359 the only active fault?

YES NO
No Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Appropriate fault code troubleshooting tree

Guided Step 2 - Inspect the crankshaft and camshaft speed/position sensors.

Guided Step 2A - Inspect the engine speed and position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft engine speed and position sensors for damage or misalignment.

Damaged or misaligned?
YES NO

Realign or replace the speed or position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the tone wheel for any damaged.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft tone wheel for damage.

  • Inspect the crankshaft tone wheel for defects.

Any damage?
YES NO

Replace the tone wheel.

Refer to Procedure 001-051 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector lock tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 5A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 5A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 5A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the air gap and target wheel.

  • Remove the crankshaft position sensor from the engine block and measure the air gap at several points in eh crankshaft's revolution.

Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications found in Procedure 019-365?
YES NO

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

Replace or shim the sensor if the air gap is out of specification.

Go to 5A

Go to 5A

Guided Step 4 - Check the camshaft position sensor circuit.

Guided Step 4A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Refer to the circuit diagram for wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Mositure in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B-1

Guided Step 4B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4B-2

Go to 5A

Guided Step 4B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4B-3

Go to 5A

Guided Step 4B-3 - Verify adequate camshaft position sensor air gap.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the air gap.

  • Remove the camshaft position sensor from the housing and measure the air gap at several points in the camshaft's revolution.

Refer to Procedure 019-363 in the Associated Procedures Table.

Air gap within specification found in Procedure 019-363?
YES NO

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Replace or shim the sensor if the air gap is out of specification.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 435 - Engine Oil Rifle Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 435 active?
STEP 2. | Check the engine oil pressure switch and circuit. |
 | STEP 2A. Inspect the switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the resistance of the engine oil pressure switch. | Less than 10 ohms?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 435 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 435 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine oil pressure switch and circuit.

Guided Step 2A - Inspect the switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Inspect the switch and connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the resistance of the engine oil pressure switch.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check the resistance of the switch.

  • Measure the resistance between the engine oil pressure SIGNAL pin of the engine oil pressure switch and ground.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine oil pressure switch.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for an open circuit.

  • Measure the resistance between the engine oil pressure SIGNAL pin at the switch connector of the engine harness and the engine oil pressure SIGNAL pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine harness from the engine oil pressure switch.

Action

Check for a pin-to-pin short circuit in the engine harness.

  • Measure the resistance and check for a short circuit between the engine oil pressure SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 435 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 482 - Fuel Supply Pressure Low - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Air In Fuel | Refer to Procedure 006-003 | ISV5.0 CM3230 V104 | 4367291
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | ISV5.0 CM3230 V104 | 4367291
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | ISV5.0 CM3230 V104 | 4367291
Fuel Filter Housing (Stage 1) | Refer to Procedure 006-082 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Lift Pump Circuit | Refer to Procedure 019-397 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for battery voltage fault codes. | Fault Code 441, 442, active?
 | STEP 1B. Check for fuel pressure fault codes. | Fault Code 268, 546, 547, 2222, 2223, 2224, or 4691 active?
 | STEP 1C. Check for lift pump fault codes. | Fault Code 2266 or 2265 active?
STEP 2. | Check the fuel supply pressure. |
 | STEP 2A. Verify the lift pump voltage. | Voltage greater than 8 volts at key on or during cranking?
 | STEP 2B. Check for adequate fuel supply or tank level. | Fuel level low?
 | STEP 2C. Check the low-pressure fuel system. | Check meets specifications found in Procedure 005-236?
 | STEP 2D. Check for air in fuel. | Air in fuel system?
 | STEP 2E. Check for fuel inlet restriction. | Check meets specifications found in Procedure 006-003?
 | STEP 2F. Inspect original equipment manufacturer (OEM) fuel supply lines. | Leaky or damaged fuel supply line?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for battery voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, or 597 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 1B

Guided Step 1B - Check for fuel pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 268, 546, 547, 2222, 2223, 2224, or 4691 active?
YES | NO
No Repair | No Repair

Troubleshoot active fault codes.

Go to 1C

Guided Step 1C - Check for lift pump fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 or 2265 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 2A

Guided Step 2 - Check the fuel supply pressure.

Guided Step 2A - Verify the lift pump voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the electric fuel lift pump.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin.

Note: Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 8 volts at key ON or during cranking?
YES NO
No Repair

Check the lift pump replay and lift pump harness for an intermittent connection.

Repair or replace the damaged component. Refer to Procedure 019-397 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for adequate fuel supply or tank level.

Conditions

  • Turn keyswitch ON.
  • Turn keyswitch OFF.

Action

Check the fuel tank level.

  • Do not rely on the fuel gauge. Check the actual tank level.
  • Verify there is fuel in the tank.

Fuel level low?
YES NO

Add fuel to the tank.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the low-pressure fuel system.

Conditions

  • Turn keyswitch ON.
  • Use the following procedure for information on low-pressure fuel system checks. Refer to Procedure 005-236 in the Associated Procedures Table.

Action

Check the fuel filter.

  • Check for fuel filter restriction above specification. Refer to Procedure 005-236 in the Associated Procedures Table.

Check meets specifications found in Procedure 005-236?
YES NO
No Repair

Replace the Stage 1 and 2 fuel filters. Refer to Procedures 006-075 and 006-076 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in fuel.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel system.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel system?
YES NO

Investigate the cause for air in the fuel system. Remove air from the fuel system.

Repair or replace components.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check for fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

Check for fuel inlet restriction.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Check meets specifications?
YES NO
No Repair

Check the OEM fuel lines to the tank for proper size, leaks, bends, or clogs.

Check the fuel tank vents for plugging.

Go to 2F

Go to 3A

Guided Step 2F - Inspect OEM fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel supply line.

  • Check the OEM suction and pressure-side fuel supply lines.

Leaky or damaged fuel supply line?
YES NO

A damaged fuel supply line has been detected.

Replace the supply line. See equipment manufacturer service information.

A damaged lift pump has been detected.

Repair or replace the missing or damaged components or replace the lift pump. Refer to Procedure 006-082 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Aug-2015


FAULT CODE 535 - Engine Fuel Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 535 active?
 | STEP 1B. Check for active fault codes. | Fault Code 263 or 265 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Measure the resistance of the engine fuel temperature sensor at room temperature 25°C [77°F]. | Fuel temperature sensor 10k ohms +/-10 percent?
 | STEP 2A-1. Inspect the engine fuel temperature sensor and connector pins. |
 | STEP 2B. Check the circuit response. | Fault Code 263 active?
 | STEP 2C. Check the circuit response. | Fault Code 265 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 263 active?
 | STEP 3C. Check the circuit response. | Fault Code 265 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for sensor circuit fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 535 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for Fault Codes 263 and 265.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 or 265 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Verify the sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Measure the resistance of the engine fuel temperature sensor at room temperature 25°C [77°F].

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fuel temperature sensor 10k ohms +/-10 percent?
YES NO
No Repair

Replace the fuel temperature sensor. Refer to procedure 019-119 in the Associated Procedures Table.

Go to 2A-1

Go to 4A

Guided Step 2A-1 - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Inspect the engine harness and engine fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine fuel temperature SIGNAL pin and the engine fuel temperature RETURN pin at the engine fuel temperature connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

An in-range malfunction of the fuel temperature sensor has been detected.

Replace the engine fuel temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the engine harness connector.

Repair the damaged harness, connector, or pins, if possible.

  • Flush the dirt, debris, or moisture from the connector pins.
  • Install the appropriate connector seal if it is damaged or missing.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the engine fuel temperature SIGNAL pin and engine fuel temperature RETURN pin at the ECM connector.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISV5.0 CM3230 V104 | 4367291
Connect, Butt Splice | Refer to Procedure 019-199 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 546 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 546 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 546 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the connector. Refer to Procedure 019-199 in the Associated Procedures Table.
  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

A damaged sensor has been detected.

  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressure sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active ?
YES NO

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the fuel delivery pressue sensor connector or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness or damaged sensor. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

An open fuel delivery pressure return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 546 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Refer to the appropriate troubleshooting steps

Last Modified: 18-Dec-2014


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Sensor | Refer to Procedure 019-188 | ISV5.0 CM3230 V104 | 4367291
Connect, Butt Splice | Refer to Procedure 019-199 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 547 active?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Check the fault codes and verify fuel delivery pressure sensor condition. | Fault Code 547 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the fuel delivery pressure 5 volt SUPPLY pin and fuel delivery pressure RETURN pin. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code | Fault Code 547 inactive?
 | STEP 4B. Clear the inactive fault codes | All faults codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.

Action

Inspect the engine harness connector and fuel delivery pressure sensor connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the fuel delivery pressure sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and they fuel delivery pressure SIGNAL pin at the fuel delivery sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use INSITE™ electronic service too to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify fuel delivery pressure sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

A damaged sensor has been detected.

  • Replace the sensor. Refer to Procedure 019-188 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the fuel delivery pressure 5 volt SUPPLY pin and fuel delivery pressure RETURN pin.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the ECM connector port of the ECM.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive ?
YES NO

An open or shorted fuel delivery pressure 5 volt supply circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all engine harness interconnections.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair or replace the connector. Refer to Procedure 019-199 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES NO
No Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components
  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

An open or short signal circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit or pin-to-pin short.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Use INSITE™ electronic service tool to verify the fault code is inactive.

Fault Code 547 inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 4B

Go to 1A

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete

Refer to the appropriate troubleshooting steps

Last Modified: 18-Dec-2014


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 281, 268, 554, 2265, 2266, 4262, 4263, or 6239 active or high inactive counts?
STEP 2. | Check the lift pump. |
 | STEP 2A. Verify low side fuel pressure. | Fuel supply pressure greater than 7 bar [102 psi]?
STEP 3. | Check the high-pressure fuel system. |
 | STEP 3A. Run the High-Pressure Fuel Acutator Override Test. | Actuators within the specifications outlined in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control (EFC) actuator.

Fault Code 271, 272, 281, 268, 554, 2265, 2266, 4262, 4263, or 6239 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the lift pump.

Guided Step 2A - Verify low side fuel pressure.

Conditions

  • Turn keyswitch ON.

Action

Monitor fuel supply pressure.

  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to monitor fuel supply pressure. Check within 30 seconds.
  • Check fuel supply pressure in Snapshot Data.

Fuel supply pressure greater than 7 bar [102 psi]?
YES NO

Replace the lift pump.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the high-pressure fuel system.

Guided Step 3A - Run the High-Pressure Fuel Actuator Override Test.

Conditions

  • Turn keyswitch ON.

Action

Perform the High-Pressure Fuel System Actuator Override Test in INSITE™ electronic service tool.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Actuator within the specifications outline in Procedure 005-236?
YES NO
No Repair

If the fuel pump actuator is not within specifications, replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

If the fuel pressure relief valve is not within specifications, replace the pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 554 - Injector Metering Rail 1 Pressure - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 271, 272, 281, 268, 451, 452, 482, 4262, or 4263 active or high inactive counts?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 451 active?
 | STEP 2C. Check the circuit response. | Fault Code 452 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pin?
 | STEP 3B. Check the circuit response. | Fault Code 451 active?
 | STEP 3C. Check the circuit response. | Fault Code 452 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.
  • Check for fault codes related to the electronic fuel control actuator shorted high or low.

Fault Code 271, 272, 281, 268, 451, 452, 482, 4262, or 4263 active or high inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the rail fuel pressure connector of the engine harness.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active?
YES NO

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the rail fuel pressure SIGNAL pin and the rail fuel pressure RETURN pin at the ECM engine connector.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the circuit diagram or wiring diagram for component pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Fault Code 452 active?
YES NO

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Jan-2015


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3230 V104 | 4367291
Fuel Rail Supply Line (High-Pressure) | Refer to Procedure 006-071 | ISV5.0 CM3230 V104 | 4367291
Fuel Rail to Fuel Rail Supply Line (High-Pressure) | Refer to Procedure 006-084 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any active injector circuit faults?
 | STEP 1B. Check for active or inactive fault codes. | Fault Code 268, 271, 272, 281, 451, 452, 482, 554, 4262, or 4263, 5736, or 5737 active or inactive counts?
STEP 2. | Check the high-pressure fuel system. |
 | STEP 2A. Check for leaks in the high-pressure system. | Leak or moisture detected?
 | STEP 2B. Check the fuel pump actuator and the pressure relief valve. | Actuators within the specifications outlined in Procedure 005-236?
 | STEP 2C. Check the injector return flow. | Injector return flow meets the specifications outlined in Procedure 005-236?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any active injector circuit faults?
YES NO

Troubleshoot active fault codes first.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 268, 271, 272, 281, 451, 452, 482, 554, 4262, or 4263, 5736, or 5737 active or inactive counts?
YES NO

Troubleshoot the fault codes listed above first.

 No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the high-pressure fuel system.

Guided Step 2A - Check for leaks in the high-pressure system.

Conditions

  • Turn keyswitch OFF.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Perform the High-Pressure Fuel System Leakage Test in INSITE™ electronic service tool.

Refer to Procedures 005-236 in the Associated Procedures Table.

Allow 1 minute after test is stopped, to check the following components for leaks or moisture:

  • Fuel rail suppy line-Refer to Procedure 006-071 in the Associated Procedures Table.
  • Fuel rail to fuel rail supply line-Refer to Procedure 006-084 in the Associated Procedures Table.
  • Injector supply lines-Refer to Procedures 006-051 in the Associated Procedures Table.

Leak or moisture detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the fuel pump actuator and the pressure relief valve.

Conditions

  • Turn keyswitch ON.

Action

Perform the High-Pressure Fuel System Actuator Override Test in INSITE™ electronic service tool.

Refer to Procedure 005-236 in the Associated Procedures Table.

Actuators within the specifications outlined in Procedure 005-236?
YES NO
No Repair

If the fuel pump actuator is not within specifications, replace the fuel pump actuator. Refer to Procedure 019-117 in the Associated Procedures Table.

If the fuel pressure relief valve is not within specifications, replace the fuel pressure relief valve. Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive fuel leakage from the injectors.

Perform the High-Pressure Fuel Injector Return Flow Test on each bank. Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flow meets the specifications outline in Procedure 005-236?
YES NO
No Repair

Replace the leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Repair or replace the damaged component(s).

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Aug-2015


FAULT CODE 1139 - Injector Solenoid Driver Cylinder 1 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1139 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostic tests. |
 | STEP 3A. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specification outline in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1139 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 1 or another cylinder is missing or is not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 1.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications outlined in Procedure 005-236?
YES NO
No Repair

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Sep-2015


FAULT CODE 1141 - Injector Solenoid Driver Cylinder 2 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1141 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostic tests. |
 | STEP 3A. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specification outline in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1141 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 2 or another cylinder is missing or is not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 2.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications outlined in Procedure 005-236?
YES NO
No Repair

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2015


FAULT CODE 1142 - Injector Solenoid Driver Cylinder 3 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1142 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostic tests. |
 | STEP 3A. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specification outline in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1142 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 3 or another cylinder is missing or is not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 3.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications outlined in Procedure 005-236?
YES NO
No Repair

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2015


FAULT CODE 1143 - Injector Solenoid Driver Cylinder 4 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1143 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostic tests. |
 | STEP 3A. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specification outline in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1143 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 4 or another cylinder is missing or is not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 4.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications outlined in Procedure 005-236?
YES NO
No Repair

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2015


FAULT CODE 1144 - Injector Solenoid Driver Cylinder 5 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1144 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostic tests. |
 | STEP 3A. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specification outline in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1144 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 5 or another cylinder is missing or is not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 5.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications outlined in Procedure 005-236?
YES NO
No Repair

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2015


FAULT CODE 1145 - Injector Solenoid Driver Cylinder 6 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active fault codes. | Fault Code 1145 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostic tests. |
 | STEP 3A. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specification outline in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1145 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 6 or another cylinder is missing or is not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 6.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications outlined in Procedure 005-236?
YES NO
No Repair

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2015


FAULT CODE 1548 - Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault codes. | Fault code active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connections.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from injector 7.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 7 SIGNAL pin and inject 7 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire or insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engihe harness from the injector 7.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 7 RETURN pin and the engine harness injector 7 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Diconnect the engine harness from the injector 7.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 7 SIGNAL pin and the engine harness injector 7 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault code active?
YES NO

Return to the troubleshooting steps

 No Repair

Go to 4B

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes inactive?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate fault code troubleshooting tree.

Last Modified: 18-Dec-2014


FAULT CODE 1549 - Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549 active?
STEP 2. | Check the injector for an open circuit. |
 | STEP 2A. Inspect the engine harness connections. | Connectors properly connected?
 | STEP 2B. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit. | Greater than 210k ohms?
STEP 3. | Check the engine harness for an open circuit. |
 | STEP 3A. Inspect the engine harness and engine control module (ECM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open return circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for an open signal circuit in the engine harness. | Less than 10 ohms?
STEP 4. | Clear fault codes. |
 | STEP 4A. Disable the fault codes. | Fault code active?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the injector for an open circuit.

Guided Step 2A - Inspect the engine harness connections.

Conditions

  • Turn keyswitch OFF.

Action

Make sure the following engine harness connections are properly made:

  • Engine harness connected to ECM.
  • Engine harness connected to the injector connections.

Connectors properly connected?
YES NO
No Repair

Install the engine harness connectors properly.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from injector 8.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pin.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for an open circuit.

  • Measure the resistance between the injector 8 SIGNAL pin and inject 8 RETURN pin at the injector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 210k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness for an open circuit.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire or insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

  • Clean the connector and pins.
  • Repair the damaged harness, connectors, or pins, if possible.
  • Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open return circuit in the engine harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Disconnect the engihe harness from the injector 8.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 8 RETURN pin and the engine harness injector 8 connector RETURN pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open return circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open signal circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness ECM connector.
  • Diconnect the engine harness from the injector 8.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector injector 8 SIGNAL pin and the engine harness injector 8 connector SIGNAL pin.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

An open signal circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Clear the fault codes.

Guided Step 4A - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to verify that the fault codes are inactive.

Fault code active?
YES NO

Return to the troubleshooting steps

 No Repair

Go to 2A

Go to 4B

Guided Step 4B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Clear the inactive fault codes.

  • Use INSITE™ electronic service tool to clear the inactive fault codes.

All fault codes inactive?
YES NO
No Repair

Troubleshoot any remaining fault codes.

Repair complete.

Go to the appropriate fault code troubleshooting tree.

Last Modified: 18-Dec-2014


FAULT CODE 1561 - Injector Solenoid Driver Cylinder 8 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1561 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuiton the injector driver. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1561 inactive?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 1561 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1561 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 8 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 8.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 8 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 8 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1561 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Fuel Injector Drain Line Restriction Test on the back of this injector.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications found in Procedure 005-236?
YES NO
No Repair

A restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1561 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 1623 - Injector Solenoid Driver Cylinder 7 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1623 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit on the injector driver. | Greater than 100k ohms?
STEP 4. | Check the injector drain line. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specification found in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 1623 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1623 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 7 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 7.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 7 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit on the injector driver.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 7 driver pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check the injector drain line.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Fuel Injector Drain Line Restriction Test on the bank of this injector.

Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specification found in Procedure 005-236?
YES NO
No Repair

A restricted injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Start engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1623 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Jan-2015


FAULT CODE 1654 - Engine Misfire Cylinder 1 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1654 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 1?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1654 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 1?
YES NO

Replace the cylinder number 1 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 1.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1655 - Engine Misfire Cylinder 2 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1655 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 2?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system,or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1655 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 2?
YES NO

Replace the cylinder number 2 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 2.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1656 - Engine Misfire Cylinder 3 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 in the Associated Procedures Table | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1656 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 3?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1654 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 3?
YES NO

Replace the cylinder number 3 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 3.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1657 - Engine Misfire Cylinder 4 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 in the Associated Procedures Table | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1657 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 4?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1657 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 4?
YES NO

Replace the cylinder number 4 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 4.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1658 - Engine Misfire Cylinder 5 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1658 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 5?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1658 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 5?
YES NO

Replace the cylinder number 5 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 5.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1659 - Engine Misfire Cylinder 6 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1659 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 6?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1659 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 6?
YES NO

Replace the cylinder number 6 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 6.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1661 - Engine Misfire Cylinder 7 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1661 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 7?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1661 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 7?
YES NO

Replace the cylinder number 7 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 7.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1662 - Engine Misfire Cylinder 8 - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active cylinder misfire fault. | Fault Code 1662 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the Cylinder Cutout Test. | Symptom attributed to cylinder 8?
 | STEP 2B. Perform the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check if an ECM calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for an active cylinder misfire fault.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1662 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the Cylinder Cutout Test.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ electronic service tool to perform a single Cylinder Cutout Diagnostic Test.

  • Operate the engine under the conditions in which the complaint occurs.
  • Use INSITE™ electronic service tool to perform the Cylinder Cutout Test to disable individual injector(s).

Symptom attributed to cylinder 8?
YES NO

Replace the cylinder number 8 injector.

Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn the keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder number 8.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Use the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS.

Replace malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 1718 - Engine Misfire for Multiple Cylinders - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP®/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, crankcase, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for camshaft or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for active cylinder misfire fault codes. | Fault Code 1718 active?
STEP 2. | Perform diagnostic tests. |
 | STEP 2A. Perform the cylinder cutout test. | Cylinder misfires detected and malfunctions isolated to injectors?
 | STEP 2B. Perform the high-pressure fuel injector drain flow test. | Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine and let it idle for 1 minute
  • Use INSITE™ electronic service tool to read the fault codes.

Any other fuel system, injector, or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, crankcase, or EGR related fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1C

Guided Step 1C - Check for camshaft or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and operate at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1D

Guided Step 1D - Check for active cylinder misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine and run at low idle.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1718 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Perform diagnostic tests.

Guided Step 2A - Perform the cylinder cutout test.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate engine at low idle.

Action

Use INSITE™ cylinder cutout test to determine if multiple cylinders are misfiring.

  • Cut out individual cylinders to locate the misfiring cylinder.

Cylinder misfires detected and malfunctions isolated to injectors?
YES NO

Damaged injectors have been detected.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Perform the high-pressure fuel injector drain flow test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on each bank.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injectors meet specifications in Procedure 005-236 in the Associated Procedures Table?
YES NO

Reference the Engine Runs Rough or Misfires troubleshooting symptom tree in Section TS of the appropriate service manual.

Replace the malfunctioning injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 2265 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2265 active?
STEP 2. | Check the lift pump relay circuit. |
 | STEP 2A. Inspect the lift pump relay and electrical connections. | Dirty or damaged pins?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and the OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit. | Less than 10 ohms?
 | STEP 3C. Check for a short circuit to battery. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2265 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the lift pump relay circuit.

Guided Step 2A - Inspect the lift pump relay and electrical connections.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the lift pump relay from the OEM harness.

Action

Inspect the lift pump relay connector and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the lift pump relay or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and the OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the ECM.

Action

Inspect the ECM and the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump relay from the harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit.

  • Measure the resistance between the lift pump relay SIGNAL pin at the OEM harness ECM connector and the lift pump relay SIGNAL pin at the lift pump relay connector.

Less than 10 ohms?
YES NO
No Repair

An open circuit has been detected in the lift pump relay signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit to battery.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump relay from the harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit to battery.

  • Measure the resistance between the lift pump relay SIGNAL pin at the OEM harness ECM connector and battery positive (+).

Greater than 100k ohms?
YES NO
No Repair

A short circuit to battery has been detected in the lift pump relay SIGNAL circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump relay from the harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the lift pump relay SIGNAL pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the lift pump relay signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2265 inactive?
YES NO

None. The removal and installation of the connector corrected the malfunction.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 2266 - Electric Lift Pump for Engine Fuel Supply Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3823993 - male Deutsch™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2266 active?
STEP 2. | Check the lift pump relay circuit. |
 | STEP 2A. Inspect the lift pump relay and electrical connections. | Dirty or damaged pins?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the OEM harness and fuel lift pump relay connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the fuel lift pump signal. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2266 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the lift pump relay circuit.

Guided Step 2A - Inspect the lift pump relay and electrical connections.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the lift pump relay from the OEM harness.

Action

Inspect the lift pump relay connector and OEM harness connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the lift pump relay or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Inspect the OEM harness and fuel lift pump relay connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or the OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the fuel lift pump signal.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump from the OEM harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a short circuit in the lift pump relay signal.

  • Measure the resistance between the fuel lift pump relay SIGNAL pin at the OEM harness ECM connector and battery ground (-).

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the lift pump relay signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the lift pump relay from the harness.
  • Disconnect the OEM harness from the ECM.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the lift pump relay SIGNAL pin at the OEM harness ECM connector and all other pins in the ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A pin-to-pin short circuit has been detected in the lift pump relay signal circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 inactive?
YES NO

None. The removal and installation of the connector corrected the fault.

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check if an ECM calibration update is available.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 2416 - Engine Control Module Calibration Memory Checksum - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2416 active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2416 active?
YES NO

A calibration mismatch has been detected in the engine control module (ECM).

Calibrate the ECM. Refer to Procedure 019-032 in Section 19.

No Repair

Repair Complete

Repair Complete

Last Modified: 18-Dec-2014


FAULT CODE 2423 - Engine Injector Group 1 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2423 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the injector driver and return circuits. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check injector 1 for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check injector 4 for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check injector 6 for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check injector 7 for a short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Perform diagnostic tests. |
 | STEP 4A. Check the injector drain line. | Injector drain flow meets the specifications in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 2423 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2423 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector 1, 4, 6, and 7 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for a short circuit in the injector(s).

  • Measure the pin-to-pin resistance on the connector of injector 1, 4, 6, and 7.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the shorted injector. Refer to Procedure 006-026 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the injector driver and return circuits.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect injectors 1, 4, 6, and 7 from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check injector 1 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injectors 1, 4, 6, and 7 from the harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the injector.

  • Measure the resistance between the injector 1 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 1 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 1 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 1 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check injector 4 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injectors 1, 4, 6, and 7 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the injector.

  • Measure the resistance between the injector 4 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 4 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 4 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 4 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check injector 6 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injectors 1, 4, 6, and 7 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the injector.

  • Measure the resistance between the injector 6 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 6 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 6 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 6 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check injector 7 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injectors 1, 4, 6, and 7 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the injector.

  • Measure the resistance between the injector 7 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 7 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 7 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 7 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform diagnostic tests.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Fuel Injector Drain Line Restriction Test on bank 1.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain flow meets the specifications in Procedure 005-236?
YES NO
No Repair

Restriction in the injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2423 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Mar-2015


FAULT CODE 2424 - Engine Injector Group 2 Circuit - Current Above Normal or Grounded Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Drain Lines | Refer to Procedure 006-013 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2424 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the injector driver and return circuits. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check injector 2 for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check injector 3 for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check injector 5 for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check injector 8 for a short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Perform diagnostic tests. |
 | STEP 4A. Check the injector drain line. | Injector drain line meets specifications in Procedure 005-236?
 | STEP 4B. Check for an inactive fault code. | Fault Code 2424 inactive?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2424 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel injector 2, 3, 5, and 8 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector.

Action

Check for a short circuit in the injector(s).

  • Measure the pin-to-pin resistance on the connector of injector 2, 3, 5, and 8.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the shorted injector. Refer to Procedure 006-026 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3A

Guided Step 3 - Check the injector driver and return circuits.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect injectors 2, 3, 5, and 8 from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check injector 2 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injectors 2, 3, 5, and 8 from the harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the injector.

  • Measure the resistance between the injector 2 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 2 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 2 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 2 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3C

Guided Step 3C - Check injector 3 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injectors 2, 3, 5, and 8 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the injector.

  • Measure the resistance between the injector 3 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 3 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 3 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 3 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 5A

Go to 3D

Guided Step 3D - Check injector 5 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injectors 2, 3, 5, and 8 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the injector.

  • Measure the resistance between the injector 5 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 5 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 5 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 5 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check injector 8 for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injectors 2, 3, 5, and 8 from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the injector.

  • Measure the resistance between the injector 8 DRIVER pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 8 DRIVER pin at the ECM connector and battery negative (-).
  • Measure the resistance between the injector 8 RETURN pin at the ECM connector and battery positive (+).
  • Measure the resistance between the injector 8 RETURN pin at the ECM connector and battery negative (-).

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Perform diagnostic tests.

Guided Step 4A - Check the injector drain line.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Perform the Fuel Injector Drain Line Restriction Test on bank 2.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector drain line meets specifications in Procedure 005-236?
YES NO
No Repair

Restriction in the injector drain line has been detected.

Replace the injector drain line. Refer to Procedure 006-013 in the Associated Procedures Table.

Go to 4B

Go to 5A

Guided Step 4B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Operate engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2424 inactive?
YES NO
No Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Mar-2015


FAULT CODE 2442 - Injector Solenoid Driver Cylinder 1 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2442 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active counts of Fault Code 2442.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2442 active?
YES NO

The injector bar code adjustable parameter for cylinder 1 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in website online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 2443 - Injector Solenoid Driver Cylinder 2 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2443 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2443.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2443 active?
YES NO

The injector bar code adjustable parameter for cylinder 2 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 2444 - Injector Solenoid Driver Cylinder 3 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2444 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fualt Code 2444

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 2444 active?
YES NO

The injector bar code adjustable parameter for cylinder 3 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts. Refer to Procedure 006-026 in the Associated Procedures Table.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 2445 - Injector Solenoid Driver Cylinder 4 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2445 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2445.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2445 active?
YES NO

The injector bar code adjustable parameter for cylinder 4 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in website Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Dec-2014


FAULT CODE 2446 - Injector Solenoid Driver Cylinder 5 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2446 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2446.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2446 active?
YES NO

The injector bar code adjustable parameter for cylinder 5 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Dec-2014


FAULT CODE 2447 - Injector Solenoid Driver Cylinder 6 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2447 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2447.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2447 active?
YES NO

The injector bar code adjustable parameter for cylinder 6 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Dec-2014


FAULT CODE 3146 - Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalystic reduction (SCR) tempearture sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in Section 19.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 3147 - Aftertreatment SCR Outlet Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Repalce the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in Section 19.

Fault Code 3142 or 3143 troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 3148 - Aftertreatment SCR Outlet Temperature Sensor Circuit - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction (SCR) temperature sensor module has been detected.

Repalce the aftertreatment SCR temperature sensor module. Refer to Procedure 019-449 in Section 19.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 3177 - Glow Plug Control Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3177 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, 5736, or 5737 active?
STEP 2. | Check the glow plug control module circuit. |
 | STEP 2A. Inspect glow plug control module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the glow plug control module. | Voltage greater than 16.5 VDC? (For 12 VDC systems)?
 | STEP 2C. Check the condition of the glow plug control module. | Fault Code 3177 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery. | Battery Voltage greater than 16.5 VDC? (For 12 VDC systems)?
 | STEP 3B. Inspect the alternator. | Alternator charging within original equipment manufacturer (OEM) specifications?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, 5736, or 5737 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the glow plug control module circuit.

Guided Step 2A - Inspect glow plug control module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug control module from the engine harness.

Action

Inspect the engine harness and glow plug control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug control module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply (1-pin) and return circuit to the glow plug control module.

  • Measure the voltage between the glow plug control module battery voltage supply circuit at the glow plug control module wiring harness connector and engine block ground.

NOTE: Check the voltage with the engine at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 16.5 VDC? (For 12 VDC systems)?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the condition of the glow plug control module.

Conditions

  • Turn keyswitch ON.
  • Connect the glow plug control module.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3177 active?
YES NO

A malfunctioning glow plug control module has been detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the voltage of the battery.

Battery voltage greater than 16.5 VDC? (For 12 VDC systems)?
YES NO

Troubleshoot the cause of the overcharging condition.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO
No Repair

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Jan-2015


FAULT CODE 3178 - Glow Plug Control Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3178 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, 5736, or 5737 active?
STEP 2. | Check the glow plug control module circuit. |
 | STEP 2A. Inspect glow plug control module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the glow plug control module. | Voltage less than 6 VDC? (For 12 VDC systems)?
 | STEP 2C. Check the condition of the glow plug control module. | Fault Code 3178 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for blown fuse. | Fuse blown?
 | STEP 3C. Inspect the alternator. | Alternator charging within OEM specifications?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3178 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, 5736, or 5737 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the glow plug control module circuit.

Guided Step 2A - Inspect glow plug control module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug control module from the engine harness.

Action

Inspect the engine harness and glow plug control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug control module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply (1-pin) and return circuit to the glow plug control module.

  • Measure the voltage between the glow plug control module battery voltage supply circuit at the glow plug control module wiring harness connector and engine block ground.

NOTE: Check the voltage at key ON while cranking the engine, and with the engine at idle.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 6 VDC? (For 12 VDC systems)?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the condition of the glow plug control module.

Conditions

  • Turn keyswitch ON.
  • Connect the glow plug control module.
  • Turn keyswitch ON.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3178 active?
YES NO

A malfunctioning glow plug control module has been detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information..

Go to 3B

Go to 4A

Guided Step 3B - Check for a blown fuse.

Conditions

  • Turn keyswitch OFF.

Action

Check for a blown fuse.

  • Inspect the 60-ampere fuse to see if it is blown.

Fuse blown?
YES NO

Replace the fuse. Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3C

Guided Step 3C - Inspect the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an OEM ammeter or install an ammeter between the alternator and the battery.

Action

Check the charging rate of the alternator.

  • Start the engine and check the alternator's charging rate (amps).

NOTE: It will probably be necessary to place a load on the batteries to measure the alternator output properly.

Alternator charging within OEM specifications?
YES NO

An open circuit or high resistance has been detected in the glow plug control module battery voltage SUPPLY circuit.

Troubleshoot the OEM harness and all interconnects.

Repair or replace the damaged component. Refer to Procedure 019-071 in Section 19.

Repair or replace the alternator, regulator, and/or OEM wiring to the alternator. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Dec-2014


FAULT CODE 3179 - Glow Plug Heater Circuit Number 1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3179 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3187 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault code 3187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3179 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the sensor or harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the Glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3187 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected. Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the aftertreatment DEF controller harness and controller connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the Glowplug or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3187 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3181 - Glow Plug Heater Circuit Number 1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3181 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3187 active and 3181 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3181 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3181 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3187 active and 3181 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3181 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3182 - Glow Plug Heater Circuit Number 1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3182 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3188?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3188 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3182 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3188 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the Glowplug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3188 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3183 - Glow Plug Heater Circuit Number 2 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3183 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3188 active and 3183 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3182 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3183 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3188 active and 3183 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3182 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3184 - Glow Plug Heater Circuit Number 3 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3184 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3189?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3189 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3184 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3189 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3189 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3185 - Glow Plug Heater Circuit Number 3 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3185 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3189 active and 3185 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3185 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3185 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3189 active and 3185 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3185 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 4A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3187 - Glow Plug Heater Circuit Number 1 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3187 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3179 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3187 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3189 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug Heater 1 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3179 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3187 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the Glow plug Heater 1 pin at the Glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3179 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3188 - Glow Plug Heater Circuit Number 2 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3188 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3182 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3188 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3182 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3188 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the glow plug heater 2.

  • Place a jumper wire between the glow plug Heater 1 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3182 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3188 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the Glow plug heater 2 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3182 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3189 - Glow Plug Heater Circuit Number 3 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3189 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3184 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3189 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3184 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3189 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 3 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3184 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3189 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 3 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3184 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3191 - Glow Plug Heater Circuit Number 4 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3191 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3196 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3191 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3196 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3179, 3181, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3191 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 4 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3196 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3191 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 3 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3196 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3192 - Glow Plug Heater Circuit Number 5 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3198, 3199, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3192 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3198 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3192 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3198 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3198, 3199, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3192 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the glow plug heater 5.

  • Place a jumper wire between the glow plug heater 5 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3198 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3192 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the glow plug heater 5.

  • Place a jumper wire between the glow plug heater 5 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3198 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3193 - Glow Plug Heater Circuit Number 6 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3211, 3212, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3193 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3211 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3193 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3211 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3211, 3212, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3193 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 6 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3211 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3193 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 6 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3211 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3194 - Glow Plug Heater Circuit Number 7 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3213, 3214, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3194 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3215 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3194 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3215 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3213, 3214, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3194 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 7 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3215 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3194 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 7 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3215 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3195 - Glow Plug Heater Circuit Number 8 - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177, 3178, 3215, 3216, 3219, 3221, 3222 active?
 | STEP 1B. Check for active glow plug control module fault codes. | Fault Code 3195 active?
STEP 2. | Check the glow plug control module and circuit. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3217 active?
 | STEP 2C. Check the fault codes and verify the glow plug heater condition. | Fault code 3195 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3217 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177, 3178, 3215, 3216, 3219, 3221, 3222 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active glow plug control module fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3195 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and circuit.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 8 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3217 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug module to the harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 3195 active?
YES NO
No Repair

The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the glow plug heater 8 pin at the glow plug module connector and ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 3217 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

An open circuit in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3196 - Glow Plug Heater Circuit Number 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3196 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3191 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3191 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3191 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3191 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3197 - Glow Plug Heater Circuit Number 4 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3197 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3191 active and 3197 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3197 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3197 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3191 active and 3197 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3197 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3198 - Glow Plug Heater Circuit Number 4 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3198 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3192 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3192 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3198 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3192 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3192 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3199 - Glow Plug Heater Circuit Number 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3199 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3192 active and 3199 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3199 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3199 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3192 active and 3199 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3199 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3211 - Glow Plug Heater Circuit Number 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3211 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3193 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3193 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3211 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3193 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3193 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3212 - Glow Plug Heater Circuit #6 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3212 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3193 active and 3212 inactive?
 | STEP 2C. Check the glow plug. | Glow plug 6 fault code active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3212 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3193 active and 3212 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Glow plug 6 fault code active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3214 - Glow Plug Control Module - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3214 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3214 active?
YES NO

A malfunctioning glow plug control module has been detected.

Replace the glow plug controller module (GPCM). Refer to Procedure 013-010 in Section 13.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. See equipment manufacturer service information.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 3215 - Glow Plug Heater Circuit #7 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3215 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3194 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3194 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3215 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3194 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3194 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3216 - Glow Plug Heater Circuit #7 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3216 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3194 active and 3216 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3216 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3216 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3194 active and 3216 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3216 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3217 - Glow Plug Heater Circuit #8 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3217 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault Code 3195 active?
STEP 3. | Check the glow plug and circuit. |
 | STEP 3A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 3B. Check the glow plug. | Fault Code 3195 active?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3217 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3195 active?
YES NO
No Repair

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the glow plug and circuit.

Guided Step 3A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3195 active?
YES NO

Malfunctioning glow plug is detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

A short circuit to ground in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3218 - Glow Plug Heater Circuit #8 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3250 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3250 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3177 or 3178 active?
 | STEP 1B. Check for an active fault code. | Fault Code 3218 active?
STEP 2. | Check the glow plug control module and harness. |
 | STEP 2A. Inspect the glow plug control module and harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug control module. | Fault code 3195 active and 3218 inactive?
 | STEP 2C. Check the glow plug. | Fault Code 3218 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3177 or 3178 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3218 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug control module and harness.

Guided Step 2A - Inspect the glow plug control module and harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.

Action

Inspect the harness and module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the module harness connector or the glow plug connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug control module.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault code 3195 active and 3218 inactive?
YES NO

A short to battery positive in the glow plug harness is detected.

Replace the glow plug harness. Refer to Procedure 019-043 in the Associated Procedures Table.

A malfunctioning glow plug control module is detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2C

Go to 2C

Guided Step 2C - Check the glow plug.

Conditions

  • Reconnect glow plug harness to the glow plug.
  • Tun keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the Glow plug for progressive damage.

  • Use INSITE™ electronic service tool to check the fault codes.

NOTE: Glow plugs can be damaged when exposed to 12 volts for long period of time.

Fault Code 3218 active?
YES NO

A damage glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3219 - Glow Plug Control Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3250 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3250 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3219 active or more than 1 inactive count?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2636, or 3597 active or more than 1 inactive count?
 | STEP 1D. Check the fault codes. | Fault Code 2771, 3232, 3868, 3911, 4151, 4152, or 4572 active or more than 1 inactive count?
STEP 2. | Check the glow plug module (GPM) and circuit. |
 | STEP 2A. Inspect the GPM and connector pins | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the GPM. | Voltage greater than 10.8 VDC?
STEP 3. | Check the GPM and circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Resistance between 54 to 66 ohms?
STEP 4. | Check the power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 to 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 to 132 ohms?
STEP 6. | Check the J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5 volts?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.1 and 4.5 volts?
STEP 7. | Check ECM calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3219 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

NOTE: To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM and measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to the block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Electrical system voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 7A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636, or 3597 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1D

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3232, 3868, 3911, 4151, 4152, or 4572 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the glow plug module (GPM) and circuit.

Guided Step 2A - Inspect the GPM and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the GPM from the engine harness.

Action

Inspect the interface harness and GPM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the GPM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the GPM from the OEM supply harness.
  • Turn keyswitch ON.

Action

Check the power supply circuit to the GPM.

  • Measure the voltage between the GPM battery voltage supply circuit at the GPM wiring harness and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC?
YES NO
No Repair

An open or high resistance circuit has been detected in the GPM battery voltage supply circuit.

  • Troubleshoot the OEM harness, and all interconnects for the malfunction.
  • Repair or replace the damaged component as necessary.

Go to 3A

Go to 7A

Guided Step 3 - Check the GPM and circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the GPM at the GPM engine harness connector.

Action

Check the terminating resistance of the Society of Automotive Engineering (SAE) J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the GPM engine wiring harness connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES NO

A malfunction has been detected in the GPM.

  • Replace the GPM. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown glow plug module power supply fuse.
  • Inspect the glow plug module power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 data link.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 to 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3-pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3-pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 108 to 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

Reference the aftertreatment harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

Reference the engine harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3-pin service data link connector and battery ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

Reference the data link circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component.

Go to 6B

Go to 7A

Guided Step 6B - Check the J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit.

  • Measure the voltage between the SAE J1939 (-) pin at the 3-pin service data link connector and battery ground. Refer to Procedure 019-417 in the Associated Procedures Table.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

Reference the data link short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Dec-2014


FAULT CODE 3221 - Glow Plug Control Module - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 3219 active?
 | STEP 1B. Read the fault codes. | Fault Code 3221 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3219 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3221 active?
YES NO

A malfunctioning glow plug control module has been detected.

Replace the GPCM. Refer to Procedure 013-010 in Section 13.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 3222 - Glow Plug Control Module - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the glow plug control module. |
 | STEP 1A. Read the fault codes. | Fault Code 1117, 3178, or 3219 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Check the glow plug control module. | Fault Code 3222 active?
STEP 2. | Check the glow plug control module circuit. |
 | STEP 2A. Inspect glow plug control module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the glow plug control module. | Voltage greater than 6 VDC? (For 12 VDC systems)?
 | STEP 2C. Check the condition of the glow plug control module. | Fault Code 3222 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the glow plug control module.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1117, 3178, or 3219 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check the glow plug control module.

Conditions

  • Connect all components.

Action

Check the glow plug control module.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.

Fault Code 3222 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the glow plug control module circuit.

Guided Step 2A - Inspect glow plug control module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug control module from the OEM harness.

Action

Inspect the OEM harness and glow plug control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the glow plug control module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug control module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply (1 pin) and return circuit to the glow plug control module.

  • Measure the voltage between the glow plug control module battery voltage supply circuit at the glow plug control module wiring harness connector and engine block ground.

Check the voltage at key ON while cranking the engine, and with the engine at idle.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 6 VDC? (For 12 VDC systems)?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the condition of the glow plug control module.

Conditions

  • Turn keyswitch ON.
  • Connect the glow plug control module.
  • Turn keyswitch ON.

Action

Check the glow plug control module.

  • Turn the keyswitch OFF and wait 5 seconds.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 3222 active?
YES NO

A malfunctioning glow plug control module has been detected.

Replace the glow plug control module. Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO

An open circuit has been detected in the glow plug control module battery voltage SUPPLY circuit.

Repair or replace the OEM harness. See equipment manufacturer service information.

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jan-2016


FAULT CODE 3228 - Aftertreatment 1 Intake NOx Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3228 active?
 | STEP 1B. Check for active fault codes. | Fault code 1885, 3232, 3649, 3682, or 3748 active?
STEP 2. | Check exhaust gas recirculation (EGR) system for leaks. |
 | STEP 2A. Check the EGR system for leaks. | Leaks detected in the EGR system?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3228 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1885, 3232, 3649, 3682, or 3748 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 2A

Guided Step 2 - Check EGR system for leaks.

Guided Step 2A - Check the EGR system for leaks.

Conditions

  • Turn keyswitch ON.

Action

Inspect the EGR system for external leaks.

  • Leaks should be easily noted by traces of soot.
  • If necessary, run the engine at idle speed to help detect any EGR leaks.

Leaks detected in the EGR system?
YES NO

Repair or replace the leaking EGR system component.

A damaged aftertreatment intake NOx sensor has been detected.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-463 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 3232 - Aftertreatment Intake NOx Sensor - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Variable Geometry Turbocharger Actuator, Electric | Refer to Procedure 010-134 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3232 active or more than one inactive count?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2536 or 3597 active or more than one inactive count?
 | STEP 1D. Check the fault codes. | Fault Code 3219, 3232, 3868, 4151, or 4152 active or more than one inactive count?
STEP 2. | Check the aftertreatment intake mono-nitrogen oxides (NOx) sensor and circuit. |
 | STEP 2A. Inspect aftertreatment intake NOx sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment intake NOx sensor. | Voltage greater than 10.8 VDC?
 | STEP 2C. Check the voltage to the aftertreatment intake NOx sensor. | Voltage greater than 10.8 VDC?
STEP 3. | Check the aftertreatment intake NOx sensor and circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Resistance between 54 to 66 ohms?
STEP 4. | Check the power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
 | STEP 4B. Check for an open circuit in the J1939 data link harness. | Less than 10 ohms?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 and 132 ohms?
STEP 6. | Check the J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5 volts?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.1 and 4.5 volts?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3232 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Make sure the Electrical System Voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Note: To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM. Measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical system voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 7A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 3597 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1D

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3219, 3232, 3868, 4151, or 4152 active or more than one inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment intake NOx sensor and circuit.

Guided Step 2A - Inspect aftertreatment intake NOx sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.

Action

Inspect the interface harness and aftertreatment intake NOx sensor connector.

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit and the aftertreatment intake NOx sensor return circuit at the NOx sensor wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 10.8 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment intake NOx sensor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment intake NOx sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment intake NOx sensor.

  • Measure the voltage between the aftertreatment intake NOx sensor battery voltage supply circuit at the aftertreatment intake NOx sensor wiring harness connector and battery ground.

Note: Check the voltage at keyswitch ON while cranking the engine.

Use the circuit diagram or wiring diagram for connector pin identificiation.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage greater than 10.8 VDC?
YES NO

An open or high resistance circuit has been detected in the aftertreatment intake NOx sensor battery voltage return circuit.

  • Troubleshoot the OEM harness and all interconnects for the malfunction.
  • Repair or replace the damaged component, as necessary.

An open or high resistance circuit has been detected in the aftertreatment intake NOx sensor battery voltage supply circuit.

  • Troubleshoot the OEM harness and all interconnects for the malfunction.
  • Repair or replace the damaged component, as necessary.

Go to 7A

Go to 7A

Guided Step 3 - Check the aftertreatment intake NOx sensor and circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the3 pin service data link connector.
  • Disconnect the aftertreatment intake NOx sensor.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the aftertreatment intake NOx sensor wiring harness connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 and 66 ohms?
YES NO

A malfunction has been detected in the aftertreatment intake NOx sensor.

Replace the aftertreatment intake NOx sensor. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Inspect for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 data link.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 and 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (-) at the aftertreatment intake NOx sensor wiring harness connector. Refer to Procedure 019-417 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 108 and 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

See the aftertreatment harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

See the aftertreatment harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3 pin service data link connector and battery ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES | NO
No Repair | No Repair

Go to 6B

Go to 7A

Guided Step 6B - Check teh J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (-) at the 3 pin service data link connector and battery ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

See data link short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Jan-2015


FAULT CODE 3748 - Aftertreatment 1 Intake NOx Sensor - Data Not Rational - Drifted High

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Intake NOx Sensor | Refer to Procedure 019-463 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3748 active?
 | STEP 1B. Check for active fault codes. | Fault Code 1885, 3232, 3649, or 3682 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3748 active?
YES | NO
No Repair | No Repair

Go to 1B

Go to 3A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1885, 3232, 3649, or 3682 active?
YES NO
No Repair

Verify the aftertreatment intake mono-nitrogen oxides (NOx) sensor is present and has been installed properly.

If the aftertreatment intake NOx sensor is present and installed properly, a damaged aftertreatment intake NOx sensor is a possible cause.

Replace the aftertreatment intake NOx sensor.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 4151 - Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4151 active or more than 1 inactive count?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2636 or 3597 active or more than 1 inactive count?
 | STEP 1D. Check the fault codes. | Fault Code 2771, 3219, 3232, 3911, 4152, or 4572 active or more than 1 inactive count?
STEP 2. | Check the aftertreatment diesel particulate filter (DPF) temperature sensor module and circuit. |
 | STEP 2A. Inspect the aftertreatment DPF temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment DPF temperature sensor module. | Voltage greater than 10.8 VDC?
 | STEP 2C. Check the voltage to the aftertreatment DPF temperature sensor module. | Voltage greater than 10.8 VDC?
STEP 3. | Check the aftertreatment DPF temperature sensor module and circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
STEP 4. | Check teh power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 and 132 ohms?
STEP 6. | Check teh J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5 volts?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.1 and 4.5 volts?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4151 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Makes sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Note: To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM. Measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical system voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 7A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 3597 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1D

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3219, 3232, 3868, 3911, 4152, or 4572 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment DPF temperature sensor module and circuit.

Guided Step 2A - Inspect the aftertreatment DPF temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM harness.

Action

Inspect the interface harness and aftertreatment DPF temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment DPF temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet mono-nitrogen oxides (NOx) sensor.

  • Measure the voltage between the aftertreatment outlet NOx battery voltage supply circuit and the aftertreatment DPF temperature sensor module battery voltage return circuit at the aftertreatment DPF temperature sensor module wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment DPF temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment DPF temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment DPF temperature sensor module.

  • Measure the voltage between the aftertreatment DPF temperature sensor module battery voltage supply circuit at the aftertreatment DPF temperature sensor module wiring harness connector and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC?
YES NO

An open or high resistance circuit has been detected in the aftertreatment DPF temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects for the malfunction.

Repair or replace the damaged component, as necessary.

An open or high resistance circuit has been detected in the aftertreatment DPF temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects for the malfunction.

Repair or replace the damaged component, as necessary.

Go to 7A

Go to 7A

Guided Step 3 - Check the aftertreatment DPF temperature sensor module and circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the aftertreatment DPF temperature sensor module.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the aftertreatment DPF temperature sensor module wiring harness connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 and 66 ohms?
YES NO

A malfunction has been detected in the aftertreatment DPF temperature sensor module.

Replace teh aftertreatment DPF temperature sensor module. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Check for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 data link.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 and 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 108 and 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

See the aftertreatment harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

See the engine harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3 pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

See data link short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component.

Go to 6B

Go to 7A

Guided Step 6B - Check the J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit.

  • Measure the voltage between the SAE J1939 (-) pin at the 3 pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

See data link short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 4152 - Aftertreatment Selective Catalyst Reduction Temperature Sensor Module - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Data Link Circuit, Proprietary | Refer to Procedure 019-417 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Outlet NOx Sensor | Refer to Procedure 019-451 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152 active or more than 1 inactive count?
 | STEP 1B. Check for correct adjustable parameter settings. | Electrical system voltage parameter correct for the engine configuration?
 | STEP 1C. Check the fault codes. | Fault Code 2636 or 3597 active or more than 1 inactive count?
 | STEP 1D. Check the fault codes. | Fault Code 2771, 3219, 3232, 3911, 4151, or 4572 active or more than 1 inactive count?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module and circuit. |
 | STEP 2A. Inspect the aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage greater than 10.8 VDC?
 | STEP 2C. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage greater than 10.8 VDC?
STEP 3. | Check the aftertreatment SCR temperature sensor module and circuit. |
 | STEP 3A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
STEP 4. | Check the power distribution center and fuse(s). |
 | STEP 4A. Check the power distribution center and fuse(s). | Power distribution center and fuse(s) damaged or corroded?
STEP 5. | Check the J1939 data link. |
 | STEP 5A. Check the J1939 terminating resistance. | Resistance between 54 and 66 ohms?
 | STEP 5B. Check the J1939 terminating resistance. | Resistance between 108 and 132 ohms?
STEP 6. | Check teh J1939 data link circuit. |
 | STEP 6A. Check the J1939 data link (+) for a short circuit. | Voltage between 0.1 and 4.5 volts?
 | STEP 6B. Check the J1939 data link (-) for a short circuit. | Voltage between 0.1 and 4.5 volts?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for correct adjustable parameter settings.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct adjustable parameter settings.

  • Makes sure the electrical system voltage setting in INSITE™ electronic service tool is correct for the engine configuration.

Note: To check the voltage configuration of the engine, disconnect the original equipment manufacturer (OEM) connector from the ECM. Measure the voltage from the ECM battery SUPPLY (+) pin of the OEM harness ECM connector to block ground.

Electrical system voltage parameter correct for the engine configuration?
YES NO
No Repair

Use INSITE™ electronic service tool to configure the electrical system voltage to match the engine configuration.

Go to 1C

Go to 7A

Guided Step 1C - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2636 or 3597 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 5A

Go to 1D

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2771, 3219, 3232, 3868, 3911, 4151, or 4572 active or more than 1 inactive count?
YES | NO
No Repair | No Repair

Go to 4A

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module and circuit.

Guided Step 2A - Inspect the aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the interface harness and aftertreatment SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

 No Repair

Go to 7A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment outlet mono-nitrogen oxides (NOx) sensor.

  • Measure the voltage between the aftertreatment outlet NOx battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.

Check the voltage at keyswitch ON and while cranking the engine.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit at the aftertreatment SCR temperature sensor module wiring harness connector and battery ground.

Check the voltage at keyswitch ON and while cranking the engine.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 10.8 VDC?
YES NO

An open or high resistance circuit has been detected in the aftertreatment SCR temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects for the malfunction.

Repair or replace the damaged component, as necessary.

An open or high resistance circuit has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects for the malfunction.

Repair or replace the damaged component, as necessary.

Go to 7A

Go to 7A

Guided Step 3 - Check the aftertreatment SCR temperature sensor module and circuit.

Guided Step 3A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the aftertreatment SCR temperature sensor module.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the aftertreatment SCR temperature sensor module wiring harness connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 and 66 ohms?
YES NO

A malfunction has been detected in the aftertreatment SCR temperature sensor module.

Replace the aftertreatment SCR temperature sensor module. Refer to Procedure 019-451 in the Associated Procedures Table.

 No Repair

Go to 7A

Go to 5A

Guided Step 4 - Check the power distribution center and fuse(s).

Guided Step 4A - Check the power distribution center and fuse(s).

Conditions

  • Turn keyswitch OFF.

Action

Check the power distribution center and fuse(s).

  • Check for a blown aftertreatment sensor power supply fuse.
  • Inspect the aftertreatment sensor power supply fuse for cracks, burns, corrosion, or discoloration.
  • Inspect the power distribution center for loose or expanded pins.
  • Inspect the power distribution center for corrosion.

Power distribution center and fuse(s) damaged or corroded?
YES NO

Repair or replace the damaged component(s). See equipment manufacturer service information.

 No Repair

Go to 7A

Go to 5A

Guided Step 5 - Check the J1939 data link.

Guided Step 5A - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 54 and 66 ohms?
YES | NO
No Repair | No Repair

Go to 6A

Go to 5B

Guided Step 5B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the INLINE™ adapter from the 3 pin service data link connector.
  • Disconnect the OEM ECM connector.

Action

Check the terminating resistance of the SAE J1939 data link.

  • Measure the resistance between the SAE J1939 (+) and SAE J1939 (-) at the 3 pin service data link connector.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 108 and 132 ohms?
YES NO

A malfunction has been detected in the aftertreatment side of the SAE J1939 data link circuit.

Continue to troubleshoot the aftertreatment side of the proprietary data link.

See the aftertreatment harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

A malfunction has been detected in the engine side of the SAE J1939 data link circuit.

Continue to troubleshoot the engine side of the proprietary data link.

See the engine harness isolation check. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component(s).

Go to 7A

Go to 7A

Guided Step 6 - Check the J1939 data link circuit.

Guided Step 6A - Check the J1939 data link (+) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (+) for a short circuit.

  • Measure the voltage between the SAE J1939 (+) pin at the 3 pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

See data link short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component.

Go to 6B

Go to 7A

Guided Step 6B - Check the J1939 data link (-) for a short circuit.

Conditions

  • Turn keyswitch ON.

Action

Check the SAE J1939 data link (-) for a short circuit.

  • Measure the voltage between the SAE J1939 (-) pin at the 3 pin service data link connector and battery ground.
  • Refer to Procedure 019-417 in the Associated Procedures Table.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Voltage between 0.1 and 4.5 volts?
YES NO
No Repair

A short circuit has been detected in the SAE J1939 data link circuit.

Continue to troubleshoot the proprietary data link.

See data link short circuit isolation. Refer to Procedure 019-417 in the Associated Procedures Table.

Repair or replace the malfunctioning component.

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Dec-2014


FAULT CODE 4158 - Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4151, 4161, 4162, 4163, or 4259 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4151, 4161, 4162, 4163, or 4259 active?
YES NO
No Repair

A malfunctioning aftertreatment diesel particulate filter (DPF) temperature sensor module has been detected.

Replace the aftertreatment DPF temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Nov-2014


FAULT CODE 4159 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4152, 4164, 4165, 4166, or 4261 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Codes 4152, 4164, 4165, 4166, or 4261 active?
YES NO
No Repair

A malfunctioning aftertreatment selective catalytic reduction temperature sensor module has been detected.

Replace the aftertreatment selective catalytic reduction temperature sensor module. Refer to procedure 019-449 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Nov-2014


FAULT CODE 4161 - Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4161 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment diesel particulate filter temperature sensor module circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment diesel particulate filter temperature sensor module. | Voltage greater than 18 VDC? (for 12 VDC systems)
 | STEP 2C. Check for correct aftertreatment diesel particulate filter temperature sensor module. | Aftertreatment diesel particulate filter temperature sensor module is the correct sensor for the engine configuration?
 | STEP 2D. Check the condition of the aftertreatment diesel particulate filter temperature sensor module. | Fault Code 4161 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery. | Battery voltage greater than 18 VDC? (for 12 VDC systems)
 | STEP 3B. Check for a short circuit in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply. | Battery voltage greater than 18 VDC? (for 12 VDC systems)
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4161 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment diesel particulate filter temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment diesel particulate filter temperature sensor module.

  • Measure the voltage between the aftertreatment diesel particulate filter temperature sensor module battery voltage supply circuit and the aftertreatment diesel particulate filter temperature sensor module battery voltage return circuit at the aftertreatment diesel particulate filter temperature sensor module wiring harness connector.
  • Check the voltage at keyswitch ON while cranking the engine and check again with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 18 VDC? (For 12 VDC systems)
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for correct aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Remove aftertreatment diesel particulate filter temperature sensor module.

Action

Verify the aftertreatment diesel particulate filter temperature sensor module is correct for the engine configuration.

Aftertreatment diesel particulate filter temperature sensor module is the correct sensor for the engine configuration?
YES NO
No Repair

Replace the aftertreatment diesel particulate filter temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the condition of the aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter temperature sensor module.
  • Start and idle the engine.

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4161 active?
YES NO

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the battery voltage.

Battery voltage greater than 18 VDC? (for 12 VDC systems)?
YES NO

Troubleshoot the cause of the overcharging condition.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.

Action

Check for an short circuit.

  • Measure the voltage from the aftertreatment diesel particulate filter temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Battery voltage greater than 18 VDC? (for 12 VDC systems)?
YES NO

A short circuit to battery has been detected in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 4162 - Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISB5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4162 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment diesel particulate filter temperature sensor module circuit. |
 | STEP 2A. Inspect the aftertreatment diesel particulate filter temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment diesel particulate filter temperature sensor module. | Voltage less than 6 VDC? (For 12 VDC systems)
 | STEP 2C. Check the condition of the aftertreatment diesel particulate filter temperature sensor module. | Fault Code 4162 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply. | Voltage less than 6 VDC? (For 12 VDC systems)
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4162 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the aftertreatment diesel particulate filter temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment diesel particulate filter temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment diesel particulate filter temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. See equipment manufacturer service information.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment diesel particulate filter temperature sensor module.

  • Measure the voltage between the aftertreatment diesel particulate filter temperature sensor module battery voltage supply circuit and the aftertreatment diesel particulate filter temperature sensor module battery voltage return circuit at the aftertreatment diesel particulate filter temperature sensor module wiring harness connector.
  • Check the voltage at keyswitch ON while cranking the engine and check again with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 VDC? (For 12 VDC systems)
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the condition of the aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment diesel particulate filter temperature sensor module.
  • Start and idle the engine

Action

Check the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4162 active?
YES NO

A malfunctioning aftertreatment diesel particulate filter temperature sensor module has been detected.

Replace the aftertreatment diesel particulate filter temperature sensor module.

Refer to Procedure 019-449 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the original equipment manufacturer (OEM) harness.

Guided Step 3A - Check the battery and power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment diesel particulate filter temperature sensor module from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment diesel particulate filter temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC? (For 12 VDC systems)
YES NO

An open circuit or high resistance has been detected in the aftertreatment diesel particulate filter temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment diesel particulate filter temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 4163 - Aftertreatment Diesel Particulate Filter Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Heat Shield | Refer to Procedure 011-032 | ISV5.0 CM3230 V104 | 4367291
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4163 active or more than three inactive counts?
STEP 2. | Check the aftertreatment diesel particulate filter temperature sensor module. |
 | STEP 2A. Make sure that the aftertreatment diesel particulate filter temperature sensor module is properly mounted. | Aftertreatment diesel particulate filter temperature sensor module properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment diesel particulate filter temperature sensor module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4163 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment diesel particulate filter temperature sensor module.

Guided Step 2A - Make sure that the aftertreatment diesel particulate filter temperature sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating.

Action

Verify the aftertreatment diesel particulate filter temperature sensor module is properly mounted.

  • Verify the module is mounted correctly.
  • Verify the proper heat shield is mounted over the temperature sensor module.
  • Refer to Procedure 019-449 in the Associated Procedures Table.

Aftertreatment diesel particulate filter temperature sensor module properly installed?
YES NO
No Repair

Relocate and/or secure the aftertreatment diesel particulate filter temperature sensor module at the correct mounting location.

  • Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment diesel particulate filter temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating.

Action

Check the aftertreatment diesel particulate filter temperature sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module.
  • Aftermarket shields, flaps, or brackets mounted too close to the module.
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the temperature sensor module. Relocate any aftermarket accessories that might be restricting air flow. Repair any causes of excessive heat to the temperature sensor module.

See equipment manufacturer service information for proper aftertreatment installation.

Go to 3A

Repair complete.

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Jan-2015


FAULT CODE 4164 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Above Normal or Shorted to High Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4164 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage greater than 18 VDC (for 12 VDC systems)?
 | STEP 2C. Check the condition of the aftertreatment SCR temperature sensor module. | Fault Code 4164 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery. | Voltage greater than 18 VDC (for 12 VDC systems)?
 | STEP 3B. Check for a short circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage greater than 18 VDC (for 12 VDC systems)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4164 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment SCR temperature sensor module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 18 VDC (for 12 VDC systems)?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the condition of the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR temperature sensor module.
  • Start and idle the engine.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4164 active?
YES NO

A malfunctioning aftertreatment SCR temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery voltage.

  • Measure the voltage of the battery.

Battery voltage greater than 18 VDC (for 12 VDC systems)?
YES NO

Troubleshoot the cause of the overcharging condition.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Check for a short circuit

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage greater than 18 VDC (for 12 VDC systems)?
YES NO

A short circuit to battery has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Dec-2014


FAULT CODE 4165 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4165 active?
 | STEP 1B. Check for active fault codes. | Fault Code 441, 442, 596, 597, or 598 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage less than 6 VDC (for 12 VDC systems)?
 | STEP 2C. Check the condition of the aftertreatment SCR temperature sensor module. | Fault Code 4165 active?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage less than 6 VDC (for 12 VDC systems)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4165 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module circuit.

Guided Step 2A - Inspect aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet NOx sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine, and with the engine at idle.

Use the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 VDC (for 12 VDC systems)?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the condition of the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Connect the aftertreatment SCR temperature sensor module.
  • Start and idle the engine.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to check the active fault codes.

Fault Code 4165 active?
YES NO

A malfunctioning aftertreatment SCR temperature sensor module has been detected.

Replace the aftertreatment SCR temperature sensor module.

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten any loose connections. Clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Check for an open circuit

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC (for 12 VDC systems)?
YES NO

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 09-Dec-2014


FAULT CODE 4166 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Aftertreatment Exhaust Gas Temperature Sensor | Refer to Procedure 019-449 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 4166 active or more than three inactive counts?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module. |
 | STEP 2A. Make sure that the aftertreatment SCR temperature sensor module is properly mounted. | Aftertreatment SCR temperature sensor module properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the aftertreatment SCR temperature sensor module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4166 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module.

Guided Step 2A - Make sure that the aftertreatment SCR temperature sensor module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating

Action

Verify the aftertreatment SCR temperature sensor module is properly mounted.

  • Verify the module is mounted correctly.
  • Verify the proper heat shield is mounted over the temperature sensor module. Refer to Procedure 019-449 in the Associated Procedures Table.

Aftertreatment SCR temperature sensor module properly installed?
YES NO
No Repair

  • Relocate and/or secure the aftertreatment SCR temperature sensor module at the correct mounting location. Refer to Procedure 019-449 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Engine not operating.

Action

Check the aftertreatment SCR temperature sensor module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module.
  • Aftermarket shields, flaps, or brackets mounted too close to the module.
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow. Remove any debris accumulated near the temperature sensor module. Relocate any aftermarket accessories that might be restricting air flow. Repair any causes of excessive heat to the temperature sensor module.

See equipment manufacturer service information for proper aftertreatment installation.

Go to 3A

Repair Complete

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 23-Dec-2014


FAULT CODE 4261 - Aftertreatment Selective Catalytic Reduction Temperature Sensor Module - Root Cause Not Known

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4261 active?
 | STEP 1B. Check for active fault codes. | Fault Code 6257, 6256, 596, 597, or 598 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4152 or 4165 active?
STEP 2. | Check the aftertreatment selective catalytic reduction (SCR) temperature sensor module circuit. |
 | STEP 2A. Inspect aftertreatment SCR temperature sensor module and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the aftertreatment SCR temperature sensor module. | Voltage less than 6 VDC (for 12 VDC systems)?
STEP 3. | Check the original equipment manufacturer (OEM) harness. |
 | STEP 3A. Check the battery and the power connector. | Connections tight and corrosion-free?
 | STEP 3B. Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply. | Voltage less than 6 VDC (for 12 VDC systems)?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4261 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6257, 6256, 596, 597, or 598 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4152 or 4165 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check the aftertreatment SCR temperature sensor module circuit.

Guided Step 2A - Inspect the aftertreatment SCR temperature sensor module and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Inspect the OEM harness and aftertreatment outlet mono-nitrogen oxides (NOx) sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connector has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the voltage to the aftertreatment SCR temperature sensor module.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the aftertreatment SCR temperature sensor module.

  • Measure the voltage between the aftertreatment SCR temperature sensor module battery voltage supply circuit and the aftertreatment SCR temperature sensor module battery voltage return circuit at the aftertreatment SCR temperature sensor module wiring harness connector.

Note: Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage less than 6 VDC (for 12 VDC systems)?
YES NO
No Repair

An intermittent connection has been detected at the aftertreatment SCR temperature sensor module.

Troubleshoot the connector and OEM harness for intermittent shorts and/or opens.

Repair or replace the damaged component.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM harness.

Guided Step 3A - Check the battery and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the connections.

Tighten any loose connections and clean the terminals. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check for an open circuit in the aftertreatment SCR temperature sensor module battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the aftertreatment SCR temperature sensor module from the OEM harness.

Action

Check for an open circuit.

  • Measure the voltage from the aftertreatment SCR temperature sensor module battery voltage SUPPLY pin of the OEM harness to engine block ground.

Voltage less than 6 VDC (for 12 VDC systems)?
YES NO

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage supply circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

An open circuit or high resistance has been detected in the aftertreatment SCR temperature sensor module battery voltage return circuit.

Troubleshoot the OEM harness and all interconnects. Repair or replace the damaged component.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Nov-2014


FAULT CODE 4643 - Injector Solenoid Driver Cylinder 7 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4643 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4643.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4643 active?
YES NO

The injector bar code adjustable parameter for cylinder 7 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in a website online by entering the correct engine serial number, selecting Service, and then Engine Data Plate. The correct injector bar code values for that engine serial number are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Dec-2014


FAULT CODE 4644 - Injector Solenoid Driver Cylinder 8 - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4644 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4644.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4644 active?
YES NO

The injector bar code adjustable parameter for cylinder 8 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in a website online by entering the correct engine serial number, selecting Service, and then Engine Data Plate. The correct injector bar code values for that engine serial number are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Dec-2014


FAULT CODE 4691 - Engine Injector Metering Rail 1 Cranking Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Priming | Refer to Procedure 005-234 | ISV5.0 CM3230 V104 | 4367291
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Injector Supply Lines (High-Pressure) | Refer to Procedure 006-051 | ISV5.0 CM3230 V104 | 4367291
Fuel Pressure Relief Valve | Refer to Procedure 006-061 | ISV5.0 CM3230 V104 | 4367291
Fuel Rail Supply Line (High-Pressure) | Refer to Procedure 006-071 | ISV5.0 CM3230 V104 | 4367291
Fuel Rail to Fuel Rail Supply Line (High-Pressure) | Refer to Procedure 006-084 | ISV5.0 CM3230 V104 | 4367291
Fuel Pump Actuator | Refer to Procedure 019-117 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Any active injector circuit fault codes?
 | STEP 1B. Check for active or inactive fault codes. | Fault Code 268, 271, 272, 281, 451, 452, 482, 553, 554, 4262, 4263, 5736, 5737, or 6239 active or inactive counts?
STEP 2. | Check the high-pressure fuel system. |
 | STEP 2A. Check for leaks in the high-pressure fuel system. | Engine starts?
 | STEP 2B. Check for leaks in the high-pressure system. | Leak detected?
 | STEP 2C. Check the fuel pump actuator and the pressure relief valve. | Actuators within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 2D. Check the injector return flow. | Injector return flows meet the specifications found in Procedure 005-236 in the Associated Procedures Table?
STEP 3. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active injector fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Any active injector circuit fault codes?
YES NO

Troubleshoot active fault codes first.

 No Repair

Go to the appropriate fault code troubleshooting symptom tree.

Go to 1B

Guided Step 1B - Check for active or inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 268, 271, 272, 281, 451, 452, 482, 553, 554, 4262, 4263, 5736, 5737, or 6239 active or inactive counts?
YES NO

Troubleshoot the fault codes listed above first.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the high-pressure fuel system.

Guided Step 2A - Check for leaks in the high-pressure system.

Conditions

  • Turn keyswitch ON.

Wait 30 seconds for the lift pump to prime.

Action

Check to see if the engine starts.

  • It can be necessary to crank the engine for 30 seconds to prime the fuel system.
  • Refer to Procedure 005-234 in the Associated Procedures Table.

Engine starts?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for leaks in the high-pressure system.

Conditions

  • Turn keyswitch OFF.

Action

Check the following for fuel leaks:

  • Fuel rail supply line: Refer to Procedure 006-071 in the Associated Procedures Table.
  • Fuel rail to fuel rail supply line: Refer to Procedure 006-084 in the Associated Procedures Table.
  • Injector supply lines: Refer to Procedure 006-051 in the Associated Procedures Table.

Leak detected?
YES NO

Repair or replace the leaking component.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel pump actuator and the pressure relief valve.

Conditions

  • Turn keyswitch ON.

Action

Perform the High-Pressure Fuel System Override in INSITE™ electronic service tool.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Actuators within specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

If the fuel pump actuator is not within specifications, replace the fuel pump actuator.

  • Refer to Procedure 019-117 in the Associated Procedures Table.

If the fuel pressure relief valve is not within specifications, replace the fuel pressure relief valve.

  • Refer to Procedure 006-061 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the injector return flow.

Conditions

  • Turn keyswitch ON.
  • Start and idle the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for excessive fuel leakage from the injectors. Run the High-Pressure Fuel Injector Return Flow Test - Engine Will Not Start.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Injector return flows meet the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Replace the leaking injector(s).

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Repair or replace the damaged component(s).

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check ECM calibration and clear fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Aug-2015


FAULT CODE 5296 - Glow Plug Module Internal Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 5296 active or more than three inactive counts?
STEP 2. | Check the glow plug module. |
 | STEP 2A. Make sure the glow plug is properly mounted. | Glow plug properly installed?
 | STEP 2B. Check for obstructed or restricted air flow to the glow plug module. | Signs of air flow restriction or excessive heat to temperature sensor module?
STEP 3. | Check if an engine control module (ECM) calibration update is available. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5296 active or more than three inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the glow plug module.

Guided Step 2A - Make sure the glow plug module is properly mounted.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Verify the glow plug module is properly mounted.

  • Verify the module is mounted correctly. Refer to Procedure 013-010 in the Associated Procedures Table.

Glow plug module properly installed?
YES NO
No Repair

Relocate and/or secure the glow plug module at the correct mounting location. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check for obstructed or restricted air flow to the glow plug module.

Conditions

  • Turn keyswitch OFF.
  • Do not operate engine.

Action

Check the glow plug module mounting area for air flow obstructions. Restrictions or blockage of the air flow could cause the temperature sensor module to overheat. Check for the following:

  • Debris on or around the temperature sensor module
  • Aftermarket shields, flaps, or brackets mounted too close to the module
  • Exhaust leaks allowing exhaust to overheat the temperature sensor module.

Signs of air flow restriction or excessive heat to temperature sensor module?
YES NO

Repair the cause of the restricted air flow.

Remove any debris accumulated near the temperature sensor module.

Relocate any aftermarket accessories restricting air flow.

Repair any causes of excessive heat to the temperature sensor module.

Replace the glow plug module. Refer to Procedure 013-010 in the Associated Procedures Table.

Go to 3A

Repair complete

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Nov-2014


FAULT CODE 5324 - Glow Plug Module - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for an active Fault Code 3219. | Fault Code 3219 active?
 | STEP 1B. Check for an active Fault Code 5324. | Fault Code 5324 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active faults.

Guided Step 1A - Check for an active Fault Code 3219.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3219 active?
YES | NO
No Repair | No Repair

Fault Code 3219 troubleshooting tree

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for an active Fault Code 5324.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5324 active?
YES NO

The glow plug module has an internal issue.

Replace the glow plug module.

Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 2A

2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Dec-2014


FAULT CODE 5415 - Engine Glow Plug 1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3179, 3181 or 3187 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5415 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Less than 1 ohm?
 | STEP 2D. Check the fault codes and verify the glow plug heater condition. | Fault Code 5415 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3179, 3181 or 3187 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5415 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 1 pin in the engine harness glow plug connector and block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5 ohms?
YES NO

A malfunctioning glow plug has been detected.

Replace the glow plug module. Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.
  • Disconnect the glow plug 1 from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow glug 1 and the block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance has been detected in the harness.

Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

High resistance has been detected in the glow plug.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 5416 - Engine Glow Plug 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3182, 3183, or 3188 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5416 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness. | Less than 1 ohm?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3182, 3183 or 3188 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5416 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the flow plug module.

Action

Check for high resistance.

  • Measure the resistance from glow plug 2 pin at the glow plug harness connector to block ground.

Less than 1.5 ohms?
YES NO

Malfunctioning glow plug module has been detected.

Replace the glow plug module. Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug module.
  • Disconnect glow plug 2 from the engine harness.

Action

Check for an open.

  • Measure the resistance between glow plug 2 and the block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance in the harness has been detected.

Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

High resistance in the glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 5417 - Engine Glow Plug 3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3184, 3185, or 3189 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5417 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the harness for a pin-to-pin short. | Less than 1 ohm?
 | STEP 2D. Check the fault codes and verify the glow plug heater condition. | Fault Code 5417 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3184, 3185, or 3189 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5417 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for high resistance.

  • Measure the resistance from glow plug 3 pin at the glow plug harness connector to block ground.

Refer to the wiring diagram for connector pin identification.

Less than 1.5 ohms?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check the engine harness for a pin-to-pin short.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug module.
  • Disconnect glow plug 3 from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 3 and the block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance has been detected in the glow plug.

Replace the glow plug. Refer to 010-030 in the Associated Procedures Table.

High resistance has been detected in the harness.

Repair or replace the harness. Refer to 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 2D - Check the fault codes and verify the glow plug heater condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the glow plug to the harness.
  • Turn keyswitch ON for 1 minute.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to check the fault codes.

Fault Code 5417 active?
YES NO

A malfunctioning glow plug has been detected.

Replace the glow plug module. Refer to 013-010 in the Associated Procedures Table.

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 5418 - Engine Glow Plug 4 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3191, 3196 or 3197 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5418 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness. | Less than 1 ohm?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3191, 3196 or 3197 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5418 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for high resistance.

  • Measure the resistance from glow plug 4 pin at the glow plug harness connector to block ground.

Less than 1.5 ohms?
YES NO

A malfunctioning glow plug has been detected.

Replace the glow plug.

Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug harness from the glow plug module.
  • Disconnect glow plug 4 from the engine harness.

Action

Check for an open.

  • Measure the resistance between glow plug 4 and the block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance has been detected in the harness.

Repair replace the harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

High resistance has been detected in the glow plug.

Replace the glow plug.

Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 5419 - Engine Glow Plug 5 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3192, 3198, or 3199 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5419 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness. | Less than 1 ohm?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3192, 3198, or 3199 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5419 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for high resistance.

  • Measure the resistance between glow plug 5 pin in the glow plug harness connector to block ground.

Less than 1.5 ohms?
YES NO

A malfunctioning glow plug module has been detected.

Replace the glow plug module.

Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.
  • Disconnect glow plug 5 from the engine harness.

Action

Check for an open.

  • Measure the resistance between glow plug 5 and the block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance has been detected in the harness.

Repair or replace the harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

High resistance has been detected in the glow plug.

Replace the glow plug.

Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 20-Aug-2015


FAULT CODE 5421- Engine Glow Plug 6 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3193, 3211 or 3212 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5421 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness for a pin-to-pin short. | Less than 1 ohm?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3193, 3211 or 3212 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5421 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 6 pin in the engine harness glow plug connector and block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5 ohms?
YES NO

A malfunctioning glow plug module has been detected.

Replace the glow plug module. Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.
  • Disconnect glow plug 6 from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 6 and the block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance has been detected in the harness.

Repair or replace the harness. Refer to Procedure 010-043 in the Associated Procedures Table.

High resistance has been detected in the glow plug.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jul-2015


FAULT CODE 5422 - Engine Glow Plug 7 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3194, 3215 or 3216 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5422 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness. | Less than 1 ohm?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3194, 3215 or 3216 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5421 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 7 pin in the engine harness glow plug connector and block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5 ohms?
YES NO

A malfunctioning glow plug module has been detected.

Replace the glow plug module. Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.
  • Disconnect glow plug 7 from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 7 and the block ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance has been detected in the harness.

Replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

High resistance has been detected in the glow plug.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Jul-2015


FAULT CODE 5423 - Engine Glow Plug 8 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Glow Plug | Refer to Procedure 010-030 | ISV5.0 CM3230 V104 | 4367291
Glow Plug Controller | Refer to Procedure 013-010 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 3195, 3217, or 3218 active?
 | STEP 1B. Check for an active fault code. | Fault Code 5423 active?
STEP 2. | Check the glow plug and circuit. |
 | STEP 2A. Inspect the glow plug and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the glow plug. | Less than 1.5 ohms?
 | STEP 2C. Check the engine harness. | Less than 1 ohm?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3195, 3217, or 3281 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5423 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the glow plug and circuit.

Guided Step 2A - Inspect the glow plug and electrical connections.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the glow plug from the harness.

Action

Inspect the harness and glow plug connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the glow plug or harness connector.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the glow plug.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 8 pin in the harness glow plug connector and the block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.5 ohms?
YES NO

A malfunctioning glow plug module has been detected.

Replace the glow plug module. Refer to Procedure 013-010 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the glow plug module.
  • Disconnec glow plug 8 from the engine harness.

Action

Check for a short circuit from pin-to-pin.

  • Measure the resistance between glow plug 8 and block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO

High resistance in the harness has been detected.

Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

High resistance in the glow plug has been detected.

Replace the glow plug. Refer to Procedure 010-030 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check if an ECM calibration update is available.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 29-Jun-2015


FAULT CODE 5534 - Engine Fuel Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Fuel Inlet Restriction | Refer to Procedure 006-020 | ISV5.0 CM3230 V104 | 4367291
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | ISV5.0 CM3230 V104 | 4367291
Fuel Lift Pump Circuit | Refer to Procedure 019-397 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

CAUTION

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the battery voltage fault codes. | Fault Code 441, 442, active?
 | STEP 1B. Check for fuel pressure fault codes. | Fault Code 268, 546, 547, 2222, 2223, 2224, or 4691 active?
 | STEP 1C. Check for lift pump fault codes. | Fault Code 2266 or 2265 active?
STEP 2. | Check the fuel supply pressure. |
 | STEP 2A. Verify the electric lift pump voltage. | Voltage greater than 8 volts during cranking?
 | STEP 2B. Check for adequate fuel supply or tank level. | Fuel level low?
 | STEP 2C. Check the low pressure fuel system. | Check meets specifications from Procedure 005-236?
 | STEP 2D. Check for air in fuel. | Air in fuel system?
 | STEP 2E. Check for fuel inlet restriction. | Check meet specification?
 | STEP 2F. Inspect original equipment manufacturer (OEM) fuel supply lines. | Check meets specifications found in Procedure 006-003?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for battery voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441, 442 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 1B

Guided Step 1B - Check for fuel pressure fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 268, 546, 547, 2222, 2223, or 2224, or 4691 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 1C

Guided Step 1C - Check for lift pump fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for multiple fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2266 or 2265 active?
YES | NO
No Repair | No Repair

Troubleshoot the active fault codes.

Go to 2A

Guided Step 2 - Check the fuel supply pressure.

Guided Step 2A - Verify the electric lift pump voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the electric fuel lift pump.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the fuel lift pump SUPPLY pin and the fuel lift pump RETURN pin.

Note: Check the voltage at keyswitch ON while cranking the engine and with the engine at idle.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Voltage greater than 8 volts during cranking?
YES NO

A damaged lift pump has been detected.

Repair or replace the missing or damaged components or replace the lift pump. Refer to Procedure 019-397 in the Associated Procedures Table.

Check the lift pump relay and lift pump harness for an intermittent connection.

Repair or replace the damaged compnent.

Go to 2B

Go to 3A

Guided Step 2B - Check for adequate fuel supply or tank level.

Conditions

  • Turn keyswitch ON.
  • Turn keyswitch OFF.

Action

Check the fuel tank level.

  • Do not rely on the fuel gauge. Check the actual tank level.
  • Verify there is fuel in the tank.

Fuel level low?
YES NO

Add fuel to the tank.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the low pressure fuel system.

Conditions

  • Turn the keyswitch ON.
  • Use the following procedure for information on low pressure fuel system checks. Refer to Procedure 005-236 in the Associated Procedures Table.

Action

Check the fuel filter.

  • Check for fuel filter restriction above specification. Refer to Procedure 005-236 in the Associated Procedures Table.

Check meets specifications from Procedure 005-236?
YES NO
No Repair

Replace the Stage 1 and 2 fuel filters.

Refer to Procedures 006-075 and 006-076 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for air in fuel.

Conditions

  • Turn the keyswitch ON.

Action

Check for air in the fuel system.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel system?
YES NO

Investiage the cause of air in the fuel system.

Remove air from the fuel system.

Repair or replace components, as necessary.

 No Repair

Go to 3A

Go to 2E

Guided Step 2E - Check for fuel inlet restriction.

Conditions

  • Turn the keyswitch ON.

Action

Check to see if there is air in the fuel system.

  • Refer to Procedure 006-020 in the Associated Procedures Table.

Check meet specification?
YES NO

Check the OEM fuel lines to the tank for proper size, leaks, bends, or clogs.

Check the fuel tank vents for plugging.

 No Repair

Go to 2F

Go to 3A

Guided Step 2F - Inspect OEM fuel supply lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the fuel supply line.

  • Check the OEM suction and pressure side fuel supply lines.

Leaky or damaged fuel supply line?
YES NO

A damaged fuel supply line has been detected.

Replace the supply line. See equipment manufacturer service information.

A damaged lift pump has been detected.

Repair or replace the missing or damaged components or replace the lift pump.

Refer to Procedure 006-082 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Aug-2015


FAULT CODE 3353 - Engine Cylinder 1 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1654 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5535 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1654 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5535 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 1 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of Cylinder 1.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specification in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5536 - Engine Cylinder 2 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1655 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5536 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1655 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5536 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 2 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 2.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5537 - Engine Cylinder 3 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1656 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5537 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1656 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5537 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 3 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 3.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5538 - Engine Cylinder 4 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1657 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5538 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1657 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5538 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 4 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 4.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5539 - Engine Cylinder 5 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1658 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5539 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1658 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5539 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 5 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 5.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5541 - Engine Cylinder 6 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1659 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5541 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1659 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5541 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 6 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 6.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5542 - Engine Cylinder 7 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1661 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5542 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1661 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5542 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly of the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 7 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 7.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5543 - Engine Cylinder 8 Fuel Injection Quantity - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for misfire fault codes. | Fault Code 1662 or 1718 active?
 | STEP 1E. Check for an active fault code. | Fault Code 5543 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for misfire fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1662 or 1718 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1E

Guided Step 1E - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5536 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 8 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 8.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5544 - Injector Solenoid Drive Cylinder 7 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active fault code. | Fault Code 5544 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5544 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 7 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 7.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5545 - Injector Solenoid Driver Cylinder 8 - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | ISV5.0 CM3230 V104 | 4367291
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
 | STEP 1B. Check for air handling fault codes. | Any turbocharger, intake air throttle, or exhaust gas recirculation (EGR) related fault codes?
 | STEP 1C. Check for cam or crankshaft fault codes. | Fault Code 689, 731, or 778 active?
 | STEP 1D. Check for an active fault code. | Fault Code 5545 active?
STEP 2. | Check injector trim codes. |
 | STEP 2A. Check the trim code. | Injector trim code missing or incorrect?
STEP 3. | Perform diagnostics tests. |
 | STEP 3A. Perfor the High-Pressure Fuel Injector Drain Flow Test. | Injectors meet specifications in Procedure 005-236?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fuel system fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any injector or rail pressure sensor circuit fault codes active or have accumulated inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for air handling fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Any turbocharger, intake air throttle, or EGR related fault codes?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree.

Go to 1C

Guided Step 1C - Check for cam or crankshaft fault codes.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 689, 731, or 778 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Start the engine. Operate at low idle.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5545 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check injector trim codes.

Guided Step 2A - Check the trim code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

The factory installed injector bar code values can be found on Quickserve® Online by entering the correct engine serial number (ESN), selecting Service, and Engine Data Plate.

The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need for removing any additional parts.

Injector trim code missing or incorrect?
YES NO

The injector bar code adjustable parameter for cylinder 8 or another cylinder is missing or not correct in INSITE™ electronic service tool.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Perform diagnostic tests.

Guided Step 3A - Perform the High-Pressure Fuel Injector Drain Flow Test.

Conditions

  • Turn keyswitch ON.

Action

Run the Fuel Injector Drain Flow Test on the bank of cylinder 8.

  • Refer to Procedure 005-236 in the Associated Procedures Table for the High-Pressure Fuel Injector Drain Flow Test.

Injectors meet specifications in Procedure 005-236?
YES NO
No Repair

Replace leaking injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Dec-2014


FAULT CODE 5546 - Injector Solenoid Driver Cylinder 1 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5546 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5546 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5546 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 1 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table for the engine harness.
  • Refer to Procedure 006-026 in the Associated Procedures Table for the injector.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 1 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5546 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes releated to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Nov-2014


FAULT CODE 5547- Injector Solenoid Driver Cylinder 2 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5547 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5547 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5547 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 2 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 2 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5547 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5548 - Injector Solenoid Driver Cylinder 3 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5548 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5548 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5548 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 3 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 3 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5548 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5549 - Injector Solenoid Driver Cylinder 4 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5549 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5549 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5549 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 4 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 4 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5549 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5551 - Injector Solenoid Driver Cylinder 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5551 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5551 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5551 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 5 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 5 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5551 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5552 - Injector Solenoid Driver Cylinder 6 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5552 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5552 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5552 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 6 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 6 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5552 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5553 - Injector Solenoid Driver Cylinder 7 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5553 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 5553 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5553 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 7 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 7 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5553 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5554 - Injector Solenoid Driver Cylinder 8 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5554 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for an inactive fault code. | Fault Code 2224 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5554 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 8 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 8 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5554 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5555 - Injector Solenoid Driver Cylinder 1 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5555 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5555 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5555 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 1 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin to pin resistance on the connector of injector 1.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 1 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness..

  • Measure the resistance between the injector 1 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit in the engine harness.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5555 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5556 - Injector Solenoid Driver Cylinder 2 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5556 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5556 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5556 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 2 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin to pin resistance on the connector of injector 2.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 2 RETURN pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness..

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness..

  • Measure the resistance between the injector 2 SIGNAL pin and all other pins in the engine harness ECM connector.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5556 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5557 - Injector Solenoid Driver Cylinder 3 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5557 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness.. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5557 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5557 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 3 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 3.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 3 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness..

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Injector 3 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5558 - Injector Solenoid Driver Cylinder 4 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5558 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5558 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5558 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 4 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 4.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 4 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Injector 4 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.Mos

Fault Code 5558 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5559 - Injector Solenoid Driver Cylinder 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5559 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5559 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5559 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 5 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 5.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 5 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 5 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace then engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5559 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5561 - Injector Solenoid Driver Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5561 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in then engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5561 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5561 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 6 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector..

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 6.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 6 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Injector 6 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5561 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5562 - Injector Solenoid Driver Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5562 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100kk ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5562 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5562 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 7 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 7.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 7 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the Injector 7 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5562 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5563 - Injector Solenoid Driver Cylinder 6 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury or death from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 5563 active?
STEP 2. | Check the fuel injector and circuit. |
 | STEP 2A. Inspect the fuel injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the injector. | Less than 150k ohms?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 5563 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5563 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel injector and circuit.

Guided Step 2A - Inspect the fuel injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect injector 8 from the engine harness.

Action

Inspect the engine harness and fuel injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.
  • For the injector: Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for a short circuit in the injector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the harness from the injector.

Action

Check for a short circuit in the injector.

  • Measure the pin-to-pin resistance on the connector of injector 8.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 150k ohms?
YES NO

For the injector: Refer to Procedure 006-026 in the Associated Procedures Table

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 8 RETURN pin and all other pins in the engine harness ECM connector.

Use a wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the injector from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for a short circuit in the engine harness.

  • Measure the resistance between the injector 8 SIGNAL pin and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5563 inactive?
YES NO
No Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 01-Jul-2015


FAULT CODE 5618 - Number of ECM Resets - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 5618 active or multiple counts?
STEP 2. | Check the batteries and the power connector. |
 | STEP 2A. Check the batteries and the power connector. | Connections tight and corrosion-free?
 | STEP 2B. Check the battery voltage. | Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system]; During Cranking: At least (+) 6.2 VDC?
STEP 3. | Check the original equipment manufacturer (OEM) power harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the battery power circuit. | At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
 | STEP 3B-1. Verify that the OEM fuse is installed correctly. |
 | STEP 3B-2. Check if the OEM fuse is blown. |
 | STEP 3B-3. Check the add-on or accessory wiring at the (+) terminal of the battery. |
 | STEP 3C. Check the resistance of the battery supply circuit. | Less than 1.0 ohms?
 | STEP 3D. Check the keyswitch input-to-engine control module (ECM) wire. | Keyswitch input wire uninterrupted?
 | STEP 3E. Check the keyswitch input circuit. | Less than 5 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5618 active or multiple inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the batteries and the power connector.

Guided Step 2A - Check the batteries and the power connector.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Check the battery voltage.

Conditions

  • Turn keyswitch ON.

Action

Check the battery voltage.

  • Place the positive (+) probe of the multimeter on the positive battery terminal and touch the negative (-) probe to the negative battery terminal while trying to start the engine.

Normal conditions: At least (+) 12 VDC [(+) 24 VDC with 24 volt system];

During Cranking: At least (+) 6.2 VDC?
YES NO
No Repair

Charge or replace the battery. See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the OEM power harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

A damaged connection has been detected in the ECM connector or battery supply connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the battery power circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.

Action

Check for an open circuit in the battery power circuits.

  • Use a multimeter to measure the voltage from the ECM battery SUPPLY (+) pin of the battery supply connector and engine block ground.

Reference the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

At least (+) 10 VDC [(+) 20 VDC for a 24 volt system]?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B-1

Guided Step 3B-1 - Verify that the OEM fuse is installed correctly.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the OEM fuse for correct installation.

Fuse installed correctly?
YES NO
No Repair

Install the fuse correctly. Refer to Procedure 019-198 in Section 19.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check if the OEM fuse is blown.

Conditions

  • Turn keyswitch OFF.

Action

Verify that the OEM fuse is not blown.

Fuse blown?
YES NO

Locate the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Replace the blown fuse(s). Refer to Procedure 019-198 in Section 19.

No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the add-on or the accessory wiring at the (+) terminal of the battery.

Conditions

  • Turn keyswitch OFF.

Action

Check the add-on or the accessory wiring at the (+) terminal of the battery.

  • Starting at the (+) terminal, follow any add-on or accessory wiring and examine wire(s) for damaged insulation or an installation error that can cause the supply wire to be shorted to the engine block.

Any damaged wires?
YES NO

Repair or replace the damaged wiring.

Repair or replace the OEM power harness from the OEM power connector to the batteries.

Go to 4A

Go to 4A

Guided Step 3C - Check the resistance of the battery supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the battery supply connector from the ECM.
  • Disconnect the positive terminal from the battery.
  • Digital multimeter set to low resistance mode and calibrated to zero.

Action

Check the resistance of the battery supply circuit.

  • Measure the resistance between the ECM battery SUPPLY (+) pin of the battery supply connector and the positive battery connector.
  • Measure the resistance between the ECM battery SUPPLY (-) pin of the battery supply connector and the negative battery connector.

Refer to the wiring diagram for connector pin identification.

Since the battery supply circuit resistance is normally very low, it is necessary to use a digital multimeter calibrated to zero on the low resistance setting to accurately measure the circuit resistance.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1.0 ohms?
YES NO
No Repair

Repair or replace the ECM power harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check the keyswitch input-to-ECM wire.

Conditions

  • Turn keyswitch OFF.

Action

Check the keyswitch wire.

Inspect the keyswitch input wire from the keyswitch ignition post in the keyswitch assembly to the ECM to make sure there are no interruptions in the wire, that is, no solenoids or relays.

Keyswitch input wire uninterrupted?
YES NO

Correct the wiring so the wire is uninterrupted.

 No Repair

Go to 4A

Go to 3E

Guided Step 3E - Check the keyswitch input circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check the keyswitch input circuit.

  • Measure the resistance from the keyswitch ignition post in the keyswitch assembly to keyswitch input SIGNAL pin of the OEM harness connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ Electronic Service Tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ Electronic Service Tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Dec-2014


FAULT CODE 6433 - Engine Camshaft Speed/Position Sensor - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft | Refer to Procedure 001-016 | ISV5.0 CM3230 V104 | 4367291
Vibration Damper, Rubber | Refer to Procedure 001-051 | ISV5.0 CM3230 V104 | 4367291
Overhead Camshaft | Refer to Procedure 002-039 | ISV5.0 CM3230 V104 | 4367291
Camshaft Position Sensor | Refer to Procedure 019-363 | ISV5.0 CM3230 V104 | 4367291
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISV5.0 CM3230 V104 | 4367291

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 6433 the only active fault code?
STEP 2. | Inspect the engine and vehicle grounding. |
 | STEP 2A. Inspect the engine block, starter, alternator, chassis, and battery grounds. | All grounds present, properly grounded, free of corrosion, and tight?
STEP 3. | Inspect the tone wheel and crankshaft sensor. |
 | STEP 3A. Inspect the crankshaft sensor for damage. | Any sensor damage?
 | STEP 3B. Inspect the tone wheel for any damage. | Any damage?
STEP 4. | Check the camshaft gears and sensors. |
 | STEP 4A. Inspect the camshaft sensor for damage. | Any sensor damage?
 | STEP 4B. Inspect the camshaft gears for any damage. | Any damage?
 | STEP 4C. Check the static timing. | Camshaft timing marks properly aligned at top dead center (TDC)?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6433 the only active fault?

YES NO
No Repair

Troubleshoot any other active faults before continuing with this tree.

Go to 2A

Go to the appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the engine and vehicle grounding.

Guided Step 2A - Inspect the engine block, starter, alternator, chassis, and battery grounds.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine and vehicle grounding.

  • Check all engine block, starter, alternator, chassis, and battery grounds.
  • Verify all grounds are present and properly grounded.
  • Verify all connections are free of corrosion and tight.

All grounds present, properly grounded, free of corrosion, and tight?
YES NO
No Repair

Replace, tighten, or clean the ground wires or connections.

Go to 3A

Go to 3A

Guided Step 3 - Inspect the tone wheel and crankshaft sensor.

Guided Step 3A - Inspect the crankshaft sensor for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft sensors for damage.

Refer to Procedure 019-365 in the Associated Procedures Table.

Any sensor damage?
YES NO

Replace the crankshaft sensor. Refer to Procedure 019-365 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Inspect the tone wheel for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft tone wheel for damage.

  • Inspect the crankshaft speed indicator ring for missing or bent teeth, cracks, or damaged surfaces. Refer to Procedure 001-051 in the Associated Procedures Table.

Any damage?
YES NO

Replace the tone wheel assembly. Refer to Procedure 001-051 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4A

Guided Step 4 - Check the camshaft gears and sensors.

Guided Step 4A - Inspect the camshaft sensor for damaged.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft sensor for damage.

Refer to Procedure 019-363 in the Associated Procedures Table.

Any sensor damage?
YES NO

Replace the camshaft sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Inspect the camshaft gears for any damage.

Conditions

  • Turn keyswitch OFF.
  • Remove the valve covers.

Action

Inspect the camshaft gears.

Inspect the camshaft gears for excessive wear, fretting, and missing teeth. Refer to Procedure 002-039 in the Associated Procedures Table.

Any damage?
YES NO

Replace the camshaft gears. Refer to Procedure 002-039 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Check static timing.

Conditions

  • Remove the valve covers.
  • Rotate the engine to TDC for the number 1 cylinder. Verify the camshaft gear timing marks are properly aligned.

Action

Inspect the timing.

Camshaft timing marks properly aligned at TDC?
YES NO
No Repair

Remove and install the camshaft to properly align timing marks at TDC. Refer to Procedure 002-039 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

If necessary, calibrate the ECM.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repeat all steps. If the fault code is still active:

  • The crankshaft and camshaft should be inspected thoroughly. Refer to Procedures 001-016 and 002-039 in the Associated Procedures Table.

Repair complete

Go to 1A

Last Modified: 23-Jan-2015


INDEX
245-fc111.htm

00-t05-111.htm

245-fc131.htm

00-t05-131.htm

245-fc132.htm

00-t05-132.htm

245-fc143.htm

00-t05-143.htm

245-fc144.htm

00-t05-144.htm

245-fc145.htm

00-t05-145.htm

245-fc146.htm

00-t05-146.htm

245-fc151.htm

00-t05-151.htm

245-fc153.htm

00-t05-153.htm

245-fc154.htm

00-t05-154.htm

245-fc186.htm

00-t05-186.htm

245-fc195-3wire.htm

357-t05-195-3wire.htm

245-fc196-3wire.htm

357-t05-196-3wire.htm

245-fc197.htm

00-t05-197.htm

245-fc234.htm

00-t05-234.htm

245-fc238.htm

00-t05-238.htm

245-fc239.htm

00-t05-239.htm

245-fc241.htm

00-t05-241.htm

245-fc249.htm

00-t05-249.htm

245-fc256.htm

00-t05-256.htm

245-fc261.htm

357-t05-261.htm

245-fc262.htm

357-t05-262.htm

245-fc263.htm

357-t05-263.htm

245-fc265.htm

357-t05-265.htm

245-fc268.htm

357-t05-268.htm

245-fc271.htm

245-t05-271.htm

245-fc272.htm

245-t05-272.htm

245-fc281.htm

357-t05-281.htm

245-fc285.htm

00-t05-285.htm

245-fc286.htm

00-t05-286.htm

245-fc311.htm

357-t05-311.htm

245-fc312.htm

357-t05-312.htm

245-fc313.htm

357-t05-313.htm

245-fc314.htm

357-t05-314.htm

245-fc315.htm

357-t05-315.htm

245-fc321.htm

357-t05-321.htm

245-fc322.htm

357-t05-322.htm

245-fc323.htm

357-t05-323.htm

245-fc324.htm

357-t05-324.htm

245-fc325.htm

357-t05-325.htm

245-fc328.htm

357-t05-328.htm

245-fc331.htm

357-t05-331.htm

245-fc332.htm

357-t05-332.htm

245-fc334.htm

00-t05-334.htm

245-fc338.htm

00-t05-338.htm

245-fc339.htm

00-t05-339.htm

245-fc343.htm

00-t05-343.htm

245-fc346.htm

245-t05-346.htm

245-fc351.htm

245-t05-351.htm

245-fc352.htm

245-t05-352.htm

245-fc359.htm

357-t05-359.htm

245-fc386.htm

245-t05-386.htm

245-fc418.htm

00-t05-418.htm

245-fc428.htm

00-t05-428.htm

245-fc429.htm

00-t05-429.htm

245-fc435.htm

357-t05-435.htm

245-fc436.htm

245-t05-436.htm

245-fc451.htm

00-t05-451.htm

245-fc452.htm

00-t05-452.htm

245-fc477.htm

245-t05-477.htm

245-fc478.htm

245-t05-478.htm

245-fc482.htm

357-t05-482.htm

245-fc488.htm

245-t05-488.htm

245-fc515.htm

245-t05-515.htm

245-fc516.htm

245-t05-516.htm

245-fc535.htm

357-t05-535.htm

245-fc546.htm

357-t05-546.htm

245-fc547.htm

357-t05-547.htm

245-fc553.htm

357-t05-553.htm

245-fc554.htm

357-t05-554.htm

245-fc555.htm

00-t05-555.htm

245-fc559.htm

357-t05-559.htm

245-fc595.htm

245-t05-595.htm

245-fc596.htm

00-t05-596.htm

245-fc597.htm

00-t05-597.htm

245-fc649.htm

00-t05-649.htm

245-fc687.htm

245-t05-687.htm

245-fc689.htm

245-t05-689.htm

245-fc691.htm

00-t05-691.htm

245-fc692.htm

00-t05-692.htm

245-fc693.htm

00-t05-693.htm

245-fc697.htm

00-t05-697.htm

245-fc698.htm

00-t05-698.htm

245-fc699.htm

00-t05-699.htm

245-fc731.htm

245-t05-731.htm

245-fc741.htm

245-t05-741.htm

245-fc742.htm

245-t05-742.htm

245-fc743.htm

245-t05-743.htm

245-fc778.htm

245-t05-778.htm

245-fc1117.htm

00-t05-1117.htm

245-fc1139.htm

357-t05-1139.htm

245-fc1141.htm

357-t05-1141.htm

245-fc1142.htm

357-t05-1142.htm

245-fc1143.htm

357-t05-1143.htm

245-fc1144.htm

357-t05-1144.htm

245-fc1145.htm

357-t05-1145.htm

245-fc1228.htm

245-t05-1228.htm

245-fc1229.htm

245-t05-1229.htm

245-fc1239.htm

00-t05-1239.htm

245-fc1241.htm

00-t05-1241.htm

245-fc1242.htm

00-t05-1242.htm

245-fc1515.htm

00-t05-1515.htm

245-fc1548.htm

357-t05-1548.htm

245-fc1549.htm

357-t05-1549.htm

245-fc1561.htm

357-t05-1561.htm

245-fc1623.htm

357-t05-1623.htm

245-fc1654.htm

357-t05-1654.htm

245-fc1655.htm

357-t05-1655.htm

245-fc1656.htm

357-t05-1656.htm

245-fc1657.htm

357-t05-1657.htm

245-fc1658.htm

357-t05-1658.htm

245-fc1659.htm

357-t05-1659.htm

245-fc1661.htm

357-t05-1661.htm

245-fc1662.htm

357-t05-1662.htm

245-fc1664.htm

245-t05-1664.htm

245-fc1668.htm

245-t05-1668.htm

245-fc1669.htm

245-t05-1669.htm

245-fc1673.htm

00-t05-1673.htm

245-fc1677.htm

245-t05-1677.htm

245-fc1678.htm

245-t05-1678.htm

245-fc1679.htm

245-t05-1679.htm

245-fc1682.htm

245-t05-1682.htm

245-fc1683.htm

245-t05-1683.htm

245-fc1684.htm

245-t05-1684.htm

245-fc1685.htm

00-t05-1685.htm

245-fc1686.htm

00-t05-1686.htm

245-fc1688.htm

245-t05-1688.htm

245-fc1691.htm

245-t05-1691.htm

245-fc1694.htm

245-t05-1694.htm

245-fc1695.htm

245-t05-1695.htm

245-fc1696.htm

245-t05-1696.htm

245-fc1712.htm

245-t05-1712.htm

245-fc1713.htm

245-t05-1713.htm

245-fc1715.htm

00-t05-1715.htm

245-fc1718.htm

357-t05-1718.htm

245-fc1843.htm

00-t05-1843.htm

245-fc1844.htm

00-t05-1844.htm

245-fc1852.htm

00-t05-1852.htm

245-fc1866.htm

00-t05-1866.htm

245-fc1867.htm

245-t05-1867.htm

245-fc1879.htm

00-t05-1879.htm

245-fc1881.htm

00-t05-1881.htm

245-fc1883.htm

245-t05-1883.htm

245-fc1885.htm

00-t05-1885.htm

245-fc1887.htm

245-t05-1887.htm

245-fc1896.htm

245-t05-1896.htm

245-fc1897.htm

245-t05-1897.htm

245-fc1921.htm

00-t05-1921.htm

245-fc1922.htm

00-t05-1922.htm

245-fc1938.htm

245-t05-1938.htm

245-fc1942.htm

00-t05-1942.htm

245-fc1974.htm

245-t05-1974.htm

245-fc1976.htm

245-t05-1976.htm

245-fc1993.htm

245-t05-1993.htm

245-fc2185.htm

00-t05-2185.htm

245-fc2186.htm

00-t05-2186.htm

245-fc2198.htm

00-t05-2198.htm

245-fc2217.htm

245-t05-2217.htm

245-fc2222.htm

245-fc2222-2wire.htm

00-t05-2222-2wire.htm

245-fc2222-3wire.htm

00-t05-2222-3wire.htm

245-fc2223.htm

245-fc2223-2wire.htm

00-t05-2223-2wire.htm

245-fc2223-3wire.htm

00-t05-2223-3wire.htm

245-fc2224.htm

245-t05-2224.htm

245-fc2265.htm

357-t05-2265.htm

245-fc2266.htm

357-t05-2266.htm

245-fc2271.htm

245-t05-2271.htm

245-fc2272.htm

245-t05-2272.htm

245-fc2273.htm

00-t05-2273.htm

245-fc2274.htm

00-t05-2274.htm

245-fc2288.htm

00-t05-2288.htm

245-fc2347.htm

245-t05-2347.htm

245-fc2351.htm

245-t05-2351.htm

245-fc2352.htm

245-t05-2352.htm

245-fc2373.htm

00-t05-2373.htm

245-fc2374.htm

00-t05-2374.htm

245-fc2375.htm

00-t05-2375.htm

245-fc2376.htm

00-t05-2376.htm

245-fc2387.htm

245-t05-2387.htm

245-fc2398.htm

245-t05-2398.htm

245-fc2416.htm

357-t05-2416.htm

245-fc2423.htm

357-t05-2423.htm

245-fc2424.htm

357-t05-2424.htm

245-fc2442.htm

357-t05-2442.htm

245-fc2443.htm

357-t05-2443.htm

245-fc2444.htm

357-t05-2444.htm

245-fc2445.htm

357-t05-2445.htm

245-fc2446.htm

357-t05-2446.htm

245-fc2447.htm

357-t05-2447.htm

245-fc2448.htm

00-t05-2448.htm

245-fc2449.htm

245-t05-2449.htm

245-fc2554.htm

245-t05-2554.htm

245-fc2571.htm

245-t05-2571.htm

245-fc2572.htm

245-t05-2572.htm

245-fc2635.htm

245-t05-2635.htm

245-fc2636.htm

245-t05-2636.htm

245-fc2638.htm

245-t05-2638.htm

245-fc2639.htm

00-t05-2639.htm

245-fc2646.htm

245-t05-2646.htm

245-fc2692.htm

00-t05-2692.htm

245-fc2698.htm

245-t05-2698.htm

245-fc2715.htm

245-t05-2715.htm

245-fc2717.htm

245-t05-2717.htm

245-fc2718.htm

245-t05-2718.htm

245-fc2771.htm

245-t05-2771.htm

245-fc2777.htm

00-t05-2777.htm

245-fc2961.htm

245-t05-2961.htm

245-fc2962.htm

245-t05-2962.htm

245-fc2963.htm

00-t05-2963.htm

245-fc2964.htm

00-t05-2964.htm

245-fc3133.htm

00-t05-3133.htm

245-fc3134.htm

00-t05-3134.htm

245-fc3135.htm

245-t05-3135.htm

245-fc3146.htm

357-t05-3146.htm

245-fc3147.htm

357-t05-3147.htm

245-fc3148.htm

357-t05-3148.htm

245-fc3151.htm

245-t05-3151.htm

245-fc3165.htm

245-t05-3165.htm

245-fc3168.htm

245-t05-3168.htm

245-fc3177.htm

357-t05-3177.htm

245-fc3178.htm

357-t05-3178.htm

245-fc3179.htm

357-t05-3179.htm

245-fc3181.htm

357-t05-3181.htm

245-fc3182.htm

357-t05-3182.htm

245-fc3183.htm

357-t05-3183.htm

245-fc3184.htm

357-t05-3184.htm

245-fc3185.htm

357-t05-3185.htm

245-fc3187.htm

357-t05-3187.htm

245-fc3188.htm

357-t05-3188.htm

245-fc3189.htm

357-t05-3189.htm

245-fc3191.htm

357-t05-3191.htm

245-fc3192.htm

357-t05-3192.htm

245-fc3193.htm

357-t05-3193.htm

245-fc3194.htm

357-t05-3194.htm

245-fc3195.htm

357-t05-3195.htm

245-fc3196.htm

357-t05-3196.htm

245-fc3197.htm

357-t05-3197.htm

245-fc3198.htm

357-t05-3198.htm

245-fc3199.htm

357-t05-3199.htm

245-fc3211.htm

357-t05-3211.htm

245-fc3212.htm

357-t05-3212.htm

245-fc3213.htm

00-t05-3213.htm

245-fc3214.htm

357-t05-3214.htm

245-fc3215.htm

357-t05-3215.htm

245-fc3216.htm

357-t05-3216.htm

245-fc3217.htm

357-t05-3217.htm

245-fc3218.htm

357-t05-3218.htm

245-fc3219.htm

357-t05-3219.htm

245-fc3221.htm

357-t05-3221.htm

245-fc3222.htm

357-t05-3222.htm

245-fc3228.htm

357-t05-3228.htm

245-fc3232.htm

357-t05-3232.htm

245-fc3235.htm

245-t05-3235.htm

245-fc3237.htm

245-t05-3237.htm

245-fc3238.htm

245-t05-3238.htm

245-fc3242.htm

245-t05-3242.htm

245-fc3243.htm

245-t05-3243.htm

245-fc3251.htm

245-t05-3251.htm

245-fc3253.htm

245-t05-3253.htm

245-fc3254.htm

245-t05-3254.htm

245-fc3255.htm

245-t05-3255.htm

245-fc3256.htm

245-t05-3256.htm

245-fc3258.htm

245-t05-3258.htm

245-fc3311.htm

245-t05-3311.htm

245-fc3312.htm

245-t05-3312.htm

245-fc3313.htm

245-t05-3313.htm

245-fc3314.htm

245-t05-3314.htm

245-fc3315.htm

245-t05-3315.htm

245-fc3316.htm

245-t05-3316.htm

245-fc3317.htm

245-t05-3317.htm

245-fc3318.htm

245-t05-3318.htm

245-fc3319.htm

245-t05-3319.htm

245-fc3321.htm

245-t05-3321.htm

245-fc3322.htm

245-t05-3322.htm

245-fc3326.htm

00-t05-3326.htm

245-fc3328.htm

00-t05-3328.htm

245-fc3337.htm

245-t05-3337.htm

245-fc3338.htm

245-t05-3338.htm

245-fc3342.htm

245-t05-3342.htm

245-fc3343.htm

245-t05-3343.htm

245-fc3374.htm

00-t05-3374.htm

245-fc3375.htm

245-t05-3375.htm

245-fc3376.htm

245-t05-3376.htm

245-fc3377.htm

245-t05-3377.htm

245-fc3382.htm

245-t05-3382.htm

245-fc3383.htm

245-t05-3383.htm

245-fc3396.htm

245-t05-3396.htm

245-fc3418.htm

00-t05-3418.htm

245-fc3478.htm

245-t05-3478.htm

245-fc3488.htm

00-t05-3488.htm

245-fc3492.htm

00-t05-3492.htm

245-fc3494.htm

245-t05-3494.htm

245-fc3497.htm

00-t05-3497.htm

245-fc3498.htm

00-t05-3498.htm

245-fc3525.htm

00-t05-3525.htm

245-fc3526.htm

00-t05-3526.htm

245-fc3527.htm

00-t05-3527.htm

245-fc3528.htm

00-t05-3528.htm

245-fc3539.htm

00-t05-3539.htm

245-fc3541.htm

00-t05-3541.htm

245-fc3542.htm

00-t05-3542.htm

245-fc3543.htm

245-t05-3543.htm

245-fc3545.htm

00-t05-3545.htm

245-fc3547.htm

245-t05-3547.htm

245-fc3555.htm

245-t05-3555.htm

245-fc3556.htm

245-t05-3556.htm

245-fc3557.htm

245-t05-3557.htm

245-fc3558.htm

245-t05-3558.htm

245-fc3559.htm

245-t05-3559.htm

245-fc3561.htm

245-t05-3561.htm

245-fc3565.htm

245-t05-3565.htm

245-fc3567.htm

245-t05-3567.htm

245-fc3568.htm

245-t05-3568.htm

245-fc3571.htm

245-t05-3571.htm

245-fc3572.htm

245-t05-3572.htm

245-fc3574.htm

245-t05-3574.htm

245-fc3575.htm

245-t05-3575.htm

245-fc3576.htm

245-t05-3576.htm

245-fc3577.htm

245-t05-3577.htm

245-fc3578.htm

245-t05-3578.htm

245-fc3583.htm

00-t05-3583.htm

245-fc3597.htm

245-t05-3597.htm

245-fc3649.htm

00-t05-3649.htm

245-fc3681.htm

00-t05-3681.htm

245-fc3682.htm

00-t05-3682.htm

245-fc3697.htm

00-t05-3697.htm

245-fc3712.htm

00-t05-3712.htm

245-fc3714.htm

00-t05-3714.htm

245-fc3715.htm

245-t05-3715.htm

245-fc3716.htm

245-t05-3716.htm

245-fc3717.htm

00-t05-3717.htm

245-fc3718.htm

00-t05-3718.htm

245-fc3725.htm

00-t05-3725.htm

245-fc3736.htm

245-t05-3736.htm

245-fc3737.htm

00-t05-3737.htm

245-fc3748.htm

357-t05-3748.htm

245-fc3749.htm

245-t05-3749.htm

245-fc3867.htm

00-t05-3867.htm

245-fc3868.htm

245-t05-3868.htm

245-fc3878.htm

00-t05-3878.htm

245-fc4143.htm

00-t05-4143.htm

245-fc4144.htm

00-t05-4144.htm

245-fc4151.htm

357-t05-4151.htm

245-fc4152.htm

357-t05-4152.htm

245-fc4153.htm

00-t05-4153.htm

245-fc4154.htm

00-t05-4154.htm

245-fc4157.htm

245-t05-4157.htm

245-fc4158.htm

357-t05-4158.htm

245-fc4159.htm

357-t05-4159.htm

245-fc4161.htm

357-t05-4161.htm

245-fc4162.htm

357-t05-4162.htm

245-fc4163.htm

357-t05-4163.htm

245-fc4164.htm

357-t05-4164.htm

245-fc4165.htm

357-t05-4165.htm

245-fc4166.htm

357-t05-4166.htm

245-fc4168.htm

245-t05-4168.htm

245-fc4169.htm

245-t05-4169.htm

245-fc4171.htm

245-t05-4171.htm

245-fc4213.htm

00-t05-4213.htm

245-fc4215.htm

00-t05-4215.htm

245-fc4233.htm

00-t05-4233.htm

245-fc4234.htm

00-t05-4234.htm

245-fc4244.htm

245-t05-4244.htm

245-fc4248.htm

245-t05-4248.htm

245-fc4252.htm

00-t05-4252.htm

245-fc4259.htm

245-t05-4259.htm

245-fc4261.htm

357-t05-4261.htm

245-fc4262.htm

245-t05-4262.htm

245-fc4263.htm

245-t05-4263.htm

245-fc4277.htm

00-t05-4277.htm

245-fc4449.htm

00-t05-4449.htm

245-fc4517.htm

245-t05-4517.htm

245-fc4518.htm

245-t05-4518.htm

245-fc4519.htm

245-t05-4519.htm

245-fc4521.htm

245-t05-4521.htm

245-fc4524.htm

245-t05-4524.htm

245-fc4525.htm

245-t05-4525.htm

245-fc4526.htm

245-t05-4526.htm

245-fc4584.htm

00-t05-4584.htm

245-fc4585.htm

00-t05-4585.htm

245-fc4612.htm

245-t05-4612.htm

245-fc4643.htm

357-t05-4643.htm

245-fc4644.htm

357-t05-4644.htm

245-fc4658.htm

00-t05-4658.htm

245-fc4678.htm

245-t05-4678.htm

245-fc4679.htm

245-t05-4679.htm

245-fc4682.htm

245-t05-4682.htm

245-fc4691.htm

357-t05-4691.htm

245-fc4713.htm

245-t05-4713.htm

245-fc4728.htm

245-t05-4728.htm

245-fc4731.htm

00-t05-4731.htm

245-fc4732.htm

00-t05-4732.htm

245-fc4736.htm

245-t05-4736.htm

245-fc4737.htm

245-t05-4737.htm

245-fc4738.htm

245-t05-4738.htm

245-fc4739.htm

245-t05-4739.htm

245-fc4746.htm

245-t05-4746.htm

245-fc4747.htm

00-t05-4747.htm

245-fc4748.htm

00-t05-4748.htm

245-fc4749.htm

245-t05-4749.htm

245-fc4751.htm

245-t05-4751.htm

245-fc4768.htm

00-t05-4768.htm

245-fc4769.htm

245-t05-4769.htm

245-fc4842.htm

00-t05-4842.htm

245-fc4956.htm

00-t05-4956.htm

245-fc4957.htm

00-t05-4957.htm

245-fc5177.htm

00-t05-5177.htm

245-fc5278.htm

245-t05-5278.htm

245-fc5296.htm

357-t05-5296.htm

245-fc5324.htm

357-t05-5324.htm

245-fc5415.htm

357-t05-5415.htm

245-fc5416.htm

357-t05-5416.htm

245-fc5417.htm

357-t05-5417.htm

245-fc5418.htm

357-t05-5418.htm

245-fc5419.htm

357-t05-5419.htm

245-fc5421.htm

357-t05-5421.htm

245-fc5422.htm

357-t05-5422.htm

245-fc5423.htm

357-t05-5423.htm

245-fc5534.htm

357-t05-5534.htm

245-fc5535.htm

357-t05-5535.htm

245-fc5536.htm

357-t05-5536.htm

245-fc5537.htm

357-t05-5537.htm

245-fc5538.htm

357-t05-5538.htm

245-fc5539.htm

357-t05-5539.htm

245-fc5541.htm

357-t05-5541.htm

245-fc5542.htm

357-t05-5542.htm

245-fc5543.htm

357-t05-5543.htm

245-fc5544.htm

357-t05-5544.htm

245-fc5545.htm

357-t05-5545.htm

245-fc5546.htm

357-t05-5546.htm

245-fc5547.htm

357-t05-5547.htm

245-fc5548.htm

357-t05-5548.htm

245-fc5549.htm

357-t05-5549.htm

245-fc5551.htm

357-t05-5551.htm

245-fc5552.htm

357-t05-5552.htm

245-fc5553.htm

357-t05-5553.htm

245-fc5554.htm

357-t05-5554.htm

245-fc5555.htm

357-t05-5555.htm

245-fc5556.htm

357-t05-5556.htm

245-fc5557.htm

357-t05-5557.htm

245-fc5558.htm

357-t05-5558.htm

245-fc5559.htm

357-t05-5559.htm

245-fc5561.htm

357-t05-5561.htm

245-fc5562.htm

357-t05-5562.htm

245-fc5563.htm

357-t05-5563.htm

245-fc5577.htm

00-t05-5577.htm

245-fc5578.htm

00-t05-5578.htm

245-fc5579.htm

00-t05-5579.htm

245-fc5581.htm

00-t05-5581.htm

245-fc5582.htm

00-t05-5582.htm

245-fc5583.htm

00-t05-5583.htm

245-fc5584.htm

00-t05-5584.htm

245-fc5618.htm

357-t05-5618.htm

245-fc5655.htm

245-t05-5655.htm

245-fc5672.htm

245-t05-5672.htm

245-fc5673.htm

245-t05-5673.htm

245-fc5674.htm

245-t05-5674.htm

245-fc5675.htm

245-t05-5675.htm

245-fc5676.htm

245-t05-5676.htm

245-fc5677.htm

245-t05-5677.htm

245-fc5678.htm

245-t05-5678.htm

245-fc5689.htm

245-t05-5689.htm

245-fc5715.htm

245-t05-5715.htm

245-fc5716.htm

245-t05-5716.htm

245-fc5736.htm

245-t05-5736.htm

245-fc5792.htm

00-t05-5792.htm

245-fc5837.htm

00-t05-5837.htm

245-fc5868.htm

245-t05-5868.htm

245-fc5874.htm

245-t05-5874.htm

245-fc5879.htm

245-t05-5879.htm

245-fc5881.htm

245-t05-5881.htm

245-fc5884.htm

245-t05-5884.htm

245-fc5951.htm

245-t05-5951.htm

245-fc5952.htm

00-t05-5952.htm

245-fc5953.htm

00-t05-5953.htm

245-fc6237.htm

245-t05-6237.htm

245-fc6238.htm

245-t05-6238.htm

245-fc6239.htm

245-t05-6239.htm

245-fc6256.htm

245-t05-6256.htm

245-fc6257.htm

245-t05-6257.htm

245-fc6261.htm

245-t05-6261.htm

245-fc6262.htm

245-t05-6262.htm

245-fc6263.htm

245-t05-6263.htm

245-fc6264.htm

245-t05-6264.htm

245-fc6266.htm

245-t05-6266.htm

245-fc6417.htm

00-t05-6417.htm

245-fc6433.htm

357-t05-6433.htm

245-fc6622.htm

245-t05-6622.htm

245-fc6623.htm

245-t05-6623.htm

245-fc6624.htm

245-t05-6624.htm

245-fc6625.htm

245-t05-6625.htm

245-fc6626.htm

245-t05-6626.htm

245-fc6627.htm

245-t05-6627.htm

245-fc6642.htm

00-t05-6642.htm

245-fc6643.htm

00-t05-6643.htm

245-fc6644.htm

00-t05-6644.htm

245-fc6645.htm

00-t05-6645.htm

245-fc6646.htm

00-t05-6646.htm

245-fc6647.htm

00-t05-6647.htm

245-fc6648.htm

00-t05-6648.htm

245-fc6649.htm

00-t05-6649.htm

245-fc6651.htm

00-t05-6651.htm

245-fc6652.htm

00-t05-6652.htm

245-fc6653.htm

00-t05-6653.htm

245-fc6688.htm

00-t05-6688.htm

245-fc6689.htm

00-t05-6689.htm

245-fc6691.htm

00-t05-6691.htm

245-fc6735.htm

00-t05-6735.htm

245-fc6881.htm

00-t05-6881.htm