QSK95 CM2350 K111

Last Modified: 12 February 2020

Copyright © 2020
Cummins Inc.
All rights reserved


FIS Usage Recommendations

  • To avoid Internet Explorer opening its "splash screen" each time when viewing a FIS page with popup content, start Internet Explorer before opening the FIS.
  • The "Hide" / "Show" button hides the left column; the right column can be maximized after hiding the left column.
  • The "Back" button will move backward through pages viewed since opening the FIS ("Alt" - "Left Arrow" is the keyboard equivalent).
  • The "Forward" button goes to the previous screen after having just used the "Back" button ("Alt" - "Right Arrow").
  • In case the display is corrupted, the "Refresh" button redraws the current FIS display ("Ctrl" - "R").
  • Right-clicking anywhere in the left-column display offers "open all" and "close all" options for expanding or compressing the left column folders.
  • The left-column search tab offers a full-text search of the FIS; the check box at the bottom selects between complete text search or page titles only.
  • The "Favorites" tab in the left column permits each user to Add and Remove bookmarks to his own frequently-used pages in each CHM FIS.

Copyright © 2017
Cummins Inc.
All rights reserved


Fault Code Path Selection

FAULT CODE 316-fc111
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc111sa00
Is the ECM source address 01? | Go to 316-fc111sa01
Is the ECM source address 144? | Go to 316-fc111sa144
Is the ECM source address 186? | Go to 316-fc111sa186

Last Modified: 03-Apr-2020
Copyright © 2000-2010 Cummins Inc. All rights reserved.


Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1117

Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1117 PID: S251 SPN: 3597 FMI: 2/2 LAMP: None SRT: | Supply voltage to the ECM fell below a calibrated limit momentarily, or the ECM was not allowed to power down correctly. | Possible reduced engine performance.
Engine Control Module (ECM) Battery Power Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by a combination of engine harness and OEM harness connected in series. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the primary ECM power supply dropped below a calibratible value while the generator set controller is active.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low battery voltage.
  • High resistance in the ECM supply or return circuit.
  • Use of a battery disconnect switch or any device that disconnects battery voltage to the ECM to turn the engine off or before the ECM is completely powered down.
Refer to Troubleshooting Fault Code 1117 .

Last Modified: 11-Dec-2020


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111 .

Last Modified: 11-Dec-2020


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 111

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 111 PID: S254 SPN: 629 FMI: 12/12 LAMP: Red SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it idle for 1 minute.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

This fault code can only be caused by an internal ECM malfunction. Repairs are not possible for the ECM.

Refer to Troubleshooting Fault Code 111 .

Last Modified: 11-Dec-2020


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 1135

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1135 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Red SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 Ω resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the battery supply circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 1135 .

Last Modified: 11-Dec-2020


Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

FAULT CODE 115

Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 115 PID: P190 SPN: 612 FMI: 2/2 LAMP: Red SRT: | At least one of the engine control modules has lost the camshaft and crankshaft position sensor signals. | The engine will shut down or will not start.
Crankshaft Position Sensor Circuit
Camshaft Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The camshaft position sensor is located in the gear cover.

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

At least one engine control module (ECM) has lost both the camshaft and crankshaft position sensor signals while another ECM is still detecting both signals.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open in both engine position sensor circuits to one ECM.
Refer to Troubleshooting Fault Code 115 .

Last Modified: 11-Dec-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 122

Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 122 PID: P102 SPN: 102 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 122, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 122 .

Last Modified: 11-Dec-2020


Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 123

Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 123 PID: P102 SPN: 102 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected in the intake manifold pressure sensor circuit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The intake manifold pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 123, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 123 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc1256
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc1256sa00
Is the ECM source address 01? | Go to 316-fc1256sa01
Is the ECM source address 144? | Go to 316-fc1256sa144
Is the ECM source address 186? | Go to 316-fc1256sa186

Last Modified: 03-Apr-2020


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1256

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1256 PID: P234 SPN: 1563 FMI: 2/2 LAMP: Amber SRT: | The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

An invalid control module identification input has been detected.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on one or more control module identification signal wire(s).
Refer to Troubleshooting Fault Code 1256 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc1257
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc1257sa00
Is the ECM source address 01? | Go to 316-fc1257sa01
Is the ECM source address 144? | Go to 316-fc1257sa144
Is the ECM source address 186? | Go to 316-fc1257sa186

Last Modified: 03-Apr-2020


Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1257

Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1257 PID: P234 SPN: 1563 FMI: 2/2 LAMP: Red SRT: | The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 1257 .

Last Modified: 11-Dec-2020


Engine Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 13266

Engine Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 13266 PID: SPN: 6302 FMI: 1/18 LAMP: Amber SRT: | Low crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pressure in the breather tube was less than expected.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or missing breather tube or hose.
  • Missing or damaged breather filter element
  • Restricted crankcase breather housing.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 13266 .

Last Modified: 08-Feb-2022


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 135

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 135 PID: P100 SPN: 100 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine oil pressure circuit. | None on performance.
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 135, check for multiple faults.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 135 .

Last Modified: 11-Dec-2020


Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1362

Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1362 PID: P99 SPN: 99 FMI: 0/16 LAMP: Amber SRT: | High oil filter restriction has been detected. | None on performance.
Pre-Oil Filter Pressure Sensor Circuit
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) uses the oil filter intake pressure sensor and engine oil pressure sensor to determine the oil filter restriction.

Component Location

The pre-oil filter pressure sensor is located on the intake of the oil filter head.

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected high oil filter restriction.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning engine oil pressure sensor.
  • Malfunctioning pre-oil filter pressure sensor.
Refer to Troubleshooting Fault Code 1362 .

Last Modified: 11-Dec-2020


Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1367

Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1367 PID: SPN: 1208 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the engine oil filter intake pressure circuit. | None on performance.
Pre-Oil Filter Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil filter intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The oil filter intake pressure sensor provides a signal to the ECM on the oil filter intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure before the oil filters. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The oil filter intake pressure sensor is located on the oil filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil filter intake pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

A default value for the engine oil filter intake pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning engine oil filter intake pressure sensor.
Refer to Troubleshooting Fault Code 1367 .

Last Modified: 11-Dec-2020


Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1368

Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1368 PID: SPN: 1208 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected in the engine oil filter intake pressure circuit. | None on performance.
Pre-Oil Filter Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the oil filter intake pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The oil filter intake pressure sensor provides a signal to the ECM on the oil filter intake pressure sensor signal circuit. This sensor signal voltage changes, based on the pressure before the oil filters. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The oil filter intake pressure sensor is located on the oil filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil filter intake pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

A default value for the engine oil filter intake pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • A malfunctioning engine oil filter intake pressure sensor.
Refer to Troubleshooting Fault Code 1368 .

Last Modified: 11-Dec-2020


Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

FAULT CODE 1376

Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1376 PID: S64 SPN: 723 FMI: 2/2 LAMP: Maintenance SRT: | The ECM has detected a loss of signal from the camshaft position sensor. | Possible reduced engine performance.
Camshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the camshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As slots in the front of the camshaft gear move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the cam gear slots indicate to the ECM the position of the engine. This sensor is used as a backup sensor if the engine crankshaft position signal is lost.

Component Location

The camshaft position sensor is located in the gear cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the camshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Damaged or malfunctioning camshaft position sensor.
  • Damaged camshaft gear.
Refer to Troubleshooting Fault Code 1376 .

Last Modified: 11-Dec-2020


Fuel Supply Pump Intake Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 1379

Fuel Supply Pump Intake Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1379 PID: P15 SPN: 1381 FMI: 1/17 LAMP: Maintenance SRT: | The Engine Control Module (ECM) has diagnosed that intake pressure of the fuel supply pump is below a calibrated threshold. | Possible reduced engine performance.
Fuel Supply Pump Intake Pressure Sensor Circuit

Circuit Description

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The engine fuel supply pump intake pressure sensor is located on the inlet of the fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the fuel supply pump intake pressure is below a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Stage 1 fuel filter restriction excessive.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 1379 .

Last Modified: 11-Dec-2020


Fuel Supply Pump Intake Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 1389

Fuel Supply Pump Intake Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1389 PID: P15 SPN: 1381 FMI: 0/15 LAMP: Maintenance SRT: | High fuel supply pump intake pressure has been detected. | Possible reduced engine performance.
Fuel Supply Pump Intake Pressure Sensor Circuit

Circuit Description

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The fuel supply pump intake pressure sensor is located on the inlet of the engine fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) has detected that the fuel supply pump intake pressure is above a calibrated threshold.

Action Taken When the Fault Code is Active

The ECM illuminates the MAINTENANCE lamp or flashes the CHECK ENGINE lamp, indicating a maintenance condition, immediately after the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel pressure regulator valve or recirculation hose.
  • A malfunctioning fuel lift pump
  • Malfunctioning fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 1389 .

Last Modified: 11-Dec-2020


Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 141

Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 141 PID: P100 SPN: 100 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the engine oil pressure circuit. | None on performance.
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The oil pressure sensor shares supply and return wires in the engine harness with other sensors, opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting Fault Code 141, check for multiple faults.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 141 .

Last Modified: 11-Dec-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 143

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 143 PID: P100 SPN: 100 FMI: 1/18 LAMP: Amber SRT: | Engine oil pressure signal indicates engine oil pressure is below the engine protection warning limit. | Engine torque output will be reduced.
Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was less than the engine protection limits for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning oil pump.
  • Blocked or restricted oil passage.
  • Incorrect oil level
  • Damaged oil pressure sensor
  • Fault simulation is enabled.
  • Threshold is set too high.
Refer to Troubleshooting Fault Code 143 .

Last Modified: 11-Dec-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 144

Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 144 PID: P110 SPN: 110 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or open circuit detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the engine coolant temperature reading.

Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Before troubleshooting Fault Code 144, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning engine coolant temperature sensor
Refer to Troubleshooting Fault Code 144 .

Last Modified: 11-Dec-2020


Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 145

Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 145 PID: P110 SPN: 110 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at engine coolant temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM).
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the engine coolant temperature sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the engine coolant temperature reading.

Fan will stay ON if controlled by the engine control module (ECM).

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The engine coolant temperature sensor shares return wires in the engine harness with other sensors. A shorted return can cause multiple fault codes to be active. Before troubleshooting Fault Code 145, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning engine coolant temperature sensor
  • Damaged extension harness.
Refer to Troubleshooting Fault Code 145 .

Last Modified: 11-Dec-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 146

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 146 PID: P110 SPN: 110 FMI: 0/16 LAMP: Amber SRT: | Engine coolant temperature is above the engine protection warning limit. | Possible reduced engine performance.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 100°C [212°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 146 .

Last Modified: 11-Dec-2020


Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 151

Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 151 PID: P110 SPN: 110 FMI: 0/0 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Engine will shut down.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 110°C [230°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code indicates that coolant temperature has exceeded the engine protection limit for high coolant temperature.

Refer to Troubleshooting Fault Code 151 .

Last Modified: 11-Dec-2020


At Least One Module Has A Most Severe Fault - Condition Exists

FAULT CODE 1517

At Least One Module Has A Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1517 PID: S254 SPN: 1484 FMI: 11/31 LAMP: Red SRT: | At least one secondary engine control module (ECM) has an active red lamp fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active red lamp fault code.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all red lamp fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 1517 .

Last Modified: 11-Dec-2020


At Least One Module Has A Moderately Severe Fault - Condition Exists

FAULT CODE 1518

At Least One Module Has A Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1518 PID: S254 SPN: 1484 FMI: 11/31 LAMP: Amber SRT: | At least one secondary engine control module (ECM) has an active amber lamp fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active amber lamp fault code.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all amber lamp fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 1518 .

Last Modified: 11-Dec-2020


At Least One Module Has A Least Severe Fault - Condition Exists

FAULT CODE 1519

At Least One Module Has A Least Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1519 PID: S254 SPN: 1484 FMI: 11/31 LAMP: Maintenance SRT: | At least one secondary engine control module (ECM) has an active maintenance severity fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active maintenance severity fault code.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all maintenance severity fault codes in secondary ECMs are inactive.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 1519 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1521

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1521 PID: S131 SPN: 1139 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1521 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1522

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1522 PID: S133 SPN: 1141 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1522 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1523

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1523 PID: S135 SPN: 1143 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1523 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1524

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1524 PID: S137 SPN: 1145 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1524 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1525

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1525 PID: S139 SPN: 1147 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1525 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1526

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1526 PID: S141 SPN: 1149 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1526 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1527

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1527 PID: S143 SPN: 1151 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1527 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1529

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1529 PID: S130 SPN: 1138 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1529 .

Last Modified: 11-Dec-2020


Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 153

Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 153 PID: P105 SPN: 105 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.
  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The intake manifold air temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check active fault codes with multiple counts first.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 153 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1531

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1531 PID: S134 SPN: 1142 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1531 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1532

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1532 PID: S136 SPN: 1144 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1532 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1533

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1533 PID: S138 SPN: 1146 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1533 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1534

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1534 PID: S140 SPN: 1148 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1534 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1535

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1535 PID: S142 SPN: 1150 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1535 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1536

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1536 PID: S144 SPN: 1152 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1536 .

Last Modified: 11-Dec-2020


Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 154

Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 154 PID: P105 SPN: 105 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The intake manifold temperature sensor shares return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Check fault codes with multiple counts first.

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 154 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1548

Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1548 PID: S7 SPN: 657 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 7 circuit. | Possible reduced engine performance.
Injector 7 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 7: Fault Codes 1548 and 1622.

Refer to Troubleshooting Fault Code 1548 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1549

Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1549 PID: S8 SPN: 658 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 8 circuit. | Possible reduced engine performance.
Injector 8 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 8: Fault Codes 1549 and 1551.

Refer to Troubleshooting Fault Code 1549 .

Last Modified: 11-Dec-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 155

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 155 PID: P105 SPN: 105 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine will shut down.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 155 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1551

Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1551 PID: S10 SPN: 660 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 10 circuit. | Possible reduced engine performance.
Injector 10 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 8: Fault Codes 1549 and 1551.

Refer to Troubleshooting Fault Code 1551 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1552

Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1552 PID: S11 SPN: 661 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 11 circuit. | Possible reduced engine performance.
Injector 11 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 5: Fault Codes 323 and 1552.

Refer to Troubleshooting Fault Code 1552 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1553

Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1553 PID: S12 SPN: 662 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 12 circuit. | Possible reduced engine performance.
Injector 12 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 6: Fault Codes 325 and 1553.

Refer to Troubleshooting Fault Code 1553 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1554

Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1554 PID: S13 SPN: 663 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 13 circuit. | Possible reduced engine performance.
Injector 13 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 3: Fault Codes 324 and 1554.

Refer to Troubleshooting Fault Code 1554 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1555

Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1555 PID: S14 SPN: 664 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 14 circuit. | Possible reduced engine performance.
Injector 14 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 4: Fault Codes 332 and 1555.

Refer to Troubleshooting Fault Code 1555 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1556

Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1556 PID: S15 SPN: 665 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 15 circuit. | Possible reduced engine performance.
Injector 15 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 1: Fault Codes 322 and 1556.

Refer to Troubleshooting Fault Code 1556 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1557

Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1557 PID: S16 SPN: 666 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 16 circuit. | Possible reduced engine performance.
Injector 16 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 2: Fault Codes 331 and 1557.

Refer to Troubleshooting Fault Code 1557 .

Last Modified: 11-Dec-2020


Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 156

Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 156 PID: SPN: 1131 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature sensor signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to voltage source.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 156 .

Last Modified: 11-Dec-2020


Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 157

Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 157 PID: SPN: 1131 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at intake manifold air temperature circuit. | Fan will stay ON if controlled by the engine control module (ECM). Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the intake manifold temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning intake manifold pressure/temperature sensor
Refer to Troubleshooting Fault Code 157 .

Last Modified: 11-Dec-2020


Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 158

Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 158 PID: SPN: 1131 FMI: 0/0 LAMP: Red SRT: | Intake manifold air temperature signal indicates intake manifold air temperature above engine protection critical limit. | Engine will shut down.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 158 .

Last Modified: 11-Dec-2020


Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

FAULT CODE 1597

Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1597 PID: S254 SPN: 629 FMI: 12/12 LAMP: Maintenance SRT: | Error internal to the engine control module (ECM) related to memory hardware malfunctions or internal ECM voltage supply circuits. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a read or write error internal to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Internal ECM failure.
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 1597 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1618

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1618 PID: S129 SPN: 1137 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1618 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

FAULT CODE 1619

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1619 PID: S132 SPN: 1140 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 1619 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

FAULT CODE 1622

Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1622 PID: S9 SPN: 659 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 9 circuit. | Possible reduced engine performance.
Injector 9 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 7: Fault Codes 1548 and 1622.

Refer to Troubleshooting Fault Code 1622 .

Last Modified: 11-Dec-2020


Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1636

Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1636 PID: SPN: 1128 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the intake manifold pressure circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1636 .

Last Modified: 11-Dec-2020


Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1637

Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1637 PID: SPN: 1128 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected in the intake manifold pressure sensor circuit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the intake manifold pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The intake manifold pressure sensor provides a signal to the ECM on the intake manifold pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the intake manifold.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold pressure sensor signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value of the intake manifold pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • A malfunctioning intake manifold pressure sensor
Refer to Troubleshooting Fault Code 1637 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc1695
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc1695sa00
Is the ECM source address 144? | Go to 316-fc1695sa144

Last Modified: 03-Apr-2020


Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1695

Sensor Supply 5 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1695 PID: S232 SPN: 3513 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply 5 circuit in the OEM wiring harness. | None on performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Short to power supply in the engine wiring harness.
  • Malfunctioning or damaged sensor.
  • Malfunctioning ECM power supply.
Refer to Troubleshooting Fault Code 1695 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc1696
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc1696sa00
Is the ECM source address 144? | Go to 316-fc1696sa144

Last Modified: 03-Apr-2020


Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1696

Sensor Supply 5 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1696 PID: S232 SPN: 3513 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 5 circuit in the OEM harness. | None on performance.
Sensor Supply 5 Circuit

Circuit Description

The sensor supply 5 circuit of the engine control module (ECM) provides a 5 volt supply for various sensors.

Component Location

Sensor Supply 5 originates in the OEM connector portion of the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 5 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

  • Low voltage on the 5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a damaged sensor, or a damaged ECM power supply.
  • Reference the appropriate OEM wiring diagram when troubleshooting circuits that utilize wiring supplied by the OEM.
Refer to Troubleshooting Fault Code 1696 .

Last Modified: 11-Dec-2020


Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1774

Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1774 PID: SPN: 3589 FMI: 3/3 LAMP: Amber SRT: | A malfunctioning OEM switch circuit has been detected. | None on performance.
OEM Switch Circuit

Circuit Description

The OEM can configure the OEM switch SIGNAL circuit to be switched to ground or voltage source. Refer to the OEM service manual for information on the engine's configuration.

Component Location

The OEM switch is located in the engine oil supply system.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the OEM switch is indicating pre-lubricating pressure is present when engine conditions and the oil pressure sensor indicate it is not.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open or shorted signal circuit.
  • Malfunctioning OEM switch.
Refer to Troubleshooting Fault Code 1774 .

Last Modified: 11-Dec-2020


Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1775

Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1775 PID: SPN: 3589 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected in the oil priming pump control circuit. | None on performance.
Oil Pump Priming Relay

Circuit Description

The OEM switch signal is used by the ECM to determine when adequate pre-lubricating oil pressure has been achieved.

Component Location

Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has diagnosed that the oil priming pump relay control has been shorted to ground.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible cause of this fault code:

  • Malfunctioning pre-lubricating pump relay.
  • Malfunctioning or damaged engine wiring harness.
Refer to Troubleshooting Fault Code 1775 .

Last Modified: 11-Dec-2020


Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1843

Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1843 PID: P101 SPN: 101 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the crankcase pressure sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning crankcase pressure sensor.
Refer to Troubleshooting Fault Code 1843 .

Last Modified: 11-Dec-2020


Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1844

Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1844 PID: P101 SPN: 101 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the crankcase pressure circuit. | None on performance.
Engine Crankcase Pressure Sensor

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected that the crankcase pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the crankcase pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The crankcase pressure sensor shares supply and return wires in the engine harness with other sensors. Opens and shorts in the engine harness can cause multiple fault codes to be active. Before troubleshooting, check for multiple fault codes.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • Malfunctioning crankcase pressure sensor.
Refer to Troubleshooting Fault Code 1844 .

Last Modified: 11-Dec-2020


Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 1845

Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1845 PID: P97 SPN: 97 FMI: 3/3 LAMP: Maintenance SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
ECM 1 Water-in-Fuel Sensor 1 Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The engine has two water in fuel sensors. If the engine is equipped with a duplex fuel filter head, the wiring harness is connected to one water in fuel sensor on the duplex filter head and one water in fuel sensor on the engine mounted stage 1 filter head. If the engine is not equipped with an duplex fuel filter head, the wiring harness is connected to two of the water in fuel sensors on the engine mounted stage 1 filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return or signal circuit in the engine wiring harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning water in fuel sensor.
Refer to Troubleshooting Fault Code 1845 .

Last Modified: 11-Dec-2020


Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 1846

Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1846 PID: P97 SPN: 97 FMI: 4/4 LAMP: Maintenance SRT: | Low voltage detected at the water-in-fuel circuit. | None on performance.
ECM 1 Water-in-Fuel Sensor 1 Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The engine has two water in fuel sensors. If the engine is equipped with a duplex fuel filter head, the wiring harness is connected to one water in fuel sensor on the duplex filter head and one water in fuel sensor on the engine mounted stage 1 filter head. If the engine is not equipped with an duplex fuel filter head, the wiring harness is connected to two of the water in fuel sensors on the engine mounted stage 1 filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the engine wiring harness, sensor or connectors.
  • Malfunctioning water in fuel sensor.
Refer to Troubleshooting Fault Code 1846 .

Last Modified: 11-Dec-2020


Engine Coolant Temperature - Special Instructions

FAULT CODE 1847

Engine Coolant Temperature - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1847 PID: P110 SPN: 110 FMI: 14/14 LAMP: Red SRT: | Engine coolant temperature is above the engine protection warning limit. | Generator will be disconnected from the grid and the engine will idle only. The generator controller will shut down the engine.
Engine Coolant Temperature Sensor Circuit

Circuit Description

The coolant temperature sensor is a variable resistor sensor and is used to measure the temperature of the coolant of the engine. The engine control module (ECM) supplies 5 volts to the coolant temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the coolant temperature.

Component Location

The engine coolant temperature sensor is located on the thermostat housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant temperature was greater than 104°C [ 220°F] for more than 5 seconds.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

The engine speed may be limited to engine idle speed.

  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Coolant temperature has exceeded the engine protection limits for high coolant temperature.
Refer to Troubleshooting Fault Code 1847 .

Last Modified: 11-Dec-2020


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1852

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1852 PID: P97 SPN: 97 FMI: 0/16 LAMP: Amber SRT: | The water in fuel Indicator indicates that the water level is above warning level. | None on performance.
ECM 1 Water-in-Fuel Sensor Circuit
ECM 3 Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The engine has two water in fuel sensors. If the engine is equipped with a duplex fuel filter head, the wiring harness is connected to one water in fuel sensor on the duplex filter head and one water in fuel sensor on the engine mounted stage 1 filter head. If the engine is not equipped with an duplex fuel filter head, the wiring harness is connected to two of the water in fuel sensors on the engine mounted stage 1 filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in the fuel filter was above the sensor level.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Bulk fuel supply may be contaminated.
  • Malfunctioning water in fuel sensor.
Refer to Troubleshooting Fault Code 1852 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc187
Fault Code Path Selection

Is the sensor supply 2 circuit fault code generated from ECM 3 source address 00? | Go to 316-fc187sa00
Is the sensor supply 2 circuit fault code generated from ECM 2 source address 01? | Go to 316-fc187sa01

Last Modified: 03-Apr-2020


Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 187

Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 187 PID: S211 SPN: 3510 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the sensor supply 2 circuit. | Possible reduced engine performance.
Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

  • Low voltage on the +5 volt supply line can be caused by a short circuit to ground in a supply line, a short circuit between a supply line and a return line, a malfunctioning sensor, or a malfunctioning ECM power supply.

During the fault code response test outlined for each sensor connected to sensor supply number 2, Fault Code 187 must be active before unplugging each sensor. If the fault code is not active, but can be easily duplicated by operating the engine, the following can be performed:

Operate the engine under the conditions that will cause Fault Code 187 to become active, even if it logs for a short period of time. Unplug one sensor at a time until Fault Code 187 stops logging under the test conditions. Each sensor can be unplugged with the engine running.

Refer to Troubleshooting Fault Code 187 .

Last Modified: 11-Dec-2020


Engine Oil Change Interval - Condition Exists

FAULT CODE 1891

Engine Oil Change Interval - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1891 PID: S115 SPN: 1378 FMI: 11/31 LAMP: Amber SRT: | Engine conditions are preventing Centinel™ operation. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) uses the Centinel™ oil control valve to regulate the amount of used oil that is removed from the engine and sent to a waste oil tank. Depending on application setup, the oil control valve can also circulate fresh oil into the engine.

Component Location

The Centinel™ oil control valve is usually located on the left rear of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the Centinel™ system has been unable to operate for an extended period due to engine conditions.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Engine oil has reached its maintenance interval.
Refer to Troubleshooting Fault Code 1891 .

Last Modified: 11-Dec-2020


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level sensor circuit. | None on performance.
High Temperature Coolant Level Sensor Circuit
Low Temperature Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
  • Sensor supply circuit shorted to battery voltage.
Refer to Troubleshooting Fault Code 195 .

Last Modified: 11-Dec-2020


Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 195

Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 195 PID: P111 SPN: 111 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine coolant level sensor circuit. | None on performance.
High Temperature Coolant Level Sensor Circuit
Low Temperature Coolant Level Sensor Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Signal circuit shorted to sensor supply or battery voltage.

An open circuit in the harness

  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 195 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc195
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 316-fc195-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 316-fc195-3wire

Last Modified: 03-Apr-2020


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level sensor circuit. | None on performance.
High Temperature Coolant Level Sensor Circuit
Low Temperature Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • Open signal circuit in the engine harness, connectors, or sensor
  • Signal circuit shorted to ground in the engine wiring harness, sensor or connectors.
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 .

Last Modified: 11-Dec-2020


Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 196

Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 196 PID: P111 SPN: 111 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine coolant level sensor circuit. | None on performance.
High Temperature Coolant Level Sensor Circuit
Low Temperature Coolant Level Sensor Circuit

Circuit Description

The engine control module (ECM) supplies a 5 volt supply to the engine coolant level sensor using a common sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine coolant level sensor provides a signal to the ECM on the engine coolant level sensor signal circuit. This sensor signal voltage changes based on the coolant level in the expansion tank.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • A short circuit to ground in the engine wiring harness.
  • An open circuit in the OEM wiring harness.
  • A malfunctioning engine coolant level sensor
Refer to Troubleshooting Fault Code 196 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc196
Fault Code Path Selection

Is the coolant level sensor a 2-wire sensor? | Go to 316-fc196-2wire
Is the coolant level sensor a 3-wire sensor? | Go to 316-fc196-3wire

Last Modified: 03-Apr-2020


Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 197

Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 197 PID: P111 SPN: 111 FMI: 1/18 LAMP: Amber SRT: | Low engine coolant level detected. | None on performance.
High Temperature Coolant Level Sensor Circuit
Low Temperature Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal for 15 seconds.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

If this fault code is active and the coolant level is not low, disconnect the coolant level sensor and check the connectors for traces of coolant. If coolant is found at the electrical connectors, the sensor has malfunctioned and must be replaced.

Refer to Troubleshooting Fault Code 197 .

Last Modified: 11-Dec-2020


Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1984

Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1984 PID: SPN: 1131 FMI: 0/16 LAMP: Amber SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold 2 Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 2 pressure/temperature sensor is located in the low temperature air transfer connection on the right bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The intake manifold air temperature sensor measures the temperature of the charge-air as it passes through the intake manifold.

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 1984 .

Last Modified: 11-Dec-2020


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 1992

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 1992 PID: P190 SPN: 190 FMI: 0/16 LAMP: Red SRT: | The engine speed has exceeded a critical limit. | Engine may be shut down.
Crankshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the crankshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As holes drilled in the flywheel move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the drillings indicate to the ECM the engine position.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Tampering of the engine speed/position sensors.
Refer to Troubleshooting Fault Code 1992 .

Last Modified: 11-Dec-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 212

Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 212 PID: P175 SPN: 175 FMI: 3/3 LAMP: Amber SRT: | High signal voltage or an open circuit detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range high which is displayed

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The engine oil temperature sensor shares return wires in the engine harness with other sensors. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • A malfunctioning oil temperature sensor.
Refer to Troubleshooting Fault Code 212 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2121

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2121 PID: S129 SPN: 1137 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2121 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2122

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2122 PID: S131 SPN: 1139 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2122 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2123

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2123 PID: S133 SPN: 1141 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2123 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2124

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2124 PID: S135 SPN: 1143 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • High intake air temperature
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2124 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2125

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2125 PID: S137 SPN: 1145 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2125 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2126

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2126 PID: S139 SPN: 1147 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2126 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2127

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2127 PID: S141 SPN: 1149 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2127 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2128

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2128 PID: S143 SPN: 1151 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2128 .

Last Modified: 11-Dec-2020


Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 213

Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 213 PID: P175 SPN: 175 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine oil temperature circuit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the engine oil temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • A malfunctioning oil temperature sensor.
Refer to Troubleshooting Fault Code 213 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2131

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2131 PID: S130 SPN: 1138 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2131 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2132

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2132 PID: S132 SPN: 1140 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2132 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2133

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2133 PID: S134 SPN: 1142 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2133 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2134

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2134 PID: S136 SPN: 1144 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2134 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2135

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2135 PID: S138 SPN: 1146 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2135 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2136

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2136 PID: S140 SPN: 1148 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2136 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2137

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2137 PID: S142 SPN: 1150 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2137 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2138

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2138 PID: S144 SPN: 1152 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2138 .

Last Modified: 11-Dec-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 214

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 214 PID: P175 SPN: 175 FMI: 0/0 LAMP: Red SRT: | Engine oil temperature was above engine protection critical limit. | Engine may be shut down.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 214 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2144

Exhaust Gas Temperature Cylinder 16 (B8) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2144 PID: S144 SPN: 1152 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2144 .

Last Modified: 11-Dec-2020


Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 221

Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 221 PID: P108 SPN: 108 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is located on the left bank engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to battery in the engine wiring harness.
  • An open return circuit in the engine wiring harness.
  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 221 .

Last Modified: 11-Dec-2020


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 2215

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2215 PID: P94 SPN: 94 FMI: 1/18 LAMP: Amber SRT: | Low fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than normal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel inlet restriction high.
  • Stage 1 fuel filter restriction excessive.
  • Stage 2 fuel filter restriction excessive.
  • Air in the fuel
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2215 .

Last Modified: 11-Dec-2020


Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 222

Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 222 PID: P108 SPN: 108 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at barometric pressure circuit. | Possible reduced engine performance.
Barometric Pressure Sensor Circuit

Circuit Description

The barometric pressure sensor responds to pressure changes in the atmospheric pressure. The pressure changes occur based on the elevation where the engine is presently operating. The barometric pressure sensor has a 5 volt supply circuit, a sensor signal voltage, and a return circuit.

Component Location

The barometric pressure sensor is located on the left bank engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the barometric air pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the barometric pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine wiring harness.
  • An open circuit in the engine wiring harness.
  • A malfunctioning barometric air pressure sensor
Refer to Troubleshooting Fault Code 222 .

Last Modified: 11-Dec-2020


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 2249

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2249 PID: P157 SPN: 157 FMI: 1/1 LAMP: Amber SRT: | The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was below commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Air in the fuel
  • High fuel inlet restriction
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel rail pressure relief valve
  • Leaking injectors and/or injector supply lines
Refer to Troubleshooting Fault Code 2249 .

Last Modified: 11-Dec-2020


Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2261

Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2261 PID: P94 SPN: 94 FMI: 0/15 LAMP: Maintenance SRT: | High fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was higher than normal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel supply line pinched or damaged
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2261 .

Last Modified: 11-Dec-2020


Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 2262

Fuel Pump Delivery Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2262 PID: P94 SPN: 94 FMI: 1/17 LAMP: Maintenance SRT: | Low fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was lower than normal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel inlet restriction high.
  • Stage 1 fuel filter restriction excessive.
  • Stage 2 fuel filter restriction excessive.
  • Air in the fuel
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2262 .

Last Modified: 11-Dec-2020


Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 227

Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 227 PID: S211 SPN: 3510 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 2 circuit. | Possible reduced engine performance.
ECM 1 Sensor Supply 2 Circuit
ECM 2 Sensor Supply 2 Circuit

Circuit Description

The sensor supply 2 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 2 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 2 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each Engine Control Module (ECM) has an individual source address that displays when Cummins® electronic service tool is connected. When troubleshooting a fault code, use the source address displayed in Cummins® electronic service tool to determine which ECM and circuit is affected.

Possible causes of this fault code include:

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 227 .

Last Modified: 11-Dec-2020


Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 228

Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 228 PID: P109 SPN: 109 FMI: 1/1 LAMP: Red SRT: | Low coolant pressure has been detected. | Engine will shut down.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine coolant pressure was less than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low coolant level
  • A malfunctioning radiator cap.
  • A malfunctioning coolant pressure sensor.
  • A malfunctioning water pump.
Refer to Troubleshooting Fault Code 228 .

Last Modified: 11-Dec-2020


Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 231

Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 231 PID: P109 SPN: 109 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at coolant pressure circuit. | None on performance.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
  • A malfunctioning coolant pressure sensor.
Refer to Troubleshooting Fault Code 231 .

Last Modified: 11-Dec-2020


Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 232

Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 232 PID: P109 SPN: 109 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at coolant pressure circuit. | None on performance.
Engine Coolant Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the coolant pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The coolant pressure sensor provides a signal to the ECM on the coolant pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the cooling system.

Component Location

The coolant pressure sensor is located on the high temperature circuit outlet of the water pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the engine wiring harness, sensor, or connector.
  • Supply wire open or shorted to ground.
  • A malfunctioning coolant pressure sensor.
Refer to Troubleshooting Fault Code 232 .

Last Modified: 11-Dec-2020


Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 234

Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 234 PID: P190 SPN: 190 FMI: 0/0 LAMP: Red SRT: | Engine speed signal indicates engine speed above engine protection limit. | Engine may be shut down.
Crankshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the crankshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As holes drilled in the flywheel move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the drillings indicate to the ECM the engine position.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine speed had exceeded the calibration limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Fueling to the engine is stopped until the engine speed drops to normal operating speeds.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • External fuel sources drawn into the intake air passage
  • Tampering of the engine speed/position sensors.
Refer to Troubleshooting Fault Code 234 .

Last Modified: 11-Dec-2020


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 2343

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2343 PID: P95 SPN: 95 FMI: 0/15 LAMP: Maintenance SRT: | Fuel filter restriction has exceeded a pre-set threshold. | Possible reduced engine performance.
Engine Fuel Supply Pump

Circuit Description

The engine fuel supply pump uses fuel delivery pressure, pump speed, and pump motor current to calculate stage 2 fuel filter restriction.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected that stage 2 fuel filter restriction was above a customer determined threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code is intended to allow customizeable early detection of stage 2 filter plugging. The fault threshold can be configured based on the engine fuel supply pump stage 2 filter life monitor parameter.

Refer to Troubleshooting Fault Code 2343 .

Last Modified: 11-Dec-2020


Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 235

Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 235 PID: P111 SPN: 111 FMI: 1/1 LAMP: Red SRT: | The engine coolant is severely low. | Generator will be disconnected from the grid and the engine will idle only. The generator controller will shut down the engine.
High Temperature Coolant Level Sensor Circuit
Low Temperature Coolant Level Sensor Circuit

Circuit Description

The coolant level sensor is a switch and is used to measure the level of the engine coolant in the radiator top tank. The coolant level sensor is immersed in the coolant and returns a different signal voltage when immersed in coolant versus being out of coolant. The engine control module (ECM) monitors the change in the signal voltage to determine the level of the engine coolant.

Component Location

The engine coolant level sensor is typically located in the radiator top tank or surge tank. Refer to the OEM service manual for the location.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the coolant level was below normal.

Action Taken When the Fault Code is Active

  • The ECM illuminates the red STOP ENGINE lamp immediately after the diagnostic runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Each ECM has an individual source address that displays when the recommended Cummins® electronic service tool or equivalent is connected. When troubleshooting a fault code, use the source address displayed in the recommended Cummins® electronic service tool or equivalent to determine which ECM and circuit is affected.

This fault code goes active when the coolant level inside the radiator top tank or surge tank drops below the sensor level. Fill the top tank with coolant.

Possible causes of this fault code include:

  • Low coolant level
  • A malfunctioning engine coolant level sensor
  • Loose, worn, or corroded connectors or pins.
Refer to Troubleshooting Fault Code 235 .

Last Modified: 11-Dec-2020


Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2372

Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2372 PID: P95 SPN: 95 FMI: 0/16 LAMP: Amber SRT: | Excessive fuel flow restriction to the high pressure fuel pump has been detected. | Possible reduced engine performance.
Engine Fuel Supply Pump

Circuit Description

The engine fuel supply pump uses fuel delivery pressure, pump speed, and pump motor current to calculate stage 2 fuel filter restriction.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected high stage 2 fuel filter restriction.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction excessive.
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 2372 .

Last Modified: 11-Dec-2020


Fan Control Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2377

Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2377 PID: S33 SPN: 647 FMI: 3/3 LAMP: Amber SRT: | Open circuit or high voltage detected at the fan control circuit. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit is a device used by the engine to control the fan operation. When the engine control module (ECM) energizes the fan control circuit, the engine fan is engaged.

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM.

Conditions for Running the Diagnostics

For ON/OFF and variable speed fan types, the diagnostic runs when the fan is turned off and will latch active when the fan PWM signal is 100 percent. For all other fan types, the diagnostic runs when the fan PWM signal is less than 100 percent and will latch active when the fan PWM signal is 100 percent.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal voltage was greater then 0-VDC when the PWM signal was commanded OFF.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • Fan operation will be disabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • An open circuit in the harness or fan control solenoid.
  • A short circuit to voltage source in the engine wiring harness.
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 2377 .

Last Modified: 11-Dec-2020


Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 238

Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 238 PID: S232 SPN: 3511 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Short circuit to ground in the engine harness, sensor, or ECM.
Refer to Troubleshooting Fault Code 238 .

Last Modified: 11-Dec-2020


Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 239

Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 239 PID: S232 SPN: 3511 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the sensor supply circuit to the engine speed sensor. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Sensor Supply 3 Circuit

Circuit Description

The sensor supply 3 circuit provides a 5 volt supply to the primary engine speed/position sensor.

Component Location

Sensor Supply 3 originates in the engine connector portion of the ECM. It provides 5 VDC to the engine crankshaft speed/position sensor.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 3 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High voltage on the +5 volt supply wire can be caused by a short to battery voltage in the engine harness or connectors, or a damaged ECM.
Refer to Troubleshooting Fault Code 239 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 1 - Out of Calibration

FAULT CODE 2442

Injector Solenoid Driver Cylinder 1 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2442 PID: S1 SPN: 651 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 1 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2442 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 2 - Out of Calibration

FAULT CODE 2443

Injector Solenoid Driver Cylinder 2 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2443 PID: S2 SPN: 652 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 2 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2443 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 3 - Out of Calibration

FAULT CODE 2444

Injector Solenoid Driver Cylinder 3 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2444 PID: S3 SPN: 653 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 3 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2444 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 4 - Out of Calibration

FAULT CODE 2445

Injector Solenoid Driver Cylinder 4 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2445 PID: S4 SPN: 654 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 4 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2445 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 5 - Out of Calibration

FAULT CODE 2446

Injector Solenoid Driver Cylinder 5 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2446 PID: S5 SPN: 655 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 5 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2446 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 6 - Out of Calibration

FAULT CODE 2447

Injector Solenoid Driver Cylinder 6 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2447 PID: S6 SPN: 656 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 6 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 2447 .

Last Modified: 11-Dec-2020


Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 245

Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 245 PID: S33 SPN: 647 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fan control circuit when commanded ON. | The fan can stay on continuously or not run at all.
Fan Control Circuit

Circuit Description

The fan control circuit utilizes a pulse width modulated (PWM) signal. A PWM signal is a pulsed voltage signal between 0-VDC and system voltage. The frequency of the pulsed voltage signal is dependent on the application requirement.

There are two types of fans supported by the fan control circuit; variable speed and ON/OFF. The recommended Cummins® electronic service tool or equivalent can be used to determine which fan type is currently set up for use. The fan control circuit varies by original equipment manufacturer (OEM). Certain OEMs can use a solenoid return that is wired to the ECM or can use a return that goes to the engine block or chassis ground.

Component Location

The control solenoid location varies by OEM.

Conditions for Running the Diagnostics

This diagnostic runs when the generator set controller is active and when the pulse width modulated (PWM) device is getting energized or de-energized. In some cases, the diagnostics can also run at some fixed intervals.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fan control circuit pulse width modulated (PWM) signal was not at system voltage when the pulse width modulated (PWM) signal was commanded ON.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

The fan control logic can be adjusted with the recommended Cummins® electronic service tool or equivalent. There are two choices: 12 or 24 volts ON, or 0 volts ON. For proper fan operation, the fan control logic setup with the recommended Cummins® electronic service tool or equivalent must match the hardware configuration on the vehicle.

If Fault Code 245 is still active after completing the following troubleshooting steps, consult the OEM service manual for procedures to check the fan control circuit for a short circuit to ground.

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the engine wiring harness, sensor or connectors.
Refer to Troubleshooting Fault Code 245 .

Last Modified: 11-Dec-2020


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2544

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2544 PID: P21 SPN: 1136 FMI: 0/0 LAMP: Red SRT: | High internal ECM temperature detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect or restricted air flow over the ECM and engine.
Refer to Troubleshooting Fault Code 2544 .

Last Modified: 11-Dec-2020


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 261

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 261 PID: P174 SPN: 174 FMI: 0/16 LAMP: Amber SRT: | Fuel temperature above the warning level has been detected. | Possible reduced engine performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature exceeded the warning limit.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel cooler.
  • Operating the engine in a hot ambient environment with a low fuel tank level
Refer to Troubleshooting Fault Code 261 .

Last Modified: 11-Dec-2020


Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 263

Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 263 PID: P174 SPN: 174 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the engine fuel temperature circuit. | None on performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source
  • Malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 263 .

Last Modified: 11-Dec-2020


Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 265

Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 265 PID: P174 SPN: 174 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the engine fuel temperature sensor circuit. | None on performance.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for the engine fuel temperature reading.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
  • Malfunctioning fuel temperature sensor
Refer to Troubleshooting Fault Code 265 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2651

Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2651 PID: SPN: 2433 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the right bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the flashing amber CHECK ENGINE lamp / MAINTENANCE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2651 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2652

Engine Exhaust Gas Temperature - Bank 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2652 PID: SPN: 2433 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the right bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 2652 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2653

Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2653 PID: SPN: 2433 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2653 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2654

Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2654 PID: SPN: 2433 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The right bank exhaust gas temperature sensor is located in the right bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2654 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 2655

Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2655 PID: SPN: 2434 FMI: 3/3 LAMP: Maintenance SRT: | High signal voltage detected at the left bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detects the exhaust gas temperature sensor circuit is out of range high.

This fault code sets when the following conditions are met:

  • Engine speed greater than 500 RPM.
  • Engine oil temperature greater than 60°C [140°F].

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

The exhaust gas temperature sensors share return wires in the harness. An open return can cause multiple fault codes to be active.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Open signal circuit or shorted to a voltage source.
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2655 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 2656

Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2656 PID: SPN: 2434 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the left bank exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 2656 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 2657

Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2657 PID: SPN: 2434 FMI: 0/16 LAMP: Amber SRT: | The exhaust gas temperature sensor has detected temperature above the warning level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The temperature to clear this fault code is lower than the temperature it set at.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2657 .

Last Modified: 11-Dec-2020


Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 2658

Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2658 PID: SPN: 2434 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The left bank exhaust gas temperature sensor is located in the left bank exhaust outlet connection.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 2658 .

Last Modified: 11-Dec-2020


Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 266

Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 266 PID: P174 SPN: 174 FMI: 0/0 LAMP: Red SRT: | Fuel temperature above the critical limit has been detected. | Engine will shut down.
Engine Fuel Temperature Sensor Circuit

Circuit Description

The engine fuel temperature sensor is a variable resistor sensor and is used to measure the temperature of the fuel at the stage 2 filter housing. The engine control module (ECM) supplies 5 volts to the engine fuel temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the delivery fuel temperature.

Component Location

The engine fuel temperature sensor is located in the stage 2 fuel filter housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel temperature was greater than 77°C [170°F] for 15 seconds.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and run it at high idle for 5 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning fuel cooler.
  • Operating the engine in a hot ambient environment with a low fuel tank level
Refer to Troubleshooting Fault Code 266 .

Last Modified: 11-Dec-2020


At Least One Unacknowledged Most Severe Fault - Condition Exists

FAULT CODE 2661

At Least One Unacknowledged Most Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2661 PID: SPN: 629 FMI: 11/31 LAMP: Red SRT: | At Least One Unacknowledged Most Severe Fault - Condition Exists. | None on performance.
Engine Control Module (ECM)

Circuit Description

There is at least one unacknowledged severe fault in the system.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fault that has not set the lamp within a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information-only fault code that will only become active if other critical engine protection fault codes are active. This fault code will remain active until acknowledged using the OEM supplied switch.

Refer to Troubleshooting Fault Code 2661 .

Last Modified: 11-Dec-2020


At Least One Unacknowledged Moderately Severe Fault - Condition Exists

FAULT CODE 2662

At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2662 PID: SPN: 629 FMI: 11/31 LAMP: Amber SRT: | At Least One Unacknowledged Moderately Severe Fault - Condition Exists. | None on performance.
Engine Control Module (ECM)

Circuit Description

There is at least one unacknowleged moderately severe fault in the system.

Component Location

The reset button or switch location depends on the original equipment manufacturer (OEM).

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a fault that has not set the lamp within a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information-only fault code that will only become active if other moderate severity fault codes are active. This fault code will remain active until acknowledged using the OEM supplied switch.

Refer to Troubleshooting Fault Code 2662 .

Last Modified: 11-Dec-2020


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 2727

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 2727 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Maintenance SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 Ω resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the battery supply circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 2727 .

Last Modified: 11-Dec-2020


SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

FAULT CODE 285

SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 285 PID: S231 SPN: 639 FMI: 9/9 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but did not receive it soon enough or did not receive it at all. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

The Engine Control Module (ECM) detected an open or short circuit condition in the J1939 data link harness.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

When this fault code is active, some multiplexed devices can possibly not function as desired.

Possible causes of this fault code include:

  • Damaged J1939 data link connection between the OEM ECU and Cummins® ECM.
  • Damaged connection between the component and the OEM ECU.
  • Damaged OEM ECU or damaged Cummins® ECM. It may be necessary to contact the OEM for proper multiplexing configuration.
  • A multiplexed component is enabled in the ECM, but the OEM ECU source address of the ECU transmitting the component message is incorrect in the Cummins® ECM, or the OEM ECU is not set up to transmit the multiplexed component message.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 285 .

Last Modified: 11-Dec-2020


SAE J1939 Multiplexing Configuration Error - Out of Calibration

FAULT CODE 286

SAE J1939 Multiplexing Configuration Error - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 286 PID: S231 SPN: 639 FMI: 13/13 LAMP: Amber SRT: | The ECM expected information from a multiplexed device but only received a portion of the necessary information. | At least one multiplexed device will not operate properly.
SAE J1939 Datalink Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) received an invalid J1939 data link message from a multiplexed device for more than 1 second.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

This fault can occur when the ECM is set up properly (components enabled and OEM ECU source addressed correctly) to receive information from an OEM ECU, but the OEM ECU is transmitting a message that says that component is not available for multiplexing.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 286 .

Last Modified: 11-Dec-2020


Real Time Clock - Data Erratic, Intermittent, or Incorrect

FAULT CODE 319

Real Time Clock - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 319 PID: P251 SPN: 251 FMI: 2/2 LAMP: Maintenance SRT: | Real-time clock lost power. | None on performance.
Real Time Clock Power Circuit

Circuit Description

Under ordinary operating conditions, the real-time clock in the Engine Control Module (ECM) is powered by the vehicle's batteries. If battery power to the ECM is lost, then the real-time clock will be powered by a battery in the engine harness (if equipped).

Component Location

The real time clock is a timing chip internal to the ECM and can not be serviced separately.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the real-time clock data was lost due to power loss

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The real-time clock values in the ECM data will be incorrect.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

  • This fault indicates that the real-time clock in the ECM lost power.

Possible causes of this fault code include:

  • Damaged wiring or connectors between the battery and ECM.
  • Engine is not equipped with a real-time clock battery. Vehicle battery power to the ECM is lost.
  • Weak or damaged real-time clock battery.
Refer to Troubleshooting Fault Code 319 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

FAULT CODE 322

Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 322 PID: S1 SPN: 651 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 1 circuit. | Possible reduced engine performance.
Injector 1 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground

Same Injector Bank Fault Codes:

Injector Bank 1: Fault Codes 322 and 1556.

Refer to Troubleshooting Fault Code 322 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

FAULT CODE 323

Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 323 PID: S5 SPN: 655 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 5 circuit. | Possible reduced engine performance.
Injector 5 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground

Same Injector Bank Fault Codes:

Injector Bank 5: Fault Codes 323 and 1552.

Refer to Troubleshooting Fault Code 323 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

FAULT CODE 324

Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 324 PID: S3 SPN: 653 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 3 circuit. | Possible reduced engine performance.
Injector 3 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine harness(es) or injector solenoid.
  • High resistance in a single injector or injector solenoid.
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground).
  • Malfunctioning or damaged ECM.

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground

Same Injector Bank Fault Codes:

Injector Bank 3: Fault Codes 324 and 1554.

Refer to Troubleshooting Fault Code 324 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

FAULT CODE 325

Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 325 PID: S6 SPN: 656 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 6 circuit. | Possible reduced engine performance.
Injector 6 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same injector bank exhibit misfires, look for a short circuit anywhere in that injector bank circuit.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 6: Fault Codes 325 and 1553.

Refer to Troubleshooting Fault Code 325 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

FAULT CODE 331

Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 331 PID: S2 SPN: 652 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 2 circuit. | Possible reduced engine performance.
Injector 2 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 2: Fault Codes 331 and 1557.

Refer to Troubleshooting Fault Code 331 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

FAULT CODE 332

Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 332 PID: S4 SPN: 654 FMI: 5/5 LAMP: Amber SRT: | Malfunction detected at injector 4 circuit. | Possible reduced engine performance.
Injector 4 Circuit

Circuit Description

The injector solenoid valves control fueling quantity and injection timing. The engine control module (ECM) energizes the solenoid by closing a high-side and a low-side switch. Each injector circuit has a dedicated low-side switch that completes the circuit path to ground inside the ECM.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a circuit error on an injector(s) circuit. The ECM will disable the injection event for the affected injector(s) circuit if there is excessive current.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If more than one injector fault code is occurring, and the faults occur for injector circuits in the same injector bank, a short circuit exists.

If the fault(s) occur intermittently, the engine can exhibit a misfire even if the injector circuit fault code does not always register. If a single cylinder exhibits misfires, look for an open circuit problem. If several cylinders on the same bank exhibit misfires, look for a short circuit anywhere in the bank of cylinders.

Possible causes of a single injector fault include:

  • Open circuit in the engine wiring harness(es) or injector solenoid
  • High resistance in a single injector or injector solenoid
  • Extremely low resistance in an injector solenoid (injector shorted internally but not to ground)

Possible causes of multiple injector fault codes in the same bank of injectors include:

  • Short circuit in the engine wiring harness(es) - either shorts to ground or to other wires in the engine harness
  • Short circuit in any of the two injectors in the bank - shorts to ground
  • Malfunctioning or damaged ECM.

Same Injector Bank Fault Codes:

Injector Bank 4: Fault Codes 332 and 1555.

Refer to Troubleshooting Fault Code 332 .

Last Modified: 11-Dec-2020


J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3329

J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3329 PID: SPN: 1231 FMI: 2/2 LAMP: None SRT: | A circuit malfunction has been detected on J1939 network 2. | Possible reduced engine performance.
SAE J1939 Data Link 2

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 Ω resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The SAE J1939 data link 2 is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an open on the J1939 data link backbone or a short circuit.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link.
Refer to Troubleshooting Fault Code 3329 .

Last Modified: 11-Dec-2020


J1939 Network #3 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 3331

J1939 Network #3 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3331 PID: SPN: 1235 FMI: 2/2 LAMP: None SRT: | A circuit malfunction has been detected on J1939 network 3. | Possible reduced engine performance.
SAE J1939 Data Link 3

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 Ω resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the smart devices to the J1939 backbone.

The Engine Control Module (ECM) uses J1939 data link 3 to communicate with the engine fuel supply pump and fuel metering valve.

Component Location

The SAE J1939 data link 3 is located in the engine harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an open on the J1939 data link backbone or a short circuit.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit on J1939 data link.
Refer to Troubleshooting Fault Code 3331 .

Last Modified: 11-Dec-2020


Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 3379

Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3379 PID: P21 SPN: 1136 FMI: 0/16 LAMP: Amber SRT: | High internal ECM temperature has been detected. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Module (ECM) internal temperature sensor is located inside the ECM.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected internal temperatures above the warning limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine, let it idle for 1 minute, and then shutdown the engine.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect or restricted air flow over the ECM and engine.
  • Plugged or restricted ECM cooling plate.
  • Plugged or restricted ECM cooling plate lines.
  • Malfunctioning Low Temperature Aftercooled (LTA) system
Refer to Troubleshooting Fault Code 3379 .

Last Modified: 11-Dec-2020


Electronic Calibration Code Incompatibility - Out of Calibration

FAULT CODE 342

Electronic Calibration Code Incompatibility - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 342 PID: S253 SPN: 630 FMI: 13/13 LAMP: Red SRT: | Calibration mismatch detected between modules. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

Calibration mismatch or incompatibility detected between ECMs in the system.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The injector will be disabled for the malfunctioning cylinder.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Corrupted engine calibration
Refer to Troubleshooting Fault Code 342 .

Last Modified: 11-Dec-2020


Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 344

Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 344 PID: P16 SPN: 1382 FMI: 0/15 LAMP: Maintenance SRT: | The engine fuel supply pump has detected high fuel intake restriction. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

The fuel supply pump intake pressure sensor measures the gauge pressure at the inlet of the engine fuel supply pump. The sensor is connected directly to the pump and the sensor value is communicated to the ECMs via the engine datalink.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel supply pump intake pressure sensor is located on the inlet of the engine fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected that fuel intake restriction was above the calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Stage 0 fuel filter restriction excessive.
  • Stage 1 fuel filter restriction excessive.
  • A malfunctioning fuel lift pump
  • High fuel inlet restriction
  • Malfunctioning fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 344 .

Last Modified: 11-Dec-2020


Injector Power Supply - Bad Intelligent Device or Component

FAULT CODE 351

Injector Power Supply - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 351 PID: S251 SPN: 3597 FMI: 12/12 LAMP: Amber SRT: | The ECM measured injector boost voltage is low. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

Between each injection event, the Engine Control Module (ECM) attempts to recharge the injector power supply. The injector power supply consists of a bank of capacitors. This power supply is maintained at high voltage. Recharging is accomplished by recovering energy stored in the injector solenoids. For the injector power supply to remain fully charged, there must be good ECM battery power and ground, a good engine speed/position sensor, and good injector circuits.

Component Location

The engine wiring harness connects the ECM to each injector. The injector connectors are located on the injectors above the valve covers.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured injector power supply voltage was less than the commanded injector power supply voltage.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Open or short circuit in the wiring harness.
  • Low battery voltage.
  • Battery Failure.
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 351 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc352
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc352sa00
Is the ECM source address 01? | Go to 316-fc352sa01

Last Modified: 03-Apr-2020


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.
  • To validate the repair, start the engine and let it run for 1 minute at no load.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352 .

Last Modified: 11-Dec-2020


Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 352

Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 352 PID: S212 SPN: 3509 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Low voltage on the +5 volt supply wire can be caused by a short circuit to ground in a supply wire, a short circuit between a supply wire and a return wire, a malfunctioning sensor, or a malfunctioning ECM power supply.

Refer to Troubleshooting Fault Code 352 .

Last Modified: 11-Dec-2020


Engine Control Module Calibration Memory - Bad Intelligent Device or Component

FAULT CODE 3697

Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3697 PID: S253 SPN: 630 FMI: 12/12 LAMP: Red SRT: | Error internal to the ECM related to engine software failures. | Engine may not start or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The ECM has internal diagnostics that continuously run and check the internal memory.

Component Location

The ECM mounting location varies, depending on the engine model, and may be mounted either on or off the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a software or calibration error.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine may not start.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Internal ECM failure.
Refer to Troubleshooting Fault Code 3697 .

Last Modified: 11-Dec-2020


High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 3727

High Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3727 PID: SPN: 5571 FMI: 7/7 LAMP: None SRT: | The fuel rail high-pressure relief valve has opened at a lower than expected pressure. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pressure relief valve had opened at a pressure lower than expected.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code will become inactive at each key OFF event, and will not become active again until the fault condition reoccurs. Troubleshoot inactive or active occurences of this fault code the same.

Possible causes of this fault code include:

  • Sudden and significant loss of fuel pressure
  • Malfunctioning fuel rail pressure sensor.
Refer to Troubleshooting Fault Code 3727 .

Last Modified: 11-Dec-2020


High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 3741

High Pressure Common Rail Fuel Pressure Relief Valve - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 3741 PID: SPN: 5571 FMI: 0/0 LAMP: Amber SRT: | The fuel rail pressure relief valve has opened due to high fuel rail pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Control Module (ECM)

Circuit Description

The high-pressure relief valve is a mechanical device that opens when the fuel pressure in the fuel rail exceeds a critical limit.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure had exceeded the fuel pressure relief valve opening pressure, and the fuel pressure relief valve opened.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel drain line restriction
  • A malfunctioning fuel metering valve.
  • Air in the fuel
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 3741 .

Last Modified: 11-Dec-2020


Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 386

Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 386 PID: S212 SPN: 3509 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at sensor supply number 1 circuit. | Possible reduced engine performance.
Sensor Supply 1 Circuit
Sensor Supply 1 Circuit

Circuit Description

The sensor supply 1 circuit of the engine control module (ECM) provides a 5 volt supply to various sensors on the engine harness. Refer to the wiring diagram for sensor supply identification.

Component Location

Sensor Supply 1 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 1 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value is used for all of the sensors on the sensor supply 1 circuit.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 386 .

Last Modified: 11-Dec-2020


Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 415

Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 415 PID: P100 SPN: 100 FMI: 1/1 LAMP: Red SRT: | The engine oil pressure sensor indicates oil pressure is below the engine protection critical limit. | Engine will shut down.
Engine Oil Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the engine oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The engine oil pressure sensor provides a signal to the ECM on the engine oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil rifle. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil temperature is low.

Component Location

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High oil filter restriction.
  • Malfunctioning oil pump.
  • Incorrect oil level
  • Damaged oil pressure sensor
Refer to Troubleshooting Fault Code 415 .

Last Modified: 11-Dec-2020


Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 421

Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 421 PID: P175 SPN: 175 FMI: 0/16 LAMP: Amber SRT: | Engine oil temperature signal indicates engine oil temperature above engine protection warning limit. | None on performance.
Engine Oil Temperature Sensor Circuit

Circuit Description

The engine oil temperature sensor is a variable resistor sensor and is used to measure the temperature of the engine oil. The engine control module (ECM) supplies 5 volts to the engine oil temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the engine oil temperature. When the oil temperature is cold, the sensor or thermistor resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the oil temperature is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage or high temperature.

Component Location

The engine oil temperature sensor is located in the oil pan.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine oil temperature was greater than the engine protection limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code indicates that the engine oil temperature has exceeded the maximum engine protection limit for oil temperature. Troubleshoot the cause of high engine oil temperature.

Refer to Troubleshooting Fault Code 421 .

Last Modified: 11-Dec-2020


J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 426

J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 426 PID: S231 SPN: 639 FMI: 2/2 LAMP: None SRT: | Communication between the engine control module (ECM) and another device on the SAE J1939 data link has been lost. | None on performance.
SAE J1939 Datalink 1 Circuit

Circuit Description

Normally, switches, accelerators, and other components are connected to the engine control module (ECM) directly through individual wires. Multiplexing allows those same components to be hard wired to an original equipment manufacturer (OEM) electronic control unit (ECU). Then component values and states from components such as sensors, throttle input, and switches can be transmitted from the OEM ECU to the Cummins® ECM over the SAE J1939 data link.

Messages sent from OEM ECUs are received by the Cummins® ECM and used for controlling the engine. The Cummins® ECM and OEM ECU(s) must be configured properly, so that proper operation of the multiplexed components will occur.

Component Location

The SAE J1939 data link wiring and the SAE J1939 devices vary by OEM options.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) did not receive a message from a multiplexed device.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.
  • The multiplexed device will not operate.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A multiplexed component is enabled in the ECM, but the OEM ECU source address of the ECU transmitting the component message is incorrect in the Cummins® ECM.
  • The OEM ECU is not set up to transmit the multiplexed component message.
  • Damaged J1939 data link connection between the OEM ECU and Cummins® ECM.
  • Damaged connection between the component and the OEM ECU.
  • Damaged OEM ECU or damaged Cummins® ECM.

It is possible to use the recommended Cummins® electronic service tool or equivalent to monitor multiplexed components.

Refer to Troubleshooting Fault Code 426 .

Last Modified: 11-Dec-2020


Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 441

Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 441 PID: P168 SPN: 168 FMI: 1/18 LAMP: Amber SRT: | ECM supply voltage is below the minimum system voltage level. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by a combination of engine harness and OEM harness connected in series. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected low battery supply voltage.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Weak batteries.
  • The ECM unswitched power supply is coming from the batteries and not the starter or other device.
Refer to Troubleshooting Fault Code 441 .

Last Modified: 11-Dec-2020


Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 442

Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 442 PID: P168 SPN: 168 FMI: 0/16 LAMP: Amber SRT: | ECM supply voltage is above the maximum system voltage level. | None on performance.
Unswitched Battery Supply Circuit

Circuit Description

The engine control module (ECM) receives constant voltage from the batteries through the unswitched battery wires that are connected directly to the positive (+) battery post. The ECM receives switched battery input through the keyswitch wire when the keyswitch is turned ON.

Component Location

The ECM is connected to the battery by a combination of engine harness and OEM harness connected in series. This direct link provides a constant power supply for the ECM. The location of the battery will vary with the original equipment manufacturer (OEM). Refer to the OEM service manual.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected excessive battery supply voltage.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Faulty alternator or regulator that is overcharging the system
  • Batteries connected in series instead of parallel
  • Incorrect jump-starting procedure.
Refer to Troubleshooting Fault Code 442 .

Last Modified: 11-Dec-2020


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 449

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 449 PID: P157 SPN: 157 FMI: 0/0 LAMP: Red SRT: | The ECM has detected that fuel pressure in the fuel rail is higher than the normal operating fuel system pressure. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the opening pressure of the fuel pressure relief valve.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel pressure relief valve
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 449 .

Last Modified: 11-Dec-2020


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 451

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 451 PID: P157 SPN: 157 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The fuel rail pressure sensor is located on the front of the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Causes for this fault code include:

  • Voltage (+5-VDC or higher shorted to the signal wire)
  • Open circuit on the signal wire
  • Open circuit on the 5 Volt supply wire
  • Open circuit on the return wire
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 451 .

Last Modified: 11-Dec-2020


Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 452

Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 452 PID: P157 SPN: 157 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel rail pressure sensor circuit. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel rail pressure sensor using a dedicated sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel rail pressure sensor provides a fuel pressure signal to the ECM on the fuel rail pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the fuel rail. The ECM will detect a high signal voltage at high rail pressure conditions. The ECM will detect a low signal voltage during low rail pressure conditions.

Component Location

The fuel rail pressure sensor is located in the high pressure fuel rail near the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel rail pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the fuel rail pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Supply or signal wire is shorted to ground.
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 452 .

Last Modified: 11-Dec-2020


Engine Fuel Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4615

Engine Fuel Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4615 PID: SPN: 94 FMI: 0/0 LAMP: Amber SRT: | High fuel delivery pressure has been detected. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure was higher than normal.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Fuel supply line pinched or damaged
  • High fuel drain line restriction
  • Malfunctioning fuel delivery pressure sensor.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 4615 .

Last Modified: 11-Dec-2020


Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4642

Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4642 PID: SPN: 97 FMI: 0/0 LAMP: Red SRT: | The water in fuel Indicator indicates that the water level is above warning level. | None on performance.
ECM 1 Water-in-Fuel Sensor Circuit
ECM 3 Water-in-Fuel Sensor Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The engine has two water in fuel sensors. If the engine is equipped with a duplex fuel filter head, the wiring harness is connected to one water in fuel sensor on the duplex filter head and one water in fuel sensor on the engine mounted stage 1 filter head. If the engine is not equipped with an duplex fuel filter head, the wiring harness is connected to two of the water in fuel sensors on the engine mounted stage 1 filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected water in fuel for an extended period of time.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Drain the Stage 1 and/or duplex fuel filters.
  • Bulk fuel supply may be contaminated.

Water in the fuel can do extensive damage to the fuel system, due to the tight tolerances of the fuel system components.

If this fault code is active and there is no water in the fuel filter then a malfunctioning Water-In-Fuel sensor or water in the sensor connector could be causing the fault.

Refer to Troubleshooting Fault Code 4642 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 7 - Out of Calibration

FAULT CODE 4643

Injector Solenoid Driver Cylinder 7 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4643 PID: SPN: 657 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 7 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4643 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 8 - Out of Calibration

FAULT CODE 4644

Injector Solenoid Driver Cylinder 8 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4644 PID: SPN: 658 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 8 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4644 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 9 - Out of Calibration

FAULT CODE 4645

Injector Solenoid Driver Cylinder 9 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4645 PID: SPN: 659 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 9 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4645 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 10 - Out of Calibration

FAULT CODE 4646

Injector Solenoid Driver Cylinder 10 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4646 PID: SPN: 660 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 10 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4646 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 11 - Out of Calibration

FAULT CODE 4647

Injector Solenoid Driver Cylinder 11 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4647 PID: SPN: 661 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 11 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4647 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 12 - Out of Calibration

FAULT CODE 4648

Injector Solenoid Driver Cylinder 12 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4648 PID: SPN: 662 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 12 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4648 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 13 - Out of Calibration

FAULT CODE 4649

Injector Solenoid Driver Cylinder 13 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4649 PID: SPN: 663 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 13 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4649 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 14 - Out of Calibration

FAULT CODE 4651

Injector Solenoid Driver Cylinder 14 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4651 PID: SPN: 664 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 14 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4651 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 15 - Out of Calibration

FAULT CODE 4652

Injector Solenoid Driver Cylinder 15 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4652 PID: SPN: 665 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 15 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The ECM illuminates the amber CHECK ENGINE lamp immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the amber CHECK ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4652 .

Last Modified: 11-Dec-2020


Injector Solenoid Driver Cylinder 16 - Out of Calibration

FAULT CODE 4653

Injector Solenoid Driver Cylinder 16 - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4653 PID: SPN: 666 FMI: 13/13 LAMP: Amber SRT: | Invalid injector barcode information has been entered. | Possible reduced engine performance.
Engine Control Module (ECM)

Circuit Description

The ECM uses diagnostic software to check for invalid injector barcodes.

Component Location

The injector barcodes are located on the top of the injectors.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the injector barcode value for cylinder 16 has not been entered correctly into the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Each fuel injector has a specific barcode. The barcode data contains specific injector information. This barcode information needs to be entered into the ECM with the recommended Cummins® electronic service tool or equivalent. If an engine is found to have incorrect injector barcode values, the correct injector barcode values must be entered. The engine symptom of incorrect barcode values can include rough idle. The factory installed injector barcode values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector barcode values for that ESN are contained in the engine dataplate section. If the engine has had a previous repair involving the replacement of injectors, the valve cover must be removed to determine the injector barcodes values on the replacement injectors. Use the recommended Cummins® electronic service tool or equivalent to enter the barcode values into the ECM for this fault code to go inactive. A keyswitch cycle is required to save the barcode information in the ECM.

Refer to Troubleshooting Fault Code 4653 .

Last Modified: 11-Dec-2020


Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4688

Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4688 PID: SPN: 6301 FMI: 3/3 LAMP: Amber SRT: | High voltage detected at the water-in-fuel circuit. | None on performance.
ECM 3 Water-in-Fuel Sensor 2 Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The engine has two water in fuel sensors. If the engine is equipped with a duplex fuel filter head, the wiring harness is connected to one water in fuel sensor on the duplex filter head and one water in fuel sensor on the engine mounted stage 1 filter head. If the engine is not equipped with an duplex fuel filter head, the wiring harness is connected to two of the water in fuel sensors on the engine mounted stage 1 filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active or the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return or signal circuit in the engine wiring harness, connectors, or sensor.
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning water in fuel sensor.
Refer to Troubleshooting Fault Code 4688 .

Last Modified: 11-Dec-2020


Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4689

Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4689 PID: SPN: 6301 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected at the water-in-fuel circuit. | None on performance.
ECM 3 Water-in-Fuel Sensor 2 Circuit

Circuit Description

The water-in-fuel sensor is in the fuel filter. The engine control module (ECM) provides a 5 volt reference signal to the water-in-fuel sensor. When the water collected in the fuel filter covers the sensor probes, the water-in-fuel sensor pulls the 5-VDC reference voltage down, indicating high water accumulation in the fuel filter.

Component Location

The engine has two water in fuel sensors. If the engine is equipped with a duplex fuel filter head, the wiring harness is connected to one water in fuel sensor on the duplex filter head and one water in fuel sensor on the engine mounted stage 1 filter head. If the engine is not equipped with an duplex fuel filter head, the wiring harness is connected to two of the water in fuel sensors on the engine mounted stage 1 filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the water in fuel sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the engine wiring harness, sensor or connectors.
  • Malfunctioning water in fuel sensor.
Refer to Troubleshooting Fault Code 4689 .

Last Modified: 11-Dec-2020


Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 4696

Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4696 PID: SPN: 6302 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the crankcase pressure 2 circuit. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure 2 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

A default value for the crankcase pressure 2 reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the engine harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 4696 .

Last Modified: 11-Dec-2020


Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4697

Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4697 PID: SPN: 6302 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the crankcase pressure 2 circuit. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active or when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure 2 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

A default value for the crankcase pressure 2 reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 4697 .

Last Modified: 11-Dec-2020


Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4698

Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4698 PID: SPN: 6302 FMI: 0/15 LAMP: Maintenance SRT: | High crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure 2 sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
Refer to Troubleshooting Fault Code 4698 .

Last Modified: 11-Dec-2020


Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4699

Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4699 PID: SPN: 6302 FMI: 0/16 LAMP: Amber SRT: | High crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure in the breather tube was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure 2 sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
Refer to Troubleshooting Fault Code 4699 .

Last Modified: 11-Dec-2020


Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 4711

Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4711 PID: SPN: 6302 FMI: 1/17 LAMP: Maintenance SRT: | Low crankcase pressure detected. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pressure in the breather tube was less than expected.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or missing breather tube or hose.
  • Missing or damaged breather filter element
  • Restricted crankcase breather housing.
  • Malfunctioning crankcase pressure 2 sensor.
Refer to Troubleshooting Fault Code 4711 .

Last Modified: 11-Dec-2020


Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 488

Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 488 PID: P105 SPN: 105 FMI: 0/16 LAMP: Amber SRT: | Intake manifold air temperature signal indicates intake manifold air temperature is above engine protection warning limit. | Possible reduced engine performance.
Intake Manifold Pressure/Temperature Sensor Circuit

Circuit Description

The Engine Control Module (ECM) provides 5 volts to the intake manifold temperature signal circuit, and monitors the change in voltage caused by changes in the resistance of the sensor to determine the intake manifold temperature. When the intake air is cold, the sensor (or thermistor) resistance is high. The ECM signal voltage only pulls down a small amount through the sensor to a ground. Therefore, the ECM senses a high signal voltage or low temperature. When the intake air is warm, the sensor resistance is low. The signal voltage pulls down a large amount. Therefore, the ECM senses a low signal voltage, or a high temperature.

Component Location

The intake manifold 1 pressure/temperature sensor is located in the low temperature air transfer connection on the left bank of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the intake manifold temperature was greater than a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Restricted air flow through the radiator.
  • Malfunctioning high temperature aftercooler element.
  • Malfunctioning low temperature aftercooler element.
  • High turbocharger compressor outlet temperature.
Refer to Troubleshooting Fault Code 488 .

Last Modified: 11-Dec-2020


Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4883

Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4883 PID: SPN: 3551 FMI: 7/7 LAMP: Amber SRT: | The engine could not reach pre-lubricating pressure. | Engine may not start.
Fuel pump Lubricating Oil Supply Pressure Sensor Circuit
Engine Oil Pressure Sensor Circuit

Circuit Description

The fuel pump lubricating oil supply pressure switch or sensor is used by the engine control module (ECM) to determine when a successful pre-lubricating cycle has been achieved. The fuel pump lubricating oil supply pressure switch or sensor is normally closed when the engine and pre-lubricating pump are not running. The switch or sensor will open when pre-lubricating pressure is reached.

The engine can be configured to use either the fuel pump lubricating oil supply pressure switch/sensor, the engine oil pressure sensor, or both to make pre-lubricating cycle success determination. If both the switch and sensor are enabled in the engine calibration for pre-lubricating use, then both have to indicate pre-lubricating pressure is at the appropriate level before the cycle is considered successful.

Component Location

The fuel pump lubricating oil supply pressure sensor or switch is located in the fuel pump lubricating oil filter head mounted to the top of the fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

The engine oil pressure sensor is located on the outlet of the oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs when the pre-lubricating cycle is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pre-lubricating pressure was not reached before the pre-lubricating pump timer expired.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The engine can be configured to alllow or disable starting if the last pre-lubricating cycle failed.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 3 minute at no load.

To validate the repair, perform a keycycle and start the engine. If the maximum number of failed pre-lubricating attempts has been reached, use the recommended Cummins® electronic service tool or equivalent to override the pre-lubricating pump using the Pre-lubricating Control feature found in the special feature section.

  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged fuel pump lubricating oil supply pressure switch.
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure sensor.
  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged engine oil pressure sensor.
  • Malfunctioning or damaged pre-lubricating oil pump relay.
  • Malfunctioning or damaged pre-lubricating oil pump.
  • Internal or external oil leak.
Refer to Troubleshooting Fault Code 4883 .

Last Modified: 06-Aug-2021


Engine Oil Priming Pump Control - Special Instructions

FAULT CODE 4884

Engine Oil Priming Pump Control - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4884 PID: SPN: 3589 FMI: 14/14 LAMP: Amber SRT: | A stuck ON pre-lubricating pump has been detected. | None on performance.
Engine Oil Pressure Sensor Circuit
Fuel pump Lubricating Oil Supply Pressure Sensor Circuit

Circuit Description

The fuel pump lubricating oil supply pressure switch or sensor is used by the engine control module (ECM) to determine when a successful pre-lubricating cycle has been achieved. The fuel pump lubricating oil supply pressure switch or sensor is normally closed when the engine and pre-lubricating pump are not running. The switch or sensor will open when pre-lubricating pressure is reached.

The engine can be configured to use either the fuel pump lubricating oil supply pressure switch/sensor, the engine oil pressure sensor, or both to make pre-lubricating cycle success determination. If both the switch and sensor are enabled in the engine calibration for pre-lubricating use, then both have to indicate pre-lubricating pressure is at the appropriate level before the cycle is considered successful.

Component Location

The fuel pump lubricating oil supply pressure sensor or switch is located in the fuel pump lubricating oil filter head mounted to the top of the fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

The engine oil pressure sensor is located on the lubricating oil filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected pre-lube pressure when the engine was not running and the pre-lube pump relay was commanded OFF.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged fuel pump lubricating oil supply pressure sensor.
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure switch.
  • Malfunctioning pre-lubricating pump relay.
Refer to Troubleshooting Fault Code 4884 .

Last Modified: 01-Jul-2021


Engine Fuel Supply Pump - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 4885

Engine Fuel Supply Pump - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4885 PID: SPN: 6323 FMI: 7/7 LAMP: Red SRT: | The engine fuel supply pump has seized. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected motor current continuously above 70 amps while fuel delivery pressure zero.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Engine fuel supply pump motor locked.

Refer to Troubleshooting Fault Code 4885 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 4886

Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4886 PID: SPN: 6323 FMI: 1/18 LAMP: Amber SRT: | Low voltage detected at the engine fuel supply pump motor circuit. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected low supply voltage to the pump motor.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Low supply voltage or high resistance on the engine fuel supply pump motor circuit.

Refer to Troubleshooting Fault Code 4886 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 4887

Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4887 PID: SPN: 6323 FMI: 1/1 LAMP: Red SRT: | Critically low or no voltage detected at the engine fuel supply pump motor circuit. | The engine will shut down or will not start.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected very low or no supply voltage at the pump motor.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Low supply voltage or high resistance on the engine fuel supply pump motor circuit.

Short circuit to ground or tripped circuit breaker/blown fuse on the engine fuel supply pump motor circuit.

Refer to Troubleshooting Fault Code 4887 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4888

Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4888 PID: SPN: 6698 FMI: 0/16 LAMP: Amber SRT: | High internal temperature detected in the engine fuel supply pump. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected internal temperature will pass the critical limit within 60 seconds.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction excessive.
  • Abnormally hot supply fuel.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 4888 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 4889

Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4889 PID: SPN: 6698 FMI: 0/0 LAMP: Amber SRT: | High internal temperature detected in the engine fuel supply pump. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump has detected internal temperature above the critical limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Stage 2 fuel filter restriction excessive.
  • Abnormally hot supply fuel.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 4889 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump - Root Cause Not Known

FAULT CODE 4891

Engine Fuel Supply Pump - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4891 PID: SPN: 6323 FMI: 11/11 LAMP: Amber SRT: | The engine fuel supply pump did not receive the initialization message from the ECM. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump did not receive the initialization message from the ECM in a calibrated amount of time.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Intermittent power supply to the engine fuel supply pump.
Refer to Troubleshooting Fault Code 4891 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump - Abnormal Update Rate

FAULT CODE 4892

Engine Fuel Supply Pump - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4892 PID: SPN: 6323 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate has been detected on the J1939 data link between the ECM and the engine fuel supply pump. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) lost communication with the engine fuel supply pump.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • The engine fuel supply pump is not receiving power from the ECM.
  • Malfunctioning SAE J1939 data link 3 circuit.
  • Malfunctioning engine fuel supply pump.
Refer to Troubleshooting Fault Code 4892 .

Last Modified: 11-Dec-2020


Engine Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 4893

Engine Fuel Filter (suction side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4893 PID: SPN: 1382 FMI: 0/16 LAMP: Amber SRT: | The engine fuel supply pump has detected high fuel intake restriction. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel supply pump intake pressure sensor is located on the inlet of the engine fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected that fuel intake restriction was above the calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Stage 1 fuel filter restriction excessive.
  • High fuel inlet restriction
  • Malfunctioning fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 4893 .

Last Modified: 11-Dec-2020


Engine Fuel Supply Pump - Out of Calibration

FAULT CODE 4894

Engine Fuel Supply Pump - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4894 PID: SPN: 6233 FMI: 13/13 LAMP: Amber SRT: | The engine fuel supply pump firmware version does not match the expected value. | Possible reduced engine performance.
Engine Fuel Supply Pump Circuit

Circuit Description

The engine fuel supply pump is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The engine fuel supply pump maintains appropriate supply fuel pressure, performs internal and system diagnostics and reports malfunctions back to the ECM. The ECM supplies 24-VDC to the supply pump control unit. The OEM provides supply voltage to the engine fuel supply pump motor. The fuel delivery pressure signal is wired in parallel between the ECM and engine fuel supply pump.

Component Location

The engine fuel supply pump is located on the left side of the engine.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the engine fuel supply pump firmware version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect firmware version installed in the engine fuel supply pump.
  • Fuel pump replacement may cause this fault code to log.
Refer to Troubleshooting Fault Code 4894 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component

FAULT CODE 4927

Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4927 PID: SPN: 7026 FMI: 12/12 LAMP: Amber SRT: | An internal error has been detected in the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has reported an internal error.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4927 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4928

Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4928 PID: SPN: 7027 FMI: 2/2 LAMP: Amber SRT: | Low voltage detected at the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has detected low supply voltage.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High resistance on the supply circuit.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4928 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source

FAULT CODE 4929

Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4929 PID: SPN: 7027 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the engine fuel supply pump/fuel metering valve supply circuit. | Possible reduced engine performance.
Engine Fuel Supply Pump/Fuel Metering Valve Supply Circuit

Circuit Description

The engine control module (ECM) supplies 24-VDC to the engine fuel supply pump and fuel metering valve.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected an open or short circuit to voltage source on the engine fuel supply pump/fuel metering valve supply circuit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • An open or short circuit to battery in the engine harness.
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 4929 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4931

Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4931 PID: SPN: 7027 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the engine fuel supply pump/fuel metering valve supply circuit. | Possible reduced engine performance.
Engine Fuel Supply Pump and Fuel Metering Valve Supply Circuit

Circuit Description

The engine control module (ECM) supplies 24-VDC to the engine fuel supply pump and fuel metering valve.

Component Location

The engine fuel supply pump is located on the left side of the engine.

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected low voltage on the engine fuel supply pump/fuel metering valve supply circuit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A short circuit to ground in the engine wiring harness.
  • A malfunctioning fuel metering valve.
  • Malfunctioning engine fuel supply pump.
  • Malfunctioning or damaged ECM.
Refer to Troubleshooting Fault Code 4931 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 4932

Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4932 PID: SPN: 7028 FMI: 0/15 LAMP: None SRT: | High temperature detected in the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has detected high internal temperature.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Abnormally hot supply fuel.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4932 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Position - Received Network Data in Error

FAULT CODE 4933

Engine Diesel Fuel Metering Valve Position - Received Network Data in Error

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4933 PID: SPN: 7029 FMI: 2/19 LAMP: None SRT: | A sticking fuel metering valve has been detected. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has detected the valve position does not match the commanded position.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4933 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source

FAULT CODE 4934

Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4934 PID: SPN: 7026 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the control signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected high voltage on the control signal circuit while the PWM signal was OFF.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Control signal wire shorted to voltage source or open.
  • Control return wire shorted to voltage source or open.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4934 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source

FAULT CODE 4935

Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4935 PID: SPN: 7026 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the control signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected low voltage on the control signal circuit while the PWM signal was ON.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Control signal wire shorted to ground.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4935 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Root Cause Not Known

FAULT CODE 4936

Engine Diesel Fuel Metering Valve - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4936 PID: SPN: 7026 FMI: 11/11 LAMP: Amber SRT: | The fuel metering valve firmware version does not match the expected value. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the fuel metering valve firmware version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect firmware version installed in the fuel metering valve.
Refer to Troubleshooting Fault Code 4936 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Out of Calibration

FAULT CODE 4937

Engine Diesel Fuel Metering Valve - Out of Calibration

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4937 PID: SPN: 7026 FMI: 13/13 LAMP: Amber SRT: | The fuel metering valve calibration version does not match the expected value. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the fuel metering valve calibration version does not match the expected value in the ECM calibration.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect calibration installed in the fuel metering valve.
Refer to Troubleshooting Fault Code 4937 .

Last Modified: 11-Dec-2020


Engine Crank Without Prelube - Condition Exists

FAULT CODE 4946

Engine Crank Without Prelube - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4946 PID: SPN: 4209 FMI: 11/31 LAMP: None SRT: | The emergency start switch was used to bypass the pre-lubricating cycle. | None on performance.
Engine Control Module (ECM)

Circuit Description

The emergency start override switch is used to allow the operator to bypass the pre-lubricating cycle and start the engine immediately in an emergency.

Component Location

The emergency start override switch is mounted by the equipment manufacturer. See equipment manufacturer service infromation.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the emergency start switch was used to bypass the pre-lubricating cycle and start the engine.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code is for information only. It is intended to track engine starts where the pre-lubricating cycle was bypassed.

Refer to Troubleshooting Fault Code 4946 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent, or Incorrect

FAULT CODE 4958

Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4958 PID: SPN: 7026 FMI: 2/2 LAMP: Amber SRT: | A malfunctioning control signal circuit has been detected. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has detected an out of range PWM control signal from the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Control signal wire shorted to voltage source or open.
  • Control signal wire shorted to ground.

Open control return wire.

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4958 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Condition Exists

FAULT CODE 4959

Engine Diesel Fuel Metering Valve - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4959 PID: SPN: 7026 FMI: 11/31 LAMP: None SRT: | A mismatch between the two control signals has been detected. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has detected a mismatch between the two control signals sent by the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Tampering with the control signal circuit.

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4959 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve - Abnormal Update Rate

FAULT CODE 4961

Engine Diesel Fuel Metering Valve - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 4961 PID: SPN: 7026 FMI: 9/9 LAMP: None SRT: | No communications or an invalid data transfer rate detected on the J1939 data link between the ECM and the fuel metering valve. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) lost communication with the fuel metering valve.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

The fuel metering valve will switch to the PWM control signal from the ECM as a backup for commanded positon.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

The fuel metering valve is not receiving power from the ECM.

  • Malfunctioning SAE J1939 data link 3 circuit.
  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 4961 .

Last Modified: 11-Dec-2020


Fuel Pump Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5119

Fuel Pump Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5119 PID: SPN: 520754 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at fuel pump lubricating oil pressure sensor circuit. | None on performance.
Fuel pump Lubricating Oil Supply Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the fuel pump lubricating oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel pump lubricating oil pressure sensor provides a signal to the ECM on the fuel pump lubricating oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil pressure is high.

Component Location

The fuel pump lubricating oil supply pressure sensor or switch is located in the fuel pump lubricating oil filter head mounted to the top of the fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pump lubricating oil pressure signal voltage is out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the fuel pump lubricating oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure switch.
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure sensor.
Refer to Troubleshooting Fault Code 5119 .

Last Modified: 23-Jun-2021


Fuel Pump Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5121

Fuel Pump Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5121 PID: SPN: 520754 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage or open circuit detected at the fuel pump lubricating oil supply pressure circuit. | None on performance.
Fuel pump Lubricating Oil Supply Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the fuel pump lubricating oil pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel pump lubricating oil pressure sensor provides a signal to the ECM on the fuel pump lubricating oil pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil pressure is high.

Component Location

The fuel pump lubricating oil pressure sensor is located in the fuel pump lubricating oil filter head mounted to the top of the fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pump lubricating oil pressure signal voltage is out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the fuel pump lubricating oil pressure reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning or damaged engine wiring harness.
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure sensor.
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure switch.
Refer to Troubleshooting Fault Code 5121 .

Last Modified: 23-Jun-2021


Allow Start Override Active - Condition Exists

FAULT CODE 5148

Allow Start Override Active - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5148 PID: SPN: 520766 FMI: 11/31 LAMP: Amber SRT: | The emergency start switch was used to bypass the pre-lubricating cycle. | None on performance.
Generator Set Controller.

Circuit Description

The emergency start override switch is used to allow the operator to bypass the pre-lubricating cycle and start the engine immediately in an emergency.

Component Location

The emergency start override switch is located in the generator set controller.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the emergency start override switch was ON for an extended period of time after an emergency start.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

If fault code 4946 becomes active after an engine start then the emergency start switch input is active. If the switch input is active for an extended period of time, fault code 5148 will be logged. Check for an OEM emergency start switch that has been left ON or stuck in the ON position.

Refer to Troubleshooting Fault Code 5148 .

Last Modified: 11-Dec-2020


Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 515

Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 515 PID: S232 SPN: 3514 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High voltage on the (+) 5 volt supply line can be caused by a short to battery voltage in the engine harness or connectors, or a malfunctioning ECM.
Refer to Troubleshooting Fault Code 515 .

Last Modified: 11-Dec-2020


Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 516

Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 516 PID: S232 SPN: 3514 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the +5 volt sensor supply circuit to the fuel rail pressure sensor. | Possible reduced engine performance.
Sensor Supply 6 Circuit

Circuit Description

The sensor supply 6 circuit of the engine control module (ECM) is a dedicated (+) 5-VDC supply for the fuel rail pressure sensor.

Component Location

Sensor Supply 6 originates in the Engine Connector portion of the ECM. It supplies 5 volts to sensors in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the sensor supply 6 signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Low voltage on the 5 volt supply line can be caused by a short circuit to ground in the supply line, a short circuit between the supply line and a return line, a failed sensor, or a damaged ECM power supply.
Refer to Troubleshooting Fault Code 516 .

Last Modified: 11-Dec-2020


Crankcase Pressure 2 - Data Erratic, Intermittent, or Incorrect

FAULT CODE 5178

Crankcase Pressure 2 - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5178 PID: SPN: 6302 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected that the crankcase pressure signal is reading an erratic value at initial key ON or during engine operation. | None on performance.
Crankcase Pressure 2 Sensor Circuit

Circuit Description

The crankcase pressure 2 sensor is used to determine the condition of the breather filter element. The engine control module (ECM) supplies the crankcase pressure 2 sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the breather tube prior to the breather filter element.

Component Location

The crankcase pressure 2 sensor is located in the breather tube before the breather filter element.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the crankcase pressure 2 sensor reading did not match other pressure sensor readings at key ON.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Malfunctioning crankcase pressure 2 sensor.
  • High resistance in the engine wiring harness.
Refer to Troubleshooting Fault Code 5178 .

Last Modified: 11-Dec-2020


Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 546

Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 546 PID: P94 SPN: 94 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel delivery pressure sensor circuit. | Possible reduced engine performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the fuel delivery pressure reading is used.
  • If only the ECM loses the fuel delivery pressure signal then the engine fuel supply pump will continue to operate normally.
  • If only the engine fuel supply pump loses the fuel delivery pressure signal then the ECM will command the supply pump via the J1939 data link.
  • If the ECM and the engine fuel supply pump both lose the delivery pressure signal then the ECM will command the supply pump via the J1939 data link. This command is based on engine operating conditions and fuel demand.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If the engine fuel supply pump loses fuel delivery pressure signal, fluctuations in delivery pressure could affect rail pressure.

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal circuit shorted to sensor supply or battery voltage.
Refer to Troubleshooting Fault Code 546 .

Last Modified: 11-Dec-2020


Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 547

Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 547 PID: P94 SPN: 94 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel delivery pressure sensor circuit. | None on performance.
Fuel Delivery Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5 volt supply to the fuel delivery pressure sensor using a sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel delivery pressure sensor provides a fuel delivery pressure signal to the ECM on the fuel delivery pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the low pressure fuel delivery system. The ECM will detect a high signal voltage at high delivery pressure conditions. The ECM will detect a low signal voltage during low delivery pressure conditions.

Component Location

The fuel delivery pressure sensor is located on the outlet of the stage 2 fuel filter head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel delivery pressure signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the fuel delivery pressure reading is used.
  • If only the ECM loses the fuel delivery pressure signal then the engine fuel supply pump will continue to operate normally.
  • If only the engine fuel supply pump loses the fuel delivery pressure signal then the ECM will command the supply pump via the J1939 data link.
  • If the ECM and the engine fuel supply pump both lose the delivery pressure signal then the ECM will command the supply pump via the J1939 data link. This command is based on engine operating conditions and fuel demand.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

If the engine fuel supply pump loses fuel delivery pressure signal, fluctuations in delivery pressure could affect rail pressure.

Possible causes of this fault code include:

  • Signal circuit open or shorted to ground in the engine wiring harness or sensor.
  • Supply wire open or shorted to ground.
Refer to Troubleshooting Fault Code 547 .

Last Modified: 11-Dec-2020


Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 553

Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 553 PID: P157 SPN: 157 FMI: 0/16 LAMP: Amber SRT: | The engine control module (ECM) has detected that fuel pressure is higher than the commanded pressure. | Possible reduced engine performance.
Fuel Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was above the commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel rail pressure sensor
  • A malfunctioning fuel metering valve.
  • Fuel leaking past the fuel metering valve.
  • High fuel drain line restriction
Refer to Troubleshooting Fault Code 553 .

Last Modified: 11-Dec-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 555

Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 555 PID: P101 SPN: 101 FMI: 0/16 LAMP: Amber SRT: | High crankcase pressure detected. | None on performance.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
  • Seized crankcase breather variable impactor assembly.
  • Internal engine damage.
Refer to Troubleshooting Fault Code 555 .

Last Modified: 11-Dec-2020


Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 556

Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 556 PID: P101 SPN: 101 FMI: 0/0 LAMP: Red SRT: | High crankcase pressure detected. | Generator will be disconnected from the grid and the engine will idle only. The generator controller will shut down the engine.
Crankcase Pressure Sensor Circuit

Circuit Description

The crankcase pressure sensor is used to monitor the pressure inside the crankcase. The engine control module (ECM) supplies the crankcase pressure sensor a 5 volt reference voltage. When the crankcase pressure is low, the sensor signal voltage is low. When the crankcase pressure is high, the sensor signal voltage is near the 5 volt reference voltage. The ECM monitors the crankcase pressure signal circuit voltage to calculate the pressure of the air within the crankcase.

Component Location

The crankcase pressure sensor is located in the oil fill hand hole cover on the left bank.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankcase pressure was greater than a calibrated value.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Internal engine damage.
  • Crankcase breather filter needs to be replaced
  • Malfunctioning crankcase pressure sensor.
  • Frozen, plugged, or restricted crankcase breather tube.
  • Seized crankcase breather variable impactor assembly.
Refer to Troubleshooting Fault Code 556 .

Last Modified: 11-Dec-2020


Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 559

Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 559 PID: P157 SPN: 157 FMI: 1/18 LAMP: Amber SRT: | The ECM has detected that fuel pressure is lower than commanded pressure. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Injector Metering Rail Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) monitors engine operating conditions, including the reading of fuel rail pressure, and changes the flow command to either increase (OPEN the fuel metering valve) or decrease (CLOSE the fuel metering valve) the fuel supply to the high-pressure pump.

Component Location

The high-pressure fuel pump is mounted to the gear housing. The fuel metering valve, fuel rail pressure sensor, and fuel pressure relief valve are mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the measured fuel rail pressure was below commanded fuel rail pressure by a calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • High fuel inlet restriction
  • Air in the fuel
  • Leaking fuel rail pressure relief valve
  • Malfunctioning high-pressure fuel pump
  • Leaking fuel injectors and or fuel injector connectors
  • Malfunctioning fuel delivery pressure sensor.
  • A malfunctioning fuel rail pressure sensor
Refer to Troubleshooting Fault Code 559 .

Last Modified: 11-Dec-2020


Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 581

Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 581 PID: P15 SPN: 1381 FMI: 3/3 LAMP: Amber SRT: | High signal voltage detected at the fuel supply pump intake pressure sensor circuit. | None on performance.
Engine Fuel Supply Pump Intake Pressure Sensor Circuit.

Circuit Description

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The engine fuel supply pump intake pressure sensor is located on the inlet of the fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected the fuel supply pump intake pressure signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open return circuit in the harness, connectors, or sensor
  • Signal wire shorted to sensor supply or battery voltage.
  • Malfunctioning engine fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 581 .

Last Modified: 11-Dec-2020


Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 582

Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 582 PID: P15 SPN: 1381 FMI: 4/4 LAMP: Amber SRT: | Low signal voltage detected at the fuel supply pump intake pressure sensor circuit. | None on performance.
Engine Fuel Supply Pump Intake Pressure Sensor Circuit.

Circuit Description

The engine fuel supply pump provides a 5 volt supply to the fuel supply pump intake pressure sensor using a dedicated sensor supply circuit. The supply pump also provides a ground on the sensor return circuit. The fuel supply pump intake pressure sensor provides a pressure signal to the pump on the fuel supply pump intake pressure sensor signal circuit. This sensor signal voltage changes based on the pressure at the intake of the engine fuel supply pump.

Component Location

The engine fuel supply pump intake pressure sensor is located on the inlet of the fuel supply pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The engine fuel supply pump detected the fuel supply pump intake pressure sensor signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal circuit shorted to ground in the engine wiring harness, sensor, or connector.
  • Supply wire open or shorted to ground.
  • Malfunctioning engine fuel supply pump intake pressure sensor.
Refer to Troubleshooting Fault Code 582 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

FAULT CODE 5862

Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5862 PID: SPN: 7029 FMI: 3/3 LAMP: Amber SRT: | High voltage detected on the position signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the position signal voltage was out of range high.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Position signal circuit shorted to voltage source.

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 5862 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

FAULT CODE 5863

Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5863 PID: SPN: 7029 FMI: 4/4 LAMP: Amber SRT: | Low voltage detected on the position signal circuit. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is mounted on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The engine control module (ECM) detected the position signal voltage was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Position signal circuit open or shorted to ground.

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 5863 .

Last Modified: 11-Dec-2020


Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 5875

Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5875 PID: SPN: 1484 FMI: 0/0 LAMP: Red SRT: | At least one secondary engine control module (ECM) has an active red lamp fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active red lamp fault code.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 5875 .

Last Modified: 11-Dec-2020


Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 5876

Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5876 PID: SPN: 1484 FMI: 0/16 LAMP: Amber SRT: | At least one secondary engine control module (ECM) has an active amber lamp fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active amber lamp fault code.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • This fault code will go inactive once all red lamp fault codes in secondary ECMs are inactive.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The ECM will turn off the red STOP ENGINE lamp immediately after the diagnostic runs and passes.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 5876 .

Last Modified: 11-Dec-2020


Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 5877

Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5877 PID: SPN: 1484 FMI: 0/15 LAMP: Maintenance SRT: | At least one secondary engine control module (ECM) has an active maintenance severity fault code. | None on performance.
Engine Control Module (ECM)

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The primary engine control module (ECM) detected at least one secondary ECM has an active maintenance severity fault code.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, operate the engine under load for at least 5 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This is an information only fault code that will only become active if other fault codes are active in the secondary ECM(s).

Refer to Troubleshooting Fault Code 5877 .

Last Modified: 11-Dec-2020


SAE J1939 Data Link 2 Engine Network - Special Instructions

FAULT CODE 5949

SAE J1939 Data Link 2 Engine Network - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 5949 PID: SPN: 1231 FMI: 14/14 LAMP: Red SRT: | The ECM has diagnosed that it cannot communicate with the other ECMs for a prolonged period of time. | Engine will shut down.
J1939 Data Link 2 Circuit

Circuit Description

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The SAE J1939 data link 2 is located in the engine wiring harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The ECM has diagnosed that it cannot communicate with the other ECMs for a prolonged period of time.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Electrical problems with the SAE J1939 data link wiring such as grounded, shorted, or open circuits

Refer to Troubleshooting Fault Code 5949 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 621

Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 621 PID: SPN: 1323 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 621 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 622

Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 622 PID: SPN: 1325 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 622 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 623

Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 623 PID: SPN: 1327 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 623 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 624

Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 624 PID: SPN: 1329 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 624 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 625

Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 625 PID: SPN: 1331 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 625 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc6253
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc6253sa00
Is the ECM source address 01? | Go to 316-fc6253sa01
Is the ECM source address 144? | Go to 316-fc6253sa144
Is the ECM source address 186? | Go to 316-fc6253sa186

Last Modified: 03-Apr-2020


Control Module Identification Input State Error - Special Instructions

FAULT CODE 6253

Control Module Identification Input State Error - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6253 PID: SPN: 1563 FMI: 14/14 LAMP: Red SRT: | The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 6253 .

Last Modified: 11-Dec-2020


Control Module Identification Input State Error - Special Instructions

FAULT CODE 6253

Control Module Identification Input State Error - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6253 PID: SPN: 1563 FMI: 14/14 LAMP: Red SRT: | The control module identification input state is incorrect. | Engine may run rough, may stop running, may not start, or may be difficult to start.
Control Module Identification Circuit

Circuit Description

The engine control module (ECM) uses the control module identification circuit to verify its location in the harness. The combination of control module identification signal pins that are connected to return allow the ECM to make this determination.

Component Location

The control module identification circuit is located in the harness.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The ECM calibration does not match the control module identification input.

Action Taken When the Fault Code is Active

The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Injector fueling will be disabled for the affected ECMs.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, and leave the key in the ON position for 1 minute.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Duplicate or incorrect ECM calibrations downloaded to the ECM(s).
  • Two or more ECMs installed in the wrong location.
Refer to Troubleshooting Fault Code 6253 .

Last Modified: 05-Mar-2020


Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 626

Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 626 PID: SPN: 1333 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 626 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 627

Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 627 PID: SPN: 1335 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 627 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 628

Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 628 PID: SPN: 1337 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 628 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 631

Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 631 PID: SPN: 1324 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 631 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 632

Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 632 PID: SPN: 1326 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 632 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 633

Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 633 PID: SPN: 1328 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 633 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 634

Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 634 PID: SPN: 1330 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 634 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 635

Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 635 PID: SPN: 1332 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 635 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 636

Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 636 PID: SPN: 1334 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 636 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 637

Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 637 PID: SPN: 1336 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 637 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 638

Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 638 PID: SPN: 1338 FMI: 1/17 LAMP: Maintenance SRT: | Exhaust gas temperature is lower than the engine average. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

This fault code sets when the following conditions are met:

  • Engine oil temperature greater than 60°C [140°F].
  • Net engine torque is above a calibrated threshold.
  • The exhaust gas temperature sensor reading is less than the engine average by a calibrated amount.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 638 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 641

Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 641 PID: S129 SPN: 1137 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 641 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 642

Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 642 PID: S131 SPN: 1139 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 642 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 643

Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 643 PID: S133 SPN: 1141 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 643 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 644

Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 644 PID: S135 SPN: 1143 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 644 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 645

Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 645 PID: S137 SPN: 1145 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 645 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 646

Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 646 PID: S139 SPN: 1147 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 646 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 647

Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 647 PID: S141 SPN: 1149 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 647 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 648

Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 648 PID: S143 SPN: 1151 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 648 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 652

Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 652 PID: S130 SPN: 1138 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 652 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 653

Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 653 PID: S132 SPN: 1140 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 653 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 654

Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 654 PID: S134 SPN: 1142 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 654 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 655

Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 655 PID: S136 SPN: 1144 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 655 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 656

Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 656 PID: S138 SPN: 1146 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 656 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 657

Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 657 PID: S140 SPN: 1148 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 657 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 6573

Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6573 PID: SPN: 7028 FMI: 0/16 LAMP: None SRT: | The Engine Control Module (ECM) has been alerted that the Fuel Metering Valve is above a calibrated temperature threshold. | Possible reduced engine performance.
Fuel Metering Valve

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is located on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has diagnosed that the internal temperature is above a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 6573 .

Last Modified: 11-Dec-2020


Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 6574

Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6574 PID: SPN: 7028 FMI: 0/0 LAMP: Amber SRT: | The Engine Control Module (ECM) has been alerted that the Fuel Metering Valve is above a calibrated temperature threshold. | Possible reduced engine performance.
Fuel Metering Valve Circuit

Circuit Description

The fuel metering valve is a smart device and communicates with the engine control module (ECM) via the J1939 data link. The ECM supplies 24-VDC to the fuel metering valve. The fuel metering valve controls fuel flow into the high pressure fuel pump by changing valve position based on ECM command. The primary position command is sent by the ECM over the J1939 data link. A PWM signal is used as the backup position command. The fuel metering valve performs internal diagnostics and reports malfunctions back to the ECM.

Component Location

The fuel metering valve is located on the high pressure fuel pump.

Conditions for Running the Diagnostics

This diagnostic runs continuously while the generator set controller is active.

Conditions for Setting the Fault Codes

The fuel metering valve has diagnosed that the internal temperature is above a calibrated threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning fuel metering valve.
Refer to Troubleshooting Fault Code 6574 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 658

Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 658 PID: S142 SPN: 1150 FMI: 0/0 LAMP: Red SRT: | The exhaust gas temperature sensor has detected temperature above the critical level. | Possible reduced engine performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor reading was greater than the calibrated limit.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The generator set controller will turn off the shutdown indicator immediately after the user presses the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A malfunctioning turbocharger
  • Air intake system restriction
  • Intake or exhaust manifold leaks
  • High intake air temperature
  • Malfunctioning fuel injector
  • Intake or exhaust valves out of adjustment
  • Malfunctioning exhaust gas temperature sensor.
Refer to Troubleshooting Fault Code 658 .

Last Modified: 11-Dec-2020


Engine Speed - Root Cause Not Known

FAULT CODE 6595

Engine Speed - Root Cause Not Known

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 6595 PID: SPN: 190 FMI: 11/11 LAMP: None SRT: | At least one of the engine control modules has lost the camshaft and crankshaft position sensor signals. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit
Camshaft Position Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The camshaft position sensor is located in the gear cover.

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

At least one engine control module (ECM) has lost both the camshaft and crankshaft position sensor signals while another ECM is still detecting both signals.

Action Taken When the Fault Code is Active

  • The generator set controller displays the fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Open in both engine position sensor circuits to one ECM.
Refer to Troubleshooting Fault Code 6595 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 671

Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 671 PID: S129 SPN: 1137 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 671 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 672

Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 672 PID: S131 SPN: 1139 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 672 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 673

Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 673 PID: S133 SPN: 1141 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 673 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 674

Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 674 PID: S135 SPN: 1143 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 674 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 675

Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 675 PID: S137 SPN: 1145 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 675 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 676

Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 676 PID: S139 SPN: 1147 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 676 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 677

Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 677 PID: S141 SPN: 1149 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 677 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 678

Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 678 PID: S143 SPN: 1151 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 678 .

Last Modified: 11-Dec-2020


Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

FAULT CODE 689

Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 689 PID: P190 SPN: 190 FMI: 2/2 LAMP: Amber SRT: | The ECM has detected an error in the engine speed signal. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-VDC supply to the crankshaft position sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. As holes drilled in the flywheel move past the position sensor, a signal is generated on the signal circuit. The ECM uses this signal to determine engine speed and position. Offset spacing of the drillings indicate to the ECM the engine position.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a loss of the crankshaft speed/position sensor while the engine was running.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • The camshaft position sensor will be used by the ECM to determine engine speed and position.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Causes of this fault include:

  • Open or short circuit of the +5-VDC supply, signal, or return wire in the engine harness
  • Crankshaft position sensor malfunction
  • Sensor air gap that is marginally too small or too large.
Refer to Troubleshooting Fault Code 689 .

Last Modified: 11-Dec-2020


Fault Code Path Selection

FAULT CODE 316-fc699
Fault Code Path Selection

Is the ECM source address 00? | Go to 316-fc699sa00
Is the ECM source address 01? | Go to 316-fc699sa01
Is the ECM source address 144? | Go to 316-fc699sa144
Is the ECM source address 186? | Go to 316-fc699sa186

Last Modified: 03-Apr-2020


Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

FAULT CODE 699

Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 699 PID: P21 SPN: 1136 FMI: 2/2 LAMP: Amber SRT: | An incorrect or inconsistent temperature reading has been detected internal to the ECM. | None on performance.
Engine Control Module

Circuit Description

The engine control module (ECM) has an internal temperature sensor that is used to measure the temperature inside the ECM.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the internal temperature sensor circuit was irrational.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This sensor is located internally to the ECM. No troubleshooting is possible for this fault code. If the fault code is active, the ECM must be replaced.

Refer to Troubleshooting Fault Code 699 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 721

Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 721 PID: S130 SPN: 1138 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 721 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 722

Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 722 PID: S132 SPN: 1140 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 722 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 723

Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 723 PID: S134 SPN: 1142 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 723 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 724

Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 724 PID: S136 SPN: 1144 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 724 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 725

Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 725 PID: S138 SPN: 1146 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 725 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 726

Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 726 PID: S140 SPN: 1148 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 726 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 727

Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 727 PID: S142 SPN: 1150 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 727 .

Last Modified: 11-Dec-2020


Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

FAULT CODE 728

Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 728 PID: S144 SPN: 1152 FMI: 4/4 LAMP: Maintenance SRT: | Low signal voltage detected at the exhaust gas temperature sensor circuit. | None on performance.
Exhaust Gas Temperature Sensor Circuit

Circuit Description

The exhaust gas temperature sensor(s) is a variable resistance sensor. The engine control module (ECM) supplies 5 volts to the exhaust gas temperature signal circuit. The ECM monitors the change in voltage caused by changes in the resistance of the sensor to determine the exhaust gas temperature.

Component Location

The exhaust gas temperature sensor is located in the cylinder head.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the exhaust gas temperature sensor circuit was out of range low.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.
  • A default value for the exhaust gas temperature reading is used.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Signal shorted to ground in the engine wiring harness.
  • Signal shorted to return or ground in the sensor.
Refer to Troubleshooting Fault Code 728 .

Last Modified: 11-Dec-2020


Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

FAULT CODE 731

Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 731 PID: S64 SPN: 723 FMI: 7/7 LAMP: Amber SRT: | Engine position signal from the crankshaft position sensor and camshaft position sensor do not match. | Possible reduced engine performance.
Crankshaft Position Sensor Circuit
Camshaft Postiion Sensor Circuit

Circuit Description

The crankshaft position and camshaft position sensors are Hall effect type sensors. The engine control module (ECM) provides a 5 volt supply and a return circuit to the position sensors. As holes drilled in the flywheel or slots in the front of the camshaft gear move past the position sensor, a signal is generated on the position sensor signal circuit. The ECM uses this signal to determine engine speed. Offset spacing of the drillings or slots indicate to the ECM the position of the engine.

Component Location

The crankshaft position sensor is located on the left bank side of the engine in the flywheel housing.

The camshaft position sensor is located in the gear cover.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the crankshaft position does not match the camshaft position signal input to the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

Base engine timing is incorrect.

Refer to Troubleshooting Fault Code 731 .

Last Modified: 11-Dec-2020


Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

FAULT CODE 7313

Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7313 PID: SPN: 520754 FMI: 1/1 LAMP: Red SRT: | Fuel pump lubricating oil supply pressure signal indicates oil pressure is below the engine protection warning limit. | Progressive power derate increasing in severity from time of alert.
Fuel pump Lubricating Oil Supply Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the fuel pump lubricating oil supply pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel pump lubricating oil pressure sensor provides a signal to the ECM on the fuel pump lubricating oil supply pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil pressure is high.

Component Location

The fuel pump lubricating oil supply pressure sensor or switch is located in the fuel pump lubricating oil filter head mounted to the top of the fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pump lubricating oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The torque output of the engine will be reduced.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Malfunctioning or damaged fuel pump lubricating oil supply pressure sensor.
  • Plugged or restricted lubricating oil filter.
  • Plugged or restricted lubricating oil flow path.
Refer to Troubleshooting Fault Code 7313 .

Last Modified: 19-Jul-2021


Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 7314

Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7314 PID: SPN: 520754 FMI: 1/18 LAMP: Amber SRT: | Fuel pump lubricating oil supply pressure signal indicates oil pressure is below the engine protection warning limit. | None on performance.
Fuel pump Lubricating Oil Supply Pressure Sensor Circuit

Circuit Description

The engine control module (ECM) provides a 5-volt supply to the fuel pump lubricating oil supply pressure sensor on the sensor supply circuit. The ECM also provides a ground on the sensor return circuit. The fuel pump lubricating oil pressure sensor provides a signal to the ECM on the fuel pump lubricating oil supply pressure sensor signal circuit. This sensor signal voltage changes based on the pressure in the oil flow path. The ECM will detect a low signal voltage at operating conditions when the oil pressure may be slightly lower. The ECM will detect a high signal voltage during high engine speeds or operating conditions when the oil pressure is high.

Component Location

The fuel pump lubricating oil supply pressure sensor or switch is located in the fuel pump lubricating oil filter head mounted to the top of the fuel pump adapter drive. Certain engines may have the filter head mounted remotely.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the fuel pump lubricating oil pressure was below minimum operating limits.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, bring the engine up to operating temperature and run it in normal loaded conditions for 15 minutes.
  • The fault code status displayed by the recommended Cummins® electronic service tool or equivalent will change to INACTIVE immediately after the diagnostic runs and passes.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Low oil pressure
  • Incorrect oil level
  • Malfunctioning or damaged engine oil pressure sensor.
  • Plugged or restricted lubricating oil filter.
  • Plugged or restricted lubricating oil flow path.
Refer to Troubleshooting Fault Code 7314 .

Last Modified: 19-Jul-2021


Engine Friction Baseline - Data Valid But Below Normal Operating Range - Least Severe Level

FAULT CODE 7548

Engine Friction Baseline - Data Valid But Below Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7548 PID: SPN: 521144 FMI: 1/17 LAMP: None SRT: | The Engine Control Module (ECM) detected an unexpected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. | Possible reduced engine performance.
Engine Control Module (ECM).

Circuit Description

Alternator Feedback Monitor is a diagnostic function that aims to detect changes in system behavior related to friction or load. The function learns the ratio between the ECM commanded torque and alternator feedback torque. The monitor can trigger a fault code and optionally shut down the engine if an abrupt increase or decrease in ECM commanded torque relative to feedback torque is detected.

Component Location

The alternator feedback monitor is internal to the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the generator set is running steady-state at rated speed and above a calibratible load threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected between generator set alternator feedback torque and ECM commanded torque deviates beyond a least severe low threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code is an information only fault code indicating an expected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. No malfunction has occurred to cause this fault code.

Refer to Troubleshooting Fault Code 7548 .

Last Modified: 28-Apr-2021


Engine Friction Baseline - Data Valid But Below Normal Operating Range - Moderately Severe Level

FAULT CODE 7549

Engine Friction Baseline - Data Valid But Below Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7549 PID: SPN: 521144 FMI: 1/18 LAMP: Amber SRT: | The Engine Control Module (ECM) detected an unexpected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. | Possible reduced engine performance.
Engine Control Module (ECM).

Circuit Description

Alternator Feedback Monitor is a diagnostic function that aims to detect changes in system behavior related to friction or load. The function learns the ratio between the ECM commanded torque and alternator feedback torque. The monitor can trigger a fault code and optionally shut down the engine if an abrupt increase or decrease in ECM commanded torque relative to feedback torque is detected.

Component Location

The alternator feedback monitor is internal to the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the generator set is running steady-state at rated speed and above a calibratible load threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ratio between generator set alternator feedback torque and ECM commanded torque deviates beyond a moderately severe low threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Damaged or malfunctioning turbocharger
  • Restricted aftercooler element.
  • Restricted intake air filter.
  • Restricted exhaust
  • Oil level excessive.
  • Incorrect alternator efficiency settings.
  • Internal engine damage.
  • Damaged alternator bearings.
Refer to Troubleshooting Fault Code 7549 .

Last Modified: 05-May-2021


Engine Friction Baseline - Data Valid But Above Normal Operating Range - Least Severe Level

FAULT CODE 7551

Engine Friction Baseline - Data Valid But Above Normal Operating Range - Least Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7551 PID: SPN: 521144 FMI: 0/15 LAMP: None SRT: | The Engine Control Module (ECM) detected an unexpected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. | Possible reduced engine performance.
Engine Control Module (ECM).

Circuit Description

Alternator Feedback Monitor is a diagnostic function that aims to detect changes in system behavior related to friction or load. The function learns the ratio between the ECM commanded torque and alternator feedback torque. The monitor can trigger a fault code and optionally shut down the engine if an abrupt increase or decrease in ECM commanded torque relative to feedback torque is detected.

Component Location

The alternator feedback monitor is internal to the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the generator set is running steady-state at rated speed and above a calibratible load threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected the ratio between generator set alternator feedback torque and ECM commanded torque deviates beyond a least severe high threshold.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

This fault code is an information only fault code indicating an expected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. No malfunction has occurred to cause this fault code.

Refer to Troubleshooting Fault Code 7551 .

Last Modified: 28-Apr-2021


Engine Friction Baseline - Data Valid But Above Normal Operating Range - Moderately Severe Level

FAULT CODE 7552

Engine Friction Baseline - Data Valid But Above Normal Operating Range - Moderately Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7552 PID: SPN: 521144 FMI: 0/16 LAMP: Amber SRT: | The Engine Control Module (ECM) detected an unexpected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. | Possible reduced engine performance.
Engine Control Module (ECM).

Circuit Description

Alternator Feedback Monitor is a diagnostic function that aims to detect changes in system behavior related to friction or load. The function learns the ratio between the ECM commanded torque and alternator feedback torque. The monitor can trigger a fault code and optionally shut down the engine if an abrupt increase or decrease in ECM commanded torque relative to feedback torque is detected.

Component Location

The alternator feedback monitor is internal to the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the generator set is running steady-state at rated speed and above a calibratible load threshold.

Conditions for Setting the Fault Codes

This Engine Control Module (ECM) detected the ratio between generator set alternator feedback torque and ECM commanded torque deviates beyond a moderately severe high threshold.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Data Reset” option command in the recommended Cummins® electronic service tool is used to clear this active fault code.

Shop Talk

Possible causes of this fault code include:

  • Damaged or malfunctioning turbocharger
  • Restricted aftercooler element.
  • Restricted intake air filter.
  • Restricted exhaust
  • Incorrect fuel.
  • Oil level excessive.
  • Incorrect alternator efficiency settings.
  • Internal engine damage.
  • Malfunctioning or damaged fuel injector.
  • Damaged alternator bearings.
Refer to Troubleshooting Fault Code 7552 .

Last Modified: 05-May-2021


Engine Friction Deviation - Data Valid But Above Normal Operating Range - Most Severe Level

FAULT CODE 7554

Engine Friction Deviation - Data Valid But Above Normal Operating Range - Most Severe Level

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7554 PID: SPN: 521145 FMI: 0/0 LAMP: Red SRT: | An increase in friction has been detected. | The engine will shutdown.
Engine Control Module (ECM).

Circuit Description

The alternator feedback monitor is a diagnostic function that prevents progressive damage to the engine and other engine components. The distance between the current friction datapoint and the threshold is called the Engine Friction Deviation.

Component Location

The alternator feedback monitor is internal to the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the generator set is running steady-state at rated speed and above a calibratible load threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an increase of friction within a calibrated amount of time.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.
  • The engine will be shut down if the Engine Protection Shutdown feature is enabled.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Fault Status Reset” option command in the recommended Cummins® electronic service tool is used to clear this active fault code.

Shop Talk

Possible causes of this fault code include:

  • Restricted aftercooler element.
  • Air intake restriction.
  • A malfunctioning turbocharger
  • Oil level excessive.
  • Incorrect alternator efficiency settings.
  • Internal engine damage.
  • Malfunctioning or damaged fuel injector.
  • Damaged alternator bearings.
Refer to Troubleshooting Fault Code 7554 .

Last Modified: 05-May-2021


Alternator Feedback Power - Special Instructions

FAULT CODE 7555

Alternator Feedback Power - Special Instructions

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7555 PID: SPN: 521146 FMI: 14/14 LAMP: Red SRT: | Communication failed between the generator set controller and the ECM. | The engine will shutdown.

Circuit Description

The power feedback J1939 message received from the generator set controller is called the alternator feedback power.

Component Location

The J1939 datalink wiring and the generator set controller may vary depending on generator set application.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the generator set controller is active.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) detected a communication failure between the generator set controller and the ECM.

Action Taken When the Fault Code is Active

  • The generator set controller displays a shutdown fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, perform a key cycle, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the shutdown indicator immediately after pressing the reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.

Shop Talk

Possible causes of this fault code include:

  • Incorrect generator set controller calibration.
  • Incorrect engine ECM calibration.
  • Malfunctioning or damaged J1939 datalink wiring.
  • Malfunctioning or damaged datalink terminating resistors.
Refer to Troubleshooting Fault Code 7555 .

Last Modified: 24-May-2021


Engine Friction Deviation - Condition Exists

FAULT CODE 7558

Engine Friction Deviation - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 7558 PID: SPN: 521145 FMI: 11/31 LAMP: None SRT: | An increase in friction has been detected. | None on performance.
Engine Control Module (ECM).

Circuit Description

The alternator feedback monitor is a diagnostic function that prevents progressive damage to the engine and other engine components. The distance between the current friction datapoint and the threshold is called the Engine Friction Deviation.

Component Location

The alternator feedback monitor is internal to the ECM.

Conditions for Running the Diagnostics

The diagnostic runs continuously when the generator set is running steady-state at rated speed and above a calibratible load threshold.

Conditions for Setting the Fault Codes

The Engine Control Module (ECM) has detected an increase of friction within a calibrated amount of time.

Action Taken When the Fault Code is Active

  • The ECM logs the fault code immediately when the diagnostic runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the fault code immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active and inactive faults.
  • The “Fault Status Reset” option command in the recommended Cummins® electronic service tool is used to clear this active fault code.

Shop Talk

This fault code is an information only fault code indicating an expected source of friction in the system that has resulted in a larger than expected difference between commanded torque and alternator feedback torque. No malfunction has occurred to cause this fault code.

Refer to Troubleshooting Fault Code 7558 .

Last Modified: 28-Apr-2021


SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

FAULT CODE 781

SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 781 PID: S206 SPN: 1231 FMI: 9/9 LAMP: Amber SRT: | No communication or an invalid data transfer rate detected on the J1939 data link between the primary ECM and one or more secondary ECMs. | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 Ω resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • A secondary ECM is not receiving power from the battery supply circuit in the harness. This can be caused by an open circuit in the power supply wire, blown ECM fuse, or open return wire.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 781 .

Last Modified: 11-Dec-2020


SAE J1939 Data Link 2 Engine Network No Data Received - Condition Exists

FAULT CODE 782

SAE J1939 Data Link 2 Engine Network No Data Received - Condition Exists

Printable Version Printable Version

Overview

CODE | REASON | EFFECT
Fault Code: 782 PID: S206 SPN: 1231 FMI: 11/31 LAMP: Amber SRT: | No communication on the J1939 data link between the primary ECM and one or more of the secondary ECMs | Engine may run rough, may stop running, may not start, or may be difficult to start.
SAE J1939 Data Link 2 Circuit

Circuit Description

The SAE J1939 data link circuit consists of one positive and one negative wire. Two 120 Ω resistors are connected in parallel to terminate the ends of the backbone. Stubs connect the engine control modules (ECM) to the J1939 backbone.

The engine control modules use the J1939 data link 2 for communication between modules.

Component Location

The Engine Control Modules (ECMs) are mounted at the front of the engine above the gear housing.

Conditions for Running the Diagnostics

This diagnostic runs continuously when the engine is running.

Conditions for Setting the Fault Codes

The primary engine control module (ECM 1) lost communication with one or more secondary ECMs via the J1939 data link 2.

Action Taken When the Fault Code is Active

  • The generator set controller displays a warning fault immediately when the diagnostics runs and fails.

Conditions for Clearing the Fault Code

  • To validate the repair, start the engine and let it run for 1 minute at no load.
  • The generator set controller will turn off the warning indicator immediately after the user presses reset.
  • The “Reset All Faults” command in the recommended Cummins® electronic service tool or equivalent can be used to clear active faults.

Shop Talk

Possible causes of this fault code include:

  • Secondary ECM is not receiving power from the ECM supply voltage circuit in the engine wiring harness.
  • Open circuit in the power supply wire.
  • Open circuit on the return wire
  • Blown ECM fuse.
  • Tripped circuit breaker in the OEM power supply circuit.
  • An open or short circuit in the SAE J1939 datalink circuit
  • Intermittent communication between the ECMs.
Refer to Troubleshooting Fault Code 782 .

Last Modified: 11-Dec-2020


ECM - No Communication Troubleshooting Tree

Symptoms

    • No communication and engine will not start
    • No communication and engine will start
    • No communication related INSITE™ electronic service tool errors
    • Communication with some ECMs but not all ECMs on a multi-module engine.

How To Use This Tree

This troubleshooting procedure can be used to troubleshoot J1939 and J1587 data link communication issues between the electronic service tool and the ECM. There are four procedures that can be used to support this troubleshooting tree:

  • Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.
  • Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate electronic control system troubleshooting and repair manual.

The troubleshooting steps in this procedure build upon information obtained in previous steps. The troubleshooting steps must be performed in the sequence specified in the troubleshooting procedure.

This troubleshooting procedure supports several engine families, therefore some instructions are stated in a general manner. Apply the requested procedures and actions to the specific engine family with the support of engine specific documentation that can be found in the Troubleshooting and Repair manuals for the specific engine family.

Shop Talk

Three basic principles were used to define and sequence the troubleshooting steps that are listed in this tree.

  • Verify high level system operation prior to troubleshooting individual components of the system. The purpose for this is to learn from the behavior of the system in order to direct the next steps for troubleshooting.
  • Use the Bench Top Harness to separate the ECM from the vehicle so the ECM can be isolated from vehicle issues that could be causing no communication.
  • Use a second vehicle or a second ECM to isolate high level system issues before troubleshooting individual components of the system.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | INSITE™ electronic service tool error code check |
 | STEP 1A. Check for INSITE™ electronic service tool error code 5023. | Is INSITE™ electronic service tool error code 5023 present?
 | STEP 1B. INSITE™ electronic service tool error code 5080 or 5081 check. | Is INSITE™ electronic service tool error code 5080 or 5081 present?
 | STEP 1C. INSITE™ electronic service tool other error code checks. | Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
 | STEP 1D. ECM password check | Does INSITE™ electronic service tool indicate the ECM is password protected?
STEP 2. | Initial data link adapter and INSITE™ electronic service tool check |
 | STEP 2A. Initial data link adapter check | Are the communication lights on the data link adapter flashing?
 | STEP 2B. data link adapter reset check | Does the ECM communicate?
 | STEP 2C. Initial INSITE™ electronic service tool check | Does the ECM communicate?
 | STEP 2D. data link adapter verification check | Is an Inline or Inline I being use to communicate with the ECM?
 | STEP 2E. data link adapter firmware check | Is firmware version compatible with ECM?
STEP 3. | Bench communication setup checks |
 | STEP 3A. Bench setup availability check | Is a bench setup available?
 | STEP 3A-1. Engine start check |
 | STEP 3B. Initial bench setup communication check | Does the ECM communicated using bench setup?
 | STEP 3B-1. Engine start check |
 | STEP 3C. Second vehicle or second ECM availability check for bench setup | Is second vehicle or second ECM available to connect to the bench setup?
 | STEP 3D. Initial bench setup functionality check | Does the second ECM communicate using bench setup?
 | STEP 3E. Troubleshoot bench setup | Does bench setup check OK?
 | STEP 3F. data link adapter replacement check | Does bench setup communicate with the second ECM using a replacement data link adapter?
STEP 4. | ECM power up circuit check |
 | STEP 4A. Engine configuration check | Is the engine equipped with a fuel shutoff valve?
 | STEP 4A-1. Check fuel shutoff valve voltage |
 | STEP 4A-2. Coolant temperature sensor signal voltage check |
 | STEP 4B. ECM keyswitch voltage check | Is the keyswitch voltage within 1-VDC or vehicle system voltage?
 | STEP 4C. Check the ECM power and ground | Is the ECM battery supply voltage equal to the battery voltage?
STEP 5. | Initial electronic tool check |
 | STEP 5A. Bench setup previously used for troubleshooting check | In Step 3 checks, was bench setup used to successfully communicate with the ECM?
 | STEP 5B. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 5C. Initial electronic tool functionality check | Does the second ECM communicate using electronic tool?
STEP 6. | data link adapter power check |
 | STEP 6A. data link adapter determination check | Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
 | STEP 6B. Check data link adapter power | Is the data link adapter power light on?
 | STEP 6C. Determination if communication is being attempted at OEM dash connector | Is the communication being attempted at the OEM data link dash connector?
 | STEP 6D. OEM data link dash connector voltage check | Is the voltage equal to or greater than 9-VDC?
 | STEP 6E. Check voltage at data link adapter auxiliary power supply | Is the voltage equal to or greater than 9-VDC?
 | STEP 6F. Check voltage at vehicle battery | Is the voltage equal or greater than 11-VDC?
 | STEP 6G. Computer serial port voltage check | Is a minimum of 5 VDC available?
STEP 7. | data link circuit check |
 | STEP 7A. Check J1939 or J1587 circuits | Does the circuit check OK?
STEP 8. | Initial electronic tool check |
 | STEP 8A. Second vehicle availability check for electronic tool | Is a second vehicle available to connect to the electronic tool?
 | STEP 8B. Initial electronic tool functionality check | Does the second ECM communicate using the electronic tool?
STEP 9. | Detailed electronic tool check |
 | STEP 9A. Troubleshoot electronic tool hardware | Does the electronic tool hardware check OK?
STEP 10. | Serial cable and computer check |
 | STEP 10A. Troubleshoot serial cable and computer | Do the serial cable and computer check OK?
STEP 11. | ROM boot ECM |
 | STEP 11A. ROM boot tool availability check | Is the ROM boot tool available?
 | STEP 11B. ROM boot ECM | Does the ECM communicate?

Guided Step 1 - INSITE™ electronic service tool error code check

Guided Step 1A - INSITE™ electronic service tool error code 5023 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ electronic service tool error code 5023.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5023 present?

Is INSITE™ electronic service tool error code 5023 present?
YES | NO
No Repair | No Repair

Go to 2A

Go to 1B

Guided Step 1B - INSITE™ electronic service tool error code 5080 or 5081 check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Check for INSITE™ error code 5080 or 5081.

  • Use INSITE™ electronic service tool to read the error codes.

Is INSITE™ electronic service tool error code 5080 or 5081 present?

Is INSITE™ electronic service tool error code 5080 or 5081 present?
YES NO

Perform the ECM calibration download

 No Repair

Repair complete

Go to 1C

Guided Step 1C - INSITE™ electronic service tool other error code checks.

Conditions

  • Connect Is INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

  • Use INSITE™ electronic service tool to read the error codes.

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?

Are any INSITE™ electronic service tool error codes present other than 5023, 5080, or 5081?
YES NO

See the INSITE™ Electronic Service Tool manual for troubleshooting guidelines.

 No Repair

Repair Complete

Go to 1D

Guided Step 1D - ECM password check

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Does INSITE™ electronic service tool indicate the ECM is password protected?

  • Use INSITE™ electronic service tool.

Does INSITE™ electronic service tool indicate the ECM is password protected?

Does INSITE™ electronic service tool indicate the ECM is password protected?
YES NO

Enter correct password

If password is unavailable, contact customer to request password information. If customer can not supply password information, see the INSITE™ electronic service tool manual for password removal information. Normal warranty guidelines will apply if ECM password removal is required.

 No Repair

Repair complete

Go to 2A

Guided Step 2 - Initial data link adapter and INSITE™ electronic service tool check

Guided Step 2A - Initial data link adapter check

Conditions

  • data link adapter connected to OEM data link connector in vehicle.
  • INSITE™ electronic service tool computer must not be connected.
  • Note: If connected to the 3 pin engine data link connector the communication lights will not blink, continue to Step 2B.

Action

Turn keyswitch on.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.

Are the communication lights on the data link adapter flashing?

  • J1708 light for Inline
  • J1708 or J1939 for Inline II, Inline 4, and Inline 5.
YES NO

No Repair

 No Repair

Go to 2C

Go to 2B

Guided Step 2B - data link adapter reset check

Conditions

INSITE™ electronic service tool connected to vehicle.

Action

Data link adapter reset check

  • Disconnect power from the data link adapter.
  • Leave disconnected for 30 seconds
  • Connect power again to the Inline adapter
  • Turn keyswitch ON.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 3A

Guided Step 2C - Initial INSITE™ electronic service tool check

Conditions

  • INSITE™ electronic service tool connected to vehicle
  • Turn keyswitch ON.

Action

Reboot INSITE™ electronic service tool PC.

  • Launch INSITE™ electronic service tool
  • Check for communication.

Does the ECM communicate?

Does the ECM communicate?
YES | NO
No Repair | No Repair

Repair complete

Go to 2D

Guided Step 2D - data link adapter verification check

Conditions

None

Action

Verify if an Inline or Inline I data link adapter is being used to communicate with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate electronic control system troubleshooting and repair manual for data link adapter identification information.

Is an Inline or Inline I being used to communicate with the ECM?

Is an Inline or Inline I being used to communicate with the ECM?
YES | NO
No Repair | No Repair

Go to 8A

Go to 2E

Guided Step 2E - data link adapter firmware check

Conditions

None

Action

Verify data link adapter firmware version is compatible with ECM.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapters, in the appropriate Electronic Control System Troubleshooting and Repair manual for data link adapter identification information.

Is firmware version compatible with the ECM?

Is firmware version compatible with the ECM?
YES NO
No Repair

Load correct firmware version

Go to 8A

Go to 2C

Guided Step 3 - Bench communication setup checks

Guided Step 3A - Bench setup availability check

Conditions

  • Bench setup available.

Action

Verify bench setup is available.

Is a bench setup available?

Is a bench setup available?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3A-1

Guided Step 3A-1 - Engine start check

Conditions

  • None

Action

Verify if engine will start.

Will engine start?

Will engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3B - Initial bench setup communication check.

Conditions

  • Use the same INSITE™ electronic service tool PC as was used for the previous checks
  • Bench setup connected to ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to comunicate with the ECM using bench setup.

Does the ECM communicate with bench setup?

Does the ECM communicate with bench setup?
YES | NO
No Repair | No Repair

Go to 3B-1

Go to 3C

Guided Step 3B-1 - Engine start check

Conditions

  • None

Action

Disconnect the bench top calibration cable from the ECM. Reconnect the ECM to the original engine or OEM wiring harness connector. Verify if the engine will start.

Will the engine start?

Will the engine start?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4A

Guided Step 3C - Second vehicle or second ECM availability check for bench setup

Conditions

  • Second vehicle or second ECM available for testing.

Action

Verify if a second vehicle or second ECM is available to connect to the bench setup.

Is a second vehicle or second ECM available to connect to the bench setup?

Is a second vehicle or second ECM available to connect to the bench setup?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3E

Guided Step 3D - Initial bench setup functionality check

Conditions

  • Use the same INSITE™ electronic service tool PC and bench setup tools that were originally used on the problem vehicle.
  • Bench setup connected to second vehicle or second ECM
  • Bench top calibration harness keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle or a spare ECM using bench setup.

Does the second ECM communicate using bench setup?

Does the second ECM communicate using bench setup?
YES | NO
No Repair | No Repair

Go to 11A

Go to 3E

Guided Step 3E - Troubleshoot bench setup hardware

Conditions

  • None

Action

Troubleshoot bench calibration cable, bench calibration harness, and serial cable.

  • Perform troubleshooting procedures for evaluating the bench calibration cable, bench calibration harness, and serial cable. Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Resistance Check - Serial Cable, Benchtop Calibration Harness, Benchtop Calibration Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual.

Does bench setup check OK?

Does bench setup check OK?
YES NO
No Repair

Repair or replace bench calibration cable, bench calibration harness, or serial cable.

Go to 3F

Go to 3B

Guided Step 3F - data link adapter replacement check

Conditions

  • None

Action

Try to communicate with the bench setup using a replacement datalink.

Does bench setup communicate with the second ECM using a replacement data link adapter?

Does bench setup communicate with the second ECM using a replacement data link adapter?
YES NO

Use replacement data link adapter.

Issue with bench setup should have been found. Troubleshoot the bench setup again.

Go to 3B

Go to 3E

Guided Step 4 - ECM power up circuit check

Guided Step 4A - Engine configuration check

Conditions

  • None

Action

Determine if the engine is equipped with a fuel shutoff valve

Is the engine equipped with a fuel shutoff valve?

Is the engine equipped with a fuel shutoff valve?
YES | NO
No Repair | No Repair

Go to 4A-1

Go to 4A-2

Guided Step 4A-1 - Check fuel shutoff valve voltage

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the fuel shutoff valve post to engine block ground.

There are 12 and 24 volt systems, the fuel shutoff valve voltage needs to be within 1-VDC of the vehicle system voltage.

Is the fuel shutoff valve voltage within 1-VDC of vehicle system voltage?

Is the fuel shutoff valve voltage within 1 VDC of vehicle system voltage?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4A-2 - Coolant temperature sensor signal voltage check

Conditions

  • Turn keyswitch ON.
  • Disconnect the coolant temperature sensor connector.

Action

Measure the voltage across the two pins of the coolant temperature sensor on the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the coolant temperature signal voltage greater than 4.5-VDC?

Is the coolant temperature signal voltage greater than 4.5-VDC?
YES | NO
No Repair | No Repair

Go to 5A

Go to 4B

Guided Step 4B - ECM keyswitch voltage check

Conditions

  • Turn keyswitch OFF.
  • Disconnect the wiring harness connector that contains the keyswitch signal from the ECM.
  • Turn the keyswitch ON.

Action

Measure the voltage from the keyswitch input SIGNAL wire of the wiring harness to engine block ground.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the keyswitch voltage within 1-VDC of vehicle system voltage?

Is the keyswitch voltage within 1-VDC of vehicle system voltage?
YES NO
No Repair

Repair or replace the wiring harness that contains the keyswitch signal, or repair or replace the keyswitch, or check the battery connection. Reference Procedure 019-064 (Key Switch Battery Supply Circuit) in Section 19 in the appropriate troubleshooting and repair manual.

See the Engine Performance Troubleshooting Tree in the appropriate troubleshooting and repair manual, if the no start condition is still present.

Go to 4C

Repair complete

Guided Step 4C - Check the ECM power and ground

Conditions

  • Turn keyswitch OFF
  • Disconnect from the ECM the wiring harness connector that contains the ECM battery SUPPLY (-) and SUPPLY (+) wiring.

Action

Measure the voltage from each ECM battery SUPPLY (+) pin to all battery SUPPLY (-) pins in the wiring harness connector.

Reference the wiring diagram or circuit diagram for connector pin identification.

Is the ECM battery supply voltage equal to the battery voltage?

Is the ECM battery supply voltage equal to the battery voltage?
YES NO

Call for authorization.

Replace the ECM. Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair or replace the wiring harness that contains the ECM battery SUPPLY (+) and battery SUPPLY (-) wiring.

See the Engine Performance Troubleshooting Tree if no start condition is still present.

Repair complete

Repair complete

Guided Step 5 - Initial electronic tool check

Guided Step 5A - Bench setup previously used for troubleshooting check

Conditions

  • None

Action

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?

In Step 3 checks, was bench setup used to successfully communicate with the ECM?
YES NO

ECM is OK, repair complete if communication is not required through OEM data link connector or harness.

If communication is required through the OEM data link connector or harness continue to Step 6A.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify a second vehicle is available to connect to the electronic tool.

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 5C

Go to 6A

Guided Step 5C - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to a second vehicle.
  • Keyswitch ON.

Action

Attempt to communicate with the ECM on the second vehicle using the same electronic tool hardware used on the problem vehicle.

Does the second ECM communicate using electronic tool?

Does the second ECM communicate using electronic tool?
YES | NO
No Repair | No Repair

Go to 6A

Go to 9A

Guided Step 6 - data link adapter power check

Guided Step 6A - data link adapter determination check

Conditions

  • None

Action

Determine if an Inline I datalink adapter is being used to communicate with INSITE™ electronic service tool.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?

Is an Inline I data link adapter being used to communicate with INSITE™ electronic service tool?
YES | NO
No Repair | No Repair

Go to 6G

Go to 6B

Guided Step 6B - Check data link adapter power

Conditions

  • Do not use an Inline I
  • Electronic tool hardware connected to the vehicle.
  • INSITE™ electronic service tool launched
  • Keyswitch ON.

Action

Note: For all datalink adapters except Inline I.

Attempt to communicate with INSITE™ electronic service tool and check to see if the data link adapter power light is on.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for General Information - data link Adapter, in the appropriate electronic control system troubleshooting and repair manual.

Is the data link adapter power light on?

Is the data link adapter power light on?
YES | NO
No Repair | No Repair

Go to 7A

Go to 6C

Guided Step 6C - Determination if communication is being attempted at the OEM data link dash connector

Conditions

  • None

Action

Check to see if communication is being attempted at the OEM datalink dash connector.

Is communication being attempted at the OEM data link dash connector?

Is communication being attempted at the OEM data link dash connector?
YES | NO
No Repair | No Repair

Go to 6D

Go to 6E

Guided Step 6D - OEM data link dash connector voltage check

Conditions

  • Turn keyswitch ON.

Action

Measure voltage across the SUPPLY and ground pins of the OEM datalink connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for In Cab data link Connector or 6-pin In Cab data link connector, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9 VDC?

Is the voltage equal to or greater than 9 VDC?
YES NO

Replace data link adapter

 No Repair

Repair complete

Go to 6F

Guided Step 6E - Check voltage at data link adapter auxiliary power supply

Conditions

  • Turn keyswitch ON.

Action

Measure the data link adapter supply voltage at the datalink adapter harness connector.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for 3-pin data link Cable, in the appropriate Electronic Control System Troubleshooting and Repair manual for pin locations.

Is the voltage equal to or greater than 9-VDC?

Is the voltage equal to or greater than 9-VDC?
YES NO

Replace data link adapter.

 No Repair

Repair complete

Go to 6F

Guided Step 6F - Check voltage at vehicle battery

Conditions

  • None

Action

Measure vehicle battery voltage in all cases except if using an Inline I.

If using an Inline I measure data link adapter voltage supply from computer.

Is the voltage equal to or greater than 11-VDC?

Is the voltage equal to or greater than 11-VDC?
YES NO

Repair or replace damaged wiring.

Clean the battery connections or replace the batteries.

Repair complete

Repair complete

Guided Step 6G - Computer serial port voltage check

Conditions

  • None

Action

Note: For Inline I only.

Measure voltage across the SIGNAL ground pin and the data terminal ready pin and the SIGNAL ground pin and the request to send pin on the computer serial port.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, for Serial Cable, in the appropriate Electronic and Control System Troubleshooting and Repair manual for pin locations.

Is a minimum of 5 VDC available?

Is a minimum of 5 VDC available?
YES NO

Replace data link adapter

Contact PC administration support.

Repair complete

Repair complete

Guided Step 7 - data link circuit check

Guided Step 7A - Check J1939 or J1587 circuits

Conditions

  • None

Action

Use the following procedures to perform J1939 or J1587 circuit checks depending on the datalink circuit being used.

Reference Procedure 019-165 (Data Link Circuit, SAE J1939) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Reference Procedure 019-166 (Data Link Circuit, SAE J1587) in Section 19 in the appropriate troubleshooting and repair manual.

This procedure gives information for a complete resistance check, check for short circuit to ground, check for short circuit from pin-to-pin, and voltage check.

Reference Procedure 019-428 (Engine data links) in Section 19 in the appropriate troubleshooting and repair manual. Complete resistance check, check for short circuit to ground, and check for short circuit from pin-to-pin.

Does the circuit check OK?

Does the circuit check OK?
YES NO
No Repair

Repair or replace the harness with the data link problem, either the engine or OEM harness.

Go to 11A

Repair complete

Guided Step 8 - Initial electronic tool check

Guided Step 8A - Second vehicle availability check for electronic tool

Conditions

  • Second vehicle available for testing

Action

Verify if a second vehicle is available to connect to electronic tool?

Is a second vehicle available to connect to the electronic tool?

Is a second vehicle available to connect to the electronic tool?
YES | NO
No Repair | No Repair

Go to 8B

Go to 10A

Guided Step 8B - Initial electronic tool functionality check

Conditions

  • Electronic tool connected to second vehicle

Action

Attempt to communicate with the ECM on the second vehicle using the electronic tool.

Does the second ECM communicate using the electronic tool?

Does the second ECM communicate using the electronic tool?
YES | NO
No Repair | No Repair

Go to 11A

Go to 10A

Guided Step 9 - Detailed electronic tool check

Guided Step 9A - Troubleshoot electronic tool hardware

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating electronic tool hardware:

  • data link adapter cable
  • data link adapter power supply cable
  • data link adapter
  • Serial cable
  • Computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Initial Check - data link Adapters
  • Resistance Check - Serial Cable
  • Resistance Check for data link adapter cable and data link adapter power supply cable.

Does the electronic tool hardware check OK?

Does the electronic tool hardware check OK?
YES NO

Communication issue found.

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 10 - Serial cable and computer check

Guided Step 10A - Troubleshoot serial cable and computer

Conditions

  • None

Action

Perform troubleshooting procedures for evaluating the serial cable and computer.

Reference Procedure 022-999 (Service Tools and Hardware - Overview) in Section F, in the appropriate troubleshooting and repair manual.

Complete the following checks:

  • Initial Check - INSITE™ electronic service tool
  • Resistance Check - Serial Cable.

Do the serial cable and computer check OK?

Do the serial cable and computer check OK?
YES NO

Communication issue found

Repair or replace damaged hardware.

Go to 11A

Repair complete

Guided Step 11 - ROM boot ECM

Guided Step 11A - ROM boot tool availability check

Conditions

  • None

Action

Verify if ROM boot tool is available for specific ECM.

Is the ROM boot tool available?

Is the ROM boot tool available?
YES NO
No Repair

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Go to 11B

Repair complete

Guided Step 11B - ROM boot the ECM

Conditions

  • None

Action

ROM boot the ECM.

Reference Procedure 019-427 (ECM ROM Boot) in Section 19 in the appropriate troubleshooting and repair manual.

Does the ECM communicate?

Does the ECM communicate?
YES NO

Calibrate the ECM again.

Call for pre-authorization

Replace the ECM.

Reference Procedure 019-031 (Electronic Control Module (ECM)) in Section 19 in the appropriate troubleshooting and repair manual.

Repair complete

Repair complete

Last Modified: 07-Dec-2007
Copyright © 2000-2009 Cummins Inc. All rights reserved.


FAULT CODE 122 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Printable Version Printable Version

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | IF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSM11 CM876 M101 | 5504547
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSM11 CM876 M101 | 5504547
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | IF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F132B | 5467327
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | R2.8 CM2220 R101B | 5467556
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B110 | 4332883
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B136C | 5504194
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F133C | 5504278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B146C | 5504283
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F135B | 5504616
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F136B | 5504621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2620 F137B | 5579517
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F4.5 CM2620 F139B | 5579522
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X125M | 5504345

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 122 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 123 active and Fault Code 122 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 122 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active and Fault Code 122 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Apr-2019


FAULT CODE 123 - Intake Manifold 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310840
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367219
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | Signature™ ISX and QSX15 | 3666259
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310840
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 40221704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367219
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | Signature™ ISX and QSX15 | 3666259
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | FCM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSM11 CM876 M101 | 5504547
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSK23 CM2250 K109 | 4367358
Intake Manifold Pressure Sensor | Refer to Procedure 019-061 | QSM11 CM876 M101 | 5504547
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310840
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK78 CM2250 K104 | 4332682
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367219
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Signature™ ISX and QSX15 | 3666259
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F132B | 5467327
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | R2.8 CM2220 R101B | 5467556
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B110 | 4332883
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B136C | 5504194
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L120C | 5504199
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F133C | 5504278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B146C | 5504283
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F135B | 5504616
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F136B | 5504621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2620 F137B | 5579517
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F4.5 CM2620 F139B | 5579522
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X125M | 5504345

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 123 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 122 active and Fault Code 123 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 123 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 122 active and Fault Code 123 inactive?
YES NO
No Repair

Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 123 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Repair complete.

Last Modified: 10-Apr-2019


FAULT CODE 135 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 433264
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B104 | 4332646
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2250 L115 | 4388626
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B6.7 CM2350 B136C | 5504194
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | L9 CM2350 L120C | 5504199
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | F3.8 CM2350 F133C | 5504278
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | B4.5 CM2350 B146C | 5504283
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | F3.8 CM2620 F137B | 5579517
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | F4.5 CM2620 F139B | 5579522
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | X15 CM2350 X125M | 5504345
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK19 CM2350 K114 | 5579623
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 135 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 141 active and Fault Code 135 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 135 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 135 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 141 active and Fault Code 135 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM engine connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

Between 4.75 VDC and 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 135 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2021


FAULT CODE 141 - Engine Oil Rifle Pressure 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332646
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL8.9 CM2150 SN | 4022190
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISM11 CM876 SN | 4022196
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISZ13 CM2150 | 4022133
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2250 | 4022256
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 | 4022255
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 EC | 2883621
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 ECF | 2883557
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | PowerGen QSX15 CM2250 | 4310664
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | Marine QSB6.7 CM2250 | 4310611
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L101 | 4310787
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX12 CM2350 X102 | 4310646
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2350 X101 | 4310641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISX15 CM2250 SN | 4310736
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B103 | 4332641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B104 | 4332641
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK19 CM2350 K105 | 4326157
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK78 CM2250 K104 | 4332682
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | VTA903 CM2250 V105 | 4332841
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B105 | 4332778
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L102 | 4332796
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 M CM2250 L106 | 4358343
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISL9 CM2350 L111 | 4367223
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B112 | 4358498
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B106 | 4367376
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G110 | 4367323
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK23 CM2250 K109 | 4367358
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2250 K112 | 4367454
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L107 | 4367386
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B130 | 4388668
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L118 | 4388673
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F118 | 4388708
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F119 | 4388703
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B122 | 4388767
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2250 B128 | 4388601
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2250 B131 | 4388774
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB3.3 CM2250 B137 | 5411058
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2250 X115 | 4388739
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | ISB6.7 CM2350 B142 | 5411131
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X114B | 5411181
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X116B | 5411186
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L116B | 5411330
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B129B | 5411247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B147B | 5411252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B135B | 5411257
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B148B | 5411262
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L119B | 5411267
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB6.7 CM2350 B145 | 5411273
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSL9 CM2350 L122 | 5411278
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSB4.5 CM2350 B144 | 5411382
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L123B | 5411465
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSF3.8 CM2350 F125 | 5411494
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSX15 CM2350 X118 | 5467247
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSG12 CM2350 G113 | 5467252
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B6.7 CM2350 B136C | 5504194
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | L9 CM2350 L120C | 5504199
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | F3.8 CM2350 F133C | 5504278
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | B4.5 CM2350 B146C | 5504283
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | F3.8 CM2620 F137B | 5579517
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | F4.5 CM2620 F139B | 5579522
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | X15 CM2350 X125M | 5504345
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK19 CM2350 K114 | 5579623
Engine Oil Pressure Sensor | Refer to Procedure 019-066 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead, Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 141 inactive?
STEP 2. | Check the oil pressure sensor and circuit. |
 | STEP 2A. Inspect the oil pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 135 active and Fault Code 141 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 141 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the oil pressure sensor and circuit.

Guided Step 2A - Inspect the oil pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.

Action

Inspect the engine harness and oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the sensor connector of the engine harness.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the oil pressure sensor connector of the engine harness.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the oil pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the oil pressure +5 volt SUPPLY pin to the oil pressure RETURN pin at the ECM engine connector.

Refer to the wiring diagram for connector pin identification.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the oil pressure +5 volt SUPPLY pin and the oil pressure SIGNAL pin at the ECM engine connector.
  • Turn keyswitch ON.
  • Use INSITE™ electronic service tool to read the fault codes.

Refer to the wiring diagram for connector pin identification.

Fault Code 135 active and Fault Code 141 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 141 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Apr-2021


FAULT CODE 143 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 143. | Active or inactive counts of Fault Code 143?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 143.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 143?
YES NO

Repair

Use the following troubleshooting symptom tree, Lubricating Oil Pressure Low or Lubricating Oil Pressure High in Section TS, in the appropriate service manual.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 19-Mar-2013


FAULT CODE 144 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F132B | 5467327
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | R2.8 CM2220 R101B | 5467556
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B110 | 4332883
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B136C | 5504194
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L120C | 5504199
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F133C | 5504278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F128C | 5504273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F135B | 5504616
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F136B | 5504621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2620 F137B | 5579517
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F4.5 CM2620 F139B | 5579522
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M101 | 5504547
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X125M | 5504345
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M102M | 5504542
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K114 | 5579623
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K144G | 5612922
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M102M | 5504542
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M102M | 5504542
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 144 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 145 active and Fault Code 144 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 144 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin and engine coolant temperature sensor RETURN pin at the engine coolant temperature sensor.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant temperature sensor SIGNAL pin and coolant temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 145 active and Fault Code 144 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor RETURN pin and the engine harness engine coolant temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine coolant temperature sensor SIGNAL pin and the engine harness engine coolant temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 144 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 145 - Engine Coolant Temperature 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12/ISX11.9 CM2250 | 2883445
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 ECF | 2883557
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | PowerGen QSX15 CM2250 | 4310664
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX11.9 CM2250 ECF | 2883561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 EC | 2883621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 EC | 2883647
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F103 | 4310839
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISV5.0 CM3230 V104 | 4367291
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISZ13 CM2150 | 4022133
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 SN | 4022190
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISM11 CM876 SN | 4022196
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 GX CM2250 | 4022250
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2250 | 4022254
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 | 4022255
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 | 4022256
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Marine QSB6.7 CM2250 | 4310611
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B101 | 2883567
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L101 | 4310787
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX12 CM2350 X102 | 4310646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2350 X101 | 4310641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F101 | 4310846
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISX15 CM2250 SN | 4310736
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB4.5 CM2350 B104 | 4332646
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B103 | 4332641
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK78 CM2250 K104 | 4332682
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L106 | 4358343
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B105 | 4332778
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L102 | 4332796
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL8.9 CM2150 L110 | 4358475
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2220 F110 | 4358480
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | VTA903 CM2250 V105 | 4332841
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISL9 CM2350 L111 | 4367223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B112 | 4358498
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z101 | 4358364
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSZ13 CM2150 Z102 | 4358369
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B106 | 4367376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F107 | 4367316
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F105 | 4358561
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF3.8 CM2350 F109 | 4367218
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G110 | 4367323
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2250 K112 | 4367454
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F132B | 5467327
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | R2.8 CM2220 R101B | 5467556
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B110 | 4332883
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B136C | 5504194
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 B133C | 5504278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 B128C | 5504273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B146C | 5504283
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M101 | 5504547
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F135B | 5504616
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F136B | 5504621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2620 F137B | 5579517
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F4.5 CM2620 F139B | 5579522
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X125M | 5504345
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M102M | 5504542
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K114 | 5579623
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K144G | 5612922
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M102M | 5504542
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 C876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M102M | 5504542
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 2. | Check the engine coolant temperature sensor and circuit. |
 | STEP 2A. Inspect the engine coolant temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 145 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 144 active and Fault Code 145 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant temperature sensor and circuit.

Guided Step 2A - Inspect the engine coolant temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 145 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 144 active and Fault Code 145 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine coolant temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine coolant temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Refer to Procedure 019-043 in the Associated Procedures Table.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 145 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2021


FAULT CODE 146 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B136C | 5504194
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L120C | 5504199
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F133C | 5504278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F128C | 5504273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B146C | 5504283
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F135B | 5504616
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F136B | 5504621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2620 F137B | 5579517
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F4.5 CM2620 F139B | 5579522
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X125M | 5504345
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K114 | 5579623
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Repair

Reference the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS of the appropriate service manual.

Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Go to the appropriate faultcode troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Apr-2021


FAULT CODE 151 - Engine Coolant Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K105 | 4326157
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK50 CM2350 K108 | 4332823
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K116 | 4367444
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K117 | 4367449
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F117 | 4388578
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L107 | 4367386
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2250 B128 | 4388601
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B130 | 4388668
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L118 | 4388673
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F118 | 4388708
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F119 | 4388703
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B122 | 4388767
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2250 B131 | 4388774
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB3.3 CM2250 B137 | 5411058
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB6.7 CM2350 B142 | 5411131
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F126 | 5411159
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B121B | 5411223
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F120B | 5411237
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L116B | 5411330
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B129B | 5411247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B147B | 5411252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B135B | 5411257
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B148B | 5411262
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L119B | 5411267
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB6.7 CM2350 B145 | 5411273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2350 L122 | 5411278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSB4.5 CM2350 B144 | 5411382
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L123B | 5411465
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F124 | 5411484
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF3.8 CM2350 F125 | 5411494
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSF2.8 CM2880 F131 | 5411489
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISF2.8 CM2220 F122 | 5467376
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F132B | 5467327
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | R2.8 CM2220 R101B | 5467556
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | ISB5.9 CM2880 B110 | 4332883
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B6.7 CM2350 B136C | 5504194
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | L9 CM2350 L120C | 5504199
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F133C | 5504278
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2350 F128C | 5504273
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | B4.5 CM2350 B146C | 5504283
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F135B | 5504616
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F2.8 CM2620 F136B | 5504621
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F3.8 CM2620 F137B | 5579517
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | F4.5 CM2620 F139B | 5579522
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X125M | 5504345
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K114 | 5579623
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Does the temperature sensor reading with the recommended Cummins® electronic service tool, or equivalent, correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use the electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with the electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with the electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Repair

Refer to the Engine Coolant Temperature Above Normal troubleshooting symptom tree in Section TS.

Repair

Replace the coolant temperature sensor.

Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 153 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSM11 CM876 M101 | 5504547
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISV5.0 CM3230 V104 | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F132B | 5467327
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | R2.8 CM2220 R101B | 5467556
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B110 | 4332883
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B136C | 5504194
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L120C | 5504199
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F133C | 5504278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B146C | 5504283
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F135B | 5504616
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F136B | 5504621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2620 F137B | 5579517
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F4.5 CM2620 F139B | 5579522
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X125M | 5504345

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 153 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 154 active and Fault Code 153 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 153 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold air temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the engine harness intake manifold air temperature sensor connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold air temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for QSK78, QSK23, and ISV5.0 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all other engines. Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold air temperature sensor SIGNAL pin and intake manifold air temperature sensor RETURN pin at the ECM connector.

Refer to the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active and Fault Code 153 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor RETURN pin and the engine harness intake manifold air temperature sensor connector RETURN pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector intake manifold air temperature sensor SIGNAL pin and the engine harness intake manifold air temperature sensor connector SIGNAL pin.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold air temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Apr-2019


FAULT CODE 154 - Intake Manifold 1 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4327291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | ISV5.0 CM3230 V104 | 4367291
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Air Manifold Temperature Sensor | Refer to Procedure 019-059 | QSM11 CM876 M101 | 5504547
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X114B | 5411181
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X116B | 5411186
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B121B | 5411223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L116B | 5411330
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L123B | 5411465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F132B | 5467327
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | R2.8 CM2220 R101B | 5467556
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B110 | 4332883
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B136C | 5504194
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L120 | 5504199
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F133C | 5504278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B146C | 5504283
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F135B | 5504616
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F136B | 5504621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2620 F137B | 5579517
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F4.5 CM2620 F139B | 5579522
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X125M | 5504345

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 2. | Check the intake manifold air temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold air temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 154 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 153 active and Fault Code 154 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 154 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine intake manifold air temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold air temperature sensor.

  • Use the following procedure for ISV5.0 and QSK78 engines. Refer to Procedure 019-059 in the Associated Procedures Table.
  • Use the following procedure for all engines except IISV5.0 and QSK78. Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 153 active and Fault Code 154 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the intake manifold air temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 154 inactive?
YES NO

Repair

The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 10-Apr-2019


FAULT CODE 155 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK78 CM2250 K104 | 4332682
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK23 CM2250 K109 | 4367358
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSK60 CM2250 K112 | 4367454
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | ISM and QSM11 CM570 | 3666266
Intake Manifold Air Temperature Sensor | Refer to Procedure 019-059 | QSM11 CM876 | 5504547
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 SN | 4022190
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISM11 CM876 SN | 4022196
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISZ13 CM2150 | 4022133
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2250 | 4022254
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISC8.3 and ISL9 CM2250 | 4022257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 GX CM2250 | 4022250
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12/ISX11.9 CM2250 | 2883445
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 | 4022256
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 | 4022255
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 EC | 2883621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | Marine QSB6.7 CM2250 | 4310611
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX11.9 CM2250 ECF | 2883561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 ECF | 2883557
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 ECF | 4310661
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | PowerGen QSX15 CM2250 | 4310664
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 EC | 2883647
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B101 | 2883567
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L101 | 4310787
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX12 X101 | 4310646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 X101 | 4310641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F101 | 4310846
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISX15 CM2250 SN | 4310736
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F103 | 4310839
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB4.5 CM2350 B104 | 4332646
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B103 | 4332641
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD4.5 CM2150 B119 | 4358465
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB/ISD6.7 CM2150 B120 | 4358470
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL8.9 CM2150 L110 | 4358475
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2220 F110 | 4358480
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 M CM2250 L106 | 4358343
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISL9 CM2350 L111 | 4367223
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z101 | 4358364
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSZ13 CM2150 Z102 | 4358369
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F105 | 4358561
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF3.8 CM2350 F109 | 4367218
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F117 | 4388578
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2250 B128 | 4388601
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2250 L115 | 4388626
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB6.7 CM2350 B142 | 5411131
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2250 B131 | 4388774
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB3.3 CM2250 B137 | 5411058
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F126 | 5411159
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2250 X115 | 4388739
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F120B | 5411237
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B129B | 5411247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B147B | 5411252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B135B | 5411257
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B6.7 CM2350 B148B | 5411262
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | L9 CM2350 L119B | 5411267
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF2.8 CM2880 F124 | 5411484
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISF2.8 CM2220 F122 | 5467376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F132B | 5467327
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | R2.8 CM2220 R101B | 5467556
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | ISB5.9 CM2880 B110 | 4332883
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F133C | 5504278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | B4.5 CM2350 B146C | 5504283
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F135B | 5504616
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F2.8 CM2620 F136B | 5504621
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2620 F137B | 5579517
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F4.5 CM2620 F139B | 5579522
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X125M | 5504345

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Repair

Refer to the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in the appropriate service manual.

Repair

Replace the intake manifold air temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Replace the intake manifold air temperature sensor for the following engines. Refer to Procedure 019-059 in the Associated Procedures Table.

  • QSK78 CM2250 K104
  • QSK23 CM2250 K109
  • QSK60 CM2250 K112
  • ISM and QSM11 CM570.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2019


FAULT CODE 156 - Intake Manifold 2 Temperature Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 157 active and Fault Code 156 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 156 is active?
STEP 3. | Check the ECM and engine wiring harness. |
 | STEP 3A. Inspect the ECM and engine wiring harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 157 active and Fault Code 156 inactive?
 | STEP 3C. Check for an open circuit in the engine wiring harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine wiring harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 156 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 air temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 air temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 air temperature sensor from the engine wiring harness.

Action

Inspect the engine wiring harness and intake manifold 2 temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or wiring harness connector.

Clean the connector and pins.

Repair the damaged wiring harness, connector, or pins, if possible.

Check all wiring harnesses connected in series.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine wiring harness
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 air temperature sensor SIGNAL pin and intake manifold 2 air temperature sensor RETURN pin at the engine wiring harness intake manifold 2 air temperature sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Fault Code 157 active and Fault Code 156 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 air temperature sensor connector to the engine wiring harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 is active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold 2 pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine wiring harness.

Guided Step 3A - Inspect the ECM and engine wiring harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the engine control module.

Action

Inspect the engine wiring harness and engine control module connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Dirt or debris in or on the connector pins
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab .

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine wiring harness connector.

Clean the connector and pins.

Repair the damaged wiring harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold 2 air temperature sensor SIGNAL pin and the intake manifold 2 air temperature sensor RETURN pin at the ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 active and Fault Code 156 inactive?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM connector.
  • Disconnect the intake manifold 2 temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine wiring harness ECM connector intake manifold 2 air temperature sensor RETURN pin and the engine wiring harness connector intake manifold 2 air temperature RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open intake manifold 2 temperature RETURN circuit has been detected in the engine wiring harness.

Troubleshoot all wiring harnesses connected in series to determine which contains the open circuit.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.
  • Disconnect the intake manifold 2 air temperature sensor connector from the engine wiring harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine wiring harness ECM connector intake manifold 2 air temperature SIGNAL pin and the engine wiring harness connector intake manifold 2 temperature SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Troubleshoot each wiring harness connected in series to determine which contains the open circuit.

Repair or replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness from the ECM connector.
  • Disconnect the intake manifold 2 air temperature sensor connector from the engine wiring harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature SIGNAL pin in the engine wiring harness ECM connector and all other pins in the engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine wiring harness.

Troubleshoot each wiring harness connected in series to determine which contains the short circuit.

Repair or replace the engine wiring harness.

Refer to Procedure 019-043 in the Associated Procedures Table..

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Go to 1A
Escalate or call for assistance.

Last Modified: 27-Apr-2020


FAULT CODE 157 - Intake Manifold 2 Temperature Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module (ECM) | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 2. | Check the intake manifold 2 temperature sensor and circuit. |
 | STEP 2A. Inspect the intake manifold 2 temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 157 is active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 156 active and Fault Code 157 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 157 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold 2 temperature sensor and circuit.

Guided Step 2A - Inspect the intake manifold 2 temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.

Action

Inspect the engine harness and temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Check all harnesses connected in series.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 temperature sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 temperature sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 157 is active?
YES NO

Repair

A damaged intake manifold 2 temperature sensor has been detected.

Replace the intake manifold 2 temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.
  • Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 156 active and Fault Code 157 inactive?
YES NO
No Repair

Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the intake manifold 2 temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the intake manifold 2 temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine intake manifold 2 temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between intake manifold 2 temperature SIGNAL pin in the engine harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector and pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the intake manifold 2 temperature SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Sep-2014


FAULT CODE 158 - Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Monitor intake manifold 2 air temperature reading.

Guided Step 1A - Monitor intake manifold 2 air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Does the temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Repair

Reference the Intake Manifold Air Temperature Above Specification symptom tree in the appropriate service manual.

Repair

Replace the intake manfiold pressure/temperature sensor.

Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 197 - Coolant Level - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B101 | 2883567
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L101 | 4310787
Cooling System | Refer to Procedure 008-018 | ISL9 CM2350 L111 | 4367223
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | ISX15 CM2250 SN | 4310736
Cooling System | Refer to Procedure 008-018 | ISB4.5 CM2350 B104 | 4332646
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B103 | 4332641
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K105 | 4326157
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K108 | 4332823
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K116 | 4367444
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K111 | 4358519
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | ISV5.0 CM3230 V104 | 4367291
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K117 | 4367449
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K121 | 4388645
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | ISB6.7 CM2350 B142 | 5411131
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X116B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L116B | 5411330
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B129B | 5411247
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B147B | 5411252
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B135B | 5411257
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B148B | 5411262
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L119B | 5411267
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L123B | 5411465
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | F3.8 CM2350 F132B | 5467327
Cooling System | Refer to Procedure 008-018 | ISB5.9 CM2880 B110 | 4332883
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B136C | 5504194
Cooling System | Refer to Procedure 008-018 | F3.8 CM2350 F133C | 5504278
Cooling System | Refer to Procedure 008-018 | F3.8 CM2350 F128C | 5504273
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B146C | 5504283
Cooling System | Refer to Procedure 008-018 | QSM11 CM876 M101 | 5504547
Cooling System | Refer to Procedure 008-018 | F3.8 CM2620 F137B | 5579517
Cooling System | Refer to Procedure 008-018 | F4.5 CM2620 F139B | 5579522
Cooling System | Refer to Procedure 008-018 | QSM11 CM876 M102M | 5504542
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K114 | 5579623
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K146G | 5612932
Cooling System | Refer to Procedure 008-018 | QSK38 CM2350 K145G | 5612927
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 197. | Active or inactive counts of Fault Code 197?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 197.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for fault codes.

  • Use the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 197?
YES NO

Repair

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

See the Coolant Loss symptom troubleshooting tree in Section TS.

If Fault Code 197 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

If the vehicle is equipped with dual coolant level sensors, Fault Code 197 will set for the lowest mounted coolant level sensor in the tank. Only replace the lowest mounted coolant level sensor.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify all steps have been completed. If all steps have been completed, follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 16-Jun-2021


FAULT CODE 212 - Engine Oil Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM3250 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M102M | 5504542
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M102M | 5504542
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISM11 CM876 SN | 4022196
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 ECF | 2883557
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K116 | 4367444
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K117 | 4367449
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K111 | 4358519
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK23 CM2250 K109 | 4367358
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2250 K112 | 4367454
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 X115 | 4388739
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X125M | 5504345
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | Z14 CM2670 Z103B | 5504577
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | QSM11 CM876 M101 | 5504547
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | QSM11 CM876 M102M | 5504542

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Between 180 ohms to 160k ohms?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 212 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 213 active and Fault Code 212 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 212 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent or inactive fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the original equipment manufacturer (OEM) wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check the sensor resistance.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the engine oil temperature sensor.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 180 ohms to 160k ohms?
YES NO
No Repair

Repair

Replace the engine oil temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Use the following procedure for the QSM11 CM876 M101 and QSM11 CM876 M102M engines. Refer to Procedure 019-155 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 is active?
YES NO
No Repair

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine oil temperature sensor SIGNAL pin and the engine oil temperature sensor RETURN pin at the ECM connector.

See the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active and Fault Code 212 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor RETURN pin and the engine harness engine oil temperature sensor connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine oil temperature sensor SIGNAL pin and the engine harness engine oil temperature sensor connector SIGNAL pin.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signalcircuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 1A

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Jun-2019


FAULT CODE 213 - Engine Oil Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSL9 CM2250 L115 | 4388626
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK60 CM2350 K121 | 4388645
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2250 X115 | 4388739
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X114B | 5411181
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X116B | 5411186
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2350 G113 | 5467252
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSX15 CM2350 X118 | 5467247
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M101 | 5504547
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | X15 CM2350 X125M | 5504345
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 X101 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISM11 CM876 SN | 4022196
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISZ13 CM2150 | 4022133
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 GX CM2250 | 4022250
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12/ISX11.9 CM2250 | 2883445
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 ECF | 2883557
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX11.9 CM2250 ECF | 2883561
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX12 CM2350 X102 | 4310646
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2350 X101 | 4310641
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | ISX15 CM2250 SN | 4310736
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK95 CM2350 K111 | 4358519
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z101 | 4358364
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSZ13 CM2150 Z102 | 4358369
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G110 | 4367323
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K116 | 4367444
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2350 K117 | 4367449
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK23 CM2250 K109 | 4367358
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSK60 CM2250 K112 | 4367454
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2250 X115 | 4388739
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X114B | 5411181
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X116B | 5411186
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSG12 CM2350 G113 | 5467252
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | QSX15 CM2350 X118 | 5467247
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | X15 CM2350 X125M | 5504345
Engine Oil Temperature Sensor | Refer to Procedure 019-067 | Z14 CM2670 Z103B | 5504577
Oil Pressure/Temperature Sensor | Refer to Procedure 019-155 | QSM11 CM876 M101 | 5504547

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault code. | Fault Code 213 inactive?
STEP 2. | Check the engine oil temperature sensor and circuit. |
 | STEP 2A. Inspect the engine oil temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor resistance. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 213 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 212 active and Fault Code 213 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 145 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for intermittent and inactive fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine oil temperature sensor and circuit.

Guided Step 2A - Inspect the engine oil temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Inspect the engine harness and engine oil temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine oil temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant temperature sensor. Refer to Procedure 019-067 in the Associated Procedures Table.

Refer to Procedure 019-019 in the Associated Procedures Table.

Use the following procedure for the QSM11 CM876 M101. Refer to Procedure 019-155 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Wire insulation damage
  • Connector shell broken
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 212 active and Fault Code 213 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

High resistance or a short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the engine oil temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine oil temperature sensor SIGNAL pin in the engine harness ECM connector and ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 213 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number is found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-May-2019


FAULT CODE 214 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 214. | Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 214.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 214 active or inactive with more than one count logged in the last 25 hours?
YES | NO
No Repair | No Repair

See the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2021


FAULT CODE 235 - Coolant Level - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System | Refer to Procedure 008-018 | ISX12 CM2350 X102 | 4310646
Cooling System | Refer to Procedure 008-018 | ISX15 CM2350 X101 | 4310641
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K105 | 4326157
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B105 | 4332778
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L102 | 4332796
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K108 | 4332823
Cooling System | Refer to Procedure 008-018 | QSK95 CM2350 K111 | 4358519
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B112 | 4358498
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z101 | 4358364
Cooling System | Refer to Procedure 008-018 | QSZ13 CM2150 Z102 | 4358369
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F105 | 4358561
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F107 | 4367316
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K116 | 4367444
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B106 | 4367376
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G110 | 4367323
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K117 | 4367449
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F114 | 4383734
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L107 | 4367386
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B130 | 4388668
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L118 | 4388673
Cooling System | Refer to Procedure 008-018 | QSK60 CM2350 K121 | 4388645
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F119 | 4388703
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F118 | 4388708
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B122 | 4388767
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2250 B131 | 4388774
Cooling System | Refer to Procedure 008-018 | QSB3.3 CM2250 B137 | 5411058
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411181
Cooling System | Refer to Procedure 008-018 | X15 CM2350 X114B | 5411186
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B121B | 5411223
Cooling System | Refer to Procedure 008-018 | QSB4.5 CM2350 B144 | 5411382
Cooling System | Refer to Procedure 008-018 | QSB6.7 CM2350 B145 | 5411273
Cooling System | Refer to Procedure 008-018 | QSL9 CM2350 L122 | 5411278
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F124 | 5411484
Cooling System | Refer to Procedure 008-018 | QSF2.8 CM2880 F131 | 5411489
Cooling System | Refer to Procedure 008-018 | QSX15 CM2350 X118 | 5467247
Cooling System | Refer to Procedure 008-018 | QSG12 CM2350 G113 | 5467252
Cooling System | Refer to Procedure 008-018 | QSF3.8 CM2350 F125 | 5411494
Cooling System | Refer to Procedure 008-018 | B6.7 CM2350 B136C | 5504194
Cooling System | Refer to Procedure 008-018 | L9 CM2350 L120C | 5504199
Cooling System | Refer to Procedure 008-018 | F3.8 CM2350 F133C | 5504278
Cooling System | Refer to Procedure 008-018 | F3.8 CM2350 F128C | 5504273
Cooling System | Refer to Procedure 008-018 | B4.5 CM2350 B146C | 5504283
Cooling System | Refer to Procedure 008-018 | QSM11 CM876 M101 | 5504547
Cooling System | Refer to Procedure 008-018 | QSM11 CM876 M102M | 5504542
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K114 | 5579623
Cooling System | Refer to Procedure 008-018 | QSK50 CM2350 K146G | 5612932
Cooling System | Refer to Procedure 008-018 | QSK19 CM2350 K144G | 5612922
Cooling System | Refer to Procedure 008-018 | QSK38 CM2350 K145G | 5612932

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 235. | Active or inactive counts of Fault Code 235?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 235.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for fault codes.

  • Use the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 235?
YES NO

Repair

Add coolant to the engine. Refer to Procedure 008-018 in the Associated Procedures Table.

If Fault Code 235 is active and the coolant level is not low, a malfunctioning coolant level sensor is a likely cause. See equipment manufacturer service information before replacing the coolant level sensor.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 1A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 238 - Sensor Supply 3 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | D6.7 CM2670 D102B | 5504515
Engine Control Module | Refer to Procedure 019-031 | B6.2 CM2670 B156B | 5579510
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M102M | 5504542
Engine Control Module | Refer to Procedure 019-031 | X12 CM2670 X121B | 5504455
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | L9 CM2670 L128B | 5504589
Engine Position Sensor (EPS) | Refer to Procedure 019-038 | QSM11 CM876 M102M | 5504542
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | D6.7 CM2670 D102B | 5504515
Engine Wiring Harness | Refer to Procedure 019-043 | B6.2 CM2670 B156B | 5579510
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M102M | 5504542
Engine Wiring Harness | Refer to Procedure 019-043 | X12 CM2670 X121B | 5504455
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2670 L128B | 5504589
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K117 | 4367449
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | R2.8 CM2220 R101B | 5467556
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F132B | 5467327
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B110 | 4332883
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B136C | 5504194
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L120C | 5504199
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F133C | 5504278
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F128C | 5504273
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B146C | 5504283
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSM11 CM876 M101 | 5504547
Crankshaft Position Sensor | Refer to Procedure 019-365 | F2.8 CM2620 F135B | 5504616
Crankshaft Position Sensor | Refer to Procedure 019-365 | F2.8 CM2620 F136B | 5504621
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2620 F137B | 5579517
Crankshaft Position Sensor | Refer to Procedure 019-365 | F4.5 CM2620 F139B | 5579522
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X125M | 5504345
Crankshaft Position Sensor | Refer to Procedure 019-365 | Z14 CM2670 Z103B | 5504577
Crankshaft Position Sensor | Refer to Procedure 019-365 | D6.7 CM2670 D102B | 5504515
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.2 CM2670 B156B | 5579510
Crankshaft Position Sensor | Refer to Procedure 019-365 | X12 CM2670 X121B | 5504455
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K114 | 5579623
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2670 L128B | 5504589

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 238 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the engine position sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 238 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 238 active?
STEP 4. | Check ECM calibration and clear the fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the engine position sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO
No Repair

Repair

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.
  • Use the following procedure for the QSM11 CM876 M102M, Bulletin 5504542. Refer to Procedure 019-038 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 238 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 22-Aug-2019


FAULT CODE 239 - Sensor Supply 3 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 L121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F134B | 5504165
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M102M | 5504542
Engine Control Module | Refer to Procedure 019-031 | D6.7 CM2670 D102B | 5504515
Engine Control Module | Refer to Procedure 019-031 | B6.2 CM2670 B156B | 5579510
Engine Control Module | Refer to Procedure 019-031 | X12 CM2670 X121B | 5504455
Engine Control Module | Refer to Procedure 019-031 | L9 CM2670 L128B | 5504589
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 L121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F134B | 5504165
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M102M | 5504542
Engine Wiring Harness | Refer to Procedure 019-043 | D6.7 CM2670 D102B | 5504515
Engine Wiring Harness | Refer to Procedure 019-043 | B6.2 CM2670 B156B | 5579510
Engine Wiring Harness | Refer to Procedure 019-043 | X12 CM2670 X121B | 5504455
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2670 L128B | 5504589

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 239 active?
STEP 2. | Check the engine control module (ECM). |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 239 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM).

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector.
  • Corroded pins.
  • Bent or broken pins.
  • Pushed back or expanded pins.
  • Moisture in or on the connector.
  • Missing or damaged connector seals.
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage.
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 239 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 3 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 15-Aug-2019


FAULT CODE 245 - Fan Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60.8 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X105 | 4332667
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X106 | 4332712
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5411484
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 245 active?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an internal short in the fan control solenoid. | Within the original equipment manufacturer (OEM) resistance specification?
 | STEP 2B-1. Check for a pin-to-ground short circuit in the fan control solenoid. |
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage and SUPPLY wire. | Greater than 5 VDC?
STEP 3. | Check the ECM and OEM harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-ground short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 245 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an internal short in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for low internal resistance of the fan control solenoid.

  • Use a multimeter to measure the resistance between the SIGNAL and RETURN pin of the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

See equipment manufacturer service information.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Within the original equipment manufacturer (OEM) resistance specification?
YES NO
No Repair

Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2B-1

Go to 4A

Guided Step 2B-1 - Check for a pin-to-ground short circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit on one connector.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL connector pin and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the fan control solenoid. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage and SUPPLY wire.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and supply line.

  • Measure the voltage between the fan control SIGNAL pin and the fan control RETURN pin at the OEM harness actuator connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-ground short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the fan control SIGNAL pin of the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 245 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2019


FAULT CODE 285 - SAE J1939 Multiplexing PGN Timeout Error - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM11 CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSL60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for engine control module (ECM) communication with the recommended Cummins® electronic service tool, or equivalent. |
 | STEP 1A. Check for ECM communication with the electronic service tool. | Communication between the electronic service tool and the ECM possible?
STEP 2. | Check the fault codes. |
 | STEP 2A. Check for an active fault code. | Fault Code 285 active?
STEP 3. | Check the equipment manufacturer service information, vehicle electronic control unit (VECU), and engine ECM for proper multiplexing configuration. |
 | STEP 3A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration. | Does the ECM multiplexing configuration match the original equipment manufacturer (OEM) VECU multiplexing configuration?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for ECM communication with the electronic service tool.

Guided Step 1A - Check for ECM communication with the electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Verify the electronic service tool communication with the ECM.

Communication between the electronic service tool and the ECM possible?
YES NO
No Repair

Repair

A communication issue between the ECM and the data link, a damaged ECM, or an incorrect calibration is causing the fault code.

See the appropriate ECM - No Communication troubleshooting symptom tree in Section TT.

Go to 2A

Go to 4A

Guided Step 2 - Check the fault codes.

Guided Step 2A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 285 active?
YES | NO
No Repair | No Repair

Go to 3A

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 3 - Check the equipment manufacturer service information, VECU, and engine ECM for proper multiplexing configuration.

Guided Step 3A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the engine ECM and compare to the engine ECM configuration.

Conditions

  • Determine proper original equipment manufacturer (OEM) VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Use the electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the engine ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

See Service Bulletin, Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

Does the ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the equipment manufacturer service information. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 286 - J1939 Network #1 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 286 active?
STEP 2. | Check the original equipment manufacturer (OEM) vehicle electronic control unit (VECU) and engine control module (ECM) for proper multiplexing configuration. |
 | STEP 2A. Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration. | ECM multiplexing configuration match the OEM VECU multiplexing configuration?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 286 active?
YES NO
No Repair

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Go to 2A

Repair Complete

Guided Step 2 - Check the OEM VECU and ECM for proper multiplexing configuration.

Guided Step 2A - Determine which VECU multiplexed components (switches, accelerators, or sensors) are enabled for multiplexing over the J1939 data link to the ECM and compare to the ECM configuration.

Conditions

  • Determine proper OEM VECU multiplexing configuration component enables and OEM VECU source addresses from the appropriate OEM information, or from a saved job image.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Use the electronic service tool SAE J1939 Multiplexed Fault Data, located in Advanced ECM data, to determine which multiplexed component is causing the fault. If the status column indicates " Active" for a multiplexed component, check that the ECM multiplexed component enables and source addresses match the OEM VECU multiplexed component enables and source addresses. These components can be found under SAE J1939 Multiplexing in Features and Parameters.

See Service Bulletin, Multiplexing Troubleshooting, Bulletin 4021378, for OEM specific multiplexing configuration information.

ECM multiplexing configuration match the OEM VECU multiplexing configuration?
YES NO

Repair

An OEM issue has been detected.

Contact the OEM for further repair instructions. It is still possible that there is a VECU, VECU setup, or VECU to data link connection issue.

Repair

An incorrect setup has been detected in the Cummins® ECM.

Enable the proper components for multiplexing on the applicable OEM application and make sure the OEM VECU source addresses for each component are correct.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Dec-2021


FAULT CODE 415 - Engine Oil Rifle Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 415?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.
  • Engine running at idle speed.

Action

Check the fault codes.

  • Use the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 415?
YES NO

Repair

Low engine oil pressure has been detected.

See the Lubricating Oil Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2021


FAULT CODE 421 - Engine Oil Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 421. | Active or inactive counts of Fault Code 421?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 421.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for fault codes.

  • Use the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 421?
YES | NO
No Repair | No Repair

See the Lubricating Oil Temperature Above Specification troubleshooting symptom tree in Section TS of the appropriate service manual.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Jan-2021


FAULT CODE 442 - Battery 1 Voltage - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 442 active?
STEP 2. | Check the battery system. |
 | STEP 2A. Check the battery connection. | Batteries connected properly for the system voltage required?
 | STEP 2B. Check the alternator. | Alternator charging within equipment manufacturers specifications?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Read the fault codes.

  • Start the engine and idle for 1 minute.
  • Use the electronic service tool to read the fault codes.

Fault Code 442 active?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3B

Guided Step 2 - Check the battery system.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check to make sure batteries are installed correctly.

Batteries connected properly for the system voltage required?
YES NO
No Repair

Repair

Install the battery system correctly. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check the alternator.

Conditions

  • Turn keyswitch OFF.
  • Use an original equipment manufacturer (OEM) ammeter or install an ammeter between the alternator and the battery.

Action

Check the alternator.

  • Start the engine and check the alternator charging rate (amperes).

Place a load on the batteries, if necessary, to measure the alternator output properly.

Alternator charging within equipment manufacturers specifications?
YES NO
No Repair

Repair

Repair or replace the alternator, regulator, and/or the equipment manufacturers wiring to the alternator.

See equipment manufacturer service information.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2021


FAULT CODE 451 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 AN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B101 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L101 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358370
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358575
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358580
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | GSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | GSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 AN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B101 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L101 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | GSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | GSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2220 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 AN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 EC | 4310575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332687
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K105 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358570
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358575
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358580
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | GSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | R2.8 CM2220 R101B | 5467556
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F132B | 5467327
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB5.9 CM2880 B110 | 4332883
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B136C | 5504194
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L120C | 5504199
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F133C | 5504278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F128C | 5504273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F2.8 CM2620 F135B | 5504616
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F2.8 CM2620 F136B | 5504621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2620 F137B | 5579517
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F4.5 CM2620 F139B | 5579522
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X125M | 5504345
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K114 | 5579623
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K146G | 5612932
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test leadPart Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 or 515 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 451 inactive?
STEP 2. | Check the fuel rail pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel rail pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 452 active and Fault Code 451 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 451 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 386 or 515 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor and circuit.

Guided Step 2A - Inspect the fuel rail pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Place a jumper wire between the fuel rail pressure RETURN pin and the fuel rail pressure SIGNAL pin at the rail fuel pressure sensor connector of the engine harness.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Use the circuit diagram or the wiring diagram for connector pin identification.

Fault Code 452 active and Fault Code 451 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the fuel rail pressure 5 volt SUPPLY pin to the fuel rail pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel rail pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 451 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Place a jumper wire between the rail fuel pressure RETURN pin and the rail fuel pressure SIGNAL pin at the ECM engine connector.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Fault Code 452 active and Fault Code 451 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the signal line of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine harness connector.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-361 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 451 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Jun-2021


FAULT CODE 452 - Injector Metering Rail 1 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 ISF3.8 CM2220 IAN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISV5.0 CM3230 V104 | 4367291
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSK3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F116 | 4383664
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2220 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | IF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISV5.0 CM3230 V104 | 4367291
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSK3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F116 | 4383664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F105 | 4358561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F131 | 5411489
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F103 | 4310839
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5, ISB6.7, ISD4.5, and ISD6.7 CM2150 SN | 4022188
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 SN | 4022190
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISZ13 CM2150 | 4022133
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F101 | 4310846
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B105 | 4332778
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L102 | 4332796
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK78 CM2220 K104 | 4332682
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD4.5 CM2150 B119 | 4358465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB/ISD6.7 CM2150 B120 | 4358470
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL8.9 CM2150 L110 | 4358475
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F110 | 4358480
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z101 | 4358364
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSZ13 CM2150 Z102 | 4358369
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSb4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2350 F109 | 4367218
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISV5.0 CM3230 V104 | 4367291
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK23 CM2250 K109 | 4367358
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F114 | 4383734
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2250 K112 | 4367454
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F117 | 4388578
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF3.8 CM2220 F116 | 4383664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F126 | 5411159
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF2.8 CM2880 F124 | 5411484
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISF2.8 CM2220 F122 | 5467376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | R2.8 CM2220 R101B | 5467556
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F132B | 5467327
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB5.9 CM2880 B110 | 4332883
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B136C | 5504194
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L120C | 5504199
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F133C | 5504278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F128C | 5504273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F2.8 CM2620 F135B | 5504616
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F2.8 CM2620 F136B | 5504621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2620 F137B | 5579517
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F4.5 CM2620 F139B | 5579522
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X125M | 5504345
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K114 | 5579623
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K146G | 5612932
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164111 - male Bosch™ test lead, Part Number 3164110 - female Bosch™ test lead, Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead, and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 187 or 516 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 452 inactive?
STEP 2. | Check the rail fuel pressure sensor and circuit. |
 | STEP 2A. Inspect the rail fuel pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 451 active and Fault Code 452 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 452 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 187 or 516 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the rail fuel pressure sensor and circuit.

Guided Step 2A - Inspect the rail fuel pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.

Action

Inspect the engine harness and rail fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the rail fuel pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the rail fuel pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 452 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the rail fuel pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply and return circuit.

  • Measure the voltage from the rail fuel pressure 5 volt SUPPLY pin to the rail fuel pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 451 active and Fault Code 452 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 452 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 488 - Intake Manifold 1 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | VTA903 CM2250 V105 | 4332841
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B112 | 4358498
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B106 | 4367376
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F107 | 4367316
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 B2350 B105 | 4332778
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L102 | 4332796
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G110 | 4367323
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X105 | 4332667
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X106 | 4332712
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B130 | 4388668
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L118 | 4388673
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L107 | 4367386
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F118 | 4388708
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F119 | 4388703
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B122 | 4388767
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB6.7 CM2350 B145 | 5411273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSL9 CM2350 L122 | 5411278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSB4.5 CM2350 B144 | 5411382
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSX15 CM2350 X118 | 5467247
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSG12 CM2350 G113 | 5467252
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSF3.8 CM2350 F125 | 5411494
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F133C | 5504278
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | F3.8 CM2350 F128C | 5504273
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | X15 CM2350 X125M | 5504345

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor intake manifold air temperature reading. |
 | STEP 1A. Monitor intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor intake manifold air temperature reading.

Guided Step 1A - Monitor intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical gauge or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlates to a known value or a mechanical gauge?
YES NO

Repair

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS in the appropriate service manual.

Repair

Replace the intake manifold 1 temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Go to the appropriate troubleshooting symptom tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 10-Apr-2019


FAULT CODE 515 - Sensor Supply 6 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 | 4332796
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | D6.7 CM2670 D102B | 5504515
Engine Control Module | Refer to Procedure 019-031 | B6.2 CM2670 B156B | 5579510
Engine Control Module | Refer to Procedure 019-031 | X12 CM2670 X121B | 5504455
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | L9 CM2670 L128B | 5504589
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | D6.7 CM2670 D102B | 5504515
Engine Wiring Harness | Refer to Procedure 019-043 | B6.2 CM2670 B156B | 5579510
Engine Wiring Harness | Refer to Procedure 019-043 | X12 CM2670 X121B | 5504455
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2670 L128B | 5504589
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823996 - female Weather-Pack™ test lead and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 515 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 515 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 515 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 6 wire.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 516 - Sensor Supply 6 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | F4.5 CM2620 F139B | 5579522
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | D6.7 CM2670 D102B | 5504515
Engine Control Module | Refer to Procedure 019-031 | B6.2 CM2670 B156B | 5579510
Engine Control Module | Refer to Procedure 019-031 | X12 CM2670 X121B | 5504455
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | L9 CM2670 L128B | 5504589
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | D6.7 CM2670 D102B | 5504515
Engine Wiring Harness | Refer to Procedure 019-043 | B6.2 CM2670 B156B | 5579510
Engine Wiring Harness | Refer to Procedure 019-043 | X12 CM2670 X121B | 5504455
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2670 L128B | 5504589
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2250 | 4022254
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISC8.3 and ISL9 CM2250 | 4022257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 GX CM2250 | 4022250
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12/ISX11.9 CM2250 | 2883445
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 | 4022256
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 | 4022255
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 EC | 2883621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Marine QSB6.7 CM2250 | 4310611
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX11.9 CM2250 ECF | 2883561
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 ECF | 2883557
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 ECF | 4310661
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | PowerGen QSX15 CM2250 | 4310664
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 EC | 2883647
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B101 | 2883567
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L101 | 4310787
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX12 CM2350 X102 | 4310646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2350 X101 | 4310641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISX15 CM2250 SN | 4310736
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB4.5 CM2350 B104 | 4332646
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B103 | 4332641
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K105 | 4326157
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK50 CM2350 K108 | 4332823
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 M CM2250 L106 | 4358343
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | VTA903 CM2250 V105 | 4332841
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B112 | 4358498
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F107 | 4367316
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B106 | 4367376
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F120B | 5411237
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISL9 CM2350 L111 | 4367223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K116 | 4367444
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G110 | 4367323
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K117 | 4367449
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2250 B128 | 4388601
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2250 L115 | 4388626
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK60 CM2350 K121 | 4388645
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B130 | 4388668
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L118 | 4388673
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L107 | 4367386
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F118 | 4388708
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F119 | 4388703
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B122 | 4388767
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2250 B131 | 4388774
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB3.3 CM2250 B137 | 5411058
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X114B | 5411181
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X116B | 5411186
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B121B | 5411223
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | ISB6.7 CM2350 B142 | 5411131
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B129B | 5411247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B147B | 5411252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B135B | 5411257
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B148B | 5411262
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2250 X115 | 4388739
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L119B | 5411267
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L116B | 5411330
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB6.7 CM2350 B145 | 5411273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSL9 CM2350 L122 | 5411278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSB4.5 CM2350 B144 | 5411382
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L123B | 5411465
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSX15 CM2350 X118 | 5467247
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSG12 CM2350 G113 | 5467252
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSF3.8 CM2350 F125 | 5411494
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F132B | 5467327
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.7 CM2350 B136C | 5504194
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2350 L120C | 5504199
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F133C | 5504278
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2350 F128C | 5504273
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B4.5 CM2350 B146C | 5504283
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F2.8 CM2620 F135B | 5504616
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F2.8 CM2620 F136B | 5504621
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F3.8 CM2620 F137B | 5579517
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | F4.5 CM2620 F139B | 5579522
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X15 CM2350 X125M | 5504345
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | Z14 CM2670 Z103B | 5504577
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | D6.7 CM2670 D102B | 5504515
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | B6.2 CM2670 B156B | 5579510
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | X12 CM2670 X121B | 5504455
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K114 | 5579623
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | L9 CM2670 L128B | 5504589
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement; Part Number 3823995 - male WeatherPack™ test lead, Part Number 3823996 - female WeatherPack™ test lead, and Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 516 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply and return. |
 | STEP 2A. Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 516 active?
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 516 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 516 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply and return.

Guided Step 2A - Inspect the fuel rail pressure sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel rail pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the original equipment manufacturer (OEM) harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 516 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Apr-2021


FAULT CODE 689 - Engine Crankshaft Speed/Position - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | B6.7 CM2350 B136C | 5504194
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | L9 CM2350 L120C | 5504199
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | F3.8 CM2350 F133C | 5504278
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | F3.8 CM2350 F128C | 5504273
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | B4.5 CM2350 B146C | 5504283
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | F3.8 CM2620 F137B | 5579517
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | Z14 CM2670 Z103B | 5504577
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | X12 CM2670 X121B | 5504455
Crankshaft Speed Indicator Ring | Refer to Procedure 001-071 | L9 CM2670 L128B | 5504589
Camshaft Tone Wheel | Refer to Procedure 001-112 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B105 | 4332778
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L102 | 4332796
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F114 | 4383734
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Control Module | Refer to Procedure 019-031 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 SN | 4022190
Engine Control Module | Refer to Procedure 019-031 | ISM11 CM876 SN | 4022196
Engine Control Module | Refer to Procedure 019-031 | ISZ13 CM2150 | 4022133
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2250 | 4022254
Engine Control Module | Refer to Procedure 019-031 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 GX CM2250 | 4022250
Engine Control Module | Refer to Procedure 019-031 | ISX12/ISX11.9 CM2250 | 2883445
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 | 4022256
Engine Control Module | Refer to Procedure 019-031 | QSX11.9 CM2250 ECF | 2883561
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 ECF | 2883557
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Control Module | Refer to Procedure 019-031 | PowerGen QSX15 CM2250 | 4310664
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 | 4022255
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 EC | 2883621
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 EC | 2883647
Engine Control Module | Refer to Procedure 019-031 | Marine QSB6.7 CM2250 | 4310611
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B101 | 2883567
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L101 | 4310787
Engine Control Module | Refer to Procedure 019-031 | ISX12 CM2350 X102 | 4310646
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2350 X101 | 4310641
Engine Control Module | Refer to Procedure 019-031 | ISX15 CM2250 SN | 4310736
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F101 | 4310846
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F103 | 4310839
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F107 | 4367316
Engine Control Module | Refer to Procedure 019-031 | ISB4.5 CM2350 B104 | 4332646
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B103 | 4332641
Engine Control Module | Refer to Procedure 019-031 | QSK78 CM2250 K104 | 4332682
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Control Module | Refer to Procedure 019-031 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Control Module | Refer to Procedure 019-031 | ISL8.9 CM2150 L110 | 4358475
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2220 F110 | 4358480
Engine Control Module | Refer to Procedure 019-031 | QSL9 M CM2250 L106 | 4358343
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B112 | 4358498
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z101 | 4358364
Engine Control Module | Refer to Procedure 019-031 | QSZ13 CM2150 Z102 | 4358369
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F105 | 4358561
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B106 | 4367376
Engine Control Module | Refer to Procedure 019-031 | ISF3.8 CM2350 F109 | 4367218
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F120B | 5411237
Engine Control Module | Refer to Procedure 019-031 | ISL9 CM2350 L111 | 4367223
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G110 | 4367323
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK23 CM2250 K109 | 4367358
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2250 K112 | 4367454
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2250 B128 | 4388601
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2250 L115 | 4388626
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F117 | 4388578
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B130 | 4388668
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L118 | 4388673
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L107 | 4367386
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F118 | 4388708
Engine Control Module | Refer to Procedure 019-031 | QSF3.8 CM2350 F119 | 4388703
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B122 | 4388767
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F126 | 5411159
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2250 B131 | 4388774
Engine Control Module | Refer to Procedure 019-031 | QSB3.3 CM2250 B137 | 5411058
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X114B | 5411181
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X116B | 5411186
Engine Control Module | Refer to Procedure 019-031 | ISB6.7 CM2350 B142 | 5411131
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2250 X115 | 4388739
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L116B | 5411330
Engine Control Module | Refer to Procedure 019-031 | QSB6.7 CM2350 B145 | 5411273
Engine Control Module | Refer to Procedure 019-031 | QSL9 CM2350 L122 | 5411278
Engine Control Module | Refer to Procedure 019-031 | QSB4.5 CM2350 B144 | 5411382
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B121B | 5411223
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B129B | 5411247
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B147B | 5411252
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B135B | 5411257
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B148B | 5411262
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F124 | 5411484
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2880 F131 | 5411489
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L123B | 5411465
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L119B | 5411267
Engine Control Module | Refer to Procedure 019-031 | QSX15 CM2350 X118 | 5467247
Engine Control Module | Refer to Procedure 019-031 | QSG12 CM2350 G113 | 5467252
Engine Control Module | Refer to Procedure 019-031 | QSF2.8 CM2350 F125 | 5411494
Engine Control Module | Refer to Procedure 019-031 | ISF4.5 CM2220 F123 | 5411320
Engine Control Module | Refer to Procedure 019-031 | ISF2.8 CM2220 F122 | 5467376
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F132B | 5467327
Engine Control Module | Refer to Procedure 019-031 | R2.8 CM2220 R101B | 5467556
Engine Control Module | Refer to Procedure 019-031 | ISB5.9 CM2880 B110 | 4332883
Engine Control Module | Refer to Procedure 019-031 | B6.7 CM2350 B136C | 5504194
Engine Control Module | Refer to Procedure 019-031 | L9 CM2350 L120C | 5504199
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F133C | 5504278
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2350 F128C | 5504273
Engine Control Module | Refer to Procedure 019-031 | B4.5 CM2350 B146C | 5504283
Engine Control Module | Refer to Procedure 019-031 | QSM11 CM876 M101 | 5504547
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F135B | 5504616
Engine Control Module | Refer to Procedure 019-031 | F2.8 CM2620 F136B | 5504621
Engine Control Module | Refer to Procedure 019-031 | F3.8 CM2620 F137B | 5579517
Engine Control Module | Refer to Procedure 019-031 | X15 CM2350 X125M | 5504345
Engine Control Module | Refer to Procedure 019-031 | Z14 CM2670 Z103B | 5504577
Engine Control Module | Refer to Procedure 019-031 | X12 CM2670 X121B | 5504455
Engine Control Module | Refer to Procedure 019-031 | XQSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | L9 CM2670 L128B | 5504589
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Speed Sensor | Refer to Procedure 019-042 | KTA38GC CM558/CM2358 | 4021656
Engine Speed Sensor | Refer to Procedure 019-042 | G5.9, G8.3, G855, and GTA855 CM558/CM2358 | 4021702
Engine Speed Sensor | Refer to Procedure 019-042 | QSL9G CM558/CM2358 | 2883471
Engine Speed Sensor | Refer to Procedure 019-042 | KTA19GC CM558/CM2358 | 4021655
Engine Speed Sensor | Refer to Procedure 019-042 | QSK19G | 4021352
Engine Speed Sensor | Refer to Procedure 019-042 | GTA8.3 CM558/CM2358 | 4021654
Engine Speed Sensor | Refer to Procedure 019-042 | QSK23 CM2250 K109 | 4367358
Engine Speed Sensor | Refer to Procedure 019-042 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B105 | 4332778
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L102 | 4332796
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F114 | 4383734
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 SN | 4022190
Engine Wiring Harness | Refer to Procedure 019-043 | ISM CM876 SN | 4022196
Engine Wiring Harness | Refer to Procedure 019-043 | ISZ13 CM2150 | 4022133
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2250 | 4022254
Engine Wiring Harness | Refer to Procedure 019-043 | ISC8.3 and ISL9 CM2250 | 4022257
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 GX CM2250 | 4022250
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12/ISX11.9 CM2250 | 2883445
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 | 4022256
Engine Wiring Harness | Refer to Procedure 019-043 | QSX11.9 CM2250 ECF | 2883561
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 ECF | 2883557
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 ECF | 4310661
Engine Wiring Harness | Refer to Procedure 019-043 | PowerGen QSX15 CM2250 | 4310664
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 | 4022255
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 EC | 2883621
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 EC | 2883647
Engine Wiring Harness | Refer to Procedure 019-043 | Marine QSB6.7 CM2250 | 4310611
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B101 | 2883567
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L101 | 4310787
Engine Wiring Harness | Refer to Procedure 019-043 | ISX12 CM2350 X102 | 4310646
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2350 X101 | 4310641
Engine Wiring Harness | Refer to Procedure 019-043 | ISX15 CM2250 SN | 4310736
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F101 | 4310846
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F103 | 4310839
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F107 | 4367316
Engine Wiring Harness | Refer to Procedure 019-043 | ISB4.5 CM2350 B104 | 4332646
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B103 | 4332641
Engine Wiring Harness | Refer to Procedure 019-043 | QSK78 CM2250 K104 | 4332682
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD4.5 CM2150 B119 | 4358465
Engine Wiring Harness | Refer to Procedure 019-043 | ISB/ISD6.7 CM2150 B120 | 4358470
Engine Wiring Harness | Refer to Procedure 019-043 | ISL8.9 CM2150 L110 | 4358475
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2220 F110 | 4358480
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 M CM2250 L106 | 4358343
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B112 | 4358498
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z101 | 4358364
Engine Wiring Harness | Refer to Procedure 019-043 | QSZ13 CM2150 Z102 | 4358369
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F105 | 4358561
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B106 | 4367376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF3.8 CM2350 F109 | 4367218
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F120B | 5411237
Engine Wiring Harness | Refer to Procedure 019-043 | ISL9 CM2350 L111 | 4367223
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G110 | 4367323
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK23 CM2250 K109 | 4367358
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2250 K112 | 4367454
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2250 B128 | 4388601
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2250 L115 | 4388626
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F117 | 4388578
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B130 | 4388668
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L118 | 4388673
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L107 | 4367386
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F118 | 4388708
Engine Wiring Harness | Refer to Procedure 019-043 | QSF3.8 CM2350 F119 | 4388703
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B122 | 4388767
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F126 | 5411159
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2250 B131 | 4388774
Engine Wiring Harness | Refer to Procedure 019-043 | QSB3.3 CM2250 B137 | 5411058
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X114B | 5411181
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X116B | 5411186
Engine Wiring Harness | Refer to Procedure 019-043 | ISB6.7 CM2350 B142 | 5411131
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2250 X115 | 4388739
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L116B | 5411330
Engine Wiring Harness | Refer to Procedure 019-043 | QSB6.7 CM2350 B145 | 5411273
Engine Wiring Harness | Refer to Procedure 019-043 | QSL9 CM2350 L122 | 5411278
Engine Wiring Harness | Refer to Procedure 019-043 | QSB4.5 CM2350 B144 | 5411382
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B121B | 5411223
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B129B | 5411247
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B147B | 5411252
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B135B | 5411257
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B148B | 5411262
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F124 | 5411484
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2880 F131 | 5411489
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L123B | 5411465
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L119B | 5411267
Engine Wiring Harness | Refer to Procedure 019-043 | QSX15 CM2350 X118 | 5467247
Engine Wiring Harness | Refer to Procedure 019-043 | QSG12 CM2350 G113 | 5467252
Engine Wiring Harness | Refer to Procedure 019-043 | QSF2.8 CM2350 F125 | 5411494
Engine Wiring Harness | Refer to Procedure 019-043 | ISF2.8 CM2220 F122 | 5467376
Engine Wiring Harness | Refer to Procedure 019-043 | ISF4.5 CM2220 F123 | 5411320
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F132B | 5467327
Engine Wiring Harness | Refer to Procedure 019-043 | R2.8 CM2220 R101B | 5467556
Engine Wiring Harness | Refer to Procedure 019-043 | ISB5.9 CM2880 B110 | 4332883
Engine Wiring Harness | Refer to Procedure 019-043 | B6.7 CM2350 B136C | 5504194
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2350 L120C | 5504199
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F133C | 5504278
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2350 F128C | 5504273
Engine Wiring Harness | Refer to Procedure 019-043 | B4.5 CM2350 B146C | 5504283
Engine Wiring Harness | Refer to Procedure 019-043 | QSM11 CM876 M101 | 5504547
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F135B | 5504616
Engine Wiring Harness | Refer to Procedure 019-043 | F2.8 CM2620 F136B | 5504621
Engine Wiring Harness | Refer to Procedure 019-043 | F3.8 CM2620 F137B | 5579517
Engine Wiring Harness | Refer to Procedure 019-043 | F4.5 CM2620 F139B | 5579522
Engine Wiring Harness | Refer to Procedure 019-043 | X15 CM2350 X125M | 5504345
Engine Wiring Harness | Refer to Procedure 019-043 | Z14 CM2670 Z103B | 5504577
Engine Wiring Harness | Refer to Procedure 019-043 | X12 CM2670 X121B | 5504455
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | L9 CM2670 L128B | 5504589
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B105 | 4332778
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L102 | 4332796
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F114 | 4383734
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 E ISF2.8 CM2220 AN ISF2.8 CM2220 IAN | 4022178
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 AN ISF3.8 CM2220 IAN | 4021704
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5, ISB6.7, ISD4.5 and ISD6.7 CM2150 SN | 4022188
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 SN | 4022190
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISZ13 CM2150 | 4022133
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2250 | 4022254
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISC8.3 and ISL9 CM2250 | 4022257
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 GX CM2250 | 4022250
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12/ISX11.9 CM2250 | 2883445
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 | 4022256
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX11.9 CM2250 ECF | 2883561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 ECF | 2883557
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 ECF | 4310661
Crankshaft Position Sensor | Refer to Procedure 019-365 | PowerGen QSX15 CM2250 | 4310664
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 | 4022255
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 EC | 2883621
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 EC | 2883647
Crankshaft Position Sensor | Refer to Procedure 019-365 | Marine QSB6.7 CM2250 | 4310611
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B101 | 2883567
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L101 | 4310787
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX12 CM2350 X102 | 4310646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2350 X101 | 4310641
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISX15 CM2250 SN | 4310736
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F101 | 4310846
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F103 | 4310839
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F107 | 4367316
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB4.5 CM2350 B104 | 4332646
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B103 | 4332641
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD4.5 CM2150 B119 | 4358465
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB/ISD6.7 CM2150 B120 | 4358470
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL8.9 CM2150 L110 | 4358475
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2220 F110 | 4358480
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 M CM2250 L106 | 4358343
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B112 | 4358498
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z101 | 4358364
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSZ13 CM2150 Z102 | 4358369
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F105 | 4358561
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B106 | 4367376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF3.8 CM2350 F109 | 4367218
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F120B | 5411237
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISL9 CM2350 L111 | 4367223
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G110 | 4367323
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K116 | 4367444
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2250 B128 | 4388601
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2250 L115 | 4388626
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F117 | 4388578
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK60 CM2350 K121 | 4388645
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B130 | 4388668
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L118 | 4388673
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L107 | 4367386
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F118 | 4388708
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF3.8 CM2350 F119 | 4388703
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B122 | 4388767
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F126 | 5411159
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2250 B131 | 4388774
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB3.3 CM2250 B137 | 5411058
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X114B | 5411181
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X116B | 5411186
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB6.7 CM2350 B142 | 5411131
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2250 X115 | 4388739
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L116B | 5411330
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB6.7 CM2350 B145 | 5411273
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSL9 CM2350 L122 | 5411278
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSB4.5 CM2350 B144 | 5411382
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B121B | 5411223
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B129B | 5411247
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B147B | 5411252
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B135B | 5411257
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B148B | 5411262
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F124 | 5411484
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2880 F131 | 5411489
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L123B | 5411465
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L119B | 5411267
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSX15 CM2350 X118 | 5467247
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSG12 CM2350 G113 | 5467252
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSF2.8 CM2350 F125 | 5411494
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF2.8 CM2220 F122 | 5467376
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISF4.5 CM2220 F123 | 5411320
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F132B | 5467327
Crankshaft Position Sensor | Refer to Procedure 019-365 | R2.8 CM2220 R101B | 5467556
Crankshaft Position Sensor | Refer to Procedure 019-365 | ISB5.9 CM2880 B110 | 4332883
Crankshaft Position Sensor | Refer to Procedure 019-365 | B6.7 CM2350 B136C | 5504194
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2350 L120C | 5504199
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F133C | 5504278
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2350 F128C | 5504273
Crankshaft Position Sensor | Refer to Procedure 019-365 | B4.5 CM2350 B146C | 5504283
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSM11 CM876 M101 | 5504547
Crankshaft Position Sensor | Refer to Procedure 019-365 | F2.8 CM2620 F135B | 5504616
Crankshaft Position Sensor | Refer to Procedure 019-365 | F2.8 CM2620 F136B | 5504621
Crankshaft Position Sensor | Refer to Procedure 019-365 | F3.8 CM2620 F137B | 5579517
Crankshaft Position Sensor | Refer to Procedure 019-365 | F4.5 CM2620 F139B | 5579522
Crankshaft Position Sensor | Refer to Procedure 019-365 | X15 CM2350 X125M | 5504345
Crankshaft Position Sensor | Refer to Procedure 019-365 | Z14 CM2670 Z103B | 5504577
Crankshaft Position Sensor | Refer to Procedure 019-365 | X12 CM2670 X121B | 5504455
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K114 | 5579623
Crankshaft Position Sensor | Refer to Procedure 019-365 | L9 CM2670 L128B | 5504589
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 238 or 239 active?
 | STEP 1B. Check for an active fault code. | Fault Code 689 active or more than one inactive count within the last 25 engine hours?
STEP 2. | Check the engine speed sensor and connector. |
 | STEP 2A. Inspect the crankshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the crankshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the crankshaft position sensor circuit. |
 | STEP 3A. Check the crankshaft position sensor supply voltage and return circuit. | Between 4.75 VDC to 5.25 VDC?
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open crankshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Inspect the air gap and target wheel. |
 | STEP 3B-4. Check the fault code and verify the crankshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check the fault code and verify crankshaft position sensor condition. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 238 or 239 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

  • Use the electronic service tool to read the fault codes.

Fault Code 689 active or more than one inactive count within the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

No repair.

Guided Step 2 - Check the engine speed sensor and connector.

Guided Step 2A - Inspect the crankshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Inspect the engine harness and crankshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine speed sensor connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the crankshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Remove the crankshaft position sensor from the gear housing. Refer to Procedure 019-365 in the Associated Procedures Table.
  • Some natural gas engines are referenced as the engine speed sensor. Refer to Proceduere 019-042 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

Repair

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, inspect the crankshaft gear and related components.

  • Refer to Procedure 019-365 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the crankshaft position sensor circuit.

Guided Step 3A - Check the crankshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor 1 RETURN pin at the crankshaft position sensor connector of the engine wiring harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the crankshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the crankshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the crankshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Inspect the air gap and target wheel.

Conditions

  • Turn keyswitch OFF.

Action

  • Measure the air gap between the crankshaft position sensor and the tone wheel.
  • Refer to Procedure 001-071 in the Associated Procedures Table or Refer to Procedure 019-365 in the Associated Procedures Table.

Air gap within specifications?
YES NO
No Repair

Repair

Replace the component that is causing the out of specification reading.

Go to 3B-4

Go to 4A

Guided Step 3B-4 - Check the fault code and verify the crankshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Start the engine. Let it idle for 1 minute

Use the electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Repair

A damaged crankshaft position sensor has been detected.

Replace the crankshaft position sensor.

  • Refer to Procedure 019-365 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the crankshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the crankshaft position sensor +5 volt SUPPLY pin and the crankshaft position sensor RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC to 5.25 VDC?
YES NO

Repair

A damaged connection has been detected in the engine harness.

Repair or replace the damaged harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C-2

Guided Step 3C-2 - Check the fault code and verify crankshaft position sensor condition.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.
  • Use the electronic service tool to read the fault codes.

Fault Code 689 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2021


FAULT CODE 1636 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1636 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1637 active and Fault Code 1636 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1636 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active and Fault Code 1636 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the intake manifold pressure sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active and Fault Code 1636 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Sep-2015


FAULT CODE 1637 - Intake Manifold 2 Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1637 inactive?
STEP 2. | Check the intake manifold pressure sensor and circuit. |
 | STEP 2A. Inspect the intake manifold pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1636 active and Fault Code 1637 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1637 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the inactive fault codes.

Fault Code 1637 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intemittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the intake manifold pressure sensor and circuit.

Guided Step 2A - Inspect the intake manifold pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.

Action

Inspect the engine harness and intake manifold 2 pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold 2 pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the sensor connector of the engine harness.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the intake manifold 2 pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the intake manifold pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active and Fault Code 1637 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the intake manifold 2 pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the intake manifold pressure +5 volt SUPPLY pin to the intake manifold pressure RETURN pin at the ECM engine connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the intake manifold pressure +5 volt SUPPLY pin and the intake manifold pressure SIGNAL pin at the engine control module engine connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1636 active and Fault Code 1637 inactive?
YES NO
No Repair

Repair

Replace the ECM. Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1637 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 1847 - Engine Coolant Temperature - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK95 CM2350 K111 | 4358519
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSK23 CM2250 K109 | 4367358
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSG12 CM2880 G112 | 4388731
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M101 | 5504547
Engine Coolant Temperature Sensor | Refer to Procedure 019-019 | QSM11 CM876 M102M | 5504542

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor coolant temperature reading. |
 | STEP 1A. Monitor coolant temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor coolant temperature reading.

Guided Step 1A - Monitor coolant temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor the coolant temperature reading.

  • Use INSITE™ electronic service tool to monitor the coolant temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical guage or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical guage?
YES NO

Repair

Use the following troubleshooting symptom tree, Engine Coolant Temperature Above Normal, in Section TS of the appropriate service manual.

Repair

Replace the coolant temperature sensor. Refer to Procedure 019-019 in the Associated Procedures Table.

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to fin the present ECM code and revison number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found the the Overview section of this troubleshooting procedure.

Fault code inactive?
YES | NO
No Repair | No Repair

Repair complete

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Last Modified: 12-Jul-2019


FAULT CODE 1852 - Water in Fuel Indicator - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 1852?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for Fault Code 1852.

  • Use the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 1852?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion. Clean or replace the connector or sensor, as necessary.

No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check the ECM calibration and clear the fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 1984 - Intake Manifold 2 Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Monitor the intake manifold air temperature reading. |
 | STEP 1A. Monitor the intake manifold air temperature reading. | Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Monitor the intake manifold air temperature reading.

Guided Step 1A - Monitor the intake manifold air temperature reading.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Monitor intake manifold temperature reading.

  • Use INSITE™ electronic service tool to monitor the intake manifold air temperature value.
  • Compare the temperature reading with INSITE™ electronic service tool to a mechanical guage or a known value.

Temperature sensor reading with INSITE™ electronic service tool correlate to a known value or a mechanical gauge?
YES NO

Repair

See the Intake Manifold Air Temperature Above Specification troubleshooting symptom tree in Section TS of the appropriate service manual.

Repair

Replace the intake manifold 2 temperature sensor. Refer to Procedure 019-159 in the Associated Procedures Table.

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronics service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronics service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2661 - At Least One Unacknowledged Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive red lamp fault codes?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code? | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive red lamp fault codes?
YES NO

Repair

This is an information-only fault code that will only become active if other critical engine protection fault codes are active. This fault code will remain active until acknowledged using the original equipment manufacturer (OEM) supplied switch.

Troubleshoot all other red lamp fault codes.

Once all other red lamp fault codes are inactive, this fault code will remain inactive when acknowledged.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2A

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 04-Dec-2018


FAULT CODE 2662 - At Least One Unacknowledged Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Active or inactive amber lamp fault codes?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive amber lamp fault codes?
YES NO

Repair

This is an information-only fault code that will only become active if other moderate severity fault codes are active. This fault code will remain active until acknowledged using the original equipment manufacturer (OEM) supplied switch.

Troubleshoot all other amber lamp fault codes.

Once all other amber lamp fault codes are inactive, this fault code will remain inactive when acknowledged.

 No Repair

Reference the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 04-Dec-2018


FAULT CODE 4642 - Water-in-Fuel Indicator - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of pin and harness damage, use the following test lead when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Active or inactive counts of Fault Code 4642?
STEP 2. | Check the engine control module (ECM) calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 4642.

  • Use INSITE™ electronic service tool to read the faut codes.

Active or inactive counts of Fault Code 4642?
YES NO

Repair

Drain water from the fuel filter(s).

If the fault code persists, check the sensor and harness connector for water intrusion.

Clean or replace the connector or sensor, as necessary.

 No Repair

Go to 2A

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 26-Jun-2019


FAULT CODE 115 - Engine Magnetic Speed/Position Lost Both of Two Signals - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possibilty of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 115 active?
STEP 2. | Check the engine position sensor signal circuits. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open crankshaft position sensor signal circuit in the engine harness. | Less than 10 ohms?
 | STEP 2C. Check for an open camshaft position sensor signal circuit in the engine wiring harness. | Less than 10 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 115 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine position sensor signal circuits.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connection.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for an open crankshaft position sensor signal circuit in the engine wiring harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect engine crankshaft position sensor from the engine harness.
  • Disconnect the engine harness from the ECM connector.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the crankshaft position sensor SIGNAL pin at the crankshaft position sensor engine harness connector to the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

  • Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for an open camshaft position sensor signal circuit in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Nov-2015


FAULT CODE 195 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K105 | 4326157
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K108 | 4332823
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K116 | 4367444
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K111 | 4358519
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K121 | 4388645
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K114 | 5579623
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 195 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the OEM harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Conenct the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use the electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the engine coolant level sensor connector SIGNAL pin.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness form the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine coolant level SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal line has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2021


FAULT CODE 195 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K105 | 4326157
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K108 | 4332823
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K116 | 4367444
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K117 | 4367449
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K111 | 4358519
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K121 | 4388645
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K114 | 5579623
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response | Fault Code 196 active and Fault Code 195 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | Between 4.75 VDC and 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 195 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the OEM harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 195 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SIGNAL pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.
  • Use the electronic service tool to read the fault codes.

Fault Code 196 active and Fault Code 195 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75 VDC and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open return circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor RETURN pin and the OEM harness engine coolant level sensor connector RETURN pin.

Use a circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the signal line has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-pin sort circuit in the OEM harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SUPPLY pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the supply line has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness.

  • Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2021


FAULT CODE 196 (2-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K105 | 4326157
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K108 | 4332823
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K111 | 4358519
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K116 | 4367444
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K117 | 4367449
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K121 | 4388645
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K114 | 5579623
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To avoid pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 196 active?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 196 is active?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit to ground in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 196 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an appropriate ECM response after 1 minute.

  • Use the electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

Repair

A damaged engine coolant level sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the engine coolant level SIGNAL pin at the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit between pins has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance and check for a short circuit between the engine coolant level sensor SIGNAL pin at the OEM harness ECM connector and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit between pins has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use the electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2021


FAULT CODE 196 (3-Wire Sensor) - Coolant Level Sensor 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K105 | 4326157
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K108 | 4332823
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K111 | 4358519
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K116 | 4367444
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K117 | 4367449
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK60 CM2350 K121 | 4388645
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK19 CM2350 K114 | 5579623
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3164133 - male Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 2. | Check the engine coolant level sensor and circuit. |
 | STEP 2A. Inspect the engine coolant level sensor and electrical connections. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | Between 4.75 and 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 195 active and Fault Code 196 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 196 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit. | Greater than 100k ohms.
 | STEP 3F. Check for an inactive fault code. | Fault Code 196 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine coolant level sensor and circuit.

Guided Step 2A - Inspect the engine coolant level sensor and electrical connections.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Inspect the OEM harness and engine coolant level sensor connections for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the engine coolant level SUPPLY pin and the engine coolant level RETURN pin at the engine coolant level sensor connector of the OEM harness.

Use a wiring diagram for connector in identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 4.75 and 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant level sensor from the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the engine coolant level sensor SUPPLY pin and the engine coolant level sensor SIGNAL pin at the engine coolant level sensor connector of the OEM harness.

Use a circuit diagram or wiring diagram for connector pin identification.

Use the electronic service tool to read the fault codes.

Fault Code 195 active and Fault Code 196 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine coolant level sensor to the OEM harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 196 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine coolant level sensor. Refer to Procedure 019-017 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SUPPLY pin and the OEM harness engine coolant level sensor connector SUPPLY pin.

Use a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open supply circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector engine coolant level sensor SIGNAL pin and the OEM harness engine coolant level sensor connector SIGNAL pin.

Use a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the OEM harness ECM connector.

Use a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the engine coolant level sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use a circuit and wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the shorted signal circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 196 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Jan-2021


FAULT CODE 221 - Barometric Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK19 CM2350 K105 | 4326157
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK50 CM2350 K108 | 4332823
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK60 CM2350 K116 | 4367444
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK60 CM2350 K117 | 4367449
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK60 CM2350 K121 | 4388645
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK19 CM2350 K114 | 5579623
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK50 CM2350 K146G | 5612932
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK19 CM2350 K144G | 5612922
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 221 active?
STEP 2. | Check the barometric pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 222 active and Fault Code 221 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 221 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 221 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric air pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric air pressure sensor from the engine harness.

Action

Inspect the engine harness and barometric air pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric pressure RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 221 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 222 active and Fault Code 221 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 221 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 222 - Barometric Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK19 CM2350 K105 | 4326157
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK50 CM2350 K108 | 4332823
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK60 CM2350 K116 | 4367444
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK60 CM2350 K117 | 4367449
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK60 CM2350 K121 | 4388645
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK19 CM2350 K114 | 5579623
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK50 CM2350 K146G | 5612932
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK38 CM2350 K145G | 5612927
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK19 CM2350 K144G | 5612922
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 222 active?
STEP 2. | Check the barometric air pressure sensor and circuit. |
 | STEP 2A. Inspect the barometric air pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 221 active and Fault Code 222 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 222 active?
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect engine control module ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 222 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the barometric air pressure sensor and circuit.

Guided Step 2A - Inspect the barometric pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness.

Action

Inspect the engine harness connector and barometric pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure 5 volt SUPPLY pin to the barometric pressure RETURN (sensor RETURN 2) pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the barometric pressure +5 volt SUPPLY pin and the barometric air pressure SIGNAL pin at the barometric air pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the barometric pressure sensor connector to the engine harness connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 222 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the barometric pressure +5 volt SUPPLY pin to the barometric air pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Between 4.75 and 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the malfunction.

Repair

An open or shorted supply circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness connector and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible..

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the barometric pressure +5 volt SUPPLY (sensor SUPPLY 2) pin and the barometric pressure SIGNAL pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 221 active and Fault Code 222 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 222 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the malfunction.

Repair

An open or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 227 - Sensor Supply 2 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 227 active?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 227 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.

Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 227 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 2 wire.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 1A

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2019


FAULT CODE 228 - Coolant Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for fault code 228. | Active or inactive counts of Fault Code 228?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an engine control module (ECM) calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 228.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check the fault codes.

  • Use the electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 228?
YES | NO
No Repair | No Repair

See the Coolant Pressure Low troubleshooting symptom tree in Section TS of the appropriate service manual.

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Jan-2021


FAULT CODE 231 - Coolant Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QST30 CM2350 T101 | 5467179
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK50 CM2350 K146G | 5612932
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK38 CM2350 K145G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QST30 CM2350 T101 | 5467179
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QST30 CM2350 T101 | 5467179
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Coolant Pressure Sensor | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 231 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 232 active and Fault Code 231 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 231 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code

  • Use the electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for troubleshooting an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and coolant pressure sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant pressure sensor or harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use the electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY pin to the coolant pressure RETURN pin at the coolant pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the appropriate circuit response after 30 seconds

  • Use the electronic service tool to read the fault codes.

Fault Code 231 active?
YES NO

Repair

A damaged coolant pressure sensor has been detected.

  • Replace the coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use the electronic service tool to read the fault codes.

Fault Code 232 active and Fault Code 231 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short circuit.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY pin to the coolant pressure RETURN pin at the ECM engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 231 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open coolant pressure return circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 232 - Coolant Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK50 CM2350 K108 | 4332823
Coolant Pressure Sensor | Refer to Procedure 019-016 | VTA903 CM2250 V105 | 4332841
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK95 CM2350 K111 | 4358519
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 CM2350 K116 | 4367444
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 CM2350 K117 | 4367449
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 CM2350 K121 | 4388645
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK50 CM2350 K146G | 5612932
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | VTA903 CM2250 V105 | 4332841
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for inactive fault code. | Fault Code 232 inactive?
STEP 2. | Check the coolant pressure sensor and circuit. |
 | STEP 2A. Inspect the coolant pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 231 active and Fault Code 232 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 232 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the coolant pressure sensor and circuit.

Guided Step 2A - Inspect the coolant pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and coolant pressure sensor pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the coolant pressure sensor harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the coolant pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the coolant pressure sensor from the engine harness connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the circuit response.

Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the coolant pressure sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the coolant pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

Repair

A damaged coolant pressure sensor has been detected.

  • Replace the damaged coolant pressure sensor. Refer to Procedure 019-016 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the coolant pressure 5 volt SUPPLY (sensor supply 1) pin to the coolant pressure RETURN (sensor return 1) pin at the ECM 60 pin engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in Section 19.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 232 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted coolant pressure SUPPLY (sensor supply 1) circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the short or open circuit.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60-pin connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO
No Repair

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Check all harnesses connected in series.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM 60 pin connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the coolant pressure 5 volt SUPPLY (sensor supply 1) pin and the coolant pressure SIGNAL pin at the ECM 60 pin engine connector.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Fault Code 231 active and Fault Code 232 inactive?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 232 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the coolant pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in series.

  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 234 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Module Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR Cummins® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed exceeds 125 percent of rated speed, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring down hill, if applcable?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with the recommended Cummins® electronic service tool, or equivalent. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the equipment. | Fault Code 234 inactive?
STEP 2. | Clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 234 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill when the fault was logged.

Engine motoring down hill, if applcable?
YES NO

Repair

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.
 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported a uncommanded acceleration where the engine rapidly accelerated to or past 115 percent of rated rpm, followed by moderate deceleration to 115 percent of rated rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with the electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.
  • Operate the engine.

Action

Check the engine rpm with the electronic service tool.

Compare the engine crankshaft speed/position sensor reading on the electronic service tool to a mechanical tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft engine speed sensor and engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1D

Troubleshoot Fault Codes 689 and 1376.

Guided Step 1D - Inspect the engine harness and engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair the damaged engine crankshaft speed/position sensor.

 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for active Fault Code 234 when the engine is operating below rated rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1F

Go to 2A

Guided Step 1F - Test the equipment.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Test the equipment in a road test or if it stationary, operate under normal operating conditions, to determine if the overspeed condition is still present.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 2A

Go to 1A

Guided Step 2 - Clear the fault codes.

Guided Step 2A - Disable the fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Disable the fault code.

  • Use the electronic service tool to verify the fault code is inactive.

Fault Code 234 inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all the steps have been completed and checked again.

Go to 2B

Go to 1A

Guided Step 2B - Clear the inactive fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Clear the inactive fault codes.

  • Use the electronic service tool to clear the inactive fault codes.

All fault codes cleared?
YES NO
No Repair

Repair

Troubleshoot any remaining active fault codes.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 16-Jun-2021


FAULT CODE 261 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K111 | 4358519
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K108 | 4332823
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K121 | 4388645
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K105 | 4326157
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K146G | 5612932
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe. | Temperature sensor reading with the recommended Cummins® electronic service tool, or equivalent, correlates to a known value or thermocouple reading?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine fuel temperature sensor accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Monitor the fuel temperature sensor reading.

  • Use the electronic service tool to monitor the fuel temperature value.
  • Compare the temperature reading with the electronic service tool to a thermocouple reading or a known value.

Temperature sensor reading with the electronic service tool correlates to a known value or thermocouple reading?
YES NO
No Repair

Repair

Replace the engine fuel supply temperature sensor. Refer to Procedure 019-119 in the Associated Procedures Table.

See the Fuel Temperature Above Normal troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 263 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K105 | 4326157
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K108 | 4332823
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K111 | 4358519
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K121 | 4388645
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K114 | 5579623
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K146G | 5612932
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK38 CM2350 K145G | 5612927
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 263 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 265 active and Fault Code 263 inactive?
 | STEP 3C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C-1. Check for an open circuit in the engine harness. |
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 263 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine fuel temperature sensor 1 SIGNAL pin and engine fuel temperature sensor 1 RETURN pin at the engine harness engine fuel temperature sensor 1 connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor 1 to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 263 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the engine fuel temperature 1 SIGNAL pin and engine fuel temperature 1 RETURN pin at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Check for the appropriate circuit response after 30 seconds.
  • Use the electronic service tool to read the fault codes.

Fault Code 265 active and Fault Code 263 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor 1 RETURN pin and the engine harness engine fuel temperature sensor 1 connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C-1

Go to 4A

Guided Step 3C-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector engine fuel temperature sensor 1 SIGNAL pin and the engine harness engine fuel temperature sensor 1 connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurements. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 263 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Troubleshooting procedures need to be repeated from the beginning. A failure mode should have been detected.

Go to 4A

Go to 1A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 265 - Engine Fuel Temperature Sensor 1 Circuit - Voltage Below Normal or Shorted Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Fuel Temperature Sensor | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Fuel Temperature Sensor | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K105 | 4326157
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K108 | 4332823
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K111 | 4358519
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K121 | 4388645
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K114 | 5579623
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K146G | 5612932
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK38 CM2350 K145G | 5612927
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3823996 - female Weather-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 265 active?
STEP 2. | Check the engine fuel temperature sensor and circuit. |
 | STEP 2A. Inspect the engine fuel temperature sensor 1 and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 265 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 263 active and Fault Code 265 inactive?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3E. Check for an active fault code. | Fault Code 265 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 265 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine fuel temperature sensor and circuit.

Guided Step 2A - Inspect the engine fuel temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and engine fuel temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-119 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check for fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

Repair

A damaged sensor has been detected.

  • Replace the engine fuel temperature sensor 1. Refer to Procedure 019-119 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness ECM connector 1.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Do not spray contact cleaner directly into the ECM ports as damage may result. Do not blow compressed air in the ECM ports or connector. Compressed air can contain moisture due to condensation.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

  • Clean the connector and pins.
  • Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 263 active and Fault Code 265 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire in the engine harness.

  • Repair or replace the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect engine harness from the ECM connector.
  • Disconnect the engine fuel temperature sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel temperature sensor 1 SIGNAL pin in the engine harness ECM connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short on the SIGNAL wire has been detected in the engine harness.

Repair or replace the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 265 active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 1A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 15-Jun-2021


FAULT CODE 266 - Engine Fuel Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Name | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K105 | 4326157
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K108 | 4332823
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK95 CM2350 K111 | 4358519
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK60 CM2350 K121 | 4388645
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K114 | 5579623
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK50 CM2350 K146G | 5612932
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK38 CM2350 K145G | 5612927
Engine Fuel Temperature Sensor | Refer to Procedure 019-119 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the engine fuel temperature sensor 1 accuracy. |
 | STEP 1A. Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe. | Readings correct?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the engine fuel temperature sensor 1 accuracy.

Guided Step 1A - Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

Conditions

  • Turn keyswitch ON.

Action

Verify the engine fuel temperature sensor 1 accuracy with a thermocouple or similar temperature probe.

  • Connect the temperature probe to the engine near the fuel temperature sensor.
  • Connect the recommended Cummins® electronic service tool, or equivalent.
  • Compare the engine fuel temperature sensor 1 reading on the service tool monitor screen to the reading from the temperature probe.

If no temperature measuring device is available, answer Yes to this step.

Readings will possibly need to be checked while engine is operating at normal temperature conditions 82°C [180°F].

Readings correct?
YES NO
No Repair

Repair

Sensor reading incorrect. Replace the fuel supply temperature sensor.

  • Refer to Procedure 019-119 in the Associated Procedures Table.

See the Fuel Temperature Above Normal Operating Range symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 342 - Electronic Calibration Code Incompatibility - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK50 CM2350 K108 | 4332823
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK95 CM2350 K111 | 4332823
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK60 CM2350 K121 | 4388645
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK50 CM2350 K146G | 5612932
Engine Control Module ROM Boot | Refer to Procedure 019-427 | QSK38 CM2350 K145G | 5612927

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 2727 or 3329 active?
STEP 2. | Calibrate the engine control modules (ECM)s. |
 | STEP 2A. Calibrate the ECMs. | ECMs accepted calibration?
 | STEP 2B. ROM boot the ECMs. | ROM boot procedure successful?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for active fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 2727 or 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the ECMs

Guided Step 2A - Calibrate the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Calibrate the ECMs.

  • Refer to Procedure 019-032 in Section 19.

ECMs accepted calibration?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - ROM boot the ECMs.

Conditions

  • Turn keyswitch OFF.

Action

ROM boot any ECMs that were not successfully calibrated.

  • Refer Procedure 019-427 in the Associated Procedures Table.

ROM boot procedure successful?
YES NO
No Repair

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 351 - Injector Power Supply - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 441 active or inactive?
 | STEP 1B. Read the fault codes. | Fault Code 351 active?
 | STEP 1C. Read the fault codes. | Fault Code 351 present in multiple ECMs?
STEP 2. | Check the batteries. |
 | STEP 2A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 2B. Load test the batteries. | Battery voltage acceptable in normal and cranking conditions?
STEP 3. | Check the ECM power supply. |
 | STEP 3A. Inspect the ECM power supply connectors and fuses. | Dirty or damaged pins?
 | STEP 3B. Check for high resistance. | Less than 0.5 ohms?
 | STEP 3C. Check for an open circuit in the ECM power return circuit. | Less than 0.5 ohms?
 | STEP 3D. Operate the engine and determine if fault code condition exists. | Fault Code 351 occurs during engine operation?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Read the fault codes.

  • Start the engine. Let it idle for 1 minute.
  • Use the electronic service tool to read the fault codes.

Fault Code 441 active or inactive?
YES NO

Repair

Troubleshoot Fault Code 441 first.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Operate the engine at high idle, no load,
  • Use the electronic service tool to read the fault codes.

Fault Code 351 active?
YES | NO
No Repair | No Repair

Go to 1C

Go to 4A

Guided Step 1C - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 351 present in multiple ECMs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the batteries.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery terminal connections on both positive (+) and negative (-) terminals for the following.

  • Looseness
  • Dirt or corrosion.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections and clean the terminals.

  • Refer to Procedure 013-007 in Section 13.
  • Refer to Procedure 013-009 in Section 13.

See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Load test the batteries.

Conditions

  • Turn keyswitch ON.

Action

  • Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start the engine or use a carbon pile load tester. Refer to Procedure 013-007 in Section 13.
  • See equipment manufacturer service information.

Normal conditions:

  • At least +24 VDC.

Cranking conditions:

  • At least +18 VDC.

Battery voltage acceptable in normal and cranking conditions?
YES NO

Repair

Perform all checks in Step 3 on each ECM that has Fault Code 351 present.

Repair

Refer to Procedure 013-007 in Section 13.

See equipment manufacturer service information.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM power supply.

Guided Step 3A - Inspect the ECM power supply connectors and fuses.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM power supply pins and fuses for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected.

Repair or replace the damaged harness, pins, fuses, or connectors.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for high resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for high resistance.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the OEM harness connector of the ECM and the battery positive (+) connector at the battery.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair

High resistance has been detected in the ECM power supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the high resistance.

Repair or replace the ECM power supply harness, fuses, or fuse holders.

Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the ECM power return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for high resistance in the ECM return circuit.

  • Measure the resistance between the battery negative (-) pins at the OEM harness connector of the ECM and the battery negative (-) connector at the battery.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 0.5 ohms?
YES NO
No Repair

Repair

High resistance has been detected in the ECM power return circuit.

Troubleshoot all harnesses connected in series to determine which one contains the high resistance.

Repair or replace the harness.Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Operate the engine and determine if fault code condition exists.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Operate the engine and determine whether the fault code condition still exists.

  • Operate the engine at high idle, no load.
  • Use the electronic service tool to read the fault codes.

Fault Code 351 occurs during engine operation?
YES NO

Repair

Replace the ECMs that have Fault Code 351 active. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connectors corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 352 (Source Address 00) - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK50 CM2350 K108 | 4332823
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 CM2350 K116 | 4367444
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 CM2350 K117 | 4367449
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK95 CM2350 K111 | 4358519
Coolant Pressure Sensor | Refer to Procedure 019-016 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure/Sensor Switch | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure/Sensor Switch | Refer to Procedure 019-066 | QSK60 CM2350 K116 | 4367444
Engine Oil Pressure/Sensor Switch | Refer to Procedure 019-066 | QSK60 CM2350 K117 | 4367449
Engine Oil Pressure/Sensor Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure/Sensor Switch | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK50 CM2350 K108 | 4332823
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK60 CM2350 K116 | 4367444
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK60 CM2350 K117 | 4367449
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK95 CM2350 K111 | 4358519
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK60 CM2350 K121 | 4388645
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K108 | 4332823
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K116 | 4367444
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K117 | 4367449
Crankshaft Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519
Crankshaft Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the camshaft position sensor and circuits connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2C. Inspect the engine coolant pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2C-1. Check the circuit response. |
 | STEP 2D. Inspect the engine fuel delivery pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2D-1. Check the circuit response. |
 | STEP 2E. Check the engine crankcase pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2E-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the camshaft position sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the camshaft position sensor.

Refer to Procedure 019-363 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine oil pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.

Action

Inspect the engine harness and the engine oil pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine oil pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine oil pressure sensor.

Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the engine coolant pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.

Action

Inspect the engine harness and engine coolant pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C-1

Guided Step 2C-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine coolant pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine coolant pressure sensor.

Refer to Procedure 019-016 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine fuel delivery pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and engine fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2D-1

Guided Step 2D-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine fuel delivery pressure sensor.

Go to 2E

Go to 4A

Guided Step 2E - Check the engine crankcase pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and aftertreatment fuel pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E-1

Guided Step 2E-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine crankcase pressure sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A short circuit has been dectected in the engine harness.

Troubleshoot all harnesses connected in the series.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Nov-2015


FAULT CODE 352 (Source Address 01) - Sensor Supply 1 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK50 CM2350 K108 | 4332823
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K116 | 4367444
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K117 | 4367449
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K111 | 4358519
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K121 | 4388645
Post-Oil Filter Pressure Sensor | Refer to Procedure 019-447 | QSK50 CM2350 K108 | 4332823
Post-Filter Oil Pressure Sensor | Refer to Procedure 019-447 | QSK60 CM2350 K116 | 4367444
Post-Filter Oil Pressure Sensor | Refer to Procedure 019-447 | QSK60 CM2350 K117 | 4367449
Post-Filter Oil Pressure Sensor | Refer to Procedure 019-447 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 352 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 1 supply and return. |
 | STEP 2A. Inspect the engine pre-oil filter pressure sensor and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the engine post-oil filter pressure sensor, if equipped, and circuit connected to the sensor number 1 supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 352 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 1 supply and return.

Guided Step 2A - Inspect the engine pre-oil filter pressure sensor and circuit connected to the sensor number 1 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine pre-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and engine pre-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure Refer to 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine pre-oil filter pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine pre-oil filter pressure sensor.

Refer to Procedure 019-126 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the engine post-oil filter pressure sensor, if equipped, and circuit connected to the sensor number 1 supply and return.

Conditions

  • If the engine is not equipped with a post-oil filter pressure sensor skip to step 3A.
  • Turn the keyswitch OFF.
  • Disconnect the engine post-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and the engine post-oil filter pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine post-oil filter pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO
No Repair

Repair

Replace the engine post-oil filter pressure sensor.

Refer to Procedure 019-447 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 352 active?
YES NO

Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Nov-2015


FAULT CODE 386 - Sensor Supply 1 Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 386 active?
STEP 2. | Check the engine control module (ECM) and engine harness. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 386 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes

Fault Code 386 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the engine control module (ECM) and engine harness.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire or insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins. Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

There is a short circuit to a voltage source in the engine harness sensor SUPPLY 1 wire.

Replace the damaged section of the wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-Sep-2019


FAULT CODE 426 - J1939 Network #1 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of pin and harness damage, use the following service tools when taking a measurement: Part Number 3163151 - ECM Bench Top Calibration Harness and Part Number 3164185 - ECM Bench Calibration Adapter Cable.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Society of Automotive Engineers (SAE) J1939 data link communication. |
 | STEP 1A. Check for engine control module (ECM) communication with the recommended Cummins® electronic service tool, or equivalent. | Electronic service tool communicates with the ECM?
 | STEP 1B. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 1C. Check ECM communication with the ECM bench calibration harness. | Electronic service tool communicates with the ECM?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the SAE J1939 data link communication.

Guided Step 1A - Check for ECM communication with the electronic service tool.

Conditions

  • Connect the INLINE™ 5 data link adapter to the vehicle SAE J1939 data link diagnostic connector.
  • Connect the electronic service tool.
  • Turn keyswitch ON.

Action

Use the electronic service tool to communicate with the ECM.

  • Use an INLINE™ (J1939) ECM connection to start the electronic service tool and connect to the ECM.

Electronic service tool communicates with the ECM?
YES NO

Repair

The ECM SAE J1939 data link circuit is functioning properly.

 No Repair

See equipment manufacturer service information for information on troubleshooting and vehicle SAE J1939 data link network

Go to 1B

Guided Step 1B - Inspect the OEM engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connectors for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damaged
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connectors and pins.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check ECM communication with the ECM bench calibration harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Connect the ECM bench calibration harness to the ECM connector.
  • Connect the INLINE™ data link adapter.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Use the electronic service tool to attempt to communicate with the ECM.

  • Start the electronic service tool and connect to the ECM using an INLINE™ (J1939) ECM connection.

Electronic service tool communicates with the ECM?
YES NO

Repair

The electronic service tool is able to communicate with the ECM. This indicates that the ECM data link circuit is functioning properly.

See equipment manufacturer service information on troubleshooting the vehicle SAE J1939 data link network.

 No Repair

See equipment manufacturer service information.

See Communication Error - Electronic Service Tool or Control Device troubleshooting symptom tree in Section TS.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 441 - Battery 1 Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 441 present in all engine control modules (ECMs)?
STEP 2. | Check the batteries. |
 | STEP 2A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 2B. Load test the batteries. | Battery voltage acceptable in normal and cranking conditions?
 | STEP 2C. Attempt to start the engine. | Engine starts and runs normally?
 | STEP 2D. Check the alternator. | Voltage greater than 26 VDC?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the original equipment manufacturer (OEM) harness connector and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for high resistance in the ECM battery supply and return circuit. | Less than 1 ohm?
 | STEP 3C. Check for a short circuit in the harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Read the fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 441 present in all engine control modules (ECMs)?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the batteries.

Guided Step 2A - Check the battery connections.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the battery terminal connections on both positive (+) and negative (-) terminals for the following:

  • Looseness
  • Dirt or corrosion
  • Check for add-on or accessory wiring that could be damaged and shorting out the ECM supply circuit.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections, and clean the terminals.

  • Refer to Procedure 013-007 in Section 13.
  • Refer to Procedure 013-009 in Section 13.
  • See equipment manufacturer service information.

Go to 2B

Go to 4A

Guided Step 2B - Load the test batteries.

Conditions

  • Turn keyswitch ON.

Action

Measure the voltage from the positive (+) battery terminal to the negative (-) battery terminal while trying to start engine or use a carbon pile load tester.

Refer to Procedure 013-009 in Section 13 or see equipment manufacturer service information.

Normal conditions:

  • At least +24 VDC.

Cranking conditions:

  • At least +18 VDC.

Battery voltage acceptable in normal and cranking conditions?
YES NO

Repair

Perform all checks in Step 3 on each ECM that has Fault Code 441 present.

Repair

Refer to Procedure 013-007 in Section 13 or see equipment manufacturer service information.

Go to 3A

Go to 2C

Guided Step 2C - Attempt to start the engine.

Conditions

  • Turn keyswitch ON.

Action

Start the engine.

Engine starts and runs normally?
YES NO
No Repair

Repair

Perform all checks in step 3 on each ECM that has Fault Code 441 present.

Go to 2D

Go to 3A

Guided Step 2D - Check the alternator.

Conditions

  • Operate the engine at idle.

Action

Measure the voltage from the positive (+) to the negative (-) terminal at the alternator.

Voltage greater than 26 VDC?
YES NO
No Repair

Repair

Replace the alternator.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the original equipment manufacturer (OEM) harness connector and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for high resistance in the ECM battery supply and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for high resistance.

  • Measure the resistance between the ECM battery SUPPLY (+) pins at the OEM harness connector of the ECM and the battery positive (+) connector at the battery.
  • Measure the resistance between the battery RETURN (-) pins at the OEM harness connector of the ECM and the battery negative (-) connector at the battery.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 1 ohm?
YES NO
No Repair

Repair

High resistance has been detected in the ECM power supply circuit.

Troubleshoot all harnesses connected in series to determine which one contains the high resistance.

Repair or replace the harness, fuses, or fuse holders.

Refer to Procedure 019-071 in Section 19.

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit in the harness.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM harness ECM connector to all other pins in the connector (except the other battery SUPPLY (+) pins).

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the battery.

Action

Check for a short circuit to ground.

  • Measure the resistance from the ECM battery SUPPLY (+) pins in the OEM harness ECM connector to engine block ground.

Use the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 14-Jun-2021


FAULT CODE 555 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure reading 0 ±0.25 kPa-g (0 ±1 in-H2O)?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.
  • Do not operate the engine.

Action

Use the electronic service tool "Data Monitor/Logger" feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use the electronic service tool to monitor crankcase pressure.

Pressure reading 0 ±0.25 kPa-g (0 ±1 in-H2O)?
YES | NO
No Repair | No Repair

See the Crankcase Gasses (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 27-Apr-2021


FAULT CODE 556 - Crankcase Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K108 | 4332823
Crankcase Pressure Sensor | Refer to Procedure 019-445 | VTA903 CM2250 V105 | 4332841
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K116 | 4367444
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K117 | 4367449
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 G CM2358 K110 | 4383781
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K121 | 4388645
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K146G | 5612932
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK38 CM2350 K145G | 5612927

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy, |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure reading 0 ±0.25 kPa – g (0 ±1 in H2O)?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.
  • Do not operate the engine.

Action

Use the electronic service tool “Data Monitor/Logger” feature to verify crankcase pressure sensor accuracy.

  • Make sure the correct sensor part number is installed.
  • When checking the pressure sensor accuracy, make sure the engine is not operating.
  • Use the electronic service tool to monitor "Crankcase Pressure".

Pressure reading 0 ±0.25 kPa – g (0 ±1 in H2O)?
YES NO
No Repair

Repair

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

See the Crankcase Gases (Blowby) Excessive troubleshooting symptom tree in Section TS.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 671 - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 671 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1618 active and Fault Code 671 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 671 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 671 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active and Fault Code 671 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 1 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 1.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 672 - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 672 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1521 active and Fault Code 672 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 672 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 672 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active and Fault Code 672 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 3 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 3.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 673 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 673 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1522 active and Fault Code 673 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 673 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 672 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine unil the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active and Fault Code 673 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhuast gas temperature sensor 5 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 5.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhuast gas temperature sensor 5 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Sep-2015


FAULT CODE 674 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 674 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1523 active and Fault Code 674 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 674 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 674 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verity the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active and Fault Code 674 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 7 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 7.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhuast gas temperature sensor 7 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM connector and engine block ground.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 675 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 675 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1524 active and Fault Code 675 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 675 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 675 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhuast gas temperature sensor 9 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with and idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active and Fault Code 675 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 9 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 9.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gast temperature sensor 9 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 676 - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 676 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1525 active and Fault Code 676 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 676 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 676 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service to to verify the oil temperature.
  • Operate the engine with and idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active and Fault Code 676 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhuast gas temperature sensor 11 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 11.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 677 - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 677 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1526 active and Fault Code 677 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 677 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 677 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active and Fault Code 677 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 13 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 13.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhuast gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 678 - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 678 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1527 active and Fault Code 678 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 678 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 678 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with and idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active and Fault Code 678 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 15 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 15.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Sep-2015


FAULT CODE 721 - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 721 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1529 active and Fault Code 721 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 721 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 721 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active and Fault Code 721 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 2 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 2.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 722 - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 722 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1619 active and Fault Code 722 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 722 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 722 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verigy the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active and Fault Code 722 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 4 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 4.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 723 - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 723 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1531 active and Fault Code 723 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 723 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 723 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active and Fault Code 723 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 6 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 6.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 724 - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 724 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1532 active and Fault Code 724 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 724 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 724 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active and Fault Code 724 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 8 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 8.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 725 - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 725 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1533 active and Fault Code 725 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 725 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 725 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active and Fault Code 725 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 10 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 10.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 726 - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 726 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1534 active and Fault Code 726 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 726 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 726 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active and Fault Code 726 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 12 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 12.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 727 - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 727 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1535 active and Fault Code 727 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 727 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 727 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active and Fault Code 727 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 14 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 14.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 30-Sep-2015


FAULT CODE 728 - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Cautions and Warnings

CAUTION

To reduce the possiblity of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 728 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1536 active and Fault Code 728 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 728 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 728 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active and Fault Code 728 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 16 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 16.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.Refer to the circuit diagram or wiring diagram for connector pin identification.Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and engine block ground.Refer to the circuit diagram or wiring diagram for connector pin identification.Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Sep-2015


FAULT CODE 731 - Engine Speed/Position Camshaft and Crankshaft Misalignment - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Camshaft Gear (Camshaft Installed) | Refer to Procedure 001-012 | QSK19 CM2350 K144G | 5612922
Camshaft Gear, Front | Refer to Procedure 001-084 | QSK19 CM2350 K105 | 4326157
Camshaft Gear, Front | Refer to Procedure 001-084 | QSK95 CM2350 K111 | 4358519
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K105 | 4326157
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK50 CM2350 K108 | 4332823
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK95 CM2350 K111 | 4358519
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K114 | 5579623
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K144G | 5612922
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K105 | 4326157
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK50 CM2350 K108 | 4332823
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK95 CM2350 K111 | 4358519
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K114 | 5579623
Crankshaft Position Sensor | Refer to Procedure 019-365 | QSK19 CM2350 K144G | 5612922

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for multiple fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 731 the only active fault code?
STEP 2. | Inspect the camshaft gear and position sensors. |
 | STEP 2A. Inspect the crankshaft and camshaft position sensors for damage. | Damage found?
 | STEP 2B. Inspect the camshaft gear for any damage. | Damage found?
STEP 3. | Inspect the engine control module (ECM) power supply ground reference. |
 | STEP 3A. Inspect the ECM power supply ground reference. | ECM power supply ground circuit properly grounded, free of corrosion, and tight?
STEP 4. | Check static timing. |
 | STEP 4A. Check static timing. | Timing marks properly aligned?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for multiple fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Connect the recommended Cummins® electronic service tool, or equivalent.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use the electronic service tool to read fault codes.

Fault Code 731 the only active fault code?

YES NO
No Repair

Repair

Troubleshoot any other active fault codes before continuing with this tree.

Go to 2A

Go to the appropriate fault code troubleshooting tree.

Guided Step 2 - Inspect the camshaft gear and position sensors.

Guided Step 2A - Inspect the crankshaft and camshaft position sensors for damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the crankshaft and camshaft position sensor for damage.

Damage found?
YES NO

Repair

Replace the damaged position sensor.

  • Refer to Procedure 019-363 in the Associated Procedures Table.
  • Refer to Procedure 019-365 in the Associated Procedures Table.

If the camshaft position sensor is damaged:

  • Inspect the camshaft gear. Refer to Procedure 001-084 in the Associated Procedures Table. For QSK19 CM2350 K144G engines, refer to Procedure 001-012 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Inspect the camshaft gear for any damage.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the camshaft gear for damage.

  • Refer to Procedure 001-084 in the Associated Procedures Table. For QSK19 CM2350 K144G engines, refer to Procedure 001-012 in the Associated Procedures Table.

Damage found?
YES NO

Repair

Replace the camshaft gear.

 No Repair

Go to 5A

Go to 3A

Guided Step 3 - Inspect the ECM power supply ground reference.

Guided Step 3A - Inspect the ECM power supply ground reference.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM power supply ground reference.

  • Verify all connections at ECM power supply ground reference on original equipment manufacturer are free from corrosion and tight.

ECM power supply ground circuit properly grounded, free of corrosion, and tight?
YES NO
No Repair

Repair

Replace, tighten, or clean ground wires or connections.

Go to 4A

Go to 4A

Guided Step 4 - Check static timing.

Guided Step 4A - Check static timing.

Conditions

  • Turn keyswitch OFF>

Action

Inspect the timing.

  • Remove the gear cover.
  • Rotate engine until right bank number 1 cylinder is at top dead center (TDC).
  • Install the camshaft timing pin.
  • Confirm timing marks on the camshaft compound idler gear and crankshaft gear are aligned.

Refer to Procedure 001-084 in the Associated Procedure Table. For QSK19 CM2350 K144G engines, refer to Procedure 001-012 in the Associated Procedures Table.

.

Timing marks properly aligned?
YES NO
No Repair

Repair

Remove and install the camshaft compound idler gear. Properly align the timing marks.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

No Repair

Repair complete.

Repair complete.

Last Modified: 14-Jun-2021


FAULT CODE 781 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 781 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the SAE J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 54 and 66 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 781 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the battery voltage SUPPLY pins and the battery voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM harness connector at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 54 and 66 ohms?
YES NO

Repair

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

Repair

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

For QSK95 CM2350 engines, check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 16-Aug-2016


FAULT CODE 1117 - Power Supply Lost With Ignition On - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for fault codes. | Fault Code 1117 present in all ECMs?
STEP 2. | Check the batteries and the power supply. |
 | STEP 2A. Check the battery connections. | Connections tight and corrosion-free?
 | STEP 2B. Check the power supply circuit. | Power supply harness or connectors damaged?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM power supply fuse. | Fuse damaged, corroded, or loose?
 | STEP 3C. Check the ECM power supply circuit. | Power supply harness or connectors damaged?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for fault codse.

Conditions

  • Connect components.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 1117 present in all ECMs?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the batteries and the power supply.

Guided Step 2A - Check the batteries connections.

Conditions

  • Turn keyswitch OFF.

Action

Check the battery connections.

  • Check the battery terminal connections.

Connections tight and corrosion-free?
YES NO
No Repair

Repair

Tighten the loose connections, and clean the terminals. See equipment manufacturer service information and the following procedures:

  • Refer to Procedure 013-007 in Section 13.
  • Refer to Procedure 013-009 in Section 13.

Go to 2B

Go to 4A

Guided Step 2B - Check the power supply circuit.

Conditions

  • Turn keyswitch ON.

Action

Inspect the power supply circuit.

  • Check for loose or corroded connectors.
  • Wiring insulation that is damaged or rubbed through.
  • Wiggle the power supply harness and check for ECMs that are intermittently losing power.

Power supply harness or connectors damaged?
YES NO

Repair

Repair or replace the damaged section of harness. See equipment manufacturer service information.

Repair

Improper use of the original equipment manufacturer (OEM) battery shut-off switches will cause Fault Code 1117 to become active.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and the ECM connector pins for the following:

  • Loose connections
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM power supply fuse.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the ECM power supply fuse and fuse holder for the following:

  • Incorrect installation
  • Corroded or damaged connection
  • Loose connection.

Fuse damaged, corroded, or loose?
YES NO

Repair

Replace the fuse.

Repair or replace the engine harness, if necessary. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check the ECM power supply circuit.

Conditions

  • Turn keyswitch ON.

Action

Inspect the power supply circuit.

  • Check for loose or corroded connectors.
  • Check for wiring insulation that is damaged or rubbed through.
  • Wiggle the power supply harness and check for ECM(s) that are intermittently losing power.

Power supply harness or connectors damaged?
YES NO

Repair

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of harness.

  • Use the following procedure for the OEM harness. Refer to Procedure 019-071 in Section 19.
  • Use the following procedure for the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 1135 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K145G | 5612927

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 1135 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 54 and 66 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1135 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the battery voltage SUPPLY pins and the battery voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM harness connector at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 54 and 66 ohms?
YES NO

Repair

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

Repair

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

For QSK95 CM2350 engines, check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 1256 (Source Address 00) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module ( ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration corresponds with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for correct calibration.

  • Use the electronic service tool to check the calibration installed on the ECM.

Calibration corresponds with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Jan-2021


FAULT CODE 1256 (Source Address 01) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Model | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for correct calibration.

  • Use the electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Mar-2021


FAULT CODE 1256 (Source Address 144) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Disable the fault code. | Fault Code 1256 inactive?
 | STEP 4B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for correct calibration.

  • Use the electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and original equipment manufacturer (OEM) harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Mar-2021


FAULT CODE 1256 (Source Address 186) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for correct calibration.

  • Use the electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and original equipment manufacturer (OEM) harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 and all other pins in the connector (except for the other ID SIGNAL pins).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Mar-2021


FAULT CODE 1257 (Source Address 00) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module ( ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2014


FAULT CODE 1257 (Source Address 01) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness.Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2014


FAULT CODE 1257 (Source Address 144) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1257 inactive?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1257 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and original equipment manufacturer (OEM) harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 07-Nov-2014


FAULT CODE 1256 (Source Address 186) - Control Module Identification Input State Error - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1256 inactive?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Does the calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1256 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for correct calibration.

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Does the calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and original equipment manufacturer (OEM) harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for an open circuit on the connected harness keying pins.

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 and all other pins in the connector (except for the other ID SIGNAL pins).

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 1362 - Engine Oil Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK50 CM2350 K108 | 4332823
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Filter (Spin-On) | Refer to Procedure 007-013 | QSK60 CM2350 K121 | 4388645
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK50 CM2350 K108 | 4332823
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK60 CM2350 K121 | 4388645
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK50 CM2350 K108 | 4332823
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K111 | 4358519
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active or inactive fault codes. |
 | STEP 1A. Check for related fault codes. | Active or inactive counts of Fault Codes 135, 141, 1367, and 1368?
 | STEP 1B. Check for an active fault code. | Active or inactive counts of Fault Code 1362?
STEP 2. | Check the lubricating oil pressure sensors. |
 | STEP 2A. Check the pre- and post- filter lubricating oil pressure sensors. | Pressure sensor readings in INSITE™ electronic service tool correlate with the mechanical gauge or multimeter pressure transducer reading?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active or inactive fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Codes 135, 141, 1367, and 1368?
YES | NO
No Repair | No Repair

Refer to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.

Active or inactive counts of Fault Code 1362?
YES | NO
No Repair | No Repair

Go to 2A

Repair complete

Guided Step 2 - Check the lubricating oil pressure sensors.

Guided Step 2A - Check the pre- and post- filter lubricating oil pressure sensors.

Conditions

  • Turn keyswitch OFF.

Action

Check operation and range of the oil filter intake pressure sensor and the lubricating oil pressure sensors.

  • Refer to Procedure 019-126 in the Associated Procedures Table.
  • Refer to Procedure 019-066 in the Associated Procedures Table.

Pressure sensor readings in INSITE™ electronic service tool correlate with the mechanical gauge or multimeter pressure transducer reading?

YES NO

Repair

Replace the lubricating oil filters. Refer to Procedure 007-013 in the Associated Procedures Table.

If the oil filters are plugging before the maintenance interval it could be an indication of a serious engine problem or that maintenance intervals should be adjusted. For more information about oil filter contamination and maintenance intervals refer to Cummins® Engine Oil and Oil Analysis Recommendations, Bulletin 3810340.

Repair

Replace the faulty pressure sensor(s).

  • Refer to Procedure 019-126 in the Associated Procedures Table.
  • Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Aug-2015


FAULT CODE 1367 - Pre-Oil Filter Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK50 CM2350 K108 | 4332823
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K116 | 4367444
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K117 | 4367449
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K121 | 4388645
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1367 inactive?
STEP 2. | Check the pre-oil filter pressure sensor and circuit. |
 | STEP 2A. Inspect the pre-oil filter pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1368 active and Fault Code 1367 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1367 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for pre-oil filter pressure sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pre-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the pre-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the pre-oil filter pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active and Fault Code 1367 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the pre-oil filter pressure sensor to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active?
YES NO

Repair

A damaged pre-oil filter pressure sensor has been detected.

Replace the pre-oil filter pressure sensor.

  • Refer to Procedure 019-126 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropraite circuit response after 30 seconds

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active and Fault Code 1367 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the pre-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in the series to determine which contains the pin-to-pin short.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open pre-oil filter pressure RETURN circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1368 - Pre-Oil Filter Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK50 CM2350 K108 | 4332823
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K116 | 4367444
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K117 | 4367449
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK60 CM2350 K121 | 4388645
Pre-Filter Oil Pressure Sensor | Refer to Procedure 019-126 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1368 inactive?
STEP 2. | Check the pre-oil filter pressure sensor and circuit. |
 | STEP 2A. Inspect the pre-oil filter pressure sensor and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1367 active and Fault Code 1368 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1368 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the pre-oil filter pressure sensor and circuit.

Guided Step 2A - Inspect the pre-oil filter pressure sensor and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF
  • Disconnect the pre-oil filter pressure sensor from the engine harness.

Action

Inspect the engine harness and pre-oil filter pressure sensor connector pin for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector or shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the pre-oil filter pressure sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Check all harnesses connected in series.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.

Action

Check supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the pre-oil filter pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques.

Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the pre-oil filter pressure sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the pre-oil filter pressure 5 volt SUPPLY pin and the pre-oil filter pressure SIGNAL pin at the pre-oil filter pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active and Fault Code 1368 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the pre-oil filter pressure sensor to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 active?
YES NO

Repair

A damaged pre-oil filter pressure sensor has been detected.

Replace the pre-oil filter pressure sensor.

  • Refer to Procedure 019-126 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the pre-oil filter pressure 5 volt SUPPLY pin to the pre-oil filter pressure RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques.

Refer to Procedure 019-359 in Section 19.

4.75 to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted pre-oil filter pressure SUPPLY circuit has been detected in the engine harness.

Troubleshoot all harnesses connected in the series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

  • Place a jumper wire between the pre-oil filter pressure 5 volt SUPPLY pin and the pre-oil filter pressure SIGNAL pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1367 active and Fault Code 1368 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1368 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open circuit or a pin-to-pin short circuit has been detected on the pre-oil filter pressure SIGNAL wire of the engine harness.

Troubleshoot all harnesses connected in the series to determine which contains the open or pin-to-pin circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1376 - Engine Camshaft Speed/Position Sensor - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K105 | 4326157
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK50 CM2350 K108 | 4332823
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK60 CM2350 K116 | 4367444
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK60 CM2350 K117 | 4367449
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK60 CM2350 K121 | 4388645
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK95 CM2350 K111 | 4358519
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K114 | 5579623
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K146G | 5612932
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK38 CM2350 K145G | 5612927
Camshaft Position Sensor | Refer to Procedure 019-363 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

WARNING

Batteries can emit explosive gases. To reduce the possibility of personal injury, always ventilate the compartment before servicing the batteries. To reduce the possibility of arcing, remove the negative (-) battery cable first and attach the negative (-) battery cable last.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an active fault code. | Fault Code 1376 active?
STEP 2. | Check the camshaft position sensor and connector. |
 | STEP 2A. Inspect the camshaft position sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the camshaft position sensor for damage. | Damaged sensor?
STEP 3. | Check the camshaft position sensor circuit. |
 | STEP 3A. Check the camshaft position sensor supply voltage and return circuit. | Between 4.75-VDC and 5.25-VDC?
 | STEP 3B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check for an open camshaft position sensor signal circuit in the engine wiring harness. |
 | STEP 3B-2. Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness. |
 | STEP 3B-3. Check the fault code and verify the camshaft position sensor condition. |
 | STEP 3C. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3C-1. Check the sensor supply voltage and return circuit. |
 | STEP 3C-2. Check for an open circuit in the camshaft position sensor return. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1376 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the camshaft position sensor and connector.

Guided Step 2A - Inspect the camshaft position sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Inspect the engine harness and camshaft position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the camshaft position sensor for damage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Remove the camshaft position sensor from the gear cover. Refer to Procedure 019-363 in the Associated Procedures Table.

Action

Inspect the engine position sensor for the following:

  • Metal debris on the end of the sensor
  • Damage to the end of the sensor caused by camshaft gear
  • Oil leakage or insulation problems such as swelling
  • Damaged electrical potting in sensing end of sensor.

Damaged sensor?
YES NO

Repair

A damaged sensor or mechanical damage has been detected.

Replace the sensor. If mechanical damage was observed, then inspect the camshaft gear and related components. Refer to Procedure 019-363 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the camshaft position sensor circuit.

Guided Step 3A - Check the camshaft position sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit.

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor 1 RETURN pin at the camshaft position sensor connector of the engine wiring harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC and 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 3C

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check for an open camshaft position sensor signal circuit in the engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the camshaft position sensor from the engine harness.
  • Disconnect the engine harness connector from the ECM.

Action

Check for an open circuit in the engine harness.

  • Measure the resistance between the camshaft position sensor SIGNAL pin at the camshaft position sensor engine harness connector to the camshaft position sensor SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms ?
YES NO
No Repair

Repair

An open circuit in the engine harness has been detected.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check the camshaft position sensor signal circuit for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the camshaft position sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the camshaft position sensor SIGNAL pin of the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-3

Go to 4A

Guided Step 3B-3 - Check the fault code and verify the camshaft position sensor condition.

Conditions

  • Connect all components in the correct positions.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an active fault code.

  • Start the engine and let it idle for 1 minute.

Use the electronic service tool to read the fault codes.

Fault Code 1376 active?
YES NO

Repair

A damaged camshaft position sensor has been detected.

Replace the camshaft position sensor. Refer to Procedure 019-363 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3C - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3C-1

Guided Step 3C-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage and return circuit

  • Measure the sensor supply voltage between the camshaft position sensor +5 volt SUPPLY pin and the camshaft position sensor RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 4.75-VDC to 5.25-VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3C-2

Go to 4A

Guided Step 3C-2 - Check for an open circuit in the camshaft position sensor return.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the ECM.
  • Disconnect the camshaft position sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the camshaft position sensor supply voltage.

  • Measure the sensor supply voltage between the camshaft sensor +5 SUPPLY pin and engine ground.

Refer to the circuit or wiring diagram for connector pin identification.

Between 4.75-VDC to 5.25-VDC?
YES NO

Repair

An open return circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

An open supply circuit has been detected in the engine harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 1517 - At Least One Module Has A Most Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Read the fault codes. | Fault Code 1517 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1517 active?
YES NO

Repair

This is an information only fault code that will only become active if other fault codes are active in the child module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes in the child module(s) are resolved.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Dec-2013


FAULT CODE 1518 - At Least One Module Has A Moderately Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Read the fault codes. | Fault Code 1518 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1518 active?
YES NO

Repair

This is an information only fault code that will only become active if other fault codes are active in the child module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes in the child module(s) are resolved.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Dec-2013


FAULT CODE 1519 - At Least One Module Has A Least Severe Fault - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Read the fault codes. | Fault Code 1519 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read fault codes.

Fault Code 1519 active?
YES NO

Repair

This is an information only fault code that will only become active if other fault codes are active in the child module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active fault codes in the child module(s) are resolved.

 No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 04-Dec-2013


FAULT CODE 1521 - Exhaust Gas Temperature Sensor Circuit Cylinder 3 (A2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1521 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 672 active and Fault Code 1521 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1521 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1521 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 3 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 3 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 3 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 672 active and Fault Code 1521 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 3 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 3. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 3 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 3 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 3 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greate than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL line wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1521 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1522 - Exhaust Gas Temperature Sensor Circuit Cylinder 5 (A3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1522 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 673 active and Fault Code 1522 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1522 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1522 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 5 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 5 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 5 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 673 active and Fault Code 1522 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 5 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 5. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 5 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 5 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 5 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1522 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1523 - Exhaust Gas Temperature Sensor Circuit Cylinder 7 (A4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1523 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 674 active and Fault Code 1523 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1523 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1523 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 7 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 7 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 7 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 674 active and Fault Code 1523 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 7 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 7. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 7 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 7 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 7 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 7 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1523 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1524 - Exhaust Gas Temperature Sensor Circuit Cylinder 9 (A5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1524 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 675 active and Fault Code 1524 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1524 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1524 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 9 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 9 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 9 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 675 active and Fault Code 1524 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 9 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 9. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 9 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 9 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 9 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1524 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1525 - Exhaust Gas Temperature Sensor Circuit Cylinder 11 (A6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1525 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 676 active and Fault Code 1525 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1525 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1525 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 11 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 11 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 11 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 676 active and Fault Code 1525 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 11 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 11. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 11 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 11 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 11 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1525 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1526 - Exhaust Gas Temperature Sensor Circuit Cylinder 13 (A7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 G CM2358 K110 | 4383781
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 G CM2358 K110 | 4383781
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 G CM2358 K110 | 4383781
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1526 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 677 active and Fault Code 1526 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1526 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1526 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 13 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 13 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 13 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 677 active and Fault Code 1526 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 13 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 13. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 RETURN pin in the OEM harness ECM connector and the exhaust gas temperature sensor 13 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the OEM harness ECM connector and the exhaust gas temperature sensor 13 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 13 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 13 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1526 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-May-2018


FAULT CODE 1527 - Exhaust Gas Temperature Sensor Circuit Cylinder 15 (A8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1527 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 677 active and Fault Code 1527 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1527 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1527 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 15 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 15 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 15 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 678 active and Fault Code 1527 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 15 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 15. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 RETURN pin in the OEM harness ECM connector and the exhaust gas temperature sensor 15 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the OEM harness ECM connector and the exhaust gas temperature sensor 15 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 15 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 15 SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1527 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1529 - Exhaust Gas Temperature Sensor Circuit Cylinder 2 (B1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1529 inactive?
STEP 2. | Check the exhaust gas temperature sensor circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 721 active and Fault Code 1529 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1529 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for an pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1529 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 2 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 2 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 721 active and Fault Code 1529 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 2. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedure Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 2 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 2 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 2 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1529 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1531 - Exhaust Gas Temperature Sensor Circuit Cylinder 6 (B3) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1531 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 723 active and Fault Code 1531 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1531 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1531 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 6 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 6 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 6 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 723 active and Fault Code 1531 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 6 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 6.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 6 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 6 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 6 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1531 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Oct-2015


FAULT CODE 1532 - Exhaust Gas Temperature Sensor Circuit Cylinder 8 (B4) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1532 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 724 active and Fault Code 1532 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1532 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1532 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 8 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 8 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 8 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 724 active and Fault Code 1532 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 8 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 8.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 8 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 8 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 8 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1532 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Oct-2015


FAULT CODE 1533 - Exhaust Gas Temperature Sensor Circuit Cylinder 10 (B5) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1533 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 725 active and Fault Code 1533 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1533 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1533 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 10 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 10 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 10 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 725 active and Fault Code 1533 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 10 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 10.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 10 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 10 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 10 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1533 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 09-Oct-2015


FAULT CODE 1534 - Exhaust Gas Temperature Sensor Circuit Cylinder 12 (B6) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1534 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 726 active and Fault Code 1534 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1534 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1534 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 12 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 12 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 12 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 726 active and Fault Code 1534 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 12 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 12.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 12 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SIGNAL circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 12 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 12 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1534 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the summary section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2015


FAULT CODE 1535 - Exhaust Gas Temperature Sensor Circuit Cylinder 14 (B7) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1535 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 727 active and Fault Code 1535 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1535 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1535 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 14 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 14 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 14 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 727 active and Fault Code 1535 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 14 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 14.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 14 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 14 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 14 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1535 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2015


FAULT CODE 1536 - Exhaust Gas Temperature Sensor Circuit Cylinder 16 (B8) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1536 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 728 active and Fault Code 1536 inactive?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 1536 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1536 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 16 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 16 connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 16 SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 728 active and Fault Code 1536 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify the sensor condition.

Conditions

  • Turn the keyswitch OFF.
  • Connect the exhaust gas temperature sensor 16 to the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 16.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 16 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 16 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 16 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn the keyswitch OFF.
  • Connect all components.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1536 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2015


FAULT CODE 1597 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | VTA903 CM2250 V105 | 4332841
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 1597 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 1597. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Disable the fault code. | Fault Code 1597 inactive?
 | STEP 2B. Clear the inactive fault codes. | All fault codes cleared?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1597 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 1597.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 1597.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 1597.

Less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Aug-2019


FAULT CODE 1618 - Exhaust Gas Temperature Sensor Circuit Cylinder 1 (A1) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1618 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 671 active and Fault Code 1618 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1618 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1618 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 1 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 1 or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 1 SIGNAL and RETURN pins at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin indentification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 671 active and Fault Code 1618 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 1 to the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Run the engine until the engine oil temperature is above 60° C [140° F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 1.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 1 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 1 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 1 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60° C [140° F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1618 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2015


FAULT CODE 1619 - Exhaust Gas Temperature Sensor Circuit Cylinder 4 (B2) - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK50 CM2350 K108 | 4332823
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K116 | 4367444
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K117 | 4367449
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK60 CM2350 K121 | 4388645
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 1619 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 722 active and Fault Code 1619 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1619 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 1619 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Inspect the engine harness and exhaust gas temperature sensor 4 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the exhaust gas temperature sensor 4 or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the exhaust gas temperature sensor 4 SIGNAL and RETURN pins at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin indentification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 722 active and Fault Code 1619 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the exhaust gas temperature sensor 4 to the engine harness.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.
  • Run the engine until the engine oil temperature is above 60° C [140° F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 active?
YES NO

Repair

Replace the exhaust gas temperature sensor 4.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 RETURN pin in the engine harness ECM connector and the exhaust gas temperature sensor 4 RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the exhaust gas temperature sensor 4 from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the exhaust gas temperature sensor 4 SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin indentification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60° C [140° F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1619 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 12-Oct-2015


FAULT CODE 1843 - Crankcase Pressure Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K108 | 4332823
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K116 | 4367444
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K121 | 4388645
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK19 CM2350 K114 | 5579623
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK38 CM2350 K145G QSK50 CM2350 K146G | 5612927 5612932

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 386 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1843 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1844 active and Fault Code 1843 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 1843 active?
STEP 3. | Check the ECM and engine harness |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 386 active?
YES | NO
No Repair | No Repair

Reference Fault Code 386

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF..
  • Disconnect the crankcase pressure sensor connector from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor connector from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor return 1) pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 active?
YES NO

Repair

A damaged sensor has been detected. Replace the crankcase pressure sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the malfunction.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1844 active and Fault Code 1843 inactive?
YES NO
No Repair

Repair

Replace the ECM.

  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Replace the damaged section of the harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins.
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector

For general inspection techniques. Refer to Procedure 019-361.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure 5 volt SUPPLY (sensor supply 1) pin to the crankcase pressure RETURN (sensor supply 1) pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1843 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open RETURN circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 1844 - Crankcase Pressure Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K108 | 4332823
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K116 | 4367444
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK60 CM2350 K121 | 4388645
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK50 CM2350 K146G | 5612932
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK38 CM2350 K145G | 5612927

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352 active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 1844 inactive?
STEP 2. | Check the crankcase pressure sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 1843 active and Fault Code 1844 inactive?
 | STEP 2D. Check the fault codes and verify the sensor condition. | Fault Code 1844 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor supply voltage and return circuit. |
 | STEP 3A-2. Check for an active fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Check for an active fault code. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 352 active?
YES | NO
No Repair | No Repair

Go to Fault Code 352

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for an inactive fault code.

  • Use the electronic service tool to read the inactive fault codes.

Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the crankcase pressure sensor connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the crankcase pressure sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the crankcase pressure sensor SUPPLY pin to the crankcase pressure sensor RETURN pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1844 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

An open or shorted circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM engine connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure sensor SUPPLY pin and the crankcase pressure sensor SIGNAL pin at the engine harness ECM connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

  • Use the electronic service tool to read the fault codes.

Fault Code 1843 active and Fault Code 1844 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1844 active?
YES NO

Repair

An open circuit or a pin-to-pin short circuit has been detected on the SIGNAL wire of the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Datapate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Jul-2021


FAULT CODE 1845 - Water in Fuel Indicator Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK19 CM2350 K105 | 4326157
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK50 CM2350 K108 | 4332823
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK60 CM2350 K116 | 4367444
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK60 CM2350 K117 | 4367449
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK60 CM2350 K121 | 4388645
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK19 CM2350 K114 | 5579623
Water In Fuel Sensor | Refer to Procedure 019-127 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 1845 inactive?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1846 active and Fault Code 1845 inactive?
 | STEP 2C. Check the fault codes and verify water in fuel sensor condition. | Fault Code 1845 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and equipment manufacturer service information (OEM) engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1845 inactive?
STEP 4. | ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1845 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the engine harness and the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor connector from the engine harness connector.

Action

Inspect the engine harness and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water in fuel sensor or harness connector.

Clean the connector and pins.

Replace the damaged section of harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.
  • Turn keyswitch ON
  • Connect the electronic service tool.

Action

Place a jumper wire between the water in fuel SIGNAL pin and the water in fuel RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the electronic service tool to read the fault codes.

Fault Code 1846 active and Fault Code 1845 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1845 active?
YES NO

Repair

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor. Refer to Procedure 019-127 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the water in fuel sensor connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector water in fuel sensor RETURN pin and the engine harness water in fuel sensor connector RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.
  • Disconnect the water in fuel sensor connector from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the sensor harness ECM connector water in fuel indicator SIGNAL pin and the engine harness water in fuel sensor connector SIGNAL pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM engine harness connector from the ECM.
  • Disconnect the water in fuel indicator sensor connector from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the water in fuel sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

  • Refer to the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1845 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table. The cause of the failure should have been detected.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 29-Apr-2021


FAULT CODE 1846 - Water in Fuel Indicator Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K144G | 5612922
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K144G | 5612922
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK19 CM2350 K105 | 4326157
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK50 CM2350 K108 | 4332823
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK60 CM2350 K116 | 4367444
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK60 CM2350 K117 | 4367449
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK60 CM2350 K121 | 4388645
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK19 CM2350 K114 | 5579623
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK19 CM2350 K144G | 5612922

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the engine control module.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1846 active?
STEP 2. | Check the water in fuel sensor and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 1845 active and Fault Code 1846 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 1846 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) engine harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1846 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for an active fault code.

  • Use the electronic service tool to read the fault codes.

Fault Code 1846 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Inspect the engine harness, and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor from the engine harness connector.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read fault codes.

Fault Code 1845 active and Fault Code 1846 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1846 is active?
YES NO

Repair

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor.

Refer to Procedure 019-127 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM engine harness.

Guided Step 3A - Inspect the ECM and OEM engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water-in-fuel sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water-in-fuel SIGNAL pin in the connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Use the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water in fuel sensor from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water in fuel sensor SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use a wiring diagram and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Use the circuit diagram or wiring diagram for all harness interconnections.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 1846 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Apr-2021


FAULT CODE 1891 - Engine Oil Change Interval - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 1891. | Fault Code 1891 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 1891.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for Fault Code 1891.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1891 active?
YES NO

Repair

This fault code indicates that the Centinel/Continuous Oil Replacement System has been unable to operate due to engine conditions. If Fault Codes 135, 141, 212, 213, 214, 223, 224, or 421 are active then oil removal/replacement will be disabled. Troubleshoot any occurrences of these fault codes. If the Centinel/Continuous Oil Replacement System has been disabled for an extended period of time, it may be necessary to change the engine oil before the next scheduled oil change.

No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 06-Aug-2014


FAULT CODE 1992 - Engine Crankshaft Speed/Position - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

DO NOT OPERATE A DIESEL ENGINE WHERE THERE ARE OR CAN BE COMBUSTIBLE VAPORS. These vapors can be sucked through the air intake system and cause engine acceleration and overspeeding that can result in a fire, an explosion, and extensive property damage. Numerous safety devices are available, such as air intake shutoff devices, to minimize the risk of overspeeding where an engine, due to its application, might operate in a combustible environment, such as due to a fuel spill or gas leak. Remember, Cummins Inc. has no way of knowing the use you have for your engine. THE EQUIPMENT OWNER AND OPERATOR ARE RESPONSIBLE FOR SAFE OPERATION IN A HOSTILE ENVIRONMENT. CONSULT YOUR CUMMINS® AUTHORIZED REPAIR LOCATION FOR FURTHER INFORMATION.
CAUTION

If the engine speed exceeds 125 percent of rated speed, the engine must be shut off immediately or engine damage can occur.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Identify the reason for the overspeed. |
 | STEP 1A. Check for proper operating conditions. | Engine motoring downhill, if applicable?
 | STEP 1B. Check for an alternate fuel source. | Alternate fuel source?
 | STEP 1C. Check the engine rpm with INSITE™ electronic service tool. | Correct rpm reading?
 | STEP 1D. Inspect the engine harness and engine crankshaft speed/position sensor connector pins. | Dirty or damaged pins?
 | STEP 1E. Check for an active fault at low engine rpm. | Inactive fault code at low rpm?
 | STEP 1F. Test the equipment. | Fault Code 1992 inactive?
STEP 2. | Check the ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Identify the reason for the overspeed.

Guided Step 1A - Check for proper operating conditions.

Conditions

  • Turn keyswitch OFF.

Action

Check for proper operating conditions.

  • Check if the engine was motoring downhill, if applicable, when the fault was logged.

Engine motoring downhill, if applicable?
YES NO

Repair

Check for engine damage.

  • Electronics are OK.
  • Check the base engine for damage due to overspeed condition.
 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an alternate fuel source.

Conditions

  • Turn keyswitch OFF.

Action

Check for an alternate fuel source.

  • Check if the driver reported an uncommanded acceleration where the engine rapidly accelerated to or past 115 percent of rated rpm, followed by moderate deceleration to 115 percent of rated rpm.

Alternate fuel source?
YES NO

Repair

Locate any alternate fuel sources, such as operating the engine near flammable vapors, blown turbocharger seals, etc.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check the engine rpm with INSITE™ electronic service tool.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine.

Action

Check the engine rpm with INSITE™ electronic service tool.

Compare the engine crankshaft speed/position sensor reading on INSITE™ electronic service tool to a mechancial tachometer or the dash tachometer.

Correct rpm reading?
YES NO
No Repair

Repair

Inspect the engine crankshaft speed/position sensor and the engine camshaft speed/position sensor as outlined in Fault Codes 689 and 1376.

Go to 1D

Fault Codes 689 and 1376

Guided Step 1D - Inspect the engine harness from the engine crankshaft speed/position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the engine crankshaft speed/position sensor connector.

Action

Inspect the engine harness and engine crankshaft speed/position sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

Repair

A damaged connection has been detected in the engine crankshaft speed/position sensor or harness connector.

Clean the connector and pins.

Refer to the circuit diagram or wiring diagram for all harness interconnections.

  • Repair the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Repair the damaged engine crankshaft speed/position sensor.
 No Repair

Go to 2A

Go to 1E

Guided Step 1E - Check for an active fault at low engine rpm.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 1992 when the engine is operating below rated rpm.

Inactive fault code at low rpm?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1F

Go to 2A

Guided Step 1F - Test the equipment.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Test the equipment in a road test or, if it is stationary, operate under normal operating conditions to check if the overspeed condition is still present.

Fault Code 1992 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault Code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2377 - Fan Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K105 | 4326157
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 | 4367444
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K117 | 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK19 CM2350 K114 | 5579623
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K105 | 4326157
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK19 CM2350 K114 | 5579623

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 2. | Check the fan control solenoid and circuit. |
 | STEP 2A. Inspect the fan control solenoid and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit in the fan control solenoid. | Less than 10k ohms?
 | STEP 2C. Check the fan control solenoid diagnostic supply voltage, supply wire, and return circuit. | Greater than 5.0 VDC?
 | STEP 2D. Check for an open circuit in the fan control return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM/original equipment manufacturer (OEM) harness and engine harness. |
 | STEP 3A. Inspect all OEM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in fan control signal circuit. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness or engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2377 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES | NO
No Repair | No Repair

Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fan control solenoid and circuit.

Guided Step 2A - Inspect the fan control solenoid and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan solenoid from the OEM harness connector.

Action

Inspect the OEM and engine harnesses and fan solenoid connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Reference the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the solenoid or harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-071 in Section 19.
No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for an open circuit in the fan control solenoid.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness connector.

Action

Check fan control resistance.

  • Measure the resistance between the fan control solenoid SIGNAL and fan control solenoid RETURN pin at the fan control solenoid connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10k ohms?
YES NO
No Repair

Repair

An open circuit in the fan control has been detected.

Replace the fan control.

See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Check the fan control solenoid diagnostic supply voltage, SUPPLY wire, and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control solenoid from the OEM harness.
  • Turn keyswitch ON.

Action

Check the fan control diagnostic supply voltage and return circuit.

  • Measure the voltage between the fan control solenoid SIGNAL pin and the fan control solenoid RETURN pin at the fan control connector of the OEM harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Greater than 5 VDC?
YES | NO
No Repair | No Repair

Go to 3C

Go to 2D

Guided Step 2D - Check for an open circuit in the fan control return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fan control connector from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the fan control solenoid RETURN pin in the OEM harness and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the damaged section of harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Clean, repair, or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM or engine harness connector.

Clean the connector and pins.

Repair or replace the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Use the circuit diagram or wiring diagram for all harness interconnections.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the fan control signal circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector fan control solenoid SIGNAL pin and the OEM harness fan control solenoid connector fan control solenoid SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open fan control signal circuit has been detected in the harness.

Troubleshoot harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the fan control solenoid from the OEM harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the fan control solenoid SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Reference the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the fan control SIGNAL wire has been detected in the harness.

Troubleshoot all harnesses connected in series to determine which contains the pin-to-pin short.

Repair or replace the damaged section of harness.

  • Refer to Procedure 019-071 in Section 19.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2377 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

  • Replace the ECM.
  • Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Aug-2019


FAULT CODE 2442 - Injector Solenoid Driver Cylinder 1 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2442 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2442.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2442 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 1 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2014


FAULT CODE 2443 - Injector Solenoid Driver Cylinder 2 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2443 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2443.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2443 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 2 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2013


FAULT CODE 2444 - Injector Solenoid Driver Cylinder 3 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2444 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2444.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2444 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 3 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2013


FAULT CODE 2445 - Injector Solenoid Driver Cylinder 4 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2445 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2445.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2445 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 4 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found on QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2014


FAULT CODE 2446 - Injector Solenoid Driver Cylinder 5 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2446 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2446.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2446 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 5 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Feb-2015


FAULT CODE 2447 - Injector Solenoid Driver Cylinder 6 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2447 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 2447.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 2447 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 6 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2014


FAULT CODE 2651 - Engine Exhaust Gas Temperature - Right Manifold Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2651 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2652 active and Fault Code 2651 in active?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2651 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2651 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 2 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or on the connector
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the bank 2 exhaust gas temperature sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the bank 2 exhaust gas temperature sensor SIGNAL and RETURN pins at the sensor connector of the engine harness.
  • See the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active and Fault Code 2651 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes are verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 2 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active?
YES NO

Repair

Replace the bank 2 exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed bank or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor RETURN pin in the engine harness ECM connector and the bank 2 exhaust gas temperature sensor RETURN pin in the engine harness sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and the bank 2 exhaust gas temperature SIGNAL pin in the engine harness sensor connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

See the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 2651 inactive?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear all fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2652 - Engine Exhaust Gas Temperature - Right Manifold Bank 2 Sensor Circuit - Voltage Above Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 2652 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2651 active and Fault Code 2652 in active?
 | STEP 2C. Check the fault codes and verify the sensor condition. | Fault Code 2652 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2652 inactive?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 2 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until the engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify the oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2651 active and Fault Code 2652 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 2 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 active?
YES NO

Repair

Replace the bank 2 exhaust gas temperature sensor.

  • Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed bank or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater thank 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 2 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the bank 2 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and engine block ground.

See the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2652 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 2651 inactive?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear all fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2655 - Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2655 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2656 active and Fault Code 2655 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2655 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the wiring harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 2655 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 1 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the bank 1 exhaust gas temperature sensor connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Place a jumper wire between the bank 1 exhaust gas temperature sensor SIGNAL and RETURN pin at the sensor connector of the engine harness.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active and Fault Code 2655 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 1 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active?
YES NO

Repair

Replace the bank 1 exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. the removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor RETURN pin in the engine harness ECM connector and the bank 1 exhaust gas temperature sensor RETURN pin in the engine harness sensor connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness sensor connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine wiring harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Turn keyswitch OFF.
  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F].
  • Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-31 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 05-Nov-2017


FAULT CODE 2656 - Engine Exhaust Gas Temperature - Bank 1 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for inactive fault codes. | Fault Code 2655 inactive?
STEP 2. | Check the exhaust gas temperature sensor and circuit. |
 | STEP 2A. Inspect the exhaust gas temperature sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 2655 active and Fault Code 2656 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 2656 active?
STEP 3. | Inspect the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the wiring harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 2656 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the exhaust gas temperature sensor and circuit.

Guided Step 2A - Inspect the exhaust gas temperature sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Inspect the engine harness and bank 1 exhaust gas temperature sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Run the engine until engine oil temperature is above 60°C [140°F]. Use INSITE™ electronic service tool to verify oil temperature.
  • Operate the engine with an idle speed greater than 600 rpm.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2655 active and Fault Code 2656 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the bank 1 exhaust gas temperature sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 active?
YES NO

Repair

Replace the bank 1 exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Repair

None. the removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Inspect the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the ECM and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the bank 1 exhaust gas temperature sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the bank 1 exhaust gas temperature sensor SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2656 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-31 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault codes.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to the appropriate troubleshooting steps.

Last Modified: 26-Sep-2014


FAULT CODE 2727 - SAE J1939 Data Link 2 Engine Network - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 | 4367444
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K117 | 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 2727 active?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Voltage between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect all engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 54 and 66 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2727 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3 and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the battery voltage SUPPLY pins and battery voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Voltage between 21 and 27 VDC ?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.
  • Use the following procedure for OEM harness repair. Refer to Procedure 019-071 in Section 19.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16-pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16-pin power connector and the OEM harness connector at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM .

Action

Check the SAE J1939 data link 2 resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin for identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 54 and 66 ohms?
YES NO

Repair

The SAE J1939 data link 2 resistance is within specification.

There may be a problem with the ECM calibrations.

Check to make sure the appropriate calibrations are installed in the ECMs.

Repair

An open or shorted engine SAE J1939 data link 2 circuit has been detected in the engine harness

For QSK 95 CM2350 engines check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Aug-2016


FAULT CODE 3329 - J1939 Network #2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K108 | 4332823
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK60 CM2350 K121 | 4388645
Engine Control Module | Refer to Procedure 019-031 | QSK50 CM2350 K146G | 5612932
Engine Control Module | Refer to Procedure 019-031 | QSK38 CM2350 K145G | 5612927
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K108 | 4332823
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K116 QSK60 CM2350 K117 | 4367444 4367449
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK60 CM2350 K121 | 4388645
Engine Wiring Harness | Refer to Procedure 019-043 | QSK50 CM2350 K146G | 5612932
Engine Wiring Harness | Refer to Procedure 019-043 | QSK38 CM2350 K145G | 5612927

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 3329 active?
STEP 2. | Check the J1939 data link 2. |
 | STEP 2A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a short circuit in the J1939 data link 2 harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ground in the J1939 data link 2 harness. | Greater than 100k ohms?
 | STEP 2D. Check for an open circuit in the J1939 data link 2 harness. | All measurements less than 10 ohms?
 | STEP 2E. Check the J1939 data link 2 terminating resistance. | 108 to 132 ohms?
 | STEP 2F. Check the J1939 data link 2 terminating resistance. | 108 to 132 ohms?
 | STEP 2G. Check the fault codes. | Fault Code 3329 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Check for active fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 data link 2.

Guided Step 2A - Inspect the engine control module (ECM) and engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a short circuit in the J1939 data link 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from each ECM.

Action

Check for a short circuit in the J1939 data link 2 harness.

  • Measure the resistance between the Society of Automotive Engineers (SAE) J1939 data link 2 (+) wire at the ECM 1 engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link 2 (-) wire at the ECM 1 engine harness connector and all other pins in the connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link 2 (+) and the SAE J1939 data link 2 (-) pins.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the J1939 data link 2 harness.

Troubleshoot each harness connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check for a short circuit to ground in the J1939 data link 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from each ECM.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire at the ECM 1 engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link 2 (-) wire at the ECM 1 engine harness connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • A short circuit to ground has been detected in the J1939 data link 2 harness.
  • Troubleshoot each harness connected in series to determine which one contains the short circuit.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for an open circuit in the J1939 data link 2 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the crossover connector.
  • Disconnect the engine harness connector from ECM 1.

Action

Check for an open circuit in the J1939 data link 2.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire at the left bank engine harness crossover connector and the SAE J1939 data link 2 (+) wire at the ECM 1 engine harness connector.
  • Measure the resistance between the SAE J1939 data link 2 (-) wire at the left bank engine harness crossover connector and the SAE J1939 data link 2 (-) wire at the ECM 1 engine harness connector.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

All measurements less than 10 ohms?
YES NO
No Repair

Repair

  • An open circuit has been detected in the J1939 data link 2.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the J1939 data link 2 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from ECM 1.
  • Disconnect the engine harness at the crossover connector.

Action

Measure the left bank engine harness terminating resistance of the SAE J1939 data link 2.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire and the J1939 data link 2 (-) wire at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

Repair

Incorrect terminating resistance or a short circuit has been detected on the SAE J1939 data link 2 circuit in the left bank engine harness.

For QSK95 CM2350 engines, check the terminating resistors and their connectors.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 3A

Guided Step 2F - Check the J1939 data link 2 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness at the crossover connector.

Action

Measure the right bank engine harness terminating resistance of the SAE J1939 data link 2.

  • Measure the resistance between the SAE J1939 data link 2 (+) wire and the J1939 data link 2 (-) wire at the right bank engine harness crossover connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

Repair

Incorrect terminating resistance or a short circuit has been detected on the SAE J1939 data link 2 circuit in the right bank engine harness.

For QSK95 CM2350 engines, check the terminating resistors and their connectors.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 3A

Guided Step 2G - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect the electronic service tool.

Action

Check the fault codes after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 3329 active?
YES NO
No Repair

Repair

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 16-Jun-2021


FAULT CODE 3331 - J1939 Network #3 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 3331 active?
STEP 2. | Check the J1939 data link #3 devices. |
 | STEP 2A. Inspect the engine fuel supply pump and connector pins. | Damaged or dirty pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2A-2. Check the fault codes. |
 | STEP 2B. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
 | STEP 2B-1. Check the fault codes. |
STEP 3. | Check the J1939 data link #3. |
 | STEP 3A. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the J1939 terminating resistance. | 108 to 132 ohms?
 | STEP 3C. Check for a short circuit in the J1939 data link 3 harness. | Greater than 100k ohms?
 | STEP 3D. Check for a short circuit to ground in the J1939 data link 3 harness. | Greater than 100k ohms?
 | STEP 3E. Check the J1939 data link 3 terminating resistance. | 54 to 66 ohms?
 | STEP 3F. Check the fault codes. | Fault Code 3331 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the J1939 data link #3 devices.

Guided Step 2A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A-2

Guided Step 2A-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel supply pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES NO

Repair

Replace the engine fuel supply pump.

Refer to Procedure 005-241 in the Associated Procedures Table.

Repair

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 2B - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel metering valve or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B-2

Guided Step 2B-2 - Check the fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES NO

Repair

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

Repair

An intermittent short circuit has been detected in the engine harness or connector. Refer to Procedure 019-362 in Section 19.

Repair the damaged engine harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3 - Check the J1939 data link #3.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect both terminating resistors from the J1939 data link 3.

Action

Measure the resistance of the SAE J1939 data link 3 terminating resistors.

  • Measure the resistance between the SAE J1939 data link (+) wire and the J1939 data link (-) pins at both of the SAE J1939 data link 3 terminating resistors.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

108 to 132 ohms?
YES NO
No Repair

Repair

Replace the damaged terminating resistor(s).

Go to 3C

Go to 4A

Guided Step 3C - Check for a short circuit in the J1939 data link 3 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Connect both terminating resistors to the J1939 data link 3.

Action

Check for a short circuit in the J1939 data link 3 harness.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire at the ECM engine harness connector and all other pins in the connector.
  • Measure the resistance between the SAE J1939 data link 3 (-) wire at the ECM engine harness connector and all other pins in the connector.

Disregard any resistance between 50 and 70 ohms between the SAE J1939 data link 3 (+) and the SAE J1939 data link 3 (-) pins.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the J1939 data link 3 harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a short circuit to ground in the J1939 data link 3 harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for a short circuit to ground in the J1939 data link harness.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire at the ECM engine harness connector and ground.
  • Measure the resistance between the SAE J1939 data link 3 (-) wire at the ECM engine harness connector and ground.

Use the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

  • A short circuit to ground has been detected in the J1939 data link 3 harness.
  • Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the J1939 data link 3 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Measure the engine harness terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the engine harness ECM connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO
No Repair

Repair

An open or short circuit has been detected on the SAE J1939 data link 3 circuit in the engine harness.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 3A

Guided Step 3F - Check the fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES NO

Repair

Replace the ECM.

Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

An intermittent short circuit has been detected in the engine harness or connectors. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 11-Aug-2016


FAULT CODE 4643 - Injector Solenoid Driver Cylinder 7 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4643 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4643.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4643 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 7 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2014


FAULT CODE 4644 - Injector Solenoid Driver Cylinder 8 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4644 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4644.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4644 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 8 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the Engine Dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2014


FAULT CODE 4645 - Injector Solenoid Driver Cylinder 9 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4645 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4645.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4645 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 9 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2014


FAULT CODE 4646 - Injector Solenoid Driver Cylinder 10 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4646 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4646.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4646 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 10 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2014


FAULT CODE 4647 - Injector Solenoid Driver Cylinder 11 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4647 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4647.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4647 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 11 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Mar-2014


FAULT CODE 4648 - Injector Solenoid Driver Cylinder 12 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4648 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4648.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4645 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 12 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2014


FAULT CODE 4649 - Injector Solenoid Driver Cylinder 13 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4649 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4649.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4649 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 13 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe® Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the Engine Dataplate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Mar-2014


FAULT CODE 4651 - Injector Solenoid Driver Cylinder 14 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4651 active?
STEP 2. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4651.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4651 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 14 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 21-Mar-2014


FAULT CODE 4652 - Injector Solenoid Driver Cylinder 15 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4652 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4652.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4652 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 15 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Data Plate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 21-Mar-2014


FAULT CODE 4653 - Injector Solenoid Driver Cylinder 16 - Out of Calibration

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4653 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active Fault Code 4653.

  • Use INSITE™ electronic service tool to read the fault code.

Fault Code 4653 active?
YES NO

Repair

The injector bar code adjustable parameter for cylinder 16 is not correct in INSITE™ electronic service tool.

The factory installed injector bar code values can be found in QuickServe™ Online by entering the correct engine serial number (ESN), selecting Service, and then Engine Dataplate. The correct injector bar code values for that ESN are contained in the engine data plate section. If the engine has had a previous repair involving the replacement of injectors, the injector bar code values can be read directly off the top of each injector without the need of removing any additional parts.

Use INSITE™ electronic service tool to correctly enter the injector bar code parameters into the ECM.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Mar-2014


FAULT CODE 5875 - Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5875 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Read the fault codes.

  • Use the electronic service tool to read fault codes.

Fault Code 5875 active?
YES NO

Repair

This is an information only fault code that will only become active if other fault codes are active in the secondary module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active red lamp fault codes in the secondary module(s) are resolved.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Feb-2021


FAULT CODE 5876 - Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5876 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Read the fault codes.

  • Use the electronic service tool to read fault codes.

Fault Code 5876 active?
YES NO

Repair

This is an information only fault code that will only become active if other fault codes are active in the secondary module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active amber lamp fault codes in the secondary module(s) are resolved.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Feb-2021


FAULT CODE 5877 - Other ECUs Have Reported Diagnostic Trouble Codes Affecting Operation - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 5877 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool, or equivalent.

Action

Read the fault codes.

  • Use the electronic service tool to read fault codes.

Fault Code 5877 active?
YES NO

Repair

This is an information only fault code that will only become active if other fault codes are active in the secondary module(s).

Troubleshoot all other active fault codes.

This fault code will become inactive when all other active maintenance lamp fault codes in the secondary module(s) are resolved.

 No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 19-Feb-2021


FAULT CODE 187 (Source Address 00) Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Barometric Air Temperature Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine conrol module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply 2 and return. |
 | STEP 2A. Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the circuit response. |
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply 2 and return.

Guided Step 2A - Inspect the barometric pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the barometric pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the barometric pressure sensor.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Inspect the intake manifold 1 pressure sensor and circuit connected to the sensor supply 2 and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 1 pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the intake manifold 1 pressure/temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A short circuit to ground or return has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Sep-2014


FAULT CODE 187 (Source Address 01) Sensor Supply 2 Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Intake Manifold Pressure/Temperature Sensor | Refer to Procedure 019-159 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine conrol module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 187 active?
STEP 2. | Check the sensors and circuits connected to the sensor number 2 supply and return. |
 | STEP 2A. Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor number 2 supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the ECM. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the circuit response. | Fault Code 187 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault codes inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor number 2 supply and return.

Guided Step 2A - Inspect the intake manifold 2 pressure sensor and circuit connected to the sensor number 2 supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure/temperature sensor from the engine harness.

Action

Inspect the engine harness sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the intake manifold 2 pressure/temperature sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO
No Repair

Repair

Replace the intake manifold 2 pressure/temperature sensor.

  • Refer to Procedure 019-159 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 187 active?
YES NO

Repair

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A short circuit to ground or return has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Sep-2014


FAULT CODE 322 - Injector Solenoid Driver Cylinder 1 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1556 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 322 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 1 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 322 and 1556 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 1 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 1 connector.

Action

  • Inspect injector 1 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 1 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and the injector 1 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 1 SIGNAL pin and the injector 1 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 1 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector 1 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 1 and injector 15 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 15 SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 1 and injector 15 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 15 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 1 and injector 15 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 15 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322 and 1556 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 323 - Injector Solenoid Driver Cylinder 5 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 active?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1552 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2C. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2E. Read the fault codes. | Fault Code 323 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 5 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 323 and 1552 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 5 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 5 connector.

Action

  • Inspect injector 5 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 5 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and the injector 5 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 5 SIGNAL pin and the injector 5 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 5 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 5 and injector 11 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 11 SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 5 and injector 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 11 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 5 and injector 11 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 11 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 323 and 1552 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 324 - Injector Solenoid Driver Cylinder 3 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1554 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 324 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 3 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 324 and 1554 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 3 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 3 connector.

Action

  • Inspect injector 3 wiring harness. Refer to Procedure 006-026 in Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 3 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and the injector 3 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 3 SIGNAL pin and the injector 3 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 3 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 3 and injector 13 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 13 SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 3 and injector 13 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 13 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 3 and injector 13 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 13 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 324 and 1554 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 325 - Injector Solenoid Driver Cylinder 6 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1553 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2d. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 325 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 6 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 325 and 1553 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 6 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 6 connector.

Action

  • Inspect injector 6 wiring harness. Refer to Procedure 006-026 in Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 6 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and the injector 6 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 6 SIGNAL pin and the injector 6 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 6 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 6 and injector 12 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 6 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 12 SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 6 and injector 12 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 12 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 6 and injector 12 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 12 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 325 and 1553 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 331 - Injector Solenoid Driver Cylinder 2 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1554 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 331 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 2 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 331 and 1557 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 2 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injector 2 connector.

Action

  • Inspect Injector 2 wiring harness. Refer to Procedure 006-026 in the Associated Procedure Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 2 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and the injector 2 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 2 SIGNAL pin and the injector 2 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 2 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 2 and injector 16 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 16 SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 2 and injector 16 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 16 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 2 and injector 16 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 16 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 331 and 1557 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 332 - Injector Solenoid Driver Cylinder 4 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1555 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 332 the only active fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector 4 connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 332 and 1555 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 4 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 4 connector.

Action

  • Inspect Injector 4 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 4 connector.

Action

Check the resistance of the injector circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and the injector 4 RETURN pin at the injector connector.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 4 SIGNAL pin and the injector 4 RETURN pin at the ECM connector of the engine harness.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 4 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for 1 minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 is the only active fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 4 and injector 14 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 14 SIGNAL pin and engine block ground.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 4 and injector 14 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 14 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 4 and injector 14 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 14 RETURN pin.

Reference the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 332 and 1555 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 344 - Engine Fuel Filter (Suction Side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K111 | 4358519
Fuel Inlet Pressure | Refer to Procedure 006-104 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 344 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check fuel inlet pressure. | Fuel inlet pressure within specification?
 | STEP 3B. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 3C. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
 | STEP 3D. Check for air in the fuel system. | Air in the fuel?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 344 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

  • Do not rely on the equipment fuel gauge.
  • Verify there is fuel in the tank.

Equipment has adequate fuel supply?
YES NO
No Repair

Repair

Perform repairs to the equipment's tank or fuel gauge.

Add fuel to the fuel tank.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Kinked or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or equipment manufacturer service information.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within specification?
YES NO
No Repair

Repair

If the fuel inlet gauge pressure is not within specification, inspect the following:

  • Customer fuel supply system
  • Original equipment manufacturer (OEM) fuel supply system.

If engine is equipped with multiple Stage 0 fuel-water separators, repeat fuel inlet gauge pressure measurement on each Stage 0 fuel-water separator.

Go to 3C

Go to 3B

Guided Step 3B - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236?
YES NO

Repair

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Repair

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Refer to Procedure 019-549 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
YES NO
No Repair

Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair

Investigate the cause of air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 03-Aug-2017


FAULT CODE 449 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K111 | 4358519
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 449 active or high inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify fuel rail pressure sensor part number. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
 | STEP 2B. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 4. | Check for air in the fuel. |
 | STEP 4A. Check for air in the fuel system. | Air in the fuel?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 449 active or high inactive counts?
YES NO

Repair

A malfunctioning fuel pressure relief valve has been detected.

Replace the high-pressure fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 1B

Go to 5A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair

Repair the source of the high fuel drain line restriction.

Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for air in the fuel.

Guided Step 4A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

Repair

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 699 (sa00) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Verify that all steps have been completed. If all steps have been completed, then follow technical escalation process.

Repair complete

Last Modified: 25-Jul-2017


FAULT CODE 699 (sa01) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388666

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or Call for assistance

Repair complete

Last Modified: 25-Jul-2017


FAULT CODE 699 (sa144) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete

Last Modified: 07-Aug-2017


FAULT CODE 699 (sa186) - Engine ECU Temperature - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 699 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete

Last Modified: 03-Aug-2017


FAULT CODE 782 - SAE J1939 Data Link 2 Engine Network - No Data Received - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 782 active or inactive with more than 1 count in the last 25 engine hours?
 | STEP 1B. Check for related fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 VDC?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 782 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Check for correct ECM supply voltage.

  • Measure the voltage between the ECM power supply voltage SUPPLY pins and the ECM power supply voltage RETURN pins in the OEM harness connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

Check for an open keyswitch signal circuit.

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM harness connector at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only if there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check the SAE J1939 data link 2 engine network resistance.

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

Repair

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

Repair

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 1379 - Fuel Supply Pump Intake Pressure - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K111 | 4358519
Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K111 | 4358519
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, or 6711 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has an adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked, restricted, or damaged fuel lines?
 | STEP 2C. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check for air in the fuel system. | Air in the fuel?
 | STEP 3B. Check fuel inlet restriction. | Fuel inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedure Table?
 | STEP 3C. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Check the fault codes.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, or 6711 active or inactive with more than one count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

  • Check for adequate fuel supply.
  • Do not rely on the equipment fuel gauge.
  • Verify there is fuel in the tank.

Equipment has an adequate fuel supply?
YES NO
No Repair

Repair

If necessary, repair:

  • Equipment fuel tank
  • Fuel gauge.

Add fuel to the equipment fuel tank.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction and low-pressure fuel lines for kinks or damage.

Kinked, restricted, or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 1 fuel filter head.

Action

  • Check the fuel supply pump intake pressure sensor accuracy.
  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

  • Check for air in the fuel.
  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair

Repair or replace the malfunctioning component(s).

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check fuel inlet restriction.

Conditions

  • Turn keyswitch ON.

Action

  • Check the fuel inlet restriction.
  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet restriction within the specifications found in Procedure 006-104 in the Associated Procedures Table?
YES NO
No Repair

Repair

Repair or replace the malfunctioning component(s). See equipment manufacturer service information.

Go to 3C

Go to 4A

Guided Step 3C - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

  • Check the Stage 1 fuel filter restriction.
  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

Repair

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table

Repair

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.
  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 04-Dec-2019


FAULT CODE 1389 - Fuel Supply Pump Intake Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Filter Head (Stage 1) | Refer to Procedure 006-079 | QSK95 CM2350 K113 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4358519
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the fuel supply system. |
 | STEP 2A. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
STEP 3. | Check for fuel recirculation line restriction. |
 | STEP 3A. Check fuel recirculation line restriction. | Kinked, restricted, or damaged fuel lines?
 | STEP 3B. Check pressure regulator valve restriction. | Pressure regulator valve damaged or restricted?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894 active or inactive with more than 1 count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel supply system.

Guided Step 2A - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

  • Refer to Procedure 019-549 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
YES NO
No Repair

Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for fuel recirculation line restriction.

Guided Step 3A - Check fuel recirculation line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

  • See equipment manufacturer service information.

Kinked, restricted, or damaged fuel lines?
YES NO
No Repair

Repair

Replace the source of the high fuel drain line restriction. See equipment manufacturer service information.

Go to 3B

Go to 4A

Guided Step 3B - Check pressure regulator valve restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

I

  • Refer to Procedure 006-079 in the Associated Procedures Table.

Pressure regulator valve damaged or restricted?
YES NO

Repair

Repair or replace the pressure regulator valve. Refer to Procedure 006-079 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 1548 - Injector Solenoid Driver Cylinder 7 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1622 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1548 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1548 and 1622 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 7 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 7 connector.

Action

  • Inspect injector 7 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 7 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 7 SIGNAL pin and the injector 7 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 7 SIGNAL pin and the injector 7 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 7 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 7 and injector 9 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 9 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 7 and injector 9 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 7 and injector 9 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1548 and 1622 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 1549 - Injector Solenoid Driver Cylinder 8 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1551 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1549 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1549 and 1551 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 8 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 8 connector.

Action

  • Inspect injector 8 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 8 connector.

Action

Checkthe resistance of the injector solenoid.

  • Measure the resistance between the injector 8 SIGNAL pin and the injector 8 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 8 SIGNAL pin and the injector 8 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 8 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 8 and injector 10 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 10 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 8 and injector 10 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 8 and injector 10 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1549 and 1551 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 1551 - Injector Solenoid Driver Cylinder 10 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1551 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1549 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1551 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1549 and 1551 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 10 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 10 connector.

Action

  • Inspect injector 10 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 10 connector.

Action

Checkthe resistance of the injector solenoid.

  • Measure the resistance between the injector 10 SIGNAL pin and the injector 10 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 10 SIGNAL pin and the injector 10 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 10 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 8 and injector 10 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 8 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 10 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 8 and injector 10 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 8 and injector 10 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 8 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 10 SIGNAL pin.
  • Measure the resistance from the injector 8 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 10 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1549 and 1551 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

Same multiple (same bank) injector fault codes active?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 20-Feb-2017


FAULT CODE 1552 - Injector Solenoid Driver Cylinder 11 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1552 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 323 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1552 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 323 and 1552 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 11 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 11 connector.

Action

  • Inspect injector 11 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 11 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 11 SIGNAL pin and the injector 11 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 11 SIGNAL pin and the injector 11 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 11 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 5 and injector 11 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 5 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 11 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 5 and injector 11 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 11 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 5 and injector 11 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 5 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 11 SIGNAL pin.
  • Measure the resistance from the injector 5 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 11 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 323 and 1552 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 21-Feb-2017


FAULT CODE 1553 - Injector Solenoid Driver Cylinder 12 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1553 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 325 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1553 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 325 and 1553 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 12 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 12 connector.

Action

  • Inspect injector 12 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 12 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 12 SIGNAL pin and the injector 12 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 12 SIGNAL pin and the injector 12 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 12 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 6 and injector 12 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 6 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 12 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 6 and injector 12 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 12 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 6 and injector 12 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 6 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 12 SIGNAL pin.
  • Measure the resistance from the injector 6 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 12 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 325 and 1553 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 21-Feb-2017


FAULT CODE 1554 - Injector Solenoid Driver Cylinder 13 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1554 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 324 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. | Damaged injector wiring harness or connector?
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes | Fault Code 1554 is the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to the ECM power supply ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins, or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to the ECM power supply ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 324 and 1554 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 13 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 13 connector.

Action

  • Inspect injector 13 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 13 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 13 SIGNAL pin and the injector 13 RETURN pin at the injector connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 13 SIGNAL pin and the injector 13 RETURN pin at the ECM connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 13 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 3 and injector 13 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to the ECM power supply ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 3 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 13 SIGNAL pin and engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to the ECM power supply ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 3 and injector 13 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 13 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ECM power supply ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 3 and injector 13 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 3 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 13 SIGNAL pin.
  • Measure the resistance from the injector 3 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 13 RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ECM power supply ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 324 and 1554 active?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.”

No Repair

Go to 1A

Repair complete.

Last Modified: 15-Feb-2017


FAULT CODE 1555 - Injector Solenoid Driver Cylinder 14 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1555 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 332 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1555 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 332 and 1555 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 14 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 14 connector.

Action

  • Inspect injector 14 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 14 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 14 SIGNAL pin and the injector 14 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 14 SIGNAL pin and the injector 14 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 14 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 4 and injector 14 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 4 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 14 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 4 and injector 14 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 14 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 4 and injector 14 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 4 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 14 SIGNAL pin.
  • Measure the resistance from the injector 4 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 14 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 332 and 1555 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 21-Feb-2017


FAULT CODE 1556 - Injector Solenoid Driver Cylinder 15 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1556 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 322 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1556 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 232 and 1556 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 15 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 15 connector.

Action

  • Inspect injector 15 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 15 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 15 SIGNAL pin and the injector 15 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 15 SIGNAL pin and the injector 15 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 15 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 1 and injector 15 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 1 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 15 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 1 and injector 15 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 15 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 1 and injector 15 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 1 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 15 SIGNAL pin.
  • Measure the resistance from the injector 1 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 15 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 322 and 1556 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 21-Feb-2017


FAULT CODE 1557 - Injector Solenoid Driver Cylinder 16 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1557 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 331 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2c. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1557 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 331 and 1557 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes with INSITE™ electronic service tool.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 16 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 16 connector.

Action

  • Inspect injector 16 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 16 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 16 SIGNAL pin and the injector 16 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector circuit.

  • Measure the resistance between the injector 16 SIGNAL pin and the injector 16 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 16 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 2 and injector 16 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 2 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 16 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 2 and injector 16 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 16 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 2 and injector 16 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 2 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 16 SIGNAL pin.
  • Measure the resistance from the injector 2 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 16 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 331 and 1557 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 21-Feb-2017


FAULT CODE 1622 - Injector Solenoid Driver Cylinder 9 Circuit - Current Below Normal or Open Circuit

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

The injector solenoids receive high voltage when the engine is operating. To reduce the possibility of personal injury from electrical shock, do not wear jewelry or damp clothing, and do not touch the injector solenoids or the solenoid wires when the engine is operating.
CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1662 active or inactive with more than one count logged in the last 25 engine hours?
 | STEP 1B. Read the fault codes with INSITE™ electronic service tool. | Fault Code 1548 also active?
STEP 2. | Check the injector and injector circuit for an open circuit. |
 | STEP 2A. Inspect the injector connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the injector wiring harness and connector pins. |
 | STEP 2C. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2D. Inspect the engine harness and the ECM connector pins. | Dirty or damaged pins?
 | STEP 2E. Check for an open circuit. | Resistance between 0.5 and 5 ohms?
 | STEP 2F. Read the fault codes. | Fault Code 1622 the only active injector fault code?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and injector connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the injector solenoids for short circuits to ground. | Greater than 100k ohms?
 | STEP 3C. Inspect the engine harness. | Dirty or damaged pins or damaged wire insulation?
 | STEP 3D. Check the engine harness for a short circuit to ground. | Greater than 100k ohms?
 | STEP 3E. Check the engine harness for pin-to-pin short circuits. | Greater than 100k ohms?
 | STEP 3F. Read the fault codes. | Fault Codes 1548 and 1622 active?
STEP 4. | Check the ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1662 active or inactive with more than one count logged in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Read the fault codes with INSITE™ electronic service tool.

Conditions

  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the injector and injector circuit for an open circuit.

Guided Step 2A - Inspect the injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 9 connector.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the injector wiring harness and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 9 connector.

Action

  • Inspect injector 9 wiring harness. Refer to Procedure 006-026 in the Associated Procedures Table.

Damaged injector wiring harness or connector?
YES NO

Repair

Repair or replace the injector wiring harness, if possible. Refer to Procedure 006-026 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the injector 9 connector.

Action

Check the resistance of the injector solenoid.

  • Measure the resistance between the injector 9 SIGNAL pin and the injector 9 RETURN pin at the injector connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

Replace the injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Inspect the engine harness and the ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and the ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check for an open circuit.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Check for continuity in the injector.

  • Measure the resistance between the injector 9 SIGNAL pin and the injector 9 RETURN pin at the ECM connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Resistance between 0.5 and 5 ohms?
YES NO
No Repair

Repair

An open or pin-to-pin short circuit has been detected on the injector 9 circuit.

Troubleshoot each section of the circuit to determine which one contains the open or short.

Repair or repace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 is the only active injector fault code?

YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and injector connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the injector 7 and injector 9 connectors.

Action

Inspect the engine harness and injector connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the injector or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the injector solenoids for short circuits to ground.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect the engine harness from the injectors being tested.

Action

Check for a short circuit to ground.

  • Measure the resistance between the injector 7 SIGNAL pin and engine block ground.
  • Measure the resistance between the injector 9 SIGNAL pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the shorted injector(s). Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins or damaged wire insulation?
YES NO

Repair

A damaged connection has been detected inthe ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3D

Guided Step 3D - Check the engine harness for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 7 and injector 9 connectors.

Action

Check for a short circuit to ground.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to engine block ground. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to engine block ground. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check the engine harness for pin-to-pin short circuits.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine harness from the injector 7 and injector 9 connectors.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance from the injector 7 SIGNAL pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check at the injector 9 SIGNAL pin.
  • Measure the resistance from the injector 7 RETURN pin at the ECM connector of the engine harness to all other pins in the connector. Repeat the check for the injector 9 RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short has been detected in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Read the fault codes.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.
  • Turn keyswitch ON.

Action

Operate the engine and observe the fault codes.

  • Use INSITE™ electronic service tool to clear the fault codes.
  • Start the engine and let it idle for one minute.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 1548 and 1622 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installaion of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check the ECM calibration and clear the fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision numbers are found in the Calibration Information section of System ID and Dataplate in Features & Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Go to 1A

Last Modified: 21-Feb-2017


FAULT CODE 1695 (Source Address 00) - Sensor Supply 5 - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1695 inactive?
STEP 2. | Check the ECM and harness. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 2C. Check for a short circuit to ECM battery (+) in the harness. | Greater than 100k ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1695 active?
YES | NO
No Repair | No Repair

2A

Use the following procedure for active or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the ECM and harness.

Guided Step 2A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the engine high temperature coolant level sensor from the OEM harness.
  • Disconnect the crankcase pressure 2 sensor from the engine harness

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the sensor SUPPLY 5 pin at the OEM harness ECM connector to all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 27-Jun-2014


FAULT CODE 1696 (Source Address 00) - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Inspect the high temperature coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
 | STEP 2B. Inspect the crankcase pressure 2 sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2B-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Inspect the high temperature coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high temperature coolant level sensor from the OEM harness.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the high temperature coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair

Replace the high temperature coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 2B - Inspect the crankcase pressure 2 sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B-1

Guided Step 2B-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair

Replace the crankcase pressure 2 sensor.

Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and original equipment manufacturer (OEM) harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the high temperature coolant level sensor from the OEM harness.
  • Disconnect the crankcase pressure 2 sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 3C

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the high temperature coolant level sensor from the OEM harness.
  • Disconnect the crankcase pressure 2 sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness: Refer to Procedure 019-071 in Section 19.
  • For the engine harness: Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 1696 (Source Address 144 90) - Sensor Supply 5 - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Coolant Level Sensor | Refer to Procedure 019-017 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 1696 active?
STEP 2. | Check the sensors and circuits connected to the sensor supply return. |
 | STEP 2A. Inspect the low temperature coolant level sensor and circuit connected to the sensor supply and return. | Dirty or damaged pins?
 | STEP 2A-1. Check the circuit response. |
STEP 3. | Check the engine control module (ECM) and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the sensors and circuits connected to the sensor supply return.

Guided Step 2A - Inspect the low temperature coolant level sensor and circuit connected to the sensor supply and return.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low temperature coolant level sensor from the OEM harness.

Action

Inspect the OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2A-1

Guided Step 2A-1 - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the low temperature coolant level sensor from the OEM harness.
  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1696 active?
YES NO
No Repair

Repair

Replace the low temperature coolant level sensor.

Refer to Procedure 019-017 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the low temperature coolant level sensor from the OEM harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the low temperature coolant level sensor from the OEM harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance and check for a short circuit between the sensor supply 5 pin in the OEM harness ECM connector and engine block ground.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected.

Troubleshoot all harnesses connected in series to determine which one contains the short circuit.

Repair or replace the damaged section of the harness.

  • For the OEM harness. Refer to Procedure 019-071 in Section 19.
  • For the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Jun-2014


FAULT CODE 1774 - Engine Oil Priming Pump Control Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1774 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the original equipment manufacturer (OEM) switch and circuit. |
 | STEP 2A. Inspect the OEM switch and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the OEM switch resistance. | Less than 10 ohms?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1774 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault code troubleshooting. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the OEM switch and circuit.

Guided Step 2A - Inspect the OEM switch and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM switch from the OEM harness.

Action

Inspect the OEM harness and switch connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the switch or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the OEM wiring harness. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the OEM switch resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM switch from the OEM harness.
  • Remove the OEM switch from the oil passage.

Action

  • Measure the resistance of the OEM switch.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO

Repair

An open or short circuit has been detected in the OEM switch circuit. The OEM can configure the OEM switch SIGNAL circuit to be switched to ground or voltage source. See equipment manufacturer service information on the engine’s configuration.

Repair

Replace the OEM switch. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to clear the fault codes. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete

Last Modified: 25-Jul-2017


FAULT CODE 1775 - Engine Oil Priming Pump Control Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 1775 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the relay and circuit. |
 | STEP 2A. Inspect the relay and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the relay for an open circuit. | Greater than 100k ohms?
 | STEP 2C. Check for an open circuit in the relay return circuit. | Less than 10 ohms?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the OEM harness | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the OEM harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 1775 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1775 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for intermittent or inactive fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the relay and circuit.

Guided Step 2A - Inspect the relay and connector pins.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the original equipment manufacturer (OEM) harness.

Action

Inspect the OEM harness and relay connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the relay or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the relay for an open circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the OEM harness.

Action

  • Measure the resistance between the relay SIGNAL pin and the relay RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

Replace the relay. See equipment manufacturer service information.

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the relay return circuit.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the relay from the OEM harness.
  • Disconnect the OEM harness from the ECM connector.

Action

  • Measure the resistance between the relay RETURN pin at the relay connector to ground.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit on the RETURN wire has been detected. Refer to the OEM wiring diagram for RETURN wire configuration.

If the return is wired to the ECM, repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

If the RETURN wire is grounded to the chassis or engine block ground, repair the source of the damaged connection.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3A

Go to 4A

Guided Step 3 - Check the ECM and original equipment manufacturer (OEM) harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the OEM harness.

Conditions

  • Energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector. Disconnect the relay from the OEM harness.

Action

  • Measure the resistance between the engine harness ECM connector relay RETURN pin and the OEM harness relay connector RETURN pin.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Troubleshoot any remaining fault codes.

Go to 3C

Less than 10 ohms?

Guided Step 3C - Check for a pin-to-pin short circuit in the OEM harness.

Conditions

  • De-energize keyswitch circuit.
  • Disconnect the OEM harness from the ECM connector.
  • Disconnect the relay from the OEM harness.

Action

  • Measure the resistance between the relay SIGNAL pin in the OEM ECM connector and all other pins in the OEM connector.

Use a wiring diagram for pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the output device driver SIGNAL wire has been detected in the OEM harness.

Repair or replace the OEM harness. Refer to Procedure 019-071 in Section 19.

Go to 3D

Go to 4A

Guided Step 3D - Check for active fault code.

Conditions

  • Connect all components.
  • Energize keyswitch circuit.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1775 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 2249 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K113 | 4388663
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K113 | 4388663
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K113 | 4388663
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K113 | 4388663
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K113 | 4388663
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K113 | 4388663
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fuel delivery pressure sensor, engine fuel supply pump, fuel filter differential pressure, fuel metering valve, or fuel leak indicator tank fault codes. | Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, 4961, 6594 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check the operation of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 2B. Check for air in the fuel system. | Air in fuel system?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
 | STEP 2D. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
 | STEP 2E. Check the operation of the high-pressure fuel pump. | Fault Code 559 active?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fuel delivery pressure sensor, engine fuel supply pump, fuel filter differential pressure, fuel metering valve, or fuel leak indicator tank fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, 4961, 6594 active or inactive with more than 1 count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the operation of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

  • Perform the High-Pressure Fuel System Leak Test. Refer to Procedure 005-236 in the Associated Procedures Table.

High-pressure fuel line leaks or damage?
YES NO

Repair

Replace any damaged high-pressure fuel supply lines. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel system?
YES NO

Repair

Repair or replace the malfunctioning component(s).

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the operation of the high-pressure fuel pump.

Conditions

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool Fuel System Leakage Test to raise the fuel rail pressure.

Fault Code 559 active?
YES NO

Repair

Replace the high-pressure fuel pump assembly. Refer to Procedure 005-016 in the Associated Procedure.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 3697 - Engine Control Module Calibration Memory - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 111 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Calibrate the engine control module (ECM). |
 | STEP 2A. Calibrate the ECM. | Fault Code 3697 active after calibrating the ECM?
 | STEP 2B. Disable and clear the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Fault Code 111 troubleshooting tree.

Go to 2A

Guided Step 2 - Calibrate the ECM.

Guided Step 2A - Calibrate the ECM.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

Fault Code 3697 active after calibrating the ECM?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable and clear the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 3727 - High-Pressure Common Rail Fuel Pressure Relief Valve - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K111 | 4358519
Injector Supply Line (High-Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the high-pressure fuel system. |
 | STEP 1A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 1B. Check for an active fault code. | Active or inactive counts of Fault Code 3727?
 | STEP 1C. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
 | STEP 1D. Check for an active fault. | Active or additional inactive counts of Fault Code 3741?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the high-pressure fuel system.

Guided Step 1A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check the high-pressure fuel system for fuel leaking at the outer wall fuel drain hose.

High-pressure fuel line leaks or damage?
YES NO

Repair

Replace any damaged high-pressure fuel supply lines. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1B

Guided Step 1B - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 3727?
YES NO

Repair

A malfunctioning fuel pressure relief valve has been detected.

Replace the high-pressure fuel pump. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 1C

Go to 2A

Guided Step 1C - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in procedure 019-115?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 1D

Go to 2A

Guided Step 1D - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes. Note the number of counts of Fault Code 3741.
  • Operate the engine in a manner that utilizes multiple accelerations and decelerations while lightly loaded.
  • Check for an active or additional inactive counts of Fault Code 3741.
  • Use INSITE™ electronic service tool to read the fault codes.

Active or additional inactive counts of Fault Code 3741?
YES | NO
No Repair | No Repair

Troubleshoot Fault Code 3741.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4688 - Water in Fuel Indicator 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4688 active?
STEP 2. | Check the water in fuel sensor 2 and circuit. |
 | STEP 2A. Inspect the engine harness and water in fuel sensor 2 connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4689 active and Fault Code 4688 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4688 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3B-1. Check for an open circuit in the engine harness. |
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 4688 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor 2 and circuit.

Guided Step 2A - Inspect the engine harness and water in fuel sensor 2 connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness connector.

Action

Inspect the engine harness and water in fuel sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the water in fuel sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Place a jumper wire between the water in fuel sensor 2 SIGNAL pin and the water in fuel sensor 2 RETURN pin at the sensor connector of the engine harness.

Use the circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active and Fault Code 4688 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES NO

Repair

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor 2. Refer to Procedure 019-127 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirty or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspect techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 connector from the engine harness connector.

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector water in fuel sensor 2 RETURN pin and the engine harness water in fuel sensor 2 connector RETURN pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3B-1

Go to 4A

Guided Step 3B-1 - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM connector water in fuel sensor 2 SIGNAL pin and the engine harness water in fuel sensor 2 connector SIGNAL pin.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the engine harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Replace the damaged section of engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the water in fuel sensor 2 connector from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water in fuel sensor 2 SIGNAL pin in the OEM connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspect techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

  • Use the circuit diagram or wiring diagram for all harness interconnections.
  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault codes.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2015


FAULT CODE 4689 - Water in Fuel Indicator 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Water in Fuel Sensor | Refer to Procedure 019-127 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4689 active?
STEP 2. | Check the water in fuel sensor 2 and circuit. |
 | STEP 2A. Inspect the water in fuel sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4688 active and Fault Code 4689 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4689 active?
STEP 3. | Check the ECM and original equipment manufacturer (OEM) engine harness. |
 | STEP 3A. Inspect the ECM and OEM engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3C. Check for a pin-to-ground short circuit. | Greater than 100k ohms?
 | STEP 3D. Check for an active fault code. | Fault Code 4688 active?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the water in fuel sensor 2 and circuit.

Guided Step 2A - Inspect the water in fuel sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness.

Action

Inspect the engine harness and water in fuel sensor 2 connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connectors, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the water in fuel sensor 2 from the engine harness connector.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active and Fault Code 4689 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the water in fuel sensor 2 to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4689 active?
YES NO

Repair

A damaged water in fuel sensor has been detected.

Replace the water in fuel sensor 2.

Refer to Procedure 019-127 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and OEM engine harness.

Guided Step 3A - Inspect the ECM and OEM engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirty or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspect techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water in fuel sensor 2 connector from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the water in fuel sensor 2 SIGNAL pin in the connector and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspect techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

  • Use the circuit diagram or wiring diagram for all harness interconnections.
  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the water in fuel sensor 2 from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the water in fuel sensor 2 SIGNAL pin in the OEM harness ECM connector and ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general inspect techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

  • Use the circuit diagram or wiring diagram for all harness interconnections.
  • Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an active fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4688 active?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact the nearest Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 24-Aug-2015


FAULT CODE 4883 - Engine Oil Priming State - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
OEM Wiring Harness | Refer to Procedure 019-071 | QSK95 CM2350 K111 | 4358519
Fuel Pump Lubricating Oil Pressure Sensor | Refer to Procedure 019-679 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K111 | 4358519
Engine Oil Pressure Sensor/Switch | Refer to Procedure 019-066 | QSK95 CM2350 K111 | 4358519
Pre-Lubricating Oil Pump | Refer to Procedure 007-063 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for primary fault codes. | Fault Code 1774, 1775, 5119, 5121, 7313, or 7314 active?
STEP 2. | Check the pre-lubricating oil system. |
 | STEP 2A. Check engine oil level. | Oil level on the dipstick?
 | STEP 2B. Inspect the pre-lubricating oil system. | Damaged or leaking components?
STEP 3. | Check the pre-lubricating oil pump supply voltage. |
 | STEP 3A. Check the pre-lubricating oil pump supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3B. Check for an open pre-lubricating oil pump supply circuit. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the fuel pump lubricating oil supply pressure component. |
 | STEP 4A. Check the pre-lubricating oil system pressure. | Pressure greater than 83 kPa [12 psi]?
 | STEP 4B. Component verification check. | Fuel pump lubricating oil supply pressure sensor is installed?
 | STEP 4C. Fuel pump lubricating oil supply pressure sensor component check. | Fuel pump lubricating oil supply pressure sensor within specification?
 | STEP 4D. Fuel pump lubricating oil supply pressure switch component check. | Fuel pump lubricating oil supply pressure switch within specification?
 | STEP 4E. Check the oil pressure sensor reading. | Oil pressure sensor reading within specification found in Procedure 019-066?
STEP 5. | Check the pre-lubricating oil pump. |
 | STEP 5A. Check the pre-lubricating oil pump. | Pre-lubricating oil pump operating correctly?
STEP 6. | Check the engine crankcase components. |
 | STEP 6A. Check for an internal pre-lubricating oil leak. | Malfunctioning or damaged engine components?
STEP 7. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 7A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 7B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for primary fault codes.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Turn keyswitch ON.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 1774, 1775, 5119, 5121, 7313, or 7314 active?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault code.

Go to 2A

Guided Step 2 - Check the pre-lubricating oil system.

Guided Step 2A - Check engine oil level.

Conditions

  • Turn keyswitch OFF.

Action

Check the engine oil level.

Oil level on the dipstick?
YES NO
No Repair

Repair

Add oil to the engine.

Go to 2B

Go to 7A

Guided Step 2B - Inspect the pre-lubricating oil system.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the pre-lubricating oil pump and external engine oil lines for damage or leaks.

Damaged or leaking components?
YES NO

Repair

Repair or replace the damaged or leaking component(s).

 No Repair

Go to 7A

Go to 3A

Guided Step 3 - Check the pre-lubricating oil pump supply voltage.

Guided Step 3A - Check the pre-lubricating oil pump supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-lubricating oil pump from the OEM wiring harness.

Action

Turn keyswitch ON.

  • Use the recommended Cummins electronic service tool or equivalent tool to override the pre-lubricating oil pump using the Prelube Control found in the Advanced ECM Data section.
  • Measure the voltage from the pre-lubricating oil pump SUPPLY pin to the pre-lubricating oil pump RETURN pin at the OEM wiring harness pre- lubricating connector. Refer to OEM service manual.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check pre-lubricating oil pump supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the pre-lubricating oil pump from the OEM wiring harness.

Action

Turn keyswitch ON.

  • Use the recommended Cummins electronic service tool or equivalent tool to override the pre-lubricating oil pump using the Prelube Control found in the Advanced ECM Data section.
  • Measure the voltage from the pre-lubricating oil pump SUPPLY pin in the harness pre-lubricating oil pump connector to the engine block ground. Refer to OEM service manual.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the pre-lubricating oil pump return circuit.

Repair or replace OEM wiring harness. Refer to Procedure 019-071 in Associated Procedure Table.

Repair

An open circuit has been detected in the pre-lubricating oil pump supply circuit.

Check for a malfunctioning or missing relay. Troubleshoot all wiring harnesses in the circuit. Repair or replace the damaged component(s), as necessary.

See equipment manufacturer service information.

Go to 7A

Go to 7A

Guided Step 4 - Check the fuel pump lubricating oil supply pressure component.

Guided Step 4A - Check the pre-lubricating oil system pressure.

Conditions

  • Turn keyswitch OFF.

Action

Install a pressure gauge in the pre-lubricating oil system. Refer to Procedure 019-679 in the Associated Procedures Table.

  • Use the recommended Cummins electronic service tool or equivalent tool to override the pre-lubricating oil pump using the Prelube Control found in the Advanced ECM Data section.
  • Monitor the pre-lubricating oil pressure with the gauge.

Pressure greater than 83 kPa [12 psi]?
YES | NO
No Repair | No Repair

Go to 4B

Go to 5A

Guided Step 4B - Component verification check.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify the fuel pump lubricating oil supply pressure sensor is installed, or the fuel pump lubricating oil supply pressure switch is installed.

Fuel pump lubricating oil supply pressure sensor is installed?
YES | NO
No Repair | No Repair

Go to 4C

Go to 4D

Guided Step 4C - Fuel pump lubricating oil supply pressure sensor component check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor from the engine wiring harness.

Action

Check for a malfunctioning fuel pump lubricating oil supply pressure sensor.

  • Inspect the fuel pump lubricating oil supply pressure sensor. Refer to Procedure 019-679 in the Associated Procedure Table.

Fuel pump lubricating oil supply pressure sensor within specification?
YES NO
No Repair

Repair

Replace the fuel pump lubricating oil supply pressure sensor. Refer to Procedure 019-679 in the Associated Procedure Table.

Go to 5A

Go to 7A

Guided Step 4D - Fuel pump lubricating oil supply pressure switch component check.

Conditions

  • · Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure switch from the engine wiring harness.

Action

Check for a malfunctioning fuel pump lubricating oil supply pressure switch.

  • Inspect the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedure Table.

Fuel pump lubricating oil supply pressure switch within specification?
YES NO
No Repair

Repair

Replace the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedure Table.

Go to 4E

Go to 7A

Guided Step 4E - Check the oil pressure sensor reading.

Conditions

  • Turn keyswitch OFF.

Action

Check the oil pressure sensor accuracy.

Refer to Procedure 019-066 in the Associated Procedures Table.

Oil pressure sensor reading within specification found in procedure 019-066 in tne Associated Procedures Table?

YES NO
No Repair

Repair

Replace the oil pressure sensor. Refer to Procedure 019-066 in the Associated Procedures Table.

Go to 7A

Go to 7A

Guided Step 5 - Check the pre-lubricating oil pump.

Guided Step 5A - Check the pre-lubricating oil pump.

Conditions

  • Turn keyswitch OFF.

Action

Verify the pre-lubricating oil pump is functioning properly.

Refer to Procedure 007-063 in the Associated Procedures Table.

Pre-lubricating oil pump operating correctly?
YES NO
No Repair

Repair

Replace the pre-lubricating oil pump. Refer to Procedure 007-063 in the Associated Procedures Table.

Go to 6A

Go to 7A

Guided Step 6 - Check the engine crankcase components.

Guided Step 6A - Check for an internal prelubricating oil leak.

Conditions

  • Remove the hand hole covers from the engine. Refer to Procedure 001-035 in the Associated Procedures Table.
  • Turn keyswitch ON.

Action

Use the recommended Cummins electronic service tool or equivalent tool to override the pre-lubricating oil pump using the Prelube Control found in the Advanced ECM Data section.

Inspect the internal engine for unintended oil leaks at pre-lubricating pressure.

  • Check for damaged or missing piston cooling nozzles. Oil should not leak from the piston cooling nozzles during the pre-lubricating cycle.
  • Check for a leaking or damaged pre-lubricating oil crossover line in the crankcase.

Malfunctioning or damaged engine components?
YES NO

Repair

Tighten any loose piston cooling nozzles.

Repair or replace any malfunctioning components. See equipment manufacturer service information.

No Repair

Go to 7A

Go to 7A

Guided Step 7 - Check ECM calibration and clear fault codes.

Guided Step 7A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Recalibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 7B

Go to 7B

Guided Step 7B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

 No Repair

Escalate or Call for assistance.

Repair complete.

Last Modified: 10-Aug-2021


FAULT CODE 4884 - Engine Oil Priming Pump Control - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Multimeter Usage | Refer to Procedure 019-359 | QSK95 CM2350 K111 | 4358519
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K111 | 4358519
Fuel Pump Lubricating Oil Pressure Sensor | Refer to Procedure 019-679 | QSK95 CM2350 K111 | 4358519
OEM Wiring Harness | Refer to Procedure 019-071 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Inactive or Intermittent Fault Code | Refer to Procedure 019-362 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4884 active?
STEP 2. | Check the pre-lubricating oil pump. |
 | STEP 2A. Check the pre-lubricating oil pump supply voltage. | Voltage greater than 5 VDC?
 | STEP 2B. Verification component check. | Switch or sensor?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
STEP 3. | Fuel pump lubricating oil supply pressure component check. |
 | STEP 3A. Fuel pump lubricating oil supply pressure switch resistance check. | Malfunctioning switch?
 | STEP 3B. Fuel pump lubricating oil supply pressure sensor check. | Malfunctioning sensor?
STEP 4. | Fuel pump lubricating oil supply pressure sensor circuit check. |
 | STEP 4A. Fuel pump lubricating oil supply pressure sensor open circuit check. | Greater than 10 ohms?
 | STEP 4B. Fuel pump lubricating oil supply pressure sensor circuit pin to ground check. | Resistance less than 100k ohms?
 | STEP 4C. Fuel pump lubricating oil supply pressure sensor circuit pin to pin check. | Resistance less than 100k ohms?
STEP 5. | Fuel pump lubricating oil supply pressure switch circuit check. |
 | STEP 5A. Fuel pump lubricating oil supply pressure switch open circuit check. | Greater than 10 ohms?
 | STEP 5B. Fuel pump lubricating oil supply pressure switch circuit pin to ground check. | Resistance less than 100k ohms?
 | STEP 5C. Fuel pump lubricating oil supply pressure switch circuit pin to pin check. | Resistance less than 100k ohms?
STEP 6. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 6A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 6B. Disable the fault code. | Fault code active?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the electronic service tool to read the active fault codes.

Fault Code 4884 active?
YES | NO
No Repair | No Repair

Go to 2A

Refer to Procedure 019-362 in the Associated Procedures Table.

Guided Step 2 - Check the pre-lubricating oil pump.

Guided Step 2A - Check the pre-lubricating oil pump supply voltage.

Conditions

  • Turn keyswitch ON.
  • Disconnect the harness from the pre-lubricating oil pump.

Action

Check for a short circuit in the pre-lubricating oil pump supply circuit.

  • Measure the voltage from the pre-lubricating oil pump SUPPLY pin to the pre-lubricating oil pump RETURN pin at the harness pre-lubricating oil pump connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in the Associated Procedures Table.

Voltage greater than 5 VDC?
YES NO

Repair

A stuck on pre-lubricating oil pump relay or short circuit on the pre-lubricating oil pump supply circuit has been detected.

Replace the relay if damaged. Repair or replace the damaged section of harness.

See equipment manufacturer service information.

 No Repair

Go to 4A

Go to 3A

Guided Step 2B - Component verification check.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify whether the fuel pump lubricating oil supply pressure sensor is installed, or the fuel pump lubricating oil supply pressure switch is installed.

Fuel pump lubricating oil supply pressure sensor is installed?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the Fuel pump oil pressure, 5 volt SUPPLY pin to the Fuel pump oil pressure RETURN pin at the sensor connector of the engine wiring harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in the Associated Procedures Table.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3B

Go to 6A

Guided Step 3 - Fuel pump lubricating oil supply pressure component check.

Guided Step 3A - Fuel pump lubricating oil supply pressure switch resistance check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure switch.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedure Table.

Malfunctioning switch?
YES NO

Repair

A malfunctioning fuel pump lubricating oil supply pressure switch has been detected.

Replace the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5A

Guided Step 3B - Fuel pump lubricating oil supply pressure sensor check.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Inspect the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning fuel pump lubricating oil supply pressure sensor has been detected.

Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4A

Guided Step 4 - Fuel pump lubricating oil supply pressure sensor circuit check.

Guided Step 4A - Fuel pump lubricating oil supply pressure sensor open circuit check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fuel pump lubricating oil supply pressure sensor from the engine wiring harness.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check for an open circuit.

  • Measure the resistance between the fuel pump lubricating oil pressure sensor SIGNAL pin at the fuel pump lubricating oil pressure sensor engine wiring harness connector and the fuel pump lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 10 ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4B

Guided Step 4B - Fuel pump lubricating oil supply pressure sensor circuit pin to ground check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance between the fuel pump lubricating oil pressure sensor SIGNAL pin at the engine wiring harness ECM connector and ground.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 4C

Guided Step 4C - Fuel pump lubricating oil pressure sensor circuit pin to pin check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance between the fuel pump lubricating oil supply pressure sensor SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 5 - Fuel pump lubricating oil supply pressure switch circuit check.

Guided Step 5A - Fuel pump lubricating oil supply pressure switch open circuit check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.
  • Disconnect the fuel pump lubricating oil supply pressure switch from the engine wiring harness.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

Check for an open circuit.

  • Measure the resistance between the fuel pump lubricating oil pressure switch SIGNAL pin at the fuel pump lubricating oil pressure switch engine wiring harness connector and the fuel pump lubricating oil pressure switch SIGNAL pin at the engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Greater than 10 ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-071 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5B

Guided Step 5B - Fuel pump lubricating oil supply pressure switch circuit pin to ground check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure switch from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance between the fuel pump lubricating oil pressure switch SIGNAL pin at the engine wiring harness ECM connector and ground.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 5C

Guided Step 5C - Fuel pump lubricating oil supply pressure switch circuit pin to pin check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure switch from the engine wiring harness.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance between the fuel pump lubricating oil supply pressure switch SIGNAL pin at the engine wiring harness ECM connector and all other pins at the engine wiring harness ECM connector.

Resistance less than 100k ohms?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 6A

Go to 6A

Guided Step 6 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 6A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 6B

Go to 6B

Guided Step 6B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Escalate or call for assistance.

Last Modified: 07-Jul-2021


FAULT CODE 4886 - Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K113 | 4388663
Electrical System | Refer to Procedure 018-021 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4886 active?
STEP 2. | Check engine fuel supply pump. |
 | STEP 2A. Check for correct battery or power supply. | Correct battery or power supply?
 | STEP 2B. Check for a tripped or malfunctioning circuit breaker. | Circuit breaker operational?
 | STEP 2C. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2D. Measure resistance in the engine fuel supply pump motor. | Measurement between 10K-2M ohms?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electroinc service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4886 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine fuel supply pump.

Guided Step 2A - Check for correct battery or power supply.

Conditions

  • Turn the keyswitch OFF.

Action

Verify the correct battery or power supply is installed and in proper operating condition.

  • Refer to Procedure 018-021 in the Associated Procedures Table.

Correct battery or power supply?
YES NO
No Repair

Repair

Replace the battery or power supply. See equipment manufacturer service information.

Go to 2B

Go to 3A

Guided Step 2B - Check for a tripped or malfunctioning circuit breaker.

Conditions

  • Turn the keyswitch OFF.

Action

Check circuit breaker.

  • Check for a tripped or malfunctioning circuit breaker. See equipment manufacturer service information.

Circuit breaker operational?
YES NO
No Repair

Repair

Replace or reset the circuit breaker. See equipment manufacturer service information.

Go to 2C

Go to 2C

Guided Step 2C - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect OEM wiring harness power connector(s) from the engine fuel supply pump.

Action

Inspect the connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the appropriate wiring diagram for pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair or replace and damaged or malfunctioning components. See equipment manufacturer service information.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Measure resistance in the engine fuel supply pump motor.

Conditions

  • Turn the keyswitch OFF.
  • Disconnect OEM wiring harness power connector(s) from the engine fuel supply pump.

Action

Measure the resistance of the fuel pump motor.

  • Place the positive lead on the fuel pump motor SUPPLY pin.
  • Place the negative lead on the fuel pump motor RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Measurement between 10K-2M ohms?
YES NO

Repair

Check the voltage source for proper operation. Inspect the OEM harness for damage and dirty, corroded, or loose connection between the engine fuel supply pump motor and the voltage source.

Repair

A damaged engine fuel supply pump has been detected.

  • Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES | NO
No Repair | No Repair

Follow the technical escalation process

Repair complete.

Last Modified: 14-Jun-2017


FAULT CODE 4894 - Engine Fuel Supply Pump - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump Calibration Code | Refer to Procedure 005-254 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check engine control module (ECM) calibration. |
 | STEP 1A. Check if an ECM calibration update is available. | More recent ECM calibration revision available?
STEP 2. | Check fault codes. |
 | STEP 2A. Check fault codes. | Fault Code 4894 active?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check ECM calibration

Guided Step 1A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

More recent ECM calibration revision available?
YES NO

Repair

Calibrate the ECM. Refer to Procedure 019-032 in Section 19.

No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check the fault codes

Guided Step 2A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4894 active?
YES NO

Repair

The firmware version in the engine fuel supply pump is not compatible with the ECM software.

Download the correct firmware to the engine fuel supply pump. Refer to Procedure 005-254 in the Associated Procedures Table.

No Repair

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 06-May-2016


FAULT CODE 4936 - Engine Diesel Fuel Metering Valve - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4936 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4936 active?
YES NO

Repair

The firmware in the fuel metering valve is not compatible with the ECM software.

Download the correct firmware to the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Aug-2014


FAULT CODE 4937 - Engine Diesel Fuel Metering Valve - Out of Calibration

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check fault codes. |
 | STEP 1A. Check fault codes. | Fault Code 4937 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4937 active?
YES NO

Repair

The calibration in the fuel metering valve is not compatible with the ECM software.

Download the correct calibration to the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Aug-2014


FAULT CODE 4958 - Engine Diesel Fuel Metering Valve - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4958 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Inspect the fuel metering valve resistor connector pins. | Dirty or damaged pins?
 | STEP 2D. Check the fuel metering valve resistor. | Between 1.7k ohms and 2k ohms?
 | STEP 2E. Check the fuel metering valve resistor. | Between 1.7k ohms and 2k ohms?
 | STEP 2F. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2G. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2H. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2I. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 4958 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the fuel metering valve resistor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check the fuel metering valve resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Measure resistance.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and fuel metering valve control RETURN pin in the engine harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.7k ohms and 2k ohms?
YES | NO
No Repair | No Repair

Go to 2F

Go to 2E

Guided Step 2E - Check the fuel metering valve resistor.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Measure resistance.

  • Measure the resistance of the fuel metering valve resistor.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 1.7k ohms and 2k ohms?
YES NO

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace to fuel metering valve resistor.

Go to 4A

Go to 4A

Guided Step 2F - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin at the ECM connector of the engine harness and the fuel metering valve control SIGNAL pin at the fuel metering valve connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 4A

Guided Step 2G - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the fuel metering valve resistor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2H

Go to 4A

Guided Step 2H - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ECM power supply ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2I

Go to 4A

Guided Step 2I - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector fuel metering valve control RETURN pin and the engine harness fuel metering valve connector control RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control signal circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected in the harness. Refer to Procedure 019-362 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Jun-2017


FAULT CODE 5119 - Fuel Pump Oil Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Multimeter Usage | Refer to Procedure 019-359 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
OEM Wiring Harness | Refer to Procedure 019-071 | QSK95 CM2350 K111 | 4358519
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Fuel Pump Lubricating Oil Pressure Sensor | Refer to Procedure 019-679 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352, 386 active?
 | STEP 1B. Component verification check. | Fuel pump lubricating oil supply pressure sensor is installed?
STEP 2. | Check the fuel pump lubricating oil supply pressure sensor and circuit. |
 | STEP 2A. Fuel pump lubricating oil supply pressure sensor voltage check. | 4.75 to 5.25 VDC?
 | STEP 2B. Fuel pump lubricating oil supply pressure sensor circuit sensor circuit check. | Less than 10 ohms?
STEP 3. | Fuel pump lubricating oil supply pressure sensor circuit response check. |
 | STEP 3A. Fuel pump lubricating oil supply pressure sensor circuit response. | Fault Code 5121 active?
 | STEP 3B. Fuel pump lubricating oil supply pressure sensor circuit response at the ECM. | Fault Code 5121 active?
STEP 4. | Fuel pump lubricating oil supply pressure switch circuit response check. |
 | STEP 4A. Fuel pump lubricating oil supply pressure switch circuit response. | Fault Code 5121 active?
 | STEP 4B. Fuel pump lubricating oil supply pressure switch circuit response at the ECM. | Fault Code 5121 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP . |
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 352, 386 active?
YES | NO
No Repair | No Repair

Go to appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Component verification check.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify whether the fuel pump lubricating oil supply pressure sensor is installed, or the fuel pump lubricating oil supply pressure switch is installed.

Fuel pump lubricating oil supply pressure sensor is installed?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump lubricating oil supply pressure sensor and circuit.

Guided Step 2A - Fuel pump lubricating oil supply pressure sensor voltage check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the Fuel pump oil pressure, 5 volt SUPPLY pin to the Fuel pump oil pressure RETURN pin at the sensor connector of the engine wiring harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in the Associated Procedures Table.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Fuel pump lubricating oil supply pressure sensor circuit sensor circuit check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the resistance between the fuel pump lubricating oil supply pressure sensor SUPPLY pin at the fuel pump lubricating oil supply pressure sensor engine wiring harness connector and the fuel pump lubricating oil supply pressure sensor SUPPLY pin at the engine wiring harness ECM connector.Measure the resistance between the fuel pump lubricating oil supply pressure sensor RETURN pin at the coolant level sensor engine wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in in the Associated Procedures Table.

Less than 10 ohms?
YES NO

Repair

A malfunctioning ECM has been detected if the resistance is less than the following specification.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Fuel pump lubricating oil supply pressure sensor circuit response check.

Guided Step 3A - Fuel pump lubricating oil supply pressure sensor circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.

Action

Inspect the pins and connectors.

Refer to Procedure 019-361 in the Associated Procedures Table.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 5121 active?
YES NO

Repair

A damaged fuel pump lubricating oil supply pressure sensor has been detected.

  • Replace the fuel pump lubricating oil supply pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Fuel pump lubricating oil supply pressure sensor circuit response at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 5121 active?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Fuel pump lubricating oil pressure switch circuit response check.

Guided Step 4A - Fuel pump lubricating oil supply pressure switch circuit connector response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure switch connector from the engine wiring harness connector.

Action

Inspect the pins and connectors.

Refer to Procedure 019-361 in the Associated Procedures Table.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 5119 active?
YES NO

Repair

A damaged fuel pump lubricating oil pressure switch has been detected.

  • Replace the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Fuel pump lubricating oil supply pressure switch circuit response at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors.

Refer to Procedure 019-361 in the Associated Procedures Table.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 5121 active?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 30-Jun-2021


FAULT CODE 5121 - Fuel Pump Oil Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Multimeter Usage | Refer to Procedure 019-359 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
OEM Wiring Harness | Refer to Procedure 019-071 | QSK95 CM2350 K111 | 4358519
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSK95 CM2350 K111 | 4358519
Fuel Pump Lubricating Oil Pressure Sensor | Refer to Procedure 019-679 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new ECM, all other active fault codes must be investigated prior to replacing the ECM.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3164596 - male Framatome™ test lead and Part Number 3822917 - female Deutsch™/Amp™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Fault Code 352, 386 active?
 | STEP 1B. Verification component check. | Switch or sensor?
STEP 2. | Check the fuel pump lubricating oil supply pressure sensor and circuit. |
 | STEP 2A. Fuel pump lubricating oil supply pressure sensor voltage check. | 4.75 to 5.25 VDC?
 | STEP 2B. Fuel pump lubricating oil supply pressure sensor circuit sensor circuit check. | Less than 10 ohms?
STEP 3. | Fuel pump lubricating oil supply pressure sensor circuit response check. |
 | STEP 3A. Fuel pump lubricating oil supply pressure sensor circuit response. | Fault Code 5119 active?
 | STEP 3B. Fuel pump lubricating oil supply pressure sensor circuit response at the ECM. | Fault Code 5119 active?
STEP 4. | Fuel pump lubricating oil supply pressure switch circuit response check. |
 | STEP 4A. Fuel pump lubricating oil supply pressure switch circuit response. | Fault Code 5119 active?
 | STEP 4B. Fuel pump lubricating oil supply pressure switch circuit response at the ECM. | Fault Code 5119 active?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Check for sensor supply fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 352, 386 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Component verification check.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify whether the fuel pump lubricating oil supply pressure sensor is installed, or the fuel pump lubricating oil supply pressure switch is installed.

Fuel pump lubricating oil supply pressure sensor is installed?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the fuel pump lubricating oil supply pressure sensor and circuit.

Guided Step 2A - Fuel pump lubricating oil supply pressure sensor voltage check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage from the Fuel pump oil pressure, 5 volt SUPPLY pin to the Fuel pump oil pressure RETURN pin at the sensor connector of the engine wiring harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in the Associated Procedures Table.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2B

Guided Step 2B - Fuel pump lubricating oil supply pressure sensor circuit sensor circuit check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure sensor connector from the engine wiring harness connector.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the resistance between the fuel pump lubricating oil supply pressure sensor SUPPLY pin at the fuel pump lubricating oil supply pressure sensor engine wiring harness connector and the fuel pump lubricating oil supply pressure sensor SUPPLY pin at the engine wiring harness ECM connector.
  • Measure the resistance between the fuel pump lubricating oil supply pressure sensor RETURN pin at the coolant level sensor engine wiring harness connector and the coolant level sensor RETURN pin at the engine wiring harness ECM connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in the Associated Procedures Table.

Less than 10 ohms?
YES NO

Repair

A malfunctioning ECM has been detected if the resistance is less than the following specification.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A malfunctioning engine wiring harness has been detected if the resistance is greater than the following specification.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-071 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Fuel pump lubricating oil supply pressure sensor circuit response check.

Guided Step 3A - Fuel pump lubricating oil supply pressure sensor circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure sensor connector from the engine wiring harness connector.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Place a jumper wire between the fuel pump lubricating oil supply pressure sensor Supply pin and the fuel pump lubricating oil supply pressure sensor Signal pin at the sensor connector at the engine wiring harness.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use the electronic service tool to read the fault codes.

Fault Code 5119 active?
YES NO

Repair

A damaged fuel pump lubricating oil supply pressure sensor has been detected.

  • Replace the fuel pump lubricating oil supply pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Fuel pump lubricating oil supply pressure sensor circuit response at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Place a jumper wire between the fuel pump lubricating oil supply pressure sensor Signal pin and the fuel pump lubricating oil supply pressure sensor Supply pin at the ECM.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 5119 active?
YES NO

Repair

A malfunctioning engine wiring harness has been detected. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Fuel pump lubricating oil pressure switch circuit response check.

Guided Step 4AFuelpumplubricatingoilsupplypressureswitchcircuitconnectorresponse. -

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil pressure switch connector from the engine wiring harness connector.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 5119 active?
YES NO

Repair

A damaged fuel pump lubricating oil pressure switch has been detected.

  • Replace the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.
 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Fuel pump lubricating oil supply pressure switch circuit response at the ECM.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine wiring harness connector from the ECM.

Action

Inspect the pins and connectors. Refer to Procedure 019-361 in the Associated Procedures Table.

Turn keyswitch ON.

Connect the recommended Cummins® electronic tool or equivalent.

Check for appropriate circuit response after 30 seconds.

  • Use electronic service tool to read the fault codes.

Fault Code 5119 active?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

A malfunctioning ECM has been detected.

  • Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Clear ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent

Action

Disable and clear the fault code.

  • Operate the engine within the ”Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

Repair complete.

Escalate or call for assistance.
Go to
Go to

Last Modified: 30-Jun-2021


FAULT CODE 5148 - Allow Start Override Active - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4946 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4946 active?
YES NO

Repair

This fault code indicates the original equipment manufacturer (OEM) start override switch has been left in the ON position.

Keep the switch in the OFF position when emergency start is not required. This will allow the prelubrication cycle to complete before starting.

Repair or replace any damaged OEM start override switch or circuit components. See equipment manufacturer service information.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 05-Aug-2014


FAULT CODE 5949 - SAE J1939 Data Link 2 Engine Network - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 5949 active or inactive with more than 1 count in the last 25 engine hours?
 | STEP 1B. Check for related J1939 Network 2 fault codes. | Fault Code 3329 active?
STEP 2. | Check the secondary engine control module (ECM) supply voltage circuits. |
 | STEP 2A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check for correct ECM supply voltage. | Between 21 and 27 volts of direct current (VDC)?
 | STEP 2C. Check the keyswitch signal circuit. | Less than 5 ohms?
STEP 3. | Check the Society of Automotive Engineers (SAE) J1939 data link 2 circuit. |
 | STEP 3A. Inspect the engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the SAE J1939 data link 2 resistance in the engine harness. | Between 50 and 70 ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5949 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for related J1939 Network 2 fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3329 active?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the secondary ECM supply voltage circuits.

Guided Step 2A - Inspect the ECM and OEM harness connector pins.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check for correct ECM supply voltage.

Conditions

Perform this check of ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

  • Measure the voltage between the ECM power supply voltage SUPPLY pins and the ECM power supply voltage RETURN pins in the OEM ECM connector.

Use a wiring diagram for pin identification and the following procedure for general multimeter usage. Refer to Procedure 019-359 in Section 19.

Between 21 and 27 VDC?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2C

Go to 4A

Guided Step 2C - Check the keyswitch signal circuit.

Conditions

Perform this check on ECM 2, 3, and 4.

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the 16 pin power connector.

Action

  • Measure the resistance of the keyswitch SIGNAL wire between the 16 pin power connector and the OEM connector at the ECM.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

Troubleshoot all harnesses connected in series to determine which contains the open circuit.

Repair or replace the damaged section of the engine harness.

  • Use the following procedure for engine harness repair. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the SAE J1939 data link 2 circuit.

Guided Step 3A - Inspect the engine harness connector pins.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

Replace the ECM only when there are damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the SAE J1939 data link 2 resistance in the engine harness.

Conditions

Perform this check on each ECM.

  • Turn keyswitch OFF.
  • Disconnect the engine connector from the ECM.

Action

  • Measure the resistance between the SAE J1939 data link 2 SUPPLY pin and the SAE J1939 data link 2 RETURN pin in the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Between 50 and 70 ohms?
YES NO

Repair

The SAE J1939 data link 2 resistance is within specification.

There is a problem in the calibration.

Check to make sure the appropriate calibrations are installed in the ECMs.

Repair

An open or shorted SAE J1939 data link 2 circuit has been detected in the engine harness.

Check the terminating resistors and their connectors.

Troubleshoot each harness connected in series to determine which one contains the open or short circuit.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 6253 (Source Address 00) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the engine harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM engine connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 6253 (Source Address 01) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4388663

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

  • Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 6253 (sa144) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check for the correct calibration |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the engine harness |
 | STEP 3A. Inspect the engine harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Clear the fault codes |
 | STEP 4A. Check ECM calibration and clear fault codes. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault codes. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 pin and all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process..

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 25-Jul-2017


FAULT CODE 6253 (Source Address 186) - Control Module Identification Input State Error - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K113 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check for the correct calibration. |
 | STEP 2A. Check for the correct calibration on the ECM. | Calibration correspond with the ECM source address and location of the ECM in the harness?
STEP 3. | Check the harness. |
 | STEP 3A. Inspect the harness and ECM connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6253 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check for the correct calibration.

Guided Step 2A - Check for the correct calibration on the ECM.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to check the calibration installed on the ECM.

Calibration correspond with the ECM source address and location of the ECM in the harness?
YES NO
No Repair

Repair

The ECM has the wrong calibration or the ECM has been installed in the wrong location.

Download the correct calibration to the ECM or install the ECM in the correct location.

Go to 3A

Go to 4A

Guided Step 3 - Check the harness.

Guided Step 3A - Inspect the harness and ECM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the original equipment manufacturer (OEM) harness connector from the ECM.

Action

Inspect the ECM and OEM harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or harness connector.

Clean the connector and pins.

Replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the control module identification SIGNAL 1 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 2 pin and the control module identification RETURN pin in the OEM harness ECM connector.
  • Measure the resistance between the control module identification SIGNAL 3 pin and the control module identification RETURN pin in the OEM harness ECM connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the control module identification circuit in the harness.

Repair or replace the damaged section of the harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 1 pin and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 2 pin and all other pins in the connector (except for the other ID SIGNAL pins).
  • Measure the resistance between the OEM harness ECM connector control module identification SIGNAL 3 pin and all other pins in the connector (except for the other ID SIGNAL pins).

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Repair

A pin-to-pin short circuit has been detected in the control module identification circuit in the harness.

Replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Reapir complete.

Last Modified: 03-Aug-2017


FAULT CODE 6573 - Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4388663

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fuel temperature or fuel metering valve fault codes. | Fault Code 261, 266, 4927, or 4933 active or inactive with more than 1 count in the last 25 engine hours?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fuel temperature or fuel metering valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 261, 266, 4927, or 4933 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

The fuel metering valve internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

Repair

The fuel metering valve internal temperature has exceeded the maximum limit.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 03-Aug-2017


FAULT CODE 6574 - Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fuel temperature or fuel metering valve fault codes. | Fault Code 261, 266, 4927, or 4933 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code active?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fuel temperature or fuel metering valve fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 261, 266, 4927, or 4933 active or inactive with more than 1 count in the last 25 engine hours?
YES NO

Repair

The fuel metering valve internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

Repair

The fuel metering valve internal temperature has exceeded the maximum limit.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow the technical escalation process.

 No Repair

Escalate or call for assistance

Repair complete.

Last Modified: 03-Aug-2017


FAULT CODE 6595 - Engine Speed - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K113 | 4358519
Unswitched Power Supply Circuit | Refer to Procedure 019-087 | QSK95 CM2350 K113 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Code 6595. | Fault Code 6595 active or inactive with more than 1 count in the last 25 engine hours?
 | STEP 1B. Check for supply voltage fault codes. | Active or inactive counts of Fault Code 441 or 442?
 | STEP 1C. Inspect crankshaft and camshaft position sensor connector pins | Dirty or damaged pins?
 | STEP 1D. Check the engine control module (ECM) power supply voltage. | ECM power supply voltage above 24 VDC?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Read the fault codes. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Code 6595.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 6595 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Go to 1B

Repair complete.

Guided Step 1B - Check for supply voltage fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of Fault Code 441 or 442?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1C

Guided Step 1C - Inspect crankshaft and camshaft position sensor connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankshaft and camshaft position sensors.

Action

Inspect the connector(s) for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Refer to the wiring diagram for connector pin identification.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1D

Guided Step 1D - Check the ECM power supply voltage.

Conditions

  • Turn keyswitch ON.

Action

  • Refer to Procedure 019-087 in the Associated Procedures Table.

ECM power supply voltage above 24 VDC?
YES NO
No Repair

Repair

See equipment manufacturer service information.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code active?
YES NO

Repair

Verify that all steps have been completed. If all steps have been completed, then follow thetechnical escalation process.

 No Repair

Escalate or call for assistance.

Repair complete.

Last Modified: 03-Aug-2017


FAULT CODE 7313 - Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K111 | 4358519
Fuel Pump Lubricating Oil Pressure Sensor | Refer to Procedure 019-679 | QSK95 CM2350 K111 | 4358519
Fuel Pump Drive Lubricating Oil Filter | Refer to Procedure 007-110 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for primary fault codes. | Fault Code 143, 415,1362 active or inactive with more than one count in the last 25 engine hours?
 | STEP 1B. Verification component check. | Switch or sensor?
STEP 2. | Fuel pump lubricating oil supply pressure component check. |
 | STEP 2A. Fuel pump lubricating oil supply pressure switch is malfunctioning. | Malfunctioning switch?
 | STEP 2B. Fuel pump lubricating oil supply pressure sensor is malfunctioning. | Malfunctioning sensor?
STEP 3. | Check the fuel pump drive lubricating oil filter. |
 | STEP 3A. Check for damage on the fuel pump drive lubricating oil filter. | Damaged or plugged fuel pump drive lubricating oil filter?
STEP 4. | Check ECM Calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for primary fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 143, 415, 1362 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault codes.

Go to 1B

Guided Step 1B - Component verification check.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify whether the fuel pump lubricating oil supply pressure sensor is installed, or the fuel pump lubricating oil supply pressure switch is installed.

Fuel pump lubricating oil supply pressure sensor is installed?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A

Guided Step 2 - Fuel pump lubricating oil supply pressure component check.

Guided Step 2A - Fuel pump lubricating oil supply pressure switch resistance check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure switch.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.

Malfunctioning switch?
YES NO

Repair

A malfunctioning fuel pump lubricating oil supply pressure switch has been detected.

  • Replace the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3A

Guided Step 2B - Fuel pump lubricating oil supply pressure sensor check.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Inspect the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning fuel pump lubricating oil supply pressure sensor has been detected.

  • Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel pump drive lubricating oil filter.

Guided Step 3A - Check for damage on the fuel pump drive lubricating oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the fuel pump drive lubricating oil filter.
  • Refer to Procedure 007-110 in the Associated Procedures Table.

Damage found on the fuel pump drive lubricating oil filter?
YES NO

Repair

Replace the fuel pump drive lubricating oil filter.

  • Refer to Procedure 007-110 in the Associated Procedures Table.
 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 12-Jul-2021


FAULT CODE 7314 - Engine Fuel Pump Oil Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Engine Model | Bulletin Number
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Pressure Switch, Prelubrication System | Refer to Procedure 007-086 | QSK95 CM2350 K111 | 4358519
Fuel Pump Lubricating Oil Pressure Sensor | Refer to Procedure 019-679 | QSK95 CM2350 K111 | 4358519
Fuel Pump Drive Lubricating Oil Filter | Refer to Procedure 007-110 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for primary fault codes. | Fault Code 143, 415,1362 active or inactive with more than one count in the last 25 engine hours?
 | STEP 1B. Verification component check. | Switch or sensor?
STEP 2. | Fuel pump lubricating oil supply pressure component check. |
 | STEP 2A. Fuel pump lubricating oil supply pressure switch is malfunctioning. | Malfunctioning switch?
 | STEP 2B. Fuel pump lubricating oil supply pressure sensor is malfunctioning. | Malfunctioning sensor?
STEP 3. | Check the fuel pump drive lubricating oil filter. |
 | STEP 3A. Check for damage on the fuel pump drive lubricating oil filter. | Damaged or plugged fuel pump drive lubricating oil filter?
STEP 4. | Check ECM Calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for primary fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 143, 415, 1362 active or inactive with more than 1 count in the last 25 engine hours?
YES | NO
No Repair | No Repair

Troubleshoot the appropriate fault codes.

Go to 1B

Guided Step 1B - Component verification check.

Conditions

  • Turn keyswitch OFF.

Action

  • Verify whether the fuel pump lubricating oil supply pressure sensor is installed, or the fuel pump lubricating oil supply pressure switch is installed.

Fuel pump lubricating oil supply pressure sensor is installed?
YES | NO
No Repair | No Repair

Go to 2B

Go to 2A

Guided Step 2 - Fuel pump lubricating oil supply pressure component check.

Guided Step 2A - Fuel pump lubricating oil supply pressure switch resistance check.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel pump lubricating oil supply pressure switch.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Measure the resistance of the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.

Malfunctioning switch?
YES NO

Repair

A malfunctioning fuel pump lubricating oil supply pressure switch has been detected.

  • Replace the fuel pump lubricating oil supply pressure switch. Refer to Procedure 007-086 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3A

Guided Step 2B - Fuel pump lubricating oil supply pressure sensor check.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic tool or equivalent.

Action

Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.

  • Inspect the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.

Malfunctioning sensor?
YES NO

Repair

A malfunctioning fuel pump lubricating oil supply pressure sensor has been detected.

  • Replace the fuel pump lubricating oil pressure sensor. Refer to Procedure 019-679 in the Associated Procedures Table.
No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel pump drive lubricating oil filter.

Guided Step 3A - Check for damage on the fuel pump drive lubricating oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the fuel pump drive lubricating oil filter.
  • Refer to Procedure 007-110 in the Associated Procedures Table.

Damage found on the fuel pump drive lubricating oil filter?
YES NO

Repair

Replace the fuel pump drive lubricating oil filter.

  • Refer to Procedure 007-110 in the Associated Procedures Table.
 No Repair

Go to 4B

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM.

Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the “Conditions for Clearing the Fault Code” found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 13-Jul-2021


FAULT CODE 7548 - Engine Friction Baseline - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Fault code is for information only. |
 | STEP 1A. Information only fault code. | No repair is necessary.
STEP 2. | Check the ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Fault code is for information only.

Guided Step 1A - Information only fault code.

Conditions

  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • This troubleshooting step is for information only stating that an unexpected source of friction has been detected.
  • This solution is information only. No repair is necessary.
OK NOT OK

Go to

Go to

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete.

Go to 1A

Last Modified: 26-Apr-2021


FAULT CODE 7549 - Engine Friction Baseline - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil System | Refer to Procedure 007-037 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Dipstick | Refer to Procedure 007-009 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Analysis | Refer to Procedure 007-051 | QSK95 CM2350 K111 | 4358519
Engine Barring Device | Refer to Procedure 009-035 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Exhaust Restriction | Refer to Procedure 011-009 | QSK95 CM2350 K111 | 4358519
Aftercooler Assembly | Refer to Procedure 010-002 | QSK95 CM2350 K111 | 4358519
Engine Testing (In Chassis) | Refer to Procedure 014-008 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Check for primary fault codes.
 | STEP 1B. Check for active or inactive oil fault codes. | Fault Code 143, 214, 415, 421, 1362, 4883, 4884 active or inactive?
 | STEP 1C. Check for active or inactive fuel system related fault codes. | Fault Code 261, 266, 344, 1379, 1389, 2215, 2261, 2262, 2343, 2372, 3727, 3741, 4615, 4885, 4886, 4887, 4888, 4889, 4891, 4892, 4893, 4894, 4927, 4928, 4932, 4933, 4936, 4937, 4958, 4959, 4961 active or inactive?
 | STEP 1D. Check for active or inactive intake related fault codes. | Fault Code 158, 1984 active or inactive?
 | STEP 1E. Check for exhaust related fault codes. | Fault Code 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138 active or inactive?
STEP 2. | Particles in oil filter. |
 | STEP 2A. Check oil level. | Oil level not within specifications?
 | STEP 2B. Inspect the oil filter. | Debris or particles found?
STEP 3. | Engine barring over check. |
 | STEP 3A. Engine barring over measurement. | Torque measurement correct?
STEP 4. | Restricted intake air filter. |
 | STEP 4A. Inspect intake air filter. | Restricted air filter?
STEP 5. | Exhaust restricted. |
 | STEP 5A. Inspect exhaust. | Restricted exhaust?
STEP 6. | Aftercooler damaged or obstructed. |
 | STEP 6A. Inspect aftercooler for damage. | Damaged aftercooler?
STEP 7. | Incorrect alternator efficiency settings. |
 | STEP 7A. Check alternator efficiency settings. | Alternator efficiency settings within specifications?
STEP 8. | Fuel injector is malfunctioning. |
 | STEP 8A. Cylinder cutout test. | Cylinder cutout test failed?
STEP 9. | Turbocharger is malfunctioning. |
 | STEP 9A. Inspect the turbocharger assembly. | Malfunctioning turbocharger?
STEP 10. | Malfunctioning alternator. |
 | STEP 10A. Inspect alternator. | Malfunctioning alternator?
STEP 11. | Check ECM calibration and clear fault codes. |
 | STEP 11A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 11B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 7549 active or inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active or inactive oil fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive oil related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 143, 214, 415, 421, 1362, 4883 active or inactive?
YES | NO
No Repair | No Repair

Go the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive fuel system related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 261, 266, 344, 1379, 1389, 2215, 2261, 2262, 2343, 2372, 3727, 3741, 4615, 4885, 4886, 4887, 4888, 4889, 4891, 4892, 4893, 4894, 4927, 4928, 4932, 4933, 4936, 4937, 4958, 4959, 4961 active or inactive?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1D

Guided Step 1D - Check for active or inactive intake related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive aftercooler related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 158, 1984 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1E

Guided Step 1E - Check for exhaust related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive exhaust related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 2A

Guided Step 2 - Lubricating oil checks.

Guided Step 2A - Check lubricating oil level.

Conditions

  • Turn keyswitch OFF.

Action

  • Check that the lubricating oil level is correct. Refer to Procedure 007-037 in the Associated Procedures Table.

Oil level correct?
YES NO
No Repair

Repair

  • Calibrate the lubricating oil dipstick for the proper oil level. Refer to Procedure 007-009 in the Associated Procedures Table.
  • If the oil level is high and coolant contamination has been detected, then reset the search to Coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to Fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.

Go to 2B

Go to 10A

Guided Step 2B - Inspect the oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil filter for debris or metal particles. Refer to Procedure 007-051 in the Associated Procedures Table.

Debris or metal particles found?
YES NO

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.
 No Repair

Go to 10A

Go to 3A
Go to
Go to

Guided Step 3 - Engine barring over check.

Guided Step 3A - Engine barring over measurement.

Conditions

  • Turn keyswitch OFF.

Action

  • Perform engine barring torque measurement check. Refer to Procedure 009-035 in the Associated Procedures Table.

Torque measurement correct?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Go to 4A

Escalate or call for assistance.

Guided Step 4 - Restricted intake air filter.

Guided Step 4A - Check air intake.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the air intake restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restricted?
YES NO

Repair

  • Replace the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 5A

Guided Step 5 - Exhaust restricted.

Guided Step 5A - Check exhaust for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restricted?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair the source of the exhaust restriction. Refer to the original equipment manufacturer (OEM) manual.
 No Repair

Go to 11A

Go to 6A

Guided Step 6 - Aftercooler damaged or obstructed.

Guided Step 6A - Inspect aftercooler for damage.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the aftercooler. Refer to Procedure 010-002 in the Associated Procedures Table.

Malfunctioning aftercooler?
YES NO

Repair

  • Repair or replace the aftercooler. Refer to Procedure 010-002 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 7A

Guided Step 7 - Incorrect alternator efficiency settings.

Guided Step 7A - Check parameter settings.

Conditions

  • Turn keyswitch OFF.

Action

  • Check alternator efficiency settings in generator set controller. Refer to OEM manual for specifications.

Alternator efficiency settings correct?
YES NO
No Repair

Repair

  • Reset alternator efficiency settings to default value.
  • Refer to the OEM manual for specifications.

Go to 8A

Go to 11A

Guided Step 8 - Fuel injector is malfunctioning.

Guided Step 8A - Cylinder cutout test.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Perform the cylinder cutout test.

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Cummins® electronic service tool Cylinder Cutout Test to determine if the misfire can be isolated to a single injector. Refer to Procedure 014-008 in the Associated Procedures Table.

Cylinder cutout test passed?
YES NO
No Repair

Repair

  • If engine fails the cylinder cutout test, before replacing the fuel injector, verify the overhead valve lash measurements are correct for the suspect cylinder and adjust if needed. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 11A

Go to 9A

Guided Step 9 - Turbocharger is malfunctioning.

Guided Step 9A - Inspect the turbocharger assembly.

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger for the following.

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.
  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.
  • Measure the radial and axial clearance of the turbocharger wheel.
  • Use the following procedure for general inspection techniques. Refer to Procedure 010-033 in the Associated Procedures Table.

Malfunctioning turbocharger?
YES NO

Repair

  • Replace the turbocharger assembly. Refer to Procedure 010-033 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 10A

Guided Step 10 - Malfunctioning alternator.

Guided Step 10A - Inspect alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator.

  • Check for original equipment manufacturer (OEM) fault codes.
  • Refer to the original equipment manufacturer (OEM) manual for any troubleshooting of this component.

Malfunctioning alternator?
YES NO

Repair

  • Refer to the original equipment manfacturer (OEM) manual for any troubleshooting of this component.
 No Repair

Go to 11A

Go to 11A

Guided Step 11 - Check ECM calibration and clear fault codes.

Guided Step 11A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 11B

Go to 11B

Guided Step 11B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 05-May-2021


FAULT CODE 7551 - Engine Friction Baseline - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Fault code is for information only. |
 | STEP 1A. Information only fault code. | No repair is necessary.
STEP 2. | Check the ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?
 | STEP . |

Guided Step 1 - Fault code is for information only.

Guided Step 1A - Information only fault code.

Conditions

  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • This troubleshooting step is for information only stating that an unexpected source of friction has been detected.
  • This solution is information only. No repair is necessary.
OK NOT OK

Go to

Go to

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete.

Go to 1A
Go to
Go to

Last Modified: 30-Apr-2021


FAULT CODE 7552 - Engine Friction Baseline - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Analysis | Refer to Procedure 007-051 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Exhaust Restriction | Refer to Procedure 011-009 | QSK95 CM2350 K111 | 4358519
Lubricating Oil System | Refer to Procedure 007-037 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Dipstick | Refer to Procedure 007-009 | QSK95 CM2350 K111 | 4358519
Engine Barring Device | Refer to Procedure 009-035 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Aftercooler Assembly | Refer to Procedure 010-002 | QSK95 CM2350 K111 | 4358519
Engine Testing (In Chassis) | Refer to Procedure 014-008 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Check for primary fault codes.
 | STEP 1B. Check for active or inactive oil fault codes. | Fault Code 143, 214, 415, 421, 1362, 4883, 4884 active or inactive?
 | STEP 1C. Check for active or inactive fuel system related fault codes. | Fault Code 261, 266, 344, 1379, 1389, 2215, 2261, 2262, 2343, 2372, 3727, 3741, 4615, 4885, 4886, 4887, 4888, 4889, 4891, 4892, 4893, 4894, 4927, 4928, 4932, 4933, 4936, 4937, 4958, 4959, 4961 active or inactive?
 | STEP 1D. Check for active or inactive intake related fault codes. | Fault Code 158, 1984 active or inactive?
 | STEP 1E. Check for exhaust related fault codes. | Fault Code 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138 active or inactive?
STEP 2. | Particles in oil filter. |
 | STEP 2A. Check oil level. | Oil level not within specifications?
 | STEP 2B. Inspect the oil filter. | Debris or particles found?
STEP 3. | Engine barring over check. |
 | STEP 3A. Engine barring over measurement. | Torque measurement correct?
STEP 4. | Restricted intake air filter. |
 | STEP 4A. Inspect intake air filter. | Restricted air filter?
STEP 5. | Exhaust restricted. |
 | STEP 5A. Inspect exhaust. | Restricted exhaust?
STEP 6. | Aftercooler damaged or obstructed. |
 | STEP 6A. Inspect aftercooler for damage. | Damaged aftercooler?
STEP 7. | Incorrect alternator efficiency settings. |
 | STEP 7A. Check alternator efficiency settings. | Alternator efficiency settings within specifications?
STEP 8. | Fuel injector is malfunctioning. |
 | STEP 8A. Cylinder cutout test. | Cylinder cutout test failed?
STEP 9. | Turbocharger is malfunctioning. |
 | STEP 9A. Inspect the turbocharger assembly. | Malfunctioning turbocharger?
STEP 10. | Malfunctioning alternator. |
 | STEP 10A. Inspect alternator. | Malfunctioning alternator?
STEP 11. | Check ECM calibration and clear fault codes. |
 | STEP 11A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 11B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 7552 active or inactive?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for active or inactive oil fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive oil related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 143, 214, 415, 421, 1362, 4883, 4884 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive fuel system related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 261, 266, 344, 1379, 1389, 2215, 2261, 2262, 2343, 2372, 3727, 3741, 4615, 4885, 4886, 4887, 4888, 4889, 4891, 4892, 4893, 4894, 4927, 4928, 4932, 4933, 4936, 4937, 4958, 4959, 4961 active or inactive?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1D
Go to

Guided Step 1D - Check for active or inactive intake related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive aftercooler related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 158, 1984 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1E

Guided Step 1E - Check for exhaust related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive exhaust related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 2A
Go to
Go to

Guided Step 2 - Lubricating oil checks.

Guided Step 2A - Check lubricating oil level.

Conditions

  • Turn keyswitch OFF.

Action

  • Check that lubricating oil level is correct. Refer to Procedure 007-037 in the Associated Procedures Table.

Oil level correct?
YES NO
No Repair

Repair

  • Calibrate the lubricating oil dipstick for the proper oil level. Refer to Procedure 007-009 in the Associated Procedures Table.
  • If the oil level is high and coolant contamination has been detected, then reset the search to coolant in the oil.
  • If the oil level high and fuel contamination has been detected, then reset the search to fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.

Go to 2B

Go to 10A

Guided Step 2B - Inspect the oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil filter for debris or metal particles. Refer to Procedure 007-051 in the Associated Procedures Table.

Debris or metal particles found?
YES NO

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.
 No Repair

Go to 10A

Go to 3A

Guided Step 3 - Engine barring over check.

Guided Step 3A - Engine barring over measurement.

Conditions

  • Turn keyswitch OFF.

Action

  • Perform engine barring torque measurement check. Refer to Procedure 009-035 in the Associated Procedures Table.

Torque measurement correct?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Go to 4A

Escalate or call for assistance.

Guided Step 4 - Restricted intake air filter.

Guided Step 4A - Check air intake.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the air intake restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restricted?
YES NO

Repair

  • Replace the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 5A

Guided Step 5 - Exhaust restricted?

Guided Step 5A - Check exhaust for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restricted?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair the source of the exhaust restriction. Refer to the OEM manual.
No Repair

Go to 11A

Go to 6A

Guided Step 6 - Aftercooler damaged or obstructed.

Guided Step 6A - Inspect aftercooler for damage.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the aftercooler. Refer to Procedure 010-002 in the Associated Procedures Table.

Malfunctioning aftercooler?
YES NO

Repair

  • Repair or replace the aftercooler. Refer to Procedure 010-002 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 7A

Guided Step 7 - Incorrect alternator efficiency settings.

Guided Step 7A - Check parameter settings.

Conditions

  • Turn keyswitch OFF.

Action

  • Check alternator efficiency settings in generator set controller. Refer to original equipment manufacturer (OEM) manual for specifications.

Alternator efficiency settings incorrect?
YES NO
No Repair

Repair

  • Reset alternator efficiency settings to default value.
  • Refer to the OEM manual for specifications.

Go to 8A

Go to 11A

Guided Step 8 - Fuel Injector is malfunctioning.

Guided Step 8A - Cylinder cutout test.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Perform the cylinder cutout test.

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Cummins® electronic service tool Cylinder Cutout Test to determine if the misfire can be isolated to a single injector. Refer to Procedure 014-008 in the Associated Procedures Table.

Cylinder cutout test failed?
YES NO
No Repair

Repair

  • If engine fails the cylinder cutout test, before replacing the fuel injector, verify the overhead valve lash measurements are correct for the suspect cylinder and adjust if needed. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 11A

Go to 9A

Guided Step 9 - Turbocharger is malfunctioning.

Guided Step 9A - Inspect the turbocharger assembly.

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger for the following:

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.
  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.
  • Measure the radial and axial clearance of the turbocharger wheel.
  • Use the following procedure for general inspection. techniques. Refer to Procedure 010-033 in the Associated Procedures Table.

Malfunctioning turbocharger?
YES NO

Repair

Replace the turbocharger assembly.

  • Refer to Procedure 010-033 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 10A

Guided Step 10 - Malfunctioning alternator.

Guided Step 10A - Inspect alternator.

Conditions

  • Turn keyswitch OFF.

Action

  • Check for original equipment manufacturer (OEM) fault codes.
  • Refer to the original equipment manufacturer (OEM) manual for any troubleshooting of this component.

Malfunctioning alternator?
YES NO

Repair

  • Refer to the original equipment manufacturer (OEM) manual for any troubleshooting of this component.
 No Repair

Go to 11A

Go to 10A

Guided Step 11 - Check ECM calibration and clear fault codes.

Guided Step 11A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 11B

Go to 11B

Guided Step 11B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.
Go to
Go to

Last Modified: 04-May-2021


FAULT CODE 7554 - Engine Friction Deviation - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Lubricating Oil Analysis | Refer to Procedure 007-051 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Exhaust Restriction | Refer to Procedure 011-009 | QSK95 CM2350 K111 | 4358519
Lubricating Oil System | Refer to Procedure 007-037 | QSK95 CM2350 K111 | 4358519
Lubricating Oil Dipstick | Refer to Procedure 007-009 | QSK95 CM2350 K111 | 4358519
Engine Barring Device | Refer to Procedure 009-035 | QSK95 CM2350 K111 | 4358519
Aftercooler Assembly | Refer to Procedure 010-002 | QSK95 CM2350 K111 | 4358519
Engine Testing (In Chassis) | Refer to Procedure 014-008 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Check for primary fault codes.
 | STEP 1B. Check for active or inactive oil fault codes. | Fault Code 143, 214, 415, 421, 1362, 4883, 4884 active or inactive?
 | STEP 1C. Check for active or inactive fuel system related fault codes. | Fault Code 261, 266, 344, 1379, 1389, 2215, 2261, 2262, 2343, 2372, 3727, 3741, 4615, 4885, 4886, 4887, 4888, 4889, 4891, 4892, 4893, 4894, 4927, 4928, 4932, 4933, 4936, 4937, 4958, 4959, 4961 active or inactive?
 | STEP 1D. Check for active or inactive intake related fault codes. | Fault Code 158, 1984 active or inactive?
 | STEP 1E. Check for exhaust related fault codes. | Fault Code 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138 active or inactive?
STEP 2. | Particles in oil filter. |
 | STEP 2A. Check oil level. | Oil level not within specification?
 | STEP 2B. Inspect the oil filter. | Debris or particles found?
STEP 3. | Engine barring over check. |
 | STEP 3A. Engine barring over measurement. | Torque measurement correct?
STEP 4. | Restricted intake air filter. |
 | STEP 4A. Inspect intake air filter. | Restricted air filter?
STEP 5. | Exhaust Restricted. |
 | STEP 5A. Inspect exhaust. | Restricted exhaust?
STEP 6. | Aftercooler damaged or obstructed. |
 | STEP 6A. Inspect aftercooler for damage. | Damaged aftercooler?
STEP 7. | Incorrect alternator efficiency settings. |
 | STEP 7A. Check alternator efficiency settings. | Alternator efficiency settings within specifications?
STEP 8. | Fuel Injector is malfunctioning. |
 | STEP 8A. Cylinder cutout test. | Cylinder cutout test failed?
STEP 9. | Turbocharger is malfunctioning. |
 | STEP 9A. Inspect the turbocharger assembly. | Malfunctioning turbocharger?
STEP 10. | Malfunctioning alternator. |
 | STEP 10A. Inspect alternator. | Malfunctioning alternator?
STEP 11. | Check ECM calibration and clear fault codes. |
 | STEP 11A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 11B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Fault Code 7554 active or inactive?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active or inactive oil fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive oil related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 143, 214, 415, 421, 1362, 4883, 4884 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1C

Guided Step 1C - Check for active or inactive fuel system related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive fuel system related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 261, 266, 344, 1379, 1389, 2215, 2261, 2262, 2343, 2372, 3727, 3741, 4615, 4885, 4886, 4887, 4888, 4889, 4891, 4892, 4893, 4894, 4927, 4928, 4932, 4933, 4936, 4937, 4958, 4959, 4961 active or inactive?

YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1D
Go to
Go to

Guided Step 1D - Check for active or inactive intake related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive aftercooler related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 158, 1984 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 1E

Guided Step 1E - Check for exhaust related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Check for active or inactive exhaust related fault codes.

  • Use the electronic service tool to read the fault codes.

Fault Code 2122, 2123, 2124, 2125, 2126, 2127, 2128, 2131, 2132, 2133, 2134, 2135, 2136, 2137, 2138 active or inactive?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree and return to this step when the issue is corrected.

Go to 2A
Go to
Go to

Guided Step 2 - Lubricating oil checks.

Guided Step 2A - Check lubricating oil level.

Conditions

  • Turn keyswitch OFF.

Action

  • Check that the lubricating oil level is correct. Refer to Procedure 007-037 in the Associated Procedures Table.

Oil level correct?
YES NO
No Repair

Repair

  • Calibrate the lubricating oil dipstick for the proper oil level. Refer to Procedure 007-009 in the Associated Procedures Table.
  • If the oil level is high and coolant contamination has been detected, then reset the search to coolant in the oil.
  • If the oil level is high and fuel contamination has been detected, then reset the search to fuel in the oil.
  • If the oil level is high and no coolant or fuel contamination has been detected, then incorrect oil dipstick calibration has been detected.

Go to 2B

Go to 11A

Guided Step 2B - Inspect the oil filter.

Conditions

  • Turn keyswitch OFF.

Action

  • Inspect the oil filter for debris or metal particles. Refer to Procedure 007-051 in the Associated Procedures Table.

Debris or metal particles found?
YES NO

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.
 No Repair

Go to 11A

Go to 3A

Guided Step 3 - Engine barring over check.

Guided Step 3A - Engine barring over measurement.

Conditions

  • Turn keyswitch OFF.

Action

Perform engine barring torque measurement check.

  • Check for proper torque measurement. Refer to Procedure 009-035 in the Associated Procedures Table.

Torque measurement correct?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Go to 4A

Escalate or call for assistance.

Guided Step 4 - Restricted intake air filter.

Guided Step 4A - Check air intake.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the air intake restriction. Refer to Procedure 010-031 in the Associated Procedures Table.

Air Intake restricted?
YES NO

Repair

Replace the air filter. Refer to Procedure 010-031 in the Associated Procedures Table.

 No Repair

Go to 11A

Go to 5A

Guided Step 5 - Exhaust restricted.

Guided Step 5A - Check exhaust for restriction.

Conditions

  • Turn keyswitch OFF.

Action

  • Check the exhaust restriction. Refer to Procedure 011-009 in the Associated Procedures Table.

Exhaust restricted?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Repair the source of the exhaust restriction. Refer to the OEM manual.
 No Repair

Go to 11A

Go to 6A

Guided Step 6 - Aftercooler damaged or obstructed.

Guided Step 6A - Inspect aftercooler for damage.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Inspect the aftercooler. Refer to Procedure 010-002 in the Associated Procedures Table.

Malfunctioning aftercooler?
YES NO

Repair

  • Repair or replace the aftercooler. Refer to Procedure 010-002 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 7A

Guided Step 7 - Incorrect alternator efficiency settings.

Guided Step 7A - Check parameter settings.

Conditions

  • Turn keyswitch OFF.

Action

  • Check alternator efficiency settings in generator set controller. Refer to original equipment manufacturer (OEM) manual for specifications.

Alternator efficiency settings incorrect?
YES NO
No Repair

Repair

  • Reset alternator efficiency settings to default value.
  • Refer to the OEM manual for specifications.

Go to 7A

Go to 11A

Guided Step 8 - Fuel Injector is malfunctioning.

Guided Step 8A - Cylinder cutout test.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Perform the cylinder cutout test.

  • Use the recommended Cummins® electronic service tool or equivalent.
  • Perform the Cummins electronic service tool Cylinder Cutout Test to determine if the misfire can be isolated to a single injector. Refer to Procedure 014-008 in the Associated Procedures Table.

Cylinder cutout test failed?
YES NO
No Repair

Repair

  • If engine fails the cylinder cutout test, before replacing the fuel injector, verify the overhead valve lash measurements are correct for the suspect cylinder and adjust if needed. Refer to Procedure 006-026 in the Associated Procedures Table.
  • Replace the fuel injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 11A

Go to 9A

Guided Step 9 - . Turbocharger is malfunctioning.

Guided Step 9A - Inspect the turbocharger assembly.

Conditions

  • Turn keyswitch OFF.
  • Remove the intake and exhaust connections from the turbocharger.

Action

Inspect the turbocharger for the following:

  • Visually inspect the compressor wheel retaining nut for signs of dust ingestion.
  • Visually inspect the turbocharger compressor and turbine blades for damage or wear.
  • Measure the radial and axial clearance of the turbocharger wheel.
  • Use the following procedure for general inspection techniques. Refer to Procedure 010-033 in the Associated Procedures Table.

Malfunctioning turbocharger?
YES NO

Repair

  • Replace the turbocharger assembly. Refer to Procedure 010-033 in the Associated Procedures Table.
 No Repair

Go to 11A

Go to 10A

Guided Step 10 - Malfunctioning alternator.

Guided Step 10A - Inspect alternator.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the alternator.

  • Check for original equipment manufacturer (OEM) fault codes.
  • Refer to the original equipment manufacturer (OEM) manual for any troubleshooting of this component.

Malfunctioning alternator?
YES NO

Repair

  • Refer to the original equipment manufacturer (OEM) manual for any troubleshooting of this component.
 No Repair

Go to 11A

Go to 11A

Guided Step 11 - Check ECM calibration and clear fault codes.

Guided Step 11A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

  • If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 11B

Go to 11B

Guided Step 11B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

  • Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 05-May-2021


FAULT CODE 7555 - Alternator Feedback Power - Special Instructions

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Component Connector and Pin Inspection | Refer to Procedure 019-361 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Data Link Circuit, SAE J1939 | Refer to Procedure 019-165 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Check for primary fault codes.
STEP 2. | Malfunctioning generator set wiring harness. |
 | STEP 2A. Inspect connections to generator set controller. | Generator set wiring harness connected to generator set controller?
STEP 3. | Data link terminating resistance is incorrect. |
 | STEP 3A. Inspect the engine wiring harness. | Malfunctioning engine wiring harness?
 | STEP 3B. Generator data link terminating resistor resistance check. | Malfunctioning terminating resistor?
 | STEP 3C. Engine data link terminating resistor resistance check. | Malfunctioning terminating resistor?
STEP 4. | Generator set controller calibration is incorrect for this application. |
 | STEP 4A. Verify generator set controller calibration. | Calibration correct?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Read the fault codes.

  • Start the engine and let it idle for 1 minute.
  • Use the recommended Cummins® electronic service tool or equivalent to read the fault codes.

Primary Fault codes 426, 3329?

YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Malfunctioning generator set wiring harness.

Guided Step 2A - Inspect connections to generator set controller.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine wiring harness and generator set wiring harness for the following:

  • Verify engine and generator set wiring harnesses are connected to generator set controller.

Generator set wiring harness connected to generator set controller?
YES NO
No Repair

Repair

Repair or replace only the components that were found to be out of specification.

  • Connect wiring harnesses to generator set controller. Refer to the original equipment manufacturer (OEM) for specifications.

Go to 3A

Go to 5A

Guided Step 3 - Data link terminating resistance is incorrect.

Guided Step 3A - Inspect engine wiring harness.

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.

Action

  • Inspect the pins and connectors for damage.
  • Measure the resistance between the data link (+) pin and the data link (-) pin at the 9-pin service data link connector.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Terminating resistance is within specifications 54- 66 Ω?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3B

Guided Step 3B - Generator data link terminating resistor resistance check.

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the terminating resistor from the generator set wiring harness.

Action

Inspect the terminating resistors for the following:

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance between the pins for the generator terminating resistor.

Terminating resistor is within specifications 108- 132 Ω?
YES NO
No Repair

Repair

A malfunctioning terminating resistor has been detected.

  • Replace the terminating resistor. Refer to the OEM manual.

Go to 3C

Go to 5A

Guided Step 3C - Engine data link terminating resistor resistance check.

Conditions

  • Turn keyswitch OFF.
  • Wait for 90 seconds.
  • Disconnect the terminating resistor from the engine wiring harness.

Action

Inspect the terminating resistors for the following:

  • Inspect the pins and connectors for damage. Refer to Procedure 019-361 in the Associated Procedures Table.
  • Measure the resistance of the terminating resistor.
  • Refer to the circuit diagram or wiring diagram for connector pin identification.

Terminating resistor is within specifications 108- 132 Ω?
YES NO

Repair

A malfunctioning engine wiring harness has been detected.

  • Repair or replace the engine wiring harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

A malfunctioning terminating resistor has been detected.

  • Replace the terminating resistor. Refer to Procedure 019-165 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Generator set controller calibration is incorrect for this application.

Guided Step 4A - Verify generator set controller calibration.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

  • Verify the generator set calibration is proper for the application. Refer to OEM Service Manual.

Calibration correct?
YES NO
No Repair

Repair

If the generator set calibration and application do not match, then a malfunctioning generator set calibration code has been detected. Refer to OEM Service Manual.

  • Download the updated generator set calibration. Refer to OEM Service Manual.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

Calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Verify that all steps have been completed. If all steps have been completed, then follow your technical escalation process.

Repair complete.

Escalate or call for assistance.

Last Modified: 18-May-2021


FAULT CODE 7558 - Engine Friction Deviation - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Fault code is for information only. |
 | STEP 1A. Information only fault code. | No repair is necessary.
STEP 2. | Check the ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Fault code is for information only.

Guided Step 1A - Information only fault code.

Conditions

  • Turn keyswitch ON.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Check for active fault codes.

  • This troubleshooting step is for information only stating that an unexpected source of friction has been detected.
  • This solution is information only. No repair is necessary.

OK NOT OK

Go to

Go to

Guided Step 2 - Check the ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect recommended Cummins® electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete.

Go to 1A

Last Modified: 22-Apr-2021


FAULT CODE 13266 - Crankcase Pressure 2 - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather System - With Filter Assembly | Refer to Procedure 001-122 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Visual inspection of crankcase breather components. |
 | STEP 1A. Inspect the breather tubes. | Damaged breather tubes?
STEP 2. | Crankcase pressure sensor is malfunctioning. |
 | STEP 2A. Crankcase pressure sensor check. | Reading correct?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Visual inspection of crankcase breather components.

Guided Step 1A - Inspect the breather tubes.

Conditions

  • Turn keyswitch OFF.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Inspect the breather tubes. Refer to Procedure 001-122 in the Associated Procedures Table.

Damaged breather tubes?
YES NO

Repair

Repair or replace only the components that were found to be out of specification.

  • Replace the breather tube. Refer to Procedure 001-122 in the Associated Procedures Table.
  • Repair or replace the breather tube hoses. Refer to Procedure 001-122 in the Associated Procedures Table.
  • Repair or replace the breather tube hose clamps. Refer to Procedure 001-122 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Crankcase pressure sensor is malfunctioning.

Guided Step 2A - Crankcase pressure sensor check.

Conditions

  • Turn keyswitch ON.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Use the recommended Cummins® electronic service tool or equivalent.

  • Monitor the crankcase pressure sensor 2. Refer to Procedure 019-445 in the Associated Procedures Table.

Reading correct?
YES NO
No Repair

Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use the recommended Cummins® electronic service tool or equivalent to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect the recommended Cummins® electronic service tool or equivalent.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 31-Jan-2022


FAULT CODE 111 - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2015


FAULT CODE 111 (Source Address 01) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2015


FAULT CODE 111 (Source Address 144) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2015


FAULT CODE 111 (Source Address 186) - Engine Control Module Critical Internal Failure - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the ECM. |
 | STEP 1A. Check the ECM. | Fault Code 111 inactive?
 | STEP 1B. Check the inactive counts of Fault Code 111. | Less than three counts?
STEP 2. | Check ECM calibration and clear the fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the ECM

Guided Step 1A - Check the ECM

Conditions

  • Connect all components.
  • Turn keyswitch OFF and wait 5 seconds.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 111 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the inactive counts of Fault Code 111.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the inactive counts of Fault Code 111.

  • Use INSITE™ electronic service tool to read the inactive counts of Fault Code 111.

Less than three counts?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 2B

Repair complete.

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 11-Jun-2015


FAULT CODE 319 - Real Time Clock - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Real-Time Clock Battery | Refer to Procedure 019-311 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the real-time clock battery voltage. |
 | STEP 1A. Check the real-time clock battery voltage at the battery module connector. | Between 3.3 and 3.6 VDC?
STEP 2. | Check the battery module harness. |
 | STEP 2A. Inspect the real-time clock battery and engine wire harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2E. Check for a short circuit to ground. |
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the real-time clock battery voltage.

Guided Step 1A - Check the real-time clock battery voltage at the battery module connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check the real-time clock battery voltage.

  • Measure the voltage between the real-time clock battery SUPPLY pin and the real-time clock battery RETURN (-) pin at the real-time clock battery connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Between 3.3 and 3.6 VDC?
YES NO
No Repair

Repair

Replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the battery module harness.

Guided Step 2A - Inspect the real-time clock battery and engine wire harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the real-time clock battery from the engine harness.

Action

Inspect the real-time clock battery and engine harness connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the module or harness connector. Repair or replace the real-time clock battery or engine harness.

  • Repair or replace the real-time clock battery. Refer to Procedure 019-311 in the Associated Procedures Table.
  • Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the module or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
  • Replace ECM only when there is damaged pins. Refer to Procedure 019-031 in the Associated Procedures Table.
 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.

Action

Measure the following resistance:

  • The resistance between the real-time clock battery SUPPLY pin at the battery connector of the engine harness to the real-time clock battery SUPPLY pin at the ECM harness connector.
  • The resistance between the real-time clock battery RETURN (-) pin at the battery connector of the engine harness to the real-time clock battery RETURN (-) pin at the ECM harness connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check for a short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to all other pins in the connector.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair the damaged harness, connector, or pins, if possible.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check for a short circuit to ground.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM connector.
  • Disconnect the real-time clock battery from the engine harness.

Action

Check for a short circuit.

  • Use a multimeter to measure the resistance from the real-time clock battery SUPPLY pin at the ECM connector of the engine harness to engine block ground.

Use the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A short circuit has been detected in the engine harness.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 546 - Fuel Delivery Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault code active?
 | STEP 1B. Check for active fault codes. | Fault Code 4892 active?
 | STEP 1C. Check for an inactive fault code. | Fault Code 546 inactive?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 547 active and Fault Code 546 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 546 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the ECM response. |
 | STEP 3A-2. Inspect the engine fuel supply pump and connector pins. |
 | STEP 3A-3. Check the ECM response. |
 | STEP 3A-4. Check for an inactive fault code. |
 | STEP 3A-5. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the sensor supply voltage and return circuit. |
 | STEP 3B-2. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active and Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO

Repair

A damaged fuel delivery pressure sensor has been detected.

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3A-3

Guided Step 3A-3 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the ECM.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES | NO
No Repair | No Repair

Go to 3A-5

Go to 3A-4

Guided Step 3A-4 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Repair

A pin-to-pin short circuit has been detected on the fuel delivery pressure SIGNAL wire of the engine harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3A-5 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Repair

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES NO

Repair

  • An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Repair

An open fuel delivery pressure return circuit has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2014


FAULT CODE 547 - Fuel Delivery Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault code active?
 | STEP 1B. Check for active fault codes. | Fault Code 4892 active?
 | STEP 1C. Check for an inactive fault code. | Fault Code 546 inactive?
STEP 2. | Check the fuel delivery pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel delivery pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 546 active and Fault Code 547 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 547 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3A-1. Check the sensor voltage and return circuit. |
 | STEP 3A-2. Check for an inactive fault code. |
 | STEP 3B. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B-1. Check the ECM response. |
 | STEP 3B-2. Inspect the engine fuel supply pump and connector pins. |
 | STEP 3B-3. Check the ECM response. |
 | STEP 3B-4. Check for an inactive fault code. |
 | STEP 3B-5. Check for an inactive fault code. |
STEP 4. | Check ECM calibration and clear fault codes |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel delivery pressure sensor and circuit.

Guided Step 2A - Inspect the fuel delivery pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.

Action

Inspect the engine harness and fuel delivery pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken.
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor connector from the engine harness connector.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

4.75 to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel delivery pressure 5 volt SUPPY pin and the fuel delivery pressure SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active and Fault Code 547 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3B

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel delivery pressure sensor to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 active?
YES NO

Repair

A damaged fuel delivery pressure sensor has been detected.

Replace the fuel delivery pressure sensor.

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A-1

Guided Step 3A-1 - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel delivery pressure 5 volt SUPPLY pin to the fuel delivery pressure RETURN pin at the engine harness connector port of the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A-2

Go to 4A

Guided Step 3A-2 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Repair

An open or shorted fuel delivery pressure 5 volt supply circuit has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness connector and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged locking tab connector.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected at the ECM or engine harness connector.

Clean the connector pins.

Replace the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B-1

Guided Step 3B-1 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the ECM engine connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response at 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3B-2

Go to 4A

Guided Step 3B-2 - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in Section 19.

 No Repair

Go to 4A

Go to 3B-3

Guided Step 3B-3 - Check the ECM response.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine harness connector to the ECM.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Disconnect the fuel delivery pressure sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the ECM response.

Place a jumper wire between the fuel delivery pressure 5 volt SUPPLY pin and the fuel delivery pressure SIGNAL pin at the fuel delivery pressure sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Check the circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546 active?
YES | NO
No Repair | No Repair

Go to 3B-5

Go to 3B-4

Guided Step 3B-4 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Repair

An open fuel delivery pressure signal circuit or pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged section of harness. Refer to 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3A-5 - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 547 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected. Refer to Procedure 019-362 in Section 19.

Repair

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2014


FAULT CODE 553 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K111 | 4358519
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?
STEP 2. | Check the rail fuel pressure sensor. |
 | STEP 2A. Verify fuel rail pressure sensor part number. | Correct fuel rail pressure sensor installed for the engine control parts list (CPL)?
 | STEP 2B. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 4. | Check for air in the fuel. |
 | STEP 4A. Check for air in the fuel system. | Air in the fuel?
STEP 5. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2261, 2262, 2343, 2372, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel rail pressure sensor.

Guided Step 2A - Verify fuel rail pressure sensor part number.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel rail pressure sensor and make sure it is correct for the engine CPL.

Correct fuel rail pressure sensor installed for the engine CPL?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2B

Go to 5A

Guided Step 2B - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor.

Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 5A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair

Repair the source of the high fuel drain line restriction.

Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 5A

Guided Step 4 - Check for air in the fuel.

Guided Step 4A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

Repair

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 559 - Injector Metering Rail 1 Pressure - Data Valid But Below Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Pump | Refer to Procedure 005-016 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Injector Supply Lines (High Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K111 | 4358519
Fuel Rail Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for active fault codes. | Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?
STEP 2. | Check the operation of the fuel system. |
 | STEP 2A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 2B. Check for air in the fuel system. | Air in the fuel?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
 | STEP 2D. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
 | STEP 2E. Check the operation of the high-pressure fuel pump. | Fault Code 559 become active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch OFF.

Action

  • Turn keyswitch ON.
  • Connect the INSITE™ electronic service tool.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2262, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive with more than one count in the last 25 engine hours?

YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the operation of the fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for external fuel leaks.

  • Turn keyswitch ON.
  • Operate the engine at idle.
  • Check the high-pressure fuel system for fuel leaking at the outer wall fuel drain hose.

High-pressure fuel line leaks or damage?
YES NO

Repair

Replace any damaged high-pressure fuel supply lines. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check for air in the fuel system.

Conditions

  • Turn keyswitch OFF.

Action

Check for air in the fuel.

  • Turn keyswitch ON.
  • Check for air in the fuel. Refer to Procedure 006-003 in the Associated Procedures Table.

Air in fuel?
YES NO

Repair

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel delivery pressure sensor accuracy.

  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Check the fuel delivery pressure sensor accuracy. Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch OFF.

Action

Check the fuel rail pressure sensor accuracy.

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Check the fuel rail pressure sensor accuracy. Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 2E

Go to 3A

Guided Step 2E - Check the operation of the high-pressure fuel pump.

Conditions

  • Turn keyswitch OFF.

Action

Use INSITE™ electronic service tool to verify the fault codes.

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Operate the engine at rated RPM and load.
  • Use INSITE™ electronic service tool to verify the fault codes.
  • Use INSITE™ electronic service tool High-Pressure Common Rail Pressure Test to raise the rail pressure.

Fault Code 559 become active?
YES NO

Repair

Replace the high-pressure fuel pump assembly. Refer to Procedure 005-016 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 08-Jan-2019


FAULT CODE 581 - Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 4892, 4929, or 4931 active or inactive counts?
 | STEP 1B. Check for an inactive fault code. | Fault Code 581 inactive?
STEP 2. | Check the fuel supply pump intake pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel supply pump intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 582 active and Fault Code 581 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 581 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892, 4929, or 4931 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 581 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel supply pump intake pressure sensor and circuit.

Guided Step 2A - Inspect the fuel supply pump intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.

Action

Inspect the fuel supply pump pigtail and fuel supply pump intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or pigtail.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 582 active and Fault Code 581 inactive?
YES NO
No Repair

Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor connector from the fuel supply pump pigtail.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel supply pump intake pressure 5 volt SUPPLY pin to the fuel supply pump intake pressure RETURN pin at the sensor connector of the pigtail.

Refer to the circuit diagram or wiring diagram for connector pin identifciation.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel supply pump intake pressure sensor to the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 581 active?
YES NO

Repair

A damaged fuel supply pump intake pressure sensor has been detected.

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2014


FAULT CODE 582 - Fuel Supply Pump Intake Pressure Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging the new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 4892, 4929, or 4931 active or inactive counts?
 | STEP 1B. Check for an inactive fault code. | Fault Code 582 inactive?
STEP 2. | Check the fuel supply pump intake pressure sensor and circuit. |
 | STEP 2A. Inspect the fuel supply pump intake pressure sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25 VDC?
 | STEP 2C. Check the circuit response. | Fault Code 581 active and Fault Code 582 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 582 active?
STEP 3. | Check ECM calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892, 4929, or 4931 active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 582 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel supply pump intake pressure sensor and circuit.

Guided Step 2A - Inspect the fuel supply pump intake pressure sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.

Action

Inspect the fuel supply pump pigtail and fuel supply pump intake pressure sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damage connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or pigtail.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor connector from the fuel supply pump pigtail.
  • Turn keyswitch ON.

Action

Check the voltage supply and return circuit.

  • Measure the voltage from the fuel supply pump intake pressure 5 volt SUPPLY pin to the fuel supply pump intake pressure RETURN pin at the sensor connector of the pigtail.

Refer to the circuit diagram or wiring diagram for connector pin identifciation.

4.75 to 5.25 VDC?
YES NO
No Repair

Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel supply pump intake pressure sensor from the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the fuel supply pump intake pressure 5 volt SUPPLY pin and the fuel supply pump intake pressure SIGNAL pin at the fuel supply pump intake pressure sensor connector of the supply pump pigtail.

Refer to the wiring diagram for connector pin identification.

  • Check for the circuit response after 30 seconds.
  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 581 active and Fault Code 582 inactive?
YES NO
No Repair

Repair

Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel supply pump intake pressure sensor to the fuel supply pump pigtail.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 582 active?
YES NO

Repair

A damaged fuel supply pump intake pressure sensor has been detected.

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 05-Sep-2014


FAULT CODE 621 - Exhaust Gas Temperature Deviation Low for Cylinder 1 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 322 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 322 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 322, a malfunction of the injector solenoid circuit could have caused cylinder 1 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 322 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Connect INSITE™ electronic service tool.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 1 sensor accuracy using an infared thermometer.

  • Start the engine
  • Connect INSITE™ electronic service tool.
  • Use an infared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infared thermometer temperature measurement with the exhaust gas temperature cylinder 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Adjust the valve lash, if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 622 - Exhaust Gas Temperature Deviation Low for Cylinder 3 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 324 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 3 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 324 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 324, a malfunction of the injector solenoid circuit could have caused cylinder 3 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 324 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Connect INSITE™ electronic service tool.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 3 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 3 sensor accuracy using an infared thermometer.

  • Start the engine
  • Connect INSITE™ electronic service tool.
  • Use an infared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infared thermometer temperature measurement with the exhaust gas temperature cylinder 3 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 3 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 3 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Adjust the valve lash, if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 3 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the engine control module (ECM) calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 623 - Exhaust Gas Temperature Deviation Low for Cylinder 5 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for related fault codes. | Fault Code 323 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 5 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 323 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 323, a malfunction of the injector solenoid circuit could have caused cylinder 5 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 323 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 5 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 5 sensor accuracy using an infrared thermometer.

  • Start the engine. Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 5 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Is the exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?

YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 5 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 5 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 5 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 5 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2015


FAULT CODE 624 - Exhaust Gas Temperature Deviation Low for Cylinder 7 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the Fault Codes |
 | STEP 1A. Check for related fault codes. | Fault Code 1548 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 7 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1548 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1548, a malfunction of the injector solenoid circuit could have caused cylinder 7 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1548 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 7 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 7 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 7 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 7 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 7 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 7 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 7 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jun-2015


FAULT CODE 625 - Exhaust Gas Temperature Deviation Low for Cylinder 9 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1622 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 9 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1622 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1622, a malfunction of the injector solenoid circuit could have caused cylinder 9 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1622 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 9 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 9 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 9 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Is the exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?

YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 9 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 9 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 9 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 9 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Jun-2015


FAULT CODE 626 - Exhaust Gas Temperature Deviation Low for Cylinder 11 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes |
 | STEP 1A. Check for related fault codes. | Fault Code 1552 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 11 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1552 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1552, a malfunction of the injector solenoid circuit could have caused cylinder 11 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1552 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 11 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 11 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 11 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Is the exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?

YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 11 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 11 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 11 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 11 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jun-2015


FAULT CODE 627 - Exhaust Gas Temperature Deviation Low for Cylinder 13 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1554 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 13 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1554 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1554, a malfunction of the injector solenoid circuit could have caused cylinder 13 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1554 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 13 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 13 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 13 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 13 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 13 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 13 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 13 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jun-2015


FAULT CODE 628 - Exhaust Gas Temperature Deviation Low for Cylinder 15 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1556 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1556 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1556, a malfunction of the injector solenoid circuit could have caused cylinder 15 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1556 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 15 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 15 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 15 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 15 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 15 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 15 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 15 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 25-Jun-2015


FAULT CODE 631 - Exhaust Gas Temperature Deviation Low for Cylinder 2 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4332823
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 331 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 331 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 331, a malfunction of the injector solenoid circuit could have caused cylinder 2 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 331 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 2 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 2 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 2 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 2 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 632 - Exhaust Gas Temperature Deviation Low for Cylinder 4 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4332823
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 332 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 4 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 332 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 332, a malfunction of the injector solenoid circuit could have caused cylinder 4 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 332 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 4 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 4 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 4 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 4 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 4 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 4 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 4 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 633 - Exhaust Gas Temperature Deviation Low for Cylinder 6 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4332823
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 325 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 6 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 325 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 325, a malfunction of the injector solenoid circuit could have caused cylinder 6 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 325 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 6 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 6 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 6 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 6 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 6 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 6 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 6 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 634 - Exhaust Gas Temperature Deviation Low for Cylinder 8 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1549 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 8 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1549 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1549, a malfunction of the injector solenoid circuit could have caused cylinder 8 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1549 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 8 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 8 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 8 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 8 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 8 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 8 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 8 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 635 - Exhaust Gas Temperature Deviation Low for Cylinder 10 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1551 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 10 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1551 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1551, a malfunction of the injector solenoid circuit could have caused cylinder 10 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1551 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 10 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 10 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 10 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 10 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 10 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 10 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 10 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 636 - Exhaust Gas Temperature Deviation Low for Cylinder 12 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1553 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 12 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1553 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1553, a malfunction of the injector solenoid circuit could have caused cylinder 12 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1553 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 12 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 12 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 12 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 12 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 12 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 12 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 12 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 637 - Exhaust Gas Temperature Deviation Low for Cylinder 14 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1555 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 14 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1555 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1555, a malfunction of the injector solenoid circuit could have caused cylinder 14 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1555 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 14 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 14 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 14 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 14 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 14 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 14 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 14 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 07-Apr-2015


FAULT CODE 638 - Exhaust Gas Temperature Deviation Low for Cylinder 16 - Data Valid But Below Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | Fault Code 1557 active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 556 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 16 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the overhead set. |
 | STEP 2A. Check the overhead set. | Damaged overhead components or valve lash severely out of adjustment?
STEP 3. | Check the engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 1557 active or inactive counts?
YES NO

Repair

If there are active or inactive counts of Fault Code 1557, a malfunction of the injector solenoid circuit could have caused cylinder 16 exhaust gas temperature to be colder than the engine average.

No Repair

Fault Code 1557 troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 556 active?
YES | NO
No Repair | No Repair

Fault Code 556 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 16 sensor accuracy.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 16 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 16 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 16 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the overhead set.

Guided Step 2A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 16 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 16 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash severely out of adjustment.

Damaged overhead components or valve lash severely out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

Repair

Replace the cylinder 16 injector. Refer to Procedures 006-026 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check the ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 641 - Exhaust Gas Temperature Cylinder 1 (A1) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check ECM calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference to the appropriate procedures in Sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 642 - Exhaust Gas Temperature Cylinder 3 (A2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 3 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to fault code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 3 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 3 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 3 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 3 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO

Repair

Replace the Barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Repair

Replace the Barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 3 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 3 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 643 - Exhaust Gas Temperature Cylinder 5 (A3) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 5 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to fault code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 5 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 5 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 5 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 5 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 5 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 5 injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 644 - Exhaust Gas Temperature Cylinder 7 (A4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 7 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to Fault Code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 7 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 7 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 7 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 7 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 7 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 7 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 7 injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 645 - Exhaust Gas Temperature Cylinder 9 (A5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 9 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to Fault Code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 9 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 9 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 9 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 9 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 9 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 9 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 9 injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 646 - Exhaust Gas Temperature Cylinder 11 (A6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 11 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 11 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 11 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 11 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 11 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the braometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 11 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 11 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 11 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 647 - Exhaust Gas Temperature Cylinder 13 (A7) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 13 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 13 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 13 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 13 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 13 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 13 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 13 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 31 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 648 - Exhaust Gas Temperature Cylinder 15 (A8) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 15 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 15 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 15 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 15 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 15 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 15 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 15 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 652 - Exhaust Gas Temperature Cylinder 2 (B1) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 2 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 2 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 653 - Exhaust Gas Temperature Cylinder 4 (B2) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 4 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 4 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 4 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 4 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 4 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 4 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 4 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 654 - Exhaust Gas Temperature Cylinder 6 (B3) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 6 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 6 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 6 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 6 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 6 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 6 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 6 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 655 - Exhaust Gas Temperature Cylinder 8 (B4) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

WARNING

To reduce the possibility of personal injury to the eyes, wear appropriate eye protection when removing the reagent nozzle line. Air pressure may be present in the reagent nozzle line if there is a fault in the system.
WARNING

The exhaust and exhaust components can become heated during troubleshooting. To avoid the risk of fire, property damage, burns, or other serious personal injury, allow the exhaust system to cool before beginning any procedure or repair. Make sure that no combustible materials are located where they are likely to come in contact with hot exhaust or exhaust components.
CAUTION

To reduce the possibility of pin and harness damage, use the following test leads when taking a measurement: Part Number 3822758 - male Deutsch™/AMP™/Metri-Pack™ test lead and Part Number 3822917 - female Deutsch™/AMP™/Metri-Pack™ test lead.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 10 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure system. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead seat. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES NO

Repair

Go to Fault Code 731 troubleshooting tree.

 No Repair

Go to 6A

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 10 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 10 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 10 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 10 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES | NO
No Repair | No Repair

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for bent, damaged, or missing fins.

  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Section 10 and 11 of the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 10 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valve or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect exhaust valves and seats for damage.

Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 10 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 656 - Exhaust Gas Temperature Cylinder 10 (B5) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 10 sensor accuracy. | Is the exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP . |
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to Fault Code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 10 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 10 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 10 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Is the exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO

Repair

Repair

A damaged exhaust gas temperature cylinder 10 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES NO

Repair

 No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the Barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger. Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 10 valve cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 10 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn the keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 10 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 657 - Exhaust Gas Temperature Cylinder 12 (B6) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 12 sensor accuracy. | Is the exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP . |
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to Fault Code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 12 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 12 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 12 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Is the exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO

Repair

Repair

A damaged exhaust gas temperature cylinder 12 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES NO

Repair

 No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger. Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 12 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 12 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn the keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 12 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 658 - Exhaust Gas Temperature Cylinder 14 (B7) - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 14 sensor accuracy. | Is the exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP . |
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

See the appropriate fault code troubleshooting tree.

1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to Fault Code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 14 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 14 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 14 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Is the exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO

Repair

Repair

A damaged exhaust gas temperature cylinder 14 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES NO

Repair

 No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor.

Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?

YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger. Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn the keyswitch OFF.
  • Remove the cylinder 14 valve cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 14 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn the keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 14 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Jul-2015


FAULT CODE 2121 - Exhaust Gas Temperature Cylinder 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 1 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 1 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 1 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2122 - Exhaust Gas Temperature Cylinder 3 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 3 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 3 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 3 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 3 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 3 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 3 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 1 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2123 - Exhaust Gas Temperature Cylinder 5 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 5 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 5 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 5 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 5 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 5 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 5 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 5 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 5 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2124 - Exhaust Gas Temperature Cylinder 7 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 7 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 7 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 7 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 7 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 7 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 7 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 7 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 7 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2125 - Exhaust Gas Temperature Cylinder 9 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 9 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 9 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 9 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 9 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 9 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 9 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 9 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 9 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2126 - Exhaust Gas Temperature Cylinder 11 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 11 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 11 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 11 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 11 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 11 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 11 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 11 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 11 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2127 - Exhaust Gas Temperature Cylinder 13 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 13 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature sensor fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 13 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 13 sensor accuracy using and infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 13 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 13 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the folowing:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 in the appropriate service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 13 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 13 overhead set for the following conditions:

  • Damage to the rocker levers or crossheads
  • Damage to the valves or valve springs
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the Cylinder Compression Test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove the cylinder head and inspect the exhaust valves and seat for damage. Replace any damaged components.

Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 13 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and check again.

Repair complete

Go to 1A

Last Modified: 10-Sep-2014


FAULT CODE 2128 - Exhaust Gas Temperature Cylinder 15 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 15 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 15 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 15 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 15 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-031 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 15 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 15 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash, if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized, listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 15 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2131 - Exhaust Gas Temperature Cylinder 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check ECM calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 2 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 2 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 2 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2132 - Exhaust Gas Temperature Cylinder 4 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 4 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 4 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 4 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 4 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 4 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 4 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 4 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2133 - Exhaust Gas Temperature Cylinder 6 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 6 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 6 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 6 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 6 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 6 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 6 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 6 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2134 - Exhaust Gas Temperature Cylinder 8 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 8 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 8 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 8 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 8 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 8 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 8 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 8 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2135 - Exhaust Gas Temperature Cylinder 10 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 10 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 10 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 10 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 10 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 10 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 10 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 10 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2136 - Exhaust Gas Temperature Cylinder 12 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Injector | Refer to Procedure 006-026 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Manifold | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 15 sensor accuracy. | Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. |
STEP 3. | Check the power cylinders. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes, |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 12 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 12 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 12 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 12 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check the air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following.

  • Bent, damaged, or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the Service Manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 12 rocker lever cover. Refer to Procedure 003-011 in the Associated Procedures Table.

Action

Inspect the cylinder 12 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-006 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to Procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch ON.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders. Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components. Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 12 injector. Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 2137 - Exhaust Gas Temperature Cylinder 14 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 14 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
 | STEP 2D. Inspect the turbochargers. | Fins damaged or missing?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to fault code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 14 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 14 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 14 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 14 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the Barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the damaged turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 14 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 14 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-006 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 14 injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2138 - Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 16 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to fault code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 16 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 16 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 16 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 16 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbocharger.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged or missing fins.
  • Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the damaged turbocharger.

  • Refer to Procedure 010-033 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 16 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to Procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 16 injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2144 - Exhaust Gas Temperature Cylinder 16 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cylinder Head | Refer to Procedure 002-004 | QSK95 CM2350 K111 | 4358519
Overhead Set | Refer to Procedure 003-004 | QSK95 CM2350 K111 | 4358519
Rocker Lever Assembly | Refer to Procedure 003-009 | QSK95 CM2350 K111 | 4358519
Valve Cover | Refer to Procedure 003-032 | QSK95 CM2350 K111 | 4358519
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K111 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Bellows | Refer to Procedure 011-018 | QSK95 CM2350 K111 | 4358519
Engine Compression | Refer to Procedure 014-012 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K111 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature cylinder 16 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
 | STEP 1D. Check for multiple fault codes. | Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check the power cylinder. |
 | STEP 3A. Check the overhead set. | Damaged overhead components or valve lash out of adjustment?
 | STEP 3B. Check for damaged exhaust valves. | Leaking exhaust valves detected?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Go to fault code 731 troubleshooting tree.

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature cylinder 16 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature cylinder 16 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature cylinder 16 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent with the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature cylinder 16 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 1D

Go to 4A

Guided Step 1D - Check for multiple fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

Use INSITE™ electronic service tool to read the fault codes.

Exhaust gas temperature high fault codes for other cylinders also active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 4A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications from Procedure 010-031 found in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 4A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins. Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

  • Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. Reference the appropriate procedures in sections 10 and 11 of the service manual.

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the power cylinder.

Guided Step 3A - Check the overhead set.

Conditions

  • Turn keyswitch OFF.
  • Remove the cylinder 16 rocker lever cover. Refer to Procedure 003-032 in the Associated Procedures Table.

Action

Inspect the cylinder 16 overhead set for the following conditions.

  • Damage to the rocker levers or crossheads.
  • Damage to the valves or valve springs.
  • Valve lash out of adjustment.

Damaged overhead components or valve lash out of adjustment?
YES NO

Repair

Readjust the valve lash if necessary. Refer to procedure 003-004 in the Associated Procedures Table.

Replace any damaged overhead components. Refer to procedure 003-009 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for damaged exhaust valves.

Conditions

  • Turn keyswitch OFF.
  • Remove the turbocharger turbine outlet bellows. Refer to Procedure 011-018 in the Associated Procedures Table.

Action

Perform the cylinder compression test.

  • Refer to Procedure 014-012 in the Associated Procedures Table.

It is not necessary to perform the test on adjacent cylinders.

  • Once the cylinder is pressurized listen for air leaking past the exhaust valves.

Leaking exhaust valves detected?
YES NO

Repair

Remove cylinder head and inspect exhaust valves and seats for damage. Replace any damaged components.

  • Refer to Procedure 002-004 in the Associated Procedures Table.

Repair

Replace the cylinder 16 injector.

  • Refer to Procedure 006-026 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2215 - Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K111 | 4358519
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Air Bleed Line Check Valve | Refer to Procedure 006-056 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K111 | 4358519
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has an adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check for air in the fuel system. | Air in the fuel?
 | STEP 3B. Check fuel inlet pressure | Fuel inlet pressure within the specifications found in Procedure 006-104 in the Associated Procedures Table?
 | STEP 3C. Check the Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3D. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3E. Check air bleed line check valve operation. | Fuel flow from the fuel pump air bleed line within the specifications found in Procedure 005-236 in the Associated Procedures Table?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Start the engine.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment has an adequate fuel supply?
YES NO
No Repair

Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction and low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor

Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within the specifications found in Procedure 006-104 in Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

Repair

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Repair

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in 005-236 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check air bleed line check valve operation.

Conditions

  • Remove the check valve from the fuel drain manifold and route into a graduated cylinder.
  • Operate the engine.

Action

Check the fuel flow through the air bleed line check valve from the high-pressure fuel pump.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel flow from the fuel pump air bleed line within the specifications found in Procedure 005-236 in the Associated Procedures Table?

YES NO

Repair

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Repair

Replace the air bleed check valve. Refer to Procedure 006-056 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2016


FAULT CODE 2261 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
STEP 2. | Check the fuel supply system. |
 | STEP 2A. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2B. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drian line restriction. | Fuel drain line restriction within the specifications outlined in Procedure 006-012?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel supply system.

Guided Step 2A - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or see equipment manufacturer service information.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair

Replace the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2262 - Fuel Pump Delivery Pressure - Data Valid But Below Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K111 | 4358519
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Air Bleed Line Check Valve | Refer to Procedure 006-056 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K111 | 4358519
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated before replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has an adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2C. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check for air in the fuel system. | Air in the fuel?
 | STEP 3B. Check fuel inlet pressure. | Fuel inlet pressure within the specifications found in Procedure 006-104 in the Associated Procedure Table?
 | STEP 3C. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3D. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
 | STEP 3E. Check air bleed line check valve operation. | Fuel flow from the fuel pump air bleed line within the specifications found in Procedure 005-236 in the Associated Procedures Table?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 2A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment has an adequate fuel supply?
YES NO
No Repair

Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction and low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to procedure 006-024 in the Associated Procedures Table or the equipment manufacturer service information.

No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

  • Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor

Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

  • Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair

Investigate the cause of the air in fuel. Check for loose Stage 1 filters, loose fuel line fittings and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within the specifications found in Procedure 006-104 in the Associated Procedures Table?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO

Repair

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Repair

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236 in the Associated Procedures Table?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check air bleed line check valve operation.

Conditions

  • Remove the check valve from the fuel drain manifold and route into a graduated cylinder.
  • Operate the engine.

Action

Check the fuel flow through the air bleed line check valve from the high-pressure fuel pump.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Fuel flow from the fuel pump air bleed line within the specifications found in Procedure 005-236 in the Associated Procedures Table?

YES NO

Repair

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Repair

Replace the air bleed check valve. Refer to Procedure 006-056 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 02-Aug-2016


FAULT CODE 2343 - Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2343 active or counts of inactive?
 | STEP 1B. Check for active fault codes. | Fault Code 2372 active or counts of inactive?
STEP 2. | Inspect the fuel delivery line. |
 | STEP 2A. Check the Stage 2 fuel filter intake line. | Kinks or damage found?
STEP 3. | Check the fuel delivery pressure sensor. |
 | STEP 3A. Verify fuel delivery pressure sensor accuracy. | Fuel delivery pressure sensor within specification found in Procedure 019-548?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2343 active or counts of inactive?
YES | NO
No Repair | No Repair

Go to 1B

Go to 4A

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 active or counts of inactive?
YES | NO
No Repair | No Repair

Appropriate troubleshooting symptom tree

Go to 2A

Guided Step 2 - Inspect the fuel delivery line.

Guided Step 2A - Check the Stage 2 fuel filter intake line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Stage 2 fuel filter intake line for kinks or damage.

Kinks or damage found?
YES NO

Repair

Replace the Stage 2 fuel filter intake line. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel delivery pressure sensor.

Guided Step 3A - Verify fuel delivery pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel delivery pressure sensor accuracy.

Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor within specification found in Procedure 019-548?
YES NO

Repair

Stage 2 fuel filter restriction is greater than a calibrateable threshold. See equipment manufacturer service information.

Replace the Stage 2 fuel filters, if necessary. Refer to Procedure 006-076 in the Associated Procedures Table.

Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2372 - Fuel Filter Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 2) | Refer to Procedure 006-076 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Read the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2372 active or inactive counts?
STEP 2. | Inspect the fuel delivery line. |
 | STEP 2A. Check the Stage 2 fuel filter intake line. | Kinks or damage found?
STEP 3. | Check the fuel delivery pressure sensor. |
 | STEP 3A. Verify fuel delivery pressure sensor accuracy. | Fuel delivery pressure sensor within specification found in Procedure 019-548 in the Associated Procedures Table?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Read the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active or inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372 active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Inspect the fuel delivery line.

Guided Step 2A - Check the Stage 2 fuel filter intake line.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the Stage 2 fuel filter intake line for kinks or damage.

Kinks or damage found?
YES NO

Repair

Replace the Stage 2 fuel filter intake line. Refer to Procedure 006-024 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the fuel delivery pressure sensor.

Guided Step 3A - Verify fuel delivery pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel delivery pressure sensor accuracy.

Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor within specification found in Procedure 019-548 in the Associated Procedures Table?
YES NO

Repair

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revision number in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 2544 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the active fault codes. | Fault Code 2544 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2544 active or inactive counts?
YES NO

Repair

The fault code indicating high internal ECM temperature has been detected. Check the low temperature coolant system for malfunctioning components.

This fault code could be caused by operation in a hot ambient environment. Inspect the original equipment manufacturer or customer engien ventilation devices for proper operation. Check air flow over the engine is not blocked or restricted.

Repair any damaged components. Remove any debris or air restriction.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Sep-2014


FAULT CODE 2653 - Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K1119 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K1119 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature bank 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate troubleshooting fault code tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature bank 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

  • Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

  • Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Sep-2014


FAULT CODE 2654 - Engine Exhaust Gas Temperature - Bank 2 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K1119 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K1119 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature bank 2 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 2 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 2 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 2 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature bank 2 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Sep-2014


FAULT CODE 2657 - Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K1119 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K1119 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature bank 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature bank 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Sep-2014


FAULT CODE 2658 - Engine Exhaust Gas Temperature - Bank 1 - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Air Leaks, Air Intake and Exhaust Systems | Refer to Procedure 010-024 | QSK95 CM2350 K111 | 4358519
Air Intake Restriction | Refer to Procedure 010-031 | QSK95 CM2350 K1119 | 4358519
Turbocharger | Refer to Procedure 010-033 | QSK95 CM2350 K111 | 4358519
Barometric Air Pressure Sensor | Refer to Procedure 019-004 | QSK95 CM2350 K1119 | 4358519
Exhaust Temperature Sensor | Refer to Procedure 019-013 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for related fault codes. | High intake manifold temperature fault codes active or inactive counts?
 | STEP 1B. Check for related fault codes. | Fault Code 731 active?
 | STEP 1C. Verify the exhaust gas temperature bank 1 sensor accuracy. | Exhaust gas temperature reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
STEP 2. | Check the air handling system. |
 | STEP 2A. Check the barometric pressure sensor. | Barometric pressure sensor reading within specifications found in Procedure 019-004?
 | STEP 2B. Check air intake restriction. | Air intake restriction within specifications found in Procedure 010-031?
 | STEP 2C. Inspect the turbochargers. | Fins damaged or missing?
 | STEP 2D. Check for air handling leaks. | Intake air pressure or exhaust manifold leaks?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Read the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

High intake manifold temperature fault codes active or inactive counts?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 731 active?
YES | NO
No Repair | No Repair

Fault Code 731 troubleshooting tree

Go to 1C

Guided Step 1C - Verify the exhaust gas temperature bank 1 sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Verify the exhaust gas temperature bank 1 sensor accuracy using an infrared thermometer.

  • Start the engine.
  • Connect INSITE™ electronic service tool.
  • Use an infrared thermometer to measure and record the surface temperature at the exhaust port side of the cylinder head.
  • Compare the infrared thermometer temperature measurement with the exhaust gas temperature bank 1 sensor reading on the INSITE™ electronic service tool data monitor/logger screen.
  • The exhaust gas temperature reading in INSITE™ electronic service tool should be within 15 percent of the infrared thermometer reading.

Exhaust gas temperature sensor reading in INSITE™ electronic service tool within 15 percent of the infrared thermometer measurement?
YES NO
No Repair

Repair

A damaged exhaust gas temperature bank 1 sensor has been detected.

Replace the exhaust gas temperature sensor. Refer to Procedure 019-013 in the Associated Procedures Table.

Go to 2A

Go to 3A

Guided Step 2 - Check the air handling system.

Guided Step 2A - Check the barometric pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the barometric pressure sensor rationality.

Refer to Procedure 019-004 in the Associated Procedures Table.

Barometric pressure sensor reading within specifications found in Procedure 019-004?
YES NO
No Repair

Repair

Replace the barometric pressure sensor. Refer to Procedure 019-004 in the Associated Procedures Table.

Go to 2B

Go to 3A

Guided Step 2B - Check air intake restriction.

Conditions

  • Turn keyswitch ON.

Action

Check air intake restriction.

Refer to Procedure 010-031 in the Associated Procedures Table.

Air intake restriction within specifications found in Procedure 010-031?
YES NO
No Repair

Repair

Replace the air filter or repair any damaged, collapsed, or restricted intake piping. See equipment manufacturer service information.

Go to 2C

Go to 3A

Guided Step 2C - Inspect the turbochargers.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the turbocharger compressor and turbine wheels for the following:

  • Bent, damaged, or missing fins.

Refer to Procedure 010-033 in the Associated Procedures Table.

Fins damaged or missing?
YES NO

Repair

Repair or replace the turbocharger. Refer to Procedure 010-033 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2D

Guided Step 2D - Check for air handling leaks.

Conditions

  • Turn keyswitch OFF.

Action

Check for intake air pressure leaks after the turbocharger or exhaust leaks before the turbocharger.

Refer to Procedure 010-024 in the Associated Procedures Table.

Intake air pressure or exhaust manifold leaks?
YES NO

Repair

Replace any malfunctioning seals or damaged components. See the appropriate procedures in Sections 10 and 11 of the service manual.

No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 3379 - Engine ECU Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Cooling System - Overview | Refer to Procedure 008-999 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check the fault codes. | Fault Code 3379 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3379 active or inactive counts?
YES NO

Repair

This fault code indicates high internal ECM temperature has been detected. Check the low temperature coolant system for malfunctioning components.

  • Refer to Procedure 008-999 in the Associated Procedures Table.

This fault code could be caused by operation in a hot ambient environment. Inspect original equipment manufacturer or customer engine ventilation devices for proper operation. Check that proper air flow over the engine is not blocked or restricted.

Repair any damaged components. Remove any debris or air restriction.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 02-Aug-2016


FAULT CODE 3741 - Injector Metering Rail 1 Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K111 | 4358519
Injector Supply Lines (High-Pressure) | Refer to Procedure 006-051 | QSK95 CM2350 K111 | 4358519
Rail Fuel Pressure Sensor | Refer to Procedure 019-115 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 2215, 2261, 2262, 2343, 2372, 3727, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?
STEP 2. | Check the high-pressure fuel system. |
 | STEP 2A. Check for external fuel leaks. | High-pressure fuel line leaks or damage?
 | STEP 2B. Check the fuel rail pressure sensor. | Sensor reading drops out or is erratic?
 | STEP 2C. Check the fuel rail pressure sensor. | Fuel rail pressure sensor meets specifications found in Procedure 019-115?
STEP 3. | Check the fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2215, 2261, 2262, 2343, 2372, 3727, 4615, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active or inactive counts?

YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the high-pressure fuel system.

Guided Step 2A - Check for external fuel leaks.

Conditions

  • Operate engine.

Action

Check the high-pressure fuel system for fuel leaking at the outer wall fuel drain hose.

High-pressure fuel line leaks or damage?
YES NO

Repair

Replace any damaged high-pressure fuel supply lines. Refer to Procedure 006-051 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel rail pressure sensor.

Conditions

  • Perform a key cycle.
  • Start the engine and let it idle.

Action

Check the fuel rail pressure sensor for an erratic reading.

  • Monitor the fuel rail pressure sensor reading in INSITE™ electronic service tool.
  • Look for a rail pressure reading that changes sharply or drops out intermittently.

Sensor reading drops out or is erratic?
YES NO

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check the fuel rail pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel rail pressure sensor accuracy.

Refer to Procedure 019-115 in the Associated Procedures Table.

Fuel rail pressure sensor meets specifications found in Procedure 019-115?
YES NO
No Repair

Repair

Replace the fuel rail pressure sensor. Refer to Procedure 019-115 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel return drain line restriction.

Guided Step 3A - Check the drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction is within the specifications outlined in Procedure 006-012?
YES NO
No Repair

Repair

Repair the source of the high fuel drain line restriction. Refer to Procedure 006-012 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Aug-2016


FAULT CODE 4615 - Fuel Pump Delivery Pressure - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Drain Line Restriction | Refer to Procedure 006-012 | QSK95 CM2350 K111 | 4358519
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Fuel Delivery Pressure Sensor | Refer to Procedure 019-548 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
STEP 2. | Check the fuel supply system. |
 | STEP 2A. Check the fuel lines. | Kinked or damaged fuel lines?
 | STEP 2B. Check the fuel delivery pressure sensor. | Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
STEP 3. | Check for fuel return drain line restriction. |
 | STEP 3A. Check drain line restriction. | Fuel drain line restriction within the specifications outlines in Procedure 006-012?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 546, 547, 2343, 2372, 4885, 4886, 4887, 4892, 4893, 4894, 4927, 4933, 4936, 4937, or 4961 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel supply system.

Guided Step 2A - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the low-pressure fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or see equipment manufacturer service information.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel delivery pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.
  • Install a pressure gauge onto the Compuchek™ fitting at the outlet of the Stage 2 fuel filter head.

Action

Check the fuel delivery pressure sensor accuracy.

Refer to Procedure 019-548 in the Associated Procedures Table.

Fuel delivery pressure sensor meets specifications found in Procedure 019-548?
YES NO
No Repair

Repair

Replace the fuel delivery pressure sensor. Refer to Procedure 019-548 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check for fuel return drain line restriction.

Guided Step 3A - Check drain line restriction.

Conditions

  • Turn keyswitch ON.
  • Operate the engine.

Action

Check for excessive fuel drain line restriction.

  • Refer to Procedure 006-012 in the Associated Procedures Table.

Fuel drain line restriction within the specifications outlined in Procedure 006-012?
YES | NO
No Repair | No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 28-Aug-2014


FAULT CODE 4696 - Crankcase Pressure 2 Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Control Module Calibration Code | Refer to Procedure 019-032 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility or damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replace the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 4696 active?
STEP 2. | Check the crankcase pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4697 active and Fault Code 4696 inactive?
 | STEP 2C. Check the sensor supply voltage and return circuit. | 4.75 VDC to 5.25 VDC?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4696 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for an inactive fault code. | Fault Code 4696 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure 2 sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the harness and crankcase pressure 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 active and Fault Code 4696 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the crankcase pressure 2 sensor SUPPLY pin and the crankcase pressure 2 sensor RETURN pin at the crankcase pressure 2 sensor connector of the engine harness.

Use a wiring diagram for connector pin identification and the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

4.75 VDC to 5.25 VDC?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the crankcase pressure 2 sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness from the ECM.

Action

Inspect the OEM harness connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Repair or replace the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.
 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector crankcase pressure 2 sensor RETURN pin and the engine harness crankcase pressure 2 sensor connector RETURN pin.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the crankcase pressure 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Use a wiring diagram for connector pin identification and the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 inactive?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in the Associated Procedures Table.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 4697 - Crankcase Pressure 2 Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To avoid damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for sensor supply fault codes. | Sensor supply fault codes active?
 | STEP 1B. Check for an inactive fault code. | Fault Code 4697 inactive?
STEP 2. | Check the crankcase pressure 2 sensor and circuit. |
 | STEP 2A. Inspect the crankcase pressure 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the sensor supply voltage and return circuit. | 4.75 to 5.25-VDC?
 | STEP 2C. Check the circuit response. | Fault Code 4696 active and Fault Code 4697 inactive?
 | STEP 2D. Check the fault codes and verify sensor condition. | Fault Code 4697 active?
STEP 3. | Check the ECM and harness. |
 | STEP 3A. Inspect the ECM and OEM harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3C. Check for an open circuit in the harness. | Less than 10 ohms?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for a pin-to-ground short circuit | Greater than 100k ohms?
 | STEP 3F. Check for an inactive fault code. | Fault Code 4697 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for sensor supply fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for sensor supply fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Sensor supply fault codes active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 1B

Guided Step 1B - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the crankcase pressure 2 sensor and circuit.

Guided Step 2A - Inspect the crankcase pressure 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the sensor supply voltage and return circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.

Action

Check the supply voltage and return circuit.

  • Measure the voltage between the crankcase pressure 2 SUPPLY pin and the crankcase pressure 2 RETURN pin at the crankcase pressure 2 sensor connector of the engine harness.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-360 in Section 19.

4.75 to 5.25-VDC?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Place a jumper wire between the crankcase pressure 2 sensor SUPPLY pin and the crankcase pressure 2 sensor SIGNAL pin at the crankcase pressure 2 sensor connector of the engine harness.

Use circuit diagram or wiring diagram for connector pin identification.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 active and Fault Code 4697 inactive?
YES | NO
No Repair | No Repair

Go to 2D

Go to 3A

Guided Step 2D - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the crankcase pressure 2 sensor from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 active?
YES NO

Repair

A damaged sensor has been detected.

Replace the crankcase pressure 2 sensor.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector crankcase pressure 2 sensor SUPPLY pin and the engine harness crankcase pressure 2 sensor connector SUPPLY pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open SUPPLY circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for an open circuit in the harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector crankcase pressure 2 sensor SIGNAL pin and the engine harness crankcase pressure 2 sensor connector SIGNAL pin.

Reference the circuit or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open signal circuit has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the open circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the crankcase pressure 2 sensor SIGNAL pin in the OEM harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for a pin-to-ground short circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the crankcase pressure 2 sensor SIGNAL pin in the OEM harness ECM connector and ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit on the SIGNAL wire has been detected in the harness.

Troubleshoot each harness connected in series to determine which contains the short circuit to ground.

Repair or replace the OEM harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3F

Go to 4A

Guided Step 3F - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 1 minute.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4697 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID & Data Plate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 4698 - Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather Filter Element | Refer to Procedure 001-125 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure sensor reading within specification found in Procedure 019-445?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Pressure sensor reading within specification found in Procedure 019-445?
YES NO

Repair

Replace the breather filter element. Refer to Procedure 001-125 in the Associated Procedures Table.

Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4699 - Crankcase Pressure 2 - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather Filter Element | Refer to Procedure 001-125 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure sensor reading within specification found in Procedure 019-445?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Pressure sensor reading within specification found in Procedure 019-445?
YES NO

Repair

Replace the breather filter element. Refer to Procedure 001-125 in the Associated Procedures Table.

Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4711 - Crankcase Pressure 2 - Data Valid But Bleow Normal Operating Range - Least Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Crankcase Breather System - With Filter Assembly | Refer to Procedure 001-122 | QSK95 CM2350 K111 | 4358519
Crankcase Breather Filter Element | Refer to Procedure 001-125 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the sensor accuracy. |
 | STEP 1A. Verify pressure sensor accuracy. | Pressure sensor reading within specification found in Procedure 019-445?
 | STEP 1B. Check the breather tube. | Damaged or missing breather tube or hose?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the sensor accuracy.

Guided Step 1A - Verify pressure sensor accuracy.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

  • Refer to Procedure 019-445 in the Associated Procedures Table.

Pressure sensor reading within specification found in Procedure 019-445?
YES NO
No Repair

Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 1B

Go to 2A

Guided Step 1B - Check the breather tube.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the breather tube and hoses for the following:

  • Damaged or missing breather tube
  • Damaged or missing breather tube hoses
  • Missing or loose breather tube hose clamps.

Refer to Procedure 001-122 in the Associated Procedures Table.

Damaged or missing breather tube or hose?
YES NO

Repair

Replace the damaged components. Refer to Procedure 001-122 in the Associated Procedures Table.

Repair

A missing or damaged breather filter element has been detected. Replace the breather filter element. Refer to Procedure 001-125 in the Associated Procedures Table.

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4885 - Engine Fuel Supply Pump - Mechanical System Not Responding or Out of Adjustment

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check for active fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4886, 4887 or 4892 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check for active fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn the keyswitch ON.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the active fault codes.

Fault Code 4886, 4887 or 4892 active?
YES NO
No Repair

Repair

A malfunctioning engine fuel supply pump has been detected.

Replace the engine fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Aug-2014


FAULT CODE 4887 - Engine Fuel Supply Pump Supply Voltage - Data Valid But Below Normal Operating Range - Most Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4887 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn the keyswitch ON.
  • Connect INSITE™ electroinc service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4887 active?
YES NO

Repair

Low voltage has been detected at the engine fuel supply pump motor.

Check for a tripped or malfunctioning circuit breaker. Inspect the original equipment manufacturer (OEM) harness for damage and dirty, corroded, or loose connection between the engine fuel supply pump motor and the voltage source.

Repair or replace any damaged or malfunctioning components. See equipment manufacturer service information.

Repair

Intermittent low voltage has been detected at the engine fuel supply pump motor.

Troubleshoot the OEM harness for an intermittent voltage malfunction.

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 05-Aug-2014


FAULT CODE 4888 - Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236. | QSK95 CM2350 K111 | 4358519
Engine Fuel Supply Pump | Refer to Procedure 005-241. | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 2) | Refer to Procedure 006-076. | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and low-pressure fuel system. |
 | STEP 1A. Check the fault codes. | Fault Code 2372, 4886, or 4887 active or inactive counts?
 | STEP 1B. Check the fault codes. | Active or inactive counts of high fuel delivery temperature fault codes?
 | STEP 1C. Check the stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 1D. Check the fault codes. | Fault Code 4888 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and low pressure fuel system.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372, 4886, or 4887 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of high fuel delivery temperature fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236?
YES | NO
No Repair | No Repair

Go to 1C

Go to 2A

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4888 active or inactive counts?
YES NO

Repair

  • Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.
 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2014


FAULT CODE 4889 - Engine Fuel Supply Pump Temperature - Data Valid But Above Normal Operating Range - Most Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236. | QSK95 CM2350 K111 | 4358519
Engine Fuel Supply Pump | Refer to Procedure 005-241. | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 2) | Refer to Procedure 006-076. | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes and low pressure fuel system. |
 | STEP 1A. Check the fault codes. | Fault Code 2372, 4886, or 4887 active or inactive counts?
 | STEP 1B. Check the fault codes. | Active or inactive counts of high fuel delivery temperature fault codes?
 | STEP 1C. Check the Stage 2 fuel filter restriction. | Stage 2 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 1D. Check the fault codes. | Fault Code 4888 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes and low pressure fuel system.

Guided Step 1A - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 2372, 4886, or 4887 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1B

Guided Step 1B - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Active or inactive counts of high fuel delivery temperature fault codes?
YES | NO
No Repair | No Repair

Go to the appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check the Stage 2 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 2 fuel filter restriction.

  • Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 2 fuel filter restriction within the specifications found in Procedure 005-236?
YES NO
No Repair

Repair

Replace the Stage 2 fuel filters. Refer to Procedure 006-076 in the Associated Procedures Table.

Go to 1D

Go to 2A

Guided Step 1D - Check the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4889 active or inactive counts?
YES NO

Repair

  • Replace the fuel supply pump. Refer to Procedure 005-241 in the Associated Procedures Table.
 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check engine control module (ECM) calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Sep-2014


FAULT CODE 4891 - Engine Fuel Supply Pump - Root Cause Not Known

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4891 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4892, 4929, or 4931 active?
STEP 2. | Check the engine fuel supply pump circuit. |
 | STEP 2A. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the engine fuel supply pump harness. | Tampering or intermittent malfunctions detected?
STEP 3. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 3A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 3B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4891 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892, 4929, or 4931 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 2A

Guided Step 2 - Check the engine fuel supply pump circuit.

Guided Step 2A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged OEM harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Check the engine fuel supply pump harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine fuel supply pump SUPPLY and RETURN wires for the following:

  • Tampering or add on wires
  • Wiggle the engine harness and check for counts of Fault Code 4892, 4929, or 4931, indicating an intermittent supply or data link 3 connection.

Tampering or intermittent malfunctions detected?
YES NO

Repair

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 12-Aug-2014


FAULT CODE 4892 - Engine Fuel Supply Pump - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4892 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3331 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4929 or 4931 active?
 | STEP 1D. Check for active fault codes. | Fault Code 4961 also active?
STEP 2. | Check the engine fuel supply pump circuit. |
 | STEP 2A. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the voltage to the engine fuel supply pump. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 54 to 66 ohms?
 | STEP 2D. Check for an open circuit in the engine fuel supply pump battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the power supply circuit. |
 | STEP 3A. Inspect the fuel metering valve and engine fuel supply pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 3D. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the data link 3 circuit. |
 | STEP 4A. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 4B. Check the J1939 terminating resistance. | 54 to 66 ohms?
 | STEP 4C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the J1939 terminating resistance | 54 to 66 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 or 4931 active?
YES | NO
No Repair | No Repair

Appropriate troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4961 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the engine fuel supply pump circuit.

Guided Step 2A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the engine fuel supply pump.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the engine fuel supply pump.

  • Measure the voltage between the engine fuel supply pump supply circuit and the engine fuel supply pump return circuit at the fuel supply pump engine harness connector.

Note: Check the voltage at keyswitch ON and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the engine fuel supply pump engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO

Repair

Replace the engine fuel supply pump.

Refer to Procedure 005-241 in the Associated Procedures Table.

Repair

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the engine fuel supply pump and the data link 3 backbone connection.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the engine fuel supply pump battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the engine fuel supply pump battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

An open circuit has been detected in the engine fuel supply pump battery voltage supply circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the power supply circuit.

Guided Step 3A - Inspect the fuel metering valve and engine fuel supply pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and the fuel metering valve connector battery voltage RETURN pin.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and the engine fuel supply pump connector battery voltage RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and engine block ground.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and engine block ground.

Refer to the wiring diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damage pins?
YES NO

Repair

A damage connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin and RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage supply circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace the ECM. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the data link 3 circuit.

Guided Step 4A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and engine fuel supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel supply pump or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the engine fuel supply pump engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO

Repair

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the ECM and the data link 3 backbone connection.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the ECM engine harness connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO
No Repair

Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 3 backbone connection.

Remove excess terminating resistors. Replace any damaged or missing terminating resistors.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Aug-2016


FAULT CODE 4893 - Engine Fuel Filter (Suction Side) Differential Pressure - Data Valid But Above Normal Operating Range - Moderately Severe Level

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel System Diagnostics | Refer to Procedure 005-236 | QSK95 CM2350 K111 | 4358519
Air in Fuel | Refer to Procedure 006-003 | QSK95 CM2350 K111 | 4358519
Fuel Supply Lines | Refer to Procedure 006-024 | QSK95 CM2350 K111 | 4358519
Fuel Filter (Stage 1) | Refer to Procedure 006-075 | QSK95 CM2350 K111 | 4358519
Fuel Inlet Pressure Measurement | Refer to Procedure 006-104 | QSK95 CM2350 K111 | 4358519
Fuel Supply Pump Intake Pressure Sensor | Refer to Procedure 019-549 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Code 4893 active or inactive counts?
STEP 2. | Check the low-pressure fuel system. |
 | STEP 2A. Check for adequate fuel supply. | Equipment has adequate fuel supply?
 | STEP 2B. Check the fuel lines. | Kinked or damaged fuel lines?
STEP 3. | Check the low-pressure fuel system operation. |
 | STEP 3A. Check fuel inlet pressure. | Fuel inlet pressure within the specifications found in Procedure 006-104?
 | STEP 3B. Check Stage 1 fuel filter restriction. | Stage 1 fuel filter restriction within the specifications found in Procedure 005-236?
 | STEP 3C. Check the fuel supply pump intake pressure sensor. | Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
 | STEP 3D. Check for air in the fuel system. | Air in the fuel?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code cleared?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4893 active or inactive counts?
YES | NO
No Repair | No Repair

Go to 2A

Go to 4A

Guided Step 2 - Check the low-pressure fuel system.

Guided Step 2A - Check for adequate fuel supply.

Conditions

  • Turn keyswitch ON.
  • Turn engine OFF.

Action

Check for adequate fuel supply.

  • Do not rely on the vehicle's fuel gauge.
  • Verify there is fuel in the tank.

Equipment has adequate fuel supply?
YES NO
No Repair

Repair

Add fuel to the fuel tank or perform repairs to the vehicle's tank or fuel gauge.

Go to 2B

Go to 4A

Guided Step 2B - Check the fuel lines.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the suction fuel lines for kinks or damage.

Kinked or damaged fuel lines?
YES NO

Repair

Replace the damaged fuel line(s). Refer to Procedure 006-024 in the Associated Procedures Table or equipment manufacturer service information

No Repair

Go to 4A

Go to 3A

Guided Step 3 - Check the low-pressure fuel system operation.

Guided Step 3A - Check fuel inlet pressure.

Conditions

  • Turn keyswitch ON.

Action

Check the fuel inlet pressure.

  • Refer to Procedure 006-104 in the Associated Procedures Table.

Fuel inlet pressure within the specifications found in Procedure 006-104?
YES | NO
No Repair | No Repair

Go to 3C

Go to 3B

Guided Step 3B - Check Stage 1 fuel filter restriction.

Conditions

  • Turn keyswitch ON.

Action

Check the Stage 1 fuel filter restriction.

Refer to Procedure 005-236 in the Associated Procedures Table.

Stage 1 fuel filter restriction within the specifications found in Procedure 005-236?
YES NO

Repair

High restriction in the fuel supply lines or fuel supply tank has been detected. Continue troubleshooting to determine the cause of the high restriction.

Replace any damaged or malfunctioning components. See equipment manufacturer service information.

Repair

Replace the Stage 1 fuel filters. Refer to Procedure 006-075 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3C - Check the fuel supply pump intake pressure sensor.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the fuel supply pump intake pressure sensor accuracy.

Refer to Procedure 019-549 in the Associated Procedures Table.

Fuel supply pump intake pressure sensor meets specifications found in Procedure 019-549?
YES NO
No Repair

Repair

Replace the fuel supply pump intake pressure sensor. Refer to Procedure 019-549 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for air in the fuel system.

Conditions

  • Turn keyswitch ON.

Action

Check for air in the fuel.

Refer to Procedure 006-003 in the Associated Procedures Table.

Air in the fuel?
YES NO

Repair

Investigate the cause of air in fuel. Check for loose Stage 1 filters, loose fuel line fittings, and fuel line punctures. Repair or replace the malfunctioning component(s).

No Repair

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 24-Mar-2016


FAULT CODE 4927 - Engine Diesel Fuel Metering Valve - Bad Intelligent Device or Component

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 4928, 4929, 4931, or 4961 active?
 | STEP 1B. Check for active fault codes. | Fault Code 4927 active?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 4928, 4929, 4931, or 4961 active?
YES | NO
No Repair | No Repair

Appropriate Fault Code Troubleshooting Tree

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4927 active?
YES NO

Repair

An internal error has been detected in the fuel metering valve.

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 13-May-2014


FAULT CODE 4928 - Engine Diesel Fuel Metering Valve Power Supply - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4982 inactive?
 | STEP 1B. Check for related fault codes. | Fault Code 441 or 442 active?
 | STEP 1C. Check for related fault codes. | Fault Code 4929 or 4931 active?
STEP 2. | Check the fuel metering valve and circuit. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the fuel metering valve battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 2D. Check for an inactive fault code. | Fault Code 4928 inactive?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage.
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4928 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 1B

Guided Step 1B - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 441 or 442 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for related fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 or 4931 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check the fuel metering valve and circuit.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the fuel metering valve battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and the fuel metering valve connector battery voltage RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2D

Go to 2C

Guided Step 2C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit or high resistance has been detected in the fuel metering valve battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 3A

Guided Step 2D - Check for an inactive fault code.

Conditions

  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4928 inactive?
YES NO

Repair

An intermittent malfunction of the battery voltage supply circuit has been detected in the fuel metering valve connector or engine harness.

Use the following procedure for intermittent fault code troubleshooting. Refer to Procedure 019-362 in Section 19.

No Repair

Go to 4A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the batter supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve battery voltage SUPPLY pin and RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open or high resistance has been detected in the fuel metering valve battery voltage supply circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4929 – Engine Diesel Fuel Metering Valve Power Supply - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4929 inactive?
STEP 2. | Check the ECM. |
 | STEP 2A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the battery supply voltage. | Voltage within 1-VDC of battery voltage?
STEP 3. | Check the engine harness. |
 | STEP 3A. Inspect the engine fuel valve and engine fuel supply pump connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1-VDC of battery voltage?
 | STEP 3C. Check for an open battery voltage supply circuit. | Voltage within 1-VDC of battery voltage?
 | STEP 3D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the ECM.

Guided Step 2A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the engine fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin and RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO
No Repair

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the engine harness.

Guided Step 3A - Inspect the fuel metering valve and engine fuel supply pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Diconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the device or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage at each component.

  • Measure the voltage between the engine fuel metering valve connector battery voltage SUPPLY pin and the engine fuel metering valve connector battery voltage RETURN pin.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and the engine fuel supply pump connector battery voltage RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1-VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 3D

Go to 3C

Guided Step 3C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the engine fuel metering valve connector battery voltage SUPPLY pin and engine block ground.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1-VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the engine fuel metering valve and/or engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

An open circuit has been detected in the engine fuel metering valve and/or engine fuel supply pump battery voltage supply circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 3D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Disconnect the engine fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin in the engine harness ECM connector and all other pins in the connector.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit on the battery voltage supply circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 4931 - Engine Diesel Fuel Metering Valve Power Supply - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Fuel Supply Pump | Refer to Procedure 005-241 | QSK95 CM2350 K111 | 4358519
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 4931 inactive?
STEP 2. | Check the fuel system data link devices and circuits. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 4931 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 4931 active?
 | STEP 2D. Inspect the engine fuel supply pump and connector pins. | Dirty or damaged pins?
 | STEP 2E. Check the circuit response. | Fault Code 4931 inactive?
 | STEP 2F. Check the fault codes and verify sensor condition. | Fault Code 4931 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check the ECM response. | Fault Code 4929 active and Fault Code 4931 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel system data link devices and circuits.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and actuator connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES NO

Repair

A damaged actuator has been detected.

Replace the fuel metering valve.

  • Refer to Procedure 005-242 in the Associated Procedures Table.

Repair

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 2D - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and supply pump connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the pump or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 2E

Guided Step 2E - Check the circuit response.

Conditions

  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 inactive?
YES | NO
No Repair | No Repair

Go to 2F

Go to 3A

Guided Step 2F - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fuel supply pump to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4931 active?
YES NO

Repair

A damaged fuel supply pump has been detected.

Replace the engine fuel supply pump.

  • Refer to Procedure 005-241 in the Associated Procedures Table.

Repair

The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques.Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check the ECM response.

Conditions

  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch OFF.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate ECM response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 active and Fault Code 4931 inactive?
YES NO

Repair

A pin-to-ground or pin-to-pin short circuit on the supply circuit has been detected in the engine harness.

Repair or replace the damaged section of the engine harness.

  • Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 17-Sep-2014


FAULT CODE 4932 - Engine Diesel Fuel Metering Valve Temperature - Data Valid But Above Normal Operating Range - Least Severe Level

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault code 261, 266, 4927 or 4933 active?
STEP 2. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault code 261, 266, 4927 or 4933 active?
YES NO

Repair

The fuel metering valve internal temperature has exceeded the maximum limit. No repair is necessary. This fault code is for information only.

No Repair

Appropriate fault code troubleshooting tree

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 22-May-2014


FAULT CODE 4933 - Engine Diesel Fuel Metering Valve Position - Received Network Data in Error

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes. | Fault Codes 4928, 4929, 4931, or 4961 active or inactive counts?
 | STEP 1B. Check for active fault codes. | Fault Code 4933 active?
 | STEP 1C. Check for inactive fault codes. | Fault Code 4933 multiple inactive counts related to other fuel system pressure fault codes?
STEP 2. | Check ECM calibration and clear fault codes. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Codes 4928, 4929, 4931, or 4961 active or inactive counts?
YES | NO
No Repair | No Repair

Go to the appropriate troubleshooting tree.

Go to 1B

Guided Step 1B - Check for active fault codes.

Conditions

  • Operate the engine at idle.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4933 active?
YES NO

Repair

A malfunctioning fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 1C

Guided Step 1C - Check for inactive fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for inactive fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.
  • If multiple inactive counts of Fault Code 4933 are present and are associated with other fuel system pressure fault codes, an intermittently malfunctioning fuel metering valve has been detected.

Fault Code 4933 multiple inactive counts related to other fuel system pressure fault codes?
YES NO

Repair

A malfunctioning fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 23-Jun-2014


FAULT CODE 4934 - Engine Diesel Fuel Metering Valve - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4934 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2D. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2E. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 4858 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4934 inactive?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin at the ECM connector of the engine harness and the fuel metering valve control SIGNAL pin at the fuel metering valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.
  • Measure the resistance between the fuel metering valve control RETURN pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector fuel metering valve control RETURN pin and the engine harness fuel metering valve connector control RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control SIGNAL circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Perform a keycycle.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected in the harness. Refer to Procedure 019-362 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4935 - Engine Diesel Fuel Metering Valve - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4935 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2D. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
 | STEP 3B. Check for an inactive fault code. | Fault Code 4935 inactive?
STEP 4. | Check engine control module (ECM) calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4935 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 4A

Guided Step 2D - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control signal circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 3B

Go to 4A

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Perform a keycycle.
  • Start the engine.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4935 inactive?
YES NO

Repair

An intermittent circuit malfunction has been detected in the harness. Refer to Procedure 019-362 in Section 19.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4946 - Engine Crank Without Prelubrication - Condition Exists

Associated Procedures

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Read the fault codes. | Fault Code 4946 active or inactive counts?
STEP 2. | Check engine control module (ECM) calibration update is available. |
 | STEP 2A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 2B. Disable the fault code. | Fault code inactive.

Guided Step 1 - Check the fault codes.

Guided Step 1A - Read the fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4946 active or inactive counts?
YES NO

Repair

This is an information only fault code that will become active if the engine start override switch is used and the engine was allowed to crank before the normal prelubrication cycle completed.

No troubleshooting is necessary for this fault code.

 No Repair

Go to 2A

Go to 2A

Guided Step 2 - Check ECM calibration and clear fault codes.

Guided Step 2A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 2B

Go to 2B

Guided Step 2B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Aug-2014


FAULT CODE 4959 - Engine Diesel Fuel Metering Valve - Condition Exists

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an active fault code. | Fault Code 4958 active?
STEP 2. | Check the fuel metering valve harness. |
 | STEP 2A. Inspect the engine harness. | Altered or tampered wiring detected?
 | STEP 2B. Inspect the engine harness and fuel metering valve connector pins. | Dirty or damaged pins?
 | STEP 2C. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 2D. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 2E. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2F. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 2G. Check for an open circuit in the engine harness. | Less than 10 ohms?
STEP 3. | Check the fuel metering valve. |
 | STEP 3A. Check the fuel metering valve resistance. | Between 9k ohms and 110k ohms?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an active fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an active fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4958 active?
YES | NO
No Repair | No Repair

Go to 2A

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Guided Step 2 - Check the fuel metering valve harness.

Guided Step 2A - Inspect the engine harness.

Conditions

  • Turn keyswitch OFF.

Action

Inspect the engine harness from the ECM to the fuel metering valve for the following:

  • Add on wiring to the fuel metering valve control SIGNAL or RETURN wires.
  • Wiring to the fuel metering valve that has been altered or other signs of tampering.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Altered or tampered wiring detected?
YES NO

Repair

Repair or replace the damaged harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Inspect the engine harness and fuel metering valve connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the fuel metering valve connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2C

Guided Step 2C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM connector or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2D

Guided Step 2D - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin at the ECM connector of the engine harness and the fuel metering valve control SIGNAL pin at the fuel metering valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2E

Go to 4A

Guided Step 2E - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-pin short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2F

Go to 4A

Guided Step 2F - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for a pin-to-ground short circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL pin in the engine harness ECM connector and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2G

Go to 4A

Guided Step 2G - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine harness ECM connector fuel metering valve control RETURN pin and the engine harness fuel metering valve connector control RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

An open return circuit has been detected in the engine harness.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3A

Go to 4A

Guided Step 3 - Check the fuel metering valve.

Guided Step 3A - Check the fuel metering valve resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Check for correct resistance on the fuel metering valve control signal circuit.

  • Measure the resistance between the fuel metering valve control SIGNAL and RETURN pins at the fuel metering valve.

Between 9k ohms and 110k ohms?
YES NO
No Repair

Repair

A damaged fuel metering valve has been detected.

Replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 4961 - Engine Diesel Fuel Metering Valve - Abnormal Update Rate

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Control Module | Refer to Procedure 019-031 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for active fault codes | Fault Code 4961 active?
 | STEP 1B. Check for active fault codes. | Fault Code 3331 active?
 | STEP 1C. Check for active fault codes. | Fault Code 4929 or 4931 active?
 | STEP 1D. Check for active fault codes. | Fault Code 4892 also active?
STEP 2. | Check the fuel metering valve circuit. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Damaged or dirty pins?
 | STEP 2B. Check the voltage to the fuel metering valve. | Voltage within 1 VDC of battery voltage?
 | STEP 2C. Check the J1939 terminating resistance. | 54 to 66 ohms?
 | STEP 2D. Check for an open circuit in the fuel metering valve battery voltage supply. | Voltage within 1 VDC of battery voltage?
STEP 3. | Check the power supply circuit. |
 | STEP 3A. Inspect the fuel metering valve and engine fuel supply pump connector pins. | Damaged or dirty pins?
 | STEP 3B. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
 | STEP 3C. Check for an open battery voltage supply circuit. | Voltage within 1 VDC of battery voltage?
 | STEP 3D. Inspect the engine control module (ECM) and engine harness connector pins. | Dirty or damaged pins?
 | STEP 3E. Check the battery supply voltage. | Voltage within 1 VDC of battery voltage?
STEP 4. | Check the engine harness. |
 | STEP 4A. Inspect the fuel metering valve and connector pins. | Damaged or dirty pins?
 | STEP 4B. Check the J1939 terminating resistance. | 54 to 66 ohms?
 | STEP 4C. Inspect the ECM and engine harness connector pins. | Dirty or damaged pins?
 | STEP 4D. Check the J1939 terminating resistance | 54 to 66 ohms?
STEP 5. | Check ECM calibration and clear fault codes. |
 | STEP 5A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 5B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4961 active?
YES | NO
No Repair | No Repair

Go to 1B

Refer to Procedure 019-362 in Section 19.

Guided Step 1B - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 3331 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1C

Guided Step 1C - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4929 or 4931 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree

Go to 1D

Guided Step 1D - Check for active fault codes.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4892 also active?
YES | NO
No Repair | No Repair

Go to 3A

Go to 2A

Guided Step 2 - Check the fuel metering valve circuit.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel metering valve or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 2B

Guided Step 2B - Check the voltage to the fuel metering valve.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check the power supply and return circuit to the fuel metering valve.

  • Measure the voltage between the fuel metering valve battery voltage supply circuit and the fuel metering valve return circuit at the fuel valve engine harness connector.

Note: Check the voltage at keyswitch ON and with the engine at idle.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general multimeter usage techniques. Refer to Procedure 019-359 in Section 19.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 2C

Go to 2D

Guided Step 2C - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Measure the terminating resistance of the Society of Automotive Engineers (SAE) J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the fuel metering valve engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO

Repair

Replace the fuel metering valve.

Refer to Procedure 005-242 in the Associated Procedures Table.

Repair

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the fuel metering valve and the data link 3 backbone connection.

Repair or replace the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 2D - Check for an open circuit in the fuel metering valve battery voltage supply.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit.

  • Measure the voltage from the fuel metering valve battery voltage SUPPLY pin of the engine harness to engine block ground.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the fuel metering valve battery voltage return circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

An open circuit has been detected in the fuel metering valve battery voltage supply circuit.

Repair or replace the damaged section of harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 3 - Check the power supply circuit.

Guided Step 3A - Inspect the fuel metering valve and engine fuel supply pump connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.

Action

Inspect the engine harness and device connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the device or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3B

Guided Step 3B - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check the battery supply voltage at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and the fuel metering valve connector battery voltage RETURN pin.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and the engine fuel supply pump connector battery voltage RETURN pin.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES | NO
No Repair | No Repair

Go to 4A

Go to 3C

Guided Step 3C - Check for an open battery voltage supply circuit.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Disconnect the engine fuel supply pump from the engine harness.
  • Turn keyswitch ON.

Action

Check for an open circuit at each component.

  • Measure the voltage between the fuel metering valve connector battery voltage SUPPLY pin and engine block ground.
  • Measure the voltage between the engine fuel supply pump connector battery voltage SUPPLY pin and engine block ground.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage return circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3D

Guided Step 3D - Inspect the ECM and engine harness connector.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.

Action

Inspec the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 3E

Guided Step 3E - Check the battery supply voltage.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness connector from the ECM.
  • Turn keyswitch ON.

Action

Check the battery supply voltage.

  • Measure the voltage between the fuel metering valve/engine fuel supply pump battery voltage SUPPLY pin and RETURN pin at the ECM.

Refer to the circuit diagram or wiring diagram for connector pin identification.

Voltage within 1 VDC of battery voltage?
YES NO

Repair

An open circuit has been detected in the fuel metering valve and/or engine fuel supply pump battery voltage supply circuit.

Repair or replace the damage section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

Replace the ECM. Refer to Procedure 019-031 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 4 - Check the data link 3 circuit.

Guided Step 4A - Inspect the engine fuel supply pump and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and fuel metering valve connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the fuel valve or harness connector.

Clean the connector and pins.

Repair the damaged engine harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4B

Guided Step 4B - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the fuel metering valve engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO

Repair

An open circuit has been detected on the SAE J1939 data link 3 (+) or (-) wire between the ECM and the data link 3 backbone connection.

Repair or replace the engine harness.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4C

Guided Step 4C - Inspect the ECM and engine harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine harness from the ECM.

Action

Inspect the engine harness and ECM connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connector has been detected in the ECM connector or the engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 5A

Go to 4D

Guided Step 4D - Check the J1939 terminating resistance.

Conditions

  • Turn keyswitch OFF.

Action

Measure the terminating resistance of the SAE J1939 data link 3.

  • Measure the resistance between the SAE J1939 data link 3 (+) wire and the J1939 data link 3 (-) wire at the ECM engine harness connector.

Use the wiring diagram or circuit diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

54 to 66 ohms?
YES NO
No Repair

Repair

Incorrect terminating resistance or an open circuit has been detected on the SAE J1939 data link 3 backbone connection.

Remove excess terminating resistors. Replace any damaged or missing terminating resistors.

Troubleshoot all harnesses connected in series to determine which one contains the open circuit.

Repair or replace the damage section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 5A

Go to 5A

Guided Step 5 - Check ECM calibration and clear fault codes.

Guided Step 5A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 5B

Go to 5B

Guided Step 5B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 16-Aug-2016


FAULT CODE 5178 - Crankcase Pressure 2 - Data Erratic, Intermittent, or Incorrect

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519
Crankcase Pressure Sensor | Refer to Procedure 019-445 | QSK95 CM2350 K111 | 4358519

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for Fault Codes 4696 and 4697. | Fault Code 4696 or 4697 active?
STEP 2. | Check the harness. |
 | STEP 2A. Inspect the crankcase pressure 2 sensor and connector pins. | Dirty or damaged pins?
 | STEP 2B. Inspect the engine control module (ECM) and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 2C. Check for an open circuit in the engine harness. | Less than 5 ohms?
 | STEP 2D. Check the sensor accuracy. | Crankcase pressure 2 sensor within specifications found in Procedure 019-445?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for Fault Codes 4696 and 4697.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for active fault codes.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 4696 or 4697 active?
YES | NO
No Repair | No Repair

Appropriate fault code troubleshooting tree.

Go to 2A

Guided Step 2 - Check the engine harness.

Guided Step 2A - Inspect the crankcase pressure 2 sensor and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Inspect the engine harness and crankcase pressure 2 sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the sensor or engine harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2B

Guided Step 2B - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.

Action

Inspect the OEM harness connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris on or in the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or OEM harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible.

Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 3A

Go to 2C

Guided Step 2C - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM harness connector from the ECM.
  • Disconnect the crankcase pressure 2 sensor from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the OEM harness ECM connector crankcase pressure 2 sensor SIGNAL pin and the engine harness crankcase pressure 2 sensor connector SIGNAL pin.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 5 ohms?
YES NO
No Repair

Repair

High resistance has been detected on the crankcase pressure 2 sensor signal circuit.

Repair or replace the damaged section of the engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 2D

Go to 3A

Guided Step 2D - Check the sensor accuracy.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the crankcase pressure 2 sensor accuracy.

Refer to Procedure 019-445 in the Associated Procedures Table.

Crankcase pressure 2 sensor within specifications found in Procedure 019-445?
YES NO
No Repair

Repair

Replace the crankcase pressure 2 sensor. Refer to Procedure 019-445 in the Associated Procedures Table.

Go to 3A

Go to 3A

Guided Step 3 - Check ECM calibration and clear fault codes.

Guided Step 3A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 3B

Go to 3B

Guided Step 3B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete.

Go to 1A

Last Modified: 18-Sep-2014


FAULT CODE 5862 - Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Above Normal or Shorted to High Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5682 inactive?
STEP 2. | Check the fuel metering valve and circuit. |
 | STEP 2A. Inspect the fuel metering valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5863 active and Fault Code 5862 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5862 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) harness connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an inactive fault code. | Fault Code 5862 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the fuel metering valve and circuit.

Guided Step 2A - Inspect the fuel metering valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the fuel metering valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 active and Fault Code 5862 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the fuel metering valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 active?
YES NO

Repair

A damaged fuel metering valve has been detected.

Repair or replace the fuel metering valve. Refer to Procedure 005-242 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM harness connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the fuel metering valve position SIGNAL wire.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 26-Aug-2014


FAULT CODE 5863 - Engine Diesel Fuel Metering Valve Position Sensor Circuit - Voltage Below Normal or Shorted to Low Source

Associated Procedures

Associated Procedures
Procedure Title | Procedure Number | Service Model Name | Bulletin Number
Fuel Metering Valve | Refer to Procedure 005-242 | QSK95 CM2350 K111 | 4358519
Engine Wiring Harness | Refer to Procedure 019-043 | QSK95 CM2350 K111 | 4358519

Cautions and Warnings

CAUTION

To reduce the possibility of damaging a new engine control module (ECM), all other active fault codes must be investigated prior to replacing the ECM.

Troubleshooting Steps

STEPS |  | SPECIFICATIONS
STEP 1. | Check the fault codes. |
 | STEP 1A. Check for an inactive fault code. | Fault Code 5863 inactive?
STEP 2. | Check the engine fuel valve and circuit. |
 | STEP 2A. Inspect the engine fuel valve and connector pins. | Dirty or damaged pins?
 | STEP 2B. Check the circuit response. | Fault Code 5862 active and Fault Code 5863 inactive?
 | STEP 2C. Check the fault codes and verify sensor condition. | Fault Code 5863 active?
STEP 3. | Check the ECM and engine harness. |
 | STEP 3A. Inspect the ECM and original equipment manufacturer (OEM) connector pins. | Dirty or damaged pins?
 | STEP 3B. Check for an open circuit in the engine harness. | Less than 10 ohms?
 | STEP 3C. Check for a pin-to-pin short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3D. Check for a pin-to-ground short circuit in the engine harness. | Greater than 100k ohms?
 | STEP 3E. Check for an inactive fault code. | Fault Code 5863 inactive?
STEP 4. | Check ECM calibration and clear fault codes. |
 | STEP 4A. Check if an ECM calibration update is available. | If a calibration update for this fault code is available, does the ECM contain that revision or higher?
 | STEP 4B. Disable the fault code. | Fault Code inactive?

Guided Step 1 - Check the fault codes.

Guided Step 1A - Check for an inactive fault code.

Conditions

  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for an inactive fault code.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 inactive?
YES | NO
No Repair | No Repair

Use the following procedure for an inactive or intermittent fault code. Refer to Procedure 019-362 in Section 19.

Go to 2A

Guided Step 2 - Check the engine fuel valve and circuit.

Guided Step 2A - Inspect the engine fuel valve and connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel valve from the engine harness.

Action

Inspect the engine harness and sensor connector pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab.

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the actuator or harness connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-043 in the Associated Procedures Table.

 No Repair

Go to 4A

Go to 2B

Guided Step 2B - Check the circuit response.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the engine fuel valve from the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check the circuit response.

  • Place a jumper wire between the engine fuel valve SUPPLY pin and the engine fuel valve position SIGNAL pin at the engine fuel valve connector of the engine harness.

Refer to the circuit diagram or the wiring diagram for connector pin identification.

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5862 active and Fault Code 5863 inactive?
YES | NO
No Repair | No Repair

Go to 2C

Go to 3A

Guided Step 2C - Check the fault codes and verify sensor condition.

Conditions

  • Turn keyswitch OFF.
  • Connect the engine fule valve to the engine harness.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 active?
YES NO

Repair

A damaged fuel metering valve has been detected.

Repair or replace the engine fuel valve. Refer to Procedure 019-043 in the Associated Procedures Table.

Repair

None. The removal and installation of the connector corrected the fault.

Go to 4A

Go to 4A

Guided Step 3 - Check the ECM and engine harness.

Guided Step 3A - Inspect the ECM and OEM connector pins.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.

Action

Inspect the OEM connector and ECM pins for the following:

  • Loose connector
  • Corroded pins
  • Bent or broken pins
  • Pushed back or expanded pins
  • Moisture in or on the connector
  • Missing or damaged connector seals
  • Dirt or debris in or on the connector pins
  • Connector shell broken
  • Wire insulation damage
  • Damaged connector locking tab

Use the following procedure for general inspection techniques. Refer to Procedure 019-361 in Section 19.

Dirty or damaged pins?
YES NO

Repair

A damaged connection has been detected in the ECM or the OEM connector.

Clean the connector and pins.

Repair the damaged harness, connector, or pins, if possible. Refer to Procedure 019-071 in Section 19.

No Repair

Go to 4A

Go to 3B

Guided Step 3B - Check for an open circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine fuel valve from the engine harness.

Action

Check for an open circuit.

  • Measure the resistance between the engine fuel valve position SIGNAL pin at the ECM connector and the engine fuel valve position SIGNAL pin at the engine fuel valve connector of the engine harness.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Less than 10 ohms?
YES NO
No Repair

Repair

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3C

Go to 4A

Guided Step 3C - Check for a pin-to-pin short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine fuel valve from the engine harness.

Action

Check for a pin-to-pin short.

  • Measure the resistance between the engine fuel valve position SIGNAL pin in the ECM OEM harness connector and all other pins in the connector.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-pin short circuit has been detected in the engine harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3D

Go to 4A

Guided Step 3D - Check for a pin-to-ground short circuit in the engine harness.

Conditions

  • Turn keyswitch OFF.
  • Disconnect the OEM connector from the ECM.
  • Disconnect the engine fuel valve from the engine harness.

Action

Check for a pin-to-ground short.

  • Measure the resistance between the engine fuel valve position SIGNAL pin in the engine fuel valve connector and engine block ground.

Use the following procedure for general resistance measurement techniques. Refer to Procedure 019-360 in Section 19.

Greater than 100k ohms?
YES NO
No Repair

Repair

A pin-to-ground short circuit has been detected in the engine harness.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 3E

Go to 4A

Guided Step 3E - Check for an inactive fault code.

Conditions

  • Connect all components.
  • Turn keyswitch ON.
  • Connect INSITE™ electronic service tool.

Action

Check for the appropriate circuit response after 30 seconds.

  • Use INSITE™ electronic service tool to read the fault codes.

Fault Code 5863 inactive?
YES NO

Repair

None. The removal and installation of the connector corrected the fault.

Repair

A pin-to-pin short circuit has been detected on the fuel metering valve position SIGNAL wire.

Repair or replace the damaged section of engine harness. Refer to Procedure 019-043 in the Associated Procedures Table.

Go to 4A

Go to 4A

Guided Step 4 - Check ECM calibration and clear fault codes.

Guided Step 4A - Check if an ECM calibration update is available.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Compare the ECM code and revision number in the ECM to the calibration revisions listed in the ECM Calibration Revision History for applicable changes related to this fault code.

  • Use INSITE™ electronic service tool to find the present ECM code and revision number in the ECM. The ECM code and revision number are found in the Calibration Information section of System ID and Dataplate in Features and Parameters.

If a calibration update for this fault code is available, does the ECM contain that revision or higher?
YES NO
No Repair

Repair

If necessary, calibrate the ECM. Refer to Procedure 019-032 in Section 19.

Go to 4B

Go to 4B

Guided Step 4B - Disable the fault code.

Conditions

  • Connect all components.
  • Connect INSITE™ electronic service tool.

Action

Disable and clear the fault code.

  • Operate the engine within the "Conditions for Clearing the Fault Code" found in the Overview section of this troubleshooting procedure.

Fault code inactive?
YES NO
No Repair

Repair

Return to the troubleshooting steps or contact a Cummins® Authorized Repair Location if all steps have been completed and checked again.

Repair complete

Go to 1A

Last Modified: 25-Aug-2014


INDEX
316-fc111.htm

316-fc111sa00.htm

339-t05-111sa00.htm

316-fc111sa01.htm

339-t05-111sa01.htm

316-fc111sa144.htm

339-t05-111sa144.htm

316-fc111sa186.htm

339-t05-111sa186.htm

316-fc115.htm

214-t05-115.htm

316-fc122.htm

00-t05-122.htm

316-fc123.htm

00-t05-123.htm

316-fc135.htm

00-t05-135.htm

316-fc141.htm

00-t05-141.htm

316-fc143.htm

00-t05-143.htm

316-fc144.htm

00-t05-144.htm

316-fc145.htm

00-t05-145.htm

316-fc146.htm

00-t05-146.htm

316-fc151.htm

00-t05-151.htm

316-fc153.htm

00-t05-153.htm

316-fc154.htm

00-t05-154.htm

316-fc155.htm

00-t05-155.htm

316-fc156.htm

00-t05-156.htm

316-fc157.htm

00-t05-157.htm

316-fc158.htm

00-t05-158.htm

316-fc187.htm

316-fc187sa00.htm

316-t05-187sa00.htm

316-fc187sa01.htm

316-t05-187sa01.htm

316-fc195.htm

316-fc195-2wire.htm

214-t05-195-2wire.htm

316-fc195-3wire.htm

214-t05-195-3wire.htm

316-fc196.htm

316-fc196-2wire.htm

214-t05-196-2wire.htm

316-fc196-3wire.htm

214-t05-196-3wire.htm

316-fc197.htm

00-t05-197.htm

316-fc212.htm

00-t05-212.htm

316-fc213.htm

00-t05-213.htm

316-fc214.htm

00-t05-214.htm

316-fc221.htm

214-t05-221.htm

316-fc222.htm

214-t05-222.htm

316-fc227.htm

214-t05-227.htm

316-fc228.htm

214-t05-228.htm

316-fc231.htm

214-t05-231.htm

316-fc232.htm

214-t05-232.htm

316-fc234.htm

214-t05-234.htm

316-fc235.htm

00-t05-235.htm

316-fc238.htm

00-t05-238.htm

316-fc239.htm

00-t05-239.htm

316-fc245.htm

00-t05-245.htm

316-fc261.htm

214-t05-261.htm

316-fc263.htm

214-t05-263.htm

316-fc265.htm

214-t05-265.htm

316-fc266.htm

214-t05-266.htm

316-fc285.htm

00-t05-285.htm

316-fc286.htm

00-t05-286.htm

316-fc319.htm

339-t05-319.htm

316-fc322.htm

316-t05-322.htm

316-fc323.htm

316-t05-323.htm

316-fc324.htm

316-t05-324.htm

316-fc325.htm

316-t05-325.htm

316-fc331.htm

316-t05-331.htm

316-fc332.htm

316-t05-332.htm

316-fc342.htm

214-t05-342.htm

316-fc344.htm

316-t05-344.htm

316-fc351.htm

214-t05-351.htm

316-fc352.htm

316-fc352sa00.htm

214-t05-352sa00.htm

316-fc352sa01.htm

214-t05-352sa01.htm

316-fc386.htm

214-t05-386.htm

316-fc415.htm

00-t05-415.htm

316-fc421.htm

00-t05-421.htm

316-fc426.htm

214-t05-426.htm

316-fc441.htm

214-t05-441.htm

316-fc442.htm

00-t05-442.htm

316-fc449.htm

316-t05-449.htm

316-fc451.htm

00-t05-451.htm

316-fc452.htm

00-t05-452.htm

316-fc488.htm

00-t05-488.htm

316-fc515.htm

00-t05-515.htm

316-fc516.htm

00-t05-516.htm

316-fc546.htm

339-t05-546.htm

316-fc547.htm

339-t05-547.htm

316-fc553.htm

339-t05-553.htm

316-fc555.htm

214-t05-555.htm

316-fc556.htm

214-t05-556.htm

316-fc559.htm

339-t05-559.htm

316-fc581.htm

339-t05-581.htm

316-fc582.htm

339-t05-582.htm

316-fc621.htm

339-t05-621.htm

316-fc622.htm

339-t05-622.htm

316-fc623.htm

339-t05-623.htm

316-fc624.htm

339-t05-624.htm

316-fc625.htm

339-t05-625.htm

316-fc626.htm

339-t05-626.htm

316-fc627.htm

339-t05-627.htm

316-fc628.htm

339-t05-628.htm

316-fc631.htm

339-t05-631.htm

316-fc632.htm

339-t05-632.htm

316-fc633.htm

339-t05-633.htm

316-fc634.htm

339-t05-634.htm

316-fc635.htm

339-t05-635.htm

316-fc636.htm

339-t05-636.htm

316-fc637.htm

339-t05-637.htm

316-fc638.htm

339-t05-638.htm

316-fc641.htm

339-t05-641.htm

316-fc642.htm

339-t05-642.htm

316-fc643.htm

339-t05-643.htm

316-fc644.htm

339-t05-644.htm

316-fc645.htm

339-t05-645.htm

316-fc646.htm

339-t05-646.htm

316-fc647.htm

339-t05-647.htm

316-fc648.htm

339-t05-648.htm

316-fc652.htm

339-t05-652.htm

316-fc653.htm

339-t05-653.htm

316-fc654.htm

339-t05-654.htm

316-fc655.htm

339-t05-655.htm

316-fc656.htm

339-t05-656.htm

316-fc657.htm

339-t05-657.htm

316-fc658.htm

339-t05-658.htm

316-fc671.htm

214-t05-671.htm

316-fc672.htm

214-t05-672.htm

316-fc673.htm

214-t05-673.htm

316-fc674.htm

214-t05-674.htm

316-fc675.htm

214-t05-675.htm

316-fc676.htm

214-t05-676.htm

316-fc677.htm

214-t05-677.htm

316-fc678.htm

214-t05-678.htm

316-fc689.htm

00-t05-689.htm

316-fc699.htm

316-fc699sa00.htm

316-t05-699sa00.htm

316-fc699sa01.htm

316-t05-699sa01.htm

316-fc699sa144.htm

316-t05-699sa144.htm

316-fc699sa186.htm

316-t05-699sa186.htm

316-fc721.htm

214-t05-721.htm

316-fc722.htm

214-t05-722.htm

316-fc723.htm

214-t05-723.htm

316-fc724.htm

214-t05-724.htm

316-fc725.htm

214-t05-725.htm

316-fc726.htm

214-t05-726.htm

316-fc727.htm

214-t05-727.htm

316-fc728.htm

214-t05-728.htm

316-fc731.htm

214-t05-731.htm

316-fc781.htm

214-t05-781.htm

316-fc782.htm

316-t05-782.htm

316-fc1117.htm

214-t05-1117.htm

316-fc1135.htm

214-t05-1135.htm

316-fc1256.htm

316-fc1256sa00.htm

214-t05-1256sa00.htm

316-fc1256sa01.htm

214-t05-1256sa01.htm

316-fc1256sa144.htm

214-t05-1256sa144.htm

316-fc1256sa186.htm

214-t05-1256sa186.htm

316-fc1257.htm

316-fc1257sa00.htm

214-t05-1257sa00.htm

316-fc1257sa01.htm

214-t05-1257sa01.htm

316-fc1257sa144.htm

214-t05-1257sa144.htm

316-fc1257sa186.htm

214-t05-1257sa186.htm

316-fc1362.htm

214-t05-1362.htm

316-fc1367.htm

214-t05-1367.htm

316-fc1368.htm

214-t05-1368.htm

316-fc1376.htm

214-t05-1376.htm

316-fc1379.htm

316-t05-1379.htm

316-fc1389.htm

316-t05-1389.htm

316-fc1517.htm

214-t05-1517.htm

316-fc1518.htm

214-t05-1518.htm

316-fc1519.htm

214-t05-1519.htm

316-fc1521.htm

214-t05-1521.htm

316-fc1522.htm

214-t05-1522.htm

316-fc1523.htm

214-t05-1523.htm

316-fc1524.htm

214-t05-1524.htm

316-fc1525.htm

214-t05-1525.htm

316-fc1526.htm

214-t05-1526.htm

316-fc1527.htm

214-t05-1527.htm

316-fc1529.htm

214-t05-1529.htm

316-fc1531.htm

214-t05-1531.htm

316-fc1532.htm

214-t05-1532.htm

316-fc1533.htm

214-t05-1533.htm

316-fc1534.htm

214-t05-1534.htm

316-fc1535.htm

214-t05-1535.htm

316-fc1536.htm

214-t05-1536.htm

316-fc1548.htm

316-t05-1548.htm

316-fc1549.htm

316-t05-1549.htm

316-fc1551.htm

316-t05-1551.htm

316-fc1552.htm

316-t05-1552.htm

316-fc1553.htm

316-t05-1553.htm

316-fc1554.htm

316-t05-1554.htm

316-fc1555.htm

316-t05-1555.htm

316-fc1556.htm

316-t05-1556.htm

316-fc1557.htm

316-t05-1557.htm

316-fc1597.htm

214-t05-1597.htm

316-fc1618.htm

214-t05-1618.htm

316-fc1619.htm

214-t05-1619.htm

316-fc1622.htm

316-t05-1622.htm

316-fc1636.htm

00-t05-1636.htm

316-fc1637.htm

00-t05-1637.htm

316-fc1695.htm

316-fc1695sa00.htm

316-t05-1695sa00.htm

316-fc1695sa144.htm

316-fc1696.htm

316-fc1696sa00.htm

316-t05-1696sa00.htm

316-fc1696sa144.htm

316-t05-1696sa144.htm

316-fc1774.htm

316-t05-1774.htm

316-fc1775.htm

316-t05-1775.htm

316-fc1843.htm

214-t05-1843.htm

316-fc1844.htm

214-t05-1844.htm

316-fc1845.htm

214-t05-1845.htm

316-fc1846.htm

214-t05-1846.htm

316-fc1847.htm

00-t05-1847.htm

316-fc1852.htm

00-t05-1852.htm

316-fc1891.htm

214-t05-1891.htm

316-fc1984.htm

00-t05-1984.htm

316-fc1992.htm

214-t05-1992.htm

316-fc2121.htm

339-t05-2121.htm

316-fc2122.htm

339-t05-2122.htm

316-fc2123.htm

339-t05-2123.htm

316-fc2124.htm

339-t05-2124.htm

316-fc2125.htm

339-t05-2125.htm

316-fc2126.htm

339-t05-2126.htm

316-fc2127.htm

339-t05-2127.htm

316-fc2128.htm

339-t05-2128.htm

316-fc2131.htm

339-t05-2131.htm

316-fc2132.htm

339-t05-2132.htm

316-fc2133.htm

339-t05-2133.htm

316-fc2134.htm

339-t05-2134.htm

316-fc2135.htm

339-t05-2135.htm

316-fc2136.htm

339-t05-2136.htm

316-fc2137.htm

339-t05-2137.htm

316-fc2138.htm

339-t05-2138.htm

316-fc2144.htm

339-t05-2144.htm

316-fc2215.htm

339-t05-2215.htm

316-fc2249.htm

316-t05-2249.htm

316-fc2261.htm

339-t05-2261.htm

316-fc2262.htm

339-t05-2262.htm

316-fc2343.htm

339-t05-2343.htm

316-fc2372.htm

339-t05-2372.htm

316-fc2377.htm

214-t05-2377.htm

316-fc2442.htm

214-t05-2442.htm

316-fc2443.htm

214-t05-2443.htm

316-fc2444.htm

214-t05-2444.htm

316-fc2445.htm

214-t05-2445.htm

316-fc2446.htm

214-t05-2446.htm

316-fc2447.htm

214-t05-2447.htm

316-fc2544.htm

339-t05-2544.htm

316-fc2651.htm

214-t05-2651.htm

316-fc2652.htm

214-t05-2652.htm

316-fc2653.htm

339-t05-2653.htm

316-fc2654.htm

339-t05-2654.htm

316-fc2655.htm

214-t05-2655.htm

316-fc2656.htm

214-t05-2656.htm

316-fc2657.htm

339-t05-2657.htm

316-fc2658.htm

339-t05-2658.htm

316-fc2661.htm

00-t05-2661.htm

316-fc2662.htm

00-t05-2662.htm

316-fc2727.htm

214-t05-2727.htm

316-fc3329.htm

214-t05-3329.htm

316-fc3331.htm

214-t05-3331.htm

316-fc3379.htm

339-t05-3379.htm

316-fc3697.htm

316-t05-3697.htm

316-fc3727.htm

316-t05-3727.htm

316-fc3741.htm

339-t05-3741.htm

316-fc4615.htm

339-t05-4615.htm

316-fc4642.htm

00-t05-4642.htm

316-fc4643.htm

214-t05-4643.htm

316-fc4644.htm

214-t05-4644.htm

316-fc4645.htm

214-t05-4645.htm

316-fc4646.htm

214-t05-4646.htm

316-fc4647.htm

214-t05-4647.htm

316-fc4648.htm

214-t05-4648.htm

316-fc4649.htm

214-t05-4649.htm

316-fc4651.htm

214-t05-4651.htm

316-fc4652.htm

214-t05-4652.htm

316-fc4653.htm

214-t05-4653.htm

316-fc4688.htm

316-t05-4688.htm

316-fc4689.htm

316-t05-4689.htm

316-fc4696.htm

339-t05-4696.htm

316-fc4697.htm

339-t05-4697.htm

316-fc4698.htm

339-t05-4698.htm

316-fc4699.htm

339-t05-4699.htm

316-fc4711.htm

339-t05-4711.htm

316-fc4883.htm

316-t05-4883.htm

316-fc4884.htm

316-t05-4884.htm

316-fc4885.htm

339-t05-4885.htm

316-fc4886.htm

316-t05-4886.htm

316-fc4887.htm

339-t05-4887.htm

316-fc4888.htm

339-t05-4888.htm

316-fc4889.htm

339-t05-4889.htm

316-fc4891.htm

339-t05-4891.htm

316-fc4892.htm

339-t05-4892.htm

316-fc4893.htm

339-t05-4893.htm

316-fc4894.htm

316-t05-4894.htm

316-fc4927.htm

339-t05-4927.htm

316-fc4928.htm

339-t05-4928.htm

316-fc4929.htm

339-t05-4929.htm

316-fc4931.htm

339-t05-4931.htm

316-fc4932.htm

339-t05-4932.htm

316-fc4933.htm

339-t05-4933.htm

316-fc4934.htm

339-t05-4934.htm

316-fc4935.htm

339-t05-4935.htm

316-fc4936.htm

316-t05-4936.htm

316-fc4937.htm

316-t05-4937.htm

316-fc4946.htm

339-t05-4946.htm

316-fc4958.htm

316-t05-4958.htm

316-fc4959.htm

339-t05-4959.htm

316-fc4961.htm

339-t05-4961.htm

316-fc5119.htm

316-t05-5119.htm

316-fc5121.htm

316-t05-5121.htm

316-fc5148.htm

316-t05-5148.htm

316-fc5178.htm

339-t05-5178.htm

316-fc5862.htm

339-t05-5862.htm

316-fc5863.htm

339-t05-5863.htm

316-fc5875.htm

214-t05-5875.htm

316-fc5876.htm

214-t05-5876.htm

316-fc5877.htm

214-t05-5877.htm

316-fc5949.htm

316-t05-5949.htm

316-fc6253.htm

316-fc6253sa00.htm

316-t05-6253sa00.htm

316-fc6253sa01.htm

316-t05-6253sa01.htm

316-fc6253sa144.htm

316-t05-6253sa144.htm

316-fc6253sa186.htm

316-t05-6253sa186.htm

316-fc6573.htm

316-t05-6573.htm

316-fc6574.htm

316-t05-6574.htm

316-fc6595.htm

316-t05-6595.htm

316-fc7313.htm

316-t05-7313.htm

316-fc7314.htm

316-t05-7314.htm

316-fc7548.htm

316-t05-7548.htm

316-fc7549.htm

316-t05-7549.htm

316-fc7551.htm

316-t05-7551.htm

316-fc7552.htm

316-t05-7552.htm

316-fc7554.htm

316-t05-7554.htm

316-fc7555.htm

316-t05-7555.htm

316-fc7558.htm

316-t05-7558.htm

316-fc13266.htm

316-t05-13266.htm